Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 14-03-2020 16:34:55

yuri_blobsky
Membre
Distrib. : Debian GNU/Linux 10 (buster) (10.3)
Noyau : Linux 4.19.0-8-amd64
Inscription : 14-03-2020

[Résolu] Disque dur externe non reconnu

Salut !

  J'ai récupéré un disque dur SATA sur un pc portable pour le transformer en disque dur externe. Ce disque fonctionne et faisait tourner une Debian 10.3 stable LXDE ce matin même.
Problème : Celui-ci ne semble pas reconnu par ma machine. La LED s'allume quand même quand je le branche.

J'ai suivi ce topic et donc j'ai ça :

fdisk -l


Disque /dev/sda : 931,5 GiB, 1000204886016 octets, 1953525168 secteurs
Modèle de disque : TOSHIBA DT01ACA1
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 4096 octets
taille d'E/S (minimale / optimale) : 4096 octets / 4096 octets
Type d'étiquette de disque : gpt
Identifiant de disque : 3A749537-66CD-4FDD-AB8D-E054B508EB80

Périphérique      Début        Fin   Secteurs Taille Type
/dev/sda1          2048    1050623    1048576   512M Système EFI
/dev/sda2       1050624 1936855039 1935804416 923,1G Système de fichiers Linux
/dev/sda3    1936855040 1953523711   16668672     8G Partition d'échange Linux


 



Donc pas de disque reconnu si je comprends bien (en général, j'ai un /dev/sdc quand je branche un disque dur externe).
D'où :

lsusb


Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 14cd:125d Super Top
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 003: ID 18f8:0f99 [Maxxter] Optical gaming mouse
Bus 006 Device 002: ID 046d:c31c Logitech, Inc. Keyboard K120
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 



Là je suis perdu. Je copie en me disant que ça peut aider mais bon...

ntfs-3g et gvfs sont installés correctement pourtant.

apt-cache policy ntfs-3g


ntfs-3g:
  Installé : 1:2017.3.23AR.3-3
  Candidat : 1:2017.3.23AR.3-3
 Table de version :
 *** 1:2017.3.23AR.3-3 500
        500 http://deb.debian.org/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status
 



apt-cache policy gvfs


gvfs:
  Installé : 1.38.1-5
  Candidat : 1.38.1-5
 Table de version :
 *** 1.38.1-5 500
        500 http://deb.debian.org/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status
 



C'est mon premier message sur le forum. Merci de me dire s'il manque des infos pour résoudre le problème.

Dernière modification par yuri_blobsky (17-03-2020 10:05:35)

Hors ligne

#2 15-03-2020 00:06:51

Genji
Membre
Distrib. : Debian GNU/Linux 10.3 (buster)
Noyau : 4.9.0-12-amd64
Inscription : 12-03-2018

Re : [Résolu] Disque dur externe non reconnu

Bonjour Yuri,

Petite question bête, quelle est la taille de ton disque dur (pas en mémoire, en pouce) ? Si le 2.5 pouce fonctionne en autoalimenté, le 3.5 pouce a besoin d'une alimentation externe.

Bienvenue sur DF en tout cas.

"Le cours de la rivière qui va jamais ne tarit, et pourtant ce n'est jamais la même eau. L'écume qui flotte sur les eaux dormantes tantôt se dissipe tantôt se reforme, et il n'est d'exemple que longtemps elle ait duré. Pareillement advient-il des hommes et des demeures qui sont en ce monde." - Kamo no Chômei, Notes de l'ermitage

Hors ligne

#3 15-03-2020 00:21:36

yuri_blobsky
Membre
Distrib. : Debian GNU/Linux 10 (buster) (10.3)
Noyau : Linux 4.19.0-8-amd64
Inscription : 14-03-2020

Re : [Résolu] Disque dur externe non reconnu

Bonjour Genji,

  Dans la mesure où j'ai extrait le DD d'un laptop, je dirais que c'est du 2,5.

Merci. smile

Hors ligne

#4 15-03-2020 00:29:58

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-7-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [Résolu] Disque dur externe non reconnu

salut big_smile

débranche le disque .

attends une minute .

rebranche le disque .

attends 30 sec .

dmesg | tail -n 50


dmesg | grep sd


hwinfo --disk

Dernière modification par Debian Alain (15-03-2020 00:32:55)

Hors ligne

#5 15-03-2020 10:11:54

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Disque dur externe non reconnu

C'est ton premier message, je vais donc poser des question bêtes en apparence mais qui pointent ses insuffisances.

yuri_blobsky a écrit :

J'ai récupéré un disque dur SATA sur un pc portable pour le transformer en disque dur externe


Par quel moyen ?

yuri_blobsky a écrit :

lsusb


Pourquoi ? Si tu as mis le disque dans un boîtier USB (ou l'as connecté à un adaptateur USB-SATA), tu peux comparer le résultat de lsusb avec et sans le disque branché.

yuri_blobsky a écrit :

ntfs-3g et gvfs sont installés correctement pourtant.


Quel rapport avec le fait que le disque ne soit pas reconnu ?

Genji a écrit :

le 2.5 pouce fonctionne en autoalimenté


Je suppose que tu parles d'USB. Deux erreurs :
- "auto-alimenté" est le contraire d'alimenté par le bus USB
- les besoins en courant de certains disques 2,5" dépassent ce que peut fournir un port USB 2 en principe (500 mA).


Il vaut mieux montrer que raconter.

Hors ligne

#6 15-03-2020 10:20:44

yuri_blobsky
Membre
Distrib. : Debian GNU/Linux 10 (buster) (10.3)
Noyau : Linux 4.19.0-8-amd64
Inscription : 14-03-2020

Re : [Résolu] Disque dur externe non reconnu

Salut Alain. Merci de te pencher sur mon problème.

Alors voilà ce que j'ai :

dmesg | tail -n 50


[   13.083635] audit: type=1400 audit(1584194526.443:8): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/cupsd//third_party" pid=471 comm="apparmor_parser"
[   13.084177] audit: type=1400 audit(1584194526.443:9): apparmor="STATUS" operation="profile_load" profile="unconfined" name="libreoffice-senddoc" pid=473 comm="apparmor_parser"
[   13.123224] audit: type=1400 audit(1584194526.487:10): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/bin/man" pid=476 comm="apparmor_parser"
[   13.123231] audit: type=1400 audit(1584194526.487:11): apparmor="STATUS" operation="profile_load" profile="unconfined" name="man_filter" pid=476 comm="apparmor_parser"
[   15.282797] r8169 0000:02:00.0: firmware: failed to load rtl_nic/rtl8168g-2.fw (-2)
[   15.284399] r8169 0000:02:00.0: Direct firmware load for rtl_nic/rtl8168g-2.fw failed with error -2
[   15.284406] r8169 0000:02:00.0 enp2s0: unable to load firmware patch rtl_nic/rtl8168g-2.fw (-2)
[   15.285293] Generic PHY r8169-200:00: attached PHY driver [Generic PHY] (mii_bus:phy_addr=r8169-200:00, irq=IGNORE)
[   15.387669] IPv6: ADDRCONF(NETDEV_UP): enp2s0: link is not ready
[   15.387779] r8169 0000:02:00.0 enp2s0: Link is Down
[   16.955881] r8169 0000:02:00.0 enp2s0: Link is Up - 100Mbps/Full - flow control off
[   16.955892] IPv6: ADDRCONF(NETDEV_CHANGE): enp2s0: link becomes ready
[   19.531363] NET: Registered protocol family 3
[   19.614006] NET: Registered protocol family 5
[   27.361635] fuse init (API version 7.27)
[  411.300088] usb 1-4: USB disconnect, device number 2
[  811.325496] usb 1-4: new high-speed USB device number 3 using ehci-pci
[ 1621.629565] usb 1-4: new high-speed USB device number 4 using ehci-pci
[ 2027.716959] usb 1-4: new high-speed USB device number 5 using ehci-pci
[ 2027.873252] usb 1-4: New USB device found, idVendor=13fd, idProduct=1618, bcdDevice= 1.00
[ 2027.873256] usb 1-4: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 2028.123632] usb 1-4: USB disconnect, device number 5
[ 3186.025353] usb 1-4: new high-speed USB device number 6 using ehci-pci
[ 3186.181712] usb 1-4: New USB device found, idVendor=13fd, idProduct=1618, bcdDevice= 1.00
[ 3186.181715] usb 1-4: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 3186.440055] usb 1-4: USB disconnect, device number 6
[ 3918.152265] usb 1-4: new high-speed USB device number 7 using ehci-pci
[ 3918.712267] usb 1-4: device not accepting address 7, error -71
[ 5135.277805] usb 1-4: new high-speed USB device number 9 using ehci-pci
[ 5944.909885] usb 1-4: new high-speed USB device number 10 using ehci-pci
[ 6754.525148] usb 1-4: new high-speed USB device number 11 using ehci-pci
[ 7523.399277] usb 1-4: new high-speed USB device number 12 using ehci-pci
[ 7523.555584] usb 1-4: New USB device found, idVendor=13fd, idProduct=1618, bcdDevice= 1.00
[ 7523.555587] usb 1-4: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 7523.765423] usb 1-4: USB disconnect, device number 12
[ 7930.676498] usb 1-4: new high-speed USB device number 13 using ehci-pci
[ 7930.832932] usb 1-4: New USB device found, idVendor=13fd, idProduct=1618, bcdDevice= 1.00
[ 7930.832935] usb 1-4: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 7930.875642] usb 1-4: USB disconnect, device number 13
[ 8336.445346] usb 1-4: new high-speed USB device number 14 using ehci-pci
[ 8336.601728] usb 1-4: New USB device found, idVendor=13fd, idProduct=1618, bcdDevice= 1.00
[ 8336.601732] usb 1-4: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 8336.783134] usb 1-4: USB disconnect, device number 14
[ 8741.901633] usb 1-4: new high-speed USB device number 15 using ehci-pci
[ 8742.058039] usb 1-4: New USB device found, idVendor=13fd, idProduct=1618, bcdDevice= 1.00
[ 8742.058043] usb 1-4: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 8742.358681] usb 1-4: USB disconnect, device number 15
[42334.125355] perf: interrupt took too long (2504 > 2500), lowering kernel.perf_event_max_sample_rate to 79750
[65308.890532] kauditd_printk_skb: 11 callbacks suppressed
[65308.890534] audit: type=1400 audit(1584259821.384:23): apparmor="ALLOWED" operation="open" profile="libreoffice-soffice" name="/home/yuri/Documents/note" pid=4253 comm="pool" requested_mask="r" denied_mask="r" fsuid=1000 ouid=1000
 



dmesg | grep sd


[    2.239719] sd 1:0:0:0: [sda] 1953525168 512-byte logical blocks: (1.00 TB/932 GiB)
[    2.239760] sd 1:0:0:0: [sda] 4096-byte physical blocks
[    2.239855] sd 1:0:0:0: [sda] Write Protect is off
[    2.239890] sd 1:0:0:0: [sda] Mode Sense: 00 3a 00 00
[    2.240049] sd 1:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    2.285031]  sda: sda1 sda2 sda3
[    2.293842] sd 1:0:0:0: [sda] Attached SCSI disk
[    3.103441] sd 4:0:0:0: [sdb] 625142448 512-byte logical blocks: (320 GB/298 GiB)
[    3.103910] sd 4:0:0:0: [sdb] Write Protect is off
[    3.103912] sd 4:0:0:0: [sdb] Mode Sense: 23 00 00 00
[    3.104528] sd 4:0:0:0: [sdb] No Caching mode page found
[    3.104533] sd 4:0:0:0: [sdb] Assuming drive cache: write through
[    3.107044]  sdb: sdb1
[    3.110907] sd 4:0:0:0: [sdb] Attached SCSI disk
[    3.364202] sd 5:0:0:0: [sdc] Attached SCSI removable disk
[    3.960844] EXT4-fs (sda2): mounted filesystem with ordered data mode. Opts: (null)
[    7.372701] EXT4-fs (sda2): re-mounted. Opts: errors=remount-ro
[    8.917013] sd 1:0:0:0: Attached scsi generic sg1 type 0
[    8.917050] sd 4:0:0:0: Attached scsi generic sg2 type 0
[    8.917086] sd 5:0:0:0: Attached scsi generic sg3 type 0
[   11.001067] Adding 8334332k swap on /dev/sda3.  Priority:-2 extents:1 across:8334332k FS
[   13.083631] audit: type=1400 audit(1584194526.443:7): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/cupsd" pid=471 comm="apparmor_parser"
[   13.083635] audit: type=1400 audit(1584194526.443:8): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/cupsd//third_party" pid=471 comm="apparmor_parser"
 



hwinfo --disk


26: SCSI 500.0: 10600 Disk                                      
  [Created at block.256]
  Unique ID: FKGF.q4+it66CY0F
  Parent ID: 06bT.Mx1RaBhWJw5
  SysFS ID: /class/block/sdc
  SysFS BusID: 5:0:0:0
  SysFS Device Link: /devices/pci0000:00/0000:00:13.2/usb2/2-1/2-1:1.0/host5/target5:0:0/5:0:0:0
  Hardware Class: disk
  Model: "Mass Storage Device"
  Vendor: usb 0x14cd "Mass"
  Device: usb 0x125d "Storage Device"
  Serial ID: "125D20140310"
  Driver: "usb-storage", "sd"
  Driver Modules: "usb_storage", "sd_mod"
  Device File: /dev/sdc (/dev/sg3)
  Device Files: /dev/sdc, /dev/disk/by-path/pci-0000:00:13.2-usb-0:1:1.0-scsi-0:0:0:0, /dev/disk/by-id/usb-Mass_Storage_Device_125D20140310-0:0
  Device Number: block 8:32-8:47 (char 21:3)
  Geometry (Logical): CHS 1024/0/62
  Speed: 480 Mbps
  Module Alias: "usb:v14CDp125Dd0100dc00dsc00dp00ic08isc06ip50in00"
  Driver Info #0:
    Driver Status: uas is active
    Driver Activation Cmd: "modprobe uas"
  Driver Info #1:
    Driver Status: usb_storage is active
    Driver Activation Cmd: "modprobe usb_storage"
  Drive status: no medium
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #3 (USB Controller)

27: IDE 100.0: 10600 Disk
  [Created at block.245]
  Unique ID: 3OOL.R1Kiuc9_oEB
  Parent ID: 7EWs.qucGIzNHIgD
  SysFS ID: /class/block/sda
  SysFS BusID: 1:0:0:0
  SysFS Device Link: /devices/pci0000:00/0000:00:11.0/ata2/host1/target1:0:0/1:0:0:0
  Hardware Class: disk
  Model: "TOSHIBA DT01ACA1"
  Vendor: "TOSHIBA"
  Device: "DT01ACA1"
  Revision: "A750"
  Serial ID: "56NL221FS"
  Driver: "ahci", "sd"
  Driver Modules: "ahci", "sd_mod"
  Device File: /dev/sda
  Device Files: /dev/sda, /dev/disk/by-id/wwn-0x5000039fe9d64df0, /dev/disk/by-id/ata-TOSHIBA_DT01ACA100_56NL221FS, /dev/disk/by-path/pci-0000:00:11.0-ata-2
  Device Number: block 8:0-8:15
  Geometry (Logical): CHS 121601/255/63
  Size: 1953525168 sectors a 512 bytes
  Capacity: 931 GB (1000204886016 bytes)
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #21 (SATA controller)

 

Hors ligne

#7 15-03-2020 10:38:00

yuri_blobsky
Membre
Distrib. : Debian GNU/Linux 10 (buster) (10.3)
Noyau : Linux 4.19.0-8-amd64
Inscription : 14-03-2020

Re : [Résolu] Disque dur externe non reconnu

Salut raleur,

yuri_blobsky a écrit :

J'ai récupéré un disque dur SATA sur un pc portable pour le transformer en disque dur externe


Par quel moyen ?



J'ai ouvert le pc et retiré le disque dur en le faisant coulisser, puis je l'ai branché sur un adaptateur USB-SATA que j'ai trouvé dans un autre disque dur externe (fonctionnel celui-là).

Si tu as mis le disque dans un boîtier USB (ou l'as connecté à un adaptateur USB-SATA), tu peux comparer le résultat de lsusb avec et sans le disque branché.


lsusb me donne la même sortie que le disque soit branché ou non.

lsusb


Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 14cd:125d Super Top
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 003: ID 18f8:0f99 [Maxxter] Optical gaming mouse
Bus 006 Device 002: ID 046d:c31c Logitech, Inc. Keyboard K120
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 


ntfs-3g et gvfs sont installés correctement pourtant.


Quel rapport avec le fait que le disque ne soit pas reconnu ?



Comme dit dans mon premier message, je suis allé voir dans un autre sujet si d'autres avaient déjà eu le même problème. Comme je faisais déjà tourner Debian sur ce disque dur, il ne doit pas être formaté en ntfs mais bon, sur un malentendu... roll

Genji a écrit :

le 2.5 pouce fonctionne en autoalimenté


Je suppose que tu parles d'USB. Deux erreurs :
- "auto-alimenté" est le contraire d'alimenté par le bus USB
- les besoins en courant de certains disques 2,5" dépassent ce que peut fournir un port USB 2 en principe (500 mA).



J'ai un autre Western Digital qui est reconnu pourtant.
WD3200BEVT : Celui qui n'est pas reconnu.
WD3200BPVT : Celui qui l'est.

Dites-moi s'il vous manque des infos. J'ai mis ce qui me semblait pertinent comme informations et j'imagine que certaines peuvent ne pas l'être. D'où le truc sur le ntfs par exemple...

Dernière modification par yuri_blobsky (15-03-2020 10:45:04)

Hors ligne

#8 15-03-2020 10:59:29

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-7-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [Résolu] Disque dur externe non reconnu

Si tu as mis le disque dans un boîtier USB (ou l'as connecté à un adaptateur USB-SATA),
tu peux comparer le résultat de lsusb avec et sans le disque branché.


lsusb me donne la même sortie que le disque soit branché ou non.



deux solutions :
1) ou l'adaptateur est en mauvais état (très rare mais çà peut arriver)
2) ou le disque es H.S. (çà arrive facilement : les diamants ne sont pas éternels)

tongue

Dernière modification par Debian Alain (15-03-2020 11:03:26)

Hors ligne

#9 15-03-2020 11:16:35

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Disque dur externe non reconnu

yuri_blobsky a écrit :

lsusb me donne la même sortie que le disque soit branché ou non.


Au début j'ai eu un doute concernant le périphérique "Super Top" car il crée un périphérique /dev/sdc vide au démarrage et la base de données d'identifiants USB mentionne des ponts SATA chez ce fabricant, mais je pense qu'il s'agit en fait d'un lecteur de carte mémoire.

dmesg mentionne plusieurs fois qu'un périphérique USB d'un autre fabricant qui fait aussi des ponts SATA a été branché mais se déconnecte immédiatement.

yuri_blobsky a écrit :

J'ai un autre Western Digital qui est reconnu pourtant.


A travers le même adaptateur USB-SATA ?
Quelles sont les consommations mentionnées sur les deux disques ?

Il n'y a pas 50 possibilités :
- disque défectueux
- adaptateur défectueux
- alimentation USB insuffisante

Il y a moyen de fournir une alimentation propre à l'adaptateur ?

Dernière modification par raleur (15-03-2020 12:16:26)


Il vaut mieux montrer que raconter.

Hors ligne

#10 15-03-2020 11:39:15

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-7-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [Résolu] Disque dur externe non reconnu

exemple, chez moi, mon adaptateur :

lsusb


.../...
Bus 001 Device 002: ID 174c:55aa ASMedia Technology Inc. Name: ASM1051E SATA 6Gb/s bridge, ASM1053E SATA 6Gb/s bridge, ASM1153 SATA 3Gb/s bridge, ASM1153E SATA 6Gb/s bridge
.../...
 


que donne chez toi ceci (si j'ai bien compris) ?

dmesg | grep sdc


fdisk -l /dev/sdc


smartctl -a /dev/sdc

Dernière modification par Debian Alain (15-03-2020 11:42:20)

Hors ligne

#11 15-03-2020 12:36:45

Genji
Membre
Distrib. : Debian GNU/Linux 10.3 (buster)
Noyau : 4.9.0-12-amd64
Inscription : 12-03-2018

Re : [Résolu] Disque dur externe non reconnu

Merci raleur pour ces précisions, en effet, je voulais dire qu'il était alimenté par le bus USB plutôt que par une alimentation d'un boitier externe. Et je ne savais pas que certains dd en 2.5 pouces pouvais également avoir besoin d'une autre source d'alimentation que par simple USB, encore une fois, merci pour l'info.

"Le cours de la rivière qui va jamais ne tarit, et pourtant ce n'est jamais la même eau. L'écume qui flotte sur les eaux dormantes tantôt se dissipe tantôt se reforme, et il n'est d'exemple que longtemps elle ait duré. Pareillement advient-il des hommes et des demeures qui sont en ce monde." - Kamo no Chômei, Notes de l'ermitage

Hors ligne

#12 15-03-2020 12:47:20

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Disque dur externe non reconnu

Je ne dis pas qu'ils ont besoin d'une autre source d'alimentation mais de plus que les 500 mA qu'un port USB est réglementairement capable de fournir. J'en ai un sous les yeux dont l'étiquette indique 800 mA. Et c'est sans compter la consommation propre de l'adaptateur. On peut avoir de la chance si le port USB ne limite pas le courant, ou bien pas de chance.

Il vaut mieux montrer que raconter.

Hors ligne

#13 15-03-2020 12:49:12

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-7-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [Résolu] Disque dur externe non reconnu

si çà peut t'aider Genji : 

http://www.tt-hardware.com/news/hardwar … dautonomie

http://www.tt-hardware.com/img/news6/news220409_5.jpg

où tu verra que pour le plus mauvais disque de l'échantillon , la conso est à peu près de 3 watts

soit 0.6 ampères en 5 volts quand on sait qu'un port usb 2.0 délivre 0.5 Ampères au grand maximum .

pas besoin d'un dessin , je crois .

Hors ligne

#14 15-03-2020 12:55:10

Genji
Membre
Distrib. : Debian GNU/Linux 10.3 (buster)
Noyau : 4.9.0-12-amd64
Inscription : 12-03-2018

Re : [Résolu] Disque dur externe non reconnu

Merci Alain,

Mais les liens ne fonctionnent pas j'ai l'impression.

Echec de la connexion sécurisée, PR_END_OF_FILE_ERROR.

Dernière modification par Genji (15-03-2020 12:56:27)


"Le cours de la rivière qui va jamais ne tarit, et pourtant ce n'est jamais la même eau. L'écume qui flotte sur les eaux dormantes tantôt se dissipe tantôt se reforme, et il n'est d'exemple que longtemps elle ait duré. Pareillement advient-il des hommes et des demeures qui sont en ce monde." - Kamo no Chômei, Notes de l'ermitage

Hors ligne

#15 15-03-2020 15:32:58

yuri_blobsky
Membre
Distrib. : Debian GNU/Linux 10 (buster) (10.3)
Noyau : Linux 4.19.0-8-amd64
Inscription : 14-03-2020

Re : [Résolu] Disque dur externe non reconnu

raleur a écrit :

yuri_blobsky a écrit :

J'ai un autre Western Digital qui est reconnu pourtant.


A travers le même adaptateur USB-SATA ?
Quelles sont les consommations mentionnées sur les deux disques ?

Il n'y a pas 50 possibilités :
- disque défectueux
- adaptateur défectueux
- alimentation USB insuffisante

Il y a moyen de fournir une alimentation propre à l'adaptateur ?



Les deux DD indiquent "5VDC : 0.55A".
J'ai pas trouvé de précision en terme d'alimentation des disques durs sur les boutiques en ligne.

Pour Alain, je pourrai te donner le retour des commandes au plus tôt mardi (je suis pas chez moi).

Juste pour tester, j'ai remis de disque dans le laptop d'origine et Debian s'est lancé dessus sans problème. C'est peut-être juste l'alimentation comme vous le suggérez.

Je vous tiens au jus. En tout cas, merci pour l'aide que vous m'apportez. smile

Hors ligne

#16 15-03-2020 15:44:19

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Disque dur externe non reconnu

Tu as testé les deux disques avec le même adaptateur USB-SATA ?
0,55 A est légèrement au-dessus du maximum permis par la spécification USB 2 (mais les ports peuvent être plus tolérants), et il faut y ajouter la consommation de l'adaptateur.

Il vaut mieux montrer que raconter.

Hors ligne

#17 17-03-2020 10:04:57

yuri_blobsky
Membre
Distrib. : Debian GNU/Linux 10 (buster) (10.3)
Noyau : Linux 4.19.0-8-amd64
Inscription : 14-03-2020

Re : [Résolu] Disque dur externe non reconnu

raleur a écrit :

Tu as testé les deux disques avec le même adaptateur USB-SATA ?
0,55 A est légèrement au-dessus du maximum permis par la spécification USB 2 (mais les ports peuvent être plus tolérants), et il faut y ajouter la consommation de l'adaptateur.



Les deux disques ont été testés avec le même adaptateur SATA - USB 2.

Entre temps j'ai acheté un boîtier SATA-USB 3 et il est correctement reconnu. Ça semblait donc bien être un problème d'alimentation.
Merci à vous tous de m'avoir aidé à régler ce problème. smile

Hors ligne

Pied de page des forums