Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-05-2020 11:03:26

jibe
Membre
Distrib. : DF-Linux 10
Noyau : Linux 4.19.0-10-amd64
(G)UI : mate
Inscription : 19-06-2018

[RESOLU] Automount USB

Salut,

Sur le nouveau poste de travail que je viens de m'installer, j'ai un problème de montage automatique des clés USB. J'ai un message "Impossible d'afficher /media/user/MACLE : l'emplacement n'est pas un dossier".

Un mount me donne pourtant bien une info qui semble correcte :

/dev/sdc on /media/user/MACLE type vfat (rw,nosuid,nodev,relatime,uid=20000,gid=20001,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,showexec,utf8,flush,errors=remount-ro,uhelper=udisks2)

Si je unmount et re-mount manuellement sur un dossier prévu à cet effet (/mnt/cle), j'ai accès normalement... Pourquoi l'automount ne fonctionne-t-il pas correctement ?

À noter que sur ce poste, après installation "normale", j'ai installé tous (enfin, ceux qu'il est possible !) les paquets de l'ancien poste.

Dernière modification par jibe (02-05-2020 12:19:37)

Hors ligne

#2 02-05-2020 11:10:55

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU] Automount USB

Ton compte utilisateur a vraiment l'UID 20000 et le GID 20001 ?

id
id 20000

Dernière modification par raleur (02-05-2020 11:11:15)


Il vaut mieux montrer que raconter.

Hors ligne

#3 02-05-2020 11:19:12

jibe
Membre
Distrib. : DF-Linux 10
Noyau : Linux 4.19.0-10-amd64
(G)UI : mate
Inscription : 19-06-2018

Re : [RESOLU] Automount USB

Oui, pour des raisons historiques.

Hors ligne

#4 02-05-2020 11:22:22

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU] Automount USB

Et donc, que dit

ls -ld /media/user/MACLE


?


Il vaut mieux montrer que raconter.

Hors ligne

#5 02-05-2020 11:27:28

jibe
Membre
Distrib. : DF-Linux 10
Noyau : Linux 4.19.0-10-amd64
(G)UI : mate
Inscription : 19-06-2018

Re : [RESOLU] Automount USB

Bien vu !

je n'ai pas les droits sur /media/user ! (drwxr-x--- root:root)

Je regarde ça de plus près...

Hors ligne

#6 02-05-2020 11:35:54

jibe
Membre
Distrib. : DF-Linux 10
Noyau : Linux 4.19.0-10-amd64
(G)UI : mate
Inscription : 19-06-2018

Re : [RESOLU] Automount USB

Effectivement, avec les droits pour user, tout semble fonctionner parfaitement. Merci pour ton aide smile

Par contre, question subsidiaire : comment se fait-il que ce dossier ait été créé automatiquement avec de mauvais droits ? Quels droits devrait-il avoir exactement (j'ai mis 777 pour tester) ?

Hors ligne

#7 02-05-2020 11:36:49

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU] Automount USB

Normalement il y a des ACL (indiqué par le signe "+" à la fin des droits).

getfacl /media/user

Dernière modification par raleur (02-05-2020 12:09:06)


Il vaut mieux montrer que raconter.

Hors ligne

#8 02-05-2020 11:40:26

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU] Automount USB

Exemple chez moi :

ls -ld /media/username


drwxr-x---+ 2 root root 4096 avril 20 11:51 /media/username



getfacl /media/username


# file: media/username
# owner: root
# group: root
user::rwx
user:username:r-x
group::---
mask::r-x
other::---
 


Il vaut mieux montrer que raconter.

Hors ligne

#9 02-05-2020 11:43:08

jibe
Membre
Distrib. : DF-Linux 10
Noyau : Linux 4.19.0-10-amd64
(G)UI : mate
Inscription : 19-06-2018

Re : [RESOLU] Automount USB

Ok, merci smile

Je n'ai pas getfcacl, et quand j'essaie de l'installer, apt me signale un paquet inutile de la série wicd (mon autre post)... Je regarde tout ça et je reviens.

Hors ligne

#10 02-05-2020 11:50:29

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU] Automount USB

Je suppose qu'il s'agit du paquet python-wicd ? Pas grave, il ne fait qu'occuper un peu d'espace.
getfacl est dans le paquet acl.

Il vaut mieux montrer que raconter.

Hors ligne

#11 02-05-2020 11:58:09

jibe
Membre
Distrib. : DF-Linux 10
Noyau : Linux 4.19.0-10-amd64
(G)UI : mate
Inscription : 19-06-2018

Re : [RESOLU] Automount USB

Oui, effectivement python-wicd et aussi rfkill. Mais c'est peut-être mieux de ne pas mélanger les deux problèmes ! wink

Pas fait gaffe à la faute de frappe getfcacl au lieu de getfacl => avec la bonne orthographe, je n'ai rien besoin d'installer smile

Effectivement, sur le dossier que j'avais simplement renommé, j'obtiens

$ getfacl /media/joseph.orig
getfacl : suppression du premier « / » des noms de chemins absolus
# file: media/joseph.orig
# owner: root
# group: root
user::rwx
user:1000:r-x
group::---
mask::r-x
other::---
 



C'est Ok, mais avec un UID de 1000, alors que mon véritable UID est 20000 ! Bon, il ne me reste probablement plus qu'à lire le man de setfacl pour savoir remettre ça d'aplomb ?

Merci de ton aide précieuse en attendant ! smile

Hors ligne

#12 02-05-2020 12:13:03

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU] Automount USB

Et le répertoire actuel, il a quels ACL ? Ce ne serait pas plus simple de le supprimer (quand rien n'est monté dedans) et de le laisser recréer automatiquement ?

Il vaut mieux montrer que raconter.

Hors ligne

#13 02-05-2020 12:16:43

jibe
Membre
Distrib. : DF-Linux 10
Noyau : Linux 4.19.0-10-amd64
(G)UI : mate
Inscription : 19-06-2018

Re : [RESOLU] Automount USB

Je l'ai créé manuellement avec les droits 777 pour tester.

J'essaie de le supprimer/recréer automatiquement (effectivement, j'ai un peu de mal à trouver comment mettre les bons droits avec setfacl : il semble y avoir quelques subtilités que j'ai mal comprises).

Hors ligne

#14 02-05-2020 12:19:09

jibe
Membre
Distrib. : DF-Linux 10
Noyau : Linux 4.19.0-10-amd64
(G)UI : mate
Inscription : 19-06-2018

Re : [RESOLU] Automount USB

Effectivement, c'était bien le plus simple, et je me retrouve bien avec les mêmes ACL que toi.

Merci encore pour ton aide, le problème est résolu smile

Hors ligne

Pied de page des forums