Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-05-2020 17:06:04

Luti
Membre
Inscription : 14-04-2020

Cups / Epson XP-2100

Bonjour,

Je me suis attaqué à cups cette après midi !

L'imprimante est reconnu direct sur le réseau... De ce coté la pas de soucis sauf que lorsque je lance l'impression pour une page test depuis cups le papier sort mais ca reste une page vierge !

Si quelqu'un a une idée pour résoudre le problème chuis preneur !

A+

Hors ligne

#2 20-05-2020 20:59:47

Luti
Membre
Inscription : 14-04-2020

Re : Cups / Epson XP-2100

Bonsoir,

J'ai finalement réussi à installer mon imprimante !

Maintenant je bloque sur la fonctionnalité scan ! J'ai installé le driver sur http://support.epson.net/linux/en/imagescanv3.php mais je sais pas quoi faire après... scratchhead.gif

J'ai lancé tout bétement l'utilitaire de chez KDE mais je me fais shouter...

Je vais continuer à tafer la dessus demain ! smile

Bonne soirée

Hors ligne

#3 20-05-2020 21:51:54

SuShY
CA Debian-Facile
Lieu : Chartres
Distrib. : Debian Sid x86_64
Noyau : Linux > 5.10.x-x-amd64
(G)UI : i3WM - 4.19-1
Inscription : 06-01-2018
Site Web

Re : Cups / Epson XP-2100

Hello,
As-tu essayé de scanner avec simple-scan ?

Hors ligne

#4 21-05-2020 15:55:05

Luti
Membre
Inscription : 14-04-2020

Re : Cups / Epson XP-2100

Salut SuShy,

Meme en passant par simple-scan ca fonctionne pas...

Echec de la numérisation
Impossible de démarrer la numérisation



Je me remets à chercher une solution...

A+

Hors ligne

#5 21-05-2020 16:06:02

Luti
Membre
Inscription : 14-04-2020

Re : Cups / Epson XP-2100

Re,

En checkant si l'imprimante est bien détecté j'obtiens ca :

$ scanimage -L
device `epson2:net:192.168.1.24' is a Epson PID flatbed scanner



Le Epson PID est bien détecté par simple-scan mais ca foire dans la foulée dès que je veux numériser...

Je continue mes investigations ! scratchhead.gif

Hors ligne

#6 21-05-2020 22:06:15

SuShY
CA Debian-Facile
Lieu : Chartres
Distrib. : Debian Sid x86_64
Noyau : Linux > 5.10.x-x-amd64
(G)UI : i3WM - 4.19-1
Inscription : 06-01-2018
Site Web

Re : Cups / Epson XP-2100

arf ok, essaie de lancer l'installation de l'imprimante par CUPS, on ne sait jamais.

Hors ligne

#7 22-05-2020 07:28:29

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Cups / Epson XP-2100

Hello
Fais tu parti du groupe scanner?

id


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#8 24-05-2020 10:50:29

EliotEliot
Membre
Distrib. : Debian 10 Buster
Noyau : Linux 4.19.0-9-686-pae
(G)UI : XFCE. Lightdm. 1 Processeur. 2 Core. 32bits (i686)
Inscription : 24-05-2020

Re : Cups / Epson XP-2100

Bonjour Luti,

Peux-tu me dire comment tu as fais pour imprimer avec ton Epson XP-2100 ?
Je viens d'acheter le même modèle et je n'arrive pas à l'utiliser.

Voilà ce que j'ai tenté pour le moment :
- J'utilise Debian 10 avec XFCE en 32bits (i686) ;
- L'imprimante est détectée par mon PC mais je n'arrive pas à imprimer ;
- Je n'ai pas encore essayé de scanner ;
- J'ai téléchargé le pilote et l'utilitaire sur le site d'Epson (http://download.ebz.epson.net/dsc/searc … archModule)
- Je n'arrive pas à installer le pilote ni l'utilitaire : quand j'essaie d'installer les .deb, avec dpkg -i ou gdebi, j'ai le message d'erreur suivant :

Sélection du paquet epson-inkjet-printer-escpr précédemment désélectionné.
(Lecture de la base de données... 214859 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../epson-inkjet-printer-escpr_1.7.7-1lsb3.2_i386.deb ...
Dépaquetage de epson-inkjet-printer-escpr (1.7.7-1lsb3.2) ...
dpkg: des problèmes de dépendances empêchent la configuration de epson-inkjet-printer-escpr :
 epson-inkjet-printer-escpr dépend de lsb (>= 3.2) ; cependant :
  Le paquet lsb n'est pas installé.

dpkg: erreur de traitement du paquet epson-inkjet-printer-escpr (--install) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 epson-inkjet-printer-escpr
 



- Pour ce qui est de lsb :

lsb-base est déjà la version la plus récente (10.2019051400)


lsb-release est déjà la version la plus récente (10.2019051400)



Merci d'avance,

Eliot

Dernière modification par EliotEliot (24-05-2020 10:57:44)

Hors ligne

#9 24-05-2020 13:39:29

phlinux
Membre
Distrib. : Jessie
Noyau : 4.9
(G)UI : Openbox (+Rox+Feh)
Inscription : 09-05-2009

Re : Cups / Epson XP-2100

Bjr,

Si epson-inkjet-printer-escpr réclame lsb c'est peut être parce qu'il n'est pas pour buster. Tu peux avoir quelques infos

dpkg -f paquet.deb


Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#10 24-05-2020 14:58:48

EliotEliot
Membre
Distrib. : Debian 10 Buster
Noyau : Linux 4.19.0-9-686-pae
(G)UI : XFCE. Lightdm. 1 Processeur. 2 Core. 32bits (i686)
Inscription : 24-05-2020

Re : Cups / Epson XP-2100

Bonjour phlinux,

Voilà ce que me donne la commande pour le pilote :

dpkg -f [...]epson-inkjet-printer-escpr_1.7.7-1lsb3.2_i386.deb


Package: epson-inkjet-printer-escpr
Version: 1.7.7-1lsb3.2
Architecture: i386
Maintainer: Seiko Epson Corporation <linux-printer@epson.jp>
Installed-Size: 5219
Depends: lsb (>= 3.2)
Section: alien
Priority: extra
Description: Epson Inkjet Printer Driver (ESC/P-R) for Linux
 This software is a filter program used with Common UNIX Printing
 System (CUPS) from the Linux. This can supply the high quality print
 with Seiko Epson Color Ink Jet Printers.
 .
 This product supports only EPSON ESC/P-R printers. This package can be
 used for all EPSON ESC/P-R printers.
 .
 For detail list of supported printer, please refer to below site:
 http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX
 .
 (Converted from a rpm package by alien version 8.95.)
 



La commande pour l'utilitaire d'impression :

dpkg -f [...]epson-printer-utility_1.1.1-1lsb3.2_i386.deb


Package: epson-printer-utility
Version: 1.1.1-1lsb3.2
Architecture: i386
Maintainer: Seiko Epson Corporation <linux-printer@epson.jp>
Installed-Size: 3068
Depends: lsb (>= 3.2)
Section: alien
Priority: extra
Description: Epson Printer Utility for Linux
 This is a Printer Utility program for Epson Printer Driver.
 Using this software, you can check ink levels, view error and other status... on EPSON Printers.
 For detail list of supported printer, please refer to below site:
 http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX
 .
 (Converted from a rpm package by alien version 8.86.)
 



D'après ce que j'ai lu sur le forum ou ailleurs, je ne suis pas le seul à avoir ce problème de lsb mais les solutions proposées ne fonctionnent pas chez moi.

Dernière modification par EliotEliot (24-05-2020 15:02:54)

Hors ligne

#11 24-05-2020 15:24:58

EliotEliot
Membre
Distrib. : Debian 10 Buster
Noyau : Linux 4.19.0-9-686-pae
(G)UI : XFCE. Lightdm. 1 Processeur. 2 Core. 32bits (i686)
Inscription : 24-05-2020

Re : Cups / Epson XP-2100

J'ai oubliée de noter dans mon premier message, que quand j'ai connecté l'imprimante à mon ordinateur :
- une fenêtre s'est ouverte pour me dire que l'imprimante été reconnue mais qu'il n'y avait pas de pilote ;
- j'ai cliqué sur rechercher ;
- on m'a proposé cinq pilotes :

Generic ESC/P Matrix Printer Foomatic/epson [en] (actuel)
Generic ESC/P Matrix Printer Foomatic/eps9high [en]
Generic ESC/P Matrix Printer Foomatic/eps9mid [en]
Generic ESC/P Matrix Printer Foomatic/epsonc [en]
Generic ESC/P Matrix Printer Foomatic/lq850 [en]


- j'ai choisi le premier.

Dernière modification par EliotEliot (24-05-2020 15:26:39)

Hors ligne

#12 25-05-2020 12:53:38

phlinux
Membre
Distrib. : Jessie
Noyau : 4.9
(G)UI : Openbox (+Rox+Feh)
Inscription : 09-05-2009

Re : Cups / Epson XP-2100

As-tu essayé

apt install printer-driver-escpr


Il y a aussi ce fil a consulter [Résolu} epson xp 2100


Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#13 25-05-2020 13:01:26

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Cups / Epson XP-2100

Salut
ElioEliot pourrais tu créer ton propre post sinon on va s'y perdre merci.gif
https://debian-facile.org/atelier:bernacle

Dernière modification par Croutons (25-05-2020 13:02:06)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#14 26-05-2020 18:52:19

EliotEliot
Membre
Distrib. : Debian 10 Buster
Noyau : Linux 4.19.0-9-686-pae
(G)UI : XFCE. Lightdm. 1 Processeur. 2 Core. 32bits (i686)
Inscription : 24-05-2020

Re : Cups / Epson XP-2100

@ Phlinux : J'ai essayé d'installer printer-driver-escpr :

printer-driver-escpr est déjà la version la plus récente (1.6.33-1).


J'ai aussi consulté la discussion d'ubuntu-fr mais je ne trouve pas de solution qui fonctionne chez moi.

Merci pour tes propositions.

@Croutons : je le fais de ce pas ! Désolé, c'était pour interpeller Luti.

Si vous possédez la solution à mon problème, vous pouvez maintenant venir dans CETTE discussion ! : https://debian-facile.org/viewtopic.php … 39#p334739 big_smile

Dernière modification par EliotEliot (26-05-2020 19:23:37)

Hors ligne

Pied de page des forums