Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 31-05-2020 15:15:38

geekyome
Membre
Lieu : LH
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux 4.19.0-9-amd64
(G)UI : Gnome
Inscription : 31-05-2020

[RESOLU] Pb GRUB après installation Debian10 en remplacement de Ubuntu

Bonjour à tous,

Je viens d'installer Debian10 sur mon laptop (en dualboot avec Win10) à la place d'une Ubuntu 20.04. Cependant après l'installation de Debian je rencontre un problème avec GRUB.

Le Laptop : ACER Swift 3, i5-7200U CPU @ 2.50GHz, 8 Go de RAM, SSD 256 Go. Mode EFI activé mais pas le secure boot.

Quand je démarre le PC, j'obtiens le prompt de grub : grub>

Si au démarrage du PC, j'appuie sur F12 et sélectionne le gestionnaire de démarrage de Windows, je peux bien démarrer Windows.

Pour pouvoir accéder au menu de GRUB, je dois taper les commandes suivantes :

set prefix=(hd0,gpt5)/boot/grub/
insmod normal
normal



Et là ça fonctionne bien, le menu de GRUB me permet de choisir Debian ou Windows qui démarrent bien.

Voici dans l'invite de commande de grub les résultats de 2 commandes :

ls


(proc) (hd0) (hd0,gpt7) (hd0,gpt6) (hd0,gpt5) (hd0,gpt4) (hd0,gpt3) (hd0,gpt2) (hd0,gpt1)



set


?=0
check_signatures=no
cmdpath=(hd0,gpt1)/EFI/ubuntu
color_highlight=black/light-gray
color_normal=light-gray/black
feature_200_final=y
feature_all_video_module=y
feature_chainloader_bpb=y
feature_default_font_path=y
feature_menuentry_id=y
feature_menuentry_options=y
feature_nativedisk_cmd=y
feature_ntldr=y
feature_platform_search_hint=y
feature_timeout_style=y
grub_cpu=x86_64
grub_platform=efi
lang=
locale_dir=
net_default_ip=(null)
net_default_mac=(null)
net_default_server=
package_version=2.04-1ubuntu26
pager=
prefix=(hd0,gpt1)/boot/grub
pxe_default_server=
root=hd0,gpt1
secondary_locale_dir=



Je suis étonné de voir apparaître des références à Ubuntu... Est-ce que l'installation de Debian n'a pas installé GRUB proprement ?

Voici les sorties des commandes fdisk et parted :

fdisk -l


Disque /dev/nvme0n1 : 238,5 GiB, 256060514304 octets, 500118192 secteurs
Modèle de disque : INTEL SSDPEKKW256G7                    
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : gpt
Identifiant de disque : FAD20CD1-5088-423B-A499-7EFE651E65B1

Périphérique       Début       Fin  Secteurs Taille Type
/dev/nvme0n1p1      2048    206847    204800   100M Système EFI
/dev/nvme0n1p2    206848    239615     32768    16M Réservé Microsoft
/dev/nvme0n1p3    239616 251002879 250763264 119,6G Données de base Microsoft
/dev/nvme0n1p4 498020352 500117503   2097152     1G Environnement de récupératio
/dev/nvme0n1p5 251002880 368189439 117186560  55,9G Système de fichiers Linux
/dev/nvme0n1p6 368189440 383813631  15624192   7,5G Partition d'échange Linux
/dev/nvme0n1p7 383813632 498020351 114206720  54,5G Système de fichiers Linux

Les entrées de la table de partitions ne sont pas dans l'ordre du disque.
 



parted -l


Model: INTEL SSDPEKKW256G7 (nvme)
Disk /dev/nvme0n1: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number  Start   End    Size    File system     Name                          Flags
 1      1049kB  106MB  105MB   fat32           EFI system partition          boot, esp
 2      106MB   123MB  16,8MB                  Microsoft reserved partition  msftres
 3      123MB   129GB  128GB   ntfs            Basic data partition          msftdata
 5      129GB   189GB  60,0GB  ext4            racine
 6      189GB   197GB  8000MB  linux-swap(v1)  swap
 7      197GB   255GB  58,5GB  ext4            home
 4      255GB   256GB  1074MB  ntfs            Basic data partition          hidden, diag
 



De plus je suis étonné de ce que me donne la commande efibootmgr :

efibootmgr -v


BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0002,0001,2001,2002,2003
Boot0000* ubuntu  HD(1,GPT,c24b24ce-5745-49d6-9f4f-191122ce126f,0x800,0x32000)/File(\EFI\ubuntu\shimx64.efi)
Boot0001* Windows Boot Manager  HD(1,GPT,c24b24ce-5745-49d6-9f4f-191122ce126f,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot0002* UbuntuShimx64 PciRoot(0x0)/Pci(0x1c,0x4)/Pci(0x0,0x0)/NVMe(0x1,00-00-00-00-00-00-00-00)/HD(1,GPT,c24b24ce-5745-49d6-9f4f-191122ce126f,0x800,0x32000)/File(\EFI\ubuntu\shimx64.efi)A01 ..
Boot0003* Unknown Device:   HD(1,GPT,c24b24ce-5745-49d6-9f4f-191122ce126f,0x800,0x32000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0005* debian  HD(1,GPT,c24b24ce-5745-49d6-9f4f-191122ce126f,0x800,0x32000)/File(\EFI\debian\shimx64.efi)
Boot2001* EFI USB Device  RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network RC
 



Là encore on voit des références à Ubuntu qui n'ont pas lieu d'être.

J'ai essayé de faire :

efibootmgr -o 0005,0001,2001,2003



mais ça ne change rien.

Bref j'aimerais faire un coup de propre à ce GRUB et faire en sorte qu'il aille bien chercher tout seul la bonne partition, mais je tourne en rond et ne trouve pas la solution.

Si jamais quelqu'un ici peut me sortir de là....

Merci de m'avoir lu jusqu'ici.

Geekyome

Dernière modification par geekyome (02-06-2020 21:21:02)

Hors ligne

#2 31-05-2020 16:35:39

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU] Pb GRUB après installation Debian10 en remplacement de Ubuntu

geekyome a écrit :

Pour pouvoir accéder au menu de GRUB, je dois taper les commandes suivantes :


Je ne pense pas que la commande "insmod normal" soit utile. L'invite "grub>" indique que GRUB est déjà dans le mode normal, sinon l'invite serait "grub rescue>".

geekyome a écrit :

Je suis étonné de voir apparaître des références à Ubuntu


Pas moi. C'est le GRUB laissé par Ubuntu qui est lancé, à cause du BootOrder qui n'est pas géré correctement par le firmware UEFI. Assez courant, hélas.
Axiome : les firmwares UEFI sont buggés. Tous.

geekyome a écrit :

Là encore on voit des références à Ubuntu qui n'ont pas lieu d'être.


Pourquoi ? Il n'y a aucune raison qu'elles disparaissent tant qu'elles ou leurs cibles n'ont pas été supprimées. Et les supprimer ne forcera pas le firmware UEFI à démarrer avec le GRUB de Debian.

geekyome a écrit :

J'ai essayé de faire :

efibootmgr -o 0005,0001,2001,2003


mais ça ne change rien.


C'est-à-dire ? BootOrder ne prend pas la valeur demandée ou bien celle-ci n'a aucun effet ?

Avec certains firmwares UEFI (il me semble que les Acer en font partie), il faut faire quelque chose dans les options UEFI pour "approuver" (ou quelque chose dans le genre) le nouveau chargeur d'amorçage.
Sinon, il reste les bidouilles :
- remplacer le contenu de /boot/efi/EFI/ubuntu par celui de /boot/efi/EFI/debian (sans garantie, le firmware pourrait s'en apercevoir et le bloquer)
- modifier le fichier de configuration de GRUB d'Ubuntu (peut-être /boot/efi/EFI/ubuntu/grub.cfg, je ne connais pas Ubuntu) pour qu'il recherche la partition de Debian au lieu de celle d'Ubuntu qui n'existe plus)

Dernière modification par raleur (31-05-2020 16:36:46)


Il vaut mieux montrer que raconter.

Hors ligne

#3 31-05-2020 16:53:40

geekyome
Membre
Lieu : LH
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux 4.19.0-9-amd64
(G)UI : Gnome
Inscription : 31-05-2020

Re : [RESOLU] Pb GRUB après installation Debian10 en remplacement de Ubuntu

raleur a écrit :

geekyome a écrit :

Pour pouvoir accéder au menu de GRUB, je dois taper les commandes suivantes :


Je ne pense pas que la commande "insmod normal" soit utile. L'invite "grub>" indique que GRUB est déjà dans le mode normal, sinon l'invite serait "grub rescue>".



Effectivement ! ça fait déjà une ligne de moins à taper ! On progresse !!

raleur a écrit :


geekyome a écrit :

J'ai essayé de faire :

efibootmgr -o 0005,0001,2001,2003


mais ça ne change rien.


C'est-à-dire ? BootOrder ne prend pas la valeur demandée ou bien celle-ci n'a aucun effet ?



Les 2 mon général ! Le Bootorder prend la bonne valeur immédiatement après avoir effectué la commande. Cependant ça ne change rien au reboot suivant (toujours le prompt grub>) et quand je vérifie à nouveau le paramétrage du BootOrder je retrouve l'ancienne valeur.

raleur a écrit :

Avec certains firmwares UEFI (il me semble que les Acer en font partie), il faut faire quelque chose dans les options UEFI pour "approuver" (ou quelque chose dans le genre) le nouveau chargeur d'amorçage.
Sinon, il reste les bidouilles :
- remplacer le contenu de /boot/efi/EFI/ubuntu par celui de /boot/efi/EFI/debian (sans garantie, le firmware pourrait s'en apercevoir et le bloquer)
- modifier le fichier de configuration de GRUB d'Ubuntu (peut-être /boot/efi/EFI/ubuntu/grub.cfg, je ne connais pas Ubuntu) pour qu'il recherche la partition de Debian au lieu de celle d'Ubuntu qui n'existe plus)



je vais explorer ces pistes.

Merci pour ce retour.

Geekyome

Hors ligne

#4 31-05-2020 18:45:50

geekyome
Membre
Lieu : LH
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux 4.19.0-9-amd64
(G)UI : Gnome
Inscription : 31-05-2020

Re : [RESOLU] Pb GRUB après installation Debian10 en remplacement de Ubuntu

raleur a écrit :


Sinon, il reste les bidouilles :
- remplacer le contenu de /boot/efi/EFI/ubuntu par celui de /boot/efi/EFI/debian (sans garantie, le firmware pourrait s'en apercevoir et le bloquer)
- modifier le fichier de configuration de GRUB d'Ubuntu (peut-être /boot/efi/EFI/ubuntu/grub.cfg, je ne connais pas Ubuntu) pour qu'il recherche la partition de Debian au lieu de celle d'Ubuntu qui n'existe plus)



Il y a effectivement une bidouille qui fonctionne, une fois le Debian démarré "à la main" on utilise la commande suivante :

grub-mkconfig -o /boot/efi/EFI/ubuntu/grub.cfg



Ainsi on crée une config de GRUB pour Debian dans l'ancien dossier de Ubuntu vers lequel pointe le démarrage de GRUB. Et ça fonctionne.

Cependant ça reste du bricolage. Si quelqu'un a une idée pour une solution plus propre, ça m'intéresse !!

Merci raleur de m'avoir mis sur la voie.

@+

Geekyome

Hors ligne

#5 31-05-2020 19:03:42

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU] Pb GRUB après installation Debian10 en remplacement de Ubuntu

Ce n'est pas la bonne méthode car ce fichier ne sera pas mis à jour automatiquement lors de la mise à jour du noyau.
Je pense qu'il serait plus propre et tout aussi efficace de copier /boot/efi/EFI/debian/grub.cfg sur /boot/efi/EFI/ubuntu/grub.cfg.

Mais il n'en reste pas moins que c'est toujours le GRUB d'Ubuntu qui est lancé, et celui-là ne sera pas mis à jour en cas de faille de sécurité.

Il vaut mieux montrer que raconter.

Hors ligne

#6 31-05-2020 20:18:05

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : [RESOLU] Pb GRUB après installation Debian10 en remplacement de Ubuntu

geekyome, pourquoi tu ne vas pas dans le bios faire du ménage ?

Tu supprimes les entrées uefi inutiles et tu bootes sur le fichier EFI/debian/grubx64.efi ou EFI/debian/shimx64.efi

Hors ligne

#7 31-05-2020 20:49:09

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : [RESOLU] Pb GRUB après installation Debian10 en remplacement de Ubuntu

Tu dois procéder comme ceci pour ajouter ton entrée debian dans le bios : https://www.youtube.com/watch?time_cont … e=emb_logo

Dernière modification par Beta-Pictoris (31-05-2020 20:53:22)

Hors ligne

#8 01-06-2020 15:41:39

geekyome
Membre
Lieu : LH
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux 4.19.0-9-amd64
(G)UI : Gnome
Inscription : 31-05-2020

Re : [RESOLU] Pb GRUB après installation Debian10 en remplacement de Ubuntu

Merci Beta-Pictoris !

J'essayais bien de faire du ménage dans le bios, mais je ne parvenais pas à trouver ni où ni comment. La vidéo que tu m'as indiquée associée à celle-ci : https://youtu.be/AF1wSPFAq_A m'ont permis de régler le problème.

Petits conseils pour ceux qui arriveraient sur ce fil de discussion par un moteur de recherche :

* définir un mot de passe Supervisor pour faire apparaître des options supplémentaires dans l'onglet Security du setup du bios.

* dans l'onglet Boot, mette le Secure Boot sur enabled pour avoir accès aux options supplémentaires.

* ensuite on peut effacer tous les paramétrages du secure boot (onglet Security : Erase all Secure Boot Setting).

* sélectionner le bon fichier UEFI (Select an UEFI file as trusted ; dans mon cas on rentre sur le disque dur (NVM), puis EFI, debian, et j'ai choisi le fichier grubx64.efi)

* enregistrer les réglages du setup du bios et redémarrer (F10)

* revenir dans le setup du bios (F2)

* dans l'onglet Boot, faire passer la ligne qui commence par EFI File Boot 0 qui a dû apparaître tout en bas de la liste en 1ère position (F6)

* repasser le Secure Boot en Disabled

* éventuellement enlever le mot de passe Supervisor si on a peur de l'oublier (ce serait dommage de ne plus accéder au setup du bios dans 6 mois)

* enregistrer les réglages du setup du bios et redémarrer (F10)

Et c'est bon !!


Merci à ceux qui ont participé à la discussion, chaque réponse a permis d'avancer.

@+

Geekyome

Hors ligne

Pied de page des forums