Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-07-2020 17:06:31

Geneviève DUCHENE
Membre
Inscription : 06-07-2020

installation : problème de dépendance

Bonjour,
je cherche à installer openboard sur Debian 10 mais mon installateur de paquets me donne le message d'erreur suivant : "

Erreur : la dépendance ne peut être satisfaite :
libavformat-ffmpeg56 (>= 7:2.8.15)

Je ne sais pas comment résoudre cette erreur : où trouver le paquet manquant ?

Hors ligne

#2 06-07-2020 17:12:28

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.8.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : installation : problème de dépendance

bonjour geneviève big_smile

et bienvenue .

je ne sais pas si tu as eu une bonne idée .
openboard semble conçu pour ubuntu , pas pour debian .

scratchhead.gif

on trouve ceci :

https://github.com/OpenBoard-org/OpenBoard

Supported platforms are Windows (7+), OS X (10.9+) and Linux (tested on Ubuntu 16.04).


https://www.debian-fr.org/t/installatio … oard/77633
qui amène --là--


testé sous sid : dépendances non satisfaites .

Dernière modification par Debian Alain (06-07-2020 20:14:59)

En ligne

#3 06-07-2020 19:57:54

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-9-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : installation : problème de dépendance

hello
Pas trop le temps maintenant je testerais cette soluce demain en Vm

sinon il y a la version en flatpak
https://debian-facile.org/doc:systeme:flatpak
https://flathub.org/apps/details/ch.openboard.OpenBoard

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#4 06-07-2020 23:40:42

èfpé
Membre
Inscription : 10-07-2016

Re : installation : problème de dépendance

Bon{soir|ne nuit|jour},

Debian Alain a écrit :

testé sous sid : dépendances non satisfaites.


L'installation des paquets de l'ITZkS ne pose pas de problème particulier sur une Debian 10 Buster :

cd /tmp


wget http://packages.it-zukunft-schule.de/debian/pool/main/o/openboard/openboard_1.5.3+dfsg1-1~itzks2~0deb10+1_amd64.deb

wget http://packages.it-zukunft-schule.de/debian/pool/main/o/openboard/openboard-common_1.5.3+dfsg1-1~itzks2~0deb10+1_all.deb


sha256sum openboard*

df573b00a0b41344f6d95c1f4969663e103542704f80deb018c7d93add50857d  openboard_1.5.3+dfsg1-1~itzks2~0deb10+1_amd64.deb
7726787a2eec03f5d0b4a25f756607b5243ef9868f04b46d3ba85e4a68aa674a  openboard-common_1.5.3+dfsg1-1~itzks2~0deb10+1_all.deb


apt install /tmp/openboard*

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Note : sélection de « openboard » au lieu de « /tmp/openboard_1.5.3+dfsg1-1~itzks2~0deb10+1_amd64.deb »
Note : sélection de « openboard-common » au lieu de « /tmp/openboard-common_1.5.3+dfsg1-1~itzks2~0deb10+1_all.deb »
Les paquets supplémentaires suivants seront installés :
  fonts-ecolier-court fonts-ecolier-lignes-court libjs-jquery-center libjs-jquery-colorpicker libjs-jquery-easing
  libjs-jquery-i18n-properties libjs-jquery-markitup libjs-jquery-ui libjs-mustache libqt5xmlpatterns5 libquazip5-1
Paquets suggérés :
  libjs-jquery-ui-docs libquazip-doc
Les NOUVEAUX paquets suivants seront installés :
  fonts-ecolier-court fonts-ecolier-lignes-court libjs-jquery-center libjs-jquery-colorpicker libjs-jquery-easing
  libjs-jquery-i18n-properties libjs-jquery-markitup libjs-jquery-ui libjs-mustache libqt5xmlpatterns5 libquazip5-1
  openboard openboard-common
0 mis à jour, 13 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 1869 ko/24,4 Mo dans les archives.
Après cette opération, 59,7 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]
 


En farfouillant on trouve aussi un paquet de fontes non libres. Pas testé la méthode propre (dépôt).

edit: utilisation du répertoire /tmp... suite à la « rectification » de Croutons (07-07-2020 09:06:18).

Dernière modification par èfpé (20-08-2020 21:40:42)

Hors ligne

#5 07-07-2020 07:44:13

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-9-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : installation : problème de dépendance

hello
Merci pour le test èfpé
d’après ce que je comprend dans ta dernière commande

apt install ./openboard*


c'est installer tout fichier commençant par openboard ce trouvant dans le répertoire courant /root ? donc message d'erreur du coup ,sauf pour quelqu'un qui utilise sudo

je me permet de rectifier pour télécharger dans le dossier Téléchargement ce qui est mieux

wget -P ~/Téléchargements/ http://packages.it-zukunft-schule.de/debian/pool/main/o/openboard/openboard_1.5.3+dfsg1-1~itzks2~0deb10+1_amd64.deb


wget -P ~/Téléchargements/ http://packages.it-zukunft-schule.de/debian/pool/main/o/openboard/openboard-common_1.5.3+dfsg1-1~itzks2~0deb10+1_all.deb



sha256sum ~/Téléchargements/openboard*


j'ai pas trouvé sur le site ou controler le hash256 des fichiers téléchargé scratchhead.gif

puis on installe en spécifiant le chemin des 2 fichiers

apt install /home/utilisateur/openboard*


utilisateur est a remplacer par le bon nom bien sur wink

Dernière modification par Croutons (07-07-2020 08:06:18)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#6 07-07-2020 07:57:44

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.7 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : installation : problème de dépendance

En me basant sur ce que propose èfpé, j’ai pu installer openboard en utilisant le dépôt fourni.

1. Installation des clés utilisées pour signer les paquets de ce dépôt :

wget http://packages.it-zukunft-schule.de/debian/pool/main/i/itzks-keyring/itzks-keyring_2019.09.06.1~0deb10+1_all.deb
dpkg --install ./itzks-keyring_2019.09.06.1~0deb10+1_all.deb


2. Ajout du dépôt aux sources de paquet du système :

echo 'deb http://packages.it-zukunft-schule.de/debian/ buster main' > /etc/apt/sources.list.d/openboard.list
apt-get update


3. Installation de openboard :

apt-get install openboard


Jouer sous Debian ? Facile !

Hors ligne

#7 07-07-2020 08:20:42

èfpé
Membre
Inscription : 10-07-2016

Re : installation : problème de dépendance

Re-,

Croutons a écrit :

j'ai pas trouvé sur le site où contrôler le hash256 des fichiers téléchargés


Les sommes de contrôle SHA256, SHA1 et autres MD5sum se trouvent dans les listes de paquets :

sed '1526,1570!d' Packages

Package: openboard
Version: 1.5.3+dfsg1-1~itzks2~0deb10+1
Architecture: amd64
Maintainer: Debian Edu Packaging Team <debian-edu-pkg-team@lists.alioth.debian.org>
Installed-Size: 6679
Depends: libasound2 (>= 1.0.16), libass9 (>= 1:0.13.6), libavcodec58 (>= 7:4.0), libavformat58 (>= 7:4.1),
libavutil56 (>= 7:4.0), libbz2-1.0, libc6 (>= 2.14), libfreetype6 (>= 2.2.1), libgcc1 (>= 1:3.0),
libgl1, libglib2.0-0 (>= 2.12.0), libgomp1 (>= 4.9), liblzma5 (>= 5.1.1alpha+20110809), libmp3lame0
(>= 3.100), libogg0 (>= 1.0rc3), libopus0 (>= 1.1), libpoppler82 (>= 0.71.0), libpulse-mainloop-glib0
(>= 0.99.1), libpulse0 (>= 0.99.1), libqt5core5a (>= 5.11.0~rc1), libqt5gui5 (>= 5.8.0), libqt5multimedia5
(>= 5.6.0~beta), libqt5multimediawidgets5 (>= 5.6.0~beta), libqt5network5 (>= 5.0.2), libqt5printsupport5
(>= 5.0.2), libqt5script5 (>= 5.6.0~beta), libqt5svg5 (>= 5.6.0~beta), libqt5webkit5 (>= 5.6.0~rc),
libqt5widgets5 (>= 5.11.0~rc1), libqt5xml5 (>= 5.0.2), libqt5xmlpatterns5 (>= 5.0.2), libquazip5-1
(>= 0.7.3), libsdl1.2debian (>= 1.2.11), libssl1.1 (>= 1.1.0), libstdc++6 (>= 5.2), libswresample3
(>= 7:4.0), libswscale5 (>= 7:4.0), libtheora0 (>= 1.0), libva-x11-2 (>= 1.0.3), libva2 (>= 1.0.3),
libvorbis0a (>= 1.1.2), libvorbisenc2 (>= 1.1.2), libvpx5 (>= 1.6.0), libx11-6, libx264-155,
libxcb-render0, libxcb-shape0, libxcb-shm0, libxcb-xfixes0, libxcb1, zlib1g (>= 1:1.1.4), openboard-common
(>= 1.5.3+dfsg1-1~itzks2~0deb10+1), fonts-ecolier-court, fonts-ecolier-lignes-court, fonts-sil-andika
Breaks: openboard-common (<< 1.5.3-1~)
Homepage: https://github.com/OpenBoard-org/OpenBoard
Priority: optional
Section: x11
Filename: pool/main/o/openboard/openboard_1.5.3+dfsg1-1~itzks2~0deb10+1_amd64.deb
Size: 2026024
SHA256: df573b00a0b41344f6d95c1f4969663e103542704f80deb018c7d93add50857d
SHA1: 4378b5a58b6532e8a03c25816f0810e5960e8b5b
MD5sum: 6de0f9bfe33a03ff59fba5abc198af29
Description: Interactive White Board Application
 OpenBoard is an open source cross-platform interactive white board
 application designed primarily for use in schools.
 .
 It was originally forked from Open-Sankoré, which was itself based on
 Uniboard.

Package: openboard-common
Source: openboard
Version: 1.5.3+dfsg1-1~itzks2~0deb10+1
Architecture: all
Maintainer: Debian Edu Packaging Team <debian-edu-pkg-team@lists.alioth.debian.org>
Installed-Size: 43678
Depends: libjs-jquery, libjs-jquery-center, libjs-jquery-colorpicker, libjs-jquery-easing,
libjs-jquery-i18n-properties, libjs-jquery-markitup, libjs-jquery-ui, libjs-modernizr, libjs-mustache
Homepage: https://github.com/OpenBoard-org/OpenBoard
Priority: optional
Section: x11
Filename: pool/main/o/openboard/openboard-common_1.5.3+dfsg1-1~itzks2~0deb10+1_all.deb
Size: 20532748
SHA256: 7726787a2eec03f5d0b4a25f756607b5243ef9868f04b46d3ba85e4a68aa674a
SHA1: cd8e52c6d0270ef305544d6e124a36b5f3fbc442
MD5sum: 888fad8c2cd8127bb3bd185e45fec033
Description: Interactive White Board Application (common files)
 OpenBoard is an open source cross-platform interactive white board
 application designed primarily for use in schools.
 .
 It was originally forked from Open-Sankoré, which was itself based on
 Uniboard.
 .
 This package contains all architecture independent files.
 


APT va plus loin, dans l'authentification... mais ces listes montrent l'intérêt du fichier de préférences.

Dernière modification par èfpé (08-07-2020 13:20:42)

Hors ligne

#8 07-07-2020 08:37:28

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.7 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : installation : problème de dépendance

èfpé a écrit :

Pas besoin de pinning ?



Ce serait probablement plus prudent, mais je me suis contenté d’un test rapide sans aller jusqu’à régler les priorités.


Jouer sous Debian ? Facile !

Hors ligne

Pied de page des forums