Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 08-07-2020 11:37:51

JM38
Membre
Distrib. : LMDE4 debbie
Noyau : Linux 4.19.0-9 Cinnamon 4.4.8
Inscription : 03-06-2020

Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

Bonjour
Je trouve le démarrage de mon ordi sous linux Mint4 assez lent
(plus de 2 minutes jusqu’à l’apparition du bureau complet, est-ce normal ?)
Je ne suis pas sur ma bécane mais le vendeur (un étudiant) avait donné:
Core2 DUO T5550 1,83 GHZ X 2
mémoire DDR2 4GO
Disque SATA 2,5 " 300GO
Processeur graphique NVIDIA Geforce 8600M GT

C’est à vérifier mais je pense que c’est ça, j’avais regardé le système

Potentiellement, tu as un pb au démarrage, peut-être des pb de déclarations de swap fantômes ou trucs du genre qui perdent 30s pour rien

Je connais très bien windows, mais je ne sais pas sous linux comment savoir ce qui est lancé au démarrage, sous windows il y a le fameux msconfig, et toute une série de logiciels (startup , processxp etc..)
Ici avec la commande top on sait ce qui tourne mais sans pour autant savoir si c’est nécessaire !!!
Il doit aussi y avoir des fichiers temporaires mais ce n’est pas ça qui nuit au démarrage
Le bureau est éthique (les icones classiques plus le raccourci vers le dossier que j’ai créé )
Merci
JM

Dernière modification par JM38 (22-07-2020 11:23:22)

Hors ligne

#2 08-07-2020 12:05:59

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.10 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

Je t’invite à partager le retour de la commande suivante, qui devrait nous donner de premières pistes sur ce qui prend du temps au démarrage du système :

systemd-analyze blame



Ici par exemple les premières lignes du retour sont :

26.594s apt-daily.service                                                                        
 3.237s transmission-daemon.service                                                              
 2.444s certbot.service                                                                          
 2.076s postfix@-.service                                                                        
 2.059s ifupdown-wait-online.service                                                            


Jouer sous Debian ? Facile !

Hors ligne

#3 08-07-2020 13:27:16

raleur
Membre
Inscription : 03-10-2014

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

JM38 a écrit :

peut-être des pb de déclarations de swap fantômes ou trucs du genre qui perdent 30s pour rien


"Peut-être" ? Si c'est le cas, ça s'affiche pendant l'attente, et ça se retrouve dans les logs avec

journalctl -xb


Un swap fantôme n'apparaît pas tout seul, soit l'administrateur a introduit une erreur dans /etc/fstab, soit un swap qui est declare dans /etc/fstab a été supprimé ou reformaté avec changement d'UUID. Un swap ne disparaît ou ne se reformate pas tout seul non plus. Ça peut arriver quand on installe un autre système.


Il vaut mieux montrer que raconter.

Hors ligne

#4 08-07-2020 14:53:52

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

J'ai eu souvent ce type de problème après ré-installation


# blkid
 


te renvoie les UUID de toutes les partitions, en particulier celle du swap.
Après il faut contrôler si c'est en accord avec /etc/fstab

Hors ligne

#5 08-07-2020 19:00:32

Debeee
Membre
Distrib. : Buster / Testing
Noyau : 4.19.0-8 / 5.4.0-4
(G)UI : mate /mate
Inscription : 11-02-2015

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

re-

Alors, effectivement, on n'est pas sur du véloce, ton processeur est du niveau d'un atom N570 (j'en ai un !), et donc, avec un ssd médiocre, ça doit booter en pas loin de 50s. Si tu as un disque dur classique, ça peut faire plus d'une minute.

Je repose ma question, concernant les swap fantômes : combien de systèmes sont installés sur ta machine ? juste la LMDE ou d'autres systèmes ? Si tu n'as que la LMDE, c'est une mauvaise piste, l'installateur gère ça très bien.

Hors ligne

#6 08-07-2020 19:28:12

JM38
Membre
Distrib. : LMDE4 debbie
Noyau : Linux 4.19.0-9 Cinnamon 4.4.8
Inscription : 03-06-2020

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

bonsoir et merci
pour vv222
systemd-analyze blame  (il n'y a pas d'espace entre systemd et analyze?

pour raleur

journalctl -xb

cela génère un fichier  à la console ou dans quel fichier et dans quel dossier ?
et comment voir s'il existe un swap fantome ?

pour gargamel79
# blkid
te renvoie les UUID de toutes les partitions, en particulier celle du swap.
Après il faut contrôler si c'est en accord avec /etc/fstab

comment voir si il y a des   "swap"  ? comment se nomment  t'il?
***********
pour tous
je passe en mode terminal avec la commande CTRL ALT F1
je suis en mode user je suppose /usr/
passer en mode root signifie racine, je dois changer de dossier?
cd .. ?

en mode superviseur
je n'ai pu m'y connecter car en donnant  le mot de passe que j'utilise pour déverrouiller ,il ne marche pas

Mais bon je chronométrerai la prochaine fois le temps entre appui sur "on" et l'affichage du  bureau
il y a des messages , un écran vierge un certain temps puis l'écusson LMDE ou MINT je ne sais plus , en plein milieu de l'écran, puis l'affichage de bienvenue que j'ai laissé coché puis je crois un écran vierge  puis enfin le bureau
quand on attend on trouve toujours le temps long même pour un jeune retraité
A suivre donc et désolé pour ce questions qui peuvent vous sembler bien stupides
PS
il n'y a pas de système sans échec sous linux?
merci encore
JM

Hors ligne

#7 09-07-2020 09:31:13

JM38
Membre
Distrib. : LMDE4 debbie
Noyau : Linux 4.19.0-9 Cinnamon 4.4.8
Inscription : 03-06-2020

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

Bonjour
journalctl -xb
le log est il en append ?  ou nouveau chaque jour ?

le fichier fstab est il l'équivalent du config.sys de windows? io.sys ,win.ini

merci
Bonne journée
J

Hors ligne

#8 09-07-2020 10:02:58

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.14.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

salut JM38 ,

pour tester ton boot , tu peux faire ceci :

pour les timings :

systemd-analyze blame


systemd-analyze time



pour les messages d'erreur avec jourtnalctl :

journalctl -r -p err | tail -n 50


journalctl -r -p warn | tail -n 50


journalctl -r -p crit | tail -n 50



pour les messages d'erreur avec dmesg :

dmesg -l err | tail -n 50


dmesg -l crit | tail -n 50


dmesg -l warn | tail -n 50


("L" minuscule , pas "I" )

Dernière modification par Debian Alain (09-07-2020 10:04:49)

Hors ligne

#9 09-07-2020 10:29:35

JM38
Membre
Distrib. : LMDE4 debbie
Noyau : Linux 4.19.0-9 Cinnamon 4.4.8
Inscription : 03-06-2020

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

Bonjour Debian Alain et merci
pour
systemd-analyze blame
et
systemd-analyze time
ça défile à la console pas à pas ou sur plusieurs pages ?
dans ce cas je suppose qu'on peut le capturer dans un fichier avec >? ou le visualiser page à page (argument tail?)

pour les messages d'erreur,   dmesg ou journalctl donnent les mêmes infos?
on peut le capturer dans un fichier avec >?

y at'il comme sous windows un journal des événements?
Quand je rentrerai at home (crochus !!) je vous ferai part des résultats
Avec ces commandes on devrait y voir plus clair
En général entre l’appui sur ON et l’affichage du bureau opérationnel (possibilité de cliquer), il faut compter combien de temps
Je sais ça dépend du vent de la pression ….(de la bécane en elle-même,processeur et composants)
Ma bécane doit au moins avoir 10 ans !!! et j’ai entendu qu’il n’était pas forcément judicieux d’avoir les dernières versions de linux, car moins adapté pour les anciennes machines !!)
Mais …. Peut-on régresser en linux Mint ?

merci beaucoup
JM

Hors ligne

#10 09-07-2020 10:42:08

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.14.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

ça défile à la console pas à pas ou sur plusieurs pages ?


normalement page par page .

pour les messages d'erreur,   dmesg ou journalctl donnent les mêmes infos?


pas tout à fait .

on peut le capturer dans un fichier avec >?


jamais eu besoin mais je pense oui .

y at'il comme sous windows un journal des événements?


il y a le dossier des logs dans /var/log

en tout cas pour debian / ubuntu / mint

Hors ligne

#11 09-07-2020 19:16:23

JM38
Membre
Distrib. : LMDE4 debbie
Noyau : Linux 4.19.0-9 Cinnamon 4.4.8
Inscription : 03-06-2020

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

Bonsoir et merci
J'essaierai tes commandes
A priori ces 2 commandes
systemd-analyze blame
systemd-analyze time
devraient être les plus utiles pour mieux comprendre la lenteur du démarrage ?
Bonne soiree
JM

Hors ligne

#12 09-07-2020 19:39:15

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.14.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

oui ,

systemd-analyze time

te donnera un résumé de tes temps de démarrage

alors que

systemd-analyze blame

te donnera le détail .
tu pourra donc voir où se situe la ou les erreur(s) .
si tu as un temps de démarrage anormalement long sur un ou plusieurs daemon(s) ...

journalctl et dmesg t'aideront à affiner  tes recherches , à voir si il n'y a pas d'autre(s) erreur(s) ailleurs que dans le timing du démarrage .

attention : ces deux commandes sont généralement très verbeuses .
j' ai séparé les options de façon à ce que tu voies plus clair dans tes recherches .
on peut tout regrouper  mais le résultat est alors plus confus et plus difficile à interpréter .

tous les  messages ne sont pas forcément  inquiétants .

N.B.: si ton hdd est vraiment  trop lent pour toi et qu'il n'y a pas d'erreur particulièrement anormale , pense à prendre un ssd .
je te recommande la marque crucial un peu moins chère que le leader samsung et aussi performante .
surtout si tu achète directement sur leur site (https://www.crucial.fr/)

Dernière modification par Debian Alain (09-07-2020 19:47:36)

Hors ligne

#13 10-07-2020 11:27:46

JM38
Membre
Distrib. : LMDE4 debbie
Noyau : Linux 4.19.0-9 Cinnamon 4.4.8
Inscription : 03-06-2020

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

Bonjour Alain et merci encore
J’essaierai
NB
Ma bécane a 4 ports usb2 dont la souris connectée , la webcam, un lecteur graveur de DVD et un écran 17 pouces, tout ça peut jouer (erreurs comprises)
Mais 2 minutes (je n’ai pas chronométré ,ce n’est pas dramatique, ça donne le temps de rêver ,et puis je préfère que ce soit long au démarrage et qu’elle tourne bien ensuite
Je ne fais que surfer de la bureautique mise à jour de site et voir photos
Il est certain qu’un SSD va « pulser » un peu plus !!
Merci encore
Je vous dirai ça quand je reviendrai chez moi en Isère
JM

Hors ligne

#14 10-07-2020 11:42:29

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.14.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

regarde si çà pourrait pas te convenir ,
un petit ssd :

-- crucial MX500 -- (500 Go.)

Dernière modification par Debian Alain (10-07-2020 11:43:30)

Hors ligne

#15 10-07-2020 13:32:38

raleur
Membre
Inscription : 03-10-2014

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

JM38 a écrit :

Ma bécane a 4 ports usb2 dont la souris connectée , la webcam, un lecteur graveur de DVD et un écran 17 pouces


Un écran branché sur un port USB ?


Il vaut mieux montrer que raconter.

Hors ligne

#16 10-07-2020 15:31:48

JM38
Membre
Distrib. : LMDE4 debbie
Noyau : Linux 4.19.0-9 Cinnamon 4.4.8
Inscription : 03-06-2020

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

pour raleur
L'écran n'est pas sur un port usb
seule la souris l'est
Pour Alain
je ne suis pas un pro de la plomberie, j'étais coté logiciel (Windows)
installer un disque , je ne sais pas faire (démonter un portable, insérer au bon endroit, avec bons branchements et tout réinstaller en étant moins qu'un béotien Linux !!! ça relèverait de l'exploit
Bon 14 juillet
et merci encore
JM

Hors ligne

#17 11-07-2020 09:19:23

JM38
Membre
Distrib. : LMDE4 debbie
Noyau : Linux 4.19.0-9 Cinnamon 4.4.8
Inscription : 03-06-2020

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

Bonjour
je ne sais pas si je l'ai indiqué mais Mon ordi est un portable !! et non un ordi de bureau !!
Bon 14 juillet
JM

Hors ligne

#18 16-07-2020 09:56:04

JM38
Membre
Distrib. : LMDE4 debbie
Noyau : Linux 4.19.0-9 Cinnamon 4.4.8
Inscription : 03-06-2020

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

Bonjour
j'ai executé les commandes préconisées et copié le résultat dans des fichiers
systemd
journalctl
dmesg
comment joindre les fichiers?
merci
JM

Hors ligne

#19 16-07-2020 10:08:29

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.14.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

ben , y  a pas beaucoup de  solutions .

1) les  stocker sur un serveur et donner le lien pour les diffuser :
     - google drive (par exemple mais y en a d'autres)
     - dl-free (normalement , c'est de l'envoi de fichiers . sais pas  s'il y a une fonction serveur)

2) les ouvrir et les copier / coller sur le forum entre les balises <autre code> pour chaque commande .

regarde et inspire toi en :  Oh, quel beau BB …code où comment mettre en forme vos messages dans le fofo

Hors ligne

#20 16-07-2020 10:08:42

JM38
Membre
Distrib. : LMDE4 debbie
Noyau : Linux 4.19.0-9 Cinnamon 4.4.8
Inscription : 03-06-2020

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

mon fstab
# UNCONFIGURED FSTAB FOR BASE SYSTEM
proc    /proc    proc    defaults    0    0
# /dev/sda2
UUID=1f27d519-0c21-41f4-ad0d-80e429d20c40 /  ext4 defaults 0 1
# /dev/sda1
UUID=28024c6c-bd49-4a25-95f8-b5b0852c72bb none   swap sw 0 0

résultat analyze seul
Startup finished in 9.501s (kernel) + 39.981s (userspace) = 49.483s
graphical.target reached after 33.490s in userspace

Hors ligne

#21 16-07-2020 10:19:03

JM38
Membre
Distrib. : LMDE4 debbie
Noyau : Linux 4.19.0-9 Cinnamon 4.4.8
Inscription : 03-06-2020

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

Rebonjour
la commande # blkid ne me renvoie rien ?
comment  dupliquer les caractères en mode terminal
exemple
j'ai exécuté systemd-analyze time
je veux relancer la commande en changeant la fin
exemple
systemd-analyze blame  (il doit exister une touche fonction caractère par caractère (sous le dos c'était F5) je n'ai pas trouvé sur internet la réponse
merci encore

Hors ligne

#22 16-07-2020 10:32:05

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.14.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

mais j'y pense : pour donner les liens vers tes  commandes , il y a aussi pastebinit .

-- sous ubuntu --
-- debian facile --
-- wiki debian.fr --

exemples , chez moi :

systemd-analyze time | pastebinit

https://paste.debian.net/1156614/



systemd-analyze blame | pastebinit

https://paste.debian.net/1156615/



JM38  a écrit :

je veux relancer la commande en changeant la fin
exemple
systemd-analyze blame  (il doit exister une touche fonction caractère par caractère (sous le dos c'était F5) je n'ai pas trouvé sur internet la réponse


joues avec les flèches de ton clavier .
<up> pour revenir à la commande précédente
<left> pour revenir au caractère précédent

Dernière modification par Debian Alain (16-07-2020 10:37:55)

Hors ligne

#23 16-07-2020 14:49:18

JM38
Membre
Distrib. : LMDE4 debbie
Noyau : Linux 4.19.0-9 Cinnamon 4.4.8
Inscription : 03-06-2020

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

Bonjour et Merci Alain pour ton aide
mon résultat du systemed-analyse (sec) vous inspire quoi?
idem
la commande # blkid ne me renvoie rien ?
idem
mon fstab ?
merci
JM
NB
mon portable a un processeur AMD
bonne journée

Hors ligne

#24 16-07-2020 15:50:24

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.14.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

tu es  sur lmde (base debian) ? ou mint (base ubuntu) ?

à installer :

apt install --reinstall lsb-release smartmontools hdparm


à configurer :

smartctl --smart=on --offlineauto=on --saveauto=on /dev/sda


que donnent ? (poster le retour)  :
quelle distribution ? :

lsb_release -a


infos sommaires /dev/sda (ton disque) :

smartctl -i /dev/sda


test performances de ton disque :

hdparm -tT /dev/sda



à priori , pour un disque mécanique , c'est normal .
un peu long mais rien de méchant ou d'inquiétant .
les commandes  ci dessus me permettront de certifier mon avis ou , au moins , de le détailler .

la commande

systemd-analyze blame

me donnerai le détail et me permettrai de confirmer ce que je pense ou de détailler ma réponse .
tu peux utiliser pastebinit si tu sais pas / veux pas poster le détail (copier / coller (à la souris par exemple) )

Dernière modification par Debian Alain (16-07-2020 16:17:54)

Hors ligne

#25 16-07-2020 19:17:24

JM38
Membre
Distrib. : LMDE4 debbie
Noyau : Linux 4.19.0-9 Cinnamon 4.4.8
Inscription : 03-06-2020

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

Merci
je pensais que LMDE signifiait Linux Mint sous Debian (je suis sous LMDE4)

A quoi servent ces 2 commandes ?
apt install --reinstall lsb-release smartmontools hdparm
smartctl --smart=on --offlineauto=on --saveauto=on /dev/sda

ça fait un peu peur !!

pour l'instant l'ordi marche
NB ce matin j'ai dû attendre après l'affichage du bureau
une vingtaine de secondes (j'ai même recliqué) quand j'ai appuyé sur firefox , et sur un raccourcu dossier
car je croyais que je n'avais pas cliqué

celles ci parlent d'elles même (lsb_release -a donne la réponse à ta question : tu es  sur lmde (base debian) ? ou mint (base ubuntu) ?
lsb_release -a
infos sommaires /dev/sda (ton disque) :
smartctl -i /dev/sda
test performances de ton disque :
hdparm -tT /dev/sda

merci encore
je posterai les exports demain
Bonne soirée
JM

Hors ligne

Pied de page des forums