Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#51 18-07-2020 13:55:33

JM38
Membre
Distrib. : LMDE4 debbie
Noyau : Linux 4.19.0-9 Cinnamon 4.4.8
Inscription : 03-06-2020

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

Pour Alain
la vitesse du disque me suffit amplement
je suis retraité et qui va piano .....
ce pc va bien plus vite que mon xp que je garde précieusement car j'ai des programmes 16 bits que j'ai écrits moi même (42 ans d"informatique, j'ai connu le langage beta et les cartes perforées...les segmentations et temporisations, les écrans eux mêmes étaient programmés, alors je sais que derrière une commande se cachent mille instructions)
J'ai fait du VI et unix il y a quelques années pour des applications spécifiques dans ma société
Linux est très coopératif, quand on se trompe il nous donne la solution exemple pour pastebinit qui n'était pas installé, il me semble qu'il y a du SQL derrière !!)
mais  je ne suis pas plombier
mais j'aime apprendre
j'ai acheté cette bécane d'occase car je ne pouvais plus maintenir le site de mon association que j'administre (pour des problèmes de sécurité serveur des histoires de SSl qui font hoqueter  Windows
je bosse parfois sur des bécanes w10 , W7 Vista et même 95 , mais je ne vais pas prêcher des convaincus ,windows est trop intrusif et demande sans cesse des mises à jours
Merci encore
JM

Hors ligne

#52 18-07-2020 14:03:46

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.8.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

tu as fait un bel effort , c'est bien .

tes posts seraient plus lisibles si tu utilisais les commandes de mises en page au dessus de la fenêtre de  rédaction .

tiens compte de ceci , s'il te  plait : Oh, quel beau BB …code où comment mettre en forme vos messages dans le fofo

je ne vois  qu'une seule ombre au tableau dans ton rapport

systemd-analyze blame


        22.689s man-db.service
         16.636s NetworkManager-wait-online.service
         10.042s udisks2.service
          9.184s ModemManager.service
          8.229s logrotate.service
          7.554s accounts-daemon.service
          7.113s dev-sda2.device
          7.088s NetworkManager.service
          6.926s debian-system-adjustments.service
          6.234s systemd-udev-settle.service
          5.855s sysfsutils.service
          5.841s acpi-support.service
          5.698s avahi-daemon.service
          5.683s wpa_supplicant.service
          5.256s thermald.service
          4.758s lm-sensors.service
          4.717s systemd-logind.service
          4.658s rsyslog.service
          4.613s apt-daily.service
          4.183s user@1000.service
          3.373s lightdm.service
          3.369s plymouth-quit-wait.service
          2.738s networking.service
          2.353s exim4.service
          1.946s colord.service
          1.938s apparmor.service
          1.709s upower.service
          1.505s systemd-udevd.service
          1.213s apt-daily-upgrade.service
          1.055s polkit.service
           989ms dns-clean.service
           824ms systemd-rfkill.service
           733ms systemd-journald.service
           717ms systemd-modules-load.service
           656ms systemd-udev-trigger.service
           635ms systemd-tmpfiles-setup.service
           598ms brltty.service
           501ms systemd-timesyncd.service
           500ms systemd-sysusers.service
           435ms dev-mqueue.mount
           417ms sys-kernel-debug.mount
           373ms systemd-remount-fs.service
           364ms console-setup.service
           362ms systemd-backlight@backlight:acpi_video0.service
           354ms keyboard-setup.service
           343ms dev-hugepages.mount
           269ms kmod-static-nodes.service
           259ms systemd-sysctl.service
           231ms blk-availability.service
           225ms systemd-journal-flush.service
           216ms ufw.service
           167ms ifupdown-pre.service
           165ms lvm2-monitor.service
           149ms systemd-tmpfiles-setup-dev.service
           115ms systemd-update-utmp.service
           103ms pppd-dns.service
           101ms systemd-random-seed.service
            92ms hddtemp.service
            70ms dev-disk-by\x2duuid-28024c6c\x2dbd49\x2d4a25\x2d95f8\x2db5b0852c72bb.swap
            66ms rtkit-daemon.service
            62ms systemd-user-sessions.service
            60ms packagekit.service
            37ms user-runtime-dir@1000.service
            29ms alsa-restore.service
            24ms systemd-update-utmp-runlevel.service
            21ms plymouth-start.service
            21ms systemd-tmpfiles-clean.service
            20ms openvpn.service
            16ms plymouth-read-write.service
            11ms sys-fs-fuse-connections.mount
 



savoir , les services network-manager et mandb qui sont un peu longs .

Dernière modification par Debian Alain (18-07-2020 20:00:42)

Hors ligne

#53 18-07-2020 14:11:47

JM38
Membre
Distrib. : LMDE4 debbie
Noyau : Linux 4.19.0-9 Cinnamon 4.4.8
Inscription : 03-06-2020

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

Je comprends pour la présentation
merci
je viens d'installer également xnview (voir autre post)
je vais aller faire un peu de vélo
il fait super beau
JM

Hors ligne

#54 18-07-2020 14:19:14

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.8.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

trouvé ceci : https://www.blog-libre.org/2018/08/15/r … untu-mint/

tu as essayé : ?

sudo systemctl disable man-db.service


sudo reboot


systemd-analyze blame


une commande  qui peut t'aider (je viens de la découvrir) :

systemd-analyze critical-chain



chez moi :

 systemd-analyze critical-chain


The time when unit became active or started is printed after the "@" character.
The time the unit took to start is printed after the "+" character.

graphical.target @4.443s
└─multi-user.target @4.443s
  └─smartmontools.service @2.127s +2.315s
    └─basic.target @2.112s
      └─sockets.target @2.112s
        └─virtlogd-admin.socket @2.112s
          └─virtlogd.socket @2.112s
            └─sysinit.target @2.104s
              └─sys-fs-fuse-connections.mount @3.220s +8ms
                └─systemd-modules-load.service @235ms +16ms
                  └─systemd-journald.socket @226ms
                    └─-.mount @146ms
                      └─system.slice @146ms
                        └─-.slice @146m



tous les temps marqués à côté (à droite) du signe "+" sont des temps perdus .
parfois on peut les supprimer . en désactivant le service .
parfois , vaut mieux pas y toucher .

Dernière modification par Debian Alain (18-07-2020 19:58:21)

Hors ligne

#55 19-07-2020 08:10:59

JM38
Membre
Distrib. : LMDE4 debbie
Noyau : Linux 4.19.0-9 Cinnamon 4.4.8
Inscription : 03-06-2020

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

Bonjour Alain et merci encore
Je suppose que la désactivation du service est uniquement pour la session ?
dans ce cas ça n'aurait aucune incidence au démarrage
A quoi sert le service man-db ?
c'est certain qu'il faut être vigilant !! supprimer le network-manager et on n'a plus de réseau!!
Le signe + indique ce qui est trop long mais pas forcément à supprimer !!
J'exécuterai la commande  systemd-analyze critical-chain
et donnerai ici le résultat
merci encore
bon dimanche
JM

Hors ligne

#56 19-07-2020 08:41:37

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.8.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

JM38  a écrit :

Je suppose que la désactivation du service est uniquement pour la session ?


la désactivation , c'est pour tout le systeme , pas uniquement la session utilisateur .
si tu crées plusieurs sessions utilisateur , ce sera valable pour eux aussi .

JM38 a écrit :

A quoi sert le service man-db ?


sauf erreur , cela doit être la database du man (manuel).
que l'on peut réactiver avec

sudo systemctl enable man-db.service


puis reboot pour le revoir au lancement .

chez moi :

alain@lmde:~$ systemd-analyze blame


          3.841s vboxadd.service
          3.697s plymouth-quit-wait.service
          1.624s systemd-udev-settle.service
           988ms apt-daily.service
           855ms man-db.service
           682ms apt-daily-upgrade.service
           443ms dev-mapper-lvmlmde\x2droot.device
           385ms NetworkManager-wait-online.service
           339ms user@1000.service
           319ms exim4.service
           282ms udisks2.service
           258ms ModemManager.service
           219ms debian-system-adjustments.service
           208ms accounts-daemon.service
           182ms upower.service
           169ms logrotate.service
           168ms systemd-logind.service
           164ms NetworkManager.service
           160ms avahi-daemon.service
           149ms thermald.service
           134ms sysfsutils.service
           133ms acpi-support.service
           132ms wpa_supplicant.service
           129ms systemd-journald.service
           105ms lm-sensors.service
           102ms rsyslog.service
            92ms systemd-modules-load.service
            90ms lvm2-monitor.service
            76ms systemd-udevd.service
            73ms polkit.service
            70ms apparmor.service
            66ms lvm2-pvscan@8:1.service
            60ms systemd-sysusers.service
            56ms lightdm.service
            53ms networking.service
            48ms systemd-udev-trigger.service
            46ms systemd-random-seed.service
            39ms colord.service
            39ms alsa-restore.service
            37ms pppd-dns.service
            30ms brltty.service
            29ms dns-clean.service
            23ms systemd-remount-fs.service
            23ms systemd-tmpfiles-setup.service
            23ms systemd-journal-flush.service
            20ms vboxadd-service.service
            20ms ifupdown-pre.service
            17ms keyboard-setup.service
            16ms systemd-tmpfiles-setup-dev.service
            16ms kmod-static-nodes.service
            16ms ufw.service
            15ms systemd-sysctl.service
            14ms hddtemp.service
            14ms blk-availability.service
            14ms plymouth-start.service
            13ms systemd-update-utmp.service
            13ms dev-mapper-lvmlmde\x2dswap.swap
            13ms sys-kernel-debug.mount
            13ms rtkit-daemon.service
            11ms plymouth-read-write.service
            10ms systemd-user-sessions.service
            10ms dev-hugepages.mount
            10ms user-runtime-dir@1000.service
             9ms console-setup.service
             9ms dev-mqueue.mount
             8ms systemd-update-utmp-runlevel.service
             7ms openvpn.service
             3ms sys-fs-fuse-connections.mount
           267us clean-mount-point@media-alain-VBox_GAs_6.1.12.service
 



alain@lmde:~$ systemd-analyze critical-chain


The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @5.826s
└─lightdm.service @5.768s +56ms
  └─vboxadd.service @1.925s +3.841s
    └─basic.target @1.905s
      └─sockets.target @1.905s
        └─cups.socket @1.905s
          └─sysinit.target @1.897s
            └─brltty.service @1.866s +30ms
              └─systemd-udev-settle.service @240ms +1.624s
                └─systemd-udev-trigger.service @190ms +48ms
                  └─systemd-journald.socket @188ms
                    └─-.mount @179ms
                      └─systemd-journald.socket @188ms
                        └─...
 



donc , c'est bon . comme tu vois , je n'ai plus le man-db . ce qui ne l'empêche pas de fonctionner  :

man systemd


SYSTEMD(1)                          systemd                         SYSTEMD(1)

NAME
       systemd, init - systemd system and service manager

SYNOPSIS
       /lib/systemd/systemd [OPTIONS...]

       init [OPTIONS...] {COMMAND}

DESCRIPTION
       systemd is a system and service manager for Linux operating systems.
       When run as first process on boot (as PID 1), it acts as init system
       that brings up and maintains userspace services.

       For compatibility with SysV, if systemd is called as init and a PID
       that is not 1, it will execute telinit and pass all command line
       arguments unmodified. That means init and telinit are mostly equivalent
       when invoked from normal login sessions. See telinit(8) for more
       information.

       When run as a system instance, systemd interprets the configuration
       file system.conf and the files in system.conf.d directories; when run
       as a user instance, systemd interprets the configuration file user.conf
       and the files in user.conf.d directories. See systemd-system.conf(5)
       for more information.

OPTIONS
       The following options are understood:

... / ...

 



amicalement , big_smile  big_smile  big_smile

alain .

coyotus.png

Dernière modification par Debian Alain (19-07-2020 08:50:14)

Hors ligne

#57 19-07-2020 09:02:00

JM38
Membre
Distrib. : LMDE4 debbie
Noyau : Linux 4.19.0-9 Cinnamon 4.4.8
Inscription : 03-06-2020

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

OK
si on le désactive le man
et qu'on ne fait pas le reboot
au redémarrage de la bécane , le man ne sera pas activé?
le reboot sert pour la session, comme après  une correction de paramètres navigateur, ou il fait relancer le navigateur pour que les modifications soient prises en compte
les temps sont exprimés en secondes et millisecondes dans le critical
ce qui signifie que le signe + est indiqué lorsque le temps est trop long sur une valeur relative et non absolue ?
As tu vu des différences de temps de démarrage en supprimant le man
ce manuel est utilisé quand ? (quand on rentre du code ? que l'on se trompe ou que l'on suffixe la commande par --help ?)
ce doit être une base sql
A suivre
merci encore
je quitte
bon dimanche
JM

Hors ligne

#58 19-07-2020 09:36:12

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.8.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

JM  a écrit :

au redémarrage de la bécane , le man ne sera pas activé?


ben ,je sais pas si tu as compris , JM , reboot , çà veut dire redémarrage .
donc , que tu redémarres maintenant à la main (en tapant la commande , donc) ou en laissant la session terminer , c'est pareil .
sauf que dans le premier cas , tu verra le résultat plus tôt , c'est tout .

JM  a écrit :

 le reboot sert pour la session, comme après  une correction de paramètres navigateur, ou il fait relancer le navigateur pour que les modifications soient prises en compte

ne confonds pas relancer un programme(le navigateur  par ex.) et relancer le systeme(cde reboot) .
des fois çà revient  au mme mais souvent ,  c'est utiliser la masse pour écraser le moucheron d'utiliser reboot (pour un navigateur seulement) .
sous linux , tu trouvera aussi l'option "déconnexion" pour quitter le bureau sans quitter le systeme . des fois çà suffit .(n'existe pas sous w$) .
ce faisant , tu te retrouvera dans ton gestionnaire d'affichage (display manager , ici lightdm) où tu peux choisir ton bureau et ton utilisateur .

JM  a écrit :

 ce qui signifie que le signe + est indiqué lorsque le temps est trop long sur une valeur relative et non absolue ?


à gauche : timing de l'éxécution du process de démarrage
à droite (du signe +) temps relatif  (donc rajouté au temps de démarrage) nécessaire au lancement du service .
avec le nom du service (essentiellement) ,
son emplacement dans la chaîne de démarrage et le temps  qu'il prend ,
on peut savoir si on peut y toucher ou s'i vaut mieux éviter .

JM  a écrit :

As tu vu des différences de temps de démarrage en supprimant le man


oui , j'ai gagné au moins 5 sec sur mon systeme .

JM  a écrit :

ce manuel est utilisé quand ? (quand on rentre du code ? que l'on se trompe ou que l'on suffixe la commande par --help ?)


le man est  souvent invoqué à la main . sur demande expresse de l'utilisateur ,donc .
oui , parfois avec --help , pas  toujours .

Dernière modification par Debian Alain (19-07-2020 09:48:00)

Hors ligne

#59 19-07-2020 19:46:09

JM38
Membre
Distrib. : LMDE4 debbie
Noyau : Linux 4.19.0-9 Cinnamon 4.4.8
Inscription : 03-06-2020

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

Bonsoir Alain
j'avais bien compris le reboot
la désactivation est effective au redémarrage de la bécane (ou fermeture ouverture session)
et je connais bien la différence entre la relance d'un programme comme le navigateur et le redémarrage de la bécane

à gauche : timing de l'éxécution du process de démarrage  (donc temps de latence?)
on peut savoir si on peut y toucher ou s'i vaut mieux éviter .
et comment ?

oui , j'ai gagné au moins 5 sec sur mon systeme .
5 secondes dans la vie d'un homme c'est peu !!!(rires)
merci encore
je ferai un test analyze
bonne soirée
JM

Hors ligne

#60 19-07-2020 20:17:04

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.8.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

j'aime pas  trop ta notion de "session" .
sous linux c'est différent.
déjà pour le redémarrage , on peut redémarrer une appli , la session (graphique par défaut(le bureau,donc)) ou le systeme tout entier .
ensuite les sessions : au départ elles sont de deux types : sessions graphiques (bureau xfce , gnome , mate , kde ...) 
ou session texte (tty , console , terminal ... ) ,
plus précisément , session root (administrateur) ou session user(simple  utilisateur)  .

JM38  a écrit :

on peut savoir si on peut y toucher ou s'i vaut mieux éviter .
et comment ?


tu peux demander sur le chan irc ou sur le forum (conseillé) ou même faire tes propres recherches
pour savoir si le service en question tu peux te permettre d'y toucher ou s'il est plus sage de le laisser tranquille .

regarde :

alain@lmde:~$ systemd-analyze critical-chain


The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @5.853s
└─lightdm.service @5.718s +134ms
  └─vboxadd.service @2.307s +3.407s
    └─basic.target @2.300s
      └─sockets.target @2.300s
        └─dbus.socket @2.300s
          └─sysinit.target @2.290s
            └─brltty.service @2.257s +33ms
              └─systemd-udev-settle.service @266ms +1.989s
                └─systemd-udev-trigger.service @197ms +65ms
                  └─systemd-udevd-kernel.socket @190ms
                    └─system.slice @184ms
                      └─-.slice @184ms

 




je prends la première ligne :
timing : un peu plus de 5 secondes , rien à signaler .

je prends la deuxième ligne :
timing : un peu plus de 5 secondes mais , il rallonge la  sauce de 134 msec .
en théorie , il prend de la place pour rien et je peux le supprimer sauf que :
https://wiki.archlinux.fr/LightDM

Arch linux  a écrit :

Configuration
Démarrage
Pour l'activer :

systemctl enable lightdm.service


Pour le démarrer sans rebooter :

systemctl start lightdm.service



https://wiki.debian.org/fr/LightDM

en clair : plus de lightdm , plus de bureau graphique .
donc on y touche  pas .

je prends la troisième ligne :

  └─vboxadd.service @2.307s +3.407s


timing : environ 2 sec  mais il perd beaucoup de temps pour s'executer en plus . puis-je le suprimer  ?
les liens parlent du service quand il est "failed",
qui plus est cela semble un élément très important de virtualbox , donc si ok , j'y touche pas :

alain@lmde:~$ systemctl status vboxadd.service


● vboxadd.service
   Loaded: loaded (/opt/VBoxGuestAdditions-6.1.12/init/vboxadd; enabled; vendor preset: enabled)
   Active: active (exited) since Mon 2020-07-20 09:12:26 CEST; 1min 9s ago
  Process: 512 ExecStart=/opt/VBoxGuestAdditions-6.1.12/init/vboxadd start (code=exited, status=0/SUCCESS)
 Main PID: 512 (code=exited, status=0/SUCCESS)

juil. 20 09:12:21 lmde vboxadd[512]: VirtualBox Guest Additions: Building the VirtualBox Guest Additions kernel
juil. 20 09:12:21 lmde vboxadd[512]: modules.  This may take a while.
juil. 20 09:12:21 lmde vboxadd[512]: VirtualBox Guest Additions: To build modules for other installed kernels, run
juil. 20 09:12:21 lmde vboxadd[512]: VirtualBox Guest Additions:   /sbin/rcvboxadd quicksetup <version>
juil. 20 09:12:21 lmde vboxadd[512]: VirtualBox Guest Additions: or
juil. 20 09:12:21 lmde vboxadd[512]: VirtualBox Guest Additions:   /sbin/rcvboxadd quicksetup all
juil. 20 09:12:26 lmde useradd[1055]: failed adding user 'vboxadd', data deleted
juil. 20 09:12:26 lmde vboxadd[512]: VirtualBox Guest Additions: Running kernel modules will not be replaced until
juil. 20 09:12:26 lmde vboxadd[512]: the system is restarted
juil. 20 09:12:26 lmde systemd[1]: Started vboxadd.service.
 



JM38  a écrit :

5 secondes dans la vie d'un homme c'est peu !!!(rires)


oui mais fait le calcul , sur un temps de démarrage d'environ 15 sec , çà fait le tiers de temps de gagné .

alain@lmde:~$ systemd-analyze time

Startup finished in 3.176s (kernel) + 6.198s (userspace) = 9.375s
graphical.target reached after 6.184s in userspace

Dernière modification par Debian Alain (20-07-2020 08:56:08)

Hors ligne

#61 20-07-2020 20:00:56

JM38
Membre
Distrib. : LMDE4 debbie
Noyau : Linux 4.19.0-9 Cinnamon 4.4.8
Inscription : 03-06-2020

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

Bonsoir
je viens de m'apercevoir que ce matin je n'ai pas envoyé mon message(je n'ai pas dû appuyer sur valider
je le ferai demain matin
j'ai execute la commande   systemd-analyze critical-chain
j'ai également  chronométré ma bécane ce matin
Après appui suron
Après 12 secondes   affichage de packard  Bell
Après 28 secondes Affichage d'un message avec choix d'arreter un lancement
Après 38 secondes et jusqu'à 64 secondes affichage écusson LMDE
Après 110 secondes affichage du choix du de panneau de présentation de LMDE(case à cocher)
Après 120 secondes Affichage du bureau

je pense qu'on doit pouvoir faire sauter l'affichage de lécusson et naturellement shunter la case à cocher pour affichage

peut-etre que le premier choix (si vous frappez je en sais quoi, le traitement se fera ou non,,je ne me souviens plus) peut également se shunter, quitte à le remettre en cas de soucis
A demain
désolé
JM

Hors ligne

#62 20-07-2020 20:06:06

JM38
Membre
Distrib. : LMDE4 debbie
Noyau : Linux 4.19.0-9 Cinnamon 4.4.8
Inscription : 03-06-2020

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

juil. 20 09:12:26 lmde useradd[1055]: failed adding user 'vboxadd', data deleted


ce service vboxadd est ok ou non?
faut il le rendre disable?
bonne soirée
JM

Hors ligne

#63 20-07-2020 20:26:56

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.8.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

ben non , y a fort à parier qu'il est déjà "disabled" (désactivé) .
peut être (j'espère pas) désinstallé .
je  crois que çà fait partie des services à pas toucher .

https://superuser.com/questions/298367/ … ice-failed
https://answers.launchpad.net/ubuntu/+question/688412

c'est en anglais . mais , en prenant le temps de bien lire et surtout de bien traduire , on comprend facilement .

Dernière modification par Debian Alain (20-07-2020 20:36:57)

Hors ligne

#64 20-07-2020 20:32:58

JM38
Membre
Distrib. : LMDE4 debbie
Noyau : Linux 4.19.0-9 Cinnamon 4.4.8
Inscription : 03-06-2020

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

s'il est disableb, comment peut-il marcher ? sinon en le réactivant (enable, start)?
bonne soirée
JM
Ps
vous êtes confinés en Bretagne? je ne sais encore si je pars une quinzaine vers Dinard!!

Hors ligne

#65 20-07-2020 20:46:12

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.8.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

vous êtes confinés en Bretagne? je ne sais encore si je pars une quinzaine vers Dinard!!


non , pas encore . par contre , port du masque obligatoire dans les lieux clos (boulangerie , supermarché , coiffeur ...)

JM38  a écrit :

s'il est disableb, comment peut-il marcher ? sinon en le réactivant (enable, start)?


non , en l'installant / reinstallant tout simplement .

https://doc.ubuntu-fr.org/virtualbox_ad … vit%C3%A9.
https://debian-facile.org/utilisateurs: … s-invite?s

tu verra , c'est simple .

Dernière modification par Debian Alain (21-07-2020 08:17:08)

Hors ligne

#66 21-07-2020 09:16:40

JM38
Membre
Distrib. : LMDE4 debbie
Noyau : Linux 4.19.0-9 Cinnamon 4.4.8
Inscription : 03-06-2020

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

Bonjour Alain
chose promise
Voici mes tests de ce mardi matin
appui sur on le mardi matin 21Juillet
après 10Secondes affichage Packard Bell avec message F2 pour setup
Après 28 secondes Affichage du mot Debbie sur la première ligne en haut de l’écran
        Message  ligne dus  bas plus que  quelques secondes .......
cet écran ne reste affiché qu'une ou 2 secondes ce qui explique le peu d'infos que je vous signifie sur celui-ci
De 38 secondes à 64 secondes affichage Ecusson LMDE (un doigt gris vert au milieu de l’écran)
    Puis de 65 à 65 secondes et demi !!! Affichage bref en haut de l’écran Module not found (pas le temps de lire)
A 119 secondes affichage page accueil Mint (qu’on peut décocher, je ne fais que la  fermer en cliquant e haut à droite  mais je vais la faire sauter en décochant)
Après 125 secondes affichage du bureau
donc ce matin c'est plus long qu'hier

utilisateur@linux-mint:~/JM/analyse$ systemd-analyze time

Startup finished in 10.232s (kernel) + 51.565s (userspace) = 1min 1.798s
graphical.target reached after 41.491s in userspace

utilisateur@linux-mint:~/JM/analyse$ systemd-analyze critical-chain

The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @41.491s
└─multi-user.target @41.491s
  └─exim4.service @36.658s +4.832s
    └─network-online.target @36.654s
      └─NetworkManager-wait-online.service @17.623s +19.029s
        └─NetworkManager.service @11.529s +5.971s
          └─dbus.service @11.521s
            └─basic.target @11.023s
              └─sockets.target @11.023s
                └─dbus.socket @11.023s
                  └─sysinit.target @10.960s
                    └─brltty.service @10.324s +636ms
                      └─systemd-udev-settle.service @4.047s +6.274s
                        └─systemd-udev-trigger.service @3.440s +581ms
                          └─systemd-udevd-control.socket @3.348s
                            └─-.mount @3.232s
                              └─systemd-journald.socket @3.257s
                                └─-.mount @3.232s
                                  └─...
utilisateur@linux-mint:~/JM/analyse$

mes résultats hier lundi matin
utilisateur@linux-mint:~/JM/analyse$ systemd-analyze critical-chain
The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @37.340s
└─multi-user.target @37.339s
  └─exim4.service @35.389s +1.949s
    └─network-online.target @35.382s
      └─NetworkManager-wait-online.service @16.788s +18.592s
        └─NetworkManager.service @10.666s +6.115s
          └─dbus.service @10.647s
            └─basic.target @10.612s
              └─sockets.target @10.612s
                └─cups.socket @10.612s
                  └─sysinit.target @10.549s
                    └─sys-fs-fuse-connections.mount @38.851s +20ms
                      └─systemd-modules-load.service @3.370s +621ms
                        └─systemd-journald.socket @3.238s
                          └─system.slice @3.165s
                            └─-.slice @3.165s

Bonne journée
JM

Hors ligne

#67 21-07-2020 10:53:25

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.8.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

si tu es sûr de ta connexion , tu peux essayer de désactiver :

└─NetworkManager-wait-online.service @16.788s +18.592s



donc :

sudo systemctl disable NetworkManager-wait-online.service


sudo reboot


systemd-analyze time

démarrage plus rapide ?



P.S.: Oh, quel beau BB …code où comment mettre en forme vos messages dans le fofo
tu en es capable , fais un effort !

chez moi , sur ma V.M. :

alain@lmde:~$ systemd-analyze time

Startup finished in 3.182s (kernel) + 6.797s (userspace) = 9.979s
graphical.target reached after 6.783s in userspace


alain@lmde:~$ systemd-analyze critical-chain

The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @6.783s
└─lightdm.service @6.724s +58ms
  └─vboxadd.service @1.951s +4.770s
    └─basic.target @1.913s
      └─sockets.target @1.913s
        └─cups.socket @1.913s
          └─sysinit.target @1.906s
            └─brltty.service @1.870s +35ms
              └─systemd-udev-settle.service @251ms +1.616s
                └─systemd-udev-trigger.service @194ms +54ms
                  └─systemd-udevd-kernel.socket @193ms
                    └─system.slice @176ms
                      └─-.slice @176ms

Dernière modification par Debian Alain (21-07-2020 11:08:05)

Hors ligne

#68 21-07-2020 12:51:50

JM38
Membre
Distrib. : LMDE4 debbie
Noyau : Linux 4.19.0-9 Cinnamon 4.4.8
Inscription : 03-06-2020

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

si tu es sûr de ta connexion , tu peux essayer de désactiver :
└─NetworkManager-wait-online.service @16.788s +18.592s


Sur internet j'ai testé je suis à 20 Méga en descendant

donc :
sudo systemctl disable NetworkManager-wait-online.service
sudo reboot


si je veux le réactiver
je ferais
systemctl NetworkManager-wait-online.service
Pour le démarrer sans rebooter :
systemctl start ligNetworkManager-wait-online.service
ou rebooter


ou je devrais  m'inspirer de votre réponse hier
s'il est disableb, comment peut-il marcher ? sinon en le réactivant (enable, start)?
non , en l'installant / reinstallant tout simplement .

Hors ligne

#69 21-07-2020 13:27:29

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.8.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

si je veux le réactiver
je ferais
systemctl NetworkManager-wait-online.service


non , comme suit , plutôt :

systemctl enable NetworkManager-wait-online.service

n'oublie pas le "enable" dans la commande .

la commande de désactivation que je t'ai donnée ,
désactive le service NetworkManager-wait-online .
ce service permet au pc d'attendre une connexion internet avant de continuer .
c'est une temporisation logicielle .

si tu es sûr de ton réseau , tu peux le désactiver . tu perdra moins de temps à la connexion .
donc , tu vas un peu l'accélérer .

je l'ai fais sur mon pc et sur ma V.M. lmde.
dans ton cas , tu gagnera environ 20 sec sur le temps de démarrage .

je te déconseille de toucher à beaucoup plus .
je suis pas assez calé .
et j'ai pas envie de casser ta machine .
demande aux anciens , ils te guideront mieux que moi .

P.S.: je remarque que tu commence à jouer avec les BBcodes . c'est bien , continue .
bientôt tu va les maîtriser  tout à fait et je ne pourrai plus te faire de réflexions .

non , en l'installant / reinstallant tout simplement .

fais attention , ne mélange pas tout . cette réflexion s'applique à vboxadd , post #62 .
service généré par les "additions invité " de virtualbox .

Dernière modification par Debian Alain (21-07-2020 13:38:42)

Hors ligne

#70 21-07-2020 13:50:25

JM38
Membre
Distrib. : LMDE4 debbie
Noyau : Linux 4.19.0-9 Cinnamon 4.4.8
Inscription : 03-06-2020

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

Dans mon coller j'avais oublié le enable (évidemment) sinon sans argument ça ne sert pas à grand chose

Hors ligne

#71 21-07-2020 13:56:40

JM38
Membre
Distrib. : LMDE4 debbie
Noyau : Linux 4.19.0-9 Cinnamon 4.4.8
Inscription : 03-06-2020

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

Je ne comprends pas bien comment marche le service  NetworkManager-wait-online
il permet de temporiser quoi? pour quel intérêt?
je vais le mettre disable
je verrai si les accès aux sites et si la navigation est altérée ?
je teste avec le site SFR, les vitesses de connexions entrantes et descendantes
je verrai également le temps de démarrage
Je pense qu'on doit pouvoir shunter l'affichage du logo LMDE
Quant aux codes, je suis habitué pour mon site géré en texte brut
entre les <div style="color"#3366ff">  et les strong  em et consorts
avec des tableaux , pas évident
dommage qu'ici on ne puisse jouer sur les couleurs et les fonds
merci encore
JM

Hors ligne

#72 21-07-2020 14:15:30

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.8.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

NetworkManager-wait-online


n'accélère pas ta connexion .
c'est une temporisation logicielle qui attend la présence du réseau avant de te connecter .
ce service permet d'attendre suffisamment longtemps avant de se connecter à internet .
pour être sûr d'avoir une connexion .

il joue sur la disponibilité du réseau , pas  sur ses performances .
si tu as une connexion à 20 MO/sec , elle n'ira pas plus vite .

c'est juste le temps de se connecter qui est raccourci .

Hors ligne

#73 21-07-2020 18:13:30

JM38
Membre
Distrib. : LMDE4 debbie
Noyau : Linux 4.19.0-9 Cinnamon 4.4.8
Inscription : 03-06-2020

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

Bonsoir
voici mes tests
21 juillet après midi

utilisateur@linux-mint:~/JM/analyse$ systemd-analyze time
Startup finished in 10.255s (kernel) + 34.549s (userspace) = 44.804s
graphical.target reached after 34.527s in userspace

utilisateur@linux-mint:~/JM/analyse$


The time after the unit is active or started is printed after the "@" characte
The time the unit takes to start is printed after the "+" character.

graphical.target @34.527s
└─multi-user.target @34.527s
  └─exim4.service @32.095s +2.430s
    └─network-online.target @32.092s
      └─NetworkManager-wait-online.service @18.003s +14.088s
        └─NetworkManager.service @10.751s +7.249s
          └─dbus.service @10.737s
            └─basic.target @10.691s
              └─sockets.target @10.691s
                └─cups.socket @10.691s
                  └─sysinit.target @10.626s
                    └─sys-fs-fuse-connections.mount @29.860s +8ms
                      └─systemd-modules-load.service @3.495s +640ms
                        └─systemd-journald.socket @3.200s
                          └─system.slice @3.154s
                            └─-.slice @3.154s

apres arret service
sudo systemctl disable NetworkManager-wait-online.service




utilisateur@linux-mint:~$ cd ~/JM/analyse
utilisateur@linux-mint:~/JM/analyse$ systemd-analyze time
Startup finished in 10.286s (kernel) + 24.643s (userspace) = 34.930s
graphical.target reached after 24.620s in userspace

utilisateur@linux-mint:~/JM/analyse$ systemd-analyze critical-chain
The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @24.620s
└─multi-user.target @24.620s
  └─exim4.service @17.975s +6.644s
    └─network-online.target @17.970s
      └─network.target @17.970s
        └─NetworkManager.service @10.973s +6.996s
          └─dbus.service @10.872s
            └─basic.target @10.868s
              └─sockets.target @10.868s
                └─avahi-daemon.socket @10.868s
                  └─sysinit.target @10.804s
                    └─brltty.service @10.214s +589ms
                      └─systemd-udev-settle.service @4.081s +6.130s
                        └─systemd-udev-trigger.service @3.310s +750ms
                          └─systemd-udevd-control.socket @3.308s
                            └─system.slice @3.065s
                              └─-.slice @3.065s

mes tests connexion
sitehttps://www.sfr.fr/mire-test-debit/
avant
Reception  Crete 19,70 MB/s Moyenne 18,74 MB/S
Envoi 0,742 crete 0,711 Moyenne

après arrêt service      NetworkManager-wait-online
Reception  Crete 19,30 MB/s Moyenne 18,57 MB/S
Envoi 0,873 crête 0,735 Moyenne
On a gagné du temps
au niveau connexion c'est pareil
Bonne soirée
JM

Hors ligne

#74 22-07-2020 08:24:53

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.8.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

tu commences à te débrouiller un peu avec les bbcodes .

encadre tes copier / coller avec les balises <autre code> s.t.p.

Oh, quel beau BB …code où comment mettre en forme vos messages dans le fofo

Voir le tuto : Le code, ça pique moins les yeux en couleur

pense à utiliser les balises <commande utilisateur> et / ou <commande root>  pour tes commandes ...

lis bien le lien que je t'ai donné , çà fait au moins 4 - 5 fois que je t'en parle . c'est énervant de voir que tu n'en tiens pas compte .

sinon , bon , le travail est bien fait . tu vois ce n'était pas si difficile .

tu as gagné du temps de démarrage , pas plus ni moins de perfs sur ta connexion .

normal . c'est ce qui était prévu .

bonne chance pour la suite ...

je te laisse  avec le forum et les anciens .

p.s.: Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre.

kenavo   big_smile  big_smile  big_smile

alain

yes.gif

coyotus.png

Dernière modification par Debian Alain (22-07-2020 08:38:15)

Hors ligne

#75 22-07-2020 10:21:45

JM38
Membre
Distrib. : LMDE4 debbie
Noyau : Linux 4.19.0-9 Cinnamon 4.4.8
Inscription : 03-06-2020

Re : Démarrage un peu lent (2 minutes) (Résolu , Merci à vous tous JM)

Bonjour Alain
J'ai fait des essais avec prévisualisation en utilisant code (html5) et autre code
sans succès
je ne comprends pas bien comment marche la colorisation,si on peut ou non la faire (autorisation)
on parle de "Utiliser la coloration syntaxique dans le forum"

mais il n'y a pas d'exemple de colorisation (le tuto boucle sur l'utilisation de code , autre code, sans afficher le résultat, ou trop vite)
faut il utiliser les balises color en html?
Comment afficher par exemple

bonjour en vert 
puis au revoir en rouge
puis revenir à la couleur standard

Merci encore
je vais clore la discussion comme j'ai clos celle concernant chromium en français
JM

Hors ligne

Pied de page des forums