Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 16-08-2020 11:26:10

zephdev
Membre
Distrib. : debian 11 Bullseye
Noyau : Linux 5.7.0-2-amd64
(G)UI : Xfce
Inscription : 15-08-2020

[Résolu] Besoin d'aide pour installé mon environnement de dev.

Bonjour,

J'ai fraichement installer debian hier, maintenant j'aimerai installé mon environnement de dev. j'ai mis apache2 et php7.4, ect.
Par contre pour mysql, il me dit : Aucune version du paquet mysql-server n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « mysql-server » n'a pas de version susceptible d'être installée

Dernière modification par zephdev (16-08-2020 19:41:09)

Hors ligne

#2 16-08-2020 11:34:44

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Besoin d'aide pour installé mon environnement de dev.

Bonjour
mysql n'existe plus sur debian => https://packages.debian.org/fr/sid/mysql-server
depuis stretch
mais il a été remplacé par mariadb qui a priori n'existe pas sur  Bullseye
je suis en train de chercher

=> https://packages.debian.org/fr/bullseye/mariadb-server
ps: c'est l' equivalent de mysql pour debian


apt-cache policy mariadb-server
 



mariadb-server:
  Installé : (aucun)
  Candidat : 1:10.3.23-1
 Table de version :
     1:10.3.23-1 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
        500 https://deb.debian.org/debian bullseye/main i386 Packages
 

Dernière modification par robert2a (16-08-2020 11:38:34)

Hors ligne

#3 16-08-2020 11:37:36

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [Résolu] Besoin d'aide pour installé mon environnement de dev.

bonjour à tous   smile   smile   smile

au pif , comme çà :

c'est pas mariadb qui remplace mysql  maintenant  ?

au moins depuis jessie ?

Hors ligne

#4 16-08-2020 11:43:15

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Besoin d'aide pour installé mon environnement de dev.

@zephdev

installe synaptic , c'est un gestionnaire de paquet graphique
tu pourra voir ce qu'il y a de disponible comme paquet "mariadb"
idem pour "phpmyadmin" il a été remplacé
en général c'est un souci de nom mais le logiciel reste a l' identique .


apt-get --reinstall install synaptic
 



ton bureau c'est quoi au fait ?

pour phpmyadmin le nouveau doit être "adminer"


Adminer (formerly phpMinAdmin) is a full-featured database management tool
written in PHP. Conversely to phpMyAdmin, it is a light weight application
with these priorities in order: security, user experience, performance,
feature set and size.
 



dans la langue des gaulois  smile


Adminer (anciennement phpMinAdmin) est un outil de gestion de base de données complet
écrit en PHP. À l'inverse de phpMyAdmin, c'est une application légère
avec ces priorités dans l'ordre: sécurité, expérience utilisateur, performances,
ensemble de fonctionnalités et taille.
 



pour la doc je pense que tu va trouver sur debian et sur le net

Dernière modification par robert2a (16-08-2020 12:05:45)

Hors ligne

#5 16-08-2020 12:45:01

Cauryl
Membre
Distrib. : Debian Buster
(G)UI : Xfce
Inscription : 12-02-2020

Re : [Résolu] Besoin d'aide pour installé mon environnement de dev.

Hors ligne

#6 16-08-2020 19:39:35

zephdev
Membre
Distrib. : debian 11 Bullseye
Noyau : Linux 5.7.0-2-amd64
(G)UI : Xfce
Inscription : 15-08-2020

Re : [Résolu] Besoin d'aide pour installé mon environnement de dev.

robert2a a écrit :

@zephdev

installe synaptic , c'est un gestionnaire de paquet graphique
tu pourra voir ce qu'il y a de disponible comme paquet "mariadb"
idem pour "phpmyadmin" il a été remplacé
en général c'est un souci de nom mais le logiciel reste a l' identique .


apt-get --reinstall install synaptic
 



ton bureau c'est quoi au fait ?

pour phpmyadmin le nouveau doit être "adminer"


Adminer (formerly phpMinAdmin) is a full-featured database management tool
written in PHP. Conversely to phpMyAdmin, it is a light weight application
with these priorities in order: security, user experience, performance,
feature set and size.
 



dans la langue des gaulois  smile


Adminer (anciennement phpMinAdmin) est un outil de gestion de base de données complet
écrit en PHP. À l'inverse de phpMyAdmin, c'est une application légère
avec ces priorités dans l'ordre: sécurité, expérience utilisateur, performances,
ensemble de fonctionnalités et taille.
 



pour la doc je pense que tu va trouver sur debian et sur le net



Du coup, j'ai mis mariadb et adminer.

Pour l'instant c'est XFCE, mais je pense changer donc je vais surment demandé encore de l'aide big_smile

Hors ligne

#7 17-08-2020 00:20:56

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Besoin d'aide pour installé mon environnement de dev.

j'ai répondu pour ton bis écran , j' attend les retours  smile

Hors ligne

Pied de page des forums