Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-09-2020 09:26:56

phlinux
Membre
Distrib. : Jessie
Noyau : 4.9
(G)UI : Openbox (+Rox+Feh)
Inscription : 09-05-2009

Réglage de 2 écrans dans leur mode maximum respectif. [Résolu]

Bjr,

Voici le problème pour configurer 2 écrans de tailles différentes connectés à la même CG comportant 2 sorties (VGA , DVI)
Tout d'abord quelques billes. La carte graphique

lspci -vk | grep -A9 VGA


01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV280 [Radeon 9200 PRO] (rev 01) (prog-if 00 [VGA controller])
  Subsystem: ASUSTeK Computer Inc. Device 004c
  Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 16
  Memory at f0000000 (32-bit, prefetchable) [size=128M]
  I/O ports at de00 [size=256]
  Memory at fe9e0000 (32-bit, non-prefetchable) [size=64K]
  Expansion ROM at 000c0000 [disabled] [size=128K]
  Capabilities: [58] AGP version 3.0
  Capabilities: [50] Power Management version 2
  Kernel driver in use: radeon

Les modes des écrans :

xrandr


Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 4096 x 4096
VGA-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 338mm x 270mm
   1280x1024     60.02 +  75.02*
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   640x480       75.00    72.81    66.67    59.94  
   720x400       70.08  
DVI-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 531mm x 299mm
   1920x1080     60.00*+
   1680x1050     59.88  
   1600x900      60.00  
   1280x1024     60.02  
   1440x900      59.90  
   1280x800      59.91  
   1280x720      60.00  
   1024x768      60.00  
   800x600       60.32  
   640x480       59.94  
   720x400       70.08  
S-video disconnected (normal left inverted right x axis y axis)

Le résultat de xrandr semble montrer que tout va bien, mais c'est trompeur.

Premièrement, pour arriver à ces mesures maxi il faut forcer soit par xrandr avec ce genre de commande ;

xrandr --output DVI-0 --mode 1920x1080 -r 60 --output VGA-0 --mode 1280x1024 -r 75

soit en ajoutant dans le xorg.conf  quelques lignes du genre :

Section "Device"
-----
  Option    "MetaModes" "1920x1080-1280x1024"
-----
EndSection
Section "Screen"
  Identifier  "Screen0"
----
  SubSection "Display"
    Modes "1920x1080"
    Depth 24
  EndSubSection
----
EndSection

Section "Screen"
  Identifier  "Screen1"
----
  SubSection "Display"
    Modes "1280x1024"
    Depth 24
  EndSubSection
----
EndSection


Donc tout va bien....sauf que sur chaque écran les 2 modes sont affichés. Autrement dit les "2 bureaux" se superposent sur chaque écran : le 1920x1080 dessus l'autre dessous.
Le résultat attendu pour cette config n'est pas le mode étendu (qui fonctionne bien d'ailleurs mais en gardant les 2 superpositions de modes). Le but est bien d'avoir 2 écrans indépendants mais avec leur mode maxi respectif. Dans cette optique l'option xinérama, disabled par défaut, a été sur-disabled dans xorg.conf

En outre si aucune des modif, xandr ou xorg.conf, n'est apportée les 2 écrans affichent bien un seul mode mais c'est celui le plus bas soit 1280x1024.

Si quelqu'un à des connaissances pratiques sur le sujet....merci d'avance pour le partage

Dernière modification par phlinux (13-09-2020 11:38:37)


Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#2 05-09-2020 12:37:08

SuShY
CA Debian-Facile
Lieu : Chartres
Distrib. : Debian Sid x86_64
Noyau : Linux > 5.9.x-x-amd64
(G)UI : i3WM - 4.18-1
Inscription : 06-01-2018
Site Web

Re : Réglage de 2 écrans dans leur mode maximum respectif. [Résolu]

Hello, j'ai deux écrans aussi chez moi avec deux tailles différentes.
Voici mon fichier /etc/X11/Xsession.d/45x11-xrandr

#!/bin/sh
xrandr --output DP-1 --mode 3840x2160 --primary
xrandr --output HDMI-1 --mode 1920x1080 --right-of DP-1



Je me suis inspiré de ce tuto https://debian-facile.org/doc:environnements:x11:xrandr et de celui-ci https://doc.ubuntu-fr.org/xrandr.

En espérant que cela puisse t'aider.

Hors ligne

#3 05-09-2020 14:07:56

phlinux
Membre
Distrib. : Jessie
Noyau : 4.9
(G)UI : Openbox (+Rox+Feh)
Inscription : 09-05-2009

Re : Réglage de 2 écrans dans leur mode maximum respectif. [Résolu]

Bjr,
Merci pour ta réponse. On voit d'emblée avec "--right-of" (qui est aussi un paramètre de xorg.conf) que c'est une commande pour un bureau étendu, ce qui donne l'illusion de 2 écrans indépendants, comme deux images cote à cote avec des modes différents.

A force de faire des essais je penserais plutôt que le problème vient d'un "display" manquant, comme s'il fallait relier chaque sortie de la CG à un écran donné.

A suivre....

Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#4 05-09-2020 15:16:21

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Réglage de 2 écrans dans leur mode maximum respectif. [Résolu]

Bonjour
je comprend pas la question sad
normalement si ton gpu fonctionne correctement (le driver) , le mode natif de l'écran est appliqué (donné par l'écran)
sans xorg.conf tu est en bureau étendu , que tu peu modifier par la configuration sur ton bureau (en clone )
du bureau tu peu modifier aussi la définition de tes écrans (en général c'est la native de chaque écran qui est appliqué )
tu peu aussi modifier l'ordre des écrans , 0 ou 1 dans ton cas (si tu a deux écrans). celui de droite ou gauche
je vois pas ou est ton souci  hmm

Hors ligne

#5 05-09-2020 16:56:22

phlinux
Membre
Distrib. : Jessie
Noyau : 4.9
(G)UI : Openbox (+Rox+Feh)
Inscription : 09-05-2009

Re : Réglage de 2 écrans dans leur mode maximum respectif. [Résolu]

Dans le post#1 j'ai mis ce que renvoie "xrandr" avec des corrections dans xorg.conf.
Mais si je ne modifie rien voilà ce qui sort:

xrandr

Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 4096 x 4096
VGA-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 338mm x 270mm
   1280x1024     60.02*+  75.02  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   640x480       75.00    72.81    66.67    59.94  
   720x400       70.08  
DVI-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 531mm x 299mm
   1920x1080     60.00 +
   1680x1050     59.88  
   1600x900      60.00  
   1280x1024     60.02*
   1440x900      59.90  
   1280x800      59.91  
   1280x720      60.00  
   1024x768      60.00  
   800x600       60.32  
   640x480       59.94  
   720x400       70.08  
S-video disconnected (normal left inverted right x axis y axis)

Tu voies bien qu'en natif le mode utilisé est celui de l'écran le moins performant.
Donc, comme indiqué au post#1, les modifications sont bonnes pour les modes, mais sur chaque écran s'affichent les 2 bureaux. Si on prend l'exemple du fond d'écran, il y a celui en 1280x1024 et au dessus le 1920x1080; si tu connais "arandr" cela ressemble aux 2 écrans l'un sur l'autre. C'est bien pour de l'étendu mais ce n'est pas le but.


Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#6 05-09-2020 18:32:11

phlinux
Membre
Distrib. : Jessie
Noyau : 4.9
(G)UI : Openbox (+Rox+Feh)
Inscription : 09-05-2009

Re : Réglage de 2 écrans dans leur mode maximum respectif. [Résolu]

Bon je pense être sur une bonne piste. Il faut effectivement mettre un "Right of" dans xorg.conf mais en ajoutant quelques petites fioritures.
Je peaufine et je ferai un rapport....si ça intéresse bien sûr

Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#7 05-09-2020 18:54:10

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Réglage de 2 écrans dans leur mode maximum respectif. [Résolu]

bonsoir phlinux smile  smile  smile

je vais poser une question stupide :

Arandr n'est pas  compatible openbox ?
çà te simplifierai pas le travail ?

comme le montre ton rapport Xrandr , non seulement tes écrans ont la mme résolution mais en plus , ils sont superposés "dans le pilote"
(si tu vois ce  que je veux dire) :

DVI-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 531mm x 299mm

VGA-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 338mm x 270mm



normalement , s'ils étaient bien gérés , tu devrai avoir qquechose du genre :

DVI-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 531mm x 299mm

VGA-0 connected 1280x1024+1280+0 (normal left inverted right x axis y axis) 338mm x 270mm



à titre d'exemple , voilà le xrandr de mes 2 écrans

Screen 0: minimum 320 x 200, current 5120 x 1440, maximum 16384 x 16384
DisplayPort-0 connected primary 2560x1440+0+0 (normal left inverted right x axis y axis) 697mm x 392mm
   3840x2160     60.00 +  30.00    29.97  
   2560x1440     59.95*
  ... / ...  
HDMI-A-0 connected 2560x1440+2560+0 (normal left inverted right x axis y axis) 697mm x 392mm
   3840x2160     60.00 +  59.94    30.00    25.00    24.00    29.97    23.98  
   2560x1440     59.95*
   1920x1200     60.00  
  ... / ...  
   720x400       70.08  
DVI-D-0 disconnected (normal left inverted right x axis y axis)

Dernière modification par Debian Alain (05-09-2020 19:04:45)

En ligne

#8 05-09-2020 20:20:38

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Réglage de 2 écrans dans leur mode maximum respectif. [Résolu]

re,
voila ma machine avec un APU amd qui fonctionne bien
le retour de xrandr


xrandr
Screen 0: minimum 320 x 200, current 2944 x 1080, maximum 16384 x 16384
HDMI-A-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 531mm x 299mm
   1920x1080     60.00*+
   1600x1200     60.00  
   1680x1050     59.88  
   1280x1024     60.02  
   1440x900      59.90  
   1280x960      60.00  
   1280x800      60.00  
   1280x720      60.00  
   1024x768      60.00  
   800x600       60.32    56.25  
   640x480       66.67    59.94  
DisplayPort-0 connected 1024x768+1920+0 (normal left inverted right x axis y axis) 160mm x 90mm
   1024x768      60.00*+  75.03    70.07    60.00  
   1920x1080     60.00  
   1400x1050     59.98  
   1600x900      60.00  
   1280x1024     75.02    60.02  
   1440x900      59.89  
   1280x960      60.00  
   1366x768      59.79  
   1280x800      59.81  
   1152x864      75.00  
   1280x768      59.87  
   1280x720      60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32  
   640x480       75.00    72.81    66.67    59.94  
   720x400       70.08  
 


un de 24 pouces et l'autre 19 pouces en 16/9
pour l'instant je suis en "étendu" sans xorg.conf
donc si je comprend bien tu veut être en "clone" , c'est bien ça ?
avec chaque écran avec sa définition native ?

Dernière modification par robert2a (05-09-2020 20:45:49)

Hors ligne

#9 05-09-2020 20:45:10

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Réglage de 2 écrans dans leur mode maximum respectif. [Résolu]

en étendu (qui fonctionne ) ou en clone (le 19 est en fréquence hors limite , pas d'affichage )
de plus en étendu je suis en 1920x1080 et 1024x768 qui n'est pas correct (DVI et VGA)
on dirait que le gpu limite la définition totale sur les 2 écrans (1920 + 1024)
je commence a comprendre ton souci  tongue
j'ai tout fait a partir du bureau , bascule de l'ordre des écrans , modification fréquence et définition etc ......
tu dois retrouver les modifications sur le Xorg.0.log
pour moi (ma machine ) il y a un souci sur les ressources du gpu
ps: les écrans sont un 24 et 19 pouces , je modifie au dessus

ps: le 19 pouces doit être en 1440x900 60hertz normalement (pas possible en étendu , et hors limite en clone )
le fichier xorg.conf existe mais créé par le système si pas de xorg.conf dans /etc/X11/ ou /etc/X11/xorg.conf.d/
la définition du 24 pouces il me semble correcte

Dernière modification par robert2a (05-09-2020 20:59:29)

Hors ligne

#10 06-09-2020 08:32:41

phlinux
Membre
Distrib. : Jessie
Noyau : 4.9
(G)UI : Openbox (+Rox+Feh)
Inscription : 09-05-2009

Re : Réglage de 2 écrans dans leur mode maximum respectif. [Résolu]

Bon matin,  Debian Alain

Debian Alain a écrit :

je vais poser une question stupide :

On sait depuis longtemps que c'est très rare...

Debian Alain a écrit :

Arandr n'est pas  compatible openbox ?

J'aime bien la vision extérieure qu'on a d'OB; ce n'est pas juste une console...

Debian Alain a écrit :

comme le montre ton rapport Xrandr , non seulement tes écrans ont la mme résolution mais en plus , ils sont superposés "dans le pilote"
(si tu vois ce  que je veux dire) :

DVI-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 531mm x 299mm

VGA-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 338mm x 270mm

Ah, oui je n'avais pas lu ces indications. Mais comme indiqué à la fin du post#1

phlinux a écrit :

En outre si aucune des modif, xandr ou xorg.conf, n'est apportée les 2 écrans affichent bien un seul mode mais c'est celui le plus bas soit 1280x1024.

Donc ça prouve que c'est possible mais que le driver ou xorg (ou un lutin autoritaire dans la machine) ne veulent pas faire correctement le boulot. En fait tu as raison ils sont superposés mais chacun dans leur écran, donc à leur place, nativement. Ce qui ressort de tout ça c'est que dès le passage du paramètre de mode 1920x1080, où que ce soit, c'est le Bronx...

Debian Alain a écrit :

normalement , s'ils étaient bien gérés , tu devrai avoir qquechose du genre :

DVI-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 531mm x 299mm

VGA-0 connected 1280x1024+1280+0 (normal left inverted right x axis y axis) 338mm x 270mm

Donc tu vois si j'accepte ce même mode sur les deux monitors c'est inutile d'ajouter un paramètre de position (genre RightOf, etc...) ou d'utiliser "arandr"

En tous cas merci de participer car je sais que c'est pénible de lire des post à rallonge


Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#11 06-09-2020 09:00:21

phlinux
Membre
Distrib. : Jessie
Noyau : 4.9
(G)UI : Openbox (+Rox+Feh)
Inscription : 09-05-2009

Re : Réglage de 2 écrans dans leur mode maximum respectif. [Résolu]

Bon matin, robert2a

robert2a a écrit :

en étendu (qui fonctionne ) ou en clone (le 19 est en fréquence hors limite , pas d'affichage )

Pour ton 19 tu dois peut être lui re-calculer un modeline légèrement inférieur ou mettre celui que propose le Xorg.0.log. Si j'ai bien compris ce problème j'ai eu aussi le même souci, genre "Out of range"

robert2a a écrit :

on dirait que le gpu limite la définition totale sur les 2 écrans (1920 + 1024)

As-tu essayé d'ajouter une option "Virtual" dans une de tes sections Screen ? Tu as de la place vu ton xrandr : maximum 16384 x 16384

robert2a a écrit :

j'ai tout fait a partir du bureau , bascule de l'ordre des écrans....

Là ça m'interesse si tu peux me dire quel fichier est modifié quand tu inverse l'ordre des écrans. Sur ma ati a9250 c'est le vga qui est prioritaire sur le dvi (ce qui est débile, non ?) et je n'ai pas réussi à inverser, que ce soit dans le xorg.conf, ou avec xrandr (--primary ne semble pas servir à ça)

robert2a a écrit :

pour moi (ma machine ) il y a un souci sur les ressources du gpu

ou du pilote ?

robert2a a écrit :

ps: le 19 pouces doit être en 1440x900 60hertz normalement (pas possible en étendu , et hors limite en clone )

Tu dois pouvoir le forcer avec xrandr, et peut être même dans le xorg.conf


Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#12 06-09-2020 09:27:25

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Réglage de 2 écrans dans leur mode maximum respectif. [Résolu]

phlinux  a écrit :

Donc tout va bien....sauf que sur chaque écran les 2 modes sont affichés. Autrement dit les "2 bureaux" se superposent sur chaque écran : le 1920x1080 dessus l'autre dessous.

qu'est ce qui te fait dire çà ?

de mémoire , je crois qu'il y a une  astuce dans xrandr :
le signe "+"  indique une compatibilité possible (mode préféré),
et le signe " * " indique un mode actif .

https://wiki.archlinux.org/index.php/Xr … figuration

When run without any option, xrandr shows the names of different outputs available on the system (VGA-1, HDMI-1, etc.)
and resolutions available on each, with a * after the current one and a + after the preferred one :



phlinux  a écrit :

Le résultat de xrandr semble montrer que tout va bien, mais c'est trompeur.

apparemment oui , parceque là , comprends rien . tu es sûr que tu t'es pas trompé de mode d'affichage ? .
tu vas me trouver bête mais je pense  sincèrement qu'en réglant les 2 écrans côte à côte avec arandr , çà devrai pouvoir t'arranger .
je me trompe ? y a qque chose  que je comprends pas  ?

si tu veux cloner un écran sur l'autre , je pense  qu'il est normal que la résolution soit réglée  sur la plus haute commune aux deux
( donc ici 1280 X 1024 )

si tu veux  utiliser le bureau étendu (que j'affectionne) , les deux écrans contigüs , chacun à leur résolution , ce me semble normal .

après , j'avoue que je comprends pas , là ...

coyotus.png

P.S.: tu as quoi comme matériel ?

apt install inxi


inxi -Fr



-- celà -- peut il t'aider ?

Dernière modification par Debian Alain (06-09-2020 10:50:30)

En ligne

#13 06-09-2020 14:56:57

phlinux
Membre
Distrib. : Jessie
Noyau : 4.9
(G)UI : Openbox (+Rox+Feh)
Inscription : 09-05-2009

Re : Réglage de 2 écrans dans leur mode maximum respectif. [Résolu]

Pour le mode étendu ça fonctionne correctement ; j'ai eu un problème d' "Out of Range" mais j'ai modifié le modeline du 1920x1080
J'aurais préféré qu'en natif (clone ?) les résolutions soient respectées, mais bon finalement je vais partir sur le mode étendu car j'ai pu résoudre le problème de priorité et donc le grand ecran est bien le "maître".
Tous les paramètres sont dans le xorg.conf, rien avec xrandr, sauf pour vérifier:

xrandr


Screen 0: minimum 320 x 200, current 3200 x 1080, maximum 4096 x 4096
DVI-0 connected 1920x1080+1280+0 (normal left inverted right x axis y axis) 531mm x 299mm
   1920x1080_60.0  60.00*+
   1920x1080     60.00 +
   1680x1050     59.88  
   1600x900      60.00  
   1280x1024     60.02  
   1440x900      59.90  
   1280x800      59.91  
   1280x720      60.00  
   1024x768      60.00  
   800x600       60.32  
   640x480       59.94  
   720x400       70.08  
VGA-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 338mm x 270mm
   1280x1024_75.02  75.02*+
   1280x1024     60.02 +  75.02  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   640x480       75.00    72.81    66.67    59.94  
   720x400       70.08  
S-video disconnected (normal left inverted right x axis y axis)

Extraits du xorg.conf :

Section "Device"
  Identifier  "9250-DVI"
  Driver    "radeon"
  BusID   "PCI:01:00:0"
  Option    "Monitor-DVI-0" "HP"
  Option    "Monitor-VGA-0" "SyncMaster"
EndSection

Section "Monitor"
  Identifier  "HP"
  Option    "Primary" "true" 
  Modeline "1920x1080_60.0"  148.50  1920 2008 2052 2200  1080 1084 1089 1125  -HSync +Vsync
  Option          "PreferredMode" "1920x1080_60.0"
EndSection

Section "Monitor"
  Identifier      "SyncMaster"
  Option    "LeftOf" "HP"
  Modeline  "1280x1024_75.02"  138.58  1280 1368 1504 1728  1024 1025 1028 1069  -HSync +Vsync
  Option    "PreferredMode" "1280x1024_75.02"
EndSection

Section "Screen"
  Identifier  "Screen-DVI"
  Device    "9250-DVI"
  Monitor   "HP"
  DefaultDepth  24
  SubSection "Display"
    Modes "1920x1080"
    Depth 24
  EndSubSection
EndSection

Donc voilà la première partie du projet est réglée; je vais peut être ouvrir un autre fil pour la seconde...

Merci, non, MERCI à vous d'avoir éclairé la route du phlinux dans les sombritudes du X


Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#14 06-09-2020 16:25:25

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Réglage de 2 écrans dans leur mode maximum respectif. [Résolu]

pour  terminer ton fil , je dirai ceci :

je ne pense pas que ce soit le grand écran le maître .
par  contre , pour avoir déjà eu le cas (entre du DVI et du HDMI) ,
je parierai gros que le DVI est prioritaire sur le VGA .
donc , si c'est la connectique du grand écran : oui , apparemment , c'est lui le maître .

curiosité : quelle norme DVI ?
https://fr.wikipedia.org/wiki/Digital_visual_interface
(t'es pas obligé de répondre)  big_smile

coyotus.png

Dernière modification par Debian Alain (06-09-2020 16:39:21)

En ligne

#15 06-09-2020 19:03:37

phlinux
Membre
Distrib. : Jessie
Noyau : 4.9
(G)UI : Openbox (+Rox+Feh)
Inscription : 09-05-2009

Re : Réglage de 2 écrans dans leur mode maximum respectif. [Résolu]

C'est pas pasque c'est résolu qu'on peut pas causer
Apparemment c'est du DVI-D.
Le grand écran en "maitre"?: je l'ai mis en primary dans xorg et on voit qu'il est premier dans la sortie xrandr, les applis se lancent bien dessus, même quand je suis sur l'autre écran (ça dépend des applis), donc y'a de fortes chances

Par contre j'ai commencé à bosser sur la prochaine étape et là c'est le petit écran qui prend la main; je sens que ça va encore être une partie de plaisir

Tu peux répondre si tu veux....

Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#16 06-09-2020 19:06:01

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Réglage de 2 écrans dans leur mode maximum respectif. [Résolu]

qu'est ce que tu appelles "la prochaine étape" ?

En ligne

#17 06-09-2020 19:57:22

SuShY
CA Debian-Facile
Lieu : Chartres
Distrib. : Debian Sid x86_64
Noyau : Linux > 5.9.x-x-amd64
(G)UI : i3WM - 4.18-1
Inscription : 06-01-2018
Site Web

Re : Réglage de 2 écrans dans leur mode maximum respectif. [Résolu]

Dans mon cas de figure, mes deux écrans sont reliés à la même carte graphique, 1 en HDMI et 1 en display port.
C'est le HDMI qui être maître dans mon cas de figure, bien que ce soit mon écran seconde.
Mais c'est bien sur le maître HDMI que s'affiche le BIOS et GRUB.
A++

Hors ligne

#18 06-09-2020 20:15:43

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Réglage de 2 écrans dans leur mode maximum respectif. [Résolu]

comme toi sushy , j'en ai un en D.P. , l'autre en HDMI .
mais je sais pas lequel est prioritaire .  tongue

lol

coyotus.png

En ligne

#19 06-09-2020 20:16:34

SuShY
CA Debian-Facile
Lieu : Chartres
Distrib. : Debian Sid x86_64
Noyau : Linux > 5.9.x-x-amd64
(G)UI : i3WM - 4.18-1
Inscription : 06-01-2018
Site Web

Re : Réglage de 2 écrans dans leur mode maximum respectif. [Résolu]

@Debian Alain, où s'affiche grub et/ou le bios ?

Hors ligne

#20 06-09-2020 20:19:07

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Réglage de 2 écrans dans leur mode maximum respectif. [Résolu]

dans celui de gauche , le D.P. .

En ligne

#21 06-09-2020 20:20:02

SuShY
CA Debian-Facile
Lieu : Chartres
Distrib. : Debian Sid x86_64
Noyau : Linux > 5.9.x-x-amd64
(G)UI : i3WM - 4.18-1
Inscription : 06-01-2018
Site Web

Re : Réglage de 2 écrans dans leur mode maximum respectif. [Résolu]

A l'inverse de moi alors.

Hors ligne

#22 07-09-2020 13:56:19

phlinux
Membre
Distrib. : Jessie
Noyau : 4.9
(G)UI : Openbox (+Rox+Feh)
Inscription : 09-05-2009

Re : Réglage de 2 écrans dans leur mode maximum respectif. [Résolu]

Yop,
Tant qu'on est en mode étendu c'est assez facile de choisir l'écran primaire. Mais il semble que les cartes aient un port favori ; peut être la + basse résolution / mode ?
@Debian Alain : la prochaine étape est d'ouvrir un vt, ou directement une session/serveur, sur un des 2 écrans; si possible le + petit.

Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#23 07-09-2020 14:22:56

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Réglage de 2 écrans dans leur mode maximum respectif. [Résolu]

tu as quoi comme carte sushy ?

chez moi :

lspci -nnkd::0300


0b:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] [1002:67df] (rev ef)
  Subsystem: Sapphire Technology Limited Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] [1da2:e343]
  Kernel driver in use: amdgpu
  Kernel modules: amdgpu
 

En ligne

#24 07-09-2020 14:54:17

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Réglage de 2 écrans dans leur mode maximum respectif. [Résolu]

re,
il faut testé , par exemple pris sur la doc nvidia pour deux écrans sur une carte graphique


To configure two separate X screens to share one graphics card, here is what you will need to do:

First, create two separate Device sections, each listing the BusID of the graphics card to be shared and listing the driver as "nvidia", and assign each a separate screen:

    Section "Device"
        Identifier  "nvidia0"
        Driver      "nvidia"
        # Edit the BusID with the location of your graphics card
        BusID       "PCI:2:0:0"
        Screen      0
    EndSection

    Section "Device"
        Identifier  "nvidia1"
        Driver      "nvidia"
        # Edit the BusID with the location of your graphics card
        BusId       "PCI:2:0:0"
        Screen      1
    EndSection

Then, create two Screen sections, each using one of the Device sections:

    Section "Screen"
        Identifier  "Screen0"
        Device      "nvidia0"
        Monitor     "Monitor0"
        DefaultDepth 24
        Subsection "Display"
            Depth       24
            Modes       "1600x1200" "1024x768" "800x600" "640x480"
        EndSubsection
    EndSection

    Section "Screen"
        Identifier  "Screen1"
        Device      "nvidia1"
        Monitor     "Monitor1"
        DefaultDepth 24
        Subsection "Display"
            Depth       24
            Modes       "1600x1200" "1024x768" "800x600" "640x480"
        EndSubsection
    EndSection

(Note: You'll also need to create a second Monitor section) Finally, update the ServerLayout section to use and position both Screen sections:

    Section "ServerLayout"
        ...
        Screen         0 "Screen0"
        Screen         1 "Screen1" leftOf "Screen0"
        ...
    EndSection

For further details, refer to the xorg.conf man page.
 



le lien de la doc => http://us.download.nvidia.com/XFree86/L … index.html
tu a le man aussi
j' avoue plus trop être dans le coup , je n'utilise plus de xorg.conf depuis "jessie"
quelque soit la marque de gpu le principe est le même sous GNU Linux   smile

Dernière modification par robert2a (07-09-2020 14:58:03)

Hors ligne

#25 07-09-2020 14:58:02

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Réglage de 2 écrans dans leur mode maximum respectif. [Résolu]

phlinux  a écrit :

la prochaine étape est d'ouvrir un vt, ou directement une session/serveur, sur un des 2 écrans; si possible le + petit.


un terminal virtuel ?

qu'est ce que tu entends par là ?

Dernière modification par Debian Alain (07-09-2020 14:58:43)

En ligne

Pied de page des forums