Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 14-09-2020 17:21:02

Obstino
Membre
Inscription : 14-09-2020

Installer Hplip 3.20 sur buster 10.5

Bonjour,

Quelqu'un aurait-il réussi à installer hplip 3.20.5 ou supérieur sur une buster 10.5 ?
J'en aurait besoin pour une hp deskjet plus 4100  qui marche bien avec ubuntu 20.04 et hplip 3.20.5.

Sur mon ordi (sous buster 10.5) le scanner n'est pas reconnu (en wifi ou en filaire) et je n'ai pas toutes les options de l'imprimante.

Merci à celle ou à celui qui aurait la solution.

ps les .run du site hp ne s'installent pas. Aucun n'accepte de s'installer pour buster 10.5

Hors ligne

#2 14-09-2020 17:49:24

cyrille
Adhérent(e)
Distrib. : SID + FreeBSD
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : Installer Hplip 3.20 sur buster 10.5

Qu'as tu essayé pour l'installer ? Et quels sont les retours ?
As tu essayé de faire du pinning vers testing qui propose cette version ? https://packages.debian.org/bullseye/hplip

Hors ligne

#3 14-09-2020 18:08:53

Obstino
Membre
Inscription : 14-09-2020

Re : Installer Hplip 3.20 sur buster 10.5

Comme je l'ai dit, aucune version de hplip du site hp ne veut s'installer.

Pour le reste je doit reconnaître que je ne connaît pas "faire du pinning vers testing".

Je vais faire une recherche à ce sujet dans la doc et sur le forum.

Merci.

Hors ligne

#4 14-09-2020 18:16:34

cyrille
Adhérent(e)
Distrib. : SID + FreeBSD
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : Installer Hplip 3.20 sur buster 10.5

Comme je l'ai dit, aucune version de hplip du site hp ne veut s'installer.


oui mais quel est le message d'erreur exact retourné

Dernière modification par cyrille (14-09-2020 20:33:23)

Hors ligne

#5 14-09-2020 23:00:19

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : Installer Hplip 3.20 sur buster 10.5

Obstino, as tu bien installé le paquet libsane-hpaio en plus de hplip ?

Hors ligne

#6 15-09-2020 09:01:29

Obstino
Membre
Inscription : 14-09-2020

Re : Installer Hplip 3.20 sur buster 10.5

Bonjour,

Le message d'erreur est:
error: debian-10.5 version is not supported, so all dependencies may not be installed. However trying to install using debian-10.3 version packages.

Je viens d'essayer à nouveau avec la version 3.20.6 au cas où...

Oui j'ai bien le bon libsane-hpaio pour le hplip installé (3.18.12)

Merci de votre aide, je continue à voir du côté de testing.

Dernière modification par Obstino (16-09-2020 19:38:03)

Hors ligne

#7 15-09-2020 20:26:48

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : Installer Hplip 3.20 sur buster 10.5

Que retourne la commande d'installation hp-setup ? :

hp-setup -i adresse_ip_de_ton_imprimante

Hors ligne

#8 15-09-2020 21:01:20

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.8.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Installer Hplip 3.20 sur buster 10.5

obstino , bonsoir . big_smile  big_smile  big_smile

installer les paquets de testing sur stable n'est pas  du tout recommandé .

dans le meilleur des cas , ton programme ne sera pas  fonctionnel à cause de dépendances non résolues ,
dans le pire des cas , tu risque de corrompre ton systeme , voire (mais c'est heureusement rare) vraiment  dans le pire des cas , de le casser .

mme avec du pinning , vu que tu installes  sciemment un programme de  testing sur stable , ce n'est pas  recommandé .

à lire : https://wiki.debian.org/fr/DontBreakDebian

bon sang , qu'est ce que je le distribue ces temps - ci ... smile

si tu tiens à avoir la version la plus récente , pense  aux backports .
mais pour hplip , cela n'existe pas , je crois .
en tout cas , pas  actuellement .

pour voire les versions de hplip disponibles  sous debian ,

apt-cache madison hplip

     hplip | 3.18.12+dfsg0-2 | http://deb.debian.org/debian buster/main amd64 Packages
     hplip | 3.18.12+dfsg0-2 | http://deb.debian.org/debian buster/main Sources



https://developers.hp.com/hp-linux-imag … ices/index

HP DeskJet Plus 4100 All-in-One Printer series  3.20.5  Yes Yes Full  Color  Yes  No 



je ne sais pas si on peut faire confiance au hplip-3.20.6.run https://sourceforge.net/projects/hplip/ … ror=freefr

P.S.: sauf erreur , ubuntu 20.04 est basé sur testing .... (a verifier)

Dernière modification par Debian Alain (15-09-2020 21:10:21)

Hors ligne

#9 15-09-2020 21:02:32

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : Installer Hplip 3.20 sur buster 10.5

Ton imprimante est la HP DeskJet Plus 4100 All-in-One Printer series ? https://developers.hp.com/hp-linux-imag … ices/index

Hors ligne

#10 16-09-2020 19:43:40

Obstino
Membre
Inscription : 14-09-2020

Re : Installer Hplip 3.20 sur buster 10.5

Oui c'est bien une HP DeskJet Plus 4100 All-in-One Printer series.

Merci pou toutes vos remarques.

Après avoir bien lu les docs je suis arrivé à la conclusion de Debian Alain. Je vais donc soit attendre un backport bien réalisé par d'autres wink Soit dans quelques temps essayer de passer en testing. Pour cela il me semble avoir compris qu'il valait mieux installer une buster minimale puis changer les dépots ?
Entre temps je vais scanner avec le portable sous ubuntu sad

Hors ligne

#11 16-09-2020 20:12:23

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.8.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Installer Hplip 3.20 sur buster 10.5

Obstino , bonsoir  big_smile  big_smile  big_smile

tu trouvera peut être ton bonheur là :  question.gif
https://cdimage.debian.org/cdimage/unof … so-hybrid/

j'ai choisi des images "live"  et non-free .

comme çà tu devrai pas  avoir de  souci avec  les pilotes et en plus tu peux tester  avant d'installer . woohoo.gif

n'oublie pas , l'actuelle testing , c'est la future stable , debian 11 , bullseye .old_geek.gif

tu peux choisir de rester en testing (tu passera automatiquement à debian 12) ou de te mettre en future stable , bullseye .
tu sera alors déjà en stable quand elle sortira .

amicalement ,

alain.

coyotus.png

Dernière modification par Debian Alain (16-09-2020 20:24:36)

Hors ligne

#12 16-09-2020 20:32:06

Obstino
Membre
Inscription : 14-09-2020

Re : Installer Hplip 3.20 sur buster 10.5

Merci pour toutes ces infos.
Je vais tester.

Amitiés

Hors ligne

Pied de page des forums