Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-09-2020 00:51:13

mikyrox83
Membre
Inscription : 07-04-2020

probleme d'installation pvr ip client simple

bonjour a tous voici le message d'erreur n'ayant que de petites notions je suis perdu pour resoudre mon probleme d'installation

$ sudo apt-get install kodi-pvr-iptvsimple
[sudo] Mot de passe de mika : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
kodi-pvr-iptvsimple : Dépend: libp8-platform2 (>= 1:2.1.0.1) mais 2.1.0.1+dfsg1-2 devra être installé
                       Dépend: kodi (>= 5:18~) mais 2:17.6+dfsg1-4+b1 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Pouvez vous me venir en aide avec un grand merci !

Hors ligne

#2 20-09-2020 09:32:21

SuShY
CA Debian-Facile
Lieu : Chartres
Distrib. : Debian Sid x86_64
Noyau : Linux > 5.9.x-x-amd64
(G)UI : i3WM - 4.18-1
Inscription : 06-01-2018
Site Web

Re : probleme d'installation pvr ip client simple

Hello, tu es sous quelle version de Debian stp ?

cat /etc/debian_version

Hors ligne

#3 28-09-2020 15:27:53

mikyrox83
Membre
Inscription : 07-04-2020

Re : probleme d'installation pvr ip client simple

Pardon pour mon silence et merci de ta réponse ma version de Debian est 10.3

Hors ligne

#4 29-09-2020 05:24:42

èfpé
Membre
Inscription : 10-07-2016

Re : probleme d'installation pvr ip client simple

Salut mikyrox83,

mikyrox83 a écrit :

apt install kodi-pvr-iptvsimple

Les paquets suivants contiennent des dépendances non satisfaites :
 kodi-pvr-iptvsimple : Dépend: libp8-platform2 (>= 1:2.1.0.1) mais 2.1.0.1+dfsg1-2 devra être installé
                       Dépend: kodi (>= 5:18~) mais 2:17.6+dfsg1-4+b1 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».


Il semble que l'installation du paquet depuis le dépôt deb-multimedia bloque du fait de ton pinning :

apt-cache policy kodi-pvr-iptvsimple libp8-platform2 kodi

kodi-pvr-iptvsimple:
  Installé : (aucun)
  Candidat : 6:3.9.8-dmo0+deb10u1
 Table de version :
     6:3.9.8-dmo0+deb10u1 100
        100 http://www.deb-multimedia.org buster/main amd64 Packages
libp8-platform2:
  Installé : (aucun)
  Candidat : 2.1.0.1+dfsg1-2
 Table de version :
     1:2.1.0.1-dmo1 100
        100 http://www.deb-multimedia.org buster/main amd64 Packages
     2.1.0.1+dfsg1-2 500
        500 http://deb.debian.org/debian buster/main amd64 Packages
kodi:
  Installé : (aucun)
  Candidat : 2:17.6+dfsg1-4+b1
 Table de version :
     5:18.8-dmo0+deb10u2 100
        100 http://www.deb-multimedia.org buster/main amd64 Packages
     2:17.6+dfsg1-4+b1 500
        500 http://deb.debian.org/debian buster/main amd64 Packages
 


apt-cache policy

Fichiers du paquet :
 100 /var/lib/dpkg/status
     release a=now
 100 http://www.deb-multimedia.org buster/main amd64 Packages
     release v=10.6,o=Unofficial Multimedia Packages,a=stable,n=buster,l=Unofficial Multimedia Packages,c=main,b=amd64
     origin www.deb-multimedia.org
 500 http://deb.debian.org/debian buster/main amd64 Packages
     release v=10.6,o=Debian,a=stable,n=buster,l=Debian,c=main,b=amd64
     origin deb.debian.org
Paquets épinglés :


apt -t 10.6 install kodi-pvr-iptvsimple -s


Cette simulation (option -s) montre comment l'option -t permet d'installer ces fichues dépendances.

Dernière modification par èfpé (30-09-2020 17:24:42)

Hors ligne

Pied de page des forums