Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 24-09-2020 08:56:30

debianestnotreprojet
Membre
Distrib. : Debian Bullseye (Testing)
Noyau : Linux 5.8.0-2-amd64
(G)UI : GNOME Wayland
Inscription : 19-05-2020

problème de mise à jour Sources.list Gnome 3 Debian Testing (Bullseye)

Salut à tous,

J'ai un problème de mise à jour avec Debian Testing NON LIBRE (Bullseye au 24092020 avec firmware amdgpu car pas le choix sinon pas d'affichage à l'écran). (problème de dépendances mais le message d'erreur est "coupé" à l'écran (seul le début s'affiche)

"Impossible de télécharger les mises à jour : The following packages have unmet dependencies:

(le message se "coupe" ici, je ne vois pas quelles dépendances manquent à l'appel.
NB : je suis sous Wayland.

Voici ma config pour être le plus clair possible :
System:    Host: ordinateur Kernel: 5.8.0-1-amd64 x86_64 bits: 64 Console: tty 0 Distro: Debian GNU/Linux bullseye/sid
Machine:   Type: Desktop Mobo: ASUSTeK model: PRIME X570-P v: Rev X.0x serial: UEFI: American Megatrends
           v: 1005 date: 08/02/2019
CPU:       Info: 12-Core model: AMD Ryzen 9 3900X bits: 64 type: MT MCP L2 cache: 6144 KiB
           Speed: 2195 MHz min/max: 2200/3800 MHz Core speeds (MHz): 1: 2198 2: 2196 3: 2192 4: 2195 5: 2193 6: 2191 7: 2194
           8: 2194 9: 2196 10: 2195 11: 2195 12: 2195 13: 2195 14: 2195 15: 2196 16: 2192 17: 2195 18: 2195 19: 2195 20: 2193
           21: 2196 22: 2196 23: 2195 24: 2195
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Vega 10 XL/XT [Radeon RX Vega 56/64] driver: amdgpu v: kernel
           Display: server: X.org 1.20.8 driver: amdgpu,ati unloaded: fbdev,modesetting,vesa tty: 140x31
           Message: Advanced graphics data unavailable in console for root.
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Vega 10 HDMI Audio [Radeon Vega 56/64] driver: snd_hda_intel
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio driver: snd_hda_intel
           Device-3: Sennheiser SC660 CTRL type: USB driver: hid-generic,snd-usb-audio,usbhid
           Sound Server: ALSA v: k5.8.0-1-amd64
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
           IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: a8:5e:45:53:2a:f3
           IF-ID-1: proton0 state: unknown speed: 10 Mbps duplex: full mac: N/A
Drives:    Local Storage: total: 1.40 TiB used: 85.93 GiB (6.0%)
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 PRO 1TB size: 953.87 GiB
           ID-2: /dev/sda vendor: Samsung model: SSD 860 PRO 512GB size: 476.94 GiB
           ID-3: /dev/sdb type: USB vendor: SanDisk model: Cruzer Blade size: 7.45 GiB
Partition: ID-1: / size: 906.00 GiB used: 85.84 GiB (9.5%) fs: ext4 dev: /dev/nvme0n1p2
Swap:      ID-1: swap-1 type: partition size: 31.91 GiB used: 13.2 MiB (0.0%) dev: /dev/nvme0n1p3
Sensors:   System Temperatures: cpu: 56.9 C mobo: N/A gpu: amdgpu temp: 46.0 C
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 85
Repos:     Active apt repos in: /etc/apt/sources.list
           1: deb http://deb.debian.org/debian/ testing main contrib non-free
           2: deb-src http://deb.debian.org/debian testing main contrib non-free
           3: deb http://deb.debian.org/debian testing-updates main contrib non-free
           4: deb-src http://deb.debian.org/debian testing-updates main contrib non-free
           5: deb http://deb.debian.org/debian testing-proposed-updates main contrib non-free
           6: deb-src http://deb.debian.org/debian testing-proposed-updates main contrib non-free
           7: deb http://security.debian.org testing-security main contrib non-free
           8: deb-src http://security.debian.org testing-security main contrib non-free
           9: deb http://us.archive.ubuntu.com/ubuntu/ bionic-updates universe
           No active apt repos in: /etc/apt/sources.list.d/costales-ubuntu-folder-color-groovy.list
           Active apt repos in: /etc/apt/sources.list.d/iridium-browser.list
           1: deb [arch=amd64] https://downloads.iridiumbrowser.de/deb/ stable main
           Active apt repos in: /etc/apt/sources.list.d/nordvpn.list
           1: deb https://repo.nordvpn.com/deb/nordvpn/debian stable main

Question : comment faire pour faire une mise à jour sans avoir le message d'erreur ci-dessous ?

"Impossible de télécharger les mises à jour : The following packages have unmet dependencies:
NB : je vous aurai bien fait une capture d'écran mais je ne vois pas où la joindre ici.

Hors ligne

#2 24-09-2020 09:24:42

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.8.0-2-amd64
(G)UI : mutter 3.38.0-2
Inscription : 15-02-2016

Re : problème de mise à jour Sources.list Gnome 3 Debian Testing (Bullseye)

Je suis partiellement dans le même cas que toi : Gnome debian 11 testing, mais pour moi rien que du libre ( C'est du vieux matos Intel CPU, Intel GPU ) et sans dépôts autre que Debian.

Mais j'ai quand même le message : "Impossible de télécharger les mises à jour : The following packages have unmet dependencies:" quand je veux mettre à jour avec "Logiciels"= gnome-software.

Par contre je peux toujours mettre à jour avec :

aptitude update && aptitude  safe-upgrade



Le problème vient de python, on peut le voir avec :

aptitude update && aptitude  full-upgrade

Atteint http://deb.debian.org/debian bullseye InRelease
Atteint http://deb.debian.org/debian-security testing-security/updates InRelease
Atteint http://debug.mirrors.debian.org/debian-debug testing-debug InRelease
Atteint http://deb.debian.org/debian bullseye-updates InRelease
                                                       
Les paquets suivants seront mis à jour :                
  libpython2-stdlib python2 python2-minimal
3 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 73,0 ko d'archives. Après dépaquetage, 147 ko seront libérés.
Les paquets suivants ont des dépendances non satisfaites :
 python : Dépend: python2 (= 2.7.17-2) but 2.7.18-2 is to be installed
 libpython-stdlib : Dépend: libpython2-stdlib (= 2.7.17-2) but 2.7.18-2 is to be installed
 python-minimal : Dépend: python2-minimal (= 2.7.17-2) but 2.7.18-2 is to be installed
Les actions suivantes permettront de résoudre ces dépendances :

     Supprimer les paquets suivants :            
1)     libpython-stdlib [2.7.17-2 (now)]        
2)     python [2.7.17-2 (now)]                  
3)     python-enum34 [1.1.6-2 (now)]            
4)     python-minimal [2.7.17-2 (now)]          
5)     python-sip [4.19.21+dfsg-1 (now)]        

     Leave the following dependencies unresolved:
6)     python-minimal recommande python          



Accepter cette solution ? [Y/n/q/?]

 



Je ne sais pas si nous devons forcer une solution, mais d'abord avant il faudrait bien comprendre les tenants et les aboutissants de cette démarche avant d'oser, ou bien attendre que les développeurs fassent évoluer la situation dans le bon sens. Pour l'instant, cela fait déjà une douzaine de jours, j'attends et je fais des mises à jour avec aptitude update && aptitude  safe-upgrade au lieu de mon habituel aptitude update && aptitude  full-upgrade.


La liberté est liée à la qualité du langage, et les bureaucrates qui veulent détruire la liberté ont tous tendance à mal écrire et à mal parler, à se servir d’expressions pompeuses ou confuses, à user de clichés qui occultent ou oblitèrent le sens. Georges Orwell

Hors ligne

#3 24-09-2020 09:45:25

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.8.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : problème de mise à jour Sources.list Gnome 3 Debian Testing (Bullseye)

bonjour debianestnotreprojet   big_smile big_smile big_smile

alors déjà , il est très déconseillé d'utiliser des dépôts externes à debian .

en général , c'est source de problèmes voire de casse dans les cas extrèmes .

qu'as tu été faire chez ubuntu ?

si tu as besoin de programmes particuliers , demande les correspondances aux anciens .

ils ont l'habitude et pourront te répondre plus finement que la majorité d'entre nous .

tu sembles n'avoir que deux partitions sur ton disque systeme (/swap et /root) . je suis surpris .

généralement , on y mets /swap /root (ou racine) et /home

par ailleurs , python est en pleine évolution .

il est question de faire évoluer python 3 et de laisser dépérir python 2 .

python 2 est en fin de vie .

compte tenu de l'évolution de python , la version 3 est appelée à aller de l'avant et la version 2 à s'arrêter là .

pour l'instant , les deux versions  sont encore maintenues mais pour combien de temps encore ?

python 2 est appelé à s'arrêter . son évolution naturelle étant de devenir python 3 .

voilà .

amicalement ,

alain .

coyotus.png

En ligne

#4 24-09-2020 09:59:29

debianestnotreprojet
Membre
Distrib. : Debian Bullseye (Testing)
Noyau : Linux 5.8.0-2-amd64
(G)UI : GNOME Wayland
Inscription : 19-05-2020

Re : problème de mise à jour Sources.list Gnome 3 Debian Testing (Bullseye)

Merci Gilles.
Tu as raison, le problème vient de Gnome Software (Logiciels) et de python
J'ai opté temporairement pour ta solution, à savoir :
aptitude update && aptitude  safe-upgrade

Visiblement, le passage de python 2 vers python 3 a laissé des traces.
Après aptitude update && aptitude safe-upgrade, j'ai fait apt update && apt upgrade et j'ai eu ce message :

Les paquets suivants ont été conservés :
  libpython2-stdlib python-all python2 python2-minimal
0 mis à jour, 0 nouvellement installés, 0 à enlever et 4 non mis à jour.

Hors ligne

#5 24-09-2020 10:11:27

debianestnotreprojet
Membre
Distrib. : Debian Bullseye (Testing)
Noyau : Linux 5.8.0-2-amd64
(G)UI : GNOME Wayland
Inscription : 19-05-2020

Re : problème de mise à jour Sources.list Gnome 3 Debian Testing (Bullseye)

Précisions : Le fait que j'ai un processeur Ryzen AMD 3900x m'oblige DE FACTO à utiliser une version Debian NON LIBRE.
Je ne sais pas si les processeurs AMD avec GPU intégré sont compatibles avec Debian Libre directement (out of the box)
J'avais auparavant un processeur Intel i7-8700 et c'est vrai que je ne posais pas le problème : J'installais Debian Libre, et pour la carte graphique, ici une Vega 56, j'avais installé amdgpu ou le firmware amd.
Espérons que AMD, à l'avenir, propose des processeurs avec circuit graphique intégré et qui fonctionne directement, comme un processeur Intel avec circuit graphique intégré.

Concrètement, sous ma Debian Non libre actuelle, j'ai dû procéder de la sorte :
1- Installer Debian Non Free Gnome Live (car les isos DVD1 par exemple ou le cd net install ne fonctionnaient pas - problème d'affichage au redémarrage lorsque le Debian était supposé être installé)
À noter que je n'avais pas ce problème avec mon processeur Intel i7-8700.
2- changer les dépôts stables en testing (car il me semble que les dépôts du Debian Gnome Live Non Libre sont des "stables" et pas des "testing")

Je peux changer les dépôts après réflexion, garder seulement les dépôts Debian et supprimer les autres, à savoir:
1- supprimer le dépôt Ubuntu Bionic (Ubuntu 18.04 LTS) (ajouté pour avoir les logiciels fonctionnant sous python 2)
2- supprimer le dépôt de Iridium Browser (dérivé libre de Chromium sans la télémétrie de Goo***)
3- supprimer le dépôt de nordvpn car pas certain que ce soit du libre et j'utiliserai NordVpn avec OpenVpn.

Question 1 : Sais-tu comment paramétrer Chromium pour qu'il soit le plus "propre et libre" possible ? (en n'envoyant pas des données à Goo***) (J'utilise Firefox Flatpak qui fonctionne très bien mais parfois je peux avoir besoin de Chromium ou dérivé si problème d'affichage sous Firefox)

Question 2 : As-tu un Sources.list à me proposer ? (Non libre à cause d'un seul fichier : amdgpu/ firmware amd)merci.gif

Dernière modification par debianestnotreprojet (24-09-2020 10:40:01)

Hors ligne

#6 24-09-2020 10:30:12

debianestnotreprojet
Membre
Distrib. : Debian Bullseye (Testing)
Noyau : Linux 5.8.0-2-amd64
(G)UI : GNOME Wayland
Inscription : 19-05-2020

Re : problème de mise à jour Sources.list Gnome 3 Debian Testing (Bullseye)

Bonjour Debian Alain. Merci pour ton aide.
Je suis parti de chez Ubuntu pour aller chez Debian dans un premier pour éviter les bugs (même si Ubuntu a beaucoup progressé et a moins de bugs) et pour avoir une distribution Gnu Linux la plus libre possible et en étant proche d'Ubuntu, sachant que j'utilise GNOME.

Debian est pour moi le meilleur choix pour mes besoins, je pense.

Mais j'avais le problème suivant :
Quelques logiciels n'étaient pas présents : The Bub Brothers (clone de Bubble Bobble). Mirage (écrit en python, utilitaire très léger pour redimensionner les fichiers jpg)

J'ai donc trouvé des alternatives :
1- The Bub Brothers : je laisse tomber si je dois ajouter des dépôts Ubuntu car risque de rendre le système instable.
2- Mirage : Nomacs est une excellente alternative disponible via Synaptic/Gnome Software (Logiciels) ou Flatpak (mais ça marche mal sous Wayland, à voir sous X.org)

Ce que j'utilise de Ubuntu ou Canonical ce sont des Snaps, auxquels je n'ai pas d'alternatives libres sous Logiciels, Synaptic ou Flatpak :
1- P7Zip pour extraire les archives en .rar (Libre)
2- Spek (pour vérifier la qualité réelle d'un fichier mp3 ou FLAC) (Libre)
3- Mountain Tapir (collage de plusieurs images en une) (Libre)

Hors ligne

#7 24-09-2020 10:49:55

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.8.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : problème de mise à jour Sources.list Gnome 3 Debian Testing (Bullseye)

pour "p7zip" , il existe sous debian . pas la  peine d'aller le chercher sous ubuntu .

https://korben.info/installer-7-zip-7z-sous-linux.html

pour "spek" , ' je sais plus qui ' avait trouvé le moyen de créer un fichier image du spectrogramme d'un fichier  audio .

pour "mountain tapir" , tu as regardé "the gimp"  ?

Mirage (écrit en python, utilitaire très léger pour redimensionner les fichiers jpg)


pour çà , y a ffmpeg (voire aussi p ê "winff" ). mais je m'en sers presque jamais .
demande , on te donnera la ligne de  commande .

Dernière modification par Debian Alain (24-09-2020 11:07:19)

En ligne

#8 24-09-2020 13:11:43

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.8.0-2-amd64
(G)UI : mutter 3.38.0-2
Inscription : 15-02-2016

Re : problème de mise à jour Sources.list Gnome 3 Debian Testing (Bullseye)

Pour python2, c'est peut-être le moment de l'enlever puisque les paquets python2 sont obsolètes :

aptitude search ?obsolete  | grep python

i A libpython-stdlib - interactive high-level object-oriented language (Python2)
i  python - interactive high-level object-oriented language (Python2 version)
i A python-enum34 - backport of Python 3.4's enum package
i  python-minimal - minimal subset of the Python2 language
i  python-sip - Python/C++ bindings generator runtime library
 



Alors je crois que je ne prends pas trop de risque avec :

aptitude  purge python-minimal

Les paquets suivants seront ENLEVÉS :                  
  python-minimal{p}
0 paquets mis à jour, 0 nouvellement installés, 1 à enlever et 3 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 44,0 ko seront libérés.
Les paquets suivants ont des dépendances non satisfaites :
 python : Pré-Dépend: python-minimal (= 2.7.17-2) but it is not going to be installed
Les actions suivantes permettront de résoudre ces dépendances :

     Supprimer les paquets suivants :  
1)     python [2.7.17-2 (now)]          
2)     python-enum34 [1.1.6-2 (now)]    
3)     python-sip [4.19.21+dfsg-1 (now)]



Accepter cette solution ? [Y/n/q/?] y
Les paquets suivants seront ENLEVÉS :
  libpython-stdlib{u} python{a} python-enum34{a} python-minimal{p} python-sip{a}
0 paquets mis à jour, 0 nouvellement installés, 5 à enlever et 3 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 752 ko seront libérés.
Voulez-vous continuer ? [Y/n/?] y
(Lecture de la base de données... 259393 fichiers et répertoires déjà installés.)
Suppression de python-sip (4.19.21+dfsg-1) ...
Suppression de python-enum34 (1.1.6-2) ...
Suppression de python (2.7.17-2) ...
Suppression de libpython-stdlib:amd64 (2.7.17-2) ...
Suppression de python-minimal (2.7.17-2) ...
Traitement des actions différées (« triggers ») pour man-db (2.9.3-2) ...
                                                       
 


La liberté est liée à la qualité du langage, et les bureaucrates qui veulent détruire la liberté ont tous tendance à mal écrire et à mal parler, à se servir d’expressions pompeuses ou confuses, à user de clichés qui occultent ou oblitèrent le sens. Georges Orwell

Hors ligne

#9 24-09-2020 13:15:04

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.8.0-2-amd64
(G)UI : mutter 3.38.0-2
Inscription : 15-02-2016

Re : problème de mise à jour Sources.list Gnome 3 Debian Testing (Bullseye)

Suivi de :

aptitude update && aptitude  full-upgrade

Atteint http://deb.debian.org/debian bullseye InRelease
Atteint http://deb.debian.org/debian-security testing-security/updates InRelease
Atteint http://debug.mirrors.debian.org/debian-debug testing-debug InRelease
Atteint http://deb.debian.org/debian bullseye-updates InRelease
                                                       
Les paquets suivants seront mis à jour :                
  libpython2-stdlib python2 python2-minimal
3 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 73,0 ko d'archives. Après dépaquetage, 147 ko seront libérés.
Voulez-vous continuer ? [Y/n/?] y
Prendre :  1 http://deb.debian.org/debian bullseye/main amd64 python2-minimal amd64 2.7.18-2 [27,4 kB]
Prendre :  2 http://deb.debian.org/debian bullseye/main amd64 python2 amd64 2.7.18-2 [24,4 kB]
Prendre :  3 http://deb.debian.org/debian bullseye/main amd64 libpython2-stdlib amd64 2.7.18-2 [21,2 kB]
 73,0 ko téléchargés en 0s (175 ko/s)    
Récupération des rapports de bogue… Fait
Analyse des informations Trouvé/Corrigé… Fait
Lecture des fichiers de modifications (« changelog »)... Terminé
(Lecture de la base de données... 259340 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../python2-minimal_2.7.18-2_amd64.deb ...
Dépaquetage de python2-minimal (2.7.18-2) sur (2.7.17-2) ...
Paramétrage de python2-minimal (2.7.18-2) ...
(Lecture de la base de données... 259328 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../python2_2.7.18-2_amd64.deb ...
Dépaquetage de python2 (2.7.18-2) sur (2.7.17-2) ...
Préparation du dépaquetage de .../libpython2-stdlib_2.7.18-2_amd64.deb ...
Dépaquetage de libpython2-stdlib:amd64 (2.7.18-2) sur (2.7.17-2) ...
Paramétrage de libpython2-stdlib:amd64 (2.7.18-2) ...
Paramétrage de python2 (2.7.18-2) ...
Traitement des actions différées (« triggers ») pour man-db (2.9.3-2) ...
Scanning processes...                                                                                                        
Scanning candidates...                                                                                                      
Scanning processor microcode...                                                                                              
Scanning linux images...                                                                                                    

Running kernel seems to be up-to-date.

Failed to check for processor microcode upgrades.

Restarting services...
Service restarts being deferred:
 systemctl restart NetworkManager.service
 /etc/needrestart/restart.d/dbus.service
 systemctl restart systemd-logind.service

No containers need to be restarted.

No user sessions are running outdated binaries.
                                                       
État actuel : 0 (-3) upgradable.
 


La liberté est liée à la qualité du langage, et les bureaucrates qui veulent détruire la liberté ont tous tendance à mal écrire et à mal parler, à se servir d’expressions pompeuses ou confuses, à user de clichés qui occultent ou oblitèrent le sens. Georges Orwell

Hors ligne

#10 24-09-2020 13:33:19

debianestnotreprojet
Membre
Distrib. : Debian Bullseye (Testing)
Noyau : Linux 5.8.0-2-amd64
(G)UI : GNOME Wayland
Inscription : 19-05-2020

Re : problème de mise à jour Sources.list Gnome 3 Debian Testing (Bullseye)

@ Debian Alain : merci pour ces informations.

Hors ligne

#11 24-09-2020 13:48:41

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.8.0-2-amd64
(G)UI : mutter 3.38.0-2
Inscription : 15-02-2016

Re : problème de mise à jour Sources.list Gnome 3 Debian Testing (Bullseye)

C'était --gilles-- et non Debia Alain. handy.png

La liberté est liée à la qualité du langage, et les bureaucrates qui veulent détruire la liberté ont tous tendance à mal écrire et à mal parler, à se servir d’expressions pompeuses ou confuses, à user de clichés qui occultent ou oblitèrent le sens. Georges Orwell

Hors ligne

#12 24-09-2020 13:51:32

debianestnotreprojet
Membre
Distrib. : Debian Bullseye (Testing)
Noyau : Linux 5.8.0-2-amd64
(G)UI : GNOME Wayland
Inscription : 19-05-2020

Re : problème de mise à jour Sources.list Gnome 3 Debian Testing (Bullseye)

@--gilles-- : merci pour ton aide.

J'avais oublié que j'avais le paquet folder color sous python 2.
Ce programme sert à donner une couleur à un dossier (on ne parle pas de thème mais bien de dossier).
Et là, aucune alternative, je ne vois pas comment contourner le problème, sauf à ne pas installer le paquet.
Tu as une idée ?
http://foldercolor.tuxfamily.org/

Hors ligne

#13 24-09-2020 14:15:24

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.8.0-2-amd64
(G)UI : mutter 3.38.0-2
Inscription : 15-02-2016

Re : problème de mise à jour Sources.list Gnome 3 Debian Testing (Bullseye)

Dans la dernière version du code foldercolor, je viens de chercher vite fait, c'est déjà à base de python3 :

https://github.com/costales/folder-color

Après, d'après ce que je comprends du site du développeur :

https://costales.github.io/projects/folder-color/  Dans le chapitre "Are you in Ubuntu 20.04?", on voit un lien censé aller vers le code de Yaru-Colors, mais il va vers le code de foldercolor :
https://github.com/costales/folder-color où il y a plusieurs mentions de la phrase : Requires python3

Est-ce que cela veut dire de façon sûre qu'il faut utiliser Ubuntu 20.04 pour pouvoir avoir foldercolor en python3, je ne peux pas l'affirmer, mais cela paraît assez probable.

Pour en être sûr, le mieux serait de lui poser la question avec la description de ton problème = "Issue", dans son github si tu es déjà inscrit à github ou tu t'y inscris pour l'occasion si tu maîtrises un peu l'anglais :

https://github.com/costales/folder-color/issues

La liberté est liée à la qualité du langage, et les bureaucrates qui veulent détruire la liberté ont tous tendance à mal écrire et à mal parler, à se servir d’expressions pompeuses ou confuses, à user de clichés qui occultent ou oblitèrent le sens. Georges Orwell

Hors ligne

#14 24-09-2020 15:59:18

debianestnotreprojet
Membre
Distrib. : Debian Bullseye (Testing)
Noyau : Linux 5.8.0-2-amd64
(G)UI : GNOME Wayland
Inscription : 19-05-2020

Re : problème de mise à jour Sources.list Gnome 3 Debian Testing (Bullseye)

@---gilles---

Bonne nouvelle que folder color soit à base de python 3.
Ça peut vouloir dire qu'il pourrait faire partie des dépôts de Debian à l'avenir.

Il est dommage de "réserver" certains dépôts pour Ubuntu, sachant que Folder Color est un programme dont le code source est libre (Licence GPL v3).

J'ai jeté un coup d'oeil à la page Github, il y a également l'adresse mail du développeur, je le contacterai certainement.

Hors ligne

#15 24-09-2020 17:43:29

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.8.0-2-amd64
(G)UI : mutter 3.38.0-2
Inscription : 15-02-2016

Re : problème de mise à jour Sources.list Gnome 3 Debian Testing (Bullseye)

à debianestnotreprojet, excellent l'idée de le contacter parce que c'est lui qui a décidé de développer que pour Ubuntu.

La liberté est liée à la qualité du langage, et les bureaucrates qui veulent détruire la liberté ont tous tendance à mal écrire et à mal parler, à se servir d’expressions pompeuses ou confuses, à user de clichés qui occultent ou oblitèrent le sens. Georges Orwell

Hors ligne

#16 29-09-2020 17:48:45

debianestnotreprojet
Membre
Distrib. : Debian Bullseye (Testing)
Noyau : Linux 5.8.0-2-amd64
(G)UI : GNOME Wayland
Inscription : 19-05-2020

Re : problème de mise à jour Sources.list Gnome 3 Debian Testing (Bullseye)

@ --gilles-- : voici le lien pastebin qui marche avec wget pour installer folder color :
https://paste.ubuntu.com/p/b9R8rzbzsB/

Donc :
apt install wget
wget https://launchpad.net/~costales/+archiv … 91_all.deb
wget https://launchpad.net/~costales/+archiv … 88_all.deb
sudo dpkg -i folder-color*.deb
nautilus -q

Ça fonctionne parfaitement sous Debian Testing (Bullseye)

En ce qui concerne le dépôt folder color pour Debian, le développeur m'a expliqué qu'il est compliqué de faire entrer un dépôt chez Debian.
Ce développeur a également créer 2 autres programmes intéressants :
Anoise (musique d'ambiance : vent...)
Gufw : parefeu qui est lui dans les dépôts Debian

Hors ligne

Pied de page des forums