Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 22-10-2020 12:57:08

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

Je réponds "non, il ne l'est pas depuis le dépot b-b"

AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#27 22-10-2020 13:02:12

bendia
Chadministrateur
Distrib. : openSUSE Tumbleweed, Buster
Noyau : Linux 5.9.1-2-default + Linux 4.19.0-12-amd64
(G)UI : Gnome + Console et un peu Fluxbox
Inscription : 20-03-2012
Site Web

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

Or, c'est ce paquet issue de buster back ports qui permettra de suivre les montées en version du noyau, et passer ainsi de 5.7 à 5.8

Conclusion, quelle commande dois-tu passer pour installer ce paquet depuis buster-backports ?

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

Hors ligne

#28 22-10-2020 13:08:04

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

Sur la pointe des pieds et avec des pincettes je dirais

apt install -s -t buster-backports linux-image-amd64

que d'ailleurs je teste de ce pas (avec le "-s" je ne risque rien) :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
  linux-image-5.8.0-0.bpo.2-amd64
Paquets suggérés :
  linux-doc-5.8 debian-kernel-handbook
Les NOUVEAUX paquets suivants seront installés :
  linux-image-5.8.0-0.bpo.2-amd64
Les paquets suivants seront mis à jour :
  linux-image-amd64
1 mis à jour, 1 nouvellement installés, 0 à enlever et 227 non mis à jour.
Inst linux-image-5.8.0-0.bpo.2-amd64 (5.8.10-1~bpo10+1 Debian Backports:buster-backports [amd64])
Inst linux-image-amd64 [4.19+105+deb10u7] (5.8.10-1~bpo10+1 Debian Backports:buster-backports [amd64])
Conf linux-image-5.8.0-0.bpo.2-amd64 (5.8.10-1~bpo10+1 Debian Backports:buster-backports [amd64])
Conf linux-image-amd64 (5.8.10-1~bpo10+1 Debian Backports:buster-backports [amd64])
 


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#29 22-10-2020 13:12:11

bendia
Chadministrateur
Distrib. : openSUSE Tumbleweed, Buster
Noyau : Linux 5.9.1-2-default + Linux 4.19.0-12-amd64
(G)UI : Gnome + Console et un peu Fluxbox
Inscription : 20-03-2012
Site Web

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

Cela serait-il le résultat que tu souhaitais obtenir ?

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

Hors ligne

#30 22-10-2020 13:23:54

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

Oui, c'est ce que je veux obtenir.
Non, je ne veux pas lancer (manière de dire, hein) une ligne de commande, je veux que ça se fasse avec un apt qqchse, automagiquement, quoi.

Ou alors je ne comprends pas ta question :

bendia a écrit :

Cela serait-il le résultat que tu souhaitais obtenir ?

Ce résultat dont tu parles vient d'un apt install chemin nom_de_paquet quand moi je voulais simplement un apt upgrade pour passer de 5.7 à 5.8.
Maintenant, si ça n'est pas possible, y a qu'à me le dire, et je passerai par la longue ligne de commande.

Relis les posts 13, 14 et 15, merci.

Dernière modification par jpt (22-10-2020 13:26:50)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#31 22-10-2020 13:36:31

bendia
Chadministrateur
Distrib. : openSUSE Tumbleweed, Buster
Noyau : Linux 5.9.1-2-default + Linux 4.19.0-12-amd64
(G)UI : Gnome + Console et un peu Fluxbox
Inscription : 20-03-2012
Site Web

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

A priori, tu n'as.pas compris hmm

Pour que apt upgrade monte les versions du noyau il faut que le paquet linux-image-amd64 provienne du dépôt backports.

Or, sur ton système, il n'en provient pas, tu as le noyau 4.19 de buster, et en plus, tu as dû installer le paquet linux-image-5.7-blabla. Ça explique pourquoi le 5.8 ne t'es pas proposé par une mise à jour.

Si tu installes linux-image-amd64 des backports tu passeras en 5.9 avec apt upgrade comme tu le souhaites

Édit : quand 5.9 sera dans les dépôts buster-backports évidemment wink

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

Hors ligne

#32 22-10-2020 13:42:58

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

du post 12 :

jpt a écrit :

concernant les 2 posts d'Alain, je n'ai pas pu tout à l'heure poster ce qui suit, tu y verras plus clair (et les autres aussi) -- ça vient de ma discussion résolue sur l'AMD Ryzen 3 3200G, Debian 5.7.10 backport, et l'écran noir.

Petit retour en arrière (14 septembre)
... une dernière manip à tenter, suite à lecture d'un post ici (http://forums.debian.net/viewtopic.php?f=17&t=145018), qui dit en substance :

        # apt install -t buster-backports linux-image-amd64


Et chalu suit au post suivant avec

apt install -t buster-backports install linux-image-amd64 firmware-amd-graphics

J'ai donc migré ma 4.19.118 en suivant les conseils du lien, puis chalu en a remis une couche et voilà comment je me suis retrouvé en 5.7.0-0.bpo.2-amd64 puis quelques jours plus tard en 5.7.10 sans que j'ai rien demandé.


Alors je veux bien admettre que je ne suis pas fut-fut surtout dans ce domaine de l'apt, mais quand même, faire des copier/coller, ça fait 30 ans (ou peut-être plus) que je sais faire...

edit : Histoire de ne pas passer l'après-midi là-dessus, je vais lancer la commande et on verra bien, quand la 5.9 sortira, ce qui se passera...

Dernière modification par jpt (22-10-2020 13:45:51)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#33 22-10-2020 14:00:45

bendia
Chadministrateur
Distrib. : openSUSE Tumbleweed, Buster
Noyau : Linux 5.9.1-2-default + Linux 4.19.0-12-amd64
(G)UI : Gnome + Console et un peu Fluxbox
Inscription : 20-03-2012
Site Web

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

Pour vérifier, tu peux peut-être repasser la commande après l'installation

apt policy linux-image-amd64


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

Hors ligne

#34 22-10-2020 14:15:50

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

Après l'install par

# apt install -t buster-backports linux-image-amd64

,

# apt policy linux-image-amd64
linux-image-amd64:
  Installé : 5.8.10-1~bpo10+1
  Candidat : 5.8.10-1~bpo10+1
 Table de version :
 *** 5.8.10-1~bpo10+1 100
        100 https://deb.debian.org/debian buster-backports/main amd64 Packages
        100 /var/lib/dpkg/status
     4.19+105+deb10u7 500
        500 http://security.debian.org/debian-security buster/updates/main amd64 Packages
     4.19+105+deb10u6 500
        500 https://deb.debian.org/debian buster/main amd64 Packages
 


Dès que j'aurai une heure, je virerai ces 4.19 qui traînent, ça ne me sert à rien.


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#35 22-10-2020 14:48:41

bendia
Chadministrateur
Distrib. : openSUSE Tumbleweed, Buster
Noyau : Linux 5.9.1-2-default + Linux 4.19.0-12-amd64
(G)UI : Gnome + Console et un peu Fluxbox
Inscription : 20-03-2012
Site Web

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

Ben, il y a dû avoir un problème la dernière fois ou le paquet a été desinstallé, mais là, ça semble bon.

Sait ans sée wink

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

Hors ligne

#36 22-10-2020 15:06:22

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

Ah, j'ai quand même un problème, au reboot avec cette nouvelle 5.8.0-0.bpo.2-amd64 : en me connectant en ssh depuis la vieille machine, les caractères | \ @ [ ] ~ sont remplacés par d'autres (ö Ö § ä Ü ß), ça va être la misère pour bosser et je n'ai pas la moindre idée de quoi et où chercher pour corriger ça.

AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#37 22-10-2020 15:54:13

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

Bon voilà, il aura suffi d'un apt remove (en fait deux, car si j'ai bien compris la sortie dpkg -l | grep linux-image*, il y a 2 paquets :

ii  linux-image-5.8.0-0.bpo.2-amd64              5.8.10-1ßbpo10+1                    amd64        Linux 5.8 for 64-bit PCs (signed)
ii  linux-image-amd64                            5.8.10-1ßbpo10+1                    amd64        Linux for 64-bit PCs (meta-package)

et le fait de supprimer le meta-package ne supprime pas les paquets qu'il contient -- pourtant l'install s'en est bien débrouillée (mais si je dis "nul !" je vais encore me faire démonter) pour retrouver un fonctionnement normal de ssh en console. Même pas besoin de rebooter !

Ceux qui croient aux choses bizarres de ce monde conviendront avec moi que si je ne pouvais pas installer cette 5.8, c'est parce qu'elle est moisie et que mes petits anges essayaient de m'en préserver.

Bon, on va patiemment attendre la 5.9...

Dernière modification par jpt (30-10-2020 15:13:15)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#38 22-10-2020 17:52:33

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux -5.14.0-4-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

méfie toi , jpt .

ne fais pas  n'importe quoi avec  les kernels .

les kernels stable , actuellement , c'est la version 4.19
les kernels testing , ce sont les 5.8
et les kernels sid , ce sont les 5.9

actuellement .

si tu mets un kernel actuel sid sur ta stable , tu va tout casser .
fais aussi attention aux kernels testing . même cause , mêmes effets . (tu risque de tout casser)

limite toi au grand maximum aux kernels backportés .

mais je me répète , si c' est pour jouer avec les backports , autant passer à testing ,
au moins tu aura des paquets récents qui gèreront mieux ta machine .
en plus , si tu configure bien ton sources , tu aura , à l' avance , bullseye stable (actuelle testing (version no 11))

Dernière modification par Debian Alain (22-10-2020 18:00:38)

Hors ligne

#39 22-10-2020 18:27:52

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

Debian Alain a écrit :

ne fais pas n'importe quoi avec les kernels.

les kernels stable, actuellement, c'est la version 4.19
les kernels testing, ce sont les 5.8
et les kernels sid, ce sont les 5.9

OK, mais parlons un langage que je comprends : et les kernels sid , ce sont les 5.9 --> et les kernels unstable, ce sont les 5.9

Debian Alain a écrit :

si tu mets un kernel actuel sid sur ta stable, tu vas tout casser.
fais aussi attention aux kernels testing. même cause, mêmes effets. (tu risques de tout casser)

Si je mets un kernel unstable sur une machine stable, je vais juste peut-être casser les pilotes très récents et pas complètement testés, il me semble. Je prendrai donc moins de risques à installer un kernel testing, ok ok, restons-en là.

Debian Alain a écrit :

limite-toi au grand maximum aux kernels backportés.

C'est ce qui a été fait pour passer de 4.19 à 5.7 pour supporter correctement les consoles. Et jusqu'à présent ça fonctionne bien (sauf cette embrouille cet aprème avec les caractères en vrac qui m'ont obligé à faire marche arrière).

Mais j'avoue que je ne vois pas la différence entre un kernel backporté et un kernel testing, si ce n'est que le kernel testing fait partie d'une distro testing (plus de pilotes, plus récents) alors que le kernel backporté concerne juste le noyau, plus récent, pour cette histoire de firmwares.

Debian Alain a écrit :

mais je me répète, si c'est pour jouer avec les backports, autant passer à testing,
au moins tu auras des paquets récents qui géreront mieux ta machine.
en plus, si tu configures bien ton sources, tu auras, à l'avance, bullseye stable (actuelle testing (version no 11))

OK, et tu fais ça comment, toi ? Montre-nous ton source, please,


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#40 22-10-2020 18:54:50

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux -5.14.0-4-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

mon sources est réglé pour testing , pas pour la future stable .

je peux te le communiquer si tu y tiens vraiment .

pour passer de buster stable à bullseye ,

remplacer le mot "buster"  dans le sources en question par "bullseye"

puis mise à jour des sources et des paquets et c'est bon ,  tu es en future stable .

attention : testing n'ayant pas été gelée pour encore , tu te retrouvera avec une future stable potentiellement incomplète .

sinon , oui , sid = unstable . "sid" , c'est le petit nom de la version unstable .

Dernière modification par Debian Alain (22-10-2020 19:06:55)

Hors ligne

#41 22-10-2020 19:14:08

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

Debian Alain a écrit :

mon sources est réglé pour testing, pas pour la future stable .

je peux te le communiquer si tu y tiens vraiment.

Plus la peine, avec ce que tu précises dessous (grand merci à toi) + 1 !

Debian Alain a écrit :

pour passer de buster stable à bullseye,

remplacer le mot "buster"  dans le sources en question par "bullseye"

puis mise à jour des sources et des paquets et c'est bon, tu es en future stable.

Trop fastoche !

Debian Alain a écrit :

attention : testing n'ayant pas encore été gelée, tu te retrouveras avec une future stable potentiellement incomplète.

Bon, ben on va attendre un peu, alors.

Debian Alain a écrit :

sinon, oui, sid = unstable. "sid", c'est le petit nom de la version unstable.

Totalement non mémorisable pour moi (je dois avoir un bug dans les neurones).

Merci pour tout,

Dernière modification par jpt (22-10-2020 19:17:03)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#42 22-10-2020 19:24:43

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux -5.14.0-4-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

upgrader sa version de debian , c'est pas  compliqué .

par contre , çà peut très vite le devenir si le systeme , au départ , n'est pas  parfaitement clean .

c.a.d. :

1) pas de liens externes .
2) pas de paquets externes .
3) pas de logiciels hybrides .
4) pas de sources hybrides .

dans le meilleur des cas les paquets externes ainsi installés ne fonctionneront plus .

dans le pire des cas , il risque d'y avoir des conflits entre paquets et donc , casse éventuelle de l'installation .

Dernière modification par Debian Alain (22-10-2020 19:41:35)

Hors ligne

Pied de page des forums