Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 21-10-2020 13:04:17

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Rester bloqué en 5.7.10, est-ce bien raisonnable ?

Bonjour,

En voyant les version du noyau dans certains posts récents, je tente ça (après un aptitude update wink ) :

# aptitude -s safe-upgrade
Les paquets suivants seront mis à jour :                
  firmware-amd-graphics virtualbox-6.1
Les paquets suivants sont RECOMMANDÉS mais ne seront pas installés :
  linux-headers-amd64
2 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 92,9 Mo d'archives. Après dépaquetage, 2546 ko seront utilisés.

Note: Using 'Simulate' mode.
Voulez-vous continuer ? [Y/n/?] n
Abandon.


puis

# aptitude -s full-upgrade

avec un résultat strictement identique, et j'en conclus que je vais donc rester en 5.7.10.

Comment certains arrivent-ils à avoir de la 5.8.xxx opérationnelle ?

Voilà mon /etc/apt/sources.list :

deb https://deb.debian.org/debian/ buster main contrib non-free
deb https://deb.debian.org/debian/ buster-updates main contrib non-free
deb http://security.debian.org/debian-security/ buster/updates main contrib non-free

# backports
deb https://deb.debian.org/debian/ buster-backports main contrib non-free

# virtualbox
deb [arch=amd64] https://download.virtualbox.org/virtualbox/debian/ buster contrib


Un truc en trop, un truc en moins ?
Merci,


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#2 21-10-2020 13:07:01

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.10 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

Je n’utilise pas le noyau des backports sur mon serveur basé sur une Debian stable, mais il semble pouvoir s’installer sans aucun souci :

apt install -s linux-image-amd64/buster-backports


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Version choisie « 5.8.10-1~bpo10+1 » (Debian Backports:buster-backports [amd64]) pour « linux-image-amd64 »
Les paquets supplémentaires suivants seront installés :
  linux-image-5.8.0-0.bpo.2-amd64
Paquets suggérés :
  linux-doc-5.8 debian-kernel-handbook
Paquets recommandés :
  firmware-linux-free apparmor
Les NOUVEAUX paquets suivants seront installés :
  linux-image-5.8.0-0.bpo.2-amd64
Les paquets suivants seront mis à jour :
  linux-image-amd64
1 mis à jour, 1 nouvellement installés, 0 à enlever et 4 non mis à jour.
Inst linux-image-5.8.0-0.bpo.2-amd64 (5.8.10-1~bpo10+1 Debian Backports:buster-backports [amd64])
Inst linux-image-amd64 [4.19+105+deb10u7] (5.8.10-1~bpo10+1 Debian Backports:buster-backports [amd64])
Conf linux-image-5.8.0-0.bpo.2-amd64 (5.8.10-1~bpo10+1 Debian Backports:buster-backports [amd64])
Conf linux-image-amd64 (5.8.10-1~bpo10+1 Debian Backports:buster-backports [amd64])


Jouer sous Debian ? Facile !

Hors ligne

#3 21-10-2020 13:24:05

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

vv222 a écrit :

Je n’utilise pas le noyau des backports sur mon serveur basé sur une Debian stable, mais il semble pouvoir s’installer sans aucun souci :


Ah oui mais ça, je l'ai fait il y a un mois ou deux (je ne sais plus trop), ma question (peut-être mal posée) était de savoir comment faire pour suivre l'évolution des versions, en utilisant des commandes d'aptitude -- si c'est possible.


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#4 21-10-2020 13:30:02

bendia
Chadministrateur
Distrib. : openSUSE Tumbleweed, Buster
Noyau : Linux 5.9.1-2-default + Linux 4.19.0-12-amd64
(G)UI : Gnome + Console et un peu Fluxbox
Inscription : 20-03-2012
Site Web

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

Est-ce que par hasard, la réponse ne se trouverait pas dans notre wiki ? https://debian-facile.org/doc:systeme:a … -backports

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

Hors ligne

#5 21-10-2020 15:29:36

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

bendia a écrit :

Est-ce que par hasard, la réponse ne se trouverait pas dans notre wiki ? https://debian-facile.org/doc:systeme:a … -backports

Je ne sais pas.
Ne comprenant rien au § sur lequel je suis tombé en suivant le lien, je suis remonté tout en haut de la page et j'ai commencé à lire.
Et très vite je suis tombé sur le mot "sid" que depuis 20 ans je ne décode pas, pas plus que son copain "stretch" et un troisième dont j'ai zappé le nom ; je l'avais déjà écrit à Debian Alain il y a qq temps, je ne capte pas (car ce n'est pas mémorisable) tous ces noms qui ne représentent rien. "stable" ça représente quelque chose, "sid" ça représente keud. Pour moi.

Et à partir de là, tout ce qui est construit là-dessus s'écroule.

En plus je lis dans l'intro

En dehors de ça, si vous voulez mélanger stable et une testing/unstable/experimental, alors vous devriez prendre rendez-vous d'urgence chez votre garagiste pour qu'il s'occupe de votre carie.

Mais est-ce qu'avoir activé les backports entre dans cette catégorie ?
Je ne sais pas, donc j'avance sur des œufs...

Ensuite je vois les priorités, qui me font penser à des joujous de développeurs.

Et de fil en aiguille de lien en lien je me suis retrouvé sur https://debian-facile.org/doc:systeme:a … -backports où je vois bien écrit

stable-backports   
Dépôt de rétroportages: optionnel
propose des nouvelles versions de paquets issus de la branche “testing” pour fonctionner sur une Debian stable. On y trouvera des versions plus récentes de certains paquets populaires, comme libreoffice ou le noyau Linux.
ATTENTION ! Les dépôts backports ne fonctionneront qu’avec le nom de code, par exemple pour la stable actuelle, buster-backports et non avec le nom de branche : stable-backports.


Et c'est bien ce que j'ai dans mon sources.list :

# backports
deb https://deb.debian.org/debian/ buster-backports main contrib non-free


Alors pourquoi ça ne me propose pas de passer en 5.8.x ? Surtout si je lis, tout en bas de la page https://debian-facile.org/doc:system:ap … ist:buster,

Les paquets installés depuis le dépôt backports sont automatiquement mis à jour vers les futures versions fournies par ce même dépôt, comme les paquets issus de la branche principale ; seule la mise à niveau initiale vers la version rétroportée nécessite cette déclaration explicite de la branche.


Tout cela me semble bien mystérieux.

Dernière modification par jpt (21-10-2020 15:31:20)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#6 21-10-2020 18:02:44

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.10 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

jpt a écrit :

ma question (peut-être mal posée) était de savoir comment faire pour suivre l'évolution des versions, en utilisant des commandes d'aptitude -- si c'est possible.



Il suffit de retirer le -s de la commande que j’ai partagée pour installer le noyau Linux 5.8 sur Debian stable. Si tu tiens à utiliser aptitude, la commande équivalente à apt install est aptitude install.


Jouer sous Debian ? Facile !

Hors ligne

#7 21-10-2020 18:40:59

bendia
Chadministrateur
Distrib. : openSUSE Tumbleweed, Buster
Noyau : Linux 5.9.1-2-default + Linux 4.19.0-12-amd64
(G)UI : Gnome + Console et un peu Fluxbox
Inscription : 20-03-2012
Site Web

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

@vv222: je pense que la question est de savoir pourquoi apt full upgrade ne met pas à jour vers 5.8.bpo alors que 5.7.bpo est installé, a priori via le meta-paquet linux-image-amd64.

Peut-être pourrait-on être aidé par le retour de

apt policy linux-image-amd64



Edit : Oups, typo dans la commande, corrigée tongue

Dernière modification par bendia (21-10-2020 18:52:18)


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

Hors ligne

#8 21-10-2020 19:21:48

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

vv222 a écrit :

Il suffit de retirer le -s de la commande que j’ai partagée pour installer le noyau Linux 5.8 sur Debian stable. Si tu tiens à utiliser aptitude, la commande équivalente à apt install est aptitude install.


D'accord, et je vais sans doute le faire demain matin (à cette heure-ci, récupérer 50 Mo quand on est ravitaillé par les corbeaux n'est pas une bonne idée), mais il y a quand même un truc que je ne comprends pas et que bendia a bien senti :

bendia a écrit :

@vv222: je pense que la question est de savoir pourquoi apt full upgrade ne met pas à jour vers 5.8.bpo alors que 5.7.bpo est installé, a priori via le meta-paquet linux-image-amd64.

Peut-être pourrait-on être aidé par le retour de

apt policy linux-image-amd64


Pas de problème, mais il y a un mystère :

# apt policy linux-image-amd64
linux-image-amd64:
  Installé : 4.19+105+deb10u7
  Candidat : 4.19+105+deb10u7
 Table de version :
     5.8.10-1~bpo10+1 100
        100 https://deb.debian.org/debian buster-backports/main amd64 Packages
 *** 4.19+105+deb10u7 500
        500 http://security.debian.org/debian-security buster/updates/main amd64 Packages
        100 /var/lib/dpkg/status
     4.19+105+deb10u6 500
        500 https://deb.debian.org/debian buster/main amd64 Packages
# uname -r
5.7.10


Merci pour le coup de main.

PS :

vv222 a écrit :

Si tu tiens à utiliser aptitude, la commande équivalente à apt install est aptitude install.

aptitude j'en ai un peu parlé là, je reste circonspect... scratchhead.gif

Dernière modification par jpt (21-10-2020 19:25:41)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#9 21-10-2020 19:51:03

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.10.0-8-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

le noyau officiel de buster est le 4.19

le noyau backporté est le 5.8 (adapté de testing à stable)

pour l'avoir , il faut faire

apt install -t buster-backports linux-image-5.8.0-0.bpo.2-amd64  linux-headers-5.8.0-0.bpo.2-amd64


l'option "-t" suivie du nom "buster-backports" demande d'aller chercher dans le dépôt des backports , spécialement .

Hors ligne

#10 21-10-2020 20:08:44

bendia
Chadministrateur
Distrib. : openSUSE Tumbleweed, Buster
Noyau : Linux 5.9.1-2-default + Linux 4.19.0-12-amd64
(G)UI : Gnome + Console et un peu Fluxbox
Inscription : 20-03-2012
Site Web

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

Bon, ben ton noyau, il ne vient pas de linux-image-amd64 a priori, mais tu as du installer directement le noyau 5.7 à la manière de ce que propose Debian Alain au dessus (et ce qui provoquera donc le même phénomène lors du passage à 5.9).

Ça doit pouvoir se voir avec

apt policy linux-image-5.7

(Y'a p'tet mieux pour filtrer). Tu devrais y voir une ligne Installé : linux-image-5.7.10-bla

Edit : et donc, l'indication de @vv222 pour installer le paquet linux-image-amd64 devrait donc installer le noyau que tu veux et le mettre à jour le prochain coup wink


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

Hors ligne

#11 21-10-2020 20:43:05

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.10.0-8-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

si le noyau 5.8 t'intéresse , jpt , comme je crois que tu vas le retravailler , je te laisse cette commande :

apt install -s -t buster-backports linux-source


retire le -s  (simulate)
tu trouveras le fichier linux-source-5.8.tar.xz dans /usr/src/

effectivement , dans mon post #9 , je suis parti du principe que tu voulais l'installer .

j'avais oublié que tu retravaille tes noyaux rapport à ton imprimante je crois .

Dernière modification par Debian Alain (21-10-2020 22:20:10)

Hors ligne

#12 21-10-2020 22:55:44

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

Bonsoir,

concernant les 2 posts d'Alain, je n'ai pas pu tout à l'heure poster ce qui suit, tu y verras plus clair (et les autres aussi) -- ça vient de ma discussion résolue sur l'AMD Ryzen 3 3200G, Debian 5.7.10 backport, et l'écran noir.

Petit retour en arrière (14 septembre)
... une dernière manip à tenter, suite à lecture d'un post ici (http://forums.debian.net/viewtopic.php?f=17&t=145018), qui dit en substance :

        # apt install -t buster-backports linux-image-amd64


Et chalu suit au post suivant avec

apt install -t buster-backports install linux-image-amd64 firmware-amd-graphics

J'ai donc migré ma 4.19.118 en suivant les conseils du lien, puis chalu en a remis une couche et voilà comment je me suis retrouvé en 5.7.0-0.bpo.2-amd64 puis quelques jours plus tard en 5.7.10 sans que j'ai rien demandé.

Pour bendia : ça ressemble plus à la réalité ! +1 !

# apt policy linux-image-5.7
linux-image-5.7.0-0.bpo.2-amd64:
  Installé : 5.7.10-1~bpo10+1
  Candidat : 5.7.10-1~bpo10+1
 Table de version :
 *** 5.7.10-1~bpo10+1 100
        100 /var/lib/dpkg/status
linux-image-5.7.0-0.bpo.2-amd64-unsigned:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :


Y a qu'un truc que je ne capte pas, c'est 5.7.0-0.bpo.2 d'un côté et 5.7.10-1~bpo10+1 de l'autre.

Plus qu'à trouver pourquoi la 5.8 ne m'est pas proposée et, oui Alain, il me faudra les sources pour recompiler le bazar, je vais partir sur ton post #11.
Et j'aimerais bien avoir les pingouins au boot -- je ne les ai vus qu'une fois ou deux.
Bien compliqué, tout ça, tongue

Dernière modification par jpt (21-10-2020 23:00:33)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#13 21-10-2020 23:12:03

bendia
Chadministrateur
Distrib. : openSUSE Tumbleweed, Buster
Noyau : Linux 5.9.1-2-default + Linux 4.19.0-12-amd64
(G)UI : Gnome + Console et un peu Fluxbox
Inscription : 20-03-2012
Site Web

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

jpt a écrit :

Plus qu'à trouver pourquoi la 5.8 ne m'est pas proposée

Ben y'a l'explication avec le retour des commandes plus haut il me semble, parce-que 5.8 et 5.7 ne sont pas deux versions différentes du paquet linux-image-*, mais deux paquets différents.

Donc, pour des montés en version il doit falloir installer linux-image-amd64 avec la commande donnée par @vv222 plus haut pour prendre celui des backports.


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

Hors ligne

#14 22-10-2020 09:58:10

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

bendia a écrit :

jpt a écrit :

Plus qu'à trouver pourquoi la 5.8 ne m'est pas proposée

Ben y a l'explication avec le retour des commandes plus haut il me semble, parce que 5.8 et 5.7 ne sont pas deux versions différentes du paquet linux-image-*, mais deux paquets différents.

OK, et donc, juste pour que je sois bien sûr de mon coup,

bendia a écrit :

pour des montées en version il doit falloir installer linux-image-amd64 avec la commande donnée par @vv222 plus haut pour prendre celui des backports.

à faire à chaque changement de version mineure, on est bien d'accord.

Bon, je vais tester ce matin et je vous dis.
Stay tuned...


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#15 22-10-2020 11:08:28

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.10 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

jpt a écrit :

bendia a écrit :

pour des montées en version il doit falloir installer linux-image-amd64 avec la commande donnée par @vv222 plus haut pour prendre celui des backports.

à faire à chaque changement de version mineure, on est bien d'accord.


Non, à faire une seule fois, ensuite ton noyau suivra les nouvelles arrivées de noyaux dans les backports simplement avec un apt upgrade. C’est bien pour ça que j’ai proposé cette commande.


Jouer sous Debian ? Facile !

Hors ligne

#16 22-10-2020 11:17:49

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

vv222 a écrit :

jpt a écrit :

bendia a écrit :

pour des montées en version il doit falloir installer linux-image-amd64 avec la commande donnée par @vv222 plus haut pour prendre celui des backports.

à faire à chaque changement de version mineure, on est bien d'accord.


Non, à faire une seule fois, ensuite ton noyau suivra les nouvelles arrivées de noyaux dans les backports simplement avec un apt upgrade. C’est bien pour ça que j’ai proposé cette commande.


Et c'est bien pour ça que j'ai ouvert cette discussion, puisqu'il semblerait, à preuve du contraire, que ça ne le fasse pas, chez moi : je suis passé en backport 5.7 et ça ne veut pas en bouger, la preuve avec ça, exécuté il y a 10 secondes :

# apt -s upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants seront mis à jour :
  firmware-amd-graphics virtualbox-6.1
2 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Inst virtualbox-6.1 [6.1.14-140239~Debian~buster] (6.1.16-140961~Debian~buster Oracle Corporation:download.virtualbox.org [amd64])
Inst firmware-amd-graphics [20200817-1~bpo10+1] (20200918-1~bpo10+1 Debian Backports:buster-backports [all])
Conf virtualbox-6.1 (6.1.16-140961~Debian~buster Oracle Corporation:download.virtualbox.org [amd64])
Conf firmware-amd-graphics (20200918-1~bpo10+1 Debian Backports:buster-backports [all])


Tu vois le malaise ?
Alors que si je fais

# aptitude install -s -t buster-backports linux-source linux-headers-5.8.0-0.bpo.2-amd64
Les NOUVEAUX paquets suivants vont être installés :    
  linux-config-5.8{a} linux-headers-5.8.0-0.bpo.2-amd64 linux-headers-5.8.0-0.bpo.2-common{a} linux-kbuild-5.8{a} linux-source
  linux-source-5.8{a}
0 paquets mis à jour, 6 nouvellement installés, 0 à enlever et 228 non mis à jour.
Il est nécessaire de télécharger 128 Mo d'archives. Après dépaquetage, 177 Mo seront utilisés.

Note: Using 'Simulate' mode.
Voulez-vous continuer ? [Y/n/?] n
Abandon.
 

ça semble déjà plus cohérent...
Que faire, OMG, que faire ?


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#17 22-10-2020 11:20:27

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.10.0-8-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

d'accord vv222 ,  smile  smile  smile   (bonjour , au fait)

mais est ce que le fait de recompiler son kernel ne casse pas  cette procédure ?

Dernière modification par Debian Alain (22-10-2020 11:23:07)

Hors ligne

#18 22-10-2020 11:41:27

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

Le problème chez apt c'est qu'ils ne sont pas cohérents, quand ils sortent les infos, regardez (je résume la sortie et réorganise la seconde ligne, celle avec "NOUVEAUX") :

apt install -s -t buster-backports linux-source linux-headers-5.8.0-0.bpo.2-amd64
Les paquets supplémentaires suivants seront installés :
  linux-config-5.8 linux-headers-5.8.0-0.bpo.2-common linux-kbuild-5.8 linux-source-5.8
Les NOUVEAUX paquets suivants seront installés :
  linux-config-5.8 linux-headers-5.8.0-0.bpo.2-common linux-kbuild-5.8 linux-source-5.8 linux-headers-5.8.0-0.bpo.2-amd64 linux-source
0 mis à jour, 6 nouvellement installés, 0 à enlever et 228 non mis à jour.


pas logique cette ligne, qui devrait être :

Les NOUVEAUX paquets suivants seront installés :
  linux-headers-5.8.0-0.bpo.2-amd64 linux-source

car 4 supplémentaires + 2 NOUVEAUX ça fait 6, hé ouais, comme on dit chez sosh...



Vous voulez l'intégralité ? :

# apt install -s -t buster-backports linux-source linux-headers-5.8.0-0.bpo.2-amd64
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
  linux-config-5.8 linux-headers-5.8.0-0.bpo.2-common linux-kbuild-5.8 linux-source-5.8
Paquets suggérés :
  qtbase5-dev
Les NOUVEAUX paquets suivants seront installés :
  linux-config-5.8 linux-headers-5.8.0-0.bpo.2-amd64 linux-headers-5.8.0-0.bpo.2-common linux-kbuild-5.8 linux-source linux-source-5.8
0 mis à jour, 6 nouvellement installés, 0 à enlever et 228 non mis à jour.
Inst linux-config-5.8 (5.8.10-1~bpo10+1 Debian Backports:buster-backports [amd64])
Inst linux-headers-5.8.0-0.bpo.2-common (5.8.10-1~bpo10+1 Debian Backports:buster-backports [all])
Inst linux-kbuild-5.8 (5.8.10-1~bpo10+1 Debian Backports:buster-backports [amd64])
Inst linux-headers-5.8.0-0.bpo.2-amd64 (5.8.10-1~bpo10+1 Debian Backports:buster-backports [amd64])
Inst linux-source-5.8 (5.8.10-1~bpo10+1 Debian Backports:buster-backports [all])
Inst linux-source (5.8.10-1~bpo10+1 Debian Backports:buster-backports [all])
Conf linux-config-5.8 (5.8.10-1~bpo10+1 Debian Backports:buster-backports [amd64])
Conf linux-headers-5.8.0-0.bpo.2-common (5.8.10-1~bpo10+1 Debian Backports:buster-backports [all])
Conf linux-kbuild-5.8 (5.8.10-1~bpo10+1 Debian Backports:buster-backports [amd64])
Conf linux-headers-5.8.0-0.bpo.2-amd64 (5.8.10-1~bpo10+1 Debian Backports:buster-backports [amd64])
Conf linux-source-5.8 (5.8.10-1~bpo10+1 Debian Backports:buster-backports [all])
Conf linux-source (5.8.10-1~bpo10+1 Debian Backports:buster-backports [all])

Dernière modification par jpt (22-10-2020 11:44:49)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#19 22-10-2020 12:03:33

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.10 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

jpt a écrit :

Le problème chez apt c'est qu'ils ne sont pas cohérents, quand ils sortent les infos



Le problème avec jpt c’est qu’à chaque fois qu’il ne comprend pas ce qui est écrit sous son nez, tout simplement parce qu’il ne prend pas le temps de le lire. Il préfère mettre ça sur le dos des développeurs et mainteneurs, c’est plus simple d’accuser gratuitement des personnes qui n’y sont pour rien.

Avec bien sûr comme conséquence que bientôt plus personne ne perdra du temps à essayer de le dépanner.


Jouer sous Debian ? Facile !

Hors ligne

#20 22-10-2020 12:06:18

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.10.0-8-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

notes :

jpt , çà ne sert à rien de préciser linux-source-5.8 , linux-source télécharge automatiquement la dernière version présente dans les dépôts .

linux-config : normal , c'est le fichier de configuration du kernel

linux-headers : normal , "common" et "amd64" sont les deux composantes des headers .

linux-kbuild : normal , là aussi . je sais plus ce que c'est . la libc , je crois (mais pas  sûr) .

tu vois , déjà là , çà fait au moins 5 paquets .

pour marcher un peu dans le sens de vv222 , tu sais combien de paquets gère debian ?

à peu près 50,000 (vraiment à la louche) . tu te sens capable de maintenir à toi tout seul autant de paquets ?

imagine la somme de travail des mainteneurs ...

en plus , il ne t'aura pas échappé que les kernels sont particulièrement  actifs ces temps - ci ...

mais , vu comment t'es parti , tu voudra sans doute participer au développement de linux .  smile  smile  smile

donc , installe "reportbug" , configure le et sert toi - en . çà te sera très utile pour faire la chasse aux bugs .  big_smile

aussi "apt-listbugs" . big_smile

amicalement ,

alain .

coyotus.png

Dernière modification par Debian Alain (22-10-2020 12:28:53)

Hors ligne

#21 22-10-2020 12:13:43

Elzen
Modérateur
Distrib. : Debian Sid GNU/Linux
Noyau : amd64 (à jour le vendredi)
(G)UI : Touhy
Inscription : 01-07-2014

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

En l'occurrence, les « NOUVEAUX » paquets sont ceux qui n'étaient pas présents sur ta machine avant l'installation, mais qui le seront une fois la procédure d'installation terminée. Donc ça correspond aux paquets que tu as demandé plus les paquets supplémentaires qu'il est nécessaire d'installer en raison des dépendances.

C'est en fait ce que tu demanderais comme affichage qui serait incohérent, puisque ça ne listerait pas l'ensemble des paquets en instance d'installation, en plus d'être inutile, puisque ça ne ferait que de redonner l'exacte liste de paquets que tu as demandée toi-même au lancement de la commande et que donc tu connais déjà. Au lieu de ça, les développeurs d'apt ont considéré qu'il était beaucoup plus intéressant de te lister, d'une part, ce qu'il y a besoin d'ajouter pour installer ce que tu demandes ; et d'autre part, un récapitulatif de l'ensemble des paquets qui seront installés, que ce soit à ta demande ou par nécessité. De cette manière, tu peux regarder soit l'une, soit l'autre de ces deux lignes, en fonction de ta convenance. Ce qui est plus efficace à tous points de vue.

Hors ligne

#22 22-10-2020 12:36:30

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

Debian Alain a écrit :

jpt, ça ne sert à rien de préciser linux-source-5.8, linux-source télécharge automatiquement la dernière version présente dans les dépôts.

Mais je ne l'ai pas précisé :

jpt a écrit :

# aptitude install -s -t buster-backports linux-source linux-headers-5.8.0-0.bpo.2-amd64


Debian Alain a écrit :

mais, vu comment t'es parti, tu voudras sans doute participer au développement de linux.

Ça serait un plaisir, si j'en avais le temps.
Mais je sens venir une recompilation de kernel 5.8 qui va encore me prendre des plombes...


Elzen a écrit :

--snip--

En fait je pense qu'il s'agit peut-être d'un problème de traduction, "supplémentaires" et "nouveaux" sont + ou - similaires.


Et au final, il y a un problème dans ma config, dont on dirait qu'elle ne fonctionne pas comme attendu, ou pas ?

Dernière modification par jpt (22-10-2020 12:37:24)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#23 22-10-2020 12:41:50

bendia
Chadministrateur
Distrib. : openSUSE Tumbleweed, Buster
Noyau : Linux 5.9.1-2-default + Linux 4.19.0-12-amd64
(G)UI : Gnome + Console et un peu Fluxbox
Inscription : 20-03-2012
Site Web

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

@kpt : a priori, il y a toutes les explications dans ce fil pour te dépanner. On va essayer de le faire méthodiquement pour que ça soit explicite :

Peux-tu (re-) donner le retour de

apt policy linux-image-amd64


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

Hors ligne

#24 22-10-2020 12:48:06

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

# apt policy linux-image-amd64
linux-image-amd64:
  Installé : 4.19+105+deb10u7
  Candidat : 4.19+105+deb10u7
 Table de version :
     5.8.10-1~bpo10+1 100
        100 https://deb.debian.org/debian buster-backports/main amd64 Packages
 *** 4.19+105+deb10u7 500
        500 http://security.debian.org/debian-security buster/updates/main amd64 Packages
        100 /var/lib/dpkg/status
     4.19+105+deb10u6 500
        500 https://deb.debian.org/debian buster/main amd64 Packages
 


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#25 22-10-2020 12:52:01

bendia
Chadministrateur
Distrib. : openSUSE Tumbleweed, Buster
Noyau : Linux 5.9.1-2-default + Linux 4.19.0-12-amd64
(G)UI : Gnome + Console et un peu Fluxbox
Inscription : 20-03-2012
Site Web

Re : Rester bloqué en 5.7.10, est-ce bien raisonnable ?

Peux-tu déduire du retour de cette commande si le paquet linux-image-amd64 installé sur ton système l'est depuis le dépôt buster-backports ou pas ?

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

Hors ligne

Pied de page des forums