Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-10-2020 18:50:41

Nononat
Membre
Inscription : 25-10-2020

Pb installation Debian: sans UEFI :RADEON NOK - avec UEFI :GRUB NOK

Bonjour à tous,

Habitué depuis de nombreuses année à Linux (Magéia), je suis tenté pour essayer Debian.
Je souhaite l'installer sur un portable Asus X72 comme seul OS (pas de Windows).
J'ai téléchargé l'image amd_x64 et mis cette image sur une clé USB (via Isodumper).
J'ai essayé plusieurs fois de faire l'installation dans différents modes mais je suis confronté à chaque fois à un blocage ou un échec.

Installation sans UEFI (désactivé dans le BIOS):
L'installation se déroule sans problème mais au lancement de la machine, Grub fonctionne correctement mais j'ai ensuite une message furtif :
"[drm:radeon_pci_probe [radeon]] *ERROR* radeon for R600 or later requires firmware installed" puis une console de commande. Bref, l'interface graphique ne se lance pas.
Je n'ai pas trouvé comment faire pour charger le microgiciel de ma carte graphique une fois l'installation terminée.

Face à ce blocage, j'ai reformaté mon disque pour faire une installation avec UEFI:
L'installation en mode graphique se déroule correctement jusqu'à l'installation de Grub où selon les tentatives j'ai obtenu les messages suivants:

Impossible d'installer GRUB dans dummy
L’exécution  de "grub-install dummy" a échoué. Cette erreur est fatale.

Bien qu'ayant cherché dans les différents posts de votre site, je n'ai pas trouvé de solution pour cette erreur. Le guide d'installation en multiboot est orienté avec un OS Windows déjà présent.

Pouvez-vous m'aider pour faire fonctionner mon installation dans l'un ou l'autre de ces 2 cas.
Merci

Hors ligne

#2 25-10-2020 19:04:18

raleur
Membre
Inscription : 03-10-2014

Re : Pb installation Debian: sans UEFI :RADEON NOK - avec UEFI :GRUB NOK

Nononat a écrit :

Je n'ai pas trouvé comment faire pour charger le microgiciel de ma carte graphique une fois l'installation terminée.


Il suffit d'activer la section non-free dans les dépôts et installer le paquet firmware-amd-graphics.

Nononat a écrit :

L’exécution  de "grub-install dummy" a échoué. Cette erreur est fatale.


Il faut basculer sur la console de logs avec Ctrl+Alt+F4 pour voir les messages d'erreur plus précis. Il y a plusieurs causes possibles.
De toute façon sans l'erreur de GRUB tu aurais rencontré le même problème de firmware manquant qui n'a rien à voir avec le mode d'amorçage.

Dernière modification par raleur (25-10-2020 19:54:50)


Il vaut mieux montrer que raconter.

Hors ligne

#3 25-10-2020 21:23:18

Nononat
Membre
Inscription : 25-10-2020

Re : Pb installation Debian: sans UEFI :RADEON NOK - avec UEFI :GRUB NOK

J'ai enfin réussi à résoudre mon problème de firmware de la carte graphique avec la commande:
apt-get update && apt-get install firmware-amd-graphics

Merci de votre aide et de votre site.

Hors ligne

#4 25-10-2020 21:25:01

Nononat
Membre
Inscription : 25-10-2020

Re : Pb installation Debian: sans UEFI :RADEON NOK - avec UEFI :GRUB NOK

Comment fait-on pour passer le post en "Résolu" ?

Hors ligne

Pied de page des forums