Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-10-2020 10:50:00

tescan
Membre
Distrib. : Debian testing
Noyau : 4.19.0-5
(G)UI : Cinnamon
Inscription : 27-07-2019

Proplème avec pilote Nvidia

Bonjour,


$ cat /etc/issue
Debian GNU/Linux bullseye/sid \n \l
 


Distribution maintenue régulièrement, et démarrant avec un pilote nvidia propriétaire depuis 2018

Ce matin au démarrage je constate:

- [FAILED]failed to start  Local kernel modules
- [FAILED]failed to start  NVIDIA Persistence Daemon

puis

- Vérifiez vos pilotes video, Votre système est actuellement sans accéleration matérielle video

Le système démarre avec "nouveau"


$ inxi -G

Graphics:
  Device-1: NVIDIA GK106 [GeForce GTX 660] driver: N/A
  Display: x11 server: X.Org 1.20.8 driver: nouveau,vesa
  unloaded: fbdev,modesetting resolution: 1920x1080
  OpenGL: renderer: llvmpipe (LLVM 10.0.1 256 bits) v: 3.3 Mesa 20.1.9
 


La CG:


$ lspci -k | grep -A3 VGA

01:00.0 VGA compatible controller: NVIDIA Corporation GK106 [GeForce GTX 660] (rev a1)
  Subsystem: Micro-Star International Co., Ltd. [MSI] GK106 [GeForce GTX 660]
  Kernel modules: nvidia
01:00.1 Audio device: NVIDIA Corporation GK106 HDMI Audio Controller (rev a1)
 


Le pilote propriétaire est installé:


# aptitude -s install nvidia-driver xserver-xorg-video-nvidia nvidia-settings
 
nvidia-driver est déjà installé avec la version demandée (450.66-1)
xserver-xorg-video-nvidia est déjà installé avec la version demandée (450.66-1)
nvidia-settings est déjà installé avec la version demandée (450.66-1)
nvidia-driver est déjà installé avec la version demandée (450.66-1)
xserver-xorg-video-nvidia est déjà installé avec la version demandée (450.66-1)
nvidia-settings est déjà installé avec la version demandée (450.66-1)
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.
Charger/installer/enlever des paquets.
 


Une idée pourquoi subitement le pilote proprio n'est pas/plus pris en compte?

Hors ligne

#2 26-10-2020 11:00:42

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Proplème avec pilote Nvidia

Bonjour
le driver nvidia est incompatible avec le noyau 4.9 (echec du building des modules )

ça commence ici => https://debian-facile.org/viewtopic.php?id=28470

et ici => https://debian-facile.org/viewtopic.php?id=28501

et la => https://debian-facile.org/viewtopic.php?id=28502

etc ..........

nvidia annonce un retard pour rendre le driver compatible avec le 5.9.1-1 (mi novembre ou plus tard )
il est conseillé de rester bloqué sur le 5.8 le temps que le souci soit résolu

remarque:
tu utilise une carte "NVIDIA Corporation GK106 [GeForce GTX 660]" , du Keppler (moi aussi en autre )
elle va finir par ne plus être prise en charge sur les futures debian avec le driver nonfree
j'ai testé le driver du dépôt  "expérimental" avec une GTX750 et le noyau 5.9 cela a fonctionné
mais cuda pose problème donc abandonné .

Dernière modification par robert2a (26-10-2020 11:17:07)

Hors ligne

#3 26-10-2020 11:53:51

tescan
Membre
Distrib. : Debian testing
Noyau : 4.19.0-5
(G)UI : Cinnamon
Inscription : 27-07-2019

Re : Proplème avec pilote Nvidia

Démarré sur le noyau 5.8.0-2 et tout fonctionne.
Merci!

Hors ligne

Pied de page des forums