Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 17-11-2020 17:41:49

®omain
Membre
Distrib. : Debian GNU/Linux 10 (buster) 10.6
Noyau : Linux 4.19.0-12-amd64
Inscription : 16-11-2020

Re : L'interface GNOME ne fonctionne pas, mais celle Xfce fonctionne

Debian Alain a écrit :



que donne , sur chacune des machines , les commandes  suivantes : ?

df -h


free -h


dmesg -l crit | tail -100


dmesg -l err | tail -100



pour commencer ....



Debian sur mon PC de bureau i5-9400F, installation directe, sans VM.

romain@Debian-Fixe:~$ df -h
Sys. de fichiers Taille Utilisé Dispo Uti% Monté sur
udev                16G       0   16G   0% /dev
tmpfs              3,2G     18M  3,2G   1% /run
/dev/sdh3           28G    9,6G   17G  37% /
tmpfs               16G     61M   16G   1% /dev/shm
tmpfs              5,0M    4,0K  5,0M   1% /run/lock
tmpfs               16G       0   16G   0% /sys/fs/cgroup
/dev/loop4          98M     98M     0 100% /snap/core/10185
/dev/loop1         4,2M    4,2M     0 100% /snap/notepad-plus-plus/238
/dev/loop5          63M     63M     0 100% /snap/gtk-common-themes/1506
/dev/loop3          56M     56M     0 100% /snap/core18/1932
/dev/loop2         232M    232M     0 100% /snap/wine-platform-runtime/188
/dev/loop0         216M    216M     0 100% /snap/wine-platform-5-stable/10
/dev/sdh1          511M    5,2M  506M   2% /boot/efi
/dev/sdh5          181G     46G  126G  27% /home
tmpfs              3,2G     20K  3,2G   1% /run/user/1000
/dev/loop6         216M    216M     0 100% /snap/wine-platform-5-stable/12

romain@Debian-Fixe:~$ free -h
              total        used        free      shared  buff/cache   available
Mem:           31Gi       1,2Gi        28Gi       129Mi       1,9Gi        29Gi
Swap:            0B          0B          0B

root@Debian-Fixe:~$ sudo dmesg -l crit | tail -100
Rien ne ce passe

root@Debian-Fixe:/home/romain# sudo dmesg -l err | tail -100
[    4.077887] sd 6:0:0:0: [sde] No Caching mode page found
[    4.077932] sd 6:0:0:0: [sde] Assuming drive cache: write through
[   12.513313] print_req_error: I/O error, dev sr0, sector 958680
[   20.546625] print_req_error: I/O error, dev sr0, sector 958680
[   20.546689] Buffer I/O error on dev sr0, logical block 119835, async page read
[   35.450770] print_req_error: I/O error, dev sr0, sector 958680
[   43.483872] print_req_error: I/O error, dev sr0, sector 958680
[   43.483935] Buffer I/O error on dev sr0, logical block 119835, async page read
[   58.448085] print_req_error: I/O error, dev sr0, sector 958680
[   66.481118] print_req_error: I/O error, dev sr0, sector 958680
[   66.481181] Buffer I/O error on dev sr0, logical block 119835, async page read
[   80.403576] print_req_error: I/O error, dev sr0, sector 958680
[   88.436644] print_req_error: I/O error, dev sr0, sector 958680
[   88.436707] Buffer I/O error on dev sr0, logical block 119835, async page read
[  103.699538] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-38.ucode (-2)
[  103.699626] firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
[  103.699740] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-37.ucode (-2)
[  103.699838] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-36.ucode (-2)
[  103.699934] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-35.ucode (-2)
[  103.700030] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-34.ucode (-2)
[  103.700126] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-33.ucode (-2)
[  103.700221] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-32.ucode (-2)
[  103.700317] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-31.ucode (-2)
[  103.700413] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-30.ucode (-2)
[  103.700497] iwlwifi 0000:00:14.3: minimum version required: iwlwifi-9000-pu-b0-jf-b0-30
[  103.700569] iwlwifi 0000:00:14.3: maximum version supported: iwlwifi-9000-pu-b0-jf-b0-38
[  103.700642] iwlwifi 0000:00:14.3: check git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
[  104.738919] bluetooth hci0: firmware: failed to load intel/ibt-17-16-1.sfi (-2)
[  104.738983] Bluetooth: hci0: Failed to load Intel firmware file (-2)
[  111.273366] print_req_error: I/O error, dev sr0, sector 958680
[  119.306465] print_req_error: I/O error, dev sr0, sector 958680
[  119.306529] Buffer I/O error on dev sr0, logical block 119835, async page read

Hors ligne

#27 17-11-2020 17:58:29

®omain
Membre
Distrib. : Debian GNU/Linux 10 (buster) 10.6
Noyau : Linux 4.19.0-12-amd64
Inscription : 16-11-2020

Re : L'interface GNOME ne fonctionne pas, mais celle Xfce fonctionne

èfpé a écrit :


Ces retours renseignent sur le matériel, la prise en charge graphique et l'état des firmwares requis :

lspci -nnk

#paquet mesa-utils
glxinfo -B

dmesg | grep firmw


Pour l'anecdote, Debian 10 GNOME (X11/Wayland) passe très bien sur une ridicule GeForce GT 610.



romain@Debian-Fixe:~$ lspci -nnk
00:00.0 Host bridge [0600]: Intel Corporation 8th Gen Core Processor Host Bridge/DRAM Registers [8086:3ec2] (rev 07)
    Subsystem: Micro-Star International Co., Ltd. [MSI] 8th Gen Core Processor Host Bridge/DRAM Registers [1462:7b50]
    Kernel driver in use: skl_uncore
00:01.0 PCI bridge [0604]: Intel Corporation Skylake PCIe Controller (x16) [8086:1901] (rev 07)
    Kernel driver in use: pcieport
00:08.0 System peripheral [0880]: Intel Corporation Skylake Gaussian Mixture Model [8086:1911]
    Subsystem: Micro-Star International Co., Ltd. [MSI] Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th Gen Core Processor Gaussian Mixture Model [1462:7b50]
00:12.0 Signal processing controller [1180]: Intel Corporation Cannon Lake PCH Thermal Controller [8086:a379] (rev 10)
    Subsystem: Micro-Star International Co., Ltd. [MSI] Cannon Lake PCH Thermal Controller [1462:7b50]
    Kernel driver in use: intel_pch_thermal
    Kernel modules: intel_pch_thermal
00:14.0 USB controller [0c03]: Intel Corporation Cannon Lake PCH USB 3.1 xHCI Host Controller [8086:a36d] (rev 10)
    Subsystem: Micro-Star International Co., Ltd. [MSI] Cannon Lake PCH USB 3.1 xHCI Host Controller [1462:7b50]
    Kernel driver in use: xhci_hcd
    Kernel modules: xhci_pci
00:14.2 RAM memory [0500]: Intel Corporation Cannon Lake PCH Shared SRAM [8086:a36f] (rev 10)
    Subsystem: Intel Corporation Cannon Lake PCH Shared SRAM [8086:7270]
00:14.3 Network controller [0280]: Intel Corporation Wireless-AC 9560 [Jefferson Peak] [8086:a370] (rev 10)
    Subsystem: Intel Corporation Wireless-AC 9560 [Jefferson Peak] [8086:0034]
    Kernel modules: iwlwifi
00:16.0 Communication controller [0780]: Intel Corporation Cannon Lake PCH HECI Controller [8086:a360] (rev 10)
    Subsystem: Micro-Star International Co., Ltd. [MSI] Cannon Lake PCH HECI Controller [1462:7b50]
    Kernel driver in use: mei_me
    Kernel modules: mei_me
00:17.0 RAID bus controller [0104]: Intel Corporation SATA Controller [RAID mode] [8086:2822] (rev 10)
    Subsystem: Micro-Star International Co., Ltd. [MSI] SATA Controller [RAID mode] [1462:7b50]
    Kernel driver in use: ahci
    Kernel modules: ahci
00:1f.0 ISA bridge [0601]: Intel Corporation Z390 Chipset LPC/eSPI Controller [8086:a305] (rev 10)
    Subsystem: Micro-Star International Co., Ltd. [MSI] Z390 Chipset LPC/eSPI Controller [1462:7b50]
00:1f.3 Audio device [0403]: Intel Corporation Cannon Lake PCH cAVS [8086:a348] (rev 10)
    Subsystem: Micro-Star International Co., Ltd. [MSI] Cannon Lake PCH cAVS [1462:cb50]
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel
00:1f.4 SMBus [0c05]: Intel Corporation Cannon Lake PCH SMBus Controller [8086:a323] (rev 10)
    Subsystem: Micro-Star International Co., Ltd. [MSI] Cannon Lake PCH SMBus Controller [1462:7b50]
    Kernel driver in use: i801_smbus
    Kernel modules: i2c_i801
00:1f.5 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH SPI Controller [8086:a324] (rev 10)
    Subsystem: Micro-Star International Co., Ltd. [MSI] Cannon Lake PCH SPI Controller [1462:7b50]
00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet Connection (7) I219-V [8086:15bc] (rev 10)
    Subsystem: Micro-Star International Co., Ltd. [MSI] Ethernet Connection (7) I219-V [1462:7b50]
    Kernel driver in use: e1000e
    Kernel modules: e1000e
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP108 [10de:1d01] (rev a1)
    Subsystem: Micro-Star International Co., Ltd. [MSI] GP108 [GeForce GT 1030] [1462:8c98]
    Kernel driver in use: nvidia
    Kernel modules: nvidia
01:00.1 Audio device [0403]: NVIDIA Corporation GP108 High Definition Audio Controller [10de:0fb8] (rev a1)
    Subsystem: Micro-Star International Co., Ltd. [MSI] GP108 High Definition Audio Controller [1462:8c98]
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel

romain@Debian-Fixe:~$ glxinfo -B
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
Memory info (GL_NVX_gpu_memory_info):
    Dedicated video memory: 2048 MB
    Total available memory: 2048 MB
    Currently available dedicated video memory: 1892 MB
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GT 1030/PCIe/SSE2
OpenGL core profile version string: 4.6.0 NVIDIA 418.152.00
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.6.0 NVIDIA 418.152.00
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)

OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 418.152.00
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20

romain@Debian-Fixe:~$ sudo dmesg | grep firmw
[sudo] Mot de passe de romain : 
[    0.363618] Spectre V2 : Enabling Restricted Speculation for firmware calls
[  103.699538] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-38.ucode (-2)
[  103.699626] firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
[  103.699712] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-38.ucode failed with error -2
[  103.699740] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-37.ucode (-2)
[  103.699820] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-37.ucode failed with error -2
[  103.699838] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-36.ucode (-2)
[  103.699917] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-36.ucode failed with error -2
[  103.699934] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-35.ucode (-2)
[  103.700013] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-35.ucode failed with error -2
[  103.700030] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-34.ucode (-2)
[  103.700110] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-34.ucode failed with error -2
[  103.700126] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-33.ucode (-2)
[  103.700205] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-33.ucode failed with error -2
[  103.700221] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-32.ucode (-2)
[  103.700300] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-32.ucode failed with error -2
[  103.700317] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-31.ucode (-2)
[  103.700396] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-31.ucode failed with error -2
[  103.700413] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-30.ucode (-2)
[  103.700493] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-30.ucode failed with error -2
[  103.700642] iwlwifi 0000:00:14.3: check git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
[  104.738910] Bluetooth: hci0: Minimum firmware build 1 week 10 2014
[  104.738919] bluetooth hci0: firmware: failed to load intel/ibt-17-16-1.sfi (-2)
[  104.738982] bluetooth hci0: Direct firmware load for intel/ibt-17-16-1.sfi failed with error -2
[  104.738983] Bluetooth: hci0: Failed to load Intel firmware file (-2)

Hors ligne

#28 17-11-2020 18:05:00

®omain
Membre
Distrib. : Debian GNU/Linux 10 (buster) 10.6
Noyau : Linux 4.19.0-12-amd64
Inscription : 16-11-2020

Re : L'interface GNOME ne fonctionne pas, mais celle Xfce fonctionne

Debian Alain a écrit :

je répète ma question :

là on travaille sur quel support ?

la V.M. ?
le portable ? (I5 -  6200U)
ou le fixe ? (I5 - 9400F) ?

sois clair , s'il te plaît .

echo $XDG_SESSION_DESKTOP && echo $XDG_CURRENT_DESKTOP && echo $XDG_SESSION_TYPE


du -hxd2 /home | sort -h



Sur PC bureau i5-9400F, Debian direct, sans VM

romain@Debian-Fixe:~$ echo $XDG_SESSION_DESKTOP && echo $XDG_CURRENT_DESKTOP && echo $XDG_SESSION_TYPE
xfce
XFCE
x11

romain@Debian-Fixe:~$ du -hxd1 | sort -h
4,0K    ./Bureau
4,0K    ./Images
4,0K    ./Modèles
4,0K    ./Musique
4,0K    ./Public
4,0K    ./Vidéos
8,0K    ./.gnupg
132K    ./output
248K    ./.gdal
1,4M    ./.local
2,2M    ./.config
104M    ./.mozilla
617M    ./.thunderbird
727M    ./projects
1,1G    ./.cache
14G    ./Téléchargements
30G    ./Documents
46G    .

Hors ligne

#29 17-11-2020 18:17:54

®omain
Membre
Distrib. : Debian GNU/Linux 10 (buster) 10.6
Noyau : Linux 4.19.0-12-amd64
Inscription : 16-11-2020

Re : L'interface GNOME ne fonctionne pas, mais celle Xfce fonctionne

Debian Alain a écrit :

repartitionner  quoi ?

tu peux pas tout simplement créer une nouvelle V.M. ?



Sur PC portable où Home plein à 99%
J'ai supprimé 21 Go de profils Thunderbird
Pas besoin de redimentionner la partition

Hors ligne

#30 17-11-2020 18:22:57

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : L'interface GNOME ne fonctionne pas, mais celle Xfce fonctionne

çà va mieux maintenant ?

ton fixe semble bien se porter aussi ,
apparemment , rien de particulier à y signaler ...

Dernière modification par Debian Alain (17-11-2020 18:23:28)

En ligne

#31 17-11-2020 18:44:22

®omain
Membre
Distrib. : Debian GNU/Linux 10 (buster) 10.6
Noyau : Linux 4.19.0-12-amd64
Inscription : 16-11-2020

Re : L'interface GNOME ne fonctionne pas, mais celle Xfce fonctionne

Debian Alain a écrit :



pourtant j'ai bien un multiboot  stable / testing  en uefi mais chacun sur son disque .

tu me dira si je comprends bien , Romain  :

tu travailles sur une V.M. debian 9 installée sur un portable (debian 10 stable ?) ? ....

c'est çà ?



Chacun à son disque
Sur PC bureau i5-9400F : SSD interne => Windows & HD WD Black connecté USB 3 => Debian 10
Choix par "Boot menu" de l'UEFI (touche F11 chez moi)
Sur PC portable i5-6200U : SSD interne => Windows & SSD externe USB 3 => Debian

VM "Oracle" Debian 9 (à vérifier ; de l'année dernière) sous Windows.
Mais je pense aussi essayer la VM donnée par l'enseignant, sous Debian

La VM "Oracle" installée sur mes PC Portable i5-6200U et mon PC de Bureau i5-9400F

Sur oui j'ai comme OS installés,  Debian 10 sur lecteurs USB et Windows sur SSD internes

Hors ligne

#32 17-11-2020 18:45:56

®omain
Membre
Distrib. : Debian GNU/Linux 10 (buster) 10.6
Noyau : Linux 4.19.0-12-amd64
Inscription : 16-11-2020

Re : L'interface GNOME ne fonctionne pas, mais celle Xfce fonctionne

Debian Alain a écrit :

çà va mieux maintenant ?

ton fixe semble bien se porter aussi ,
apparemment , rien de particulier à y signaler ...



Oui, mais, je n'ai pas pu utiliser le même environement de bureau que la VM donnée par l'enseignant

Hors ligne

#33 17-11-2020 18:57:35

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : L'interface GNOME ne fonctionne pas, mais celle Xfce fonctionne

Debian 10 sur lecteurs USB

hum ... comment dire... pas top .
rien ne vaut un disque interne .

Windows sur SSD internes

ouaip , si w$ était installé par défaut , çà se comprend ...

Oui, mais, je n'ai pas pu utiliser le même environement de bureau que la VM donnée par l'enseignant

c'est quoi comme V.M. ?
virtualbox ?

dpkg -l | grep virtualbox



que donne , dans ta vm : ?

echo $XDG_SESSION_DESKTOP && echo $XDG_CURRENT_DESKTOP && echo $XDG_SESSION_TYPE

Dernière modification par Debian Alain (17-11-2020 19:00:52)

En ligne

#34 17-11-2020 19:00:42

èfpé
Membre
Inscription : 10-07-2016

Re : L'interface GNOME ne fonctionne pas, mais celle Xfce fonctionne

Re-,

®omain a écrit :

lspci -nnk

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP108 [10de:1d01] (rev a1)
        Subsystem: Micro-Star International Co., Ltd. [MSI] GP108 [GeForce GT 1030] [1462:8c98]
        Kernel driver in use: nvidia
        Kernel modules: nvidia

glxinfo -B

OpenGL version string: 4.6.0 NVIDIA 418.152.00


Donc tu as installé le pilote propriétaire (nvidia-driver) en version 418.152, est-ce mieux que sans ?

Il n'y a pas de firmware demandé pour nouveau. Car c'est le pilote propriétaire nvidia qui est utilisé.

Dernière modification par èfpé (18-11-2020 20:00:42)

Hors ligne

#35 17-11-2020 19:20:34

®omain
Membre
Distrib. : Debian GNU/Linux 10 (buster) 10.6
Noyau : Linux 4.19.0-12-amd64
Inscription : 16-11-2020

Re : L'interface GNOME ne fonctionne pas, mais celle Xfce fonctionne

Debian Alain a écrit :

Lubuntu , c'est LXDE , un bureau au moins  aussi léger  que Xfce si ce n'est plus .
et puis un pentium 4 , c'est un ordinosaure .
tu peux pas en changer  ?
si j'en crois -- ceci -- (j'espère pas me tromper ) ton P4 , c'est un 32 bits .


Mon vieux PC est un 36 bits, pas 32. Un 32 bits avec extension permettant d'executer les instructions 64 bits.
"address sizes    : 36 bits physical, 48 bits virtual"
J'ai Xubuntu 20 qui n'existe qu'en 64 bits.
Mais c'est très lents même pour cette page Web "Debian Facile" sans fioritures.

Puis-je utiliser cet Ordinosaure, sous LXQt, seulement pour des commande Bash RC et des Script Python de débutant ?
Et ainsi réserver mon nouveau PC i5-9400F pour Debian et Windows ?

https://ark.intel.com/content/www/fr/fr … z-fsb.html

Dernière modification par ®omain (17-11-2020 19:25:54)

Hors ligne

#36 17-11-2020 19:39:20

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : L'interface GNOME ne fonctionne pas, mais celle Xfce fonctionne

Mon vieux PC est un 36 bits, pas 32.


36 bits c'est la taille du bus d'adressage de la mémoire .
bus physique .
en virtuel cette capacité d'adressage monte à 48 bits .

le bus d'adressage , en théorie , ne permets pas , pour un 32  bits , d'adresser plus de 4 Go
seules des instructions spéciales permettent d'utiliser une ram plus grande .
disponibles surtout sur les procs 64 Bits

le microprocesseur est prévu pour gérer des mots de 32 bits .

Jeux d'instructions 32-bit



le faire fonctionner en 64 bits revient à diviser par 2 la vitesse de fonctionnement .
vu que l'on double le temps d'accès . (il faut s'y reprendre à deux fois (2 X 32 bits = 64 bits)  pour charger un mot)
pense aussi au temps que met le proc à calculer sur des mots du double pus longs que ceux de sa conception ...

En ligne

#37 17-11-2020 19:39:43

®omain
Membre
Distrib. : Debian GNU/Linux 10 (buster) 10.6
Noyau : Linux 4.19.0-12-amd64
Inscription : 16-11-2020

Re : L'interface GNOME ne fonctionne pas, mais celle Xfce fonctionne

èfpé a écrit :


Donc tu as installé le pilote propriétaire (nvidia-driver) en version 418.152, est-ce mieux que sans ?


Non ☺ car je n'ai rien fait de lourd.
Je ne sais même pas comment ajouter GNOME ou MATE !?
Mon idée, était que si GNOME plantait, c'était à cause de l'absence de pilote efficace.

Avec les manipulations précédentes, peut-on identifier l'environnement de bureau de ma VM Debian ?

Dois-je ouvir une nouvelle discution pour demander de l'aide, pour ajouter le même environnement de bureau que la VM ?

Merci

Dernière modification par ®omain (17-11-2020 19:41:03)

Hors ligne

#38 17-11-2020 19:52:54

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : L'interface GNOME ne fonctionne pas, mais celle Xfce fonctionne

Avec les manipulations précédentes, peut-on identifier l'environnement de bureau de ma VM Debian ?


echo $XDG_SESSION_DESKTOP && echo $XDG_CURRENT_DESKTOP && echo $XDG_SESSION_TYPE

(dans la V.M.)

Je ne sais même pas comment ajouter GNOME ou MATE !?


apt install --reinstall gnome

pour installer gnome



apt install --reinstall mate-desktop-environment

pour installer mate



une fois fait , reboot :

reboot



et , dans lightdm , tu peux choisir ton bureau , au démarrage .

-- Mate --
https://debian-facile.org/doc:environnement:mate

-- gnome --
https://debian-facile.org/doc:environnements:gnome

Romain  a écrit :


èfpé a écrit :

Donc tu as installé le pilote propriétaire (nvidia-driver) en version 418.152, est-ce mieux que sans ?


Non ☺ car je n'ai rien fait de lourd.

tu peux utiliser unigine pour tester ta carte graphique :
site web unigine

benchmark unigine "superposition" 
benchmark unigine "valley"
benchmark unigine "heaven"

(attention , c'est du lourd ... très lourd mme ...)

Dernière modification par Debian Alain (17-11-2020 20:47:48)

En ligne

#39 17-11-2020 20:15:19

®omain
Membre
Distrib. : Debian GNU/Linux 10 (buster) 10.6
Noyau : Linux 4.19.0-12-amd64
Inscription : 16-11-2020

Re : L'interface GNOME ne fonctionne pas, mais celle Xfce fonctionne

"webmapping@debian:~$ echo $XDG_SESSION_DESKTOP && echo $XDG_CURRENT_DESKTOP && echo $XDG_SESSION_TYPE
lightdm-xsession
MATE
x11"

Donc, j'ai MATE et GNOME dans la VM, alors j'intalle MATE dans mes installations de Debian pour avoir la même chose !?

Hors ligne

#40 17-11-2020 20:17:44

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : L'interface GNOME ne fonctionne pas, mais celle Xfce fonctionne

logiquement , oui .

as tu assez de place sur tes disques et dans tes /racines ?

En ligne

#41 17-11-2020 22:09:41

®omain
Membre
Distrib. : Debian GNU/Linux 10 (buster) 10.6
Noyau : Linux 4.19.0-12-amd64
Inscription : 16-11-2020

Re : L'interface GNOME ne fonctionne pas, mais celle Xfce fonctionne

Debian Alain a écrit :

Debian 10 sur lecteurs USB

hum ... comment dire... pas top .
rien ne vaut un disque interne .

Windows sur SSD internes

ouaip , si w$ était installé par défaut , çà se comprend ...
]


D'accord pour le branchement SATA, c'est prévu, il faut m'acheter une carte extension. Mais j'hésite entre RAID ou non RAID.

J'ai tout assemblé moi même, je fesais déjà ça sous Windows avant le plug & play, devant assigner les IRQ et canaux DMA. Ce sont d'autres compétances.

Si le HD interne de Debian est en USB 3 interne, c'est que les 4 ports SATA sont occupés par un volume RAID 5 pseudo matériel géré par la carte mère. J'ai un 5e HD pour mettre en réserve du RAID 5 mais je n'ai plus de ports SATA. D'ou mon hésitation, entre carte SATA non RAID ou RAID. Certaine carte d'extension non RAID, permette le RAID si la carte mère le prend en charge. Dans mon BIOS UEFI, il y a 6 ports, mais 2 ports sont des ports "fantômes" car il n'y a que 4 connecteurs.

Vers quel forum, demander conseil pour une carte d'extension SATA ?

J'aimerai un RAID pris en charge par Windows et Linux.

Dernière modification par ®omain (17-11-2020 22:17:52)

Hors ligne

#42 17-11-2020 22:16:33

®omain
Membre
Distrib. : Debian GNU/Linux 10 (buster) 10.6
Noyau : Linux 4.19.0-12-amd64
Inscription : 16-11-2020

Re : L'interface GNOME ne fonctionne pas, mais celle Xfce fonctionne

Debian Alain a écrit :


as tu assez de place sur tes disques et dans tes /racines ?



"/" ?

17.78 Gio.

Hors ligne

#43 17-11-2020 22:20:18

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : L'interface GNOME ne fonctionne pas, mais celle Xfce fonctionne

pour le choix entre raid et non - raid , c'est pas très important .

de toutes façons , mdadm permet de faire du raid logiciel sous linux .

En ligne

#44 17-11-2020 23:41:08

®omain
Membre
Distrib. : Debian GNU/Linux 10 (buster) 10.6
Noyau : Linux 4.19.0-12-amd64
Inscription : 16-11-2020

Re : L'interface GNOME ne fonctionne pas, mais celle Xfce fonctionne

Debian Alain a écrit :

apt install --reinstall mate-desktop-environment

pour installer mate



une fois fait , reboot :

reboot


Merci, ça à l'air de très bien fonctionner sur mon PC de bureau i5-9400F,
Il y a eu une erreur à l'installation sur mon PC portable i5-6200U mais ça fonctionne.

Merci.

Je me demande pourquoi, à chaque fois que je dois installer des paquets téléchargés sur un dépot via Internet, le DVD d'installation est requis ?

Dernière modification par ®omain (17-11-2020 23:41:45)

Hors ligne

#45 17-11-2020 23:49:36

®omain
Membre
Distrib. : Debian GNU/Linux 10 (buster) 10.6
Noyau : Linux 4.19.0-12-amd64
Inscription : 16-11-2020

Re : L'interface GNOME ne fonctionne pas, mais celle Xfce fonctionne

Est-ce grave si GParted interprète la disquette FAT12 comme en FAT16 ?
Si je ne mets pas de disquette, le lecteur gueule encore + fort et + longtemps que sans, lorsque le système y accède

Hors ligne

#46 17-11-2020 23:56:44

®omain
Membre
Distrib. : Debian GNU/Linux 10 (buster) 10.6
Noyau : Linux 4.19.0-12-amd64
Inscription : 16-11-2020

Re : L'interface GNOME ne fonctionne pas, mais celle Xfce fonctionne

Debian Alain a écrit :

pour le choix entre raid et non - raid , c'est pas très important .

de toutes façons , mdadm permet de faire du raid logiciel sous linux .


Le disque dur avec Debian restera-t-il bootble après le passage d'un port USB 3, avec un adaptateur, à un port SATA ?

À propos du RAID logiciel, est-ce possible d'avoir des disques durs en RAID accécibles par Linux et Windows ?

Autre idée + simple, il me reste un port M2,
Serait-ce un luxe de prendre un 2nd SSD M2 WD Black SN750 500 Go ?
Mon HD WD Black a vitesse É ; L : 60 ; 100 Mo/s et le SSD 3000 ; 3400 !

Dernière modification par ®omain (18-11-2020 01:50:28)

Hors ligne

#47 18-11-2020 01:55:35

®omain
Membre
Distrib. : Debian GNU/Linux 10 (buster) 10.6
Noyau : Linux 4.19.0-12-amd64
Inscription : 16-11-2020

Re : L'interface GNOME ne fonctionne pas, mais celle Xfce fonctionne

Debian Alain a écrit :

tu peux utiliser unigine pour tester ta carte graphique :
site web unigine

benchmark unigine "superposition" 
benchmark unigine "valley"
benchmark unigine "heaven"

(attention , c'est du lourd ... très lourd mme ...)


Merci mais ma résolution 16/10e intermédiaire batarde entre HD 720p et HD 1080p n'est pas proposée.
J'ai un écran de 1680 × 1050 choisi spécialement pour ne pas avoir de petit pixel est du petit texte à lire.

Errata : Si dans custom, il y a

Merci

En Low, entre 30 et 53 images / s, moyenne 40. En médium ça s'éffondre.

Mais pour de la modélisation de terrain basique, celà sera-t-il suffisant ? : une image de la surface terrestre de 100 000 × 100 000 avec un compte pixel de 16 bits représentant l'altitude. Il faut afficher le terrain avec des perspectives 3D, ça peut aller doucement pendant qu'on fait une pose et un affichage sacadé m'empèche des étudiants d'avoir 17/20 à leur projet. On n'est pas de mention uniquement si on a un PC de Gamming à 3000€

Dernière modification par ®omain (18-11-2020 02:19:53)

Hors ligne

#48 18-11-2020 11:48:12

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : L'interface GNOME ne fonctionne pas, mais celle Xfce fonctionne

Romain  a écrit :

Je me demande pourquoi, à chaque fois que je dois installer des paquets téléchargés sur un dépot via Internet, le DVD d'installation est requis



tu peux nous communiquer tes sources ?

cat -n /etc/apt/sources.list



Romain  a écrit :

Il y a eu une erreur à l'installation sur mon PC portable i5-6200U mais ça fonctionne.


quelle erreur ?
peux tu nous la poster ?

Romain  a écrit :

Le disque dur avec Debian restera-t-il bootble après le passage d'un port USB 3, avec un adaptateur, à un port SATA ?


il n'y a  que l'interface qui change . tu retires le boitier usb pour brancher  en direct ton disque sur un port sata .
donc , si le travail est  bien fait , il doit pas y avoir de bin's ....

Romain  a écrit :

À propos du RAID logiciel, est-ce possible d'avoir des disques durs en RAID accécibles par Linux et Windows ?


le raid logiciel de linux demande  un formatage particulier , donc , je pense pas .

Romain  a écrit :

Autre idée + simple, il me reste un port M2,

oui , si tu veux . les deux meilleurs sur le marché sont samsung (top qualité mais aussi très cher) et  crucial (concurrent direct) 

Romain  a écrit :

En Low, entre 30 et 53 images / s, moyenne 40. En médium ça s'éffondre.

Mais pour de la modélisation de terrain basique, celà sera-t-il suffisant ? :

pour un bon rendu , faut prévoir au strict minimum 60 Fps
sinon , j'ai pas assez d'expérience , mais pour de la modélisation ou de la 3D , vaut mieux avoir une bonne carte graphique .
une Gtx 1030 , c'est beaucoup trop léger . pense plutôt à une Rtx 2070 (nvidia) ou une RX 5700 (amd) .
mais c'est pas  du tout  les mmes prix .

Dernière modification par Debian Alain (18-11-2020 12:33:30)

En ligne

#49 18-11-2020 18:52:25

®omain
Membre
Distrib. : Debian GNU/Linux 10 (buster) 10.6
Noyau : Linux 4.19.0-12-amd64
Inscription : 16-11-2020

Re : L'interface GNOME ne fonctionne pas, mais celle Xfce fonctionne

cat -n /etc/apt/sources.list

romain@debian-ASUSPRO:~$ cat -n /etc/apt/sources.list
     1    #
     2   
     3    # deb cdrom:[Debian GNU/Linux 10.2.0 _Buster_ - Official amd64 DVD Binary-1 20191116-09:57]/ buster contrib main
     4   
     5    deb cdrom:[Debian GNU/Linux 10.2.0 _Buster_ - Official amd64 DVD Binary-1 20191116-09:57]/ buster contrib main
     6   
     7    deb http://debian.proxad.net/debian/ buster main
     8    deb-src http://debian.proxad.net/debian/ buster main
     9   
    10    deb http://security.debian.org/debian-security buster/updates main contrib
    11    deb-src http://security.debian.org/debian-security buster/updates main contrib
    12   
    13    # buster-updates, previously known as 'volatile'
    14    deb http://debian.proxad.net/debian/ buster-updates main contrib
    15    deb-src http://debian.proxad.net/debian/ buster-updates main contrib
    16   
    17    #QGis
    18    deb https://qgis.org/debian-ltr buster main
    19    deb https://qgis.org/debian buster main
    20    # deb-src https://qgis.org/debian buster main
    21    deb-src https://qgis.org/debian-ltr buster main
    22   
    23    # buster-backports
    24    deb http://deb.debian.org/debian buster-backports main contrib non-free

Erreur installation Mate sur PC portable i5-6200U :
"Erreur : GDBus.Error:org.freedesktop.systemd1.UnitMasked: Unit var.mount is masked."

Hors ligne

#50 18-11-2020 18:59:35

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : L'interface GNOME ne fonctionne pas, mais celle Xfce fonctionne

commentes la ligne no 5

les 2 lignes "deb cdrom"  doivent être désactivées .

assure toi bien d'avoir un # devant chacune de ces 2 lignes

ensuite :

apt update

poste la réponse


puis :

apt upgrade

pareil , poste la réponse

En ligne

Pied de page des forums