Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 24-11-2020 22:35:55

jahfly
Membre
Lieu : Aquitaine
Distrib. : raspbian Buster
Noyau : Raspberry pi 3
Inscription : 05-09-2017

Pas de connexion internet [résolu]

Bonjour,

Je viens vers vous car je sèche. J’ai beau cherché ? mais ...
J’ai un rpi3 sous jessie en connexion ethernet et tout fonctionnait nickel, j ai fait la mise à jour puis passé l’OS sous stretch.
C est là, que tout ce complique. Une fois rebooter plus de connexion.
Plus de possibilité de se connecter en me mettant en haut à droite de l écran.
Après quelques recherches je suis tombé sur ce sujet https://debian-facile.org/viewtopic.php?id=21137
Je me suis dit que j étais pas tout seul mais dès l essais de la première commande

 nmcli device


J ai un retour

Command no found



J ai donc testé d autre commande et voilà le retour.

ip a


2: enxb827ebe4e58f: <BROADCASTER.MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000



J’ai verfié aussi le firmware

dmesg | grep firmware


[0.090129] rpi-firmware soc firmware: attached to firmware from 2019-08-15 12:06. variant start
[0.100399] rpi-firmware soc firmware: Firmware hash is oe6........


Et pour finir quand je met ma sourie en haut à droite sur le logo de connexion barré j’ai

connection to dhcpcd lost



J avais aussi paramètré pour une ip fixe.

Pouvez vous me donnez un petit coup de main.
Merci par avance de votre aide.

Dernière modification par jahfly (29-11-2020 21:57:55)

Hors ligne

#2 24-11-2020 23:34:42

èfpé
Membre
Inscription : 10-07-2016

Re : Pas de connexion internet [résolu]

Bonsoir,

jahfly a écrit :

Après quelques recherches je suis tombé sur ce sujet https://debian-facile.org/viewtopic.php?id=21137


Le sujet concerne les connexions Wi-Fi USB et le gestionnaire NetworkManager, vraiment rien à voir.

jahfly a écrit :

Connection to dhcpcd lost


Il s'agit plus probablement du frontal pour dhcpcd5. As-tu essayé de redémarrer le démon dhcpcd ?

Dernière modification par èfpé (25-11-2020 19:34:42)

Hors ligne

#3 25-11-2020 21:32:09

jahfly
Membre
Lieu : Aquitaine
Distrib. : raspbian Buster
Noyau : Raspberry pi 3
Inscription : 05-09-2017

Re : Pas de connexion internet [résolu]

Bonsoir,

J’ai essayé de redémarrer le démon avec

systemctl start dhcpcd.service


job for dhcpcd.service failed because the control process exited with error code



J’ai donc regardé le détail

sudo systemctl status dhcpcd.service


service- dhcpcd on all interfaces
Load (/lib/systemd/system/dhcpcd.service: enable: vendor preset...
Active: failed (resultat:exit-code) sincèrement...
Process: 3640 execstart=/usr/lib/dhcpcd5/dhcpcd -q -b (code=exited, status=6)



Alors là j’ai besoin d’aide.

Hors ligne

#4 25-11-2020 22:05:58

Debian Alain
Membre
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-6-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Pas de connexion internet [résolu]

le raspi 3 n'utilise pas LXDE , comme bureau ?

Hors ligne

#5 25-11-2020 22:08:07

jahfly
Membre
Lieu : Aquitaine
Distrib. : raspbian Buster
Noyau : Raspberry pi 3
Inscription : 05-09-2017

Re : Pas de connexion internet [résolu]

LXDE ?
Qu est ce que c est ?

Dernière modification par jahfly (25-11-2020 22:09:38)

Hors ligne

#6 25-11-2020 22:14:31

Debian Alain
Membre
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-6-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Pas de connexion internet [résolu]

c'est un bureau très léger .

conçu pour les matériels peu puissants comme les raspi .

https://fr.wikipedia.org/wiki/LXDE

par contre , je n'ai pas trouvé de renseignements pour le gestionnaire internet de ce bureau .

regarde si ce livre ne peut pas t'aider ?

https://www.amazon.fr/Raspberry-Zero-Ex … 2409004377

Dernière modification par Debian Alain (25-11-2020 22:17:22)

Hors ligne

#7 25-11-2020 23:04:42

èfpé
Membre
Inscription : 10-07-2016

Re : Pas de connexion internet [résolu]

Re-,

en #3, jahfly a écrit :

Alors là j’ai besoin d’aide.


Nous aussi... peux-tu nous en dire un peu plus sur le système, les paquets installés et tes manips :

  • système ayant servi à l'installation initiale ;

  • environnement de bureau, si présent ;

  • autres gestionnaires réseau à disposition ;

  • fichier de configuration de l'adresse IP fixe.


Il serait également sympa de poster des retours ni charcutés, ni commentés, ni forgés, ni tronqués.

en #1, jahfly a écrit :

J’avais aussi paramétré pour une IP fixe.


Sous Jessie ? selon ce commentaire de juillet 2020 cela pourrait très bien être l'origine du problème.

Dernière modification par èfpé (26-11-2020 08:14:42)

Hors ligne

#8 26-11-2020 09:13:06

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Pas de connexion internet [résolu]

Hello

J’ai un rpi3 sous jessie en connexion ethernet et tout fonctionnait nickel, j ai fait la mise à jour puis passé l’OS sous stretch.


Je me souviens que pendant la migration de Jessie a Stretch , il y a plein d’arrêt concernant les fichiers de configuration
peut être un fichier a été remplacer par un nouveau


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#9 29-11-2020 19:01:08

jahfly
Membre
Lieu : Aquitaine
Distrib. : raspbian Buster
Noyau : Raspberry pi 3
Inscription : 05-09-2017

Re : Pas de connexion internet [résolu]

Bonjour,

Donc pour plus de renseignement pour vous aidez à m'aider big_smile
J'ai suivi scrupuleusement le tuto
https://www.arnaudmartin.net/2020/07/20 … s-stretch/
ma version de raspbian après mis à jour 4.19.66-v7+, c'est une version avec interface graphique.
J'ai regardé ma config pour le paramétrage d'une IP fixe et je pensais avoir fait quelque chose, mais en faite quand j'ai regardé dans etc/dhcpcd.conf tous les paramètres ont un # devant donc rien n'est pris en compte à moins qu'à l’époque j'avais changé un autre fichier en relation avec network, mais je sais plus lequel si c'est le cas.
Sinon pour etre plus precis dans quand je tape la commande

systemctl status dhcpcd.service


dhcpcd.service - dhcpcd on all interfaces
Load: load (/lib/systemd/system/dhcpcd.service; enable; vendor preset: e
Active: failed (resultat: exit-code) since Sun 2020-11-29 17:55:42 CET; 8min ag
Process: 3610 ExecStart=/usr/lib/dhcpcd5/dhcpcd -q -b (code=exited, status=6)
Raspi systemd[1]: Starting dhcpcd on all interfaces...
Raspi dhcpcd[3610]: not running dhcpcd because /etc/network/interfaces
Raspi dhcpcd[3610]: defines some interfaces that will use a
Raspi dhcpcd[3610]: DHCP client or static adress
Raspi systemd[1]: Failed to start dhcpcd on all interfaces.
Raspi systemd[1]: dhcpcd.service: Unit entered failed state.
Raspi systemd[1]: dhcpcd.service: Failed with result 'exit-code'.



èfpé@
il doit bien avoir un conflit entre dhcpcd et network
J'utilise le gestionnaire de réseau de base.

Croutons@
Je pense aussi, mais lequel?
Je veux pas faire de bêtise.

Dernière modification par jahfly (29-11-2020 19:04:22)

Hors ligne

#10 29-11-2020 19:18:42

èfpé
Membre
Inscription : 10-07-2016

Re : Pas de connexion internet [résolu]

Bonsoir,

jahfly a écrit :

systemctl status dhcpcd.service

Raspi dhcpcd[3610]: Not running dhcpcd because /etc/network/interfaces
Raspi dhcpcd[3610]: defines some interfaces that will use a
Raspi dhcpcd[3610]: DHCP client or static address


Apparemment tu as configuré l'adresse IP fixe dans /etc/network/interfaces, ce qui est déconseillé...
Note que l'interface graphique de dhcpcd (voir lien donné en #7) te permet de le faire correctement.

jahfly a écrit :

il doit bien avoir un conflit entre dhcpcd et network


C'est quoi network ? Le service networking (paquet ifupdown) ? NetworkManager n'est pas installé.

Dernière modification par èfpé (29-11-2020 23:28:42)

Hors ligne

#11 29-11-2020 19:18:52

Debian Alain
Membre
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-6-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Pas de connexion internet [résolu]

y a pas une modification du systreme d'init entre jessie et stretch ?

genre sysV init évolué en systemd .

bon , apparemment , je me trompe :

https://fr.wikipedia.org/wiki/Systemd#D … riv%C3%A9s

oui , je confirme . m'a trompé :

https://wiki.debian.org/fr/Init

Dernière modification par Debian Alain (29-11-2020 20:01:49)

Hors ligne

#12 29-11-2020 21:55:50

jahfly
Membre
Lieu : Aquitaine
Distrib. : raspbian Buster
Noyau : Raspberry pi 3
Inscription : 05-09-2017

Re : Pas de connexion internet [résolu]

Merci éfpé@

En faisant

 service --status-all



Je me suis aperçu que j’avais effectivement dhcpcd et networking qui fonctionnaient en même temps. Ça faisait un conflit.

Donc avec

sudo systemctl disable networking



Et un petit

sudo systemctl enable dhcpcd



Un reboot et le tour est joué.
Surtout que l’IP fixe me sert à rien car je l’ai déjà rendu fixe par mon modem.

Hors ligne

Pied de page des forums