Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-11-2020 18:33:45

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

[Résolu] problème carte Wifi avec Debian 10

bonjour,
Ma carte Wifi Broadcom Corporation BCM4306 802.11b/g fonctionne sur Debian 8
avec le paquet firmware-b43-installer, merci éfpé !
Mais lorsque je l'installe sur un station Debian10 : pas d'accès Wifi.

nmcli device status



DEVICE  TYPE      STATE         CONNECTION
enp2s0  ethernet  indisponible  --
wlan0   wifi      indisponible  --


rfkill list


0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no


grep -i 'fail' /var/log/syslog



wpa_supplicant[434]: wlan0: CTRL-EVENT-SCAN-FAILED ret=-16
NetworkManager[445]: <info>  [1606321542.7437] device (wlan0): state change: config -> unavailable (reason 'supplicant-failed', sys-iface-state: 'managed')


Le module paraît correctement installé:

 # lsmod |grep -i b43



b43                   454656  0
bcma                   61440  1 b43
mac80211              835584  1 b43
cfg80211              774144  2 b43,mac80211
rng_core               16384  1 b43
ssb                    90112  1 b43
mmc_core              176128  2 b43,ssb


modinfo  b43



filename:       /lib/modules/4.19.0-12-amd64/kernel/drivers/net/wireless/broadcom/b43/b43.ko
...................
depends:        mac80211,ssb,bcma,mmc_core,cfg80211,rng-core
......................
retpoline:      Y
intree:         Y
name:           b43
........


Ce qui me surprend c'est que "wlan0" n'est pas renommé ???

Dernière modification par gargamel79 (08-12-2020 10:52:38)

Hors ligne

#2 26-11-2020 17:48:30

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu] problème carte Wifi avec Debian 10

1 petite précision


# systool -v -m b43



Module = "b43"

  Attributes:
    coresize            = "454656"
    initsize            = "0"
    initstate           = "live"
    refcnt              = "0"
    taint               = ""
    uevent              = <store method only>

  Parameters:
    allhwsupport        = "0"
    bad_frames_preempt  = "0"
    btcoex              = "1"
    fwpostfix           = ""
    hwpctl              = "0"
    hwtkip              = "0"
    nohwcrypt           = "0"
    pio                 = "0"
    qos                 = "1"
    verbose             = "2"
  Sections:
    .altinstr_replacement= "0xffffffffc0c6332c"
    .altinstructions    = "0xffffffffc0c92c4e"
    .bss                = "0xffffffffc0c98040"
    .data               = "0xffffffffc0c93000"
    .exit.text          = "0xffffffffc0c6330f"
    .gnu.linkonce.this_module= "0xffffffffc0c97d00"
    .init.text          = "0xffffffffc0a27000"
    .note.Linux         = "0xffffffffc0c64024"
    .note.gnu.build-id  = "0xffffffffc0c64000"
    .orc_unwind         = "0xffffffffc0c8cd74"
    .orc_unwind_ip      = "0xffffffffc0c88e38"
    .parainstructions   = "0xffffffffc0c86de0"
    .rodata             = "0xffffffffc0c64060"
    .rodata.str1.1      = "0xffffffffc0c86e3c"
    .rodata.str1.8      = "0xffffffffc0c878f0"
    .smp_locks          = "0xffffffffc0c88ca4"
    .strtab             = "0xffffffffc0a2e438"
    .symtab             = "0xffffffffc0a28000"
    .text               = "0xffffffffc0c34000"
    .text.unlikely      = "0xffffffffc0c62fe1"
    __bug_table         = "0xffffffffc0c97c40"
    __mcount_loc        = "0xffffffffc0c85fe0"
    __param             = "0xffffffffc0c88ca8"



Mais je ne sais pas décrypter ce genre de choses.
Merci pour l'aide.

Hors ligne

#3 26-11-2020 18:34:51

deuchdeb
Moderato ma non troppo
Lieu : Ca bouge Ca bouge!!!
Distrib. : Debian 10 Buster KDE DFlinux et LinuxMintCinnamon
Noyau : Noyau stable
(G)UI : KDE Plasma 5.14, Xfce et Cinnamon
Inscription : 13-01-2010
Site Web

Re : [Résolu] problème carte Wifi avec Debian 10

Bonjour gargamel79,

Peut-être une piste selon qu'il s'agisse de  BCM4306 revision 2 ou BCM4306 révision 3, il ne faut pas installer le même paquet.

dans un cas il faudrait installer: firmware-b43legacy-installer
dans l'autre cas il faudrait installer: firmware-b43-installer

C'est ici dans le wiki Debian: https://wiki.debian.org/fr/bcm43xx#b43-b43legacy

Une fleur, c'est magique non? smile
Association Debian Facile

Hors ligne

#4 27-11-2020 11:52:19

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu] problème carte Wifi avec Debian 10

merci beaucoup pour ta réponse.
j'ai essayé firmware-b43legacy-installer mais c'est pire, il fallait s'y attendre.
Pour la rev 3, c'est bien firmware-b43-installer.
J'ai de nouveau : nmcli device status -> nmcli device status
DEVICE  TYPE      STATE         CONNECTION
enp2s0  ethernet  indisponible  --
wlan0   wifi      indisponible
---------------------
je pense qu'à partir de Debian 9 les nouveaux kernels ne gèrent plus correctement les drivers contenus dans les paquets...
Je ne me souviens plus à partir de quelle realise Debian est passé sous systemD. Je me demande si c'est lié ? roll

Hors ligne

#5 27-11-2020 20:43:57

deuchdeb
Moderato ma non troppo
Lieu : Ca bouge Ca bouge!!!
Distrib. : Debian 10 Buster KDE DFlinux et LinuxMintCinnamon
Noyau : Noyau stable
(G)UI : KDE Plasma 5.14, Xfce et Cinnamon
Inscription : 13-01-2010
Site Web

Re : [Résolu] problème carte Wifi avec Debian 10

Aurais-tu un live cd / usb d'Ubuntu ou Linux Mint récent pour voir si ça fonctionne?

Une fleur, c'est magique non? smile
Association Debian Facile

Hors ligne

#6 28-11-2020 16:42:28

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu] problème carte Wifi avec Debian 10

merci pour ta suggestion, c'est un travail de longue haleine:
.claquer un DVD
.cela fait quelques années que je n'ai pas pratiqué Ubuntu; en particulier configurer l'interface Wifi
.est-ce possible de récupérer un driver en mode live ?

Si j'ai un peu de temps, je vais tenter la manip... smile

Hors ligne

#7 29-11-2020 08:48:01

deuchdeb
Moderato ma non troppo
Lieu : Ca bouge Ca bouge!!!
Distrib. : Debian 10 Buster KDE DFlinux et LinuxMintCinnamon
Noyau : Noyau stable
(G)UI : KDE Plasma 5.14, Xfce et Cinnamon
Inscription : 13-01-2010
Site Web

Re : [Résolu] problème carte Wifi avec Debian 10

gargamel79 a écrit :

est-ce possible de récupérer un driver en mode live ?



Ça je ne sais pas mais ma suggestion est de voir si le wifi est détecté et si oui qu'est-ce qu'il y a de différent avec Debian.


Une fleur, c'est magique non? smile
Association Debian Facile

Hors ligne

#8 29-11-2020 16:11:11

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu] problème carte Wifi avec Debian 10

Je pense que pour installer un driver Wifi il faut faire une install. , être en live ne suffit pas.
Si j'installe une Xubuntu sur une autre station, je te tiens au courant.
Merci pour tes réponses.

Hors ligne

#9 08-12-2020 10:51:51

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu] problème carte Wifi avec Debian 10

J'ai installé cette carte sur sa station d'origine passée en Debian 10 (après changement de carte graphique !)
Et cela fonctionne parfaitement. Comprend qui peut roll
Je passe en résolu. Merci pour votre aide.

Hors ligne

Pied de page des forums