Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 22-12-2020 16:21:04

SwarmZz
Membre
Inscription : 31-01-2019

Impossible de télécharger un paquet

Bonjour, il est impossible pour moi de télécharger un paquet qui se nomme heartbeat


Je lance en root:
apt-get install heartbeat
et cette erreur me parviens
Pouvez vous m'aider svp ?

https://image.noelshack.com/fichiers/20 … pture8.png
Cordialement
Hugo

Hors ligne

#2 22-12-2020 16:32:32

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : Impossible de télécharger un paquet

0/ Vérifier que tu as bien internet
1/ Faire un apt update et un apt upgrade
2/ Réessayer !

datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#3 22-12-2020 16:39:19

SwarmZz
Membre
Inscription : 31-01-2019

Re : Impossible de télécharger un paquet

Déjà fait

Hors ligne

#4 22-12-2020 16:42:48

Debian Alain
Membre
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux -5.10.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Hors ligne

#5 22-12-2020 16:43:51

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.9 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : Impossible de télécharger un paquet

C’est possible que ton index des paquets ne soit pas à jour, et qu’APT essaie donc de récupérer une ancienne version du paquet qui n’est plus disponible.
Avant l’installation, lance cette commande :

apt update



---

Oups, doublé par otyugh big_smile

---

Dans ce cas c’est peut-être le serveur que tu vises qui a un souci. Dans ton fichier /etc/apt/sources.list, essaie en remplaçant les ocurrences de http://ftp.fr.debian.org/debian/ par https://deb.debian.org/debian/ (à faire suivre d’un apt update).


Jouer sous Debian ? Facile !

Hors ligne

#6 22-12-2020 16:49:18

SwarmZz
Membre
Inscription : 31-01-2019

Re : Impossible de télécharger un paquet

Ma source.list
https://image.noelshack.com/fichiers/20 … pture9.png

Dernière modification par SwarmZz (22-12-2020 16:54:16)

Hors ligne

#7 22-12-2020 16:56:07

Debian Alain
Membre
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux -5.10.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Impossible de télécharger un paquet

tu as pensé rajouter "contrib non-free " à chacune de tes lignes ?

Hors ligne

#8 22-12-2020 17:00:17

SwarmZz
Membre
Inscription : 31-01-2019

Re : Impossible de télécharger un paquet

J'ai rajouter "contrib non-free" à la fin de chaque ligne de ma source.list et j'ai refais apt-get update ainsi que apt-get upgrade.
Toujours la même erreur quand je lance l'installation du paquet.

Hors ligne

#9 22-12-2020 17:04:21

Debian Alain
Membre
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux -5.10.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Hors ligne

#10 22-12-2020 17:07:42

SwarmZz
Membre
Inscription : 31-01-2019

Re : Impossible de télécharger un paquet

La configuration de mes interfaces => https://image.noelshack.com/fichiers/20 … ture10.png

Hors ligne

#11 22-12-2020 17:33:56

Debian Alain
Membre
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux -5.10.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Hors ligne

#12 22-12-2020 17:35:24

SwarmZz
Membre
Inscription : 31-01-2019

Re : Impossible de télécharger un paquet

Haha heu je fais un cluster big_smile

Hors ligne

#13 22-12-2020 17:40:30

SwarmZz
Membre
Inscription : 31-01-2019

Re : Impossible de télécharger un paquet

Dans ce laps de temps j'ai refais ma VM tout fonctionne à merveille, je vous remercie big_smile

Hors ligne

#14 22-12-2020 17:40:42

èfpé
Membre
Inscription : 10-07-2016

Re : Impossible de télécharger un paquet

Bonsoir, en passant,

En #1, SwarmZz a écrit :

1608650359-capture8.png


Comme l'a écrit vv222 en #5 la recherche de la version 2.9.4+dfsg1-7+b3 est totalement anormale.
Cette version n'est plus disponible nulle part, une liste de paquets n'a pas été mise à jour, regarde :

ls -lh /var/lib/apt/lists/


Ensuite tu supprimes soit sélectivement, soit brutalement, puis tu relances la mise à jour (update).

Dernière modification par èfpé (22-12-2020 20:40:42)

Hors ligne

#15 22-12-2020 17:52:39

SwarmZz
Membre
Inscription : 31-01-2019

Re : Impossible de télécharger un paquet

Je t'aime, j'ai souvent des erreurs avec le apt-get update et tu viens de me donner la solution pour mes prochains problèmes.
Je te remercie
En donnant les droits sur le dossier /lists/ et en supprimant le dossier ca fonctionne de nouveau.
C'est résolu
cordialement
Hugo

Dernière modification par SwarmZz (22-12-2020 17:59:55)

Hors ligne

#16 23-12-2020 09:36:15

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Impossible de télécharger un paquet


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

Pied de page des forums