Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-01-2021 23:03:02

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian bullseye (testing)
Noyau : Linux 5.10.0-5-amd64
(G)UI : LightDM et Xfce4.16
Inscription : 29-04-2015

[RÉSOLU] Comportements étranges de debian-facile.org

Hello,
Deux phénomènes étranges constatés avec le site :
− si je fais un host du site

host debian-facile.org


debian-facile.org has address 89.234.146.138
debian-facile.org has IPv6 address 2a00:5880:1401:11::1:1
debian-facile.org mail is handled by 10 mail.debian-facile.org.


et que je tape l’adresse ip dans un navigateur je tombe sur la page https://debian-facile.org/images/ au lieu de la page d’accueil.

− si je tape

w3m https://debian-facile.org


ou

elinks https://debian-facile.org


la page d’accueil du site met plusieurs minutes avant de s’ouvrir. Idem pour les liens dans le site.

Je n’ai aucun problème avec d’autres sites web.

Dernière modification par Philou92 (17-01-2021 00:45:44)


Tousse antique Ovide !

Hors ligne

#2 12-01-2021 22:52:35

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian bullseye (testing)
Noyau : Linux 5.10.0-5-amd64
(G)UI : LightDM et Xfce4.16
Inscription : 29-04-2015

Re : [RÉSOLU] Comportements étranges de debian-facile.org

Un petit up neutral

Tousse antique Ovide !

Hors ligne

#3 12-01-2021 23:07:09

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.10.0-9-amd64
(G)UI : mutter 3.38.6-2~deb11u1
Inscription : 15-02-2016

Re : [RÉSOLU] Comportements étranges de debian-facile.org

UP, UP, UP, Philou92, ça ne va pas se passer comme ça !

Moi aussi 89.234.146.138 m'entraîne vers Jyraphe !


Je ne sais pas interpréter la commande dig, mais l'administrateur de https://www.debian-fr.xyz/ m'avait diagnostiqué un problème de ce genre avec cette commande :

dig debian-facile.org


 <<>> DiG 9.16.8-Debian <<>> debian-facile.org
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 34411
;; flags: qr rd ra ad; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;debian-facile.org.   IN  A

;; ANSWER SECTION:
debian-facile.org.  36468 IN  A 89.234.146.138

;; Query time: 40 msec
;; SERVER: 87.98.149.171#53(87.98.149.171)
;; WHEN: mar. janv. 12 21:58:48 CET 2021
;; MSG SIZE  rcvd: 62
 


;

Dernière modification par --gilles-- (12-01-2021 23:08:02)


Nos vies commencent à prendre fin le jour où nous devenons silencieux à propos des choses qui comptent. Martin Luther King

Hors ligne

#4 12-01-2021 23:36:23

raleur
Membre
Inscription : 03-10-2014

Re : [RÉSOLU] Comportements étranges de debian-facile.org

Philou92 a écrit :

je tape l’adresse ip dans un navigateur je tombe sur la page https://debian-facile.org/images/ au lieu de la page d’accueil.


Pourquoi diable faudrait-il tomber sur la page d'accueil ? La relation site->adresse n'est pas bidirectionnelle.

Philou92 a écrit :

la page d’accueil du site met plusieurs minutes avant de s’ouvrir


Et pendant ce temps, tu as regardé les sockets ouverts et fait une capture du trafic réseau ?


Il vaut mieux montrer que raconter.

Hors ligne

#5 13-01-2021 00:13:25

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.10 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : [RÉSOLU] Comportements étranges de debian-facile.org

Soyons clair de suite, avec les autres admins on ne va sûrement pas prendre du temps à s'assurer que http://89.234.146.138/ pointe sur une page donnée du site. Tant que https://debian-facile.org/ amène au bon endroit, c'est que tout fonctionne comme prévu.

---

Pour les soucis de chargement très long, je pense qu'on a un problème au niveau de notre IPv6. Je n'observe ce que tu décris que lors de la connexion au serveur de Debian-Facile via son IPv6, pas si je force le passage par IPv4.

Pour ma part je ne pourrai pas y faire grand chose, n'ayant jamais eu de soucis liés à IPv6 sur mes systèmes perso, je n'ai jamais non plus eu à apprendre à dépanner ce genre de problème. Si vraiment notre IPv6 n'est pas fonctionnelle, le mieux à faire est probablement de virer totalement l'enregistrement AAAA du domaine.

Jouer sous Debian ? Facile !

Hors ligne

#6 13-01-2021 01:21:21

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian bullseye (testing)
Noyau : Linux 5.10.0-5-amd64
(G)UI : LightDM et Xfce4.16
Inscription : 29-04-2015

Re : [RÉSOLU] Comportements étranges de debian-facile.org

raleur a écrit :

Philou92 a écrit :

je tape l’adresse ip dans un navigateur je tombe sur la page https://debian-facile.org/images/ au lieu de la page d’accueil.


Pourquoi diable faudrait-il tomber sur la page d'accueil ? La relation site->adresse n'est pas bidirectionnelle.


Oui je sais, mais bon, qu’en j’accueille des personnes à la maison, je ne les fais pas entrer par le garage.
J’ai cru qu’il y avait une intention, a priori non si on s’en tient à ce que écrit vv222.
Donc sujet clos.


raleur a écrit :

Philou92 a écrit :

la page d’accueil du site met plusieurs minutes avant de s’ouvrir


Et pendant ce temps, tu as regardé les sockets ouverts et fait une capture du trafic réseau ?


Bonne idée je vais faire ça.


vv222 a écrit :


Pour les soucis de chargement très long, je pense qu'on a un problème au niveau de notre IPv6. Je n'observe ce que tu décris que lors de la connexion au serveur de Debian-Facile via son IPv6, pas si je force le passage par IPv4.


J’ai du mal à comprendre ton histoire d’IPV6.
Comment observes-tu ce que je décris ?
Que signifie « forcer » le passage en IPV4 ?

Précision je n’ai aucun problème avec un navigateur en mode « graphique » comme firefox. Le problème de latence (j’usqu’à 5mn) n’a lieu qu’avec un navigateur en mode texte uniquement avec le site debian-facile, ou en faisant une requête directement sur l’adresse IPV4 qui m’amène dans l’enclos de la gyraphe.


Tousse antique Ovide !

Hors ligne

#7 13-01-2021 02:22:40

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.10 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : [RÉSOLU] Comportements étranges de debian-facile.org

Philou92 a écrit :

Que signifie « forcer » le passage en IPV4 ?



Par exemple en ajoutant cette ligne dans /etc/hosts :

89.234.146.138 debian-facile.org

De cette manière tu es sûr que les logiciels qui respectent les entrées de ce fichier joindront le serveur de debian-facile.org via son adresse IPv4.

---

Philou92 a écrit :

Précision je n’ai aucun problème avec un navigateur en mode « graphique » comme firefox. Le problème de latence (j’usqu’à 5mn) n’a lieu qu’avec un navigateur en mode texte uniquement avec le site debian-facile



Firefox utilise probablement une autre façon de gérer un éventuel échec de connexion en IPv6, et passe plus rapidement à l'adresse IPv4 que les navigateurs en mode texte que tu as testés.


Jouer sous Debian ? Facile !

Hors ligne

#8 17-01-2021 00:45:07

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian bullseye (testing)
Noyau : Linux 5.10.0-5-amd64
(G)UI : LightDM et Xfce4.16
Inscription : 29-04-2015

Re : [RÉSOLU] Comportements étranges de debian-facile.org

Bon plus problème depuis trois jours. Le site s’ouvre au quart de poil dans w3m. C’est désolant de ne pas connaître l’origine du problème.
Je classe en résolu par dépit. neutral

Tousse antique Ovide !

Hors ligne

Pied de page des forums