Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-03-2021 16:09:29

Toulibre
Membre
Lieu : Chéniers, Creuse
Distrib. : Debian 11
Noyau : Linux 5.10.0-12-amd64
(G)UI : xfce-thunar
Inscription : 10-08-2020
Site Web

Beautify (plug-in), Script pour GIMP 2.10

Beautify est un plug-in pour Gimp qui permet d'embellir facilement et rapidement une image ou une photo.
210326030701804749.png
beautify-gimp-2.10.sh

#!/bin/bash
sudo apt install -y build-essential git make libgimp2.0-dev
git clone https://github.com/hejiann/beautify.git
cd beautify
make
make userinstall
wget https://github.com/hejiann/beautify/wiki/textures/rip-border-textures-0.5.1.tar.bz
wget https://github.com/hejiann/beautify/wiki/textures/texture-border-textures-0.5.1.tar.bz
tar xvf rip-border-textures-0.5.1.tar.bz -C ~/.config/GIMP/2.10/plug-ins/
tar xvf texture-border-textures-0.5.1.tar.bz -C ~/.config/GIMP/2.10/plug-ins/
rm ~/beautify/texture-border-textures-0.5.1.tar.bz
rm ~/beautify/rip-border-textures-0.5.1.tar.bz
echo "Beautify pour Gimp 2.10 a bien été installé"

Dernière modification par Toulibre (02-11-2021 09:41:07)

Hors ligne

#2 26-03-2021 20:27:39

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Beautify (plug-in), Script pour GIMP 2.10

cool
et un de plus
merci.gif

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#3 26-03-2021 20:32:29

Toulibre
Membre
Lieu : Chéniers, Creuse
Distrib. : Debian 11
Noyau : Linux 5.10.0-12-amd64
(G)UI : xfce-thunar
Inscription : 10-08-2020
Site Web

Re : Beautify (plug-in), Script pour GIMP 2.10

Avec plaisir smile

Hors ligne

#4 26-03-2021 20:43:51

arpinux
CA Debian-Facile
Lieu : Montréal d'aude
Distrib. : nakeDeb
Noyau : 5.10-amd64
(G)UI : i3wm - fluxbox
Inscription : 30-06-2016
Site Web

Re : Beautify (plug-in), Script pour GIMP 2.10

en voilà un plugin bien pratique, merci Toulibre smile

petite erreur dans le script : ~/tmp puis /tmp wink

Dernière modification par arpinux (26-03-2021 20:49:19)


nous sommes tous différents ... c'est notre point commun ...
Association Debian-Facile - Les cahiers du débutant - ISO Debian-Facile - 3hg - nakeDeb
make code ☮ not war

Hors ligne

#5 26-03-2021 22:56:50

Toulibre
Membre
Lieu : Chéniers, Creuse
Distrib. : Debian 11
Noyau : Linux 5.10.0-12-amd64
(G)UI : xfce-thunar
Inscription : 10-08-2020
Site Web

Re : Beautify (plug-in), Script pour GIMP 2.10

Avec plaisir
oups, c'est corrigé, merci smile

Hors ligne

#6 26-03-2021 23:32:58

Toulibre
Membre
Lieu : Chéniers, Creuse
Distrib. : Debian 11
Noyau : Linux 5.10.0-12-amd64
(G)UI : xfce-thunar
Inscription : 10-08-2020
Site Web

Re : Beautify (plug-in), Script pour GIMP 2.10

Je me suis aperçu que Jyraphe renomme les fichiers portant le même nom, donc re-corrigé pour que ça colle, mais après tout renommez le fichier comme vous souhaitez!

Hors ligne

#7 27-03-2021 10:42:13

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Beautify (plug-in), Script pour GIMP 2.10

fonctionne bien sauf le simple-border
j'ai ce message d'erreur
KF3CRFY.png

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#8 27-03-2021 10:56:49

Toulibre
Membre
Lieu : Chéniers, Creuse
Distrib. : Debian 11
Noyau : Linux 5.10.0-12-amd64
(G)UI : xfce-thunar
Inscription : 10-08-2020
Site Web

Re : Beautify (plug-in), Script pour GIMP 2.10

aaaaaa ???? l'installation des textures a dû mal se passer, chez moi ça fonctionne
mini_210327100520925760.png

Hors ligne

#9 27-03-2021 12:30:29

Toulibre
Membre
Lieu : Chéniers, Creuse
Distrib. : Debian 11
Noyau : Linux 5.10.0-12-amd64
(G)UI : xfce-thunar
Inscription : 10-08-2020
Site Web

Re : Beautify (plug-in), Script pour GIMP 2.10

J'ai rajouté dans le script "build-essential" car il est aussi nécessaire

Dernière modification par Toulibre (27-03-2021 12:31:07)

Hors ligne

#10 27-03-2021 12:30:57

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Beautify (plug-in), Script pour GIMP 2.10

le message apparait quand j'essai d'appliqué la simple-border

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#11 27-03-2021 12:55:13

Toulibre
Membre
Lieu : Chéniers, Creuse
Distrib. : Debian 11
Noyau : Linux 5.10.0-12-amd64
(G)UI : xfce-thunar
Inscription : 10-08-2020
Site Web

Re : Beautify (plug-in), Script pour GIMP 2.10

oups exact, je n'étais pas allé jusqu'au bout de la démarche.
là c'est un bug ... mes capacités de débugger ce truc sont nulles ...

Hors ligne

#12 27-03-2021 14:05:00

Toulibre
Membre
Lieu : Chéniers, Creuse
Distrib. : Debian 11
Noyau : Linux 5.10.0-12-amd64
(G)UI : xfce-thunar
Inscription : 10-08-2020
Site Web

Re : Beautify (plug-in), Script pour GIMP 2.10

le bug est situé là : https://github.com/hejiann/beautify/issues/48
Traduction :
C'est probablement parce que dans la version 2.10, le motif Clipboard a été renommé Clipboard Image. Cependant, ce nom dépend de la langue, ce qui signifie que le plugin ne fonctionnera pas si Gimp est configuré dans une autre langue. Il peut cependant être obtenu d'une manière indépendante du nom et de la langue comme le premier motif retourné par gimp-patterns-get-list().

Corrigé pour Microsoft et non-officiellement.
J'imagine qu'avec l'ancienne version Gimp 2.8 ce bug n'apparaît pas.

Hors ligne

#13 27-03-2021 14:33:47

Toulibre
Membre
Lieu : Chéniers, Creuse
Distrib. : Debian 11
Noyau : Linux 5.10.0-12-amd64
(G)UI : xfce-thunar
Inscription : 10-08-2020
Site Web

Re : Beautify (plug-in), Script pour GIMP 2.10

*******
J'ai laissé un p'tit mot sur github.
******
Le dev à l'air absent depuis longtemps...

Hors ligne

#14 01-11-2021 15:32:26

Toulibre
Membre
Lieu : Chéniers, Creuse
Distrib. : Debian 11
Noyau : Linux 5.10.0-12-amd64
(G)UI : xfce-thunar
Inscription : 10-08-2020
Site Web

Re : Beautify (plug-in), Script pour GIMP 2.10

Coucou, je reviens sur cette discussion pour indiiquer que les fichiers des textures et des bordures sont à dézipper dans :

/home/utilisateur/.config/GIMP/2.10/plug-ins/


Cela dépend bien sûr de votre version de Gimp et de votre nom d'utilisateur, rajoutez le éventuellement au script ci-dessus si vous souhaitez automatiser la tâche ou faites le manuellement.
L'adresse pour les 2 téléchargements.
https://github.com/hejiann/beautify/wik … s-Download
Sur ma distri cela fonctionne au poil.
Bien à vous

Hors ligne

#15 02-11-2021 07:27:21

Toulibre
Membre
Lieu : Chéniers, Creuse
Distrib. : Debian 11
Noyau : Linux 5.10.0-12-amd64
(G)UI : xfce-thunar
Inscription : 10-08-2020
Site Web

Re : Beautify (plug-in), Script pour GIMP 2.10

Hop; j'ai corrigé le script pour une installation automatisée sur debian buster avec Gimp 2.10

Dernière modification par Toulibre (02-11-2021 07:27:40)

Hors ligne

#16 19-03-2022 15:29:57

phlinux
Membre
Distrib. : Buster
Noyau : 5.10
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Beautify (plug-in), Script pour GIMP 2.10

Bjr,

En cours d'essais. Il y a une série de messages d'erreurs de ce style

Message GIMP
Erreur d’appel pour la procédure « gimp-image-add-layer » :
La procédure « gimp-image-add-layer » a été appelée avec un ID erroné pour le paramètre « layer ». Très probablement un greffon est en train d’essayer de travailler sur un calque qui n’existe plus.

Erreur d’appel pour la procédure « gimp-layer-scale » :
La procédure « gimp-layer-scale » a été appelée avec un ID erroné pour le paramètre « layer ». Très probablement un greffon est en train d’essayer de travailler sur un calque qui n’existe plus.

Je ne les poste pas tous... Cela se produit quand je choisis certaines corrections ou onglet du plugin

EDIT: bon en fait le problème se pose sur les fichiers .xcf et apparemment ça fonctionne super sur du .png

Dernière modification par phlinux (19-03-2022 15:38:40)


Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#17 19-03-2022 19:30:38

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 5.17.4-arch1-1
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

Re : Beautify (plug-in), Script pour GIMP 2.10

phlinux a écrit :

Bjr, ...
EDIT: bon en fait le problème se pose sur les fichiers .xcf et apparemment ça fonctionne super sur du .png




le fichier .xcf est une sauvegarde de travail ... c'est peut-être normal ? wink

Dernière modification par golgot200 (19-03-2022 19:31:48)

Hors ligne

#18 20-03-2022 11:47:07

phlinux
Membre
Distrib. : Buster
Noyau : 5.10
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Beautify (plug-in), Script pour GIMP 2.10

OK. Le fichier xcf que j'ai testé s'ouvrait en tant que calque jpg.
J'en ai testé un autre qui est un "vrai" xcf, c'est à dire qui regroupe les différents éléments qui constituent l'image (je pense que c'est ce que tu veux dire golgot200 ?) et là ça fonctionne sur chacun des éléments sélectionnés.
En même temps c'est peut être un plug-in destiné à modifier des images "complètes" plutôt que des parties dissociées.

Dernière modification par phlinux (20-03-2022 12:21:24)


Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#19 20-03-2022 13:48:07

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 5.17.4-arch1-1
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

Re : Beautify (plug-in), Script pour GIMP 2.10

phlinux a écrit :

... (je pense que c'est ce que tu veux dire golgot200 ?) et là ça fonctionne sur chacun des éléments sélectionnés...



Tout à fait smile

Hors ligne

Pied de page des forums