Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-04-2021 18:29:21

lauragais31
Membre
Inscription : 15-04-2021

Wifi ne s'active au démarrage

Bonjour,

-Ordinateur-
Processeur        : Intel(R) Core(TM)2 Duo CPU     T5800  @ 2.00GHz
Mémoire        : 3098MB (1333MB utilisé)
Machine Type        : Notebook
Systeme d'exploitation        : Debian GNU/Linux 10 (buster)
Utilisateur        : patrick (patrick)
Date/Heure        : lun. 19 avril 2021 18:14:36 CEST
-Affichage-
Résolution        : 1366x768 pixels
OpenGL Renderer        : (Unknown)
X11 Vendor        : The X.Org Foundation
-Audio Devices-
Adapteur Audio        : HDA-Intel - HDA Intel
Adapteur Audio        : HDA-Intel - HDA ATI HDMI
-Périphériques d'entrée-
AT Translated Set 2 keyboard
Lid Switch
Sleep Button
Power Button
Video Bus
USB Optical Mouse
SynPS/2 Synaptics TouchPad
HDA ATI HDMI HDMI/DP,pcm:3
HDA Digital PCBeep
HDA Intel Mic
HDA Intel Headphone
CNF8015: USB 2.0 Camera

Le bureau: xfce4-panel 4.12.2

$ lspci | grep Ethernet
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller (rev 02)

Je suis obligé pour l'activer de cliquer plusieurs fois à gauche, après avoir cliquer à droite sur l'icône du réseau (Applet NetworkManager Vers:1.8.20)
Il y a aussi un bouton, avec une lumière, sur le clavier mais quand le Wifi est activé il n'a aucune incidence sur déconnexion.
Après branchement d'un câble Ethernet l'icône change.
Ma question est: Pourquoi le Wifi ne s'active pas automatiquement au démarrage de la session?
Merci de vos réponses
Patrick

Hors ligne

#2 21-04-2021 09:48:06

mikeismike
Membre
Inscription : 17-06-2020

Re : Wifi ne s'active au démarrage

Bonjour
Peux tu  chercher dans le log ( l'init) ou dans le log du réseau
Par ailleurs
lspci | grep Ethernet
Ne renseigne que sur la carte filaire
essai
sudo ip a
ou
sudo iwlist
Mike

Dernière modification par mikeismike (21-04-2021 09:49:10)

Hors ligne

#3 22-04-2021 22:36:39

lauragais31
Membre
Inscription : 15-04-2021

Re : Wifi ne s'active au démarrage

Bonsoir,

Voila ce que donne:

sudo ip a

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp2s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 00:1f:16:0d:30:d3 brd ff:ff:ff:ff:ff:ff
3: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 00:21:5d:79:c7:2c brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.19/24 brd 192.168.0.255 scope global dynamic noprefixroute wlp3s0
       valid_lft 42862sec preferred_lft 42862sec
    inet6 2a01:e0a:a2d:6390:6426:23fb:8784:6bff/64 scope global dynamic noprefixroute
       valid_lft 86226sec preferred_lft 86226sec
    inet6 fe80::1f8c:996a:4872:c030/64 scope link noprefixroute
       valid_lft forever preferred_lft forever

sudo iwlist
Usage: iwlist [interface] scanning [essid NNN] [last]
              [interface] frequency
              [interface] channel
              [interface] bitrate
              [interface] rate
              [interface] encryption
              [interface] keys
              [interface] power
              [interface] txpower
              [interface] retry
              [interface] ap
              [interface] accesspoints
              [interface] peers
              [interface] event
              [interface] auth
              [interface] wpakeys
              [interface] genie
              [interface] modulation


Merci de votre réponse
Cordialement
Patrick

Dernière modification par lauragais31 (22-04-2021 22:39:03)

Hors ligne

#4 25-04-2021 21:10:06

Bardem
Membre
Inscription : 15-03-2021

Re : Wifi ne s'active au démarrage

A tout hasard, que te donnes un cat /etc/network/interfaces ?

Hors ligne

#5 25-04-2021 21:16:11

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.14.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Wifi ne s'active au démarrage

bonjour lauragais31  big_smile  big_smile  big_smile

histoire d'apporter un peu ma (toute petite) pierre :

lspci -nnk | grep net -A3

normalement , on doit voir tes cartes réseau (wifi et ethernet) et leurs pilotes



tu utilises  quel bureau ?

echo $XDG_CURRENT_DESKTOP $XDG_SESSION_DESKTOP



amicalement ,

Alain

coyotus.png

Dernière modification par Debian Alain (26-04-2021 10:14:41)

Hors ligne

#6 26-04-2021 19:52:17

lauragais31
Membre
Inscription : 15-04-2021

Re : Wifi ne s'active au démarrage

Bonjour Bardem, Alain,

Voici ce donne ces commandes:
Pour Bardem:
patrick@debian:~$ cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

Pour Alain:
patrick@debian:~$ lspci -nnk | grep net -A3
02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [10ec:8136] (rev 02)
    Subsystem: Packard Bell B.V. RTL810xE PCI Express Fast Ethernet controller [1631:c216]
    Kernel driver in use: r8169
    Kernel modules: r8169
03:00.0 Network controller [0280]: Intel Corporation WiFi Link 5100 [8086:4232]

patrick@debian:~$ echo $XDG_CURRENT_DESKTOP $XDG_SESSION_DESKTOP
XFCE lightdm-xsession

Merci
Cordialement
Patrick

Hors ligne

#7 26-04-2021 21:19:18

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.14.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Wifi ne s'active au démarrage

bonsoir lauragais31 .  big_smile  big_smile  big_smile

que donne : ?

lspci -nnkd::0280



amicalement ,

alain .

coyotus.png

Dernière modification par Debian Alain (26-04-2021 21:21:53)

Hors ligne

#8 27-04-2021 10:15:12

lauragais31
Membre
Inscription : 15-04-2021

Re : Wifi ne s'active au démarrage

Bonjour Alain,

lspci -nnkd::0280
03:00.0 Network controller [0280]: Intel Corporation WiFi Link 5100 [8086:4232]
    Subsystem: Intel Corporation WiFi Link 5100 AGN [8086:1201]
    Kernel driver in use: iwlwifi
    Kernel modules: iwlwifi
Merci
Amicalement
Patrick

Dernière modification par lauragais31 (27-04-2021 10:19:27)

Hors ligne

#9 27-04-2021 10:22:37

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.14.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Wifi ne s'active au démarrage

bonjour lauragais31   smile  smile  smile

tu peux faire une (des) capture(s) d'écran de ce que tu vois / a fait  ?

je viens d'installer une DFL 10.7 en V.M. mais ,étant en filaire , je crains ne pas  avoir du tout les mêmes écrans  que toi .

amicalement ,

alain

coyotus.png

Dernière modification par Debian Alain (27-04-2021 10:23:27)

Hors ligne

#10 27-04-2021 14:49:20

lauragais31
Membre
Inscription : 15-04-2021

Re : Wifi ne s'active au démarrage

Bonjour Alain,

Désolé, mais je ne ne sais pas comment mettre une capture d'écran sur le forum.

Amicalement
Patrick

Hors ligne

#11 27-04-2021 15:54:29

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.14.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Wifi ne s'active au démarrage

qu'est ce que tu ne sais pas faire ?

- prendre une capture d'écran ?
- la mettre sur le forum  ?

Hors ligne

#12 27-04-2021 17:44:30

lauragais31
Membre
Inscription : 15-04-2021

Re : Wifi ne s'active au démarrage

Eureka, j'ai réussi

Dernière modification par lauragais31 (27-04-2021 17:53:11)

Hors ligne

#13 27-04-2021 17:52:13

lauragais31
Membre
Inscription : 15-04-2021

Re : Wifi ne s'active au démarrage

[url=https://i.imgur.com/cthM5NM.png]
  cthM5NMl.png
[/url]

Hors ligne

#14 29-04-2021 18:33:10

mikeismike
Membre
Inscription : 17-06-2020

Re : Wifi ne s'active au démarrage

Salut

En fait ca marche
sudo ip a te donne ton ip (champ inet)
3: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 00:21:5d:79:c7:2c brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.19/24 brd 192.168.0.255 scope global dynamic noprefixroute wlp3s0

Tu es donc connecté : pas d'ip si pas de cx wifi
Tu peux essayer
1

ping 192.168.0.1 ou 192.168.0.254 (en fonction de la box de ton fai)


puis
2

ping 8.8.8.8


puis
3

ping www.google.fr


Si le deuxieme ne répond pas tu as un probleme de route
si le 3eme ne repond pas tu as un probleme de dns (ou éventuellement de proxy mais c'est rare chez soi)
MiM

Dernière modification par mikeismike (29-04-2021 18:33:44)

Hors ligne

#15 30-04-2021 21:04:40

lauragais31
Membre
Inscription : 15-04-2021

Re : Wifi ne s'active au démarrage

Bonsoir Alain,
Tous répondent correctement, la question au départ est pourquoi le wifi ne s'active pas automatiquement au démarrage de la session?
Je suis obligé de l'activer avec "Activer le réseau Wifi" et en face le petit carré n'est pas coché
e8CWwAkl.png

Merci
Amicalement
Patrick

Hors ligne

#16 01-05-2021 23:28:42

èfpé
Membre
Inscription : 10-07-2016

Re : Wifi ne s'active au démarrage

Bonsoir,

lauragais31 a écrit :

pourquoi le wifi ne s'active pas automatiquement au démarrage de la session ?


Tu as raison, c'est étrange. En principe, le Wi-Fi est activé par défaut et toute modif est conservée :

cat /var/lib/NetworkManager/NetworkManager.state

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true


Mais s'agissant d'un portable, il faut s'attendre à un coup tordu, impliquant RF-kill, que retournent :

lsmod

dmesg | grep DMI:


La commande lsmod listera les modules chargés ; dmesg devrait afficher les références du portable.

Hors ligne

#17 02-05-2021 16:01:39

lauragais31
Membre
Inscription : 15-04-2021

Re : Wifi ne s'active au démarrage

Bonjour,

patrick@debian:~$ lsmod
Module                  Size  Used by
ctr                    16384  0
ccm                    20480  0
fuse                   90112  3
uvcvideo               90112  0
videobuf2_vmalloc      16384  1 uvcvideo
videobuf2_memops       16384  1 videobuf2_vmalloc
videobuf2_v4l2         20480  1 uvcvideo
videobuf2_common       36864  2 uvcvideo,videobuf2_v4l2
videodev              139264  3 uvcvideo,videobuf2_common,videobuf2_v4l2
media                  28672  2 uvcvideo,videodev
arc4                   16384  2
snd_hda_codec_realtek    86016  1
iwldvm                126976  0
msr                    16384  0
snd_hda_codec_generic    65536  1 snd_hda_codec_realtek
snd_hda_codec_hdmi     45056  1
snd_hda_intel          32768  6
snd_hda_codec          94208  4 snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
mac80211              573440  1 iwldvm
snd_hda_core           57344  5 snd_hda_intel,snd_hda_codec,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hwdep              16384  1 snd_hda_codec
iwlwifi               180224  1 iwldvm
snd_pcm                81920  4 snd_hda_intel,snd_hda_codec,snd_hda_core,snd_hda_codec_hdmi
sg                     28672  0
iTCO_wdt               16384  0
snd_timer              28672  1 snd_pcm
iTCO_vendor_support    16384  1 iTCO_wdt
acer_wmi               20480  0
sparse_keymap          16384  1 acer_wmi
coretemp               16384  0
joydev                 20480  0
cfg80211              503808  3 iwlwifi,mac80211,iwldvm
snd                    61440  20 snd_hda_intel,snd_hwdep,snd_hda_codec,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek,snd_pcm
rfkill                 20480  2 acer_wmi,cfg80211
soundcore              16384  1 snd
battery                20480  0
ac                     16384  0
evdev                  20480  12
serio_raw              16384  0
wmi_bmof               16384  0
pcc_cpufreq            16384  0
acpi_cpufreq           20480  1
parport_pc             28672  0
ppdev                  20480  0
lp                     20480  0
parport                40960  3 lp,parport_pc,ppdev
ip_tables              20480  0
x_tables               24576  1 ip_tables
autofs4                36864  2
ext4                  532480  1
crc16                  16384  1 ext4
mbcache                16384  1 ext4
jbd2                   86016  1 ext4
fscrypto               24576  1 ext4
ecb                    16384  0
crypto_simd            16384  0
cryptd                 20480  1 crypto_simd
aes_i586               20480  0
btrfs                1085440  0
xor                    28672  1 btrfs
zstd_decompress        57344  1 btrfs
zstd_compress         143360  1 btrfs
xxhash                 20480  2 zstd_compress,zstd_decompress
raid6_pq              106496  1 btrfs
libcrc32c              16384  1 btrfs
crc32c_generic         16384  3
sd_mod                 49152  3
sr_mod                 24576  0
cdrom                  49152  1 sr_mod
hid_generic            16384  0
usbhid                 45056  0
hid                   102400  2 hid_generic,usbhid
ums_realtek            20480  0
uas                    24576  0
usb_storage            53248  2 uas,ums_realtek
radeon               1347584  4
i2c_algo_bit           16384  1 radeon
ttm                    65536  1 radeon
ahci                   36864  2
drm_kms_helper        135168  1 radeon
libahci                28672  1 ahci
syscopyarea            16384  1 drm_kms_helper
libata                192512  2 ahci,libahci
sysfillrect            16384  1 drm_kms_helper
sysimgblt              16384  1 drm_kms_helper
fb_sys_fops            16384  1 drm_kms_helper
r8169                  73728  0
drm                   323584  6 radeon,ttm,drm_kms_helper
uhci_hcd               40960  0
lpc_ich                24576  0
scsi_mod              172032  6 sd_mod,usb_storage,libata,uas,sr_mod,sg
psmouse               131072  0
ehci_pci               16384  0
ehci_hcd               61440  1 ehci_pci
i2c_i801               24576  0
mfd_core               16384  1 lpc_ich
realtek                16384  1
usbcore               188416  8 uvcvideo,usbhid,usb_storage,ehci_hcd,uhci_hcd,uas,ums_realtek,ehci_pci
libphy                 49152  2 r8169,realtek
usb_common             16384  1 usbcore
thermal                20480  0
wmi                    20480  2 wmi_bmof,acer_wmi
video                  40960  1 acer_wmi
button                 16384  0
patrick@debian:~$ sudo dmesg | grep DMI:
[    0.000000] DMI: Packard Bell BV EASYNOTE TN65  /Etna GM        , BIOS PBP08B1.P25     09/17/2008
 


Merci
Patrick

Dernière modification par lauragais31 (02-05-2021 16:08:36)

Hors ligne

#18 02-05-2021 17:04:42

èfpé
Membre
Inscription : 10-07-2016

Re : Wifi ne s'active au démarrage

Bonjour lauragais31,

lauragais31 a écrit :

lsmod | grep acer_wmi

acer_wmi               20480  0
sparse_keymap          16384  1 acer_wmi
rfkill                 20480  2 acer_wmi,cfg80211
wmi                    20480  2 wmi_bmof,acer_wmi
video                  40960  1 acer_wmi


Ce module acer_wmi (qui dépend de rfkill) est connu pour créer des soucis... Tu peux le décharger :

sudo modprobe -rv acer_wmi


Si cela ne pose aucun problème tout en réglant le souci de touche clavier inopérante... blackliste-le :

sudo nano /etc/modprobe.d/wmi-blacklist.conf

blacklist acer_wmi


Par la suite, ce module acer_wmi ne sera plus chargé automatiquement, au démarrage du système.

Hors ligne

#19 03-05-2021 10:16:05

lauragais31
Membre
Inscription : 15-04-2021

Re : Wifi ne s'active au démarrage

Bonjour èfpé,
Super, cela fonctionne
Problème résolu
Merci
Patrick

Hors ligne

Pied de page des forums