Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 22-04-2021 23:15:55

mazkagaz
Membre
Distrib. : Debian buster essentiellement
Noyau : Ça dépend...
(G)UI : Je migre petit à petit vers KDE.
Inscription : 13-05-2018

ibus problem

Bonsoir,

J'ai installé zoom pour pouvoir travailler avec mes élèves en distanciel il y a à peu près 3 semaines (vous vous rappelez, confinement, tout ça tout ça...).

Et l'une des dépendances incontournables de zoom est : ibus.

Et depuis qu'ibus est installé, c'est la merd.... Bref, ça fait vraiment chie......

D'habitude quand je mets à jour mes serveurs, j'ouvre Terminator, je le subdivise en 8 terminaux, chacun connecté sur un serveur, je lance une saisie de groupe (même saisie dans tous les terminaux) pour pas avoir à taper 8 fois "apt update && apt dist-upgrade". Mais là, avec ibus, chaque caractère tapé dans le terminal source est copié 2 fois (au lieu d'une seule) dans les autres terminaux.

Par exemple, mon "apt update" dans le terminal source devient "aapptt  uuppddaattee" dans tous les autres terminaux.

Solution trouvée : clic droit sur le panneau ibus (le gros "FR" en bas à droite de mon écran, dans la zone de notifications de kde) et je quitte ibus. Et là, tout est beau, la copie automatique entre les terminaux refonctionne comme un charme.

Mais... (et oui, il y a un mais)... Mais après ça, de temps en temps, la saisie au clavier devient totalement inopérante, avec comme seule échappatoire un redémarrage -_-

Je me retrousse les manches, je lance un "im-config", il me dit :

Current configuration for the input method:
 * Active configuration: ibus (normally missing)
 * Normal automatic choice: ibus (normally ibus or fcitx or uim)
 * Override rule: zh_CN,fcitx:zh_TW,fcitx:zh_HK,fcitx:zh_SG,fcitx
 * Current override choice:  (fr_FR)
 * Current automatic choice: ibus
 * Number of valid choices: 2 (normally 1)
The override rule is defined in /etc/default/im-config.
The configuration set by im-config is activated by re-starting X.
Explicit selection is not required to enable the automatic configuration if the active one is default/auto/cjkv/missing.
  Available input methods: ibus xim
Unless you really need them all, please make sure to install only one input method tool.



Je me démonte pas, puisque zoom veut ibus, je vais virer l'autre. Mais là je tombe sur un os : il n'y a apparemment rien à virer... o_O

#apt autoremove --purge uim-xim
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Le paquet « uim-xim » n'est pas installé, et ne peut donc être supprimé
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.



Je joue un peu avec les options de "im-config", je redémarre X à chaque fois : toujours pareil, rien à faire.

Je me dis puisque c'est ça, je vire ibus qui en plus ne me sert à rien :

# apt remove ibus
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  ibus-clutter ibus-gtk ibus-gtk3 libclutter-imcontext-0.1-0
  libclutter-imcontext-0.1-bin libxcb-xtest0
Veuillez utiliser « apt autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  ibus zoom
0 mis à jour, 0 nouvellement installés, 2 à enlever et 0 non mis à jour.
Après cette opération, 245 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] n
Annulation.
 


Mais voilà, moi j'ai besoin de zoom... la semaine prochaine et peut-être davantage...

C'est à ce moment que je me dis : et si tu postais un message sur le fofo de debian facile ? big_smile

Hors ligne

#2 23-04-2021 00:08:56

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : ibus problem

Bonsoir,

je ne connais pas du tout ibus mais ton histoire de "aapptt  uuppddaattee" m'a immédiatement fait penser à une option qu'on rencontrait dans les vieux terminaux série genre VT52, VT100, peut-être VT220, je veux parler de "l'écho local" pour les liaisons série en half-duplex (pas courant, je n'en ai jamais vu) où le terminal envoie à l'UC sur un fil le code du caractère tapé au clavier et n'attend pas le retour sur un autre fil qui, en l'espèce, n'existe pas, pour affichage (fonctionnement normal du full-duplex), il affiche directement, "localement", le caractère.

Je ne sais pas du tout si cette option existe dans ibus (et je ne sais pas où chercher) mais ça fait vraiment penser à ce que j'ai raconté : l'écho local serait activé.
Et j'ai peut-être complètement tort.

AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#3 23-04-2021 00:47:26

mazkagaz
Membre
Distrib. : Debian buster essentiellement
Noyau : Ça dépend...
(G)UI : Je migre petit à petit vers KDE.
Inscription : 13-05-2018

Re : ibus problem

Je ne saurais dire si tu as complètement tord ou raison, mais je n'ai trouvé aucune option dans le panneau de ibus me rappelant de près ou de loin ce que tu décris.

Mais merci pour cette anecdote ! smile ("les vieux terminaux série genre VT52" : whaou ! Tu dois être encore plus vieux.vieille que moi ! big_smile )

Du coup je pars sur une autre piste. Je me demande si j'ai bien interprété cette partie :

Current configuration for the input method:
 * Active configuration: ibus (normally missing)
 * Normal automatic choice: ibus (normally ibus or fcitx or uim)
 * Override rule: zh_CN,fcitx:zh_TW,fcitx:zh_HK,fcitx:zh_SG,fcitx
 * Current override choice:  (fr_FR)
 * Current automatic choice: ibus
 * Number of valid choices: 2 (normally 1)
The override rule is defined in /etc/default/im-config.
The configuration set by im-config is activated by re-starting X.
Explicit selection is not required to enable the automatic configuration if the active one is default/auto/cjkv/missing.
  Available input methods: ibus xim
Unless you really need them all, please make sure to install only one input method tool.


Number of valid choices: 2 (normally 1) : c'est à propos de ibus et xim ou ça concerne les deux lignes qui précèdent (ou les deux ? ).
Parce que du coup, est-ce qu'il ne suffirait pas de faire en sorte que 

* Current override choice:  (fr_FR)

devienne

* Current override choice:  ibus



Reste à savoir comment. Je verrai ça demain...

Hors ligne

#4 23-04-2021 09:58:03

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : ibus problem

Bonjour,

mazkagaz a écrit :

Mais merci pour cette anecdote ! smile ("les vieux terminaux série genre VT52" : whaou ! Tu dois être encore plus vieux.vieille que moi ! big_smile )

Bah… J'ai commencé ma carrière info en les dépannant sur site, un truc impensable maintenant.

J'ai un peu regardé dans ma vieille machine avec Synaptic, je n'ai pas ibus (l'ai-je viré en constatant que ça ne me servirait jamais ? Me souviens pas), mais j'ai remarqué qu'il existait un ibus-xkbc "keyboard layout emulation engine for ibus", à voir ?

Autre chose : en regardant ton fichier de conf, je trouve curieuse la première ligne avec son commentaire (normally missing) et le champ rempli.
Et un poil plus bas, Number of valid choices: 2 (normally 1) : c'est toi qui as rempli ces champs ? Je suppose que "man ibus" doit être une abomination pour s'y retrouver, et ggl ? "ibus keyboard auto-repeat" donne 18 000 résultats, les premiers ont l'air intéressants.
Je te laisse les examiner.

Dernière modification par jpt (23-04-2021 10:01:08)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#5 23-04-2021 10:50:26

hybridemoineau
Membre
Inscription : 21-02-2016

Re : ibus problem

Lorsque j'ai installé Zoom, en ayant xfce4, j'ai eu le même genre de problème, mon clavier avait basculé dans une variante exotique, et je n'avais pas la main via les outils de configuration habituels.

En fouillant les menus graphiques, j'ai trouvé un item nouveau, et il me semble que j'ai désinstallé le truc. Ce n'était pas ibus. C'était un module de réglage supplémentaire du clavier.

Désolé de ne pouvoir être plus précis, c'était en novembre, souvenez-vous....

Hors ligne

#6 23-04-2021 14:20:08

hybridemoineau
Membre
Inscription : 21-02-2016

Re : ibus problem

Ca vient de me revenir. Je n'ai pas déinstallé quoi que ce soit, soit je suis passé par le panneau de configuration d'ibus qui s'était ajouté dans le menu des applis...Voir ce lien, qui concerne Gnome et d'autres

https://wiki.archlinux.org/index.php/Ibus#GNOME

Soit j'avais désactivé ibus dans la configuration des claviers.

Hors ligne

#7 26-04-2021 12:31:42

mazkagaz
Membre
Distrib. : Debian buster essentiellement
Noyau : Ça dépend...
(G)UI : Je migre petit à petit vers KDE.
Inscription : 13-05-2018

Re : ibus problem

Merci pour cette réponse.

hybridemoineau a écrit :

Ca vient de me revenir. Je n'ai pas déinstallé quoi que ce soit, soit je suis passé par le panneau de configuration d'ibus qui s'était ajouté dans le menu des applis...Voir ce lien, qui concerne Gnome et d'autres

https://wiki.archlinux.org/index.php/Ibus#GNOME


Et qu'as-tu fait dans ce panneau de configuration ?

hybridemoineau a écrit :



Soit j'avais désactivé ibus dans la configuration des claviers.


Alors ça m'intéresserait de savoir comment procéder, notamment sous KDE. Parce que dans la configuration du système, et plus particulièrement du claivier, je ne trouve aucune mention d'ibus...

Hors ligne

#8 26-04-2021 13:17:36

hybridemoineau
Membre
Inscription : 21-02-2016

Re : ibus problem

Je viens d'aller voir sur le pc qui me sert pour Zoom et j'ai facilement retrouvé.

Avec xfce4 et son menu d'applications :

Paramètres >> Préférences de Ibus >> Onglet avancé >> utiliser la disposition clavier système coché.

Comme ce n'est pas tout à fait le même problème, il y a aussi partager la même méthode d'entrée pour toutes les applis qui peut être cochée ou pas, et qui pourrait faire l'affaire. Plus l'onglet méthode d'entrée, qui concerne les variantes clavier, et qui peut ouvrir à des paramètres supplémentaires.

ibus en console donne accès à la config. ibus read-config, et ça a l'air d'être une usine à gaz. (Red Hat forever)

Dernière modification par hybridemoineau (26-04-2021 13:22:38)

Hors ligne

#9 26-04-2021 13:34:26

mazkagaz
Membre
Distrib. : Debian buster essentiellement
Noyau : Ça dépend...
(G)UI : Je migre petit à petit vers KDE.
Inscription : 13-05-2018

Re : ibus problem

hybridemoineau a écrit :

Paramètres >> Préférences de Ibus >> Onglet avancé >> utiliser la disposition clavier système coché.


Déjà fait donc ce n'est pas ça pour moi.

hybridemoineau a écrit :

Comme ce n'est pas tout à fait le même problème, il y a aussi partager la même méthode d'entrée pour toutes les applis qui peut être cochée ou pas, et qui pourrait faire l'affaire.


Coché ou décoché, rien ne change pour moi, toujours le même soucis, même en redémarrant ibus.

hybridemoineau a écrit :

Plus l'onglet méthode d'entrée, qui concerne les variantes clavier, et qui peut ouvrir à des paramètres supplémentaires.


Une seule variante pour moi, celle du système : French(alternative).

hybridemoineau a écrit :

ibus en console donne accès à la config. ibus read-config, et ça a l'air d'être une usine à gaz. (Red Hat forever)


ibus read-config me "dit" entre autres choses : use-system-keyboard-layout: true
et ibus-setup ouvre le panneau de commandes obtenu via le clic droit dans la barre des tâches.

La vérité est ailleurs... big_smile

Hors ligne

#10 26-04-2021 13:55:47

hybridemoineau
Membre
Inscription : 21-02-2016

Re : ibus problem

La variante que j'ai est un clavier anglais... Je n'ai pas eu de problèmes de doubles touches. En retirant la variante french(alternative) peut-être ?

On peut aussi jouer sur le démon ibus. Je me suis apperçu qu'il était désactivé chez moi (et zoom marche), et je crois qu'il s'était incrusté dans les applications au démarrage de xfce.

Hors ligne

Pied de page des forums