Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-05-2021 14:28:43

Debian Alain
Membre
Lieu : Bretagne
Distrib. : unstable sid / bullseye (stable)
Noyau : Linux sid 5.18.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

[résolu] perte boot uefi

bonjour à tous smile  smile  smile

j'ai effectué la réinstall de bullseye sur un de mes deux disques uefi (le ssd)

tout s'est bien passé sauf que , maintenant , le boot  se  trouve sur le ssd et pas  sur le nvme .

comment rectifier le tir ?

comment mettre le boot sur le NVME ?

merci .

Dernière modification par Debian Alain (19-05-2021 14:47:32)

Hors ligne

#2 19-05-2021 14:46:58

Debian Alain
Membre
Lieu : Bretagne
Distrib. : unstable sid / bullseye (stable)
Noyau : Linux sid 5.18.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] perte boot uefi

ceci m'a bien aidé  :  https://wiki.debian-fr.xyz/Debian_%26_UEFI

j'ai fait :

update-grub


grub-install /dev/nvme0n1


vérifications :

ls /sys/firmware |grep efi


efibootmgr



merci

Hors ligne

#3 19-05-2021 19:28:30

raleur
Membre
Inscription : 03-10-2014

Re : [résolu] perte boot uefi

La seule commande nécessaire était "grub-install" sans argument depuis le système dont tu veux que GRUB soit actif. En mode EFI, la spécification d'un secteur de boot est sans objet. Tu aurais pu aussi seulement modifier l'entrée de boot EFI avec efibootmgr, mais c'est un peu plus délicat. update-grub était bien entendu superflu pour changer le GRUB actif, il n'est utile que pour ajouter le nouvel OS au menu de GRUB le cas échéant.

PS. Quand tu parles de SSD et de NVMe, c'est un peu confus : un SSD NVMe est un SSD, par définition.

Il vaut mieux montrer que raconter.

Hors ligne

#4 21-05-2021 08:28:41

Debian Alain
Membre
Lieu : Bretagne
Distrib. : unstable sid / bullseye (stable)
Noyau : Linux sid 5.18.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] perte boot uefi

râleur  a écrit :

PS. Quand tu parles de SSD et de NVMe, c'est un peu confus : un SSD NVMe est un SSD, par définition.

quand je parle de ssd , je pense à un ssd  sata en 2.5 pouces (classique , donc)

quand je parle nvme , je pense à un ssd nvme M.2 NGFF 2280 (classique là aussi)

je ne parle pas en termes exotiques .
enfin , je pense pas ?. si ?

Hors ligne

#5 21-05-2021 08:29:49

Debian Alain
Membre
Lieu : Bretagne
Distrib. : unstable sid / bullseye (stable)
Noyau : Linux sid 5.18.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] perte boot uefi

à effacer .

Dernière modification par Debian Alain (21-05-2021 15:10:55)

Hors ligne

#6 21-05-2021 13:25:55

raleur
Membre
Inscription : 03-10-2014

Re : [résolu] perte boot uefi

Tes termes ne sont pas exotiques mais ambigus. Les lecteurs ne voient que ce que tu écris, et pas ce que tu penses. Il serait beaucoup plus clair d'écrire "SSD SATA" et "SSD NVMe" par exemple.

Il vaut mieux montrer que raconter.

Hors ligne

Pied de page des forums