Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-06-2021 14:51:06

phlinux
Membre
Distrib. : Buster
Noyau : 4.19
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Clé_wifi_:_Bit_Rate_bloqué_sur_1 Mb

Bjr,

Quelqu'un sait-il où sont stockées les informations sur la config wifi ?
Pour être plus clair :

iwconfig


wlan1     IEEE 802.11  ESSID:"HUAWEI_Y635-L21_EE1E"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 64:A6:51:5D:3C:5C  
          Bit Rate=1 Mb/s   Tx-Power=20 dBm  
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=60/70  Signal level=-50 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Comme on le voit le bitrate est au plus bas. Les commandes, anciennes ou conseillées, soit ne passent pas ou n'ont aucune action.
Exemples en vrac :

>> d'après https://wireless.wiki.kernel.org/en/users/documentation/iw
# iw dev wlan1 set bitrates legacy-2.4 54
command failed: Invalid argument (-22)

# iw wlan1 set bitrates legacy-2.4 24 36 48 54
command failed: Invalid argument (-22)

>> commande habituelle antédiluvienne
# iwconfig wlan1 rate 54M
Error for wireless request "Set Bit Rate" (8B20) :
    SET failed on device wlan1 ; Invalid argument.

>> celle là passe mais ne change rien
# iwconfig wlan1 rate 54



Des avis, des questions ?

Merci d'avance


Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#2 04-06-2021 15:24:47

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.14.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Clé_wifi_:_Bit_Rate_bloqué_sur_1 Mb

curiosité , phlinux .  big_smile  big_smile  big_smile

que donnent ?

lspci -nnk | grep -i net

cartes réseau pci


lshw -c network

configuration réseau matérielle


rfkill list

des blocages ?


tu as quoi comme config ?

inxi -Fr

(à installer)



amicalement ,

alain .

coyotus.png

Dernière modification par Debian Alain (04-06-2021 15:49:06)

Hors ligne

#3 04-06-2021 15:56:10

phlinux
Membre
Distrib. : Buster
Noyau : 4.19
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Clé_wifi_:_Bit_Rate_bloqué_sur_1 Mb

C'est un bouchon wifi donc on saute > lspci -nnk | grep -i net

lshw -c network


*-network
       description: Interface réseau sans fil
       identifiant matériel: 1
       information bus: usb@5:7
       nom logique: wlan1
       numéro de série: 40:5d:82:d9:ed:d1
       fonctionnalités: ethernet physical wireless
       configuration: broadcast=yes driver=rtl8192cu driverversion=4.19.0-12-686-pae firmware=N/A ip=192.168.xx.x link=yes multicast=yes wireless=IEEE 802.11


inxi -Fr


System:
  Host: phlinux Kernel: 4.19.0-12-686-pae i686 bits: 32
  Desktop: Openbox 3.6.1 Distro: Debian GNU/Linux 10 (buster)
Machine:
  Type: Desktop System: Dell product: Dimension 8300 v: N/A
  serial: <superuser required>
  Mobo: Dell model: N/A serial: <superuser required> BIOS: Dell v: A01
  date: 04/28/2003
CPU:
  Info: Single Core model: Intel Pentium 4 bits: 32 type: MT
  L2 cache: 512 KiB
  Speed: 2993 MHz min/max: N/A Core speeds (MHz): 1: 2993 2: 2993
Graphics:
  Device-1: NVIDIA G73 [GeForce 7600 GS] driver: nouveau v: kernel
  Display: server: X.Org 1.20.4 driver: loaded: nouveau
  resolution: 1920x1080~60Hz
  OpenGL: renderer: NV4B v: 2.1 Mesa 18.3.6
Audio:
  Device-1: Intel 82801EB/ER AC97 Audio driver: snd_intel8x0
  Sound Server: ALSA v: k4.19.0-12-686-pae
Network:
  Device-1: Intel 82562EZ 10/100 Ethernet driver: e100
  IF: eth2 state: up speed: 100 Mbps duplex: full mac: 00:07:e9:6e:b1:e1
  Device-2: NetGear WNA3100M(v1) Wireless-N 300 [Realtek RTL8192CU]
  type: USB driver: rtl8192cu
  IF: wlan1 state: up mac: 40:5d:82:d9:ed:d1
Drives:
  Local Storage: total: 150.87 GiB used: 63.59 GiB (42.1%)
  ID-1: /dev/sda vendor: Seagate model: ST380215A size: 74.53 GiB
  ID-2: /dev/sdb vendor: Maxtor model: 6Y080L0 size: 76.34 GiB
Partition:
  ID-1: / size: 4.84 GiB used: 3.58 GiB (73.9%) fs: ext3 dev: /dev/sda5
  ID-2: /boot size: 208.6 MiB used: 78.4 MiB (37.6%) fs: ext3 dev: /dev/sda7
  ID-3: /home size: 8.75 GiB used: 4.08 GiB (46.6%) fs: ext3 dev: /dev/sda6
  ID-4: /usr size: 6.81 GiB used: 5.62 GiB (82.5%) fs: ext3 dev: /dev/sda8
Swap:
  ID-1: swap-1 type: partition size: 1.03 GiB used: 0 KiB (0.0%)
  dev: /dev/sda2
Sensors:
  Message: No sensors data was found. Is sensors configured?
Repos:
  Active apt repos in: /etc/apt/sources.list
  1: deb http://deb.debian.org/debian/ buster main contrib non-free
  2: deb http://deb.debian.org/debian-security/ buster/updates main contrib non-free
  3: deb http://deb.debian.org/debian/ buster-updates main contrib non-free
  4: deb http://deb.debian.org/debian/ buster-backports main contrib non-free
Info:
  Processes: 141 Uptime: 1h 21m Memory: 3.21 GiB used: 796.6 MiB (24.3%)
  Shell: Bash inxi: 3.3.01
 


Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#4 04-06-2021 15:58:08

phlinux
Membre
Distrib. : Buster
Noyau : 4.19
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Clé_wifi_:_Bit_Rate_bloqué_sur_1 Mb

Non pas de blocage physique:

rfkill list


0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no


Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#5 04-06-2021 16:08:37

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.14.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Clé_wifi_:_Bit_Rate_bloqué_sur_1 Mb

tu as pensé à installer le firmware realtek ?

apt install firmware-realtek


çà donne quoi ?

trouvé ceci aussi :  https://github.com/pvaret/rtl8192cu-fixes

Dernière modification par Debian Alain (04-06-2021 16:18:33)

Hors ligne

#6 04-06-2021 17:23:25

phlinux
Membre
Distrib. : Buster
Noyau : 4.19
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Clé_wifi_:_Bit_Rate_bloqué_sur_1 Mb

C'est une clé que j'utilise depuis au moins 5 ans, donc oui le firmware qui va bien est installé. J'ai même tenté celui des bpo, mais ça ne change rien. J'ai aussi downgradé sur un autre kernel, pas mieux.

En fait c'est depuis la migration sur Buster que j'ai remarqué le problème. Sur Jessie tout fonctionnait correctement; je forçais juste le bitrate à 54Mb/s dans /etc/rc.local. C'est d'ailleurs une erreur de systemd au boot qui m'a alerté sur le dysfonctionnement de la commande mise dans /etc/rc.local.

systemd[1]: Failed to start /etc/rc.local Compatibility
>> la ligne qui cause l'erreur
iwconfig wlan1 rate 54M # si on retire le "M" plus d'erreur, mais le bitrate reste à 1Mb/s
 

Ce qui me parait très étrange est que les commandes "officielles", avec iw, renvoient des messages d'erreur et sont aussi la cause de la descente du bitrate à 1Mb/s. Juste avant ces commandes il était environ à 7Mb/s.


Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#7 04-06-2021 17:33:45

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-16-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Clé_wifi_:_Bit_Rate_bloqué_sur_1 Mb

Hello
et si tu passes par auto?

iwconfig wlan1 rate auto


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#8 04-06-2021 17:34:08

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.14.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Clé_wifi_:_Bit_Rate_bloqué_sur_1 Mb

tout à l'heure , j'ai fait qques recherches .
sur un fil , il semble se dégager , comme possibilité , un mauvais pilote (je t'ai donné le lien git) .

pour un besoin spécifique , en réseau , je m'y connais très peu .

si je peux aider , ce sera avec plaisir , mais je connais pas tout .

https://github.com/pvaret/rtl8192cu-fixes

https://forum-francophone-linuxmint.fr/ … php?t=4913

Hors ligne

#9 04-06-2021 17:47:03

phlinux
Membre
Distrib. : Buster
Noyau : 4.19
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Clé_wifi_:_Bit_Rate_bloqué_sur_1 Mb

@Croutons : salut. J'ai pas mis toutes les commandes essayées mais celle que tu indiques ne change rien, pareil pour celle-là : iwconfig wlan1 rate 54M auto (bizarre, ici il faut le "M")
@Debian Alain : Ok, je vais lire (si c'est pas déjà fait parce que j'en ai bouffé de la page...)

Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#10 04-06-2021 18:09:39

phlinux
Membre
Distrib. : Buster
Noyau : 4.19
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Clé_wifi_:_Bit_Rate_bloqué_sur_1 Mb

Bon c'est une bonne idée que tu as eu. Donc j'ai remis le firmware-realtek de Jessie, mais ça ne change rien. Je pense que c'est du coté soit de udev ou du kernel que ça déconne. Avec le renommage des interfaces il y a peut être quelque chose qui coince de ce coté (bien que passer sous Buster n'a généré aucun message d'erreur du network ou à propos des anciens noms)

Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#11 05-06-2021 18:43:00

phlinux
Membre
Distrib. : Buster
Noyau : 4.19
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Clé_wifi_:_Bit_Rate_bloqué_sur_1 Mb

Pour voir, tentative de migration des noms d'interfaces. Résultat, du Buster tout craché :

● networking.service - Raise network interfaces
   Loaded: loaded (/lib/systemd/system/networking.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sat 2021-06-05 17:32:15 CEST; 3min 8s ago
     Docs: man:interfaces(5)
  Process: 405 ExecStart=/sbin/ifup -a --read-environment (code=exited, status=1/FAILURE)
 Main PID: 405 (code=exited, status=1/FAILURE)

juin 05 17:32:04 phlinux systemd[1]: Starting Raise network interfaces...
juin 05 17:32:15 phlinux ifup[405]: /etc/network/if-pre-up.d/wpasupplicant: 120: /etc/network/if-pre-up.d/wpasupplicant: cannot create /dev/stderr: No such device or address
juin 05 17:32:15 phlinux ifup[405]: run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
juin 05 17:32:15 phlinux ifup[405]: ifup: failed to bring up wlp0s29f7u7
juin 05 17:32:15 phlinux ifup[405]: Cannot find device "enp2s8"
juin 05 17:32:15 phlinux ifup[405]: ifup: failed to bring up enp2s8
juin 05 17:32:15 phlinux systemd[1]: networking.service: Main process exited, code=exited, status=1/FAILURE
juin 05 17:32:15 phlinux systemd[1]: networking.service: Failed with result 'exit-code'.
juin 05 17:32:15 phlinux systemd[1]: Failed to start Raise network interfaces.

et donc

-- L'unité (unit) networking.service a commencé à démarrer.
juin 05 17:35:41 phlinux wpa_supplicant[907]: Successfully initialized wpa_supplicant
juin 05 17:35:41 phlinux wpa_supplicant[907]: Could not read interface wlp0s29f7u7 flags: No such device
juin 05 17:35:41 phlinux wpa_supplicant[907]: nl80211: Driver does not support authentication/association or connect commands
juin 05 17:35:41 phlinux wpa_supplicant[907]: nl80211: deinit ifname=wlp0s29f7u7 disabled_11b_rates=0
juin 05 17:35:41 phlinux wpa_supplicant[907]: Could not read interface wlp0s29f7u7 flags: No such device
juin 05 17:35:41 phlinux wpa_supplicant[907]: rfkill: Cannot get wiphy information
juin 05 17:35:41 phlinux wpa_supplicant[907]: Could not read interface wlp0s29f7u7 flags: No such device
juin 05 17:35:41 phlinux wpa_supplicant[907]: WEXT: Could not set interface 'wlp0s29f7u7' UP
juin 05 17:35:41 phlinux wpa_supplicant[907]: wlp0s29f7u7: Failed to initialize driver interface
juin 05 17:35:41 phlinux ifup[882]: /etc/network/if-pre-up.d/wpasupplicant: 120: /etc/network/if-pre-up.d/wpasupplicant: cannot create /dev/stderr: No such device or address
juin 05 17:35:41 phlinux ifup[882]: run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
juin 05 17:35:41 phlinux ifup[882]: ifup: failed to bring up wlp0s29f7u7
juin 05 17:35:41 phlinux ifup[882]: Cannot find device "enp2s8"
juin 05 17:35:41 phlinux ifup[882]: ifup: failed to bring up enp2s8
juin 05 17:35:41 phlinux systemd[1]: networking.service: Main process exited, code=exited, status=1/FAILURE
-- Subject: Unit process exited
-- Defined-By: systemd

Donc panne sèche de réseau... Après renommage avec les anciens noms d'interfaces + quelques commandes, récupération du réseau et pourtant...

service networking restart

Job for networking.service failed because the control process exited with error code.
See "systemctl status networking.service" and "journalctl -xe" for details.

Donc ça marche sans systemd et même mieux

iwconfig

wlan1     IEEE 802.11  ESSID:"HUAWEI_Y635-L21_EE1E"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 64:A6:51:5D:3C:5C  
          Bit Rate=72.2 Mb/s   Tx-Power=20 dBm


Voilà, voilà, à suivre ......


Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#12 09-06-2021 17:08:34

phlinux
Membre
Distrib. : Buster
Noyau : 4.19
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Clé_wifi_:_Bit_Rate_bloqué_sur_1 Mb

Un début de solution à confirmer. 2 exemples de commandes pour régler le Bit rate ou tx bitrate (valeurs à adapter bien sur)

pour du wifi en 802.11n :

# iw dev wlan1 set bitrates ht-mcs-2.4 7


pour du wifi en 802.11bg :

# iw dev wlan1 set bitrates ht-mcs-2.4 54.0 ht-mcs-2.4 7

Vérifier avec les commandes iw habituelles, genre

iw dev wlan1 link

Connected to 69:a6:54:5d:3c:7c (on wlan1)
  SSID: Janet_Jackson
  freq: 2437
  RX: 50666322 bytes (136277 packets)
  TX: 5555982 bytes (28972 packets)
  signal: -44 dBm
  rx bitrate: 65.0 MBit/s MCS 7
  tx bitrate: 72.2 MBit/s MCS 7 short GI

  bss flags:  short-preamble short-slot-time
  dtim period:  2
  beacon int: 100
 


Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

Pied de page des forums