Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-06-2021 16:17:20

Trefix
Membre
Lieu : 48
Distrib. : buster 10.9 + bpo
Noyau : linux 4.19.0-16-amd64
(G)UI : Xfce4 4.12.5
Inscription : 15-02-2015

[Résolu] [audacity] ladspa-plugin = paquet virtuel

Bonjour.

Résolu a écrit :

Il fallait donc deviner que le nom du paquet virtuel n'est pas celui du paquet réel et rechercher avec les bonnes commandes, merci @Croutons.
Deux possibilités après avoir regardé de plus près :
- installer le métapaquet (dernière commande du post #3)
- installer seulement le paquet lsp-plugins-ladspa.
Audacity ne m'a pas refait de vilain plantage depuis (disparition complète d'une des trois occurence ouvertes)...



Bugs étranges depuis peu avec audacity (installé par APT). J'ai fait de la place sur mon HDD qui frisait la saturation et viens de repasser mon home à 71% d'occupation. Au cas où, un tour dans le wiki df pour me rafraîchir les idées puis j'ai envoyé :

apt autoremove --purge audacity

pour virer audacity (mark manuel) et audacity-data (mark auto), dépendances et fichiers de conf. Reboot, puis

apt update && install audacity

Tiens, un paquet suggéré :

Les paquets supplémentaires suivants seront installés :
  audacity-data libflac++6v5 libmad0 libportsmf0 libsuil-0-0
  libvamp-hostsdk3v5
Paquets suggérés :
  ladspa-plugin


Du coup pendant que j'installe (enfin APT bosse pour) je vais faire un tour de web, puis j'envoie :

apt install ladspa-plugin

des fois que ça aide à l'intégration. Sauf que :

Le paquet ladspa-plugin est un paquet virtuel fourni par :
  lsp-plugins-ladspa 1.1.24-1~bpo10+1
  wah-plugins 0.1.0-4
  vco-plugins 0.3.0-5
  tap-plugins 1.0.0-1
  swh-plugins 0.4.17-2
  ste-plugins 0.0.2-6
  rev-plugins 0.7.1-3
  omins 0.2.0-7.1
  mcp-plugins 0.4.0-6
  calf-ladspa 1.1.3-8.1
  ladspa-sdk 1.13-3
  invada-studio-plugins-ladspa 0.3.1-5
  guitarix-ladspa 0.36.1-1+b1
  fil-plugins 0.3.0-6
  csladspa 1:6.11.1-1
  cmt 1.16-2
  caps 0.9.26-1
  bs2b-ladspa 0.9.1-3
  blop 0.2.8-6.1
  blepvco 0.1.0-3+b1
  autotalent 0.2-5
  ambdec 0.7.1-1
  amb-plugins 0.8.1-7
Vous devez explicitement sélectionner un paquet à installer.

E: Le paquet « ladspa-plugin » n'a pas de version susceptible d'être installée



Bon, j'ai du boulot qui presse et ce retour me fait une belle jambe... Si l'un de vous a quelques éclaircissements sur ce fameux paquets virtuel et ce qui pourrait s'avérer utile pour ma Debian 10.9 Xfce 4, je lirai avec intérêt. MERCI d'avance.




P.S.: par curiosité, j'ai fait :

apt search lsp-plugin

En train de trier... Fait
Recherche en texte intégral... Fait
lsp-plugins/buster-backports 1.1.24-1~bpo10+1 amd64
  LSP (Linux Studio Plugins) audio-plugins (metapackage)

lsp-plugins-jack/buster-backports 1.1.24-1~bpo10+1 amd64
  LSP (Linux Studio Plugins) audio-plugins (standalone Jack clients)

lsp-plugins-ladspa/buster-backports 1.1.24-1~bpo10+1 amd64
  LSP (Linux Studio Plugins) audio-plugins (ladspa plugins)

lsp-plugins-lv2/buster-backports 1.1.24-1~bpo10+1 amd64
  LSP (Linux Studio Plugins) audio-plugins (LV2 plugins)

lsp-plugins-vst/buster-backports 1.1.24-1~bpo10+1 amd64
  LSP (Linux Studio Plugins) audio-plugins (VST plugins)


d'où je déduirais qu'audacity pourrait être content d'avoir le deuxième, ou carrément le premier (metapaquet)...

Dernière modification par Trefix (23-06-2021 08:34:28)

Hors ligne

#2 19-06-2021 18:46:47

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [Résolu] [audacity] ladspa-plugin = paquet virtuel

Hello
pourquoi ne pas installer un paquet qui est dans la liste fourni par apt install
tu fais
apt show le nom du paquet pour avoir des infos avant l'installation
exemple

apt show lsp-plugins-ladspa



d'où je déduirais qu'audacity pourrait être content d'avoir le deuxième, ou carrément le premier (metapaquet)...


tous dépendent du premier

apt depends lsp-plugins


lsp-plugins
  Dépend: lsp-plugins-ladspa
  Dépend: lsp-plugins-lv2
  Dépend: lsp-plugins-vst
  Dépend: lsp-plugins-jack
  Suggère: dgedit




installe le metapaquet au moins tu seras sur big_smile

Dernière modification par Croutons (19-06-2021 18:50:13)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#3 21-06-2021 14:04:00

Trefix
Membre
Lieu : 48
Distrib. : buster 10.9 + bpo
Noyau : linux 4.19.0-16-amd64
(G)UI : Xfce4 4.12.5
Inscription : 15-02-2015

Re : [Résolu] [audacity] ladspa-plugin = paquet virtuel

Coucou.

Tel que je le comprends, apt suggère le paquet virtuel. En utilisant apt show puis apt depends avec tes indices la réponse est claire : le terminal m'a dit nawak mrgreen.gif

Bref :

apt show ladspa-plungin

N: Impossible de trouver le paquet ladspa-plungin
N: Impossible de trouver le paquet ladspa-plungin
E: Aucun paquet n'a été trouvé


apt show lsp-plugins-ladspa

Package: lsp-plugins-ladspa
Version: 1.1.24-1~bpo10+1
Priority: optional
Section: sound
Source: lsp-plugins
Maintainer: Debian Multimedia Maintainers <debian-multimedia@lists.debian.org>
Installed-Size: 4087 kB
Provides: ladspa-plugin
Depends: libc6 (>= 2.27), libgcc1 (>= 1:3.0), libsndfile1 (>= 1.0.20), libstdc++6 (>= 4.1.1)
Homepage: https://lsp-plug.in/
Download-Size: 523 kB
APT-Sources: http://deb.debian.org/debian buster-backports/main amd64 Packages
Description: LSP (Linux Studio Plugins) audio-plugins (ladspa plugins)
 Linux Studio Plugins (LSP) provides a collection of audio effects,
 synthesizers, and a selection of audio tools for music and sound
 production. It provides standalone Jack clients and integrates
 into the LV2, LADSPA and VST plugin frameworks.
 .
 LSP provides the following plugins:
 .
 Audio effects: limiters, dynamic processors, expanders, gates,
 graphic equalisers, impulse responses, impulse reverbs, compressors,
 multiband compressors, parametric equalisers, phase detector,
 sidechain multiband compressors, sidechain limiters,
 sidechain dynamic processors, sidechain expanders, sidechain gates,
 sidechain compressors, slapback delays, delay compensators, triggers.
 .
 Synths: samplers, and multisamplers.
 .
 Tools: latency meters, oscillators, profiler, spectrum analyzers,
 and MIDI triggers
 .
 This package provies the ladspa plugins.

This package provies the ladspa plugins.
Tu pouvais pas le dire tout de suite ? Donc vérif' express :

apt depends audacity

audacity
  Dépend: audacity-data (= 2.2.2-1)
  Dépend: libasound2 (>= 1.0.16)
 |Dépend: libavcodec58 (>= 7:4.0)
    libavcodec-extra58
  Dépend: libavcodec-extra58 (>= 7:4.0)
  Dépend: libavformat58 (>= 7:4.0)
  Dépend: libavutil56 (>= 7:4.0)
  Dépend: libc6 (>= 2.27)
  Dépend: libexpat1 (>= 2.0.1)
  Dépend: libflac++6v5 (>= 1.3.1)
  Dépend: libflac8 (>= 1.3.0)
  Dépend: libgcc1 (>= 1:3.0)
  Dépend: libgdk-pixbuf2.0-0 (>= 2.22.0)
  Dépend: libglib2.0-0 (>= 2.12.0)
  Dépend: libgtk2.0-0 (>= 2.24.0)
  Dépend: libid3tag0 (>= 0.15.1b)
  Dépend: liblilv-0-0 (>= 0.16.0~dfsg0)
  Dépend: libmad0 (>= 0.15.1b-3)
  Dépend: libmp3lame0 (>= 3.100)
  Dépend: libogg0 (>= 1.0rc3)
  Dépend: libportaudio2 (>= 19+svn20101113-2~)
  Dépend: libportsmf0
  Dépend: libsndfile1 (>= 1.0.20)
  Dépend: libsoundtouch1 (>= 1.9.2)
  Dépend: libsoxr0 (>= 0.1.0)
  Dépend: libstdc++6 (>= 5.2)
  Dépend: libsuil-0-0 (>= 0.8.0~dfsg0)
  Dépend: libtwolame0 (>= 0.3.6)
  Dépend: libvamp-hostsdk3v5
  Dépend: libvorbis0a (>= 1.1.2)
  Dépend: libvorbisenc2 (>= 1.1.2)
  Dépend: libvorbisfile3 (>= 1.1.2)
  Dépend: libwxbase3.0-0v5 (>= 3.0.4+dfsg)
  Dépend: libwxgtk3.0-0v5 (>= 3.0.4+dfsg)
  Suggère: <ladspa-plugin>
    amb-plugins
    ambdec
    autotalent
    blepvco
    blop
    bs2b-ladspa
    calf-ladspa
    caps
    cmt
    csladspa
    fil-plugins
    guitarix-ladspa
    invada-studio-plugins-ladspa
    ladspa-sdk
    lsp-plugins-ladspa
    mcp-plugins
    omins
    rev-plugins
    ste-plugins
    swh-plugins
    tap-plugins
    vco-plugins
    wah-plugins
 



Donc lsp-plugins-ladspa suffirait certainement, la solution "ceinture ET bretelles" c'est un

apt update && apt install -t buster-backports lsp-plugins



33 Mo le meta contre moins de 5 Mo le -ladspa...

Hors ligne

Pied de page des forums