Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-07-2021 07:52:18

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

[Clôturé][Synaptic] dépendance incongrue.

Bonjour,

ayant fait une recherche sur poppler, tout en bas de la liste me vient le lecteur xpdf, et si je lui fais "clic droit / Propriétés / Dépendances", tout en bas de la fenêtre je lis (vous êtes assis ? Non ? Vous devriez) : En conflit avec: xpdf ! Avec lui-même, quoi.
Sans rire.
Ça m'a tellement intrigué, cette info, que j'ai regardé à la va-vite quelques autres paquets et c'est partout pareil : pour le paquet duschmoll, les dépendances indiquent qu'il est en conflit avec le paquet duschmoll.
Et il y a plus rigolo : tant qu'à être sur la page de résultats de poppler, je jette un coup d'œil au paquet poppler-utils et là, je constate que ce paquet va casser xpdf-utils puis va remplacer xpdf-utils, deux fois !, et va encore le casser : totalement incompréhensible pour moi, d'autant plus que je ne trouve pas de paquet xpdf-utils, comme s'il n'existait pas…

C'est pareil chez vous ?
Si "oui", c'est normal ce comportement absurde qui n'existe pas dans ma vieille machine (vieille version de Debian [Wheezy…], où pour poppler-utils je n'ai qu'une fois casse et remplace) ?

Au lieu de jouer avec la position du bouton "Rechercher" (qui me perturbe à chaque fois que je passe d'une machine à l'autre...), ils auraient mieux fait de se concentrer sur le cœur de l'outil, hein.
Moi, ça me fait penser à la grenouille qui voulait se faire aussi grosse que le bœuf

Dernière modification par jpt (09-07-2021 18:52:39)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#2 09-07-2021 08:59:10

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-16-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [Clôturé][Synaptic] dépendance incongrue.

Hello
en faite l'affichage n'est pas encore au point dirait on, si tu regarde avec

apt show poppler-utils


casse d'ancienne version et remplace des versions inférieur ( chose que synaptic ne précise pas)

Breaks: xpdf-common, xpdf-utils (<< 1:0)
Replaces: pdftohtml, xpdf-reader, xpdf-utils (<< 3.02-2~)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#3 09-07-2021 09:47:20

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : [Clôturé][Synaptic] dépendance incongrue.

Yep !

Croutons a écrit :

en fait l'affichage n'est pas encore au point dirait-on,

Ouais ouais ouais...

Et il y a aussi ça, dans la sortie de la commande que tu as proposée :
" Poppler est une bibliothèque de rendu PDF fondée sur l'afficheur PDF Xpdf."

Et là je tremble en lisant ça, car dans ma nouvelle machine j'ai poppler-utils installé et pas xpdf, ce qui ne m'empêche pas de faire man pdfimages par exemple (ou n'importe quel autre utilitaire de ce genre), et ça fonctionne.

Donc la ligne ne serait-elle pas plutôt :
" Poppler est une bibliothèque de rendu PDF utilisée par l'afficheur PDF Xpdf."
D'ailleurs

apt show xpdf

renvoie, entre autres,

Depends: ..., libpoppler82 (>= 0.71.0), ...
Recommends: poppler-utils, poppler-data, ...


Ou c'est les traducteurs qui se sont pris les pieds dans le tapis, ou c'est la pagaille dans apt…
D'un côté comme de l'autre j'ai peur.

D'ailleurs, en faisant

apt show xpdf-utils

on gagne

Package: xpdf-utils
State: pas un véritable paquet (virtuel)
N: Impossible de choisir une version candidate du paquet « xpdf-utils » qui n'en n'a pas
N: Impossible de choisir les versions du paquet « xpdf-utils » qui n'est qu'un paquet virtuel
N: Aucun paquet n'a été trouvé

ce qui montre bien qu'il y a une blague sous le tapis (dans lequel on se prend les pieds, à cause de la bosse générée par le bug poussé sous le... tapis, lol)

Dernière modification par jpt (09-07-2021 09:52:29)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#4 09-07-2021 09:54:34

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.10 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : [Clôturé][Synaptic] dépendance incongrue.

Tu devrais passer à Windows, qui te posera moins de soucis. Enfin, qui t’en posera sûrement autant mais t’évitera de passer ton temps à cracher sur les contributeurs à Debian à chaque fois que tu ne comprends pas quelque chose (autant dire tout le temps).

Je pense que tu peux en acheter une copie par ici : https://www.microsoft.com/fr-fr/windows

Jouer sous Debian ? Facile !

Hors ligne

#5 09-07-2021 11:29:13

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : [Clôturé][Synaptic] dépendance incongrue.

vv222 a écrit :

Tu devrais passer à Windows, qui te posera moins de soucis. Enfin, qui t’en posera sûrement autant mais t’évitera de passer ton temps à cracher sur les contributeurs à Debian à chaque fois que tu ne comprends pas quelque chose (autant dire tout le temps).

Et ta merveilleuse prose apporte quoi en termes de résolution du souci ? Si je me barre personne ne remontera les problèmes, qui vont s'accumuler, jusqu'à ce qu'un jour… Je vous laisse imaginer.

Mais ce n'est pas moi qui ai écrit récemment qu'apt autoremove avait enlevé à tort des choses qui auraient dû rester en place (et flemme de chercher, mais pour les curieux c'est pas vieux : une semaine à 10 jours à peu près), sans que l'auteur ne se fasse incendier : deux poids deux mesures ? Et on s'étonne que le monde barre en quenouille…

Je ne vois pas en quoi le fait de constater puis signaler des problèmes qui ne devraient pas exister doit m'obliger à retourner sous Windows (dont je viens, mais l'absence de pilote depuis XP SP3 pour ma vieille imprimante toujours vaillante et valide m'a fait abandonner cet os).
Ce n'est pas une attitude responsable ! Quand il y a un problème, il faut le régler, quand on a le temps ; moi je ne l'ai pas, mais je prends au moins celui de le signaler, un peu comme un trou sur la route : je ne suis pas équipé pour le reboucher, mais je peux au moins mettre un drapeau ou autre, ou à tout le moins en informer les services techniques de la commune concernée.

Alors tiens, j'ai ça qui squatte le bureau depuis plus d'un mois, c'est toi qui l'a gagné aujourd'hui :

La fiabilité de Debian

Ce matin 30 mai 2021, comme tous les jours et sans me prendre particulièrement la tête, j'ouvre un dossier présent sur le bureau, dans lequel j'enregistre ce que je fais pour faire avancer ce problème de changement aléatoire du nom des disques [tu parles d'une fiabilité !], sous forme de fichiers texte tout bêtes, que je renomme, tout bêtement (clic sur l'objet, F2, modifier le nom, <ENTREE>) et comme j'en avais un qui zonait encore sur le bureau, je le drag'n'drope dans le dossier en question, comme' d'hab' je dirais.

Sauf que cette fois rien ne se passe.
J'essaie de déplacer la fenêtre de l'explorateur, des fois qu'il y aurait une message-box cachée dessous (grand classique sous Debian/Lxde) mais au lieu de se déplacer l'image du programme se duplique tant que la souris bouge, et je comprends instantanément que le prog est planté, hé ouais.
Clic sur la croix, une 'tite fenêtre me dit que le prog est planté, "voulez-vous l'arrêter ?" que ça me demande -- ben ouais je réponds, mais rien ne se passe.
Un coup de top me montre que pcmanfm est à bloc, alors je reclique sur la croix, 'tite fenêtre "voulez-vous le tuer ?" ouais ouais et paf !, explorateur dégagé et toutes les icônes du bureau avec.

Alors j'ai fermé tous les autres progs ouverts et je vous pianote ça avant de redémarrer la session.
Quelle perte de temps, cette informatique…

PS : j'enregistre donc "ce" texte sous forme d'un fichier, "fichier / enregistrer sous..." a l'air de fonctionner mais retour sur le bureau il n'y a toujours rien.
Un coup de mc pour voir, tout est là, ouf !
Ainsi que les trois fichiers déplacés et renommés, et le quatrième, juste déplacé puisque le bazar a planté juste après.


Ce matin 31 mai 2021, comme tous ces derniers jours et sans me prendre particulièrement la tête, j'ouvre un dossier présent sur le bureau et je continue le boulot en cours, purement graphique (Gimp, LO-writer, ce genre de choses) et je ne touche pas au son, même pas pour avoir de la zique en sourdine, je préfère la radio.
Je ferme la machine (poweroff) à 13 h et la rouvre vers 17 h 30 en constatant avec stupeur que l'icône du son est barrée (au sens propre, elle a une barre en diagonale), ie je suis en sourdine.
Et pourquoi ?
Nobody knows…

Et en parlant d'ouvrir des dossiers sur le bureau, en général un double-clic sur l'objet lance l'explorateur, mais des fois, plutôt en fin de journée, ça ne lance plus rien. Il me faut alors lancer l'explorateur depuis son icône dans la barre de lancement rapide puis naviguer jusqu'au dossier pour voir son contenu, qui n'est parfois pas à jour -- heureusement qu'il me reste mc (qui n'est en général pas installé par défaut, on se demande bien pourquoi roll).


Et pour le problème d'apt, tu as une idée technique ?

Dernière modification par jpt (09-07-2021 11:31:58)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#6 09-07-2021 11:44:14

David5647
Membre
Distrib. : Debian Bullseye/Sid
Noyau : 5.7.0-2-amd64
(G)UI : KDE/i3wm
Inscription : 27-08-2017

Re : [Clôturé][Synaptic] dépendance incongrue.

TL:DR

aptitude : outil en ligne de commande, généralement plus adapté pour les questions poussées que toute GUI:

aptitude show xpdf


Paquet : xpdf                                          
Version : 3.04+git20210103-3
Nouveau: oui
État: non installé
Priorité : optionnel
Section : text
Responsable : Florian Schlichting <fsfs@debian.org>
Architecture : amd64
Taille décompressée : 390 k
Dépend: libc6 (>= 2.14), libgcc-s1 (>= 3.0), libpaper1, libpoppler102 (>= 20.09.0), libstdc++6 (>= 5.2), libx11-6, libxm4 (>= 2.3.4), libxt6
Recommande: poppler-utils, poppler-data, gsfonts-x11, cups-bsd, sensible-utils
Est en conflit: xpdf:i386
Fournit: pdf-viewer
Description : Motif-based PDF reader using the Poppler library
 xpdf is a light-weight open source viewer for Portable Document Format (PDF) files (also called 'Adobe Acrobat' or 'Acrobat' files).  This is just the xpdf viewer
 client; various command-line pdf tools are now provided via the poppler-utils package.
 
 Debian's xpdf is a fork of Xpdf version 3, modified to use the Poppler PDF rendering library but keeping the Motif toolkit, and nowadays maintained as the xpopple
 project.
Site : http://offog.org/code/xpopple/
Étiquettes: implemented-in::c++, interface::graphical, interface::x11, role::program, scope::application, uitoolkit::motif, use::viewing, works-with-format::pdf,
            works-with::text, x11::application
 


Architecture : amd64

Est en conflit: xpdf:i386



Manuel debian
Chapter 7. Basics of the Debian package management system : https://www.debian.org/doc/manuals/debi … ml#virtual
https://www.debian.org/doc/manuals/debi … ml#diverse

Hors ligne

#7 09-07-2021 12:05:10

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : [Clôturé][Synaptic] dépendance incongrue.

David5647 a écrit :

TL:DR

tu as bien fait, c'est une réponse HS à un post HS.

David5647 a écrit :

aptitude : outil en ligne de commande, généralement plus adapté pour les questions poussées que toute GUI:

Merci pour l'info.
J'ai comparé les sorties de ta commande et la mienne (inspirée par Croutons), il y a donc 3 lignes en plus chez toi :

État: non installé
Architecture : amd64
Est en conflit: xpdf:i386

qui ne sont pas dans ma sortie, qui propose de son côté 2 lignes qui ne sont pas dans ta sortie :

Download-Size: 165 kB
APT-Sources: https://deb.debian.org/debian buster/main amd64 Packages


Avec synaptic on a donc 3 outils pour faire le même taf, chacun des trois étant incomplet et/ou erroné. À quand un 4ᵉ outil qui synthétiserait tout ça ?

Je n'ai pas suivi ton lien, j'ai d'autres choses sur le gaz, désolé.

Dernière modification par jpt (09-07-2021 14:07:26)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#8 09-07-2021 12:13:30

arpinux
CA Debian-Facile
Lieu : Montréal d'aude
Distrib. : nakeDeb
Noyau : 5.10-amd64
(G)UI : i3wm - fluxbox
Inscription : 30-06-2016
Site Web

Re : [Clôturé][Synaptic] dépendance incongrue.

... it's not a bug ... it's a feaure ! lol

jpt a écrit :

On a donc 3 outils pour faire le même taf


et encore, là tu parles du gestionnaire de paquets ... si tu prends l'exemple des navigateurs de fichiers, il y en a plus, et pour les visionneuses d'images, c'est pire ... ça s'appelle la diversité wink

jpt a écrit :

chacun des trois étant incomplet


à tes yeux ...
ils ne sont pas incomplets, ils fonctionnent de manière différente, n'offrent pas les mêmes option ni les mêmes informations.


nous sommes tous différents ... c'est notre point commun ...
Association Debian-Facile - Les cahiers du débutant - ISO Debian-Facile - 3hg - nakeDeb

Hors ligne

#9 09-07-2021 12:27:53

David5647
Membre
Distrib. : Debian Bullseye/Sid
Noyau : 5.7.0-2-amd64
(G)UI : KDE/i3wm
Inscription : 27-08-2017

Re : [Clôturé][Synaptic] dépendance incongrue.

jpt a écrit :

Je n'ai pas suivi ton lien, j'ai d'autres choses sur le gaz, désolé.


Il va de soit que j'ai lu les posts #1 et #3 qui concernent encore une demande d'aide et pas le #5 qui est uniquement injurieux.   
Et super si tu as autre chose à faire que de lire les réponses à tes questions.

Hors ligne

#10 09-07-2021 12:38:36

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : [Clôturé][Synaptic] dépendance incongrue.

David5647 a écrit :

et pas le #5 qui est uniquement injurieux.

Ah, parce que le #4 qui en est à l'origine ne l'est pas, lui ?

David5647 a écrit :

Et super si tu as autre chose à faire que de lire les réponses à tes questions.

J'ai commencé par ton second lien et n'ai absolument pas vu le rapport avec mon problème.

Et oui, j'ai vraiment des tas de trucs sur le gaz et y a rien qui avance (bientôt 13 mois que la machine neuve n'est pas en prod') puisque je suis obligé de me battre avec plusieurs programmes incomplets différents pour synthétiser une information totale et que tout est comme ça...

Tu vas comprendre, dans l'autre post qui ne va pas tarder à tomber.


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#11 09-07-2021 12:47:16

David5647
Membre
Distrib. : Debian Bullseye/Sid
Noyau : 5.7.0-2-amd64
(G)UI : KDE/i3wm
Inscription : 27-08-2017

Re : [Clôturé][Synaptic] dépendance incongrue.

jpt a écrit :

D'ailleurs, en faisant
apt show xpdf-utils

on gagne

    Package: xpdf-utils
    State: pas un véritable paquet (virtuel)
    N: Impossible de choisir une version candidate du paquet « xpdf-utils » qui n'en n'a pas
    N: Impossible de choisir les versions du paquet « xpdf-utils » qui n'est qu'un paquet virtuel
    N: Aucun paquet n'a été trouvé

ce qui montre bien qu'il y a une blague sous le tapis (dans lequel on se prend les pieds, à cause de la bosse générée par le bug poussé sous le... tapis, lol)



=> 2nd lien, 2ème paragraphe : Debian uses a "virtual" package system to
=> titre du chapitre vers lequel point le 1er lien : What is a Virtual Package?

jpt a écrit :

Tu vas comprendre, dans l'autre post qui ne va pas tarder à tomber.


Il va de soit qu'il est inutile que je réponde à d'autres de tes demande d'aide, mes réponses étant systématiquement hors sujet.

Dernière modification par David5647 (09-07-2021 12:49:16)

Hors ligne

#12 09-07-2021 12:58:08

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-16-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [Clôturé][Synaptic] dépendance incongrue.

y'a une façon de présenter les soucis rencontré
en somme si tu dis que font ses glandus de la voirie la route est pleine de trous , ça le fait moyen
puis souvent le soucis est entre la chaise et l'écran comme on dit
faut dire que même quand on tente d'apporter des réponses  tu as du mal a les intégrer
mais c'est po grave on commence a avoir l'habitude
perso je lis toujours tes posts avec beaucoup de curiosité peace_flag.gif

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#13 09-07-2021 17:37:17

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.10 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : [Clôturé][Synaptic] dépendance incongrue.

jpt a écrit :

Si je me barre personne ne remontera les problèmes, qui vont s'accumuler, jusqu'à ce qu'un jour… Je vous laisse imaginer.


Excellent idée, je pense qu’on devrait tenter le coup.
J’accepterai sans râler tes « Je vous l’avais bien dit. » si Debian se casse la figure suite à ton départ.

jpt a écrit :

Mais ce n'est pas moi qui ai écrit récemment qu'apt autoremove avait enlevé à tort des choses qui auraient dû rester en place (et flemme de chercher, mais pour les curieux c'est pas vieux : une semaine à 10 jours à peu près), sans que l'auteur ne se fasse incendier : deux poids deux mesures ? Et on s'étonne que le monde barre en quenouille…


Bien sûr qu’on réagit différemment en fonction de nos interlocuteurs.
J’imagine que la personne que tu paraphrase ne finit pas tous ses paragraphes par « Et de toutes façons Debian c’est nul et ses contributeurs sont des nazes. », ce qui lui fait bénéficier de bien plus de bienveillance que ce à quoi tu as droit.


Jouer sous Debian ? Facile !

Hors ligne

#14 09-07-2021 18:52:16

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : [Clôturé][Synaptic] dépendance incongrue.

Croutons a écrit :

en somme si tu dis "que font ces glandus de la voirie, la route est pleine de trous", ça le fait moyen

Certes, mais il faut également voir le contexte.
Supposons que ça fasse des années que la route se dégrade sans que personne ne fasse quelque chose d'efficace, et que vienne un moment où le seul bonheur c'est celui du garagiste qui change des amortos à tour de bras, tout comme des triangles et autres pneumatiques, qu'est-ce qu'on dirait au café du coin le soir ? "Ces glandus sont vraiment payés à rien foutre, j'ai encore pété un cardan !" et tout le monde trouverait ça normal.

Croutons a écrit :

perso je lis toujours tes posts avec beaucoup de curiosité peace_flag.gif

Merci.

David5647 a écrit :

Il va de soi qu'il est inutile que je réponde à d'autres de tes demandes d'aide, mes réponses étant systématiquement hors sujet.

Faux, j'ai bien apprécié ta commande avec aptitude, qui m'a permis de comparer avec apt et synaptic, et on ne m'otera pas de l'idée qu'un outil d'informations qui ne donne pas toutes les informations est certes différent d'un autre mais est aussi incomplet au niveau des informations données.

Bon, on ne va pas passer la soirée là-dessus à polémiquer, pour moi c'est clair, il n'y a pas de solution simple et lumineuse.
Dommage, ça aurait pu, mais vous savez quoi ? Sur un écran très large, la première fois que j'ai lancé Synaptic il m'a fallu un bout de temps pour le trouver, leur bouton "Rechercher" déplacé à l'extrêmité de l'extrême-droite, habitué que j'ai été pendant 8 ans à l'avoir après le dernier bouton des 3 ou 4 qui sont tassés à gauche.
Et depuis, à chaque fois il faut que je me demande sur quelle machine je suis pour ne pas perdre du temps à le chercher. C'est de l'ergonomie aléatoire, le contraire d'une ergonomie productive, point.


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#15 09-07-2021 18:52:47

Elzen
Modérateur
Distrib. : Debian Sid GNU/Linux
Noyau : amd64 (à jour le vendredi)
(G)UI : Touhy
Inscription : 01-07-2014

Re : [Clôturé][Synaptic] dépendance incongrue.

Bon, on va tenter de médiater un peu tout ça.

jpt, une maxime qui pourrait éventuellement t'être utile à l'occasion : « descends de ton vélo, et regarde-toi pédaler ».
Autrement dit, au lieu de continuer de foncer la tête dans le guidon, essaye de prendre un peu de recul et d'essayer de voir si tu ne pourrais pas un peu mieux faire les choses.

Ce topic en étant une démonstration assez flagrante, essayons de détailler ça ensemble.


Dans le premier post, tu remarques un comportement qui te paraît saugrenu, et tu demandes donc si d'autres personnes le rencontrent, et si quelqu'un serait en mesure de te l'expliquer. Jusque là, c'est une assez bonne démarche : un programme dont le comportement qui nous paraît aberrant, c'est généralement soit un bug, soit une logique que l'on n'a pas comprise, donc soit une occasion de contribuer en aidant à améliorer le logiciel, soit une occasion de progresser dans notre connaissance de l'écosystème.

Sauf que.

Sauf que tu ne peux manifestement pas t'empêcher de terminer ce message par cette remarque :

jpt a écrit :

Au lieu de jouer avec la position du bouton "Rechercher" (qui me perturbe à chaque fois que je passe d'une machine à l'autre...), ils auraient mieux fait de se concentrer sur le cœur de l'outil, hein.
Moi, ça me fait penser à la grenouille qui voulait se faire aussi grosse que le bœuf…


En d'autres termes, avant même de savoir si ce que tu remarques est spécifique ou pas à ta situation et dans laquelle des deux catégories sus-mentionnées ça se trouve (puisque c'était l'objet de ton post de te renseigner à ce sujet), tu sembles nous poser comme hypothèse indépassable non seulement qu'il s'agit d'un bug, mais que ce bug est dû à un mauvais sens des priorités de la part des développeurs (ce qui est assez rare, en vrai).

À ce stade, une telle remarque est totalement prématurée et ne peut avoir comme effet que de mettre tes interlocuteurs dans de mauvaises dispositions (et spoiler : si tu te renseignes un minimum sur l'histoire de la gestion de paquets sous Debian, tu verras que tu as très mal cerné leur sens des priorités, le « cœur de l'outil » ayant été largement plus soigné, et par beaucoup plus de gens, que l'interface graphique que tu utilises –d'ailleurs, tu ne précises même pas de laquelle il s'agit).

(Oh, et, soit dit en passant : ce serait quand même bien que tu relises un peu la fable de la grenouille, parce qu'elle ne porte absolument pas sur le fait de se focaliser sur quelque chose au détriment du reste, hein. D'ailleurs, le système de gestion de paquets sous Debian étant historiquement le premier du genre, on se demande un peu qui serait censé être le bœuf ici, mais bref.)


Croutons te répond donc en te fournissant une explication au problème : une histoire de versionnage. Ce qui tend donc à laisser entendre que, dans notre alternative, on est plus près du second cas (quelque chose que tu n'as pas compris dans la logique de fonctionnement du programme, à savoir qu'on peut à la fois dépendre d'une version d'un paquet et en casser une autre) que du premier, bien qu'on puisse considérer qu'il y ait un souci d(e manque d)'affichage qui puisse éventuellement relever du bug, ce que Croutons souligne au passage.

Or c'est sur ce seul point que tu sembles embrayer dans le post suivant, dans lequel tu continues manifestement sur le même travers : tu repères un truc que tu n'arrives pas à comprendre dans les descriptions des paquets, en partant du principe que ce sont forcément les gens qui ont rédigé ça qui ont fait n'importe quoi, et en l'exprimant d'ailleurs d'une manière qui aurait été assez peu respectueuse même si ça avait été le cas, ce qui ne l'était pas.

(À vue de nez, ce qui te paraît incohérent est une bête histoire de fork toute simple comme on en croise des centaines dans le logiciel libre : poppler est basé à l'origine sur du code venu de xpdf, mais, étant maintenant plus avancé que ce code d'origine, les devs d'xpdf ont décidé de reprendre le code de poppler plutôt que de continuer à maintenir leur code d'origine, ce qui est parfaitement compréhensible dans les extraits que tu cites, à condition de les lire sans tes présupposés méprisants.)

Suite à ce message (et surtout à de très nombreux autres partageant les mêmes travers), vv222 intervient en te faisant remarquer qu'étant donné l'ampleur de tes préjugés envers le développement de Debian, n'importe quel système qui ne soit pas Debian, fut-ce Windows, te conviendrait sans doute bien mieux, ce qui est une réaction d'agacement fort compréhensible vu ce qui précède.

Et là, tu nous commet la perle suivante :

jpt a écrit :

Si je me barre personne ne remontera les problèmes, qui vont s'accumuler, jusqu'à ce qu'un jour… Je vous laisse imaginer.


Tu sembles donc partir du principe que tu es le seul susceptible de remonter de tels problèmes (ça va, les chevilles ? Note que ça pourrait quand même être vrai, ceci dit… mais à la condition que ces « problèmes » ne soient des problèmes que pour toi. Auquel cas le fait que tu ne sois pas là pour les remonter signifierait simplement qu'ils n'existeraient plus.), et que tu fais là un travail essentiel.

Mais à qui remontes-tu ces problèmes, au juste ? Accompagnes-tu tes messages ici de rapports de bugs adressés aux mainteneurs Debian ? Si oui, j'espère sincèrement pour eux que tu le fais de manière beaucoup moins agressive. Et si non, qu'est-ce que venir râler sur un forum d'utilisateurs dans des formes qui ne permettent pas grand chose de concret, et surtout pas de remonter jusqu'aux gens qui seraient en mesure d'intervenir, pourrait-il avoir d'aussi salutaire ?

Littéralement tout ce que cette phrase montre, c'est que ton égo est assez surdimensionné, ce qui, quelque part, explique peut-être ta tendance à partir du principe que, si quelque chose te paraît ne pas aller, c'est que le reste du monde est trop con pour avoir bossé convenablement, et ne peut en aucun cas venir du fait que tu n'aurais pas compris quelque chose.

Mais ce n'est pas tout : tu arrives également à conclure le même post par

jpt a écrit :

Et pour le problème d'apt, tu as une idée technique ?


Ce qui est juste totalement incohérent vis-à-vis de ce qui précède : tout au plus, en admettant qu'il y ait un problème dans ce que tu as rapporté (ce qui, encore une fois, est tout sauf évident à ce stade), ce problème
– n'est pas lié spécifiquement à apt, mais plutôt à l'interface graphique (toujours non précisée, ce qui n'aide pas à proposer des solutions) que tu utilisais,
– et porte sur les informations qui sont, ou pas, rapportées par cette interface, donc sont de nature rédactionnelles et absolument pas techniques.

En d'autres termes, en trois posts, tu remarques que tu ne comprends pas quelque chose, tu exposes ton mécontentement de manière passablement injurieuse, puis tu reproches aux gens de ne pas avoir répondu à des questions que tu n'as manifestement pas posées. On peut difficilement dire que c'est de la faute de vv222 que ce topic part en vrille…


Mais continuons. Après ça, intervient David5647 avec une réponse qui semble assez pertinente : puisque tu sembles mécontent du fonctionnement de l'outil que tu utilises (toujours non-précisé à ce stade), il te propose d'en essayer un autre, qui fait environ le même job, mais le fait d'une manière différente, qui pourrait éventuellement satisfaire tes frustrations sur le fonctionnement de l'autre. En l'état, on aurait difficilement pu faire mieux.

…mais ce n'est manifestement pas ce que tu souhaitais entendre, puisque tu lui rétorques aussitôt que sa réponse n'a rien à voir avec le sujet. Ah. Eùh. Mais c'est quoi le sujet, alors ? Parce qu'il était précisément en train de t'apporter la seule réponse technique qui aurait pu t'aider en l'état, là…

Bref, et tu nous conclues donc (après avoir, enfin, précisé que c'était Synaptic que tu utilises, ce qui veut dire que ta râlerie à propos d'apt plus haut était elle-même hors sujet, vu que Synaptic n'est pas apt…) par cette merveilleuse remarque :

jpt a écrit :

Je n'ai pas suivi ton lien, j'ai d'autres choses sur le gaz, désolé.


Tu demandes de l'aide, on tente de t'en apporter malgré les formes très décourageantes que tu y mets, et tu trouves quand même le moyen de répondre d'un air snob que tu as mieux à faire que d'essayer de suivre les conseils.


La suite de ce topic n'est que la suite logique de ta façon d'intervenir : ça part en vrille, parce que ça ne pouvait pas faire mieux vu la constance avec laquelle tu as fait vriller les propos.

Donc, en l'espèce, la seule réponse raisonnable semble être celle-ci : ni rien, ni personne d'autre que toi ne peut être susceptible de régler le problème que tu nous exposes ici, parce que ce problème se situe exclusivement dans ta tête. Le seul et unique problème, quoi que Synaptic mentionne ou ne mentionne pas à propos de poppler, xpdf, et leurs dépendances, c'est que tu sembles avoir décidé, à propos de sujets que tu ne maîtrises manifestement pas le moins du monde, que tu savais tout mieux que tout le monde et que les gens qui ont passé une partie non-négligeable de leur vie à essayer de faire marcher tout ça avaient fait n'importe quoi, ce qui ne peut pas aboutir à autre chose qu'à te faire passer pour quelqu'un d'à la fois ignorant, agressif et méprisant.

Il existe donc deux issues possibles : soit tu arrives à prendre conscience de ce problème et tu fais des efforts pour y travailler, auquel cas tes interlocuteurs ici pourront t'expliquer sereinement ce que tu n'as pas compris quand tu n'arrives pas à comprendre quelque chose, et t'aider à faire remonter efficacement les problèmes dans les quelques cas où tu repéreras effectivement de vrais problèmes existant ailleurs que dans ta tête, soit, comme vv222 le suggérait, tu vas voir ailleurs, avec si possible (dans ton intérêt, mais bon, après, ça, ça te regarde) un autre système dont la logique de fonctionnement te conviendra mieux. Cette seconde issue risquant fort de se produire de force si tu persistes à n'opter de ton plein gré pour aucune des deux.

Hors ligne

Pied de page des forums