Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-07-2021 22:48:29

cihoa
Membre
Distrib. : Debian 11 (bullseye)
Noyau : Linux 5.10.0-8
(G)UI : XFCE 4.16.12
Inscription : 09-09-2020

Mise à jour vers les dépôts unstable

Bonsoir la communauté,

Après avoir mis à jour ma debian sur Bullseye j'aurais souhaité ajouter les dépôts unstable à mon fichier source mais je n'arrive pas à trouver l'url exacte du dépôt correspondant avec mes dépôts actuels qui sont les dépôts par défaut.


deb http://deb.debian.org/debian/ bullseye main contrib non-free
deb-src http://deb.debian.org/debian/ bullseye-updates main contrib non-free

deb http://security.debian.org/debian-security bullseye-security main non-free contrib
deb-src http://security.debian.org/debian-security bullseye-security main non-free contrib
deb http://ftp.debian.org/debian bullseye-backports main contrib non-free
 



Pourriez-vous m'aider à trouver la bonne url de façon à ce que je ne fasse pas d'erreur ? smile

edit : question complémentaire, j'ai lu sur des forums que la commande add-apt-repository ajoutait automatiquement le dépôts ET la clé gpg, est-ce bien vrai ou devrais-je ajouter la clé manuellement ?

Dernière modification par cihoa (10-07-2021 22:50:11)

Hors ligne

#2 10-07-2021 23:27:28

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-7-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Mise à jour vers les dépôts unstable

bonsoir cihoa big_smile  big_smile  big_smile

tu peux utiliser ce dépôt :
(utilises nano pour l'ajouter)

# unstable
deb http://deb.debian.org/debian/ unstable main contrib non-free
deb-src http://deb.debian.org/debian/ unstable main contrib non-free



n'oublie pas de gérer les priorités de tes dépôts (fichier préférences) .
sinon sid va prendre le dessus sur bullseye .

https://debian-facile.org/doc:systeme:apt:pinning

amicalement ,

alain .

coyotus.png

Dernière modification par Debian Alain (11-07-2021 00:16:50)

Hors ligne

#3 11-07-2021 00:49:20

cihoa
Membre
Distrib. : Debian 11 (bullseye)
Noyau : Linux 5.10.0-8
(G)UI : XFCE 4.16.12
Inscription : 09-09-2020

Re : Mise à jour vers les dépôts unstable

Bonsoir Debian Alain !

Merci pour ton aide ! big_smile

Juste pour vérifier est-ce que la syntaxe comme ceci est optimale ?


Package: *
Pin: release a=unstable
Pin-Priority: 990

Package: *
Pin: release a=stable
Pin-Priority: 900
 
Package: *
Pin: release a=stable-updates
Pin-Priority: 900
 
Package: *
Pin: release a=proposed-updates
Pin-Priority: 900
 

Dernière modification par cihoa (11-07-2021 00:49:44)

Hors ligne

#4 11-07-2021 08:53:08

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-16-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Mise à jour vers les dépôts unstable

Hello
il me semble que non pas optimale vu que le dépôt unstable aura la plus haute priorité
il faudrait mettre une priorité inférieur a Bulleye pour bien faire
après pour contrôler que les priorités son bien bonne

apt update


apt policy

Dernière modification par Croutons (11-07-2021 08:53:40)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#5 11-07-2021 09:44:56

jarek
Membre
Lieu : Haute Loire
Distrib. : bullseye
Noyau : linux 5.10 amd64
(G)UI : xfce4 - lightdm
Inscription : 24-06-2014

Re : Mise à jour vers les dépôts unstable

Croutons a écrit :

il faudrait mettre une priorité inférieur a Bulleye pour bien faire


Chipotons . . .
Unstable doit avoir une priorité inférieure à celle de Bullseye.


Définitivement pour ce qui est contre et contre ce qui est pour.
Ryzen3 3200G - Asrock B450

Hors ligne

#6 11-07-2021 09:55:58

cihoa
Membre
Distrib. : Debian 11 (bullseye)
Noyau : Linux 5.10.0-8
(G)UI : XFCE 4.16.12
Inscription : 09-09-2020

Re : Mise à jour vers les dépôts unstable

D'accord j'ai bien fais de poser la question tongue

Est-ce mieux ainsi ?

Package: *
Pin: release a=stable
Pin-Priority: 990
 
Package: *
Pin: release a=stable-updates
Pin-Priority: 990
 
Package: *
Pin: release a=proposed-updates
Pin-Priority: 990

Package: *
Pin: release a=unstable
Pin-Priority: 590



Par contre j'ai l'impression que ça ne donne pas le résultat désiré car les priorités restent à 500 au niveau de bullseye (et en plus le apt policy indique "testing" pour bullseye et "sid" pour le unstable).

sudo apt update && apt policy


Atteint :1 http://deb.debian.org/debian bullseye InRelease
Atteint :2 http://security.debian.org/debian-security bullseye-security InRelease                      
Atteint :3 http://ftp.debian.org/debian bullseye-backports InRelease                                    
Atteint :4 http://deb.debian.org/debian bullseye-updates InRelease                                      
Atteint :5 http://deb.debian.org/debian unstable InRelease
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
5 paquets peuvent être mis à jour. Exécutez « apt list --upgradable » pour les voir.
Fichiers du paquet :
 100 /var/lib/dpkg/status
     release a=now
 590 http://deb.debian.org/debian unstable/non-free amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=non-free,b=amd64
     origin deb.debian.org
 590 http://deb.debian.org/debian unstable/contrib amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=contrib,b=amd64
     origin deb.debian.org
 590 http://deb.debian.org/debian unstable/main amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=main,b=amd64
     origin deb.debian.org
 500 http://security.debian.org/debian-security bullseye-security/main amd64 Packages
     release o=Debian,a=testing-security,n=bullseye-security,l=Debian-Security,c=main,b=amd64
     origin security.debian.org
 500 http://deb.debian.org/debian bullseye/non-free amd64 Packages
     release o=Debian,a=testing,n=bullseye,l=Debian,c=non-free,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian bullseye/contrib amd64 Packages
     release o=Debian,a=testing,n=bullseye,l=Debian,c=contrib,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian bullseye/main amd64 Packages
     release o=Debian,a=testing,n=bullseye,l=Debian,c=main,b=amd64
     origin deb.debian.org
Paquets épinglés :
 

Dernière modification par cihoa (11-07-2021 10:15:00)

Hors ligne

#7 11-07-2021 10:08:16

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-7-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Mise à jour vers les dépôts unstable

bonjour cihoa big_smile  big_smile  big_smile

la priorité "classique" des dépôts est de  500 .

personnellement , pour un dépôt que je souhaite conserver / activer ,
je mets une priorité de 500 .
et pour un dépôt que je souhaite conserver en réserve sans empiéter sur les  autres ,
je mets une priorité de 100 .

dans ton cas , si tu veux  quitter bullseye pour sid , voilà ce  que j'aurai fait :


Package: *
Pin: release a=unstable
Pin-Priority: 500

Package: *
Pin: release a=testing
Pin-Priority: 100

Package: *
Pin: release a=stable
Pin-Priority: 100
 



sans garantie , a vérifier .

n'oublie pas , comme l'a écrit croutons :

pour mettre à jour tes dépôts :

apt update



pour vérifier tes priorités :

apt policy



amicalement ,

alain.

coyotus.png

Dernière modification par Debian Alain (11-07-2021 10:08:56)

Hors ligne

#8 11-07-2021 10:18:24

raleur
Membre
Inscription : 03-10-2014

Re : Mise à jour vers les dépôts unstable

cihoa a écrit :

Par contre j'ai l'impression que ça ne donne pas le résultat désiré car les priorités restent à 500 au niveau de bullseye (et en plus le apt policy indique "testing" pour bullseye


Normal, bullseye n'est ni stable ni unstable donc n'est pas affecté par ton fichier preferences et conserve sa priorité par défaut.


Il vaut mieux montrer que raconter.

Hors ligne

#9 11-07-2021 10:24:54

cihoa
Membre
Distrib. : Debian 11 (bullseye)
Noyau : Linux 5.10.0-8
(G)UI : XFCE 4.16.12
Inscription : 09-09-2020

Re : Mise à jour vers les dépôts unstable

Ah ok !

Du coup c'est aussi pour cette raison que sur unstable il est indiqué "sid" et que pour bullseye il est indiqué "testing", si je comprends bien c'est parce que bullseye n'a pas encore de dépôt unstable et stable en service.

Je viens de mettre à jour en suivant ce qu'a mis Debian Alain (effectivement c'est des priorités plus logiques, on priorise en partant du plus bas, moi j'avais tendance à prioriser en commencant par les valeurs les plus hautes). Et maintenant j'ai ça :

apt policy


Fichiers du paquet :
 100 /var/lib/dpkg/status
     release a=now
 500 http://deb.debian.org/debian unstable/non-free amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=non-free,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian unstable/contrib amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=contrib,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian unstable/main amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=main,b=amd64
     origin deb.debian.org
 500 http://security.debian.org/debian-security bullseye-security/main amd64 Packages
     release o=Debian,a=testing-security,n=bullseye-security,l=Debian-Security,c=main,b=amd64
     origin security.debian.org
 100 http://deb.debian.org/debian bullseye/non-free amd64 Packages
     release o=Debian,a=testing,n=bullseye,l=Debian,c=non-free,b=amd64
     origin deb.debian.org
 100 http://deb.debian.org/debian bullseye/contrib amd64 Packages
     release o=Debian,a=testing,n=bullseye,l=Debian,c=contrib,b=amd64
     origin deb.debian.org
 100 http://deb.debian.org/debian bullseye/main amd64 Packages
     release o=Debian,a=testing,n=bullseye,l=Debian,c=main,b=amd64
     origin deb.debian.org
Paquets épinglés :
 

Hors ligne

#10 11-07-2021 11:12:28

raleur
Membre
Inscription : 03-10-2014

Re : Mise à jour vers les dépôts unstable

cihoa a écrit :

si je comprends bien c'est parce que bullseye n'a pas encore de dépôt unstable et stable en service.


Je crains que tu n'aies pas bien compris, car cette phrase ne veut rien dire.

buster, bullseye et sid sont des noms de code. stable, testing et unstable sont des suites.
buster est actuellement stable et deviendra oldstable lorsque bullseye sera publiée.
bullseye est actuellement testing, deviendra stable lorsqu'elle sera publiée.
sid est, a été et sera toujours unstable. Aucun autre nom de code n'a jamais été et ne sera jamais unstable.

cihoa a écrit :

Je viens de mettre à jour en suivant ce qu'a mis Debian Alain


Je ne vois pas l'intérêt de définir des priorités dans ton cas puisque les paquets de sid/unstable ont des versions supérieures ou égales à ceux de testing.


Il vaut mieux montrer que raconter.

Hors ligne

#11 11-07-2021 19:24:00

cihoa
Membre
Distrib. : Debian 11 (bullseye)
Noyau : Linux 5.10.0-8
(G)UI : XFCE 4.16.12
Inscription : 09-09-2020

Re : Mise à jour vers les dépôts unstable

raleur a écrit :


buster, bullseye et sid sont des noms de code. stable, testing et unstable sont des suites.
buster est actuellement stable et deviendra oldstable lorsque bullseye sera publiée.
bullseye est actuellement testing, deviendra stable lorsqu'elle sera publiée.
sid est, a été et sera toujours unstable. Aucun autre nom de code n'a jamais été et ne sera jamais unstable.



Aaaaaah d'accord ! Du coup je comprends mieux : c'est normal que sid soit toujours en unstable et les paquets provenant de unstable étant toujours plus récents par défaut ils primeront sur les autres si je n'indique aucune priorité dans mes préférences d'apt.

Pour d'autres potentiels lecteurs je laisse une page de wiki : https://debian-facile.org/doc:systeme:a … hes-debian

Alors j'ai une dernière question : sur la commande apt policy j'ai remarqué une priorité à 100 que je ne comprends pas :

apt policy


100 /var/lib/dpkg/status
     release a=now



Pourquoi y a t-il cette priorité définie à 100 avec dpkg ? à quoi sert-elle ?

Hors ligne

Pied de page des forums