Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-08-2021 00:02:16

Roland05
Adhérent(e)
Distrib. : Bookworm
Noyau : Linux 6.0.0-4-amd64
(G)UI : Xfce et Lightdm
Inscription : 06-01-2020

RESOLU - Erreur Apache2.

Bonjour.
Je cherche à me former à sql. Je suis sous Buster.
Pour installer Apache2, MariadB, phpmyadmin ..., j'ai suivi ce tuto.
Arrivé au lancement d'Apache2, j'ai cette erreur :

root@Debian:/home/roland# sudo systemctl restart apache2
Job for apache2.service failed because the control process exited with error code.
See "systemctl status apache2.service" and "journalctl -xe" for details.
 

.

Est-ce ce tuto qui comporte des erreurs ?
Comment procédez-vous pour lancer MariadB sous Firefox en localhost ?
Merci de vos retours.
Bonne soirée.
Roland.

Dernière modification par Roland05 (04-08-2021 18:48:45)

En ligne

#2 03-08-2021 04:51:24

cyrille
CA Debian-Facile
Lieu : Nowhere
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : RESOLU - Erreur Apache2.

Bonjour
Tu dois avoir une erreur dans la conf d'apache2

Que donne ? SI tu peux copier le retour de cette commande ?

systemctl status apache2.service




Et si tu peux montrer la conf des rep virtuels d'apache ? /etc/apache2/sites-available/phpmyadmin.conf et /etc/apache2/ports.conf

Comment procédez-vous pour lancer MariadB sous Firefox en localhost ?


mariadb est une base de données qui n'a pas de lanceur via firefox. Elle se "lance" tout comme apache via systemctl....
Mais dans ton cas, il faut déjà savoir pour apache ne se lance pas.



root@Debian:/home/roland# sudo systemctl ...


Tu es déjà en root, pas besoin du sudo wink

Dernière modification par cyrille (03-08-2021 04:52:59)


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

Hors ligne

#3 03-08-2021 07:56:08

Roland05
Adhérent(e)
Distrib. : Bookworm
Noyau : Linux 6.0.0-4-amd64
(G)UI : Xfce et Lightdm
Inscription : 06-01-2020

Re : RESOLU - Erreur Apache2.

Bonjour et merci de ta réponse.
Voici les retours :

cyrille a écrit :


Que donne ?
systemctl status apache2.service



roland@Debian:~$ systemctl status apache2.service
● apache2.service - The Apache HTTP Server
   Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Tue 2021-08-03 05:37:27 CEST; 2h 9min ago
     Docs: https://httpd.apache.org/docs/2.4/
  Process: 472 ExecStart=/usr/sbin/apachectl start (code=exited, status=1/FAILURE)
 



cyrille a écrit :


Et si tu peux montrer la conf des rep virtuels d'apache ?
- /etc/apache2/sites-available/phpmyadmin.conf

<VirtualHost *:9000>
ServerAdmin webmaster@localhost
DocumentRoot /opt/phpMyAdmin

<Directory /opt/phpMyAdmin>
Options Indexes FollowSymLinks
AllowOverride none
 



- /etc/apache2/ports.conf

# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default.conf

Listen 80
Listen 9000

<IfModule ssl_module>
        Listen 443
</IfModule>

<IfModule mod_gnutls.c>
        Listen 443
</IfModule>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
 



cyrille a écrit :


Tu es déjà en root, pas besoin du sudo wink


C'est vrai, yes Sir wink.
Roland.

Dernière modification par Roland05 (03-08-2021 08:00:13)

En ligne

#4 03-08-2021 09:02:13

cyrille
CA Debian-Facile
Lieu : Nowhere
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : RESOLU - Erreur Apache2.

Hello tu as déjà un soucis avec ton répertoire virtuel, tu as ouvert les balises <virtualhosts> et <directory> que tu n'as pas fermées et la conf est incomplète. Dans le tuto ils ont un soucis de pagination à cet endroit (pas de bol wink

Pat contre leur image est correcte. Ca devrait donner ça :

17f4bde9d25c2c938729742405b1c9fba47b3f838c8ea9e77cfdc19b089ec1ef.png


Essaie d'apporter les modif et redémarre apache voir ce que ça raconte wink

"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

Hors ligne

#5 03-08-2021 09:58:53

jce76350
Membre
Lieu : Rouen
Distrib. : Debian_Bullseye 11.4
Noyau : 5.10.0-16-amd64
(G)UI : XFCE
Inscription : 24-08-2016
Site Web

Re : RESOLU - Erreur Apache2.

Pour débuter ce serait plus simple d’utiliser Adminer et non pas phpmyadmin (il n'y a pas de bidouilles à faire wink car le paquet phpmyadmin n'existe plus sous Buster sauf dans les backports et n'est pas à jour)
Pour information et installation d'Adminer

--
Jc E

Hors ligne

#6 03-08-2021 11:47:11

Roland05
Adhérent(e)
Distrib. : Bookworm
Noyau : Linux 6.0.0-4-amd64
(G)UI : Xfce et Lightdm
Inscription : 06-01-2020

Re : RESOLU - Erreur Apache2.

OK, merci beaucoup.
Je ferai les modifications ce soir et vous dirai wink.
Bonne journée.
Roland.

En ligne

#7 03-08-2021 11:52:30

Anonyme
Invité

Re : RESOLU - Erreur Apache2.

Je n'utilise plus apache depuis un moment mais normalement avec cette commande tu peux tester ta config et afficher les erreurs :

apache2 -t

#8 03-08-2021 12:24:54

cyrille
CA Debian-Facile
Lieu : Nowhere
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : RESOLU - Erreur Apache2.

En effet adminer fait partie du repo officiel et finalement se manipule assez bien...
Quoiqu'il en soit, ici le soucis est dans la conf incomplète du répertoire virtuel, il suffit de la modifier en respectant les entrées de l'image sus citée wink

"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

Hors ligne

#9 03-08-2021 19:16:14

Roland05
Adhérent(e)
Distrib. : Bookworm
Noyau : Linux 6.0.0-4-amd64
(G)UI : Xfce et Lightdm
Inscription : 06-01-2020

Re : RESOLU - Erreur Apache2.

cyrille a écrit :


Essaie d'apporter les modif et redémarre apache voir ce que ça raconte wink



Bonsoir.
Modifs effectuée et Apache démarre big_smile.
Top, merci !!!
Roland.

En ligne

#10 03-08-2021 19:18:38

Roland05
Adhérent(e)
Distrib. : Bookworm
Noyau : Linux 6.0.0-4-amd64
(G)UI : Xfce et Lightdm
Inscription : 06-01-2020

Re : RESOLU - Erreur Apache2.

jce76350 a écrit :

Pour débuter ce serait plus simple d’utiliser Adminer et non pas phpmyadmin (il n'y a pas de bidouilles à faire wink car le paquet phpmyadmin n'existe plus sous Buster sauf dans les backports et n'est pas à jour)
Pour information et installation d'Adminer



Bon, phpmyadmin ne fonctionne pas ... grrrr !!! Normalement, un localhost/phpmyadmin devrait ouvrir  la bdd ...
En attendant vos réponses, m'en vais essayer le tuto d'Adminer wink.
Merci.
Roland.

En ligne

#11 03-08-2021 19:38:43

cyrille
CA Debian-Facile
Lieu : Nowhere
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : RESOLU - Erreur Apache2.

D'après ton tuto, pour accéder ce n'est pas localhost/phpmyadmin
mais via le port 9000

donc http://localhost:9000
ou IP_DU_SERVEUR:9000

Dernière modification par cyrille (03-08-2021 19:39:19)


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

Hors ligne

#12 03-08-2021 19:41:41

Roland05
Adhérent(e)
Distrib. : Bookworm
Noyau : Linux 6.0.0-4-amd64
(G)UI : Xfce et Lightdm
Inscription : 06-01-2020

Re : RESOLU - Erreur Apache2.

Bon ... décidément ...
Un localhost/adminer (que ce soit le fichier avec ou sans mysql, c'est la même chose) me donne des hiéroglyphes comme ci-dessous ...

$W){unset($tg[$z][$he]);if(is_array($W)){$tg[$z][stripslashes($he)]=$W;$tg[]=&$tg[$z][stripslashes($he)];}else$tg[$z][stripslashes($he)]=($ad?$W:stripslashes($W));}}}}function bracket_escape($v,$Na=false){static$ui=array(':'=>':1',']'=>':2','['=>':3','"'=>':4');return strtr($v,($Na?array_flip($ui):$ui));}function min_version($Zi,$De="",$h=null){global$g;if(!$h)$h=$g;$nh=$h->server_info;if($De&&preg_match('~([\d.]+)-MariaDB~',$nh,$C)){$nh=$C[1];$Zi=$De;}return(version_compare($nh,$Zi)>=0);}function charset($g){return(min_version("5.5.3",0,$g)?"utf8mb4":"utf8");}function script($yh,$ti="\n"){return"$yh$ti";}function script_src($Ni){return"\n";}function nonce(){return' nonce="'.get_nonce().'"';}function target_blank(){return' target="_blank" rel="noreferrer noopener"';}function h($P){return str_replace("\0","",htmlspecialchars($P,ENT_QUOTES,'utf-8'));}function nl_br($P){return str_replace("\n","
"
,$P);}function checkbox($D,$Y,$db,$me="",$uf="",$hb="",$ne=""){$I="".($uf?script("qsl('input').onclick = function () { $uf };",""):"");return($me!=""||$hb?"$I".h($me)."":$I);}function optionlist($_f,$gh=null,$Ri=false){$I="";foreach($_f as$he=>$W){$Af=array($he=>$W);if(is_array($W)){$I.='';}return$I;}function html_select($D,$_f,$Y="",$tf=true,$ne=""){if($tf)return"".(is_string($tf)?script("qsl('select').onchange = function () { $tf };",""):"");$I="";foreach($_f as$z=>$X)$I.="".h($X)."";return$I;}function select_input($Ia,$_f,$Y="",$tf="",$fg=""){$Yh=($_f?"select":"input");return"<$Yh$Ia".($_f?">



Vous avez une idée ?
Merci.
Roland.

En ligne

#13 03-08-2021 19:45:58

cyrille
CA Debian-Facile
Lieu : Nowhere
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : RESOLU - Erreur Apache2.

Apache démarre t il sans erreur ? Car sinon le php ne sera pas interprété...

Dernière modification par cyrille (03-08-2021 19:46:25)


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

Hors ligne

#14 03-08-2021 19:50:59

Roland05
Adhérent(e)
Distrib. : Bookworm
Noyau : Linux 6.0.0-4-amd64
(G)UI : Xfce et Lightdm
Inscription : 06-01-2020

Re : RESOLU - Erreur Apache2.

cyrille a écrit :

D'après ton tuto, pour accéder ce n'est pas localhost/phpmyadmin
mais via le port 9000

donc http://localhost:9000
ou IP_DU_SERVEUR:9000



Yes, j'avais oublié hmm.
Désormais, j'ai cette erreur :

Composer detected issues in your platform: Your Composer dependencies require the following PHP extensions to be installed: mysqli, xml



Et pour Apache, oui il me retourne des erreurs.
Avec la commande donnée plus haut par Anonyme, j'ai :

root@Debian:/var/www/html# apache2 -t
[Tue Aug 03 19:46:52.385644 2021] [core:warn] [pid 2750] AH00111: Config variable ${APACHE_RUN_DIR} is not defined
apache2: Syntax error on line 80 of /etc/apache2/apache2.conf: DefaultRuntimeDir must be a valid directory, absolute or relative to ServerRoot
 



Roland.

En ligne

#15 03-08-2021 19:55:38

Roland05
Adhérent(e)
Distrib. : Bookworm
Noyau : Linux 6.0.0-4-amd64
(G)UI : Xfce et Lightdm
Inscription : 06-01-2020

Re : RESOLU - Erreur Apache2.

En ligne 80 de apache2.conf, j'ai :

DefaultRuntimeDir ${APACHE_RUN_DIR}
 

En ligne

#16 03-08-2021 19:59:02

cyrille
CA Debian-Facile
Lieu : Nowhere
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : RESOLU - Erreur Apache2.

Composer detected issues in your platform: Your Composer dependencies require the following PHP extensions to be installed: mysqli, xml


Dans ce cas, il te manque les dépendances sus citées

apache2: Syntax error on line 80 of /etc/apache2/apache2.conf: DefaultRuntimeDir must be a valid directory, absolute or relative to ServerRoot


L'erreur est parlante, non erreur de syntaxe ligne 80
Tu peux nous montrer ce fichier

Il se peut aussi que ton DoucmentRoot dans la conf du répertoire virtuel pointe sur rien....

A mon avis que tu as un mic mac entre l'installation de phpmyadmin et d'admin et autres....

Dernière modification par cyrille (03-08-2021 20:01:18)


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

Hors ligne

#17 03-08-2021 20:04:00

cyrille
CA Debian-Facile
Lieu : Nowhere
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : RESOLU - Erreur Apache2.

Honnetement je purgerai ton installation afin de repartir sur du propre car là tu dois avoir un mélange de conf phpmyadmin / adminer....

"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

Hors ligne

#18 03-08-2021 20:11:33

Roland05
Adhérent(e)
Distrib. : Bookworm
Noyau : Linux 6.0.0-4-amd64
(G)UI : Xfce et Lightdm
Inscription : 06-01-2020

Re : RESOLU - Erreur Apache2.

cyrille a écrit :

Honnetement je purgerai ton installation afin de repartir sur du propre car là tu dois avoir un mélange de conf phpmyadmin / adminer....



Oui, je pense que c'est préférable ...
Désinstaller Apache, adminer et le reste peut suffire ou il faut une réinstall complète ?
Merci en tout cas ;).
Roland.

Edit : j'ai désinstallé tout ce que j'avais installé via le tuto et mes essais ...
Je réinstalleria uniquement Apache2, php7 et adminer tout après le repas.
Roland.

Dernière modification par Roland05 (03-08-2021 20:20:18)

En ligne

#19 03-08-2021 20:20:56

cyrille
CA Debian-Facile
Lieu : Nowhere
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : RESOLU - Erreur Apache2.

Essaie d'attaquer la base SQL en CLI voir si elle est configurée correctement

 mysql -u root -p



et au prompt mysql>
Saisir

 show databases ;



ça devrait te donner un truc du genre

mysql> show databases ;
+--------------------+
| Database           |
+--------------------+
| information_schema |
| mysql              |
| performance_schema |
| sys                |
+--------------------+
4 rows in set (0,00 sec)




J'avais fait un how to pour Mint il y a quelques temps, la marche à suivre était la mienne, ton tuto doit être bon
( https://forum-francophone-linuxmint.fr/ … 2&p=148999 )

Dernière modification par cyrille (03-08-2021 20:21:21)


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

Hors ligne

#20 03-08-2021 23:50:40

Roland05
Adhérent(e)
Distrib. : Bookworm
Noyau : Linux 6.0.0-4-amd64
(G)UI : Xfce et Lightdm
Inscription : 06-01-2020

Re : RESOLU - Erreur Apache2.

J'ai beau désinstaller Apache2, php, myadmin ... dès la réinstallation de php et d'Apache, j'ai toujours des erreurs bien que le local donne la page d'acceuil d'Apache !
J'ai suivi le guide d'install d'Apache (httpd et apr) mais le problème demeure.
Je suis en dual-boot W7 sur mon netbook connecté au net via smartphone en usb.
Je démarre la formation sql sur W7, trant pis sad.
Je verrai plus tard sous Debian !
Merci à Cyrille et à tous.
Roland.

Dernière modification par Roland05 (04-08-2021 13:47:29)

En ligne

#21 04-08-2021 09:40:48

jce76350
Membre
Lieu : Rouen
Distrib. : Debian_Bullseye 11.4
Noyau : 5.10.0-16-amd64
(G)UI : XFCE
Inscription : 24-08-2016
Site Web

Re : RESOLU - Erreur Apache2.

ET tu es sur d'avoir installé PHP ??
si tu veux faire une installation sans soucis mon tuto Installer PHP 7.3.x + MariaDB avec Debian 10 ou Installer PHP 8.x + MariaDB avec Debian 10

Dernière modification par jce76350 (04-08-2021 10:11:22)


--
Jc E

Hors ligne

#22 04-08-2021 10:40:34

Roland05
Adhérent(e)
Distrib. : Bookworm
Noyau : Linux 6.0.0-4-amd64
(G)UI : Xfce et Lightdm
Inscription : 06-01-2020

Re : RESOLU - Erreur Apache2.

Bonjour.
La nuit s'est passée ... et je préfère travailler sur Linux wink.
J'ai donc réinstallé Buster et allais vous demander la bonne manip pour installer proprement l'ensemble.
Je verrai cela ce soir tranquillement.
Merci Jce pour ton tuto.
Bonne journée.
Roland.

En ligne

#23 04-08-2021 15:38:47

Roland05
Adhérent(e)
Distrib. : Bookworm
Noyau : Linux 6.0.0-4-amd64
(G)UI : Xfce et Lightdm
Inscription : 06-01-2020

Re : RESOLU - Erreur Apache2.

jce76350 a écrit :


si tu veux faire une installation sans soucis mon tuto Installer PHP 7.3.x + MariaDB avec Debian 10



Bonjour Jce.
J'ai suivi ton tuto et quasi tout fonctionne. J'ai pas pu installer php8 en raison d'un certificat non valide. J'ai pas cherché plus n'ayant pas beaucoup de temps ... Pour le moment, php7.3 me suffira amplement !
J'ai bien l'error_reporting à 32767 wink.

Par contre, localhost/adminer.php me dit que ""Aucune des extensions PHP supportées (MySQLi, MySQL, PDO_MySQL) n'est disponible."" quand je me logue avec mon login user (roland).
J'ai du louper un truc ... grrrr wink.
Merci.
Roland.

P.S. : lors de la précédente install de Buster, j'avais sélectionné les bureaux Gnome, Cinnamon et le serveur web. Je pensais que je pouvais par la suite me loguer avec sad.
Mes problèmes d'erreurs apache et autres provenaient peut-être de là ...

En ligne

#24 04-08-2021 15:57:03

jce76350
Membre
Lieu : Rouen
Distrib. : Debian_Bullseye 11.4
Noyau : 5.10.0-16-amd64
(G)UI : XFCE
Inscription : 24-08-2016
Site Web

Re : RESOLU - Erreur Apache2.

adminer.php me dit que Aucune des extensions PHP supportées ET quand je me logue avec mon login user

- quelle version d'adminer. : Adminer 4.8.1 (.php, 465 kB) ?? et tu l'as mis ou ce fichier adminer.php ?
- pour les PHP tu as bien pris la ligne en A4b avec toutes les extensions ?
dons dans un phpinfo tu dois avoir Additional .ini files parsed  mysqli,  pdo_mysql
- le  loginuser celui du MariaDB ?  et en login avec root MariaDB c'est bon ?

Dernière modification par jce76350 (04-08-2021 17:44:24)


--
Jc E

Hors ligne

#25 04-08-2021 18:43:11

Roland05
Adhérent(e)
Distrib. : Bookworm
Noyau : Linux 6.0.0-4-amd64
(G)UI : Xfce et Lightdm
Inscription : 06-01-2020

Re : RESOLU - Erreur Apache2.

jce76350 a écrit :


- quelle version d'adminer. : Adminer 4.8.1 (.php, 465 kB) ?? et tu l'as mis ou ce fichier adminer.php ?
- pour les PHP tu as bien pris la ligne en A4b avec toutes les extensions ?
dons dans un phpinfo tu dois avoir Additional .ini files parsed  mysqli,  pdo_mysql
- le  loginuser celui du MariaDB ?  et en login avec root MariaDB c'est bon ?



C'est bon, no stress wink. J'ai fait une erreur dans les paquets php à installer. J'ai du en oublier 2 ou 3 ... ou quatre wink.
Adminer 4.8.1 (pas le for Mysql) de 465 kB, placé dans mon home/roland/sites (Là, j'avais suivi;)).
Un phpinfo donne ce que tu demandes avec pour Mysqli :

Client API library version  mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $


et pdo_mysqli :

Client API version  mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $

.

Log root Mariadb ok,
log user de Mariadb ... euh, comment tu fais ?
En replacant root par roland, ca va mieux wink.

Sinon, log Adminer sur firefox, OK merci.gif,
-

Version de MySQL : 5.5.5-10.3.29-MariaDB-0+deb10u1 via l'extension PHP MySQLi
Authentifié en tant que : roland@localhost


et 3 bdd

information_schema 
  mysql et  performance_schema



Voilà, un grand merci.gif à tous.
Cela a été une prise de tête kernal_panic.gif mais ça marche.

Je passe en résolu woohoo.gifwoohoo.gifwoohoo.gif.
Bonne soirée.
Roland.

Dernière modification par Roland05 (04-08-2021 18:47:56)

En ligne

Pied de page des forums