Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-10-2021 11:15:55

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.14.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

[résolu] elgato HD60S+ coupure automatique signal (USB)

bonjour à tous   smile  smile  smile

je possède un elgato HD60S+ .
très bel appareil de capture / streaming (sur obs)

https://www.elgato.com/en/game-capture-hd60-s-plus

malheureusement , quand je capture mon pc source ,
dès que le pc passe par un écran noir ,
l'elgato perd le signal et je suis obligé de débrancher / rebrancher l' USB  .
ce qui me fait perdre du temps et , potentiellement , louper mon démarrage (écran noir) .

j'ai posté ce problème à elgato , voilà leur réponse :

https://www.windowscentral.com/how-prev … sb-devices

mais comment désactiver l'extinction automatique (usb) ?
en clair , comment faire en sorte de ne pas perdre le signal sur le port usb à l'écran noir ?

il doit y avoir une commande , mais je la connais pas .

un coup de main ? une (des), piste(s) ?

merci .

amicalement ,

alain.

coyotus.png

p.s.: trouvé ceci :  https://qastack.fr/programming/4702216/ … with-linux

mais j'y comprends rien  .

un coup de main ? 

merci .

Dernière modification par Debian Alain (09-10-2021 20:54:11)

En ligne

#2 09-10-2021 20:15:41

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.14.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] elgato HD60S+ coupure automatique signal (USB)

sudo dmesg | grep usb

[ 8256.251622] input: Game Capture HD60 S+: Game Capt as /devices/pci0000:00/0000:00:01.2/0000:02:00.0/0000:03:08.0/0000:05:00.3/usb4/4-1/4-1:1.0/input/input34
[ 8256.252489] hid-generic 0003:0FD9:006A.000C: hiddev3,hidraw3: USB HID v1.01 Device [Elgato Game Capture HD60 S+] on usb-0000:05:00.3-1/input2
[ 8259.822209] usb 4-1: USB disconnect, device number 6
[ 8259.834951] usb 4-1: cannot submit urb (err = -19)
[ 8259.834991] usb 4-1: cannot submit urb 0, error -19: no device
[ 8260.546984] usb 4-1: new SuperSpeed USB device number 7 using xhci_hcd
[ 8260.571365] usb 4-1: LPM exit latency is zeroed, disabling LPM.
[ 8260.571965] usb 4-1: New USB device found, idVendor=0fd9, idProduct=006a, bcdDevice= 0.01
[ 8260.571969] usb 4-1: New USB device strings: Mfr=1, Product=2, SerialNumber=4
[ 8260.571971] usb 4-1: Product: Game Capture HD60 S+
[ 8260.571973] usb 4-1: Manufacturer: Elgato
[ 8260.571974] usb 4-1: SerialNumber: 0123456789000
[ 8260.654208] usb 4-1: Found UVC 1.10 device Game Capture HD60 S+ (0fd9:006a)
[ 8260.675343] input: Game Capture HD60 S+: Game Capt as /devices/pci0000:00/0000:00:01.2/0000:02:00.0/0000:03:08.0/0000:05:00.3/usb4/4-1/4-1:1.0/input/input35
[ 8260.676173] hid-generic 0003:0FD9:006A.000D: hiddev3,hidraw3: USB HID v1.01 Device [Elgato Game Capture HD60 S+] on usb-0000:05:00.3-1/input2
 



alain@sid:/sys/bus/usb/devices/4-1/power$ sudo nano control

on



j'ai réussi à modifier le fichier  "control" une fois le elgato branché .
l'opération est  fonctionnelle . je ne perds plus le signal .

mais , le périphérique de capture débranché , ce fichier n'est plus modifiable et revient à auto .

comment pérenniser la modification ?

amicalement ,

alain .

coyotus.png

merci .

Dernière modification par Debian Alain (09-10-2021 20:17:13)

En ligne

#3 09-10-2021 20:53:22

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.14.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] elgato HD60S+ coupure automatique signal (USB)

bon, apparement , j'ai trouvé la solution .

je teste .

oui , c'est bon .

voilà la soluce :

https://qastack.fr/programming/4702216/ … with-linux

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="usbcore.autosuspend=0 quiet"
GRUB_CMDLINE_LINUX=""
 



je clôt ce fil .

amicalement ,

alain.

coyotus.png

En ligne

#4 09-10-2021 20:57:55

raleur
Membre
Inscription : 03-10-2014

Re : [résolu] elgato HD60S+ coupure automatique signal (USB)

Sérieux ? nano pour écrire dans /sys ? (soupir)

Debian Alain a écrit :

ce fichier n'est plus modifiable et revient à auto .

comment pérenniser la modification ?


Ce n'est pas un vrai fichier, comme tout ce qui est dans /sys (sysfs). C'est une interface avec le noyau, les pilotes, modules...
Le module pilote de cet appareil a peut-être un paramètre pour contrôler la gestion d'énergie.
Sinon, on doit pouvoir utiliser une règle udev lors de l'initialisation de l'appareil, du style :

SUBSYSTEM=="usb", ACTION=="add", ATTR{idVendor}=="0fd9", ATTR{idProduct}=="006a", ATTR{power/control}="on"


dans un fichier /etc/udev/rules.d/elgato.rules

Edit: messages croisés. Ta solution s'applique à tous les périphériques USB, la mienne seulement au périphérique ciblé.

Dernière modification par raleur (09-10-2021 20:59:16)


Il vaut mieux montrer que raconter.

Hors ligne

#5 10-10-2021 11:18:09

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.14.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] elgato HD60S+ coupure automatique signal (USB)

oui , et  d'ailleurs , elle semble poser problème avec le fonctionnement de la  webcam sous obs .

voici la règle udev selon tes conseils :
(je l'ai recopiée)  

/etc/udev/rules.d$ cat elgato.rules


SUBSYSTEM=="usb",
ACTION=="add",
ATTR{idVendor}=="0fd9",
ATTR{idProduct}=="006a",
ATTR{power/control}="on"
 



udevadm control --reload-rules



j'ai bien fait ?

En ligne

#6 10-10-2021 13:10:49

raleur
Membre
Inscription : 03-10-2014

Re : [résolu] elgato HD60S+ coupure automatique signal (USB)

Debian Alain a écrit :

elle semble poser problème avec le fonctionnement de la  webcam sous obs


Quelle méthode pose problème ? usbcore.autosuspend=0 ou power/control=on ?

Debian Alain a écrit :

j'ai bien fait ?


Il faut tester et voir à l'usage si elle est efficace et n'a pas d'effet indésirable.
J'ignorais qu'on pouvait répartir une règle udev sur plusieurs lignes.


Il vaut mieux montrer que raconter.

Hors ligne

#7 10-10-2021 13:59:57

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.14.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] elgato HD60S+ coupure automatique signal (USB)

Quelle méthode pose problème ? usbcore.autosuspend=0 ou power/control=on ?


usbcore.autosuspend=0



https://www.malekal.com/comment-creer-l … dev-rules/
https://doc.ubuntu-fr.org/udev

n.b.: j'ai rectifié mon fichier  *.rules

cat elgato.rules


SUBSYSTEM=="usb", ACTION=="add", ATTR{idVendor}=="0fd9", ATTR{idProduct}=="006a", ATTR{power/control}="on"

Dernière modification par Debian Alain (10-10-2021 14:06:26)

En ligne

#8 10-10-2021 14:22:34

raleur
Membre
Inscription : 03-10-2014

Re : [résolu] elgato HD60S+ coupure automatique signal (USB)

Et ça marche ?

Il vaut mieux montrer que raconter.

Hors ligne

#9 10-10-2021 15:38:50

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.14.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] elgato HD60S+ coupure automatique signal (USB)

pas très bien mais çà marche à peu près .

obs a tendance à perdre le signal .

mais çà fonctionne à peu près .

En ligne

#10 14-10-2021 07:58:02

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.14.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] elgato HD60S+ coupure automatique signal (USB)

râleur , peut on tester la règle udev sans brancher le périphérique ?

style : 

udevadm test <règle>

En ligne

#11 14-10-2021 07:58:25

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.14.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] elgato HD60S+ coupure automatique signal (USB)

râleur , peut on tester la règle udev sans brancher le périphérique ?

style : 

udevadm test <règle>

En ligne

#12 15-10-2021 00:42:07

raleur
Membre
Inscription : 03-10-2014

Re : [résolu] elgato HD60S+ coupure automatique signal (USB)

Je l'ignore. D'après la page de manuel, on doit spécifier un périphérique, pas une règle.

Il vaut mieux montrer que raconter.

Hors ligne

Pied de page des forums