Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-10-2021 18:50:52

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Demande une version de LSB indisponnible chez Debian

TL;DR : imprimante EPSON P5000 pour un OS Debian
Driver officiel trouvé : http://download.ebz.epson.net/dsc/du/02 … da906710b4

Quand on essaye d'installer le .deb "require a version of LSB 3.4 or highter". LSB est un metapaquet chez debian qu'est pas plus haut en version que 0.11 sur sid :<

Comment ça se passe dans ces cas-là ? Installez Ubuntu et essayez encore ? tongue

Dernière modification par otyugh (29-10-2021 18:51:46)

En ligne

#2 29-10-2021 19:24:17

Tawal
Membre
Distrib. : Debian Stable à jour
Noyau : amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : Demande une version de LSB indisponnible chez Debian

Hello,

Consulte mon topic au sujet d'une EPSON ET-2710 avec le même souci de lsb : https://debian-facile.org/viewtopic.php?id=30856
Tu as une solution pour pallier à ce problème de lsb.
En fait, il faut installer en local l'ancien paquet lsb-compat disponible jusqu'à la version Stretch de Debian.
Ensuite, tu pourras installer le driver fourni par Epson.

Sinon, tu peux aussi tenter d'installer le paquet printer-driver-escpr, mais je ne vois pas ton modèle pris en charge par ce paquet sad

Edit:
lsb-compat pour Stretch : https://packages.debian.org/fr/stretch/lsb-compat
Il existe aussi pour Sid et c'est la même version que pour Stretch wink

Dernière modification par Tawal (29-10-2021 19:52:35)


Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

En ligne

#3 29-10-2021 21:05:20

Caribou22
Br3izhG33k =)
Lieu : 22, Côtes d'Armor, Bretagne
Distrib. : Debian Stable
Noyau : Sans pépins
(G)UI : Xfce, Gnome
Inscription : 10-11-2014
Site Web

Re : Demande une version de LSB indisponnible chez Debian

Salut smile

Tu as essayé d'installer ce paquet ? : https://packages.debian.org/source/bull … nter-escpr

Normalement c'est le même pilote Epson qui "fonctionne sans LSB".

En tout cas il m'a déjà dépanné pour des imprimantes Epson comme dans ton cas wink

Hors ligne

#4 29-10-2021 23:15:16

kawer
Membre
Lieu : Earth
Distrib. : Stable
Noyau : Current
(G)UI : Xfce
Inscription : 08-10-2013

Re : Demande une version de LSB indisponnible chez Debian

2 méthodes me viennent à l'esprit,

la première est d'installer un paquet proposé par debian (compilé ou à compiler) tel que proposé par Tawal et  Caribou22.
la seconde étant d'installer le paquet initial (d'epson) sans installer les dépendances (inutiles?) ..

Pour la seconde méthode, il est bon de rappeler la commande :

dpkg -i --ignore-depends=LSBCaca FrankeinEpsonPaquet.deb



G'luck.


Songez à ce que vous avez été, à ce que vous êtes, et à ce que vous serez un jour, et vous deviendrez humbles. Saint Vincent de Paul
La maladie la plus constante et la plus mortelle, mais aussi la plus méconnue de toute société, est l’indifférence. Abbé Pierre

Hors ligne

#5 30-10-2021 09:36:10

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : Demande une version de LSB indisponnible chez Debian

La prochaine fois que je la vois en install party je tente, et je vous dis ce qu'a marché smile
Merci en tous cas, ça me semble être les bonnes pistes (que j'avais pas trouvé en cherchant sur le moment).

En ligne

Pied de page des forums