Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-10-2021 23:10:21

Jkart
Membre
Distrib. : Bullseye
Noyau : 5.10.0-9-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Bullseye et secure boot (Résolu)

Bonjour,
J’ai Bullseye et Windows en dual boot.
Bullseye est installé sur un SSD externe qui se lance au démarrage de l’ordinateur, ce qui m’ouvre le Grub.
A l’origine j’avais désactivé le Secure boot pour effectuer l’installation de Debian (Stretch) que j’ai ensuite mise à niveau. Depuis Buster, Debian fonctionne avec le secure boot, j’ai donc décidé de le remettre. Pour cela j’ai réalisé deux choses dans le Bios
- j’ai activé l’amorçage sécurisé
- au niveau de « Propriétés des clés » j’ai remis « Touches Hp » à la place de «Touches personnalisées »
Ce deuxième point est indispensable sinon le secure boot ne s’active pas et j’obtiens un "disabled" avec la commande
 

bootctl status


- j’ai enregistré les modifications

Le problème c’est que une fois que j’ai réalisé cela, au démarrage de l’ordinateur, j’obtiens une fenêtre rouge avec « signature non valide détectée » et  si je fais « enter »l’ordinateur se lance directement sur Windows sans passer par le Grub. Je peux vérifier que le secure boot est activé dans les « Informations système ».

Comment peut-on valider la signature du Grub et/ou de Bullseye ? J’ai réinstallé le Grub mais cela n’a rien donné.
Merci

Dernière modification par Jkart (01-11-2021 17:14:44)


Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Bullseye 11.1/Windows 10
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#2 29-10-2021 23:22:54

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux -5.14.0-4-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Bullseye et secure boot (Résolu)

j'ai pas bien compris ta question Jkart  .  roll  roll  roll

pour ma part , sur un bios uefi , j'ai mis en dual boot windows 11 et bullseye (même disk, un vieux nvme)

j'ai réglé le sécure boot  et le tpm , et , dans les options de boot , je démarre sur debian .

ce qui fait que j'obtiens le grub et je peux choisir , comme je veux , de démarrer sur w$ ou sur Lx .

c' est de çà que tu voulais parler ?

amicalement ,

alain .

coyotus.png

Hors ligne

#3 30-10-2021 08:42:37

raleur
Membre
Inscription : 03-10-2014

Re : Bullseye et secure boot (Résolu)

Vérifications de base :

efibootmgr -v
ls -l /boot/efi/efi/{boot,debian}/
apt-cache policy grub-efi-amd64-signed shim-signed


Il vaut mieux montrer que raconter.

Hors ligne

#4 30-10-2021 11:13:22

Jkart
Membre
Distrib. : Bullseye
Noyau : 5.10.0-9-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Re : Bullseye et secure boot (Résolu)

Bonjour et merci pour vos réponses,

Pour faire court et pour répondre à Alain. Oui c'est bien de cela dont je veux parler.
L'installation d'origine Stretch a été faite avec le secure boot désactivé
Avec l'installation actuelle (Bullseye) si je remet le secure boot (Activation du secure boot + Proriétés des clés/Touches Hp) le Grub n'apparait pas, j'installe directement Windows.

Et pour répondre à Raleur

efibootmgr -v



BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001,0000
Boot0000* Windows Boot Manager  HD(1,GPT,0fa7e086-0c84-4fd7-9ab0-e6a8b7c5181e,0x800,0x82000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot0001* UEFI: Samsung Portable SSD T5 0 PciRoot(0x0)/Pci(0x14,0x0)/USB(23,0)/HD(1,MBR,0xf8914be7,0x800,0x64000)..BO




ls -l /boot/efi/efi/{boot,debian}/



/boot/efi/efi/boot/:
total 1474
-rwx------ 1 root root 1508720 26 avril  2019 BOOTX64.EFI

/boot/efi/efi/debian/:
total 3456
-rwx------ 1 root root     108 29 oct.  22:55 BOOTX64.CSV
-rwx------ 1 root root   84648 29 oct.  22:55 fbx64.efi
-rwx------ 1 root root     128 29 oct.  22:55 grub.cfg
-rwx------ 1 root root 1672576 29 oct.  22:55 grubx64.efi
-rwx------ 1 root root  845480 29 oct.  22:55 mmx64.efi
-rwx------ 1 root root  934240 29 oct.  22:55 shimx64.efi





apt-cache policy grub-efi-amd64-signed shim-signed



grub-efi-amd64-signed:
  Installé : 1+2.04+20
  Candidat : 1+2.04+20
 Table de version :
 *** 1+2.04+20 500
        500 [url]https://deb.debian.org/debian[/url] bullseye/main amd64 Packages
        100 /var/lib/dpkg/status
shim-signed:
  Installé : 1.38+15.4-7
  Candidat : 1.38+15.4-7
 Table de version :
 *** 1.38+15.4-7 500
        500 [url]https://deb.debian.org/debian[/url] bullseye/main amd64 Packages
        100 /var/lib/dpkg/status

Dernière modification par Jkart (30-10-2021 11:21:38)


Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Bullseye 11.1/Windows 10
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#5 30-10-2021 11:43:44

raleur
Membre
Inscription : 03-10-2014

Re : Bullseye et secure boot (Résolu)

Dans les variables d'amorçage UEFI, efibootmgr montre qu'il n'y a pas d'entrée d'amorçage EFI spécifique pour Debian. Il n'y a qu'une entrée pour Windows et une entrée non spécifique pour le SSD externe que je suppose utiliser le chemin de support amovible.

Dans la partition système EFI, le chemin spécifique à Debian efi/debian contient bien les fichiers pour le secure boot (shim et compagnie) mais ça ne sert à rien sans entrée d'amorçage EFI correspondante dans les variables d'amorçage EFI ; le chemin de support amovible efi/boot/ ne contient qu'un fichier bootx64.efi qui, vu sa date, doit correspondre au fichier grubx64.efi non signé de stretch.

Tu as trois options :
a) Créer une entrée d'amorçage EFI pour Debian.
b) Installer un GRUB signé dans le chemin de support amovible
c) Faire les deux

L'option a) ne rendra le SSD amorçable avec secure boot que sur cette machine. Les options b) et c) peuvent le rendre amorçable avec secure boot sur n'importe quelle machine.

Pour a), il y a la méthode manuelle avec efibootmgr et les options qui vont bien (voir page de manuel) ou la méthode automatique par réinstallation du chargeur d'amorçage avec la commande "grub-install" sans argument en root, puis vérification avec efibootmgr.

Pour b), il y a différentes méthodes plus ou moins propres :
- copier les fichiers de /boot/efi/efi/debian dans /boot/efi/efi/boot et y renommer shimx64.efi en bootx64.efi
- réinstaller le chargeur d'amorçage avec

grub-install --force-extra-removable --no-nvram


- reconfigurer le paquet grub-efi-amd64 avec

dpkg-reconfigure grub-efi-amd64


en choisissant "installer dans le chemin de support amovible : oui" et "mettre à jour la NVRAM : non". Méthode recommandée car elle s'appliquera aux futures mises à jour de GRUB.

Pour c), ça ressemble à b) + mise à jour la NVRAM, plusieurs méthodes aussi :
- réinstaller le chargeur d'amorçage avec

grub-install --force-extra-removable


- reconfigurer le paquet grub-efi-amd64 avec

dpkg-reconfigure grub-efi-amd64


en choisissant "installer dans le chemin de support amovible : oui" et "mettre à jour la NVRAM : oui". Méthode recommandée car elle s'appliquera aux futures mises à jour de GRUB.

Dernière modification par raleur (30-10-2021 11:44:53)


Il vaut mieux montrer que raconter.

Hors ligne

#6 30-10-2021 16:07:25

Jkart
Membre
Distrib. : Bullseye
Noyau : 5.10.0-9-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Re : Bullseye et secure boot (Résolu)

sdb1 étant la partition EFI dus SSD externe, j'ai tenté

grub-install /dev/sdb1
update-grub


L'installation semble s'être réalisée mais cela ne change rien à mon problème avec le secure boot.

Tentative avec une solution de Raleur
J'ai copié les fichier de boot/efi/efi/debian/ dans boot/afi/efi/boot/. Cependant le fichier shimx64.efi ne peut être renommé en bootx64.efi car il existe déjà. Le nom a t'il de l'importance? Peut-on l'appeler autrement ou faut-il supprimer le bootx64.efi original?


Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Bullseye 11.1/Windows 10
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#7 30-10-2021 16:45:02

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux -5.14.0-4-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Bullseye et secure boot (Résolu)

bonjour Jkart   big_smile  big_smile  big_smile

faudrai vérifier mais je crois que , dans le bios ,
l'option "sécure boot" ne s'active par défaut que  avec windows .
si tu veux l'activer avec linux , il faut choisir "autre os" .

tu as quoi comme carte mère ?

dmesg | grep DMI:



amicalement ,

alain .

coyotus.png

Dernière modification par Debian Alain (30-10-2021 16:48:52)

Hors ligne

#8 30-10-2021 17:04:17

Jkart
Membre
Distrib. : Bullseye
Noyau : 5.10.0-9-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Re : Bullseye et secure boot (Résolu)

Bonjour Alain,
J'ai pas mal fouillé dans le Bios et je n'ai jamais vu "autre OS". J'irai voir à nouveau, cependant il faut que le secure boot, en raison du dual boot, fonctionne avec Debian et Windows.

dmesg | grep DMI:


[    0.000000] DMI: HP HP Pavilion Gaming Desktop PC/843B, BIOS F.46 08/03/2021

Dernière modification par Jkart (30-10-2021 17:05:02)


Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Bullseye 11.1/Windows 10
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#9 30-10-2021 17:26:06

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux -5.14.0-4-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Bullseye et secure boot (Résolu)

Jkart , big_smile  big_smile  big_smile

voilà quelques photos , qui , je l'espère , te parleront .
c'est le même bios (uefi) sur toutes les photos ,
mais , je l'ai passé en anglais vers la  fin pour  que tu puisses te repérer plus facilement .

ma configuration générale :  s28wntY.png

configuration de mon démarrage :  UqcaSUk.png

sécure boot bien configuré pour  avoir le double démarrage mixte w$ / Lx :  4gwAVzT.png

erreur à ne pas faire dans le cas d'un démarrage mixte :  KKqermz.png

dis moi si çà peut t'aider .
je cherche de la doc sur ton pc , en attendant .
je n'ai pas trouvé la doc que je cherchais .

Dernière modification par Debian Alain (30-10-2021 17:29:41)

Hors ligne

#10 30-10-2021 18:40:56

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux -5.14.0-4-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Hors ligne

#11 30-10-2021 19:42:24

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : Bullseye et secure boot (Résolu)

Bonsoir
@Debian Alain
autre os = secure boot désactivé
windows = secure-boot actif
uniquement pour Asus donc mauvais exemple pour Jkart
bref tu ne l'aide pas trop sur le coup
j'ai une petite idée pour son souci , mais laisse faire raleur , on est pas autorisé a aider , on est trop C.........   tongue     old_geek.gif
out.gif

En ligne

#12 30-10-2021 21:55:31

raleur
Membre
Inscription : 03-10-2014

Re : Bullseye et secure boot (Résolu)

Jkart a écrit :

j'ai tenté
grub-install /dev/sdb1
update-grub


Ce qui ne correspond à rien de  ce que j'ai suggéré.

Jkart a écrit :

le fichier shimx64.efi ne peut être renommé en bootx64.efi car il existe déjà


Tu fais l'opération avec un gestionnaire de fichiers graphique ? Utilise plutôt "mv" en ligne de commande, tu n'auras pas cet inconvénient.

Jkart a écrit :

Le nom a t'il de l'importance?


Plutôt, oui. C'est ce nom que le firmware UEFI recherche.

Jkart a écrit :

faut-il supprimer le bootx64.efi original?


Si tu veux absolument utiliser un gestionnaire de fichiers graphique qui refuse de renommer un fichier en remplaçant le fichier de même nom, oui...

robert2a a écrit :

j'ai une petite idée pour son souci


Si ça n'implique pas une interminable digression hors sujet, ne te gêne pas.

Dernière modification par raleur (30-10-2021 21:56:21)


Il vaut mieux montrer que raconter.

Hors ligne

#13 30-10-2021 23:47:28

Jkart
Membre
Distrib. : Bullseye
Noyau : 5.10.0-9-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Re : Bullseye et secure boot (Résolu)

Bonsoir et merci pour vos réponses,

Pour Alain
Les images présentées sont assez éloignées de la présentation de mon Bios/EFI. Je suis retourné dans le Bios Hp et il n'y a pas de chois entre Windows et autres OS. Le lien pour le site Hp est intéressant et conforte ce que j'ai pu réaliser.

Pour Raleur

Raleur a écrit :
Ce qui ne correspond à rien de  ce que j'ai suggéré.


C'est exact.

Suite:
J'ai donc copié (méthode graphique) les fichiers de boot/efi/efi/debian/ dans boot/afi/efi/boot/, puis renommé le fichier shimx64.efi en bootx64.efi
Puis:

grub-install --force-extra-removable --no-nvram



Installation pour la plate-forme x86_64-efi.
Installation terminée, sans erreur.



dpkg-reconfigure grub-efi-amd64


Raleur a écrit:
en choisissant "installer dans le chemin de support amovible : oui" et "mettre à jour la NVRAM : non". Méthode recommandée car elle s'appliquera aux futures mises à jour de GRUB.


Installation pour la plate-forme x86_64-efi.
Installation terminée, sans erreur.
Generating grub configuration file ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Found linux image: /boot/vmlinuz-5.10.0-9-amd64
Found initrd image: /boot/initrd.img-5.10.0-9-amd64
Found linux image: /boot/vmlinuz-5.10.0-8-amd64
Found initrd image: /boot/initrd.img-5.10.0-8-amd64
Found Windows Boot Manager on /dev/nvme0n1p1@/efi/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for EFI firmware configuration
done
Traitement des actions différées (« triggers ») pour shim-signed:amd64 (1.38+15.4-7) ...




efibootmgr -v


BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0002,0001,0000
Boot0000* Windows Boot Manager  HD(1,GPT,0fa7e086-0c84-4fd7-9ab0-e6a8b7c5181e,0x800,0x82000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot0001* UEFI: Samsung Portable SSD T5 0 PciRoot(0x0)/Pci(0x14,0x0)/USB(23,0)/HD(1,MBR,0xf8914be7,0x800,0x64000)..BO
Boot0002* debian  HD(1,MBR,0xf8914be7,0x800,0x64000)/File(\EFI\debian\shimx64.efi)




Je vais maintenant activer le Secure Boot et observer le résultat. Retour demain après une bonne nuit de sommeil.
Bonne nuit.
Jkart

Dernière modification par Jkart (31-10-2021 12:51:38)


Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Bullseye 11.1/Windows 10
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#14 31-10-2021 09:14:30

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux -5.14.0-4-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Bullseye et secure boot (Résolu)

bonjour Jkart big_smile  big_smile  big_smile

Jkart  a écrit :

Les images présentées sont assez éloignées de la présentation de mon Bios/EFI. Je suis retourné dans le Bios Hp et il n'y a pas de chois entre Windows et autres OS.

oui , je m'en suis douté assez rapidement .mais , pour commencer , c'est tout ce qui m'est venu à l'esprit .

Jkart  a écrit :

Le lien pour le site Hp est intéressant et conforte ce que j'ai pu réalisé

.oui , quelques recherches m'ont amené  là . mais la doc est difficile à trouver . et ton pc est une technologie propriétaire , donc fermée . ce qui complique  beaucoup les choses.

j'espère quand même avoir pu t'aider  au moins un peu . non ?

amicalement ,

alain.

coyotus.png

Hors ligne

#15 31-10-2021 13:12:17

Jkart
Membre
Distrib. : Bullseye
Noyau : 5.10.0-9-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Re : Bullseye et secure boot (Résolu)

Bonjour à tous,

Pour Alain,
Je suis souvent dans le brouillard. Le fait d'être conforté dans ses choix est toujours rassurant et donc utile. Merci.

I Je poursuis le post d'hier soir.

ls -l /boot/efi/efi/{boot,debian}/



/boot/efi/efi/boot/:
total 4930
-rwx------ 1 root root     108 30 oct.  15:56 BOOTX64.CSV
-rwx------ 1 root root  934240 31 oct.  00:23 BOOTx64.efi
-rwx------ 1 root root   84648 31 oct.  00:16 fbx64.efi
-rwx------ 1 root root     128 30 oct.  15:56 grub.cfg
-rwx------ 1 root root 1672576 31 oct.  00:23 grubx64.efi
-rwx------ 1 root root  845480 30 oct.  15:56 mmx64.efi
-rwx------ 1 root root 1508720 27 avril  2019 OriginalBOOTX64.EFI

/boot/efi/efi/debian/:
total 3456
-rwx------ 1 root root     108 31 oct.  00:23 BOOTX64.CSV
-rwx------ 1 root root   84648 31 oct.  00:23 fbx64.efi
-rwx------ 1 root root     128 31 oct.  00:23 grub.cfg
-rwx------ 1 root root 1672576 31 oct.  00:23 grubx64.efi
-rwx------ 1 root root  845480 31 oct.  00:23 mmx64.efi
-rwx------ 1 root root  934240 31 oct.  00:23 shimx64.efi



II Après activation du secure boot dans le bios (Secure boot activé + Propriétés des clés / Touches Hp) 

Au démarrage de Debian un message de type

failed to start load kernel module




bootctl status



Couldn't find EFI system partition. It is recommended to mount it to /boot or /efi.
Alternatively, use --esp-path= to specify path to mount point.
System:
     Firmware: n/a (n/a)
  Secure Boot: enabled
   Setup Mode: user
 Boot into FW: supported

Current Boot Loader:
      Product: n/a
     Features: ✗ Boot counting
               ✗ Menu timeout control
               ✗ One-shot menu timeout control
               ✗ Default entry control
               ✗ One-shot entry control
               ✗ Support for XBOOTLDR partition
               ✗ Support for passing random seed to OS
               ✗ Boot loader sets ESP partition information
          ESP: n/a
         File: └─n/a

Random Seed:
 Passed to OS: no
 System Token: not set

Boot Loaders Listed in EFI Variables:
        Title: Windows Boot Manager
           ID: 0x0000
       Status: active, boot-order
    Partition: /dev/disk/by-partuuid/0fa7e086-0c84-4fd7-9ab0-e6a8b7c5181e
         File: └─/EFI/MICROSOFT/BOOT/BOOTMGFW.EFI



Le Secure Boot fonctionne donc.

Problème, gênant, de définition immédiatement observable.
La définition de l’écran ne peut plus être changée ni par l’utilitaire graphique de Xfce (Click droit puis Applications/Paramètres/Affichage) ni en ligne de commande (xrandr).

xrandr



xrandr: Failed to get size of gamma for output default
Screen 0: minimum 3840 x 2160, current 3840 x 2160, maximum 3840 x 2160
default connected 3840x2160+0+0 0mm x 0mm
   3840x2160     88.00*



Y a t-ils d'autres problèmes que je vais découvrir peu à peu? Pourquoi ces problèmes et comment les résoudre?


Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Bullseye 11.1/Windows 10
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#16 31-10-2021 13:16:14

raleur
Membre
Inscription : 03-10-2014

Re : Bullseye et secure boot (Résolu)

Si tu utilises un pilote propriétaire Nvidia ou autre module compilé localement, il faut le signer pour le secure boot.

Dernière modification par raleur (31-10-2021 13:16:35)


Il vaut mieux montrer que raconter.

Hors ligne

#17 31-10-2021 13:53:13

Jkart
Membre
Distrib. : Bullseye
Noyau : 5.10.0-9-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Re : Bullseye et secure boot (Résolu)

Bonjour,

J'utilise effectivement le pilote Nvidia (installé il y a 2-3 ans)

apt policy nvidia-driver



nvidia-driver:
  Installé : 460.91.03-1
  Candidat : 460.91.03-1
 Table de version :
 *** 460.91.03-1 500
        500 https://deb.debian.org/debian bullseye/non-free amd64 Packages
        100 /var/lib/dpkg/status



Je pourrais peut être, car signer le pilote Nvidia me semble compliqué, le remplacer par le nouveau qui a sans doute évolué depuis 2,5 ans?

grep -B2 'Module class: X.Org Video Driver' /var/log/Xorg.0.log



[   354.438] (II) Module nouveau: vendor="X.Org Foundation"
[   354.438]  compiled for 1.20.10, module version = 1.0.17
[   354.438]  Module class: X.Org Video Driver
--
[   354.439] (II) Module modesetting: vendor="X.Org Foundation"
[   354.439]  compiled for 1.20.11, module version = 1.20.11
[   354.439]  Module class: X.Org Video Driver
--
[   354.439] (II) Module fbdev: vendor="X.Org Foundation"
[   354.439]  compiled for 1.20.0, module version = 0.5.0
[   354.439]  Module class: X.Org Video Driver
--
[   354.440] (II) Module vesa: vendor="X.Org Foundation"
[   354.440]  compiled for 1.20.9, module version = 2.5.0
[   354.440]  Module class: X.Org Video Driver

Dernière modification par Jkart (31-10-2021 13:54:52)


Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Bullseye 11.1/Windows 10
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#18 31-10-2021 14:11:44

Jkart
Membre
Distrib. : Bullseye
Noyau : 5.10.0-9-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Re : Bullseye et secure boot (Résolu)

Pour compléter le message précédent je viens de m'apercevoir que le pilote "nouveau" est lui aussi installé.

apt policy xserver-xorg-video-nouveau



xserver-xorg-video-nouveau:
  Installé : 1:1.0.17-1
  Candidat : 1:1.0.17-1
 Table de version :
 *** 1:1.0.17-1 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status



Si je supprime le pilote Nvidia cela posera-t'il des problèmes?


Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Bullseye 11.1/Windows 10
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#19 31-10-2021 14:28:27

raleur
Membre
Inscription : 03-10-2014

Re : Bullseye et secure boot (Résolu)

Les pilotes nouveau du noyau et de X.org sont installés par défaut. Mais ils sont peut-être désactivés par les pilotes Nvidia (fichier blacklist dans /etc/modprobe.d/ pour le module nouveau du noyau). J'ignore s'ils peuvent gérer correctement ta carte graphique avec les performances dont tu as besoin, tout autant que j'ignore si on peut les réactiver et désactiver les pilotes Nvidia sans désinstaller ces derniers. Si tu désinstalles les pilotes Nvidia et que les pilotes nouveau ne prennent pas correctement en charge ta carte graphique, cela posera certainement des problèmes, pouvant aller de l'absence d'affichage graphique au plantage total au démarrage.

Je laisse la suite aux connaisseurs de ces problématiques. J'en vois deux qui sont déjà intervenus dans cette discussion.

Dernière modification par raleur (31-10-2021 14:29:25)


Il vaut mieux montrer que raconter.

Hors ligne

#20 31-10-2021 14:53:07

Jkart
Membre
Distrib. : Bullseye
Noyau : 5.10.0-9-amd-64
(G)UI : Xfce
Inscription : 16-12-2017

Re : Bullseye et secure boot (Résolu)

Je te remercie Raleur pour ton aide.

Tour: HP Pavilion 690-0095nf
Ram 8 giga  SSD 128 giga Disque 1T
Bullseye 11.1/Windows 10
Intel(R) i7 8700 Nvidia GTX 1050ti

Hors ligne

#21 31-10-2021 20:33:48

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : Bullseye et secure boot (Résolu)

Bonjour
je suis sur Arch Linux maintenant et je n'installe plus de gpu nvidia (intel ou amd comme préconisé par debian)
je vais me faire plus rare ici pour le plaisir de certains  tongue

bref le noyau est signé , le grub est signé , la logique voudrait que le driver nonfree soit signé sur debian
je vais me renseigner , mais la doc officielle de nvidia (pour linux) explique comment signer un driver

pour nouveau normal qu'il soit installé , et le driver nvidia le blacklist automatiquement (rien a faire) il faut aussi installer le firmware-misc-nonfree pour le cas ou on retourne sous nouveau (il contient les ".bin" pour certaines cartes nvidia)
pour répondre a la question sous nouveau , la carte va poser problème ? , il faut connaître le type de carte de la machine et si pris en charge par bullseye
oui nouveau sera moins performant que le driver nvidia

ps: je pense que debian va s'adapter au couple "TPM + Secure-boot" mais c'est le "mal" dans le monde du libre

pour terminer a ma connaissance il n'est pas possible de désactiver nvidia et activer nouveau sans désinstaller le driver nvidia
ps: pour info Debian Alain est full AMD et il n'aime pas nvidia  tongue

remarque: normalement c'est "modeset" (KMS du noyau) qui va charger le driver "nouveau" ,  mais vaut mieux conserver le paquet "xserver-xorg-video-nouveau" installé .

En ligne

#22 31-10-2021 20:41:38

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : Bullseye et secure boot (Résolu)

un wiki pour signer le driver nvidia sous  debian => https://wiki.debian.org/SecureBoot

je rajoute deux liens sur ubuntu
=> https://wiki.ubuntu.com/UEFI/SecureBoot
=> https://wiki.ubuntu.com/UEFI/SecureBoot/Signing

tu va trouver plein de lien sur le net sur le sujet , avec l'arrivé de windows11 , le double "boot" risque d'être compliqué
j'ai abandonné les tests , je garde ma liberté  wink

Force et Courage

ps: demande a raleur comment ça se passe lors d une mise a jour d'un driver signer ?

Dernière modification par robert2a (31-10-2021 20:55:46)

En ligne

#23 31-10-2021 21:08:43

raleur
Membre
Inscription : 03-10-2014

Re : Bullseye et secure boot (Résolu)

Aucune idée. Le sujet ne me concerne pas ni ne m'intéresse.

Il vaut mieux montrer que raconter.

Hors ligne

#24 01-11-2021 10:33:23

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux -5.14.0-4-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Bullseye et secure boot (Résolu)

Jkart , big_smile big_smile  big_smile

je crois que , pour l'instant , le sécure boot est limité à windows et aux systemes compatibles windows .

c.a.d. pas grand chose d'autre .

donc linux ... ben , c'est à craindre , pour longtemps encore , qu'il ne soit pas compatible .
il faut donc désactiver le sécure boot pour assurer la compatibilité mixte w$ / Lx .

avec l'arrivée sur le marché de w$11 , çà se complique encore : sécure boot et tpm exigés .
sur ma petite config (w$ / Lx , asus b550m-k) je te l'ai pas montré clairement ,
j' ai désactivé le sécure boot (photos) et quant au tpm (là je te l'ai pas montré) ,
je sais plus ce que j'en ai fait .
je crois qu' il est intégré à l'APU (Ryzen5 5600G) donc  activé par défaut .
mais je me demande si je l'ai pas  désactivé .
faudrai que je partage des photos de mon bios pour savoir .

amicalement ,

alain .

coyotus.png

Hors ligne

#25 01-11-2021 11:42:38

raleur
Membre
Inscription : 03-10-2014

Re : Bullseye et secure boot (Résolu)

Debian Alain a écrit :

le sécure boot est limité à windows et aux systemes compatibles windows


Qu'est-ce que tu veux dire ? Qu'entends-tu par "système compatible Windows" ?

Debian Alain a écrit :

il faut donc désactiver le sécure boot pour assurer la compatibilité mixte w$ / Lx


Pourquoi ? Linux support le secure boot.


Il vaut mieux montrer que raconter.

Hors ligne

Pied de page des forums