Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-11-2021 15:29:13

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Buster (10)
Noyau : Linux 4.19.37-5
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Ma Debian comme serveur local

Bonjour,

j'aurai besoin prochainement de mettre ma Debian au centre d'un petit réseau local pour en faire le serveur HTTP de tous les usagers ( j'ignore ce qu'ils auront comme systèmes - Win, Mac, Linux, téĺephones, ... )

Je lis ceci http://www.linux-france.org/article/serveur/dns.html mais ça date de 1999 !

Description du but:
Ma Debian offre un site  auquel tous les usagers doivent se connecter FACILEMENT;
Je veux que ma Debian réponse à un nom de domaine simulé

Contexte
Il n'y a pas d'accès à internet dans le décor, seulement un réseau local.
J'ai un routeur LAN / Wifi à ma disposition, c'est un LinkSys

État actuel
Dans mon serveur Apache2, j'ai défini une adresse 127.0.0.1 et une autre 127.0.0.2  qui fonctionnent bien sur ma Debian seulement.
Mon fichier /etc/host est le suivant:


cat /etc/host
127.0.0.1 localhost.net localhost
127.0.0.2 patriboom.net patriboom
 



L'adresse de ma Debian est fixée à 192.168.1.244 sur le réseau local


Objectif final
Que les usagers aillent sur le site patriboom.net  et atteignent le site qui leur est désigné.

Résultat actuel
Sur ma Debian:  « patriboom.net » ne mène nulle part
Sur un ordinateur local en Windows:  l'adresse 192.168.0.244 mène à localhost  ( 127.0.0.1 ) et l'accès aux sous-répertoire est interdit


Pouvez-vous m'aiguiller vers un tuto qui m'aiderait ?
Je ne sais pas quel vocabulaire je dois utiliser pour trouver mes réponses.


Merci.


Portez la paix
Patrick Allaire, ptre

Hors ligne

#2 03-11-2021 21:04:49

raleur
Membre
Inscription : 03-10-2014

Re : Ma Debian comme serveur local

Patriboom a écrit :

Dans mon serveur Apache2, j'ai défini une adresse 127.0.0.1 et une autre 127.0.0.2


Vague.

Patriboom a écrit :

qui fonctionnent bien sur ma Debian seulement.


Vague.

Patriboom a écrit :

le site qui leur est désigné.


Vague.

Patriboom a écrit :

Sur ma Debian:  « patriboom.net » ne mène nulle part


Vague.

Patriboom a écrit :

Sur un ordinateur local en Windows:  l'adresse 192.168.0.244 mène à localhost  ( 127.0.0.1 )


Vague.


Il vaut mieux montrer que raconter.

Hors ligne

#3 03-11-2021 22:58:10

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Buster (10)
Noyau : Linux 4.19.37-5
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Ma Debian comme serveur local

Bonjour

ReseauLocal.jpg

Tentons ici d'être plus clair.

Serveur apache 2
Mon ordinateur sous Debian a un serveur Apache2 actif.  Ci-haut, c'est l'ordinateur D.
Ce dernier a l'adresse interne 127.0.0.1 (localhost) comme le veut la tradition.  Cette adresse pointe vers /var/www/html
Il a aussi une adresse 127.0.0.2 ( patriboom.net ).  Cette adresse point vers /var/www/html/MesSites/MonSite

IP du réseau local
Mon serveur (appareil D) reçoit l'adresse 192.168.1.244 du DHCP  ( routeur à la fois câble et wifi, au centre des appareils ci-haut )


Objectif
Que les appareils A, B, C et F visitent le site  patriboom.net (oui, en écrivant cette adresse-là bien précisément dans la barre d'adresse)


Résultats actuellement obtenus
1. Comme usager de l'appareil D
     L'adresse 127.0.0.1 répond adéquatement (serveur web) en retournant le contenu de /var/www/html/index.php et tous les sous-répertoire
     L'adresse 172.0.0.2 répond adéquatement (serveur web) en retournant le contenu de /var/www/html/MesSites/MonSite/index.php
     L'adresse patriboom.net me retourne un message d'erreur (site introuvable )

2. Comme usager de l'apapreil B
    L'adresse 192.168.1.244 me retourne la réponse du serveur web /var/www/html/index.php
          Cependant, les sous-sites ne sont pas accessibles ( cliquer sur un lien de la page menant vers /var/www/html/MesSites/index.php est refusé)

3. Je veux que l'usager de l'appareil B puisse
     Inscrire l'adresse « patriboom.net » et voit le site /var/www/html/MesSites/MonSite/index.php s'afficher


Comme faire ?

Merci.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#4 04-11-2021 00:17:20

raleur
Membre
Inscription : 03-10-2014

Re : Ma Debian comme serveur local

Apparemment tu n'as pas compris. Relis ma signature. Montre tes fichiers de configuration. Montre leS URL, messages d'erreur... exacts et complets.

Patriboom a écrit :

Je veux que l'usager de l'appareil B puisse Inscrire l'adresse « patriboom.net »


Tu as un serveur DNS ?


Il vaut mieux montrer que raconter.

Hors ligne

#5 04-11-2021 00:51:49

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Buster (10)
Noyau : Linux 4.19.37-5
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Ma Debian comme serveur local

J'ai trouvé le tuto suivant:   https://le-guide-du-sysops.fr/index.php … bian-10-x/

Et j'ai pu faire en sorte que mon serveur me réponde localement à patriboom.net
Voici comment:

la ligne suivante a été ajoutée au fichier /etc/hosts

127.0.0.2       patriboom.net




/etc/hosts est donc celui-ci

/etc# cat hosts
127.0.0.1 localhost
127.0.0.2 patriboom.net
127.0.0.2 sa.sibi

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
 



J'ai aussi apporté des changements à mon routeur et serveur DHCP, mais ce ne semble pas encore suffire à mon projet, car l'ordinateur B ne trouve toujours pas le nom de domaine.

Ça progresse.

Dernière modification par Patriboom (04-11-2021 00:55:57)


Portez la paix
Patrick Allaire, ptre

Hors ligne

#6 04-11-2021 02:28:44

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Buster (10)
Noyau : Linux 4.19.37-5
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Ma Debian comme serveur local

Bonjour à tosu,

J'avance encore,

en suivant ce même tuto j'arrive à pingner mon serveur à partir d'un ordinateur du réseau local.

ping debian.partriboom.net


répond bien.

Voici les fichiers créés dans /etc/bind ;

/etc/bind/named.conf.local

zone "patriboom.net" {
  type master;
  file "/etc/bind/db.patriboomNET";
};
zone "1.168.192.in-addr.arpa" {
  type master;
  file "/etc/bind/db.1.168.192.in-addr.arpa";
};
 



/etc/bind/db.patriboomNET

TTL 10800
$ORIGIN patriboom.net.
@       IN SOA debian.patriboom.net. root.patriboom.net. (
        2021092501;
        24h;
        1h;
        1000h;
        2d);
@       IN NS debian.patriboom.net.
debian       IN A 192.168.1.244
host         IN A 192.168.1.240
 



/etc/bind/db.1.168.192.in-addr.arpa

  GNU nano 5.4                                                            db.1.168.192.in-addr.arpa                                                                      
$TTL 10800
$ORIGIN 1.168.192.in-addr.arpa.
@       IN SOA debian.patriboom.net. root.patriboom.net. (
        2021092501;
        24h;
        1h;
        1000h;
        2d);
@       IN NS debian.patriboom.net.
132     IN PTR debian.patriboom.net.
1       IN PTR host.patriboom.net.
 



La commande de vérification donne de bons résultats (et le ping depuis l'autre ordinateur le confirme)

/etc/bind# named-checkconf -z
zone patriboom.net/IN: loaded serial 2021092501
zone 1.168.192.in-addr.arpa/IN: loaded serial 2021092501
zone localhost/IN: loaded serial 2
zone 127.in-addr.arpa/IN: loaded serial 1
zone 0.in-addr.arpa/IN: loaded serial 1
zone 255.in-addr.arpa/IN: loaded serial 1
 



j'aurais besoin d'explications, car j'ai tenté de définir le serveur patriboom.net plutôt que debian.patriboom.net mais n'y suis pas arrivé.
Ce que j'ai tenté, c'est de modifier seulement les deux fichier personnels de la manière suivante:

/etc/bind/db.patriboomNET

TTL 10800
$ORIGIN patriboom.net.
@       IN SOA patriboom.net. root.patriboom.net. (
        2021092501;
        24h;
        1h;
        1000h;
        2d);
@       IN NS patriboom.net.
debian       IN A 192.168.1.244
host         IN A 192.168.1.240
 



/etc/bind/db.1.168.192.in-addr.arpa

  GNU nano 5.4                                                            db.1.168.192.in-addr.arpa                                                                      
$TTL 10800
$ORIGIN 1.168.192.in-addr.arpa.
@       IN SOA patriboom.net. root.patriboom.net. (
        2021092501;
        24h;
        1h;
        1000h;
        2d);
@       IN NS patriboom.net.
132     IN PTR patriboom.net.
1       IN PTR host.patriboom.net.
 



et voici ce que me retourne la commande de vérification:

/etc/bind# named-checkconf -z
zone patriboom.net/IN: NS 'patriboom.net' has no address records (A or AAAA)
zone patriboom.net/IN: not loaded due to errors.
_default/patriboom.net/IN: bad zone
zone 1.168.192.in-addr.arpa/IN: loaded serial 2021092501
zone localhost/IN: loaded serial 2
zone 127.in-addr.arpa/IN: loaded serial 1
zone 0.in-addr.arpa/IN: loaded serial 1
zone 255.in-addr.arpa/IN: loaded serial 1
 




D'où sort et pourquoi est-elle présente l'expression  "debian" ?
Ce que je veux c'est un nom de domaine simple comme  patriboom.net 
et NON debian.patriboom.net


Ensuite, ce que je voudrai, ce sera de faire en sorte que ce nom de domaine pointe sur 127.0.0.2 et non sur 127.0.0.1

Merci à l'avance.


Portez la paix
Patrick Allaire, ptre

Hors ligne

#7 04-11-2021 06:36:18

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : Ma Debian comme serveur local

Bonjour
il faut commencer par le serveur et le routeur (passerelle)
bind9 avec des clients en dhcp c'est pas le top
vérifier si ton routeur dans le dhcp ne te propose pas un domaine local a préciser

coter serveur tu a le fichier interfaces , hosts , hostname et resolv.conf dans /etc/

le fichier "hosts" devait être sous cette forme sur le serveur


/etc# cat hosts
127.0.0.1 localhost
127.0.1.1 debian.patriboom.net debian # boucle locale (localhost ou 127.0.0.1)
192.168.0.244 debian.patriboom.net debian # ip du serveur

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
 



a partir du serveur le ping de : localhost , 127.0.0.1 , 192.168.0.244  doit fonctionner

ton fichier interfaces (du serveur) doit contenir la passerelle (ton routeur) par exemple 192.168.0.1 (ton serveur l ip 192.168.0.244 par exemple)

ton fichier resolv.conf doit contenir quelque chose sous la forme


domain patriboom.net
search patriboom.net
nameserver 192.168.0.1
 



il faut que tu donne le contenu sur le serveur de /etc/network/interfaces
tu dois avoir l'ip fixe , la passerelle et le dns (en option)
pas besoin d'installer un dns sur le serveur , le routeur doit faire le taf par le dhcp qui va enregistrer les clients

pour atteindre le serveur c'est par nommachine.domaine ou l'ip sous la forme 192.168.0.xxx

127.0.0.1 ou localhost ne fonctionne que sur la boucle locale de la machine (pas sur le réseau)

pour le domaine "patriboom.net" il doit y avoir une astuce pour pointer sur le serveur apache (mais déjà debian.patriboom.net doit pointer sur ta page d index du serveur apache)
ps: "debian" est le nom du serveur dans ton fichier "hostname"

donc regarde si ton routeur a l'option "domaine" pour le réseau local , ça va te simplifier la configuration (normalement sur la configuration dhcp du routeur )
par exemple pour moi , le routeur "livebox" , le domaine local "home"
le ping


ping -v4 -c4 livebox.home
PING  (192.168.1.1) 56(84) bytes of data.
64 bytes from livebox.home (192.168.1.1): icmp_seq=1 ttl=64 time=0.823 ms
64 bytes from livebox.home (192.168.1.1): icmp_seq=2 ttl=64 time=0.871 ms
64 bytes from livebox.home (192.168.1.1): icmp_seq=3 ttl=64 time=0.813 ms
64 bytes from livebox.home (192.168.1.1): icmp_seq=4 ttl=64 time=0.801 ms

---  ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3003ms
rtt min/avg/max/mdev = 0.801/0.827/0.871/0.026 ms
 


je peu joindre n'importe quelle machine (en dhcp sur le réseau local)  par son nom , nom.domaine et l'ip
c'est le plus simple si ton routeur peut le faire .

pour le fichier /etc/network/interfaces  un exemple (ip a modifier selon ta configuration ainsi que le nom de l'interface eth0)


auto eth0
    iface eth0 inet static
        address 192.168.0.244/24  # ip du serveur
        gateway 192.168.0.1  # ip de ton routeur
 



pour tester tu a (du paquet bind9-dnsutils) la commande dig ou nslookup en user
par exemple


nslookup debian
 



ps: pour bind9 (serveur DNS) avec des clients en dhcp il va falloir faire une mise a jour dynamique a partir du dhcpd ( serveur dhcp a installer sur le serveur) du serveur DNS bind9

Dernière modification par robert2a (04-11-2021 08:07:00)

Hors ligne

#8 04-11-2021 08:46:49

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : Ma Debian comme serveur local

je vais essayer de corriger ce que tu a indiqué


Tentons ici d'être plus clair.

Serveur apache 2
Mon ordinateur sous Debian a un serveur Apache2 actif.  Ci-haut, c'est l'ordinateur D.
Ce dernier a l'adresse interne 127.0.0.1 (localhost) comme le veut la tradition.  Cette adresse pointe vers /var/www/html
Il a aussi une adresse 127.0.0.2 ( patriboom.net ).  Cette adresse point vers /var/www/html/MesSites/MonSite

IP du réseau local
Mon serveur (appareil D) reçoit l'adresse 192.168.1.244 du DHCP  ( routeur à la fois câble et wifi, au centre des appareils ci-haut )
 


ici il te faut indiquer une IP du réseau local , a priori 192.168.0.244 du serveur et configurer apache pour cette IP (127.0.0.1 ne fonctionnera que en local sur le serveur )
et il te faut une IP fixe pour le serveur (soit par le routeur reserver une IP (toujours la même ) , soit par le fichier interfaces comme indiqué en #7 )


Objectif
Que les appareils A, B, C et F visitent le site  patriboom.net (oui, en écrivant cette adresse-là bien précisément dans la barre d'adresse)
 


ceci doit être possible , mais debian.patriboom.net doit fonctionner déjà


Résultats actuellement obtenus
1. Comme usager de l'appareil D
     L'adresse 127.0.0.1 répond adéquatement (serveur web) en retournant le contenu de /var/www/html/index.php et tous les sous-répertoire
     L'adresse 172.0.0.2 répond adéquatement (serveur web) en retournant le contenu de /var/www/html/MesSites/MonSite/index.php
     L'adresse patriboom.net me retourne un message d'erreur (site introuvable )
 


je comprends pas pourquoi tu utilise un 127.0.0.2


2. Comme usager de l'apapreil B
    L'adresse 192.168.1.244 me retourne la réponse du serveur web /var/www/html/index.php
          Cependant, les sous-sites ne sont pas accessibles ( cliquer sur un lien de la page menant vers /var/www/html/MesSites/index.php est refusé)
 


la je pense a une configuration d'apache


3. Je veux que l'usager de l'appareil B puisse
     Inscrire l'adresse « patriboom.net » et voit le site /var/www/html/MesSites/MonSite/index.php s'afficher
 


la j'ai pas la solution ( doit fonctionner par "debian" ou "debian.patriboom.net" ou "l'IP du serveur")

Dernière modification par robert2a (04-11-2021 08:48:16)

Hors ligne

#9 04-11-2021 09:05:23

raleur
Membre
Inscription : 03-10-2014

Re : Ma Debian comme serveur local

Il manque les fichiers de configuration du serveur web, notamment la définition des virtualhosts.

Patriboom a écrit :

NS 'patriboom.net' has no address records (A or AAAA)


Le message est clair : il manque un enregistrement d'adresse A pour patriboom.net. (ou @).

Patriboom a écrit :

D'où sort et pourquoi est-elle présente l'expression  "debian" ?


C'est toi qui l'as mis là.


Il vaut mieux montrer que raconter.

Hors ligne

#10 04-11-2021 16:18:28

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Buster (10)
Noyau : Linux 4.19.37-5
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Ma Debian comme serveur local

Merci à tous pour ces réponses détaillées.  Je tâcherai d'appliquer ces conseils avant de vous revenir avec les résultats. 
Néanmoins, il faut que je clarifie ceci afin de vous aider à m'aider.

robert2a a écrit :

je comprends pas pourquoi tu utilise un 127.0.0.2



127.0.0.1 est le tronc de tous mes sites.
127.0.0.2 est la branche spécifique où es clients pourront visiter.

raleur a écrit :

Patriboom a écrit :
    NS 'patriboom.net' has no address records (A or AAAA)
Le message est clair : il manque un enregistrement d'adresse A pour patriboom.net. (ou @).



Pas si clair, non.
Où définis-je @
Mon /etc/localhost est

# cat hostname
patriboom.net



Je ne vois pas où est inscirt le « debian ».  Je ne l'ai jamais défini.

et ma définition du serveur 127.0.0.2 va comme suit:


/etc/apache2/sites-available# cat PatriboomNet.conf
<VirtualHost *:80>
  ServerName 127.0.0.2
  ServerAlias patriboom.net
  ServerAlias sa.sibi
  UseCanonicalName Off
  DocumentRoot /var/www/html/MesSites/Sports/Quiz

  ErrorLog ${APACHE_LOG_DIR}/error.log
  CustomLog ${APACHE_LOG_DIR}/access.log combined

  <Directory /var/www/html/MesSites/Sports/Quiz>
    allow from all
    Options Indexes FollowSymLinks MultiViews
    Order allow,deny
    Satisfy any
    AllowOverride All
    AddDefaultCharset UTF-8
    DefaultLanguage fr-CA
  </Directory>

  <IfModule mod_rewrite.c>
    RewriteEngine On
  </IfModule>
</VirtualHost>
 



Directement sur le serveur, ça fonctionne.  À partir d¡un ordinateur du réseau local, ça ne fonctionne pas.  Seule l'adresse debian.patriboom.net affiche la page de la racine  ( 127.0.0.1 ) mais ce n'est pas ce que je veux.

Comme dit ci-haut.  Je vais suivre vos indications et vous rendrai compte des résultats.

Merci.


Portez la paix
Patrick Allaire, ptre

Hors ligne

#11 04-11-2021 17:18:34

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : Ma Debian comme serveur local

Bonjour
aucun client ne pourra joindre le serveur ou apache par l'ip 127.0.0.2 (boucle locale uniquement sur le serveur)
le hostname doit contenir le nom de la machine et pas le domaine du réseau( ce nom doit être unique pour chaque machine sur le réseau)
tu ne précise pas comment se connecte les clients , en IP fixe ou par le dhcp du routeur ?

Hors ligne

#12 04-11-2021 17:59:54

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Buster (10)
Noyau : Linux 4.19.37-5
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Ma Debian comme serveur local

Bonjour,

Les clients se connectent en DHCP du routeur.

Voici,  la configuration du routeur:
Config_Routeur.png

J'ai défini là mon serveur de noms (192.168.1.244), car mon serveur sous Debian a cet IP fixe.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#13 04-11-2021 18:37:44

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : Ma Debian comme serveur local

modifier:
super mais tu n'est pas très créatif , des patriboom quelque chose partout
donc tu peu donner un nom a ton routeur , un domaine  et son IP et tu peu configurer au moins 3 DNS selon ta photo
par contre la réservation d ip commence a 210 , donc les ip fixe en dur doivent être a l'extérieur de la plage , de 1 a 209
pour le routeur l adresse 192.168.1.1 serait parfaite (éviter celle la 192.168.1.240 qui est dans la plage dhcp 210/254
pour le routeur il attribut (dhcp) une ip pour 24h (1 day)
tu a réservé une ip 192.168.1.244 pour le serveur debian ( a mon avis Static DNS 1 c'est pour donner un DNS (pas une réservation d'adresse)
ton serveur de nom sera ton routeur "192.168.1.1"
le hostname par exemple "lynksys"
le static DNS1 (si pas optionnel)  192.168.1.1
le domaine name "patriboom.net" , tu peu utiliser un nom simple "patriboom" pour le domaine
pour tester a partir du serveur


ping -v4 -c4 linksys.patriboom.net
 


il faut stopper le dns bind9 ou bind (me souvient plus)


systemctl status bind.service
 


puis


systemctl stop bind.service
 


bien vérifier la configuration du serveur debian (comme expliqué plus haut) et de apache (fichier hostname , hosts , resolv.conf)
et faire les tests
normalement tu n'a plus besoin du dns bind
tester tes clients en dhcp (pas en ip fixe)

c'est ton routeur (dhcp) qui va propager le domaine au client et inscrire les noms (unique) des machines en dhcp
remarque: sur la photo je ne vois pas de réservation d ip pour une machine , donc mettre le serveur en ip static en dehors de la plage 210 + 36 (246)
plage que tu peu diminuer selon le nombre de client que tu pense connecter  (pour 5 clients par exemple , 10 suffit au lieu de 36 ) 210 + 10 => de 210 a 230 les ip distribués par le dhcp
j'ai eu du syslink avant la livebox mais je me souvient plus des options

Dernière modification par robert2a (04-11-2021 18:53:21)

Hors ligne

#14 04-11-2021 19:16:08

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : Ma Debian comme serveur local

rafraîchit la page , j'ai fait des modifs
je te redonne l'exemple pour ma livebox , son hostname =livebox , son ip 192.168.1.1 son domaine "home"


ping -v4 -c4 livebox.home
PING  (192.168.1.1) 56(84) bytes of data.
64 bytes from livebox.home (192.168.1.1): icmp_seq=1 ttl=64 time=0.839 ms
64 bytes from livebox.home (192.168.1.1): icmp_seq=2 ttl=64 time=1.79 ms
64 bytes from livebox.home (192.168.1.1): icmp_seq=3 ttl=64 time=1.04 ms
64 bytes from livebox.home (192.168.1.1): icmp_seq=4 ttl=64 time=0.877 ms

---  ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3004ms
rtt min/avg/max/mdev = 0.839/1.136/1.788/0.383 ms
 


tu dois obtenir la même chose avec tes paramètres (idem le ping de "livebox" fonctionne aussi , configuration du resolv.conf)
ps: moi j'aurai appeler le serveur "patriboom" (hostname) et changer le nom de domaine et tester si patriboom te dirige ver la page d index
mais je connais pas bien la configuration d'apache
mais bon déjà teste comme ci dessus  smile
ps: je n'ai que des machines en linux , debian et arch linux (pas tester avec windows)

Hors ligne

#15 04-11-2021 21:14:50

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Buster (10)
Noyau : Linux 4.19.37-5
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Ma Debian comme serveur local

Merci de votre aide, tous. 
Je reviens avec des surprises pas très agréables.
D'abord, j'ai tenté de modifier mon routeur comme robert2a me le propose.
Voici la nouvelle capture de la configuration:
Config_Routeur1.png


Et voici les résultats ( après déconnexion et reconnexion de mon ordinateur au réseau, c'est NetworkManager qui est là et j'ai créé une connexion à IP fixe =  192.168.1.244 )


# ping 192.168.1.240
PING 192.168.1.240 (192.168.1.240) 56(84) bytes of data.
64 bytes from 192.168.1.240: icmp_seq=1 ttl=64 time=1.62 ms
64 bytes from 192.168.1.240: icmp_seq=2 ttl=64 time=1.30 ms
64 bytes from 192.168.1.240: icmp_seq=3 ttl=64 time=1.28 ms
64 bytes from 192.168.1.240: icmp_seq=4 ttl=64 time=1.29 ms
64 bytes from 192.168.1.240: icmp_seq=5 ttl=64 time=1.26 ms
64 bytes from 192.168.1.240: icmp_seq=6 ttl=64 time=1.32 ms
^C
--- 192.168.1.240 ping statistics ---
6 packets transmitted, 6 received, 0% packet loss, time 5008ms
rtt min/avg/max/mdev = 1.258/1.344/1.622/0.125 ms


# ping routeur.home
ping: routeur.home: Nom ou service inconnu

 



J'ai attendu 2-3 minutes ... toujours le même résultat.


Ensuite..  Je suis sorti avec mon portable (et seveur Debian 127.0.0.1 et 127.0.0.2).
Lorsque j'ai voulu me connecter au wfii local :  plus d'accès à l'internet.
La config actuelle me cloue au réseau câblé local.
Il me faut retrouver la liberté de mouvement.

À bientôt.


Portez la paix
Patrick Allaire, ptre

Hors ligne

#16 05-11-2021 08:29:06

raleur
Membre
Inscription : 03-10-2014

Re : Ma Debian comme serveur local

Patriboom a écrit :

127.0.0.2 est la branche spécifique où es clients pourront visiter.


Sûrement pas. Cette adresse n'est pas joignable par les autres hôtes.

Patriboom a écrit :

Où définis-je @


Tu n'as pas une petite idée ? Un indice : quelle commande a affiché ce message d'erreur et quels sont les fichiers que tu as modifiés juste avant ?

Patriboom a écrit :

j'ai tenté de modifier mon routeur


D'où sort l'adresse IP du DNS 2 qui n'est même pas dans le sous-réseau local ?

Patriboom a écrit :

plus d'accès à l'internet


Ce ne serait pas plutôt plus de résolution DNS des domaines externes si tu as oublié d'activer la résolution récursive sur ton serveur DNS ?

Dernière modification par raleur (07-11-2021 21:45:28)


Il vaut mieux montrer que raconter.

Hors ligne

#17 07-11-2021 21:06:19

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Buster (10)
Noyau : Linux 4.19.37-5
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Ma Debian comme serveur local

Bonjour à tous,

je reprends à zéro :
- dé-configurai le routeur
- changeai les adresses de mes sites

Alors, ce qui fonctionne bien:
- mes noms de domaine fonctionnent bien sur mon serveur
- J'ai retrouvé les capacités réseautiques de mon ordinateur autant en câblé qu'en wifi.

Je tenterai prochainement la configuration du routeur de façon à rendre facile l'accès au serveur à partir d'une autre machine.


Avec ceci ConfigRouteur2.png ...
je m'attendais à avoir une réponse un résutat de quelque forme comme "Introuvable" ou « inexistant »   Mais non ... transfert vers Google, page de recherche.

Devrai-je m'attendre à mieux lorsque je configurerai Bind9 sur mon serveur ?

Dernière modification par Patriboom (08-11-2021 04:52:02)


Portez la paix
Patrick Allaire, ptre

Hors ligne

Pied de page des forums