Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 24-11-2021 12:28:45

MuadDibII
Membre
Distrib. : Debian 11
(G)UI : KWin
Inscription : 24-11-2021

Impossible de donner la permission "write" à un sous dossier

Bonjour à tous,

Sur mon PC j'ai 2 disques :

- SSD avec un dual boot Windows 10 / Debian 11
- HDD utilisé d'abord pour mes fichiers Windows, qui je souhaite faire aussi le disque des fichiers Debian (en partage avec Windows) - formaté en NTFC

J'essaye de faire des manipulations des fichiers sur mon disque partagé (sur Debian), mais j'ai une message d'opération non supportée (qu'il soit avec mon user ou avec sudo) :

$ cat >/mnt/windows/Documents/Marcelo/creationTest.txt
bash: /mnt/windows/Documents/Marcelo/creationTest.txt: Opération non supportée
 



$ sudo cat >/mnt/windows/Documents/Marcelo/creationTest.txt
bash: /mnt/windows/Documents/Marcelo/creationTest.txt: Opération non supportée



Je fais le montage de ce disque au démarrage avec fstab :

UUID=ACB23705B236D414   /mnt/windows    ntfs-3g defaults    0   0



Et normalement les utilisateur Debian peuvent y accéder R/W (je pense hmm) :

$ ls -l /mnt/windows/
total 80
drwxrwxrwx 1 root root  4096 14 nov.  20:20 '$RECYCLE.BIN'
drwxrwxrwx 1 root root  4096 24 nov.  09:13  CloudStation
drwxrwxrwx 1 root root  4096 21 nov.  11:44  Documents
-rwxrwxrwx 1 root root  8192 25 juin  08:15  DumpStack.log.tmp
drwxrwxrwx 1 root root  4096 22 nov.  20:41  Images
drwxrwxrwx 1 root root  4096 24 nov.  09:12  Music
drwxrwxrwx 1 root root  8192 23 nov.  06:21 'System Volume Information'
drwxrwxrwx 1 root root 40960 21 nov.  22:22  Téléchargements
drwxrwxrwx 1 root root  4096 21 nov.  19:44  Videos
 



J'ai normalement désactivé l'hibernation dans mon Windows, je n'arrive pas à comprendre ce qui peut ne pas fonctionner...
Dans PowerShell :

powercfg -h off



Pouvez-vous m'aider, svp ?

Je vous remercie par avance,

Cordialement,
Marc

Dernière modification par MuadDibII (26-11-2021 10:58:51)

Hors ligne

#2 24-11-2021 14:18:21

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Impossible de donner la permission "write" à un sous dossier

Hello Je pense que c'est ton utilisation de cat qui n'est pas bonne
a lire https://debian-facile.org/doc:systeme:cat
utilise plutôt touch si tu veux créer un fichier vide
https://debian-facile.org/doc:systeme:touch

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#3 24-11-2021 17:58:16

MuadDibII
Membre
Distrib. : Debian 11
(G)UI : KWin
Inscription : 24-11-2021

Re : Impossible de donner la permission "write" à un sous dossier

Bonjour, merci de ton retour smile

J'ai essayé aussi avec touch, mais le résultat est toujours le même. Par contre j'ai une autre piste.

J'ai modifié mon fichier fstab pour ajouter umask=000 :

UUID=ACB23705B236D414   /mnt/windows    ntfs-3g defaults,umask=000    0   0



Maintenant les dossiers montent avec les permissions suivantes :

$ ls -l /mnt/windows/Documents/
total 117
drwxrwxrwx 1 root root 16384 24 nov.  15:59  User1
-rwxrwxrwx 1 root root     0 26 nov.   2020  Default.rdp
-rwxrwxrwx 1 root root   432 11 mars   2021  desktop.ini
dr-xr-xr-x 1 root root 40960 24 nov.  15:59  User2
drwxrwxrwx 1 root root 16384 24 nov.  16:00  Public
drwxrwxrwx 1 root root  4096 24 nov.  15:59  User3
dr-xr-xr-x 1 root root 20480 21 nov.  12:05  Scan
-rwxrwxrwx 1 root root 18432  4 déc.   2016  Thumbs.db
drwxrwxrwx 1 root root     0 16 nov.  23:13 'Unified Remote'
 



Je n'arrive pas à comprendre pouquoi le dossier User2 n'a pas les permissions de write...
J'ai fait le test touch dans le dossier User1, et cela fonctionne correctement

La question que ce pose est donc : pourquoi User1 permissions sont différentes ? Voici les permissions du dossier parent :

$ ls -l /mnt/windows/
total 80
drwxrwxrwx 1 root root  4096 14 nov.  20:20 '$RECYCLE.BIN'
drwxrwxrwx 1 root root  4096 24 nov.  15:59  CloudStation
drwxrwxrwx 1 root root  4096 21 nov.  11:44  Documents
-rwxrwxrwx 1 root root  8192 25 juin  08:15  DumpStack.log.tmp
drwxrwxrwx 1 root root  4096 22 nov.  20:41  Images
drwxrwxrwx 1 root root  4096 24 nov.  11:53  Music
drwxrwxrwx 1 root root  8192 23 nov.  06:21 'System Volume Information'
drwxrwxrwx 1 root root 40960 21 nov.  22:22  Téléchargements
drwxrwxrwx 1 root root  4096 21 nov.  19:44  Videos
 



On voit qu'ils sont tous en rwx... Pourquoi pas un seul sous-dossier ?

Merci encore une fois,
Marc

Dernière modification par MuadDibII (24-11-2021 17:58:43)

Hors ligne

#4 24-11-2021 18:29:19

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : Impossible de donner la permission "write" à un sous dossier

Bonjour
j'ai le même souci (enfin presque) sur une partition ntfs sur le disque de debian
le message de nano


Le répertoire « . » n'est pas accessible en écriture
 


les permissions de la partition "Archives"


ls -l
total 4
drwxrwx--- 1 robert robert    0 22 nov.  09:43 '$RECYCLE.BIN'
drwxrwx--- 1 robert robert    0 21 nov.  15:37  Fichiers-PDF
drwxrwx--- 1 robert robert    0 21 nov.  14:59  Fichiers-TXT
drwxrwx--- 1 robert robert 4096 22 nov.  09:44 'System Volume Information'
 



mon fstab


#partition ntfs
UUID="6A216E370DCBC79B" /home/robert/Archives  ntfs     rw,nodev,noexec,user,uid=1000,gid=1000,umask=007        0       0
 



depuis que windows10 a pris la partition a son compte (on le voit au 2 dossiers '$RECYCLE.BIN' et 'System Volume Information'
j'ai un cadenas sur le dossier "Archives" sous debian
je pourrai pas t'aider  hmm
je vais formater la partition en ext4 ça va être résolu  roll   tongue
idem je voulais faire une partition partagé entre les deux système
je suivrais ton fil avec attention  wink

Hors ligne

#5 24-11-2021 18:46:29

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : Impossible de donner la permission "write" à un sous dossier

re,
si cela peut aider , j'ai fait sous win10 => redémarrer (et pas arrêt)  , toujours le cadenas sur le dossier , mais je peu écrire et effacer fichier et dossier sous debian
si cela fais avancer ta recherche , j'ai pris les infos ici sur le forum (wiki etc ......... )
je suis pas trop chaud pour mélanger win10 et debian  hmm  , mais je teste  smile

ps:
pour moi , le seul souci est de désactiver le démarrage rapide de windows je suppose (qui verrouille les partitions ntfs)  , sinon ça fonctionne lecture et écriture.
j'ai testé en user et en root , avec "touch" et "nano"
il me semble aussi que monter la partition dans ton "home" plutôt que dans "/mnt"

Dernière modification par robert2a (24-11-2021 19:18:14)

Hors ligne

#6 26-11-2021 10:43:40

MuadDibII
Membre
Distrib. : Debian 11
(G)UI : KWin
Inscription : 24-11-2021

Re : Impossible de donner la permission "write" à un sous dossier

Bonjour,

J'ai déjà désactivé le démarrage rapide sad

Et pour le monter dans mon home, cela ne marcherais pas parce que je souhaite que le disque soit accessible à tous les utilisateurs (2 dans mon cas)

Hors ligne

#7 26-11-2021 11:39:38

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Impossible de donner la permission "write" à un sous dossier

Hello

MuadDibII a écrit :

J'ai déjà désactivé le démarrage rapide


es tu sur que le démarrage rapide est désactivé?
En cas d'erreur le montage sera remonté en lecture
voir le man ntfs-3g

Hibernation des fenêtres et redémarrage rapide
       Sur les ordinateurs qui peuvent être doublement démarrés sous Windows ou Linux, Windows doit être complètement éteint avant de démarrer sous Linux, sinon les systèmes de fichiers NTFS sur les disques internes peuvent être
       laissée dans un état incohérent et les modifications apportées par Linux peuvent être ignorées par Windows.

       Ainsi, Windows ne doit pas être laissé en hibernation lors du démarrage de Linux, afin d'éviter les incohérences. De plus, la fonction de redémarrage rapide disponible sur les systèmes Windows récents doit
       être désactivé. Cela peut être réalisé en émettant en tant qu'administrateur la commande Windows qui désactive à la fois l'hibernation et le redémarrage rapide :

              powercfg /h off

       Si Windows est en hibernation ou si son redémarrage rapide est activé, les partitions des disques internes sont forcées d'être montées en mode lecture seule.
Traduit avec www.DeepL.com/Translator (version gratuite)



powercfg /h off



voir les options de montage avec

mount




raleur a écrit :

Il faut distinguer deux types de systèmes de fichiers :
- les systèmes de fichiers "Unix" qui supportent les permissions POSIX : ext2/3/4, reiserfs, xfs, btrfs...
- les systèmes de fichiers "non Unix" qui ne supportent pas les permissions POSIX : FAT, NTFS...

Souvent les disques externes utilisent FAT ou NTFS pour la compatibilité avec d'autres systèmes d'exploitation comme Windows.

Les droits sur le contenu d'un système de fichiers non Unix sont définis lors du montage de celui-ci. Typiquement, tous les fichiers apparaissent comme appartenant à root ou à l'utilisateur qui a monté le volume et qui a tous les droits dessus. Il ne sert à rien d'essayer de modifier les propriétaires ou les permissions avec chmod ou chown.

Dernière modification par Croutons (26-11-2021 11:41:49)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#8 26-11-2021 12:06:43

MuadDibII
Membre
Distrib. : Debian 11
(G)UI : KWin
Inscription : 24-11-2021

Re : Impossible de donner la permission "write" à un sous dossier

Merci de ton retour Croutons,

J'ai bien désactivé le démarrage rapide dans Windows :
- avant de faire la commande PowerShell, j'ai décoché la case correspondante dans les options des boutons d'alimentation
- ensuite j'ai fait la commande "powercfg -h off" avec le compte Admin de mon Windows
- j'ai même vérifié les "group policies"

Sinon je viens de tester la commande mount :

$ mount
...
/dev/sdb1 on /mnt/windows type fuseblk (rw,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096)
...



J'ai trouvé un autre sous dossier (dans Videos, Images) avec le même soucis, sans aucune logique évidente pour moi...
J'ai aussi essayé de regarder côté Windows les permissions, mais je n'ai pu rien trouver...

Hors ligne

#9 26-11-2021 12:47:24

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Impossible de donner la permission "write" à un sous dossier

montage via le gestionnaire de fichier

/dev/sda2 on /media/stephane/OS type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)


aucun soucis
edit: au cas ou ce que tu peux essayer d'ajouter remove_hiberfile a l'option de montage
voir

man ntfs-3g


man ntfs-3g a écrit :

remove_hiberfile
Lorsque le volume NTFS est en hibernation, un montage en lecture-écriture est refusé et un montage en lecture seule est forcé. Il faut soit relancer Windows et l'éteindre correctement, soit utiliser cette option qui supprimera le fichier d'hibernation de Windows. Veuillez noter que cela signifie que la session Windows sauvegardée sera complètement perdue. Utilisez cette option sous votre propre responsabilité.

Dernière modification par Croutons (26-11-2021 13:23:54)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#10 26-11-2021 13:33:37

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Impossible de donner la permission "write" à un sous dossier

remoi

cat >/mnt/windows/Documents/Marcelo/creationTest.txt


en relisant je vois qu'il n'y a pas de répertoire Marcelo dans Documents
donc la création d'un fichier ne peut être dans un répertoire qui n'existe pas
a moins que le résultat de ta commande ls ne soit pas complète


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#11 27-11-2021 10:45:43

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : Impossible de donner la permission "write" à un sous dossier

Bonjour
en user tu ne peu pas écrire dans /mnt
en root


mkdir /mnt/windows
 


tu te place dans /mnt


ls -l
total 4
drwxr-xr-x 2 root root 4096 27 nov.  08:46 windows
 


tu modifies le propriétaire de "windows"


chown robert:robert /mnt/windows
 


tu vérifie


/mnt/ls -l
 



ls -l
total 4
drwxr-xr-x 2 robert robert 4096 27 nov.  08:46 windows
 


tu passe en user et tu crée tes dossiers dans /mnt/windows


/mnt/windows$ mkdir Documents
 


vérifier


/mnt/windows$ ls -l
total 4
drwxr-xr-x 2 robert robert 4096 27 nov.  08:50 Documents
 


tu fais ton montage correctement dans le fstab
et tu regarde les permissions
pour modifier une permission (par exemple robert + le groupe robert)
tu place dans /mnt/windows


chmod 770 Documents
 


tu vérifie (toujours dans /mnt/windows/ )


ls -l
total 4
drwxrwx--- 2 robert robert 4096 27 nov.  08:50 Documents
 



un 777 donne les droits a tout le monde , ou juste en lecture pour tout le monde 774 , etc ......
je pense qu'il est possible d'affecter un user2 dans le groupe de l'user1 aussi (a confirmer ...... )
je pense que tu te prend mal au départ quand tu créer le dossier "windows"
après c'est juste l'utilisation de chown et chmod (voir le wiki des permissions sur un dossier ou fichier )
et de faire un montage correct dans ton fichier fstab

quand tu crées un dossier dans /mnt/windows/ , le nouveau dossier prendra les droits du dossier "windows" par défaut
il me semble que tu dois pouvoir gérer tout cela proprement
ps: je connais juste les bases , mais je ne pense pas avoir écrit de bêtises   roll

remarque:
hier j'ai désactivé le démarrage rapide de windows10 , je n'ai plus le cadenas sur mon dossier de la partition ntfs en partage.

Dernière modification par robert2a (27-11-2021 11:14:12)

Hors ligne

#12 27-11-2021 11:04:26

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Impossible de donner la permission "write" à un sous dossier

Hello @robert2a dans ton message #4 je vois que il me semble que tu utilises le pilote ntfs interne au noyau et non pas par le paquet ntfs-3g
concrètement je sais pas ce que cela change mais les options ne sont les même entre le man mount option du pilote noyau et le man ntfs-3g

De ce que j'ai pu lire sur le net ntfs-3g aurait une meilleur prise en charge

edit:

Les droits sur le contenu d'un système de fichiers non Unix sont définis lors du montage de celui-ci. Typiquement, tous les fichiers apparaissent comme appartenant à root ou à l'utilisateur qui a monté le volume et qui a tous les droits dessus. Il ne sert à rien d'essayer de modifier les propriétaires ou les permissions avec chmod ou chown.

Dernière modification par Croutons (27-11-2021 11:57:33)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#13 27-11-2021 11:22:29

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : Impossible de donner la permission "write" à un sous dossier

arrfffff  donc il vaudrait mieux que je passe a ntfs-3g 
mon souci cela va être un fstab correct.et comment gérer les utilisateurs sous debian
je vais regarder tout ça  roll

j'ai le même souci ,


mkdir: impossible de créer le répertoire « test1 »: Système de fichiers accessible en lecture seulement
 

Dernière modification par robert2a (27-11-2021 11:48:00)

Hors ligne

#14 27-11-2021 12:13:18

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : Impossible de donner la permission "write" à un sous dossier

sans comprendre ce que je fais
le fstab (pris un tuto de ubuntu-fr )


# Partitions Windows - NTFS
UUID=6A216E370DCBC79B /home/robert/Archives  ntfs-3g  rw,user,auto,gid=1000,uid=1000,nls=utf8,umask=002 0 0
 


en user , a partir de /home/robert/Archives/


ls -l
total 4
drwxrwxr-x 1 robert robert    0 22 nov.  09:43 '$RECYCLE.BIN'
drwxrwxr-x 1 robert robert    0 25 nov.  08:53  Documents
drwxrwxr-x 1 robert robert    0 25 nov.  08:52  Images
drwxrwxr-x 1 robert robert    0 25 nov.  08:52  Musiques
drwxrwxr-x 1 robert robert    0 25 nov.  08:50  Photos
drwxrwxr-x 1 robert robert 4096 26 nov.  17:14 'System Volume Information'
drwxrwxr-x 1 robert robert    0 25 nov.  08:50  Vidéos
 


puis créer un dossier


mkdir test1
 



 ls -l
total 4
drwxrwxr-x 1 robert robert    0 22 nov.  09:43 '$RECYCLE.BIN'
drwxrwxr-x 1 robert robert    0 25 nov.  08:53  Documents
drwxrwxr-x 1 robert robert    0 25 nov.  08:52  Images
drwxrwxr-x 1 robert robert    0 25 nov.  08:52  Musiques
drwxrwxr-x 1 robert robert    0 25 nov.  08:50  Photos
drwxrwxr-x 1 robert robert 4096 26 nov.  17:14 'System Volume Information'
drwxrwxr-x 1 robert robert    0 27 nov.  11:04  test1
drwxrwxr-x 1 robert robert    0 25 nov.  08:50  Vidéos
 


pour les droits on fera avec  roll

oublier pour un sous dossier
a partir de /home/robert/test1/


mkdir monsousdossier
 



ls -l
total 0
drwxrwxr-x 1 robert robert 0 27 nov.  11:34 monsousdossier
 


correct aussi  smile

@MuadDibII
tu dois arriver au même résultat , et pas tous tes dossiers/fichiers en root et des permissions exotiques
mais mon dossier de base (qui correspond a ton dossier "windows" ) que l'on crée pour le montage de la partition (pour moi "Archives")


drwxrwxr-x 1 robert robert 4096 27 nov.  11:04 Archives
 


l'endroit ou tu monte le partage n'a aucune importance , /mnt c'est très bien

Dernière modification par robert2a (27-11-2021 13:46:18)

Hors ligne

#15 30-11-2021 16:38:55

MuadDibII
Membre
Distrib. : Debian 11
(G)UI : KWin
Inscription : 24-11-2021

Re : Impossible de donner la permission "write" à un sous dossier

Bonjour, je suis désolé pour le délai de réponse (travail oblige)

Le soucis c'est que dans mon cas, je n'ai aucune permission de "write" :

dr-xr-xr-x 1 root root 40960 24 nov.  15:59  User2



De la même façon, si je fais un "chmod 777", je n'ai pas vraiment d'erreur qui remonte, mais comme a précisé Croutons, les permissions ne changent pas... sad

Je commence sérieusement à considérer une des 2 options :
- soit le passage à exFat
- soit la création d'un nouveau dossier, où je copierais les fichiers : j'ai fait un petit test et cela semble fonctionner aussi

Enfin, je me laisse un peu le temps de réfléchir un peu...

Hors ligne

#16 30-11-2021 16:57:23

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : Impossible de donner la permission "write" à un sous dossier

Bonjour
les permissions de mon #14 ne te conviennent pas ?
ça demande a recommencer le mkdir de ton dossier windows
et utiliser la ligne de mon fstab
tu aura "lecture ecriture execution" pour l user , le groupe de l'user et  execution pour tous

regarde avant de faire le montage du dossier
les droits sur windows


robert@debian11:/mnt$ ls -l
total 4
drwxrwx--- 2 robert robert 4096 30 nov.  16:02 windows
 


ensuite tu monte la partition sur ce dossier comme indiqué en #14
ensuite tu aura sur les sous dossiers et fichiers les droits rwxrwx--- pour "user" et le groupe "user"
mais il faut créer le dossier en root
toujours en root  chown user:user windows
passer en user et un chmod 770 windows
et en dernier tu monte ta partition sur ce dossier
ps: pas regarder ce que fais exactement la ligne utilisé dans le fstab mais elle fonctionne en ntfs-g3


# Partitions Windows - NTFS
UUID=6A216E370DCBC79B /mnt/windows  ntfs-3g  rw,user,auto,gid=1000,uid=1000,nls=utf8,umask=002 0 0
 


je vais regarder ce que fait "umask=002"

=> https://fr.wikipedia.org/wiki/Umask

pour gérer les droits sur la partition monter


A l'inverse, le umask 0000 ne supprime aucun droit.
 


a priori "002" est déjà pas mal , a toi d'adapter a tes besoins

a priori le umask pour "user" est définit a :


umask -p
umask 0022
 


de ce que je lit c'est "pam" qui s'occupe de cela , tu trouvera des infos dans /etc/login.defs

et pour ntfs-g3


Typiquement, tous les fichiers apparaissent comme appartenant à root ou à l'utilisateur qui a monté le volume et qui a tous les droits dessus.
 


donc si ton dossier appartient a "user" et si tu monte la partition au nom de "user" tu ne dois pas avoir de problème

Dernière modification par robert2a (30-11-2021 18:02:10)

Hors ligne

Pied de page des forums