Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-11-2021 08:46:09

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux sid 5.15.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

[résolu] grub uefi ne reconait pas tous mes disques

bonjour à tous .

depuis une violente coupure de réseau (box défectueuse ?)

grub ne m'affiche que mon nvme .

or normalement il m'affiche aussi mon ssd  avec stable bullseye .

ce qui fait que pour démarrer sur stable , je suis obligé  d'utiliser super grub disk .

je n'arrive pas à réinstaller grub complet sur le ssd et sur le nvme .

un coup de main ?

d'avance merci

sudo fdisk -l


Disque /dev/nvme0n1 : 1,82 TiB, 2000398934016 octets, 3907029168 secteurs
Modèle de disque : Force MP600                            
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : gpt
Identifiant de disque : 7B760C75-DE45-451D-B7DA-AC3579516339

Périphérique       Début        Fin   Secteurs Taille Type
/dev/nvme0n1p1      2048    1050623    1048576   512M Système EFI
/dev/nvme0n1p2   1050624  482330623  481280000 229,5G Système de fichiers Linux
/dev/nvme0n1p3 684283904  686284799    2000896   977M Partition d'échange Linux
/dev/nvme0n1p4 696524800 3907028991 3210504192   1,5T Système de fichiers Linux


Disque /dev/sdb : 931,51 GiB, 1000204886016 octets, 1953525168 secteurs
Modèle de disque : CT1000MX500SSD1
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 4096 octets
taille d'E/S (minimale / optimale) : 4096 octets / 4096 octets
Type d'étiquette de disque : gpt
Identifiant de disque : 99ACFAC3-757E-40E0-91C4-FE8DEE47F11A

Périphérique     Début        Fin   Secteurs Taille Type
/dev/sdb1         2048    1050623    1048576   512M Système EFI
/dev/sdb2      1050624  128026623  126976000  60,5G Système de fichiers Linux
/dev/sdb3    182374400  249958399   67584000  32,2G Partition d'échange Linux
/dev/sdb4    266444800 1953523711 1687078912 804,5G Système de fichiers Linux


Disque /dev/sda : 3,64 TiB, 4000787030016 octets, 7814037168 secteurs
Modèle de disque : ST4000VM000-2AF1
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 4096 octets
taille d'E/S (minimale / optimale) : 4096 octets / 4096 octets
Type d'étiquette de disque : gpt
Identifiant de disque : DC1017DA-46E9-4D49-8384-B03855AD60A2

Périphérique Début        Fin   Secteurs Taille Type
/dev/sda1     2048 7814035455 7814033408   3,6T Système de fichiers Linux
 



sudo efibootmgr -v


[sudo] Mot de passe de alain :
BootCurrent: 001B
Timeout: 1 seconds
BootOrder: 001B,001C,001D
Boot001B* debian  HD(1,GPT,01344e75-f05c-46df-b2d8-b74792ac776f,0x800,0x100000)/File(\EFI\DEBIAN\SHIMX64.EFI)
Boot001C* debian  HD(1,GPT,01344e75-f05c-46df-b2d8-b74792ac776f,0x800,0x100000)/File(\EFI\DEBIAN\GRUBX64.EFI)..BO
Boot001D  debian  HD(1,GPT,3c9e2a68-d3f1-4b75-be3a-b24644ba47f6,0x800,0x100000)/File(\EFI\DEBIAN\GRUBX64.EFI)..BO
 



sudo update-grub


[sudo] Mot de passe de alain :
Generating grub configuration file ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Found linux image: /boot/vmlinuz-5.15.0-2-amd64
Found initrd image: /boot/initrd.img-5.15.0-2-amd64
Found linux image: /boot/vmlinuz-5.15.0-1-amd64
Found initrd image: /boot/initrd.img-5.15.0-1-amd64
Found linux image: /boot/vmlinuz-5.10.0-8-amd64
Found initrd image: /boot/initrd.img-5.10.0-8-amd64
Warning: os-prober will not be executed to detect other bootable partitions.
Systems on them will not be added to the GRUB boot configuration.
Check GRUB_DISABLE_OS_PROBER documentation entry.
Adding boot menu entry for UEFI Firmware Settings ...
done
 

Dernière modification par Debian Alain (03-12-2021 13:50:49)

En ligne

#2 29-11-2021 09:14:50

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux sid 5.15.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] grub uefi ne reconait pas tous mes disques

solution trouvée :

https://forum.manjaro.org/t/warning-os- … ions/57849

sudo nano /etc/default/grub


# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

# os prober
GRUB_DISABLE_OS_PROBER=false
 



sudo update-grub


[sudo] Mot de passe de alain :
Generating grub configuration file ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Found linux image: /boot/vmlinuz-5.15.0-2-amd64
Found initrd image: /boot/initrd.img-5.15.0-2-amd64
Found linux image: /boot/vmlinuz-5.15.0-1-amd64
Found initrd image: /boot/initrd.img-5.15.0-1-amd64
Found linux image: /boot/vmlinuz-5.10.0-8-amd64
Found initrd image: /boot/initrd.img-5.10.0-8-amd64
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found Debian GNU/Linux 11 (bullseye) on /dev/sdb2
Adding boot menu entry for UEFI Firmware Settings ...
done
 



un petit souci qd mme , bullseye est passé en 5.10.0-9 et ici , je n'ai que le noyau 5.10.0-8
par contre , je démarre bien sur le noyau 5.10.0-9

qui plus est , je n'arrive pas à installer  grub sur le disque de bullseye .(ssd)

quand je boot sur le  ssd depuis le bios , j'obtiens :

minimal bash-like line is supported . .... / ....


avec le prompt de grub .

ps: ma machine est instable et je sais pas d'où çà vient .

Dernière modification par Debian Alain (29-11-2021 09:36:34)

En ligne

#3 29-11-2021 09:34:14

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] grub uefi ne reconait pas tous mes disques

Bonjour smile
raleur va te sortir de ce mauvais pas
il y a un souci ici


Warning: os-prober will be executed to detect other bootable partitions.
 


sinon chez moi aussi , mauvais temps , foudre , neige ,grêle , pluie  bref le chat est en dépression  wink

Hors ligne

#4 29-11-2021 09:41:58

raleur
Membre
Inscription : 03-10-2014

Re : [résolu] grub uefi ne reconait pas tous mes disques

Debian Alain a écrit :

depuis une violente coupure de réseau


C'est la première fois que je vois une coupure de réseau modifier une option de configuration de GRUB.
Plus sérieusement, d'après un autre forum ce serait suite à une mise à jour des paquets grub* dans sid.
Est-ce que ton fichier /etc/default/grub contenait GRUB_DISABLE_OS_PROBER=true ? Sinon cela voudrait dire que c'est la valeur par défaut de GRUB_DISABLE_OS_PROBER qui a changé avec cette nouvelle version.

Debian Alain a écrit :

un petit souci qd mme , bullseye est passé en 5.10.0-9 et ici , je n'ai que le noyau 5.10.0-8


Où ça ? Dans l'installation de bullseye ou dans les entrées de bullseye dans le menu de GRUB de sid ?

Debian Alain a écrit :

qui plus est , je n'arrive pas à installer  grub sur le disque de bullseye .(ssd)


Ai-je besoin d'écrire que cette phrase ne contient aucune information utile ?

Dernière modification par raleur (29-11-2021 09:56:36)


Il vaut mieux montrer que raconter.

En ligne

#5 29-11-2021 10:59:42

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux sid 5.15.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] grub uefi ne reconait pas tous mes disques

raleur  a écrit :

Debian Alain a écrit :

depuis une violente coupure de réseau

C'est la première fois que je vois une coupure de réseau modifier une option de configuration de GRUB.
Plus sérieusement, d'après un autre forum ce serait suite à une mise à jour des paquets grub* dans sid.
Est-ce que ton fichier /etc/default/grub contenait GRUB_DISABLE_OS_PROBER=true ? Sinon cela voudrait dire que c'est la valeur par défaut de GRUB_DISABLE_OS_PROBER qui a changé avec cette nouvelle version.

non , la modification , c'est moi qui  l'ai faite .
sans çà , je n'avais que les entrées de  sid .

raleur  a écrit :

   

Debian Alain a écrit :

un petit souci qd mme , bullseye est passé en 5.10.0-9 et ici , je n'ai que le noyau 5.10.0-8

Où ça ? Dans l'installation de bullseye ou dans les entrées de bullseye dans le menu de GRUB de sid ?

la commande "update-grub" ne montre que le noyau 5.10.0-8
mais je viens de voir que le menu de grub lance bien le noyau 5.10.0-9

Debian Alain a écrit :

qui plus est , je n'arrive pas à installer  grub sur le disque de bullseye .(ssd)

quand je boot sur le  ssd depuis le bios , j'obtiens :

minimal bash-like line is supported . .... / ....


avec le prompt de grub .

qu'est ce que tu comprends pas râleur ?
j'ai beau installer  grub dans le ssd (bullseye) , redémarrer dessus depuis le bios me donne le prompt de grub .

par contre , démarrer bullseye depuis le grub du nvme (sid) ne me pose pas de souci .

amicalement,

alain.

coyotus.png

En ligne

#6 29-11-2021 11:21:57

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] grub uefi ne reconait pas tous mes disques

sur sid ce message aujourd'hui


apt-listchanges : nouveautés
----------------------------

grub2 (2.06-1) UNRELEASED; urgency=medium

  * Boot menu entries for other operating systems are no longer generated by
    default.  To re-enable this, set GRUB_DISABLE_OS_PROBER=false in
    /etc/default/grub.

 -- Colin Watson <cjwatson@debian.org>  Wed, 18 Aug 2021 13:03:23 +0100
 

Hors ligne

#7 29-11-2021 11:40:36

raleur
Membre
Inscription : 03-10-2014

Re : [résolu] grub uefi ne reconait pas tous mes disques

Debian Alain a écrit :

non , la modification , c'est moi qui  l'ai faite.


Tu veux dire qu'il n'y avait pas d'option GRUB_DISABLE_OS_PROBER dans /etc/default/grub ? Donc c'est sa valeur par défaut qui a dû changer. Je serais curieux de connaître la raison de ce changement, je n'ai rien vu dans le changelog du paquet source grub2 de sid...

Debian Alain a écrit :

la commande "update-grub" ne montre que le noyau 5.10.0-8
mais je viens de voir que le menu de grub lance bien le noyau 5.10.0-9


La commande update-grub exécutée depuis sid ? Si je ne m'abuse, update-grub n'affiche que les noyaux de son propre système, pas ceux des autres systèmes.

Debian Alain a écrit :

j'ai beau installer  grub dans le ssd (bullseye) , redémarrer dessus depuis le bios me donne le prompt de grub


Comment installes-tu GRUB dans le SSD SATA depuis bullseye ?
Comment sélectionnes-tu le démarrage sur le SSD SATA ? Via une entrée "debian" ou le modèle du SSD ?
A l'invite grub>, peux-tu exécuter la commande "set" pour relever les valeurs de cmdpath et prefix ?


Il vaut mieux montrer que raconter.

En ligne

#8 29-11-2021 11:45:23

raleur
Membre
Inscription : 03-10-2014

Re : [résolu] grub uefi ne reconait pas tous mes disques

robert2a a écrit :

sur sid ce message aujourd'hui


Bizarre, je ne le retrouve pas dans https://metadata.ftp-master.debian.org/ … _changelog


Il vaut mieux montrer que raconter.

En ligne

#9 29-11-2021 12:12:14

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux sid 5.15.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] grub uefi ne reconait pas tous mes disques

j' ai bien entré la commande "set"  mais j'ai beaucoup trop de données .
l'écran n'est pas assez grand .
je n'ai pas pu  recopier la ligne  "cmdpath"
par contre , je peux te donner la ligne "prefix"

prefix=(hd1,gpt1)/boot/grub

En ligne

#10 29-11-2021 12:20:19

raleur
Membre
Inscription : 03-10-2014

Re : [résolu] grub uefi ne reconait pas tous mes disques

Si set affiche trop dfe lignes, tu peux soit afficher seulement une variable avec

echo $cmdpath


soit stopper l'affichage entre chaque page en exécutant la commande suivante avant :

set pager=1


ça a à peu près le même effet qu'ajouter "| more" dans bash.
hd1 est-il bien le SSD SATA et la partition hd1,gpt1 est-elle bien la racine de bullseye ? Tu peux vérifier avec

ls
ls (hd1,gpt1)/
 



Tu n'as pas dit comment tu avais installé GRUB sur le SSD SATA.
Est-ce qu'il y a bien un fichier /boot/grub/grub.cfg dans bullseye ?

Dernière modification par raleur (29-11-2021 12:24:22)


Il vaut mieux montrer que raconter.

En ligne

#11 29-11-2021 12:45:08

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] grub uefi ne reconait pas tous mes disques

@raleur
messagerie de tous les "messages système" en local donc aucun doute pour moi


MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: 7bit
Message-Id: <E1mrcoy-0001Ao-I5@debian2.home>
From: root <root@debian2.home>
Date: Mon, 29 Nov 2021 10:19:36 +0100

grub2 (2.06-1) UNRELEASED; urgency=medium

  * Boot menu entries for other operating systems are no longer generated by
    default.  To re-enable this, set GRUB_DISABLE_OS_PROBER=false in
    /etc/default/grub.

 -- Colin Watson <cjwatson@debian.org>  Wed, 18 Aug 2021 13:03:23 +0100
 



de plus si ma mémoire était bonne , j'ai du avoir la même chose a l'installation de Arch Linux
mais cela est un autre problème  roll

Hors ligne

#12 29-11-2021 13:05:58

raleur
Membre
Inscription : 03-10-2014

Re : [résolu] grub uefi ne reconait pas tous mes disques

Vu. Cette information est dans le fichier local /usr/share/doc/grub-common/NEWS.Debian.gz mais pas dans le changelog local ou en ligne. Bizarre.
En tout cas il s'agit d'un changement introduit dans la version 2.6 amont, pas spécifique à Debian. Raison invoquée : risque de sécurité. Je sens que ça va en surprendre plus d'un...

Dernière modification par raleur (29-11-2021 13:06:35)


Il vaut mieux montrer que raconter.

En ligne

#13 29-11-2021 16:57:42

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux sid 5.15.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] grub uefi ne reconait pas tous mes disques

echo $cmdpath


(hd1,gpt1)/EFI/DEBIAN



ls


(proc) (hd0) (hd0,gpt1) (hd1) (hd1,gpt4) (hd1,gpt3) (hd1,gpt2) (hd1,gpt1) (hd2) (hd2,gpt4) (hd2,gpt3) (hd2, gpt2) (hd2,gpt1)



ls (hd1,gpt1)/


efi/



pour l'installation de grub , j'ai fait un peu n'importe quoi .
je me suis inspiré entre autres de ces deux sites , mais pas que ...

https://wiki.debian.org/GrubEFIReinstall
https://doc.ubuntu-fr.org/grub-uefi

bien sur , je n'ai rien compris .
la procédure paraît pourtant simple .

p.s.: essayé aussi ceci : https://debian-facile.org/doc:systeme:grub2:reparer
mais échec . les commandes fonctionnent , j'arrive à installer grub , mais , en lançant le bios sur le disque sdb , grub ne  fonctionne pas . j'obtiens le prompt et c'est tout .

Dernière modification par Debian Alain (29-11-2021 17:44:20)

En ligne

#14 29-11-2021 20:49:21

raleur
Membre
Inscription : 03-10-2014

Re : [résolu] grub uefi ne reconait pas tous mes disques

On voit qu'il y a 3 "disques" hd0 (1 partition), hd1 (4 partitions) et hd2 (4 partitions).

La valeur de $cmdpath indique que l'amorçage a utilisé le chargeur Debian situé dans la partition n° 1 du disque hd1, qui est donc la partition EFI. Comme le disque hd2 a le même nombre de partitions, ce n'est pas évident de les distinguer. S'ils sont de tailles différentes, tu peux les comparer grâce à la sortie de

ls (hd1) (hd2)



La valeur de $prefix pointe vers la même partition EFI, ce qui est inhabituel car normalement /boot/grub est dans la partition racine ou la partition /boot, pas dans la partition EFI. D'ailleurs la dernière commande montre que cette partition ne contient pas de répertoire /boot. Avec la variante signée de GRUB qui est installée par défaut, les variables $root et $prefix sont initialisée par un fichier /EFI/debian/grub.cfg qui recherche l'UUID de la partition qui contient /boot/grub. Si l'UUID n'est pas trouvé, $root conserve la valeur initiale de la la partition EFI. C'est probablement ce qui se passe.

Pour installer correctement GRUB, ce n'est pas compliqué.
Démarrer sur le système concerné.
Vérifier que la bonne partition EFI est montée sur /boot/efi (par /etc/fstab).
Exécuter

grub-install --force-extra-removable


Attention : cette commande va créer une entrée de boot EFI "debian" qui va soit remplacer l'entrée "debian" existante soit s'ajouter, selon le firmware UEFI. Apparemment c'est le second cas pour toi puisque efibootmgr affiche 3 entrées "debian". Elle peut aussi changer l'ordre de priorité des entrées de boot. Vérifier tout ça avec efibootmgr. Pour ne pas modifier les variables de boot EFI, ajouter l'option --no-nvram.
L'option --force-extra-removable écrit une copie de GRUB dans le "chemin de support amovible" /EFI/boot de la partition EFI, qui est amorçable sans entrée de boot depuis le menu de boot du firmware.

D'ailleurs tu n'as toujours pas dit comment tu démarrais sur le SSD bullseye.


Il vaut mieux montrer que raconter.

En ligne

#15 29-11-2021 20:59:57

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux sid 5.15.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] grub uefi ne reconait pas tous mes disques

D'ailleurs tu n'as toujours pas dit comment tu démarrais sur le SSD bullseye.


çà va faire trois fois que je dis que cette erreur apparaît quand j'utilise le bios pour démarrer en direct sur ce ssd .

le démarrage de bullseye depuis le grub du nvme (sid)  ne pose pas de problème .

En ligne

#16 29-11-2021 21:08:26

raleur
Membre
Inscription : 03-10-2014

Re : [résolu] grub uefi ne reconait pas tous mes disques

Debian Alain a écrit :

çà va faire trois fois que je dis que cette erreur apparaît quand j'utilise le bios pour démarrer en direct sur ce ssd .


Mais tu ne dis pas comment, ce que tu fais exactement, dans quel menu, avec quelle option...


Il vaut mieux montrer que raconter.

En ligne

#17 29-11-2021 21:33:01

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux sid 5.15.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] grub uefi ne reconait pas tous mes disques

je te remercie râleur .

ta commande m'a tiré d'affaire .

maintenant , je peux booter en direct depuis le bios sur le ssd .

j'ai dû rectifier une erreur d'installation .
quand a t elle été faite ? je ne sais pas .
est ce vraiment une erreur ? je ne sais pas
pourquoi cette écriture ? ... mystère

voilà mon fstab rectifié :

  GNU nano 5.9                                                fstab                                                          
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# systemd generates mount units based on this file, see systemd.mount(5).
# Please run 'systemctl daemon-reload' after making changes here.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb2 during installation
UUID=24484c9c-b16e-4960-b4e3-378272350cf5 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/nvme0n1p1 during installation
#UUID=4C19-32CF  /boot/efi       vfat    umask=0077      0       1
# remis sur /dev/sdb1
UUID=78AB-CDD1  /boot/efi       vfat    umask=0077      0       1

# /home was on /dev/sdb4 during installation
UUID=72b67e18-c7bc-4734-b802-63fe432a8ed5 /home           ext4    defaults        0       2
# swap was on /dev/sdb3 during installation
UUID=0d9fc33f-1f78-4b1c-8956-0f79f95b7fec none            swap    sw              0       0
#
# rajout sid-home
#UUID=723480b2-77b1-4521-ba4b-a2060c4a6187 /mnt/sid-home          ext4  defaults        0       2
 



NAME        FSTYPE FSVER LABEL       UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
sda                                                                                      
└─sda1      ext4   1.0   sauvegarde  ba86cfa4-fed0-4809-a91a-14ef0a8ea671  869,8G    71% /mnt/sauvegarde
sdb                                                                                      
├─sdb1      vfat   FAT32 BOOT        78AB-CDD1                                          
├─sdb2      ext4   1.0   stable      24484c9c-b16e-4960-b4e3-378272350cf5                
├─sdb3      swap   1     swap        0d9fc33f-1f78-4b1c-8956-0f79f95b7fec                
└─sdb4      ext4   1.0   home-stable 72b67e18-c7bc-4734-b802-63fe432a8ed5  749,3G     0% /mnt/stable
nvme0n1                                                                                  
├─nvme0n1p1 vfat   FAT32             4C19-32CF                               505M     1% /boot/efi
├─nvme0n1p2 ext4   1.0               6a094235-a2d1-4e18-864d-a2a6234eb693  188,2G    12% /
├─nvme0n1p3 swap   1                 1bcdfe02-d0c8-4f75-a8b7-f579ad77700e                [SWAP]
└─nvme0n1p4 ext4   1.0               1b3de2a2-af58-4278-b0b3-115e0c426ab8  816,3G    41% /home
 



merci pour ta commande .

donc , concrètement , en détail , qu'a t elle fait ?
où était mon erreur ?
qu'ai je fait de mauvais ?

merci .

alain .

coyotus.png

Dernière modification par Debian Alain (29-11-2021 21:35:09)

En ligne

#18 29-11-2021 21:34:42

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] grub uefi ne reconait pas tous mes disques

il utilise les enregistrements EFI , en fin onglet tu a tous les OS que tu peu lancer directement
sinon tu sélectionne de disque de boot (de bullseye) que tu place en position 1 (qui commence par "debian")
donc je suppose que tu fais la première méthode

pour grub de sid normal que ça fonctionne , c'est le grub de bullseye qui est mauvais

ps: tu a deux endroit a modifier , les disques autoriser (ou tu peu changer l'ordre de préférence) et le disque que tu place en position 1 de l'ordre de boot
mais je suppose que tu connais tout cela  smile

c'est résolu   tongue

Dernière modification par robert2a (29-11-2021 21:36:57)

Hors ligne

#19 29-11-2021 21:39:31

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux sid 5.15.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] grub uefi ne reconait pas tous mes disques

robert2a  a écrit :

ps: tu a deux endroit a modifier , les disques autoriser (ou tu peu changer l'ordre de préférence) et le disque que tu place en position 1 de l'ordre de boot
mais je suppose que tu connais tout cela

je touche très rarement aux boots .
je commence à peine à le comprendre .
le sujet est encore nébuleux pour moi .
faudrai que je me remette le sujet en mémoire .
pas évident quand on n'y touche pas souvent .

merci à tous .

alain .

coyotus.png

En ligne

#20 29-11-2021 22:39:10

raleur
Membre
Inscription : 03-10-2014

Re : [résolu] grub uefi ne reconait pas tous mes disques

Debian Alain a écrit :

voilà mon fstab rectifié


Rectifié de quelle façon ?
Ce fstab n'est pas celui du système actuellement actif.

Debian Alain a écrit :

donc , concrètement , en détail , qu'a t elle fait ?


Elle a installé le chargeur GRUB dans /boot/efi/EFI/debian/ et /boot/efi/EFI/Boot/ (par l'option --force-extra-removable).
Elle a créé un fichier /boot/efi/EFI/debian/grub.cfg pour définir la variable $prefix avec la position (UUID et chemin) du répertoire /boot/grub dans lequel le chargeur GRUB ira lire le fichier /boot/grub/grub.cfg permettant d'afficher le menu.
Elle a créé une entrée "debian" dans les variables de boot EFI pointant vers le PARTUUID de la partition EFI et le fichier /EFI/debian/shimx64.efi qui sert à lancer GRUB avec le secure boot activé.

Debian Alain a écrit :

qu'ai je fait de mauvais ?


Impossible de dire sans savoir exactement ce que tu as fait, dans quelles conditions...


Il vaut mieux montrer que raconter.

En ligne

#21 29-11-2021 23:08:22

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Debian Sid 64bits Ordi.: Thinkpad T400
Noyau : 5.10.40-1
(G)UI : xfce
Inscription : 04-03-2017

Re : [résolu] grub uefi ne reconait pas tous mes disques

Bonsoir Debian Alain

J'ai vu ça récemment, en faisant la mise à jour de ma debian sid, peut-être que ça pourra t'aider:

apt-listchanges : nouveautés
----------------------------

grub2 (2.06-1) UNRELEASED ; urgency=medium

  * Les entrées du menu de démarrage pour d'autres systèmes d'exploitation ne sont plus générées par
    par défaut.  Pour réactiver cette fonction, définissez GRUB_DISABLE_OS_PROBER=false dans le fichier
    /etc/default/grub.

Debian sid
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#22 30-11-2021 12:11:51

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux sid 5.15.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] grub uefi ne reconait pas tous mes disques

râleur  a écrit :

   

Debian Alain  a écrit :

voilà mon fstab rectifié


Rectifié de quelle façon ?
Ce fstab n'est pas celui du système actuellement actif.



râleur  a écrit :

Vérifier que la bonne partition EFI est montée sur /boot/efi (par /etc/fstab).



... / ...
# /boot/efi was on /dev/nvme0n1p1 during installation
#UUID=4C19-32CF  /boot/efi       vfat    umask=0077      0       1
# remis sur /dev/sdb1
UUID=78AB-CDD1  /boot/efi       vfat    umask=0077      0       1
... / ...

 



lsblk -f


NAME        FSTYPE FSVER LABEL       UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
sda                                                                                      
└─sda1      ext4   1.0   sauvegarde  ba86cfa4-fed0-4809-a91a-14ef0a8ea671  869,8G    71% /mnt/sauvegarde
sdb                                                                                      
├─sdb1      vfat   FAT32 BOOT        78AB-CDD1                                          
├─sdb2      ext4   1.0   stable      24484c9c-b16e-4960-b4e3-378272350cf5                
├─sdb3      swap   1     swap        0d9fc33f-1f78-4b1c-8956-0f79f95b7fec                
└─sdb4      ext4   1.0   home-stable 72b67e18-c7bc-4734-b802-63fe432a8ed5  749,3G     0% /mnt/stable
nvme0n1                                                                                  
├─nvme0n1p1 vfat   FAT32             4C19-32CF                               505M     1% /boot/efi
├─nvme0n1p2 ext4   1.0               6a094235-a2d1-4e18-864d-a2a6234eb693  188,2G    12% /
├─nvme0n1p3 swap   1                 1bcdfe02-d0c8-4f75-a8b7-f579ad77700e                [SWAP]
└─nvme0n1p4 ext4   1.0               1b3de2a2-af58-4278-b0b3-115e0c426ab8  816,3G    41% /home
 



râleur  a écrit :

Mais tu ne dis pas comment, ce que tu fais exactement, dans quel menu, avec quelle option...


Debian Alain  a écrit :

maintenant , je peux booter en direct depuis le bios sur le ssd .



5UjIjUq.png

tu comprends mieux , maintenant ?

Dernière modification par Debian Alain (30-11-2021 12:35:54)

En ligne

#23 30-11-2021 20:56:02

raleur
Membre
Inscription : 03-10-2014

Re : [résolu] grub uefi ne reconait pas tous mes disques

Avec l'image, oui. Mais je me serais contenté d'une description de ce menu de démarrage :
- debian sur SATA6G_4
- debian sur M.2_1
- debian sur SATA6G_4 <- entrée sélectionnée pour démarrer buster.
- UEFI: USB

Curieux qu'il y ait deux entrées "debian" sur le SSD SATA. Que donne l'autre ?

Par contre, concernant le fstab de bullseye, ce n'est toujours pas clair. Faut-il comprendre que la rectification que tu as évoquée a consisté à remplacer l'UUID de la partition EFI de /dev/nvme0n1 par l'UUID de la partition EFI de /dev/sdb ?

Dernière modification par raleur (30-11-2021 20:56:33)


Il vaut mieux montrer que raconter.

En ligne

#24 30-11-2021 22:30:51

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux sid 5.15.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] grub uefi ne reconait pas tous mes disques

râleur  a écrit :

Curieux qu'il y ait deux entrées "debian" sur le SSD SATA. Que donne l'autre ?


oui , j'ai vu çà quand je t'ai posté la photo .
pas  fait attention .
faudrai que je regarde les options de boot .
normalement , c'est rigoureusement la même entrée .

râleur  a écrit :

Par contre, concernant le fstab de bullseye, ce n'est toujours pas clair. Faut-il comprendre que la rectification que tu as évoquée a consisté à remplacer l'UUID de la partition EFI de /dev/nvme0n1 par l'UUID de la partition EFI de /dev/sdb ?


oui .

En ligne

#25 30-11-2021 22:44:49

raleur
Membre
Inscription : 03-10-2014

Re : [résolu] grub uefi ne reconait pas tous mes disques

Comment se fait-il que le fstab de bullseye montait la partition EFI de sid ?

Debian Alain a écrit :

normalement , c'est rigoureusement la même entrée .


On devrait pouvoir les retrouver et les comparer avec "efibootmgr -v".

Dernière modification par raleur (30-11-2021 22:45:43)


Il vaut mieux montrer que raconter.

En ligne

Pied de page des forums