Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 28-12-2021 23:37:42

Thund
Membre
Distrib. : Debian Buster, Voyager 9.4 Stretch, Bodhi Linux
(G)UI : Xfce et enlightment.
Inscription : 14-07-2019

[Résolu] Plus d'ethernet après passage Bullseye

Bonjour, je viens solliciter de l'aide suite à la mise à niveau de Buster à Bullseye. Depuis le redémarrage à la fin de l'installation, je n'ai plus d’Ethernet sur mon pc fixe. J'ai une carte wifi qui elle fonctionne normalement. Dans Netwotk Manager seul le wifi est affiché. J'essaie en temps normal de me débrouiller seul mais n'y connaissant strictement rien en réseaux, je sèche lamentablement.

Si quelqu'un a une idée ou un conseil, je suis preneur.

Merci.

Dernière modification par Thund (02-01-2022 18:46:46)

Hors ligne

#2 28-12-2021 23:44:22

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Plus d'ethernet après passage Bullseye

lspci -nnkd ::200
ip link


Il vaut mieux montrer que raconter.

Hors ligne

#3 28-12-2021 23:48:26

lagrenouille
Adhérent(e)
Lieu : Saturne
Distrib. : debian buster_bulseyes
Noyau : d'olive
(G)UI : ça dépends des jours
Inscription : 28-03-2012
Site Web

Re : [Résolu] Plus d'ethernet après passage Bullseye

salut
normalement ça doit marcher, puisque le wifi fonctionne
vérifie si ton câble RJ45 est bien enficher, enlève le wifi et la connexion filière devrait démarrer.
tu as network-manager

dans ton fichier network/interface tu dois avoir au minimum

 cat /etc/network/interfaces



  # The loopback network interface
auto lo
iface lo inet loopback


admin dans le chaton : https://le-pic.org....
.
Une crise ne devient catastrophique que si nous y répondons par des idées toutes faites
Hannah Arendt

Hors ligne

#4 28-12-2021 23:54:09

Thund
Membre
Distrib. : Debian Buster, Voyager 9.4 Stretch, Bodhi Linux
(G)UI : Xfce et enlightment.
Inscription : 14-07-2019

Re : [Résolu] Plus d'ethernet après passage Bullseye

lspci -nnkd ::200
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 03)
  Subsystem: Gigabyte Technology Co., Ltd Onboard Ethernet [1458:e000]
  Kernel modules: r8169
thierry@debianterry:~$ ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: wlp4s6: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DORMANT group default qlen 1000
    link/ether d8:eb:97:15:69:59 brd ff:ff:ff:ff:ff:ff

Hors ligne

#5 28-12-2021 23:57:21

Thund
Membre
Distrib. : Debian Buster, Voyager 9.4 Stretch, Bodhi Linux
(G)UI : Xfce et enlightment.
Inscription : 14-07-2019

Re : [Résolu] Plus d'ethernet après passage Bullseye

lagrenouille a écrit :

salut
normalement ça doit marcher, puisque le wifi fonctionne
vérifie si ton câble RJ45 est bien enficher, enlève le wifi et la connexion filière devrait démarrer.
tu as network-manager

dans ton fichier network/interface tu dois avoir au minimum

 cat /etc/network/interfaces



  # The loopback network interface
auto lo
iface lo inet loopback




# The loopback network interface
auto lo
iface lo inet loopback
 



Désolé pour les balises, je ne me rappelle plus comment on fait....

Hors ligne

#6 29-12-2021 00:06:45

Thund
Membre
Distrib. : Debian Buster, Voyager 9.4 Stretch, Bodhi Linux
(G)UI : Xfce et enlightment.
Inscription : 14-07-2019

Re : [Résolu] Plus d'ethernet après passage Bullseye

lagrenouille a écrit :


vérifie si ton câble RJ45 est bien enficher, enlève le wifi et la connexion filière devrait démarrer.
tu as network-manager



J'ai déja essayer, changer de câble, toujours pareil, si je désactive le wifi l'ethernet ne réapparaît pas.

Hors ligne

#7 29-12-2021 00:14:34

lagrenouille
Adhérent(e)
Lieu : Saturne
Distrib. : debian buster_bulseyes
Noyau : d'olive
(G)UI : ça dépends des jours
Inscription : 28-03-2012
Site Web

Re : [Résolu] Plus d'ethernet après passage Bullseye

ton firmware realtek ( firmware-realtek ) est toujours là


que dit en root

systemctl status networking.service


admin dans le chaton : https://le-pic.org....
.
Une crise ne devient catastrophique que si nous y répondons par des idées toutes faites
Hannah Arendt

Hors ligne

#8 29-12-2021 00:20:25

Thund
Membre
Distrib. : Debian Buster, Voyager 9.4 Stretch, Bodhi Linux
(G)UI : Xfce et enlightment.
Inscription : 14-07-2019

Re : [Résolu] Plus d'ethernet après passage Bullseye

systemctl status networking.service


● networking.service - Raise network interfaces
     Loaded: loaded (/lib/systemd/system/networking.service; enabled; vendor pr>
     Active: active (exited) since Tue 2021-12-28 22:26:14 CET; 52min ago
       Docs: man:interfaces(5)
    Process: 454 ExecStart=/sbin/ifup -a --read-environment (code=exited, statu>
   Main PID: 454 (code=exited, status=0/SUCCESS)
        CPU: 68ms

déc. 28 22:26:13 debianterry systemd[1]: Starting Raise network interfaces...
déc. 28 22:26:14 debianterry systemd[1]: Finished Raise network interfaces

Hors ligne

#9 29-12-2021 00:39:32

lagrenouille
Adhérent(e)
Lieu : Saturne
Distrib. : debian buster_bulseyes
Noyau : d'olive
(G)UI : ça dépends des jours
Inscription : 28-03-2012
Site Web

Re : [Résolu] Plus d'ethernet après passage Bullseye

je sais pas trop ce que dit cette courte réponse

en root


systemctl restart NetworkManager.service

et

service NetworkManager restart


admin dans le chaton : https://le-pic.org....
.
Une crise ne devient catastrophique que si nous y répondons par des idées toutes faites
Hannah Arendt

Hors ligne

#10 29-12-2021 00:45:09

Thund
Membre
Distrib. : Debian Buster, Voyager 9.4 Stretch, Bodhi Linux
(G)UI : Xfce et enlightment.
Inscription : 14-07-2019

Re : [Résolu] Plus d'ethernet après passage Bullseye

Ca redémarre Network manager mais toujours pareil.

Hors ligne

#11 29-12-2021 01:20:49

lagrenouille
Adhérent(e)
Lieu : Saturne
Distrib. : debian buster_bulseyes
Noyau : d'olive
(G)UI : ça dépends des jours
Inscription : 28-03-2012
Site Web

Re : [Résolu] Plus d'ethernet après passage Bullseye

là je donne ma langue au chat pour l'instant
tu avais le réseau filière sous buster ?

admin dans le chaton : https://le-pic.org....
.
Une crise ne devient catastrophique que si nous y répondons par des idées toutes faites
Hannah Arendt

Hors ligne

#12 29-12-2021 01:32:26

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Plus d'ethernet après passage Bullseye

lagrenouille a écrit :

ton firmware realtek ( firmware-realtek ) est toujours là


C'est une question ou une affirmation ? Si c'est une question, il manque un point d'interrogation. Si c'est une affirmation, je suis curieux de savoir sur quoi elle se base.

@ Thund :
ip link ne montre pas d'interface ethernet, donc toute tentative avec NetworkManager ou n'importe quel autre gestionnaire de réseau est vouée à l'échec.
lspci indique que le module r8169 est censé prendre en charge le contrôleur ethernet mais n'est pas utilisé. Causes possibles :
- erreur lors du chargement du module, peut-être un firmware indispensable manquant, à vérifier avec

dmesg | grep r8169


- si c'est un firmware manquant, installer/mettre à jour le paquet firmware-realtek.
- module r8169 en blacklist via GRUB_CMDLINE_LINUX* dans /etc/default/grub ou une directive dans /etc/modprobe.d/*, peut-être pour utiliser le pilote Realtek r8168 qui fonctionnait mieux (paquet r8168-dkms). Dans ce cas, tu peux charger le module r8169 manuellement avec

modprobe r8169


et voir s'il fonctionne, ou bien rechercher pourquoi le module r8168 n'est pas listé par lspci. Peut-être qu'il n'a pas été recompilé pour le noyau de bullseye, ou que la compilation a échoué peut-être à cause de en-têtes du noyau manquants (paquet linux-headers-$(uname -r) à installer).

Infos utiles :


uname -a
dpkg -l linux-image* linux-headers* r8168* firmware*

Dernière modification par raleur (29-12-2021 01:37:54)


Il vaut mieux montrer que raconter.

Hors ligne

#13 29-12-2021 01:33:41

lagrenouille
Adhérent(e)
Lieu : Saturne
Distrib. : debian buster_bulseyes
Noyau : d'olive
(G)UI : ça dépends des jours
Inscription : 28-03-2012
Site Web

Re : [Résolu] Plus d'ethernet après passage Bullseye

C'est une question ou une affirmation ? Si c'est une question, il manque un point d'interrogation. Si c'est une affirmation, je suis curieux de savoir sur quoi elle se base.


c'est une connerie car c'est pour le wifi


admin dans le chaton : https://le-pic.org....
.
Une crise ne devient catastrophique que si nous y répondons par des idées toutes faites
Hannah Arendt

Hors ligne

#14 29-12-2021 10:36:40

Thund
Membre
Distrib. : Debian Buster, Voyager 9.4 Stretch, Bodhi Linux
(G)UI : Xfce et enlightment.
Inscription : 14-07-2019

Re : [Résolu] Plus d'ethernet après passage Bullseye

Bonjour, merci pour vos réponses. Je donnerait les retours des s commandes dès que je peux dans la journée.
Merci

Hors ligne

#15 29-12-2021 10:55:56

bartaba
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-13-amd64
(G)UI : Mate
Inscription : 04-02-2014

Re : [Résolu] Plus d'ethernet après passage Bullseye

lagrenouille a écrit :

C'est une question ou une affirmation ? Si c'est une question, il manque un point d'interrogation. Si c'est une affirmation, je suis curieux de savoir sur quoi elle se base.


c'est une connerie car c'est pour le wifi


Bonjour
C'est pas une connerie la carte ethernet est bien une realtek

03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 03)
  Subsystem: Gigabyte Technology Co., Ltd Onboard Ethernet [1458:e000]
  Kernel modules: r8169



firmware-realtek c'est pas que pour le wifi, c'était une bonne idée de vérifier si le paquet était bien installé

Dernière modification par bartaba (29-12-2021 10:58:22)

Hors ligne

#16 29-12-2021 11:21:19

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Debian bullseye
Noyau : 5.10.0-10-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu] Plus d'ethernet après passage Bullseye

Lorsqu'une carte réseau me donne quelque chagrin; voici mon pense bête:

Problème de reconnaissance d'une carte réseau
Après changement d'une carte réseau, la reconnaissance de celle-ci peut poser problème...
Consulter le répertoire /etc/udev/rules.d
  Un fichier, du genre 70-persistente-net.rules, contient la référence à la MAC adresse
  de la carte associée à eth0.
Sur debian/ubuntu si ce fichier n'existe plus, il est recréé au redémarrage. Il suffit
donc de le supprimer (ou de le renommer)...

Hors ligne

#17 29-12-2021 11:46:05

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Plus d'ethernet après passage Bullseye

Les règles udev de nommage par adresse MAC sont sans objet ici puisque l'interface n'existe même pas.

gargamel79 a écrit :

Sur debian/ubuntu si ce fichier n'existe plus, il est recréé au redémarrage.


Ce n'est plus vrai depuis plusieurs versions de Debian avec le passage au nommage soi-disant prévisible et à systemd qui permet de faire la même chose.

gargamel79 a écrit :

Il suffit donc de le supprimer (ou de le renommer)


Quel intérêt de le supprimer ou le renommer s'il est recréé au démarrage ?
D'autre part, le renommer sans changer l'extension .rules n'empêche pas sa prise en compte.

Dernière modification par raleur (29-12-2021 11:47:36)


Il vaut mieux montrer que raconter.

Hors ligne

#18 29-12-2021 23:44:03

Thund
Membre
Distrib. : Debian Buster, Voyager 9.4 Stretch, Bodhi Linux
(G)UI : Xfce et enlightment.
Inscription : 14-07-2019

Re : [Résolu] Plus d'ethernet après passage Bullseye

tu avais le réseau filière sous buster ?



Oui tout était ok. Pendant la migration de Buster à Bullseye j'étais en filaire, c'est au premier redémarrage que ça a disparu.

Hors ligne

#19 29-12-2021 23:53:19

Thund
Membre
Distrib. : Debian Buster, Voyager 9.4 Stretch, Bodhi Linux
(G)UI : Xfce et enlightment.
Inscription : 14-07-2019

Re : [Résolu] Plus d'ethernet après passage Bullseye

raleur a écrit :

lagrenouille a écrit :

ton firmware realtek ( firmware-realtek ) est toujours là


C'est une question ou une affirmation ? Si c'est une question, il manque un point d'interrogation. Si c'est une affirmation, je suis curieux de savoir sur quoi elle se base.

@ Thund :
ip link ne montre pas d'interface ethernet, donc toute tentative avec NetworkManager ou n'importe quel autre gestionnaire de réseau est vouée à l'échec.
lspci indique que le module r8169 est censé prendre en charge le contrôleur ethernet mais n'est pas utilisé. Causes possibles :
- erreur lors du chargement du module, peut-être un firmware indispensable manquant, à vérifier avec

dmesg | grep r8169


- si c'est un firmware manquant, installer/mettre à jour le paquet firmware-realtek.
- module r8169 en blacklist via GRUB_CMDLINE_LINUX* dans /etc/default/grub ou une directive dans /etc/modprobe.d/*, peut-être pour utiliser le pilote Realtek r8168 qui fonctionnait mieux (paquet r8168-dkms). Dans ce cas, tu peux charger le module r8169 manuellement avec

modprobe r8169


et voir s'il fonctionne, ou bien rechercher pourquoi le module r8168 n'est pas listé par lspci. Peut-être qu'il n'a pas été recompilé pour le noyau de bullseye, ou que la compilation a échoué peut-être à cause de en-têtes du noyau manquants (paquet linux-headers-$(uname -r) à installer).

Infos utiles :


uname -a
dpkg -l linux-image* linux-headers* r8168* firmware*



Bonsoir,
Voici le retour des commandes :

thierry@debianterry:~$ sudo dmesg | grep r8169
[sudo] Mot de passe de thierry :
[    1.463854] r8169 0000:03:00.0: can't disable ASPM; OS doesn't have ASPM control
[    1.477589] libphy: r8169: probed
[    1.477594] r8169 0000:03:00.0: no dedicated PHY driver found for PHY ID 0xc2077002, maybe realtek.ko needs to be added to initramfs?
[    1.507431] r8169: probe of 0000:03:00.0 failed with error -49
thierry@debianterry:~$ sudo modprobe r8169
thierry@debianterry:~$ uname -a
Linux debianterry 5.10.0-10-amd64 #1 SMP Debian 5.10.84-1 (2021-12-08) x86_64 GNU/Linux
thierry@debianterry:~$ dpkg -l linux-image* linux-headers* r8168* firmware*
dpkg-query: aucun paquet ne correspond à r8168*
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                                  Version      Architecture Description
+++-====================================-============-============-==========================================================
un  firmware-adi                         <aucune>     <aucune>     (aucune description n'est disponible)
un  firmware-amd-graphics                <aucune>     <aucune>     (aucune description n'est disponible)
un  firmware-ivtv                        <aucune>     <aucune>     (aucune description n'est disponible)
un  firmware-linux                       <aucune>     <aucune>     (aucune description n'est disponible)
ii  firmware-linux-free                  20200122-1   all          Binary firmware for various drivers in the Linux kernel
un  firmware-linux-nonfree               <aucune>     <aucune>     (aucune description n'est disponible)
ii  firmware-misc-nonfree                20210315-3   all          Binary firmware for various drivers in the Linux kernel
ii  firmware-ralink                      20190114-2   all          Binary firmware for Ralink wireless cards (dummmy package)
un  linux-headers                        <aucune>     <aucune>     (aucune description n'est disponible)
un  linux-headers-2.6-686                <aucune>     <aucune>     (aucune description n'est disponible)
un  linux-headers-2.6-amd64              <aucune>     <aucune>     (aucune description n'est disponible)
ii  linux-headers-5.10.0-10-amd64        5.10.84-1    amd64        Header files for Linux 5.10.0-10-amd64
ii  linux-headers-5.10.0-10-common       5.10.84-1    all          Common header files for Linux 5.10.0-10
un  linux-headers-686-pae                <aucune>     <aucune>     (aucune description n'est disponible)
ii  linux-headers-amd64                  5.10.84-1    amd64        Header files for Linux amd64 configuration (meta-package)
un  linux-headers-generic                <aucune>     <aucune>     (aucune description n'est disponible)
un  linux-headers-generic-pae            <aucune>     <aucune>     (aucune description n'est disponible)
un  linux-image                          <aucune>     <aucune>     (aucune description n'est disponible)
lines 1-23
 

Hors ligne

#20 30-12-2021 00:22:36

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Plus d'ethernet après passage Bullseye

Thund a écrit :

[    1.477594] r8169 0000:03:00.0: no dedicated PHY driver found for PHY ID 0xc2077002, maybe realtek.ko needs to be added to initramfs?
[    1.507431] r8169: probe of 0000:03:00.0 failed with error -49


Donc le module r8169 pour le contrôleur est bien chargé mais il manque un pilote pour le PHY. On va vérifier le module realtek.ko mentionné.

/sbin/lsmod | grep realtek
lsinitramfs /boot/initrd.img-$(uname -r) | grep realtek


Il vaut mieux montrer que raconter.

Hors ligne

#21 30-12-2021 00:39:41

Thund
Membre
Distrib. : Debian Buster, Voyager 9.4 Stretch, Bodhi Linux
(G)UI : Xfce et enlightment.
Inscription : 14-07-2019

Re : [Résolu] Plus d'ethernet après passage Bullseye

/sbin/lsmod | grep realtek


thierry@debianterry:~$ /sbin/lsmod | grep realtek
snd_hda_codec_realtek   159744  1
snd_hda_codec_generic    98304  1 snd_hda_codec_realtek
snd_hda_codec         172032  3 snd_hda_codec_generic,snd_hda_intel,snd_hda_codec_realtek
snd_hda_core          110592  4 snd_hda_codec_generic,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
snd                   110592  15 snd_hda_codec_generic,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_compress,snd_soc_core,snd_pcm
realtek                24576  0
libphy                151552  3 r8169,mdio_devres,realtek



lsinitramfs /boot/initrd.img-$(uname -r) | grep realtek


thierry@debianterry:~$ lsinitramfs /boot/initrd.img-$(uname -r) | grep realtek
usr/lib/modules/5.10.0-10-amd64/kernel/drivers/net/ethernet/realtek
usr/lib/modules/5.10.0-10-amd64/kernel/drivers/net/ethernet/realtek/8139cp.ko
usr/lib/modules/5.10.0-10-amd64/kernel/drivers/net/ethernet/realtek/8139too.ko
usr/lib/modules/5.10.0-10-amd64/kernel/drivers/net/ethernet/realtek/r8169.ko
usr/lib/modules/5.10.0-10-amd64/kernel/drivers/net/phy/realtek.ko
usr/lib/modules/5.10.0-10-amd64/kernel/drivers/usb/storage/ums-realtek.ko
 

Hors ligne

#22 30-12-2021 01:01:08

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Plus d'ethernet après passage Bullseye

Le module realtek.ko est bien présent dans l'initramfs et chargé.
Il y a un souci soit avec les pilotes Realtek du noyau, soit avec le PHY ID ethernet.
Pourrais-tu éteindre complètement, redémarrer et refaire la commande dmesg ?

EDIT : d'après une recherche sur le web, il pourrait s'agir d'un bug de certains cartes mères Gigabyte. Une solution possible consisterait à aller dans le BIOS et activer l'option "Network Boot ROM".

EDIT 2 : autre contournement possible : installer le pilote Realtek avec le paquet r8168-dkms.

Dernière modification par raleur (30-12-2021 01:25:43)


Il vaut mieux montrer que raconter.

Hors ligne

#23 30-12-2021 01:47:39

Thund
Membre
Distrib. : Debian Buster, Voyager 9.4 Stretch, Bodhi Linux
(G)UI : Xfce et enlightment.
Inscription : 14-07-2019

Re : [Résolu] Plus d'ethernet après passage Bullseye

J'ai activer la fonction dans le bios mais c'est toujours pareil.

Là dure journée, je vais au lit. Je pars plusieurs jours sans le pc, je reprends mes tests la semaine prochaine. Je commencerais par le pilote.

Merci pour ton aide, bonne fin d'année.

Hors ligne

#24 02-01-2022 18:45:28

Thund
Membre
Distrib. : Debian Buster, Voyager 9.4 Stretch, Bodhi Linux
(G)UI : Xfce et enlightment.
Inscription : 14-07-2019

Re : [Résolu] Plus d'ethernet après passage Bullseye

bonjour à tous et bonne année.

Après avoir réinstallé le paquet paquet r8168-dkms tout fonctionne normalement.

Merci à tous.

Hors ligne

#25 02-01-2022 19:00:30

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Plus d'ethernet après passage Bullseye

Réinstallé ? Il était déjà installé ? Pourtant dpkg ne l'avait pas trouvé.

Il vaut mieux montrer que raconter.

Hors ligne

Pied de page des forums