Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 16-02-2022 18:35:53

greb
Membre
Lieu : France
Distrib. : Debian 11 (+ W10)
Noyau : Linux 5.10.0-11-amd64
(G)UI : Kde
Inscription : 25-08-2020

[Résolu] Problème DNS à chaque redémarrage

Bonjour,

Depuis ce matin, l'ordinateur de ma compagne (distribution DFiso Debian 11) a un soucis : impossible de visiter un site web, que ce soit sur Firefox ou Chromium, ou même en ping, si je rentre un URL.
Si je mets une adresse IP, pas de soucis. Ce qui m'a fait penser qu'il s'agissait de la résolution de noms de domaine.
Et en visitant le fichier /etc/resolv.conf, j'ai ceci :

# Generated by NetworkManager
nameserver ::1


Ce qui ne correspond pas à ce que j'ai sur mon ordinateur (où je ne me rappelle pas avoir configuré ce fichier, et ai des adresses IP en nameserver).

Si je changer le nameserver (par exemple une IP de la FDN : 80.67.169.12), je peux ensuite naviguer normalement sur internet sur l'ordi de ma compagne.
Le truc est qu'à chaque redémarrage (et il me semble sortie de veille), le fichier retrouve son "nameserver ::1", et le navigateur ne permet pas de consulter aucune page via URL.

Il semblerait que NetworkManager devrait gérer automatiquement ça ? Mais je ne sais pas quoi changer…

Si vous avez une idée de piste, je suis preneur !!
D'avance merci beaucoup !

Dernière modification par greb (16-02-2022 21:34:39)


Ordinateur portable Thinkpad W540

Hors ligne

#2 16-02-2022 19:10:30

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Problème DNS à chaque redémarrage

Bonjour
cette machine est en cable ou en wifi ?
tu peu passer en statique avec le fichier "interfaces" le temps de trouver la raison de ce bug , networkmanager sera désactivé

donne le retour de ceci


systemctl status NetworkManager.service
 


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#3 16-02-2022 19:41:19

cyrille
CA Debian-Facile
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : [Résolu] Problème DNS à chaque redémarrage

Bonjour

Pour personnaliser tes DNS

apt install resolvconf




nano /etc/resolvconf/resolv.conf.d/head




Ajouter ton DNS

Exemple :

nameserver 8.8.8.8




Recharger

resolvconf -u




Redémarrer le réseau

 service network-manager restart




Le DNS ajouté est prioritaire

cat /etc/resolv.conf




Rebooter pour vérification


nslookup google.com
Server:   8.8.8.8
Address:  8.8.8.8#53

Non-authoritative answer:
Name: google.com
Address: 216.58.206.238
Name: google.com
Address: 2a00:1450:4007:810::200e




donc on voit via nslookup que le DNS enregistré est bien resté après un reboot avec les valeurs renseignées

Dernière modification par cyrille (16-02-2022 19:42:45)


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

Hors ligne

#4 16-02-2022 21:34:06

greb
Membre
Lieu : France
Distrib. : Debian 11 (+ W10)
Noyau : Linux 5.10.0-11-amd64
(G)UI : Kde
Inscription : 25-08-2020

Re : [Résolu] Problème DNS à chaque redémarrage

Merci pour vos retour robert2a et cyrille !

- robert2a, la machine rencontre le même problème aussi bien en wifi qu'en ethernet. Et le retour de la commande :

~$ sudo  systemctl status NetworkManager.service
● NetworkManager.service - Network Manager
     Loaded: loaded (/lib/systemd/system/NetworkManager.service; enabled; vendor preset: enabled)
     Active: active (running) since Wed 2022-02-16 20:01:02 CET; 14min ago
       Docs: man:NetworkManager(8)
   Main PID: 415 (NetworkManager)
      Tasks: 3 (limit: 3273)
     Memory: 16.2M
        CPU: 577ms
     CGroup: /system.slice/NetworkManager.service
             └─415 /usr/sbin/NetworkManager --no-daemon

févr. 16 20:01:10 debian NetworkManager[415]: <info>  [1645038070.5252] dhcp4 (wlp2s0): activation: beginning transaction (timeout in 45 seconds)
févr. 16 20:01:12 debian NetworkManager[415]: <info>  [1645038072.5447] dhcp4 (wlp2s0): state changed unknown -> bound, address=192.168.1.111
févr. 16 20:01:12 debian NetworkManager[415]: <info>  [1645038072.5463] device (wlp2s0): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'managed')
févr. 16 20:01:12 debian NetworkManager[415]: <info>  [1645038072.5488] device (wlp2s0): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'managed')
févr. 16 20:01:12 debian NetworkManager[415]: <info>  [1645038072.5491] device (wlp2s0): state change: secondaries -> activated (reason 'none', sys-iface-state: 'manage')
févr. 16 20:01:12 debian NetworkManager[415]: <info>  [1645038072.5519] policy: set 'MA_BOX' (wlp2s0) as default for IPv4 routing and DNS
févr. 16 20:01:12 debian NetworkManager[415]: <info>  [1645038072.5580] device (wlp2s0): Activation: successful, device activated.
févr. 16 20:01:12 debian NetworkManager[415]: <info>  [1645038072.5595] manager: startup complete
févr. 16 20:01:48 debian NetworkManager[415]: <warn>  [1645038108.9738] dhcp4 (ipv6leakintrf0): request timed out
févr. 16 20:01:48 debian NetworkManager[415]: <info>  [1645038108.9739] dhcp4 (ipv6leakintrf0): state changed unknown -> timeout
lines 1-21/21 (END)



- cyrille, j'ai effectué toutes les commandes, et ça fonctionne après un redémarrage, top ! merci !
J'ai essayé aussi avec comme nameserver celui mentionné dans mon premier post, ça reste en place après un redémarrage.
Juste, le service network-manager ne semble pas exister chez moi... Ça aurait pu être la cause de mon souci ?

~$ sudo service network-manager restart
Failed to restart network-manager.service: Unit network-manager.service not found.



J'ai par contre un service networking, mais ne sais pas si c'est l'équivalent.

En tous cas, le problème semble pour l'instant ok, je mets donc le sujet en résolu, et vous remercie pour cette réactivité et la solution !

Dernière modification par greb (16-02-2022 21:40:42)


Ordinateur portable Thinkpad W540

Hors ligne

#5 17-02-2022 03:51:17

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Problème DNS à chaque redémarrage

Bonjour
tu a fais une erreur , la commande est celle ci


~$ sudo service NetworkManager restart
 


ou


~$ sudo systemctl restart NetworkManager.service
 



sinon comme moi sans "NM"


systemctl status networking.service
● networking.service - Raise network interfaces
     Loaded: loaded (/lib/systemd/system/networking.service; enabled; vendor preset: enabled)
     Active: active (exited) since Wed 2022-02-16 19:00:01 CET; 7h ago
       Docs: man:interfaces(5)
    Process: 555 ExecStart=/sbin/ifup -a --read-environment (code=exited, status=0/SUCCESS)
   Main PID: 555 (code=exited, status=0/SUCCESS)
        CPU: 9ms

févr. 16 19:00:01 skylake1 systemd[1]: Starting Raise network interfaces...
févr. 16 19:00:01 skylake1 systemd[1]: Finished Raise network interfaces.
 


et (donc sans NM )


systemctl status NetworkManager.service
Unit NetworkManager.service could not be found.
 



pour ton problème je sais pas


févr. 16 20:01:48 debian NetworkManager[415]: <warn>  [1645038108.9738] dhcp4 (ipv6leakintrf0): request timed out
févr. 16 20:01:48 debian NetworkManager[415]: <info>  [1645038108.9739] dhcp4 (ipv6leakintrf0): state changed unknown -> timeout
 



normalement ta box doit fournir une IP v6 et v4 , et un serveur dhcp et DNS , moi c'est l' IP de la box
par contre il ne faut activer que le wifi ou le cable (et pas les deux ) , il me semble . roll

Dernière modification par robert2a (17-02-2022 04:04:26)


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

Pied de page des forums