Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-02-2022 12:05:02

fred02840
Membre
Lieu : Aisne
Distrib. : Debian GNU/Linux bookworm/sid
Noyau : 5.16.0-5-amd64
(G)UI : Gnome 42.beta
Inscription : 07-02-2018

Clavier Mac non reconnu

Bonjour,
Je travaille avec un portable Lenovo muni d'un clavier externe Mac (récupéré) ; quelques touches du clavier d'origine n'étaient plus opérationnelles (bousillées, quoi, à cause du gars — mézigue — qui a voulu faire un nettoyage complet dudit clavier…). Dans les paramètres, j'avais choisi « Français (Macintosh) » dans « Clavier », et tout fonctionnait parfaitement depuis des années. Et voilà que le clavier est passé en « Français (variante) » depuis deux ou trois jours : étonnant, non ?

Voici le contenu du fichier `/etc/default/keyboard`, qui n'a pas dû être modifié sans mon intervention :

XKBLAYOUT="fr"
XKBVARIANT="mac"
BACKSPACE="guess"
XKBMODEL="pc105"
XKBOPTIONS=""



Je ne sais plus trop (si je l'ai jamais su…) à quoi correspond XKBMODEL, et plus pourquoi j'ai opté pour "pc105"… Mai sje vais chercher.

Comment faire pour récupérer mon clavier Mac ?

Merci de votre aide


Lenovo E540 (Intel Core i3) : Debian GNU/Linux bookworm/sid. Gnome 40.4

Très accessoirement : Debian 10 Buster sur un MacBook Pro 6,4 (mi-2010), 15'', mod. A1286 (ah mais...) et une Debian 9 sur une eMachines (Intel Atom N455, 1Go de Ram, et 250 Go. LXDE minimale).

Hors ligne

#2 19-02-2022 12:25:45

fred02840
Membre
Lieu : Aisne
Distrib. : Debian GNU/Linux bookworm/sid
Noyau : 5.16.0-5-amd64
(G)UI : Gnome 42.beta
Inscription : 07-02-2018

Re : Clavier Mac non reconnu

Bon, j'ai modifié le fichier `/etc/default/keyboard` de cette façon :

XKBLAYOUT="fr"
XKBVARIANT="pc105"
BACKSPACE="guess"
XKBMODEL="mac"
XKBOPTIONS=""



Vous voyez que je me suis contenté d'inverser XKBVARIANT="pc105" et XKBMODEL="mac". À noter que XKBVARIANT="pc105" ou XKBVARIANT="" donnent les mêmes résultats.
Bref, j'ai récupéré mon clavier, sauf deux touches qui sont inversées : celle qui est en haut, à gauche (qui donne maintenant < et >) et celle qui est à la droite de la touche majuscule (maintenant : # et @). Peut-on les changer ?

clavie10.png

Dernière modification par fred02840 (19-02-2022 12:36:03)


Lenovo E540 (Intel Core i3) : Debian GNU/Linux bookworm/sid. Gnome 40.4

Très accessoirement : Debian 10 Buster sur un MacBook Pro 6,4 (mi-2010), 15'', mod. A1286 (ah mais...) et une Debian 9 sur une eMachines (Intel Atom N455, 1Go de Ram, et 250 Go. LXDE minimale).

Hors ligne

#3 22-04-2022 17:56:44

fred02840
Membre
Lieu : Aisne
Distrib. : Debian GNU/Linux bookworm/sid
Noyau : 5.16.0-5-amd64
(G)UI : Gnome 42.beta
Inscription : 07-02-2018

Re : Clavier Mac non reconnu

Bonjour,
Je coince toujours avec cette inversion des touches "@#" (en haut à gauche) et "<>" (à côté de la touche Maj).
Merci de vos suggestions

Lenovo E540 (Intel Core i3) : Debian GNU/Linux bookworm/sid. Gnome 40.4

Très accessoirement : Debian 10 Buster sur un MacBook Pro 6,4 (mi-2010), 15'', mod. A1286 (ah mais...) et une Debian 9 sur une eMachines (Intel Atom N455, 1Go de Ram, et 250 Go. LXDE minimale).

Hors ligne

#4 22-04-2022 19:05:13

VBrice
Membre
(G)UI : mate
Inscription : 04-10-2021

Re : Clavier Mac non reconnu

Bonjour,

Apparemment certain on trouver une solution ici https://forum.ubuntu-fr.org/viewtopic.php?id=315444 mais je ne sais pas si cella s’applique à ton cas, et je n'ai pas MAC pour tester.scratchhead.gif

Ceci dit, voici comment je ferais;idea.gif

Pour modifier une touche de mon clavier j'utilise deux paquets: xmodmap  ainsi que xcape qui est dans le dépôt Debian.
Il s’utilise ainsi:

xmodmap -e "keycode 24 = b"

ici je remplace ma lettre "a" (keycode24) par le lettre "b"

Pour trouver le keycodes de 2 touches que tu souhaite échanger il faut utiliser le mode debug de xcape: dans le terminal: xcape -d
Tu appuie sur tes 2 touches et le terminal te renvoie les deux keycode de tes touches.
Quand cela est fait: Ctrl+C pour quitter xcape .

Par exemple, chez moi la touche "<>" avec le modèle de clavier PC 105 donne le code 10.

Une fois le keycode trouvé on peut utiliser xmodmap pour changer les touches:
Dans un premier temps, il faut utiliser la commande

xmodmap -pke

pour avoir la liste de keycodes.


Puisque chez moi xcape me renvoie le code 10, je recherche dans la liste de xmodmap  les éléments qui appartiennent au keycode 10.
Ici le keycode10 m'indique "ampersand 1 ampersand 1 dead_acute periodcentered dead_acute"

Donc je devrai attribuer "ampersand 1 ampersand 1 dead_acute periodcentered dead_acute" à la 2eme touche, si le keycode de ma seconde touche est 20 on aura donc:

xmodmap -e "keycode 20= ampersand 1 ampersand 1 dead_acute periodcentered dead_acute"



Pour finir il suffira de lancer la commande au démarrage ou de faire un script bash, mais on verra après.




Donc, chez toi, avec xcape -d :
     quel est le keycode de ta 1ere touche "#@"?
     quel est le keycode de ta 2eme touche "<>"?
Et avec avec xmodmap -pke:
    quels éléments est associer au keycode de ta 1ere touche "#@"?
    quels éléments est associer au keycode de ta 2eme touche "<>"?

on aura donc2 commande à faire:

xmodmap -e "keycode 1ereTouche  = éléments2emeTouche"
xmodmap -e "keycode 2emeTouche = éléments1ereTouche"

En attente de ton retour. smile

Dernière modification par VBrice (22-04-2022 20:27:37)

Hors ligne

#5 22-04-2022 21:25:24

Tawal
Membre
Distrib. : Debian Stable à jour
Noyau : amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : Clavier Mac non reconnu

Merci pour ce petit cours smile

Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

#6 23-04-2022 16:26:56

fred02840
Membre
Lieu : Aisne
Distrib. : Debian GNU/Linux bookworm/sid
Noyau : 5.16.0-5-amd64
(G)UI : Gnome 42.beta
Inscription : 07-02-2018

Re : Clavier Mac non reconnu

Merci beaucoup @VBrice : voilà qui est très précis. Je vais m'appliquer à mettre tes conseils en œuvre : merci encore.
Il est tout de même étonnant que cette inversion se soit faite : j'utilise ce clavier Apple sur un Lenovo depuis bien des années, et toutes les touches étaient parfaitement reconnues.

Lenovo E540 (Intel Core i3) : Debian GNU/Linux bookworm/sid. Gnome 40.4

Très accessoirement : Debian 10 Buster sur un MacBook Pro 6,4 (mi-2010), 15'', mod. A1286 (ah mais...) et une Debian 9 sur une eMachines (Intel Atom N455, 1Go de Ram, et 250 Go. LXDE minimale).

Hors ligne

#7 23-04-2022 16:58:53

VBrice
Membre
(G)UI : mate
Inscription : 04-10-2021

Re : Clavier Mac non reconnu

Les modifications que tu appliquera avec les 2 commandes ne s’appliqueront plus au prochain démarrage.

Si les manipulations fonctionnent tu auras 3 choix pour les lancer au démarrage de ta session:

- Si tu est sous l'environnement de bureau MATE, il faudra allez dans le menu System,Préférences,information personnelles, Applications au démarrage et la tu pourra ajouter des commandes au demarage de ta session. Avoir sous les autres environnement de bureau comme gnome ou KDE, j'imagine que cela doit aussi être possible.

- Faire un script bash avec les commandes à lancer et l’exécuter au démarrage.

- Créer un fichier dans le home de l'utilisateur et utiliser la commande

xmodmap ~/.xmodmap

(si le fichier s'appelle .xmodmap, qui comportera uniquement les keycode et leurs événements).

Hors ligne

#8 24-04-2022 22:28:42

èfpé
Membre
Inscription : 10-07-2016

Re : Clavier Mac non reconnu

Bonsoir,

fred02840 a écrit :

Bref, j'ai récupéré mon clavier, sauf deux touches qui sont inversées : celle qui est en haut, à gauche (qui donne maintenant < et >) et celle qui est à la droite de la touche majuscule (maintenant : # et @).


@falke a remonté un problème similaire (qui ne semble pas correspondre à une version d'xkb-data).

Hors ligne

#9 30-04-2022 11:54:39

pascal63
Membre
Inscription : 30-04-2022

Re : Clavier Mac non reconnu

Bonjour,

Possédant aussi un clavier mac alu (que j'adore, m'en séparerai pour rien au mode) provenant de mon ancien Imac pour l'utiliser sur mon pc actuel sous debian11. J'ai luter un bon moment avant d'avoir un clavier dont toutes les touches soient reconnue aussi bien sous X que sur console.

Pour Xwindows :

Éditer le fichier

sudo nano /etc/modprobe.d/hid_apple.conf

  pour ajouter la ligne suivante :

options hid_apple iso_layout=0



Puis exécuter la commande suivante pour rendre la config permanente :

sudo update-initramfs -u -k all




Pour le mode Console (sans mode graphique donc)

Modifier le fichier : 

sudo nano  /etc/default/keyboard



XKBMODEL="pc105"
XKBLAYOUT="fr"
XKBVARIANT="mac"
XKBOPTIONS="lv3:switch,compose:lwin"
BACKSPACE="guess"



Redémarrer le PC et normalement le clavier et parfaitement reconnue comme sur un mac (touches @#, ><, |, et autres)

Hors ligne

Pied de page des forums