Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-02-2022 10:09:01

Pascalito
Membre
Inscription : 25-02-2022

[résolu] Usb wifi fonctionnelle en live iso mais plus après l'installe

Salut,

Mon problème est dans le titre. Ma clé usb wifi est fonctionnelle en live iso (unofficial) mais plus après l'installe ?
La clé est une Tp-link WN722N v1 donc Atheos.
Je n'ai pas de connexion internet et pour installer les drivers (firmware-atheros_20210315-3_all.deb) il faut des dépendances...

merci pour votre aide.

p.

Dernière modification par Pascalito (26-02-2022 21:47:10)

Hors ligne

#2 26-02-2022 12:08:49

raleur
Membre
Inscription : 03-10-2014

Re : [résolu] Usb wifi fonctionnelle en live iso mais plus après l'installe

Le paquet firmware-atheros ne contient pas de pilote mais des firmwares, et je ne lui vois aucune dépendance obligatoire.
Informations supplémentaires bienvenues.
Brancher la clé USB wifi.
Récupérer les derniers messages du  noyau avec

dmesg | tail -n 40


Il vaut mieux montrer que raconter.

Hors ligne

#3 26-02-2022 13:34:42

èfpé
Membre
Inscription : 10-07-2016

Re : [résolu] Usb wifi fonctionnelle en live iso mais plus après l'installe

Salut et bienvenue Pascalito,

Pascalito a écrit :

[...] (firmware-atheros_20210315-3_all.deb) [...]


Le paquet firmware-ath9k-htc fournit un firmware libre fonctionnel testé avec un TL-WN722N v1.10.

Dernière modification par èfpé (26-02-2022 18:34:42)

Hors ligne

#4 26-02-2022 15:43:09

Pascalito
Membre
Inscription : 25-02-2022

Re : [résolu] Usb wifi fonctionnelle en live iso mais plus après l'installe

raleur a écrit :

Le paquet firmware-atheros ne contient pas de pilote mais des firmwares...



Oui, oups...  merci pour ta réponse. Installation de Debian 11 toute fraîche de ce matin.

Voici ce qui sort :

[    6.438502] cfg80211: Loaded X.509 cert 'romain.perier@gmail.com: 3abbc6ec146e09d1b6016ab9d6cf71dd233f0328'
[    6.438775] cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
[    6.441446] platform regulatory.0: firmware: direct-loading firmware regulatory.db
[    6.442040] platform regulatory.0: firmware: direct-loading firmware regulatory.db.p7s
[    6.680230] usb 2-1.2: ath9k_htc: Firmware ath9k_htc/htc_9271-1.4.0.fw requested
[    6.680262] usbcore: registered new interface driver ath9k_htc
[    6.680469] usb 2-1.2: firmware: failed to load ath9k_htc/htc_9271-1.4.0.fw (-2)
[    6.680472] firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
[    6.680475] usb 2-1.2: Direct firmware load for ath9k_htc/htc_9271-1.4.0.fw failed with error -2
[    6.680479] usb 2-1.2: ath9k_htc: Firmware htc_9271.fw requested
[    6.680492] usb 2-1.2: firmware: failed to load htc_9271.fw (-2)
[    6.680495] usb 2-1.2: Direct firmware load for htc_9271.fw failed with error -2
[    6.680497] usb 2-1.2: no suitable firmware found!
[    6.680615] usb 2-1.2: ath9k_htc: USB layer deinitialized
[    6.711146] kvm: VM_EXIT_LOAD_IA32_PERF_GLOBAL_CTRL does not work properly. Using workaround
[    6.792644] snd_hda_codec_via hdaudioC0D0: autoconfig for VT2020: line_outs=4 (0x24/0x25/0x26/0x27/0x0) type:line
[    6.792648] snd_hda_codec_via hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    6.792650] snd_hda_codec_via hdaudioC0D0:    hp_outs=1 (0x28/0x0/0x0/0x0/0x0)
[    6.792652] snd_hda_codec_via hdaudioC0D0:    mono: mono_out=0x0
[    6.792653] snd_hda_codec_via hdaudioC0D0:    dig-out=0x2d/0x2e
[    6.792655] snd_hda_codec_via hdaudioC0D0:    inputs:
[    6.792657] snd_hda_codec_via hdaudioC0D0:      Front Mic=0x29
[    6.792659] snd_hda_codec_via hdaudioC0D0:      Rear Mic=0x2b
[    6.792661] snd_hda_codec_via hdaudioC0D0:      Line=0x2a
[    6.792662] snd_hda_codec_via hdaudioC0D0:      CD=0x2c
[    6.806342] input: HDA Intel MID Front Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input14
[    6.806416] input: HDA Intel MID Rear Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input15
[    6.806480] input: HDA Intel MID Line as /devices/pci0000:00/0000:00:1b.0/sound/card0/input16
[    6.806547] input: HDA Intel MID Line Out Front as /devices/pci0000:00/0000:00:1b.0/sound/card0/input17
[    6.806628] input: HDA Intel MID Line Out Surround as /devices/pci0000:00/0000:00:1b.0/sound/card0/input18
[    6.806696] input: HDA Intel MID Line Out CLFE as /devices/pci0000:00/0000:00:1b.0/sound/card0/input19
[    6.806763] input: HDA Intel MID Line Out Side as /devices/pci0000:00/0000:00:1b.0/sound/card0/input20
[    6.806837] input: HDA Intel MID Front Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input21
[    7.477159] r8169 0000:02:00.0: firmware: failed to load rtl_nic/rtl8168d-2.fw (-2)
[    7.477164] r8169 0000:02:00.0: Direct firmware load for rtl_nic/rtl8168d-2.fw failed with error -2
[    7.477167] r8169 0000:02:00.0: Unable to load firmware rtl_nic/rtl8168d-2.fw (-2)
[    7.478035] RTL8211B Gigabit Ethernet r8169-0-200:00: attached PHY driver [RTL8211B Gigabit Ethernet] (mii_bus:phy_addr=r8169-0-200:00, irq=IGNORE)
[    7.549511] r8169 0000:02:00.0 enp2s0: Link is Down
[    9.185382] r8169 0000:02:00.0 enp2s0: Link is Up - 100Mbps/Full - flow control rx/tx
[    9.185396] IPv6: ADDRCONF(NETDEV_CHANGE): enp2s0: link becomes ready
 



ps. j'ai finalement bidouillé un câble réseau de 15m provisoirement, donc j'ai une connexion

Dernière modification par Pascalito (26-02-2022 18:01:44)

Hors ligne

#5 26-02-2022 15:47:54

Pascalito
Membre
Inscription : 25-02-2022

Re : [résolu] Usb wifi fonctionnelle en live iso mais plus après l'installe

èfpé a écrit :

Le paquet firmware-ath9k-htc fournit un firmware libre fonctionnel testé avec un TL-WN722N v1.10.



Ben en fait j'ai pas trop envie de modifier le firmware de ma clé qui fonctionne parfaitement avec l'iso live Debian, OpenSuse Leap / Tumbelweed  et windows..

Hors ligne

#6 26-02-2022 18:15:02

raleur
Membre
Inscription : 03-10-2014

Re : [résolu] Usb wifi fonctionnelle en live iso mais plus après l'installe

Pascalito a écrit :

[    6.680469] usb 2-1.2: firmware: failed to load ath9k_htc/htc_9271-1.4.0.fw (-2)


Il manque un firmware fourni par le paquet firmware-atheros.

Pascalito a écrit :

j'ai pas trop envie de modifier le firmware de ma clé


Le firmware est volatil et doit être chargé par le pilote à chaque démarrage.


Il vaut mieux montrer que raconter.

Hors ligne

#7 26-02-2022 18:39:28

Pascalito
Membre
Inscription : 25-02-2022

Re : [résolu] Usb wifi fonctionnelle en live iso mais plus après l'installe

èfpé a écrit :

Salut et bienvenue Pascalito,



Bon finalement j'ai fait comme tu as dis èfpé et ça fonctionne !

Merci les gars pour votre aide

Hors ligne

Pied de page des forums