Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-04-2022 20:24:43

Skippythekangoo
Membre
Lieu : >> /dev/null
Distrib. : Lenny
Noyau : 2.6.27.10-grsec-xxxx-grs-ipv4-32
(G)UI : CLI
Inscription : 14-11-2007
Site Web

[RESOLU] libc6:i386 et Sid/Eperimental

Salutations à toutes et à tous.

Je n'arrive pas à installer libc6:i386, requie pour Steam et autre jeux.

 $ sudo apt-get install libc6:i386
[sudo] Mot de passe de skippy :
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'
état... Fait      
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'
ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'
information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 apt : Dépend: adduser mais ne sera pas installé
       Dépend: gpgv ou
                gpgv2 mais ne sera pas installé ou
                gpgv1
       Dépend: libapt-pkg6.0 (>= 2.4.4) mais ne sera pas installé
       Dépend: libc6 (>= 2.33) mais il n'est pas installable
       Dépend: libgnutls30 (>= 3.7.0) mais ne sera pas installé
       Dépend: libseccomp2 (>= 2.4.2) mais ne sera pas installé
       Dépend: libstdc++6 (>= 11) mais ne sera pas installé
       Dépend: libsystemd0
 base-files : Pré-Dépend: awk
 base-passwd : Dépend: libc6 (>= 2.8) mais il n'
est pas installable
               Dépend: libdebconfclient0 (>= 0.145) mais ne sera pas installé
 bash : Pré-Dépend: libc6 (>= 2.33) mais il n'est pas installable
        Pré-Dépend: libtinfo6 (>= 6) mais ne sera pas installé
 bsdutils : Pré-Dépend: libc6 (>= 2.33) mais il n'
est pas installable
            Pré-Dépend: libsystemd0
 coreutils : Pré-Dépend: libacl1 (>= 2.2.23) mais ne sera pas installé
             Pré-Dépend: libattr1 (>= 1:2.4.44) mais ne sera pas installé
             Pré-Dépend: libc6 (>= 2.32) mais il n'est pas installable
             Pré-Dépend: libgmp10 (>= 2:6.2.1+dfsg) mais ne sera pas installé
             Pré-Dépend: libselinux1 (>= 3.1~) mais ne sera pas installé
 dash : Pré-Dépend: libc6 (>= 2.33) mais il n'
est pas installable
 debianutils : Pré-Dépend: libc6 (>= 2.33) mais il n'est pas installable
 dictionaries-common : Dépend: libtext-iconv-perl mais ne sera pas installé
 diffutils : Pré-Dépend: libc6 (>= 2.17) mais il n'
est pas installable
 dpkg : Pré-Dépend: libbz2-1.0 mais ne sera pas installé
        Pré-Dépend: libc6 (>= 2.33) mais il n'est pas installable
        Pré-Dépend: liblzma5 (>= 5.2.2) mais ne sera pas installé
        Pré-Dépend: libselinux1 (>= 3.1~) mais ne sera pas installé
        Pré-Dépend: zlib1g (>= 1:1.1.4) mais ne sera pas installé
 e2fsprogs : Pré-Dépend: libblkid1 (>= 2.36) mais ne sera pas installé
             Pré-Dépend: libc6 (>= 2.33) mais il n'
est pas installable
             Pré-Dépend: libcom-err2 (>= 1.43.9) mais ne sera pas installé
             Pré-Dépend: libext2fs2 (= 1.46.5-2) mais ne sera pas installé
             Pré-Dépend: libss2 (>= 1.38) mais ne sera pas installé
             Pré-Dépend: libuuid1 (>= 2.16) mais ne sera pas installé
             Dépend: logsave
 findutils : Pré-Dépend: libc6 (>= 2.33) mais il n'est pas installable
             Pré-Dépend: libselinux1 (>= 3.1~) mais ne sera pas installé
 grep : Pré-Dépend: libc6 (>= 2.26) mais il n'
est pas installable
        Pré-Dépend: libpcre3 mais ne sera pas installé
 gzip : Pré-Dépend: libc6 (>= 2.17) mais il n'est pas installable
 hostname : Pré-Dépend: libc6 (>= 2.4) mais il n'
est pas installable
 init : Pré-Dépend: systemd-sysv ou
                      sysvinit-core mais il n'est pas installable
 libc-bin : Dépend: libc6 (> 2.34) mais il n'
est pas installable
            Dépend: libc6 (< 2.35) mais il n'est pas installable
 libcrypt1 : Dépend: libc6 (>= 2.25) mais il n'
est pas installable
 libgcc-s1 : Dépend: libc6 (>= 2.14) mais il n'est pas installable
 login : Pré-Dépend: libaudit1 (>= 1:2.2.1) mais ne sera pas installé
         Pré-Dépend: libc6 (>= 2.33) mais il n'
est pas installable
         Pré-Dépend: libpam0g (>= 0.99.7.1) mais ne sera pas installé
         Pré-Dépend: libpam-runtime mais ne sera pas installé
         Pré-Dépend: libpam-modules mais ne sera pas installé
 ncurses-bin : Pré-Dépend: libc6 (>= 2.33) mais il n'est pas installable
               Pré-Dépend: libtinfo6 (>= 6.3) mais ne sera pas installé
 perl-base : Pré-Dépend: libc6 (>= 2.33) mais il n'
est pas installable
 sed : Pré-Dépend: libacl1 (>= 2.2.23) mais ne sera pas installé
       Pré-Dépend: libc6 (>= 2.14) mais il n'est pas installable
       Pré-Dépend: libselinux1 (>= 3.1~) mais ne sera pas installé
 sysvinit-utils : Dépend: libc6 (>= 2.33) mais il n'
est pas installable
 tar : Pré-Dépend: libacl1 (>= 2.2.23) mais ne sera pas installé
       Pré-Dépend: libc6 (>= 2.28) mais il n'est pas installable
       Pré-Dépend: libselinux1 (>= 3.1~) mais ne sera pas installé
 util-linux : Pré-Dépend: libaudit1 (>= 1:2.2.1) mais ne sera pas installé
              Pré-Dépend: libblkid1 (>= 2.37.2) mais ne sera pas installé
              Pré-Dépend: libc6 (>= 2.33) mais il n'
est pas installable
              Pré-Dépend: libcap-ng0 (>= 0.7.9) mais ne sera pas installé
              Pré-Dépend: libmount1 (>= 2.37.2) mais ne sera pas installé
              Pré-Dépend: libpam0g (>= 0.99.7.1) mais ne sera pas installé
              Pré-Dépend: libselinux1 (>= 3.1~) mais ne sera pas installé
              Pré-Dépend: libsmartcols1 (>= 2.34) mais ne sera pas installé
              Pré-Dépend: libsystemd0
              Pré-Dépend: libtinfo6 (>= 6) mais ne sera pas installé
              Pré-Dépend: libudev1 (>= 183) mais ne sera pas installé
              Pré-Dépend: libuuid1 (>= 2.16) mais ne sera pas installé
              Pré-Dépend: zlib1g (>= 1:1.1.4) mais ne sera pas installé
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.



Et mon sources.list

 $ cat /etc/apt/sources.list.d/deb_debian-testing-sid_non-libre.list
## testing
#deb http://deb.debian.org/debian/ testing main contrib non-free
## dépôt sécurity testing
#deb http://deb.debian.org/debian-security/ testing-security/updates main contrib non-free
## unstable
#deb http://deb.debian.org/debian/ unstable main contrib non-free
## experimental
#deb http://deb.debian.org/debian/ experimental main contrib non-free

deb [arch=amd64,i386] http://deb.debian.org/debian/ sid main non-free contrib



Merci d'avance...

Dernière modification par Skippythekangoo (11-04-2022 17:27:28)


Quiconque à cette louange d'être homme sans boire de vin, si il en buvait serait un ange.

Hors ligne

#2 10-04-2022 21:12:52

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : [RESOLU] libc6:i386 et Sid/Eperimental

Bonjour,
c"es quoi ton O.S ? une debian sid/expérimentale ?
.... au vu des ceci sera pas installé paske manque cela,
  ça laisse pantois ...

Dernière modification par ubub (10-04-2022 21:19:01)

Hors ligne

#3 10-04-2022 22:28:50

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.15 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : [RESOLU] libc6:i386 et Sid/Eperimental

Tu as apparemment un conflit de version entre la version du build amd64 de libc6 actuellement installée et celle du build i386 que tu cherches à installer. Ça peut se vérifier avec :

apt policy libc6:{amd64,i386}



Avant de pouvoir installer libc6:i386, il va falloir que tu mettes à jour libc6:amd64 et probablement le reste de ton système au passage.


Jouer sous Debian ? Facile !

Hors ligne

#4 10-04-2022 23:06:22

Debian Alain
Membre
Lieu : Bretagne
Distrib. : unstable sid / bullseye (stable)
Noyau : Linux sid 5.18.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [RESOLU] libc6:i386 et Sid/Eperimental

bonsoir Skippythekangoo  smile  smile  smile

curiosité :

tu as quoi comme distribution ?

lsb_release -a


quoi comme noyau ?

uname -a


quoi comme architecture ?

dpkg --print-architecture


dpkg --print-foreign-architectures



amicalement .

alain .

coyotus.png

Hors ligne

#5 11-04-2022 08:23:57

Skippythekangoo
Membre
Lieu : >> /dev/null
Distrib. : Lenny
Noyau : 2.6.27.10-grsec-xxxx-grs-ipv4-32
(G)UI : CLI
Inscription : 14-11-2007
Site Web

Re : [RESOLU] libc6:i386 et Sid/Eperimental

Merci de vous intéresser.

Je paste les infos demandées.

$ apt policy libc6:{amd64,i386}
libc6:
  Installé : 2.34-0experimental3
  Candidat : 2.34-0experimental3
 Table de version :
 *** 2.34-0experimental3 100
          1 http://cdn.debian.net/debian experimental/main amd64 Packages
        100 /var/lib/dpkg/status
     2.33-7 100
        100 http://deb.debian.org/debian sid/main amd64 Packages
libc6:i386:
  Installé : (aucun)
  Candidat : 2.33-7
 Table de version :
     2.34-0experimental3 1
          1 http://cdn.debian.net/debian experimental/main i386 Packages
     2.33-7 100
        100 http://deb.debian.org/debian sid/main i386 Packages



$ lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:  Debian GNU/Linux bookworm/sid
Release:  unstable
Codename: sid



 $ uname -a
Linux nakedeb 5.16.0-5-amd64 #1 SMP PREEMPT Debian 5.16.14-1 (2022-03-15) x86_64 GNU/Linux



$ dpkg --print-architecture
amd64



$ dpkg --print-foreign-architectures
i386


Quiconque à cette louange d'être homme sans boire de vin, si il en buvait serait un ange.

Hors ligne

#6 11-04-2022 08:26:44

Skippythekangoo
Membre
Lieu : >> /dev/null
Distrib. : Lenny
Noyau : 2.6.27.10-grsec-xxxx-grs-ipv4-32
(G)UI : CLI
Inscription : 14-11-2007
Site Web

Re : [RESOLU] libc6:i386 et Sid/Eperimental

vv222 a écrit :

Tu as apparemment un conflit de version entre la version du build amd64 de libc6 actuellement installée et celle du build i386 que tu cherches à installer. Ça peut se vérifier avec :

apt policy libc6:{amd64,i386}



Avant de pouvoir installer libc6:i386, il va falloir que tu mettes à jour libc6:amd64 et probablement le reste de ton système au passage.



Mon système est régulièrement à jour, une fois par semaine plus ou moins.


Quiconque à cette louange d'être homme sans boire de vin, si il en buvait serait un ange.

Hors ligne

#7 11-04-2022 11:29:07

Debian Alain
Membre
Lieu : Bretagne
Distrib. : unstable sid / bullseye (stable)
Noyau : Linux sid 5.18.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [RESOLU] libc6:i386 et Sid/Eperimental

chez moi :

apt policy libc6:{amd64,i386}


libc6:
  Installé : 2.33-7
  Candidat : 2.33-7
 Table de version :
     2.34-0experimental3 1
          1 http://deb.debian.org/debian experimental/main amd64 Packages
 *** 2.33-7 500
        100 http://deb.debian.org/debian testing/main amd64 Packages
        500 http://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
     2.31-13+deb11u3 100
        100 http://deb.debian.org/debian stable/main amd64 Packages
libc6:i386:
  Installé : 2.33-7
  Candidat : 2.33-7
 Table de version :
     2.34-0experimental3 1
          1 http://deb.debian.org/debian experimental/main i386 Packages
 *** 2.33-7 500
        100 http://deb.debian.org/debian testing/main i386 Packages
        500 http://deb.debian.org/debian unstable/main i386 Packages
        100 /var/lib/dpkg/status
     2.31-13+deb11u3 100
        100 http://deb.debian.org/debian stable/main i386 Packages
 



je ne sais pas si tu as bien fait de passer ton systeme en expérimental .

que donne ton sources.list  ?
avant tout :

cat /etc/apt/sources.list


et qu'as tu comme pinning : ?

apt policy



je ne touche jamais à la libc et je ne conseille jamais de le faire .
le paquet est beaucoup trop sensible .

je préfères que tu demandes à un très grand connaisseur .
dans le doute , tu  peux peut être essayer ceci :
mais saches  que je soumets ma démarche à plus calé que moi .
(downgrade de la libc )

apt install --reinstall libc6=2.33-7


(mise à jour  de la liste des paquets smile )

apt update


(mise à jour des paquets smile  )

apt upgrade


(verification de la libc smile  )

apt policy libc6:{amd64,i386}



regarde aussi le wiki sur le multiarch  :
https://wiki.debian.org/fr/Multiarch/HOWTO

amicalement ,

alain .

coyotus.png

Dernière modification par Debian Alain (11-04-2022 12:02:43)

Hors ligne

#8 11-04-2022 11:55:02

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.15 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : [RESOLU] libc6:i386 et Sid/Eperimental

Skippythekangoo a écrit :

$ apt policy libc6:{amd64,i386}
libc6:
  Installé : 2.34-0experimental3
  Candidat : 2.34-0experimental3
 Table de version :
 *** 2.34-0experimental3 100
          1 http://cdn.debian.net/debian experimental/main amd64 Packages
        100 /var/lib/dpkg/status
     2.33-7 100
        100 http://deb.debian.org/debian sid/main amd64 Packages
libc6:i386:
  Installé : (aucun)
  Candidat : 2.33-7
 Table de version :
     2.34-0experimental3 1
          1 http://cdn.debian.net/debian experimental/main i386 Packages
     2.33-7 100
        100 http://deb.debian.org/debian sid/main i386 Packages



Ah, je ne m’attendais pas à ce que tu utilises déjà la version 2.34 de libc6:amd64.

Dans ce cas tu peux installer la version i386 simplement avec :

apt install libc6:i386/experimental


Jouer sous Debian ? Facile !

Hors ligne

#9 11-04-2022 12:02:01

Debian Alain
Membre
Lieu : Bretagne
Distrib. : unstable sid / bullseye (stable)
Noyau : Linux sid 5.18.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [RESOLU] libc6:i386 et Sid/Eperimental

question , Skippythekangoo :

pourquoi as tu passé ta libc en expérimental ?

tu as eu du souci ?
lequel ?

amicalement ,

alain.

coyotus.png

Hors ligne

#10 11-04-2022 16:56:01

Skippythekangoo
Membre
Lieu : >> /dev/null
Distrib. : Lenny
Noyau : 2.6.27.10-grsec-xxxx-grs-ipv4-32
(G)UI : CLI
Inscription : 14-11-2007
Site Web

Re : [RESOLU] libc6:i386 et Sid/Eperimental

Je pense avoir du faire une erreur dans mon sources.list.

J'ai aussi mélangé dans ma tête Sid et Experimental, je pensais que c'était les même version, et apparement, non...

JE n'avais jamais franchis le pas de passé au dessus de Stable jusquà présent.

Quiconque à cette louange d'être homme sans boire de vin, si il en buvait serait un ange.

Hors ligne

#11 11-04-2022 17:27:58

Skippythekangoo
Membre
Lieu : >> /dev/null
Distrib. : Lenny
Noyau : 2.6.27.10-grsec-xxxx-grs-ipv4-32
(G)UI : CLI
Inscription : 14-11-2007
Site Web

Re : [RESOLU] libc6:i386 et Sid/Eperimental

Merci à tous.

Je passe le fil en résolu...

Quiconque à cette louange d'être homme sans boire de vin, si il en buvait serait un ange.

Hors ligne

#12 11-04-2022 17:28:41

Skippythekangoo
Membre
Lieu : >> /dev/null
Distrib. : Lenny
Noyau : 2.6.27.10-grsec-xxxx-grs-ipv4-32
(G)UI : CLI
Inscription : 14-11-2007
Site Web

Re : [RESOLU] libc6:i386 et Sid/Eperimental

vv222 a écrit :

Skippythekangoo a écrit :

$ apt policy libc6:{amd64,i386}
libc6:
  Installé : 2.34-0experimental3
  Candidat : 2.34-0experimental3
 Table de version :
 *** 2.34-0experimental3 100
          1 http://cdn.debian.net/debian experimental/main amd64 Packages
        100 /var/lib/dpkg/status
     2.33-7 100
        100 http://deb.debian.org/debian sid/main amd64 Packages
libc6:i386:
  Installé : (aucun)
  Candidat : 2.33-7
 Table de version :
     2.34-0experimental3 1
          1 http://cdn.debian.net/debian experimental/main i386 Packages
     2.33-7 100
        100 http://deb.debian.org/debian sid/main i386 Packages



Ah, je ne m’attendais pas à ce que tu utilises déjà la version 2.34 de libc6:amd64.

Dans ce cas tu peux installer la version i386 simplement avec :

apt install libc6:i386/experimental



Parfit, c'est bien ça.

Il me faudra y penser les autre fois.

merci beaucoup.


Quiconque à cette louange d'être homme sans boire de vin, si il en buvait serait un ange.

Hors ligne

Pied de page des forums