Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-10-2022 20:00:27

Debian Alain
Membre
Lieu : Bretagne
Distrib. : sid (unstable) / bullseye (stable)
Noyau : Linux sid 6.0.0-4-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

upgrade paquets surprenant

sudo apt update


[sudo] Mot de passe de alain :
Atteint :1 http://deb.debian.org/debian bookworm InRelease
Atteint :2 http://deb.debian.org/debian testing InRelease
Atteint :3 http://deb.debian.org/debian-security testing-security/updates InRelease
Atteint :4 http://deb.debian.org/debian unstable InRelease
Atteint :5 http://deb.debian.org/debian experimental InRelease
Atteint :6 http://deb.debian.org/debian stable InRelease
Atteint :7 http://deb.debian.org/debian stable-updates InRelease
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
12 paquets peuvent être mis à jour. Exécutez « apt list --upgradable » pour les voir.
 



sudo apt upgrade


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Calcul de la mise à jour... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  gir1.2-champlain-0.12 gir1.2-geocodeglib-1.0 gir1.2-gtkchamplain-0.12
  gir1.2-mutter-10 gir1.2-rest-0.7 gnome-applets-data gnome-orca
  gnome-panel-data gnome-screenshot isa-support libabsl20210324
  libappstream-glib8 libatk1.0-data libchamplain-0.12-0
  libchamplain-gtk-0.12-0 libebackend-1.2-10 libebook-1.2-20
  libebook-contacts-1.2-3 libedata-book-1.2-26 libedata-cal-2.0-1
  libedataserverui-1.2-3 libfreerdp-client2-2 libgeocode-glib0 libgit2-1.3
  libgnome-todo libhttp-server-simple-perl libilmbase25 libmalcontent-ui-0-0
  libmozjs-91-0 libmutter-10-0 libnsl2:i386 libopenexr25 libopenh264-6
  libpcre16-3 libpcre3:i386 libpcre3-dev libpcre32-3 libplacebo192
  libpoppler118 libqpdf28 librest-0.7-0 libtirpc3:i386 libwrap0:i386
  linux-kbuild-5.17 linux-kbuild-5.18 node-exit-hook sse3-support
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets suivants ont été conservés :
  gnome gnome-control-center gnome-control-center-data gnome-core
  gnome-settings-daemon gnome-settings-daemon-common gnome-todo libsdl2-2.0-0
  mangohud nautilus nautilus-data onedrive
0 mis à jour, 0 nouvellement installés, 0 à enlever et 12 non mis à jour.
 



sudo apt -s autoremove


[sudo] Mot de passe de alain :
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Les paquets suivants seront ENLEVÉS :
  gir1.2-champlain-0.12 gir1.2-geocodeglib-1.0 gir1.2-gtkchamplain-0.12
  gir1.2-mutter-10 gir1.2-rest-0.7 gnome-applets-data gnome-orca
  gnome-panel-data gnome-screenshot isa-support libabsl20210324
  libappstream-glib8 libatk1.0-data libchamplain-0.12-0
  libchamplain-gtk-0.12-0 libebackend-1.2-10 libebook-1.2-20
  libebook-contacts-1.2-3 libedata-book-1.2-26 libedata-cal-2.0-1
  libedataserverui-1.2-3 libfreerdp-client2-2 libgeocode-glib0 libgit2-1.3
  libgnome-todo libhttp-server-simple-perl libilmbase25 libmalcontent-ui-0-0
  libmozjs-91-0 libmutter-10-0 libnsl2:i386 libopenexr25 libopenh264-6
  libpcre16-3 libpcre3:i386 libpcre3-dev libpcre32-3 libplacebo192
  libpoppler118 libqpdf28 librest-0.7-0 libtirpc3:i386 libwrap0:i386
  linux-kbuild-5.17 linux-kbuild-5.18 node-exit-hook sse3-support
0 mis à jour, 0 nouvellement installés, 47 à enlever et 12 non mis à jour.
Remv gir1.2-gtkchamplain-0.12 [0.12.20-1+b1]
Remv gir1.2-champlain-0.12 [0.12.20-1+b1]
Remv gir1.2-geocodeglib-1.0 [3.26.2-2]
Remv gir1.2-mutter-10 [42.4-2]
Remv gir1.2-rest-0.7 [0.8.1-1.1]
Remv gnome-applets-data [3.44.0-1]
Remv gnome-orca [42.0-1]
Remv gnome-panel-data [3.46.0-1]
Remv gnome-screenshot [41.0-2]
Remv sse3-support [15]
Remv isa-support [15]
Remv libabsl20210324 [0~20210324.2-4]
Remv libmalcontent-ui-0-0 [0.10.5-1]
Remv libappstream-glib8 [0.8.1-1]
Remv libatk1.0-data [2.38.0-1]
Remv libchamplain-gtk-0.12-0 [0.12.20-1+b1]
Remv libchamplain-0.12-0 [0.12.20-1+b1]
Remv libebook-1.2-20 [3.44.4-1]
Remv libedata-book-1.2-26 [3.44.4-1]
Remv libedata-cal-2.0-1 [3.44.4-1]
Remv libebackend-1.2-10 [3.44.4-1]
Remv libebook-contacts-1.2-3 [3.44.4-1]
Remv libedataserverui-1.2-3 [3.44.4-1]
Remv libfreerdp-client2-2 [2.8.0+dfsg1-1]
Remv libgeocode-glib0 [3.26.2-2]
Remv libgit2-1.3 [1.3.0+dfsg.1-3]
Remv libgnome-todo [3.28.1-6+b1]
Remv libhttp-server-simple-perl [0.52-2]
Remv libopenexr25 [2.5.7-1]
Remv libilmbase25 [2.5.7-2+b1]
Remv libmozjs-91-0 [91.13.0-1]
Remv libmutter-10-0 [42.4-2]
Remv libwrap0:i386 [7.6.q-31]
Remv libnsl2:i386 [1.3.0-2]
Remv libopenh264-6 [2.3.0+dfsg-2]
Remv libpcre3-dev [2:8.39-14]
Remv libpcre16-3 [2:8.39-14]
Remv libpcre3:i386 [2:8.39-14]
Remv libpcre32-3 [2:8.39-14]
Remv libplacebo192 [4.192.1-1]
Remv libpoppler118 [22.02.0-3]
Remv libqpdf28 [10.6.3-1]
Remv librest-0.7-0 [0.8.1-1.1]
Remv libtirpc3:i386 [1.3.3+ds-1]
Remv linux-kbuild-5.17 [5.17.11-1]
Remv linux-kbuild-5.18 [5.18.16-1]
Remv node-exit-hook [3.1.0-2]
 



j'ai fait quelques recherches :
entre des paquets de ubuntu , de stable , le gestionnaire de fenêtres , etc ...
je ne sais que penser .
je ne suis pas très rassuré .
je ne tiens pas à casser encore une fois ma machine à cause d'une m.a.j. stupide .

un (des) conseils ?
je le fais ce "sudo apt autoremove" ?

apt policy


Fichiers du paquet :
 100 /var/lib/dpkg/status
     release a=now
   1 http://deb.debian.org/debian experimental/non-free i386 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=non-free,b=i386
     origin deb.debian.org
   1 http://deb.debian.org/debian experimental/non-free amd64 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=non-free,b=amd64
     origin deb.debian.org
   1 http://deb.debian.org/debian experimental/contrib i386 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=contrib,b=i386
     origin deb.debian.org
   1 http://deb.debian.org/debian experimental/contrib amd64 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=contrib,b=amd64
     origin deb.debian.org
   1 http://deb.debian.org/debian experimental/main i386 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=main,b=i386
     origin deb.debian.org
   1 http://deb.debian.org/debian experimental/main amd64 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=main,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian unstable/non-free i386 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=non-free,b=i386
     origin deb.debian.org
 500 http://deb.debian.org/debian unstable/non-free amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=non-free,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian unstable/contrib i386 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=contrib,b=i386
     origin deb.debian.org
 500 http://deb.debian.org/debian unstable/contrib amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=contrib,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian unstable/main i386 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=main,b=i386
     origin deb.debian.org
 500 http://deb.debian.org/debian unstable/main amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=main,b=amd64
     origin deb.debian.org
 100 http://deb.debian.org/debian testing/non-free i386 Packages
     release o=Debian,a=testing,n=bookworm,l=Debian,c=non-free,b=i386
     origin deb.debian.org
 100 http://deb.debian.org/debian testing/non-free amd64 Packages
     release o=Debian,a=testing,n=bookworm,l=Debian,c=non-free,b=amd64
     origin deb.debian.org
 100 http://deb.debian.org/debian testing/contrib i386 Packages
     release o=Debian,a=testing,n=bookworm,l=Debian,c=contrib,b=i386
     origin deb.debian.org
 100 http://deb.debian.org/debian testing/contrib amd64 Packages
     release o=Debian,a=testing,n=bookworm,l=Debian,c=contrib,b=amd64
     origin deb.debian.org
 100 http://deb.debian.org/debian testing/main i386 Packages
     release o=Debian,a=testing,n=bookworm,l=Debian,c=main,b=i386
     origin deb.debian.org
 100 http://deb.debian.org/debian testing/main amd64 Packages
     release o=Debian,a=testing,n=bookworm,l=Debian,c=main,b=amd64
     origin deb.debian.org
 100 http://deb.debian.org/debian bookworm/non-free i386 Packages
     release o=Debian,a=testing,n=bookworm,l=Debian,c=non-free,b=i386
     origin deb.debian.org
 100 http://deb.debian.org/debian bookworm/non-free amd64 Packages
     release o=Debian,a=testing,n=bookworm,l=Debian,c=non-free,b=amd64
     origin deb.debian.org
 100 http://deb.debian.org/debian bookworm/contrib i386 Packages
     release o=Debian,a=testing,n=bookworm,l=Debian,c=contrib,b=i386
     origin deb.debian.org
 100 http://deb.debian.org/debian bookworm/contrib amd64 Packages
     release o=Debian,a=testing,n=bookworm,l=Debian,c=contrib,b=amd64
     origin deb.debian.org
 100 http://deb.debian.org/debian bookworm/main i386 Packages
     release o=Debian,a=testing,n=bookworm,l=Debian,c=main,b=i386
     origin deb.debian.org
 100 http://deb.debian.org/debian bookworm/main amd64 Packages
     release o=Debian,a=testing,n=bookworm,l=Debian,c=main,b=amd64
     origin deb.debian.org
Paquets épinglés :
 

Dernière modification par Debian Alain (04-10-2022 20:07:10)

Hors ligne

#2 11-10-2022 17:51:48

Debian Alain
Membre
Lieu : Bretagne
Distrib. : sid (unstable) / bullseye (stable)
Noyau : Linux sid 6.0.0-4-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : upgrade paquets surprenant

alain@sid:~$ sudo apt -s full-upgrade


[sudo] Mot de passe de alain :
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Calcul de la mise à jour... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  gir1.2-champlain-0.12 gir1.2-geocodeglib-1.0 gir1.2-gtkchamplain-0.12
  gir1.2-mutter-10 gir1.2-rest-0.7 gnome-applets-data gnome-bluetooth-common
  gnome-orca gnome-panel-data gnome-screenshot isa-support libabsl20210324
  libappstream-glib8 libatk1.0-data libcamel-1.2-63 libchamplain-0.12-0
  libchamplain-gtk-0.12-0 libebackend-1.2-10 libebook-1.2-20
  libebook-contacts-1.2-3 libecal-2.0-1 libedata-book-1.2-26
  libedata-cal-2.0-1 libedataserver-1.2-26 libedataserverui-1.2-3 libfmt8
  libfreerdp-client2-2 libfwupdplugin7 libgeocode-glib0 libgit2-1.3
  libgnome-bluetooth13 libgnome-todo libhttp-server-simple-perl libilmbase25
  libmalcontent-ui-0-0 libmozjs-91-0 libmutter-10-0 libnautilus-extension1a
  libnsl2:i386 libopenexr25 libopenh264-6 libpcre16-3 libpcre3:i386
  libpcre3-dev libpcre32-3 libplacebo192 libpoppler118 libqpdf28 librest-0.7-0
  libtirpc3:i386 libwrap0:i386 linux-kbuild-5.17 linux-kbuild-5.18
  node-exit-hook sse3-support
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  gnome-bluetooth gnome-todo-common libphobos2-ldc-shared99 libspdlog1
  nautilus-extension-brasero pipewire-media-session
Les NOUVEAUX paquets suivants seront installés :
  endeavour endeavour-common gnome-bluetooth-sendto libphobos2-ldc-shared100
  libspdlog1.10 libwireplumber-0.4-0 wireplumber
Les paquets suivants ont été conservés :
  gnome gnome-core libllvm14:i386
Les paquets suivants seront mis à jour :
  gnome-control-center gnome-control-center-data gnome-settings-daemon
  gnome-settings-daemon-common gnome-todo mangohud nautilus nautilus-data
  onedrive
9 mis à jour, 7 nouvellement installés, 6 à enlever et 3 non mis à jour.
Remv gnome-bluetooth [3.34.5-8] [gnome-core:amd64 ]
Inst gnome-bluetooth-sendto (42.4-1 Debian:testing, Debian:unstable [amd64])
Inst gnome-todo [41.0-3] (42.0-4 Debian:testing, Debian:unstable [all]) []
Remv gnome-todo-common [41.0-3] []
Inst endeavour-common (42.0-4 Debian:testing, Debian:unstable [all]) []
Inst endeavour (42.0-4 Debian:testing, Debian:unstable [amd64])
Inst onedrive [2.4.18-0.1] (2.4.21-1 Debian:testing, Debian:unstable [amd64]) []
Remv libphobos2-ldc-shared99 [1:1.29.0-2+b1] []
Inst libphobos2-ldc-shared100 (1:1.30.0-1+b1 Debian:testing, Debian:unstable [amd64])
Inst mangohud [0.6.8-1] (0.6.8-1+b1 Debian:testing, Debian:unstable [amd64]) []
Remv libspdlog1 [1:1.10.0+ds-0.1] []
Inst libspdlog1.10 (1:1.10.0+ds-0.4 Debian:testing, Debian:unstable [amd64])
Remv nautilus-extension-brasero [3.12.3-1]
Inst libwireplumber-0.4-0 (0.4.12-1 Debian:testing, Debian:unstable [amd64])
Remv pipewire-media-session [0.4.1-4] [gnome-remote-desktop:amd64 ]
Inst wireplumber (0.4.12-1 Debian:testing, Debian:unstable [amd64])
Inst gnome-settings-daemon [43.0-1] (43.0-2 Debian:testing, Debian:unstable [amd64]) []
Inst gnome-settings-daemon-common [43.0-1] (43.0-2 Debian:testing, Debian:unstable [all])
Inst gnome-control-center [1:42.3-2+b1] (1:43.0-1 Debian:testing, Debian:unstable [amd64]) []
Inst gnome-control-center-data [1:42.3-2] (1:43.0-1 Debian:testing, Debian:unstable [all])
Inst nautilus [42.2-2] (43.0-1 Debian:testing, Debian:unstable [amd64]) []
Inst nautilus-data [42.2-2] (43.0-1 Debian:testing, Debian:unstable [all])
Conf gnome-bluetooth-sendto (42.4-1 Debian:testing, Debian:unstable [amd64])
Conf gnome-todo (42.0-4 Debian:testing, Debian:unstable [all])
Conf endeavour-common (42.0-4 Debian:testing, Debian:unstable [all])
Conf endeavour (42.0-4 Debian:testing, Debian:unstable [amd64])
Conf onedrive (2.4.21-1 Debian:testing, Debian:unstable [amd64])
Conf libphobos2-ldc-shared100 (1:1.30.0-1+b1 Debian:testing, Debian:unstable [amd64])
Conf mangohud (0.6.8-1+b1 Debian:testing, Debian:unstable [amd64])
Conf libspdlog1.10 (1:1.10.0+ds-0.4 Debian:testing, Debian:unstable [amd64])
Conf libwireplumber-0.4-0 (0.4.12-1 Debian:testing, Debian:unstable [amd64])
Conf wireplumber (0.4.12-1 Debian:testing, Debian:unstable [amd64])
Conf gnome-settings-daemon (43.0-2 Debian:testing, Debian:unstable [amd64])
Conf gnome-settings-daemon-common (43.0-2 Debian:testing, Debian:unstable [all])
Conf gnome-control-center (1:43.0-1 Debian:testing, Debian:unstable [amd64])
Conf gnome-control-center-data (1:43.0-1 Debian:testing, Debian:unstable [all])
Conf nautilus (43.0-1 Debian:testing, Debian:unstable [amd64])
Conf nautilus-data (43.0-1 Debian:testing, Debian:unstable [all])
 



je ne sais que penser ? ni que faire ?
je peux y aller tranquillement ?

amicalement ,

alain .

coyotus.png

Hors ligne

#3 11-10-2022 18:05:09

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : upgrade paquets surprenant

Déjà pour une fois, il t'enlève pas gnome-core    big_smile ....
Après, moi je dirai, teste, tu verras bien après ce qui ne marche plus    lol
bon, en un peu plus sérieux ....
Le full-upgrade avec des paquets épinglés, c'est moyen je trouve ...
Un exemple avec pipewire où t'en as épinglé ...
Ceux qui auront besoin d'un paquet épinglé ou de ses dépendances vont prendre un autre chemin, se construire différement je pense ...
Et ça t'empêche de savoir si le full-pgrade règlera tes problèmes ...
Je pense toujours à pipewire et là je vois qu'il installe wire plumber qui aurait peut-être solutionné ton problème
à toi de voir ... prépare toi une verveine ...  smile

En ligne

#4 11-10-2022 18:08:19

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : upgrade paquets surprenant

Debian Alain a écrit :

des paquets de ubuntu


C'est malin ça ....    roll

En ligne

#5 11-10-2022 19:40:36

robert2a
Membre
Distrib. : Bookworm version 12
Noyau : kernel 6.x.x
(G)UI : Mate
Inscription : 15-11-2014

Re : upgrade paquets surprenant

il est casse pied avec sa sid   tongue
par exemple les linux-kbuild-5.17 linux-kbuild-5.18 ne font plus parti de testing/sid (ainsi que les image et headers )  a virer
il a un outil "synaptic" qui lui permet de voir les paquets qui ne font plus partie des dépôt , a virer sans crainte (.dans version ils sont marqué "now").
ps: il y a des commandes en console pour détecter ce genre de paquet aussi.
mise a jour tous les jours , comme si cela est vital .........
bloquer des versions je sais pas pourquoi ..........
son sources.list ne doit pas être triste aussi  tongue
mais bon c'est Alain  roll , on l'aime bien quand même  wink

Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#6 11-10-2022 19:55:00

naguam
Membre
Lieu : Quelque part
Distrib. : Plusieurs
Noyau : Ça dépend
(G)UI : La CLI il n'y a que ça de vrai!
Inscription : 13-06-2016

Re : upgrade paquets surprenant

Oui, je conseillerais bien à Alain de rester sur debian stable + dépots backports au besoin quand la 12 sortira (après une clean install).

L'intérèt majeur de la debian sid c'est pour dev et tester debian, même si tout le monde peut s'en servir bien évidemment.
Honnêtement si c'est pas pour faire des bug rapport officiels / packager des paquets / être mainteneur, ça n'a d'intéret que les nouveaux paquets mais encore faut-il savoir faire face à ce que ça implique : pas ouf si on arrive pas réparer tout seul derrière.

Après si ça ne dérange personne d'aider Alain sur la Sid en soit c'est pas un soucis.
Mais j'avoue que je trouve ça dérangeant (en toute gentillesse) vu que c'est plutôt récurrent et que si on est une communauté, on est pas non plus un SAV.
Je dis on mais vous n'êtes pas forcés de vous sentir concernés, c'est à votre appréciation.

En effet le message du projet debian sur l'utilisation de la Sid est on ne peut plus clair :
N'utilisez debian sid que si vous êtes à l'aise et que vous savez ce que vous faites, soyez autonomes :
c'est unstable ça peut casser à tout moment soyez prévenus
c'est la branche de dev ne l'oubliez pas
c'est cool pour les nouveaux paquets, mais c'est avec ce que ça implique.

Maitriser les process de snapshot de mark hold de paquet, de réparation du système est un minimum avant d'être en sid en daily.
(Voir faq https://wiki.debian.org/DebianUnstable#FAQ)

Debian Alain a écrit :

je ne sais que penser .
je ne suis pas très rassuré .
je ne tiens pas à casser encore une fois ma machine à cause d'une m.a.j. stupide .


Bref je pense en toute gentillesse, au vu des nombreuses demandes et du message que je viens de citer que debian stable serait plus adaptée pour Alain.
La 12 quand elle sortira aura tout le support matériel pour son matos dernier cri, même si actuellement stable + backports ferait le travail.

Aussi l'intéret du stable c'est que tu utilise ton pc comme un outil, ton pc dépend de toi alors que en sid tu dépend du pc et du fait d'arriver à faire sa maintenance.

Pour ton problème, je pense que si tu autoremove, tu vas avoir des soucis avec ton gnome, mais c'est à toi de voir (savoir) si ce qui part t'es important.
Faudrais investiguer l'historique des manipulations de apt ainsi que les changelogs des paquets des dernières mises à jour pour savoir ce qui a cassé.
Ensuite en fonction réinstaller les paquets qui ont générés le autoremove, ou bien mark etc.

Désolé si je me répète.

Dernière modification par naguam (11-10-2022 20:28:38)

Hors ligne

#7 09-11-2022 01:35:02

Debian Alain
Membre
Lieu : Bretagne
Distrib. : sid (unstable) / bullseye (stable)
Noyau : Linux sid 6.0.0-4-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : upgrade paquets surprenant

j'ai finalement fait l'autoremove que réclamait sid .

apparemment , cela ne porte pas à conséquence .

trouvé ceci :

       autoremove (apt-get(8))
           La commande autoremove, supprime les paquets installés
           automatiquement dans le but de satisfaire les dépendances d'autres
           paquets et qui ne sont plus nécessaires parce que les dépendances
           ont changé ou parce que le ou les paquets ont été supprimés
           entre-temps.

           Vous devriez vérifier que la liste ne contient pas des applications
           que vous avez fini par apprécier, même si elles ont été installées
           seulement comme dépendance d'un autre paquet. Vous pouvez marquer
           ces paquets comme installés manuellement avec apt-mark(8). Les
           paquets que vous avez installés explicitement avec la commande
           install ne seront jamais proposés non plus pour une suppression
           automatique.



par contre , je ne sais  que penser de la réaction de  robert2a :

robert2a  a écrit :

il est casse pied avec sa sid


d'autant que je sache , il fait partie de ceux  qui ont insisté lourdement auprès de moi pour  que je passe à sid
il y a maintenant , en effet , un petit bout de temps .

alors de quoi il se plaint ?
voilà , je suis sous sid !

et si j'ai si longuement hésité ,
c'est que , justement , je me sentais pas capable  d'administrer une sid ...

sid , pour ses paquets récents , m'intéresse .
unstable , pas trop .

mais on ne peut pas avoir l'un sans l'autre , apparemment .

amicalement ,

alain .

merci pour le soutien .

coyotus.png

noyaux


[sudo] Mot de passe de alain :
ii  linux-headers-6.0.0-1-amd64                      6.0.2-1+b1                           amd64        Header files for Linux 6.0.0-1-amd64
ii  linux-headers-6.0.0-1-common                     6.0.2-1                              all          Common header files for Linux 6.0.0-1
ii  linux-headers-6.0.0-2-amd64                      6.0.6-2                              amd64        Header files for Linux 6.0.0-2-amd64
ii  linux-headers-6.0.0-2-common                     6.0.6-2                              all          Common header files for Linux 6.0.0-2
ii  linux-headers-amd64                              6.0.6-2                              amd64        Header files for Linux amd64 configuration (meta-package)
rc  linux-image-5.19.0-1-amd64                       5.19.6-1                             amd64        Linux 5.19 for 64-bit PCs (signed)
rc  linux-image-5.19.0-2-amd64                       5.19.11-1+b1                         amd64        Linux 5.19 for 64-bit PCs (signed)
ii  linux-image-6.0.0-1-amd64                        6.0.2-1+b1                           amd64        Linux 6.0 for 64-bit PCs (signed)
ii  linux-image-6.0.0-2-amd64                        6.0.6-2                              amd64        Linux 6.0 for 64-bit PCs (signed)
ii  linux-image-amd64                                6.0.6-2                              amd64        Linux for 64-bit PCs (meta-package)
 



upd


Atteint :1 http://deb.debian.org/debian bookworm InRelease
Atteint :2 http://deb.debian.org/debian testing InRelease
Atteint :3 http://deb.debian.org/debian-security testing-security/updates InRelease
Atteint :4 http://deb.debian.org/debian unstable InRelease
Atteint :5 http://deb.debian.org/debian experimental InRelease
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
26 paquets peuvent être mis à jour. Exécutez « apt list --upgradable » pour les voir.
 



alu


En train de lister... Fait
clang-14/unstable 1:14.0.6-7 amd64 [pouvant être mis à jour depuis : 1:14.0.6-6]
clang-format-14/unstable 1:14.0.6-7 amd64 [pouvant être mis à jour depuis : 1:14.0.6-6]
ghostscript/testing,testing,unstable 10.0.0~dfsg-6 amd64 [pouvant être mis à jour depuis : 9.56.1~dfsg-1]
gimp/testing,testing,unstable 2.10.32-1+b2 amd64 [pouvant être mis à jour depuis : 2.10.32-1+b1]
gnome-control-center-data/testing,testing,testing,testing,unstable,unstable 1:43.0-2 all [pouvant être mis à jour depuis : 1:42.3-2]
gnome-control-center/testing,testing,unstable 1:43.0-2 amd64 [pouvant être mis à jour depuis : 1:42.3-2+b1]
gnome-core/testing,testing,unstable 1:42+8 amd64 [pouvant être mis à jour depuis : 1:42+6]
gnome-settings-daemon-common/testing,testing,testing,testing,unstable,unstable 43.0-3 all [pouvant être mis à jour depuis : 43.0-1]
gnome-settings-daemon/testing,testing,unstable 43.0-3 amd64 [pouvant être mis à jour depuis : 43.0-1]
gnome-todo/testing,testing,testing,testing,unstable,unstable 42.0-4 amd64 [pouvant être mis à jour depuis : 41.0-3]
gnome/testing,testing,unstable 1:42+8 amd64 [pouvant être mis à jour depuis : 1:42+6]
libclang-common-14-dev/unstable 1:14.0.6-7 amd64 [pouvant être mis à jour depuis : 1:14.0.6-6]
libclang-cpp14/unstable 1:14.0.6-7 amd64 [pouvant être mis à jour depuis : 1:14.0.6-6]
libclang1-14/unstable 1:14.0.6-7 amd64 [pouvant être mis à jour depuis : 1:14.0.6-6]
libgs9-common/testing,testing,testing,testing,unstable,unstable 10.0.0~dfsg-6 all [pouvant être mis à jour depuis : 9.56.1~dfsg-1]
libllvm14/unstable 1:14.0.6-7 amd64 [pouvant être mis à jour depuis : 1:14.0.6-6]
libspectre1/testing,testing,unstable 0.2.10-1+b1 amd64 [pouvant être mis à jour depuis : 0.2.10-1]
llvm-14-dev/unstable 1:14.0.6-7 amd64 [pouvant être mis à jour depuis : 1:14.0.6-6]
llvm-14-linker-tools/unstable 1:14.0.6-7 amd64 [pouvant être mis à jour depuis : 1:14.0.6-6]
llvm-14-runtime/unstable 1:14.0.6-7 amd64 [pouvant être mis à jour depuis : 1:14.0.6-6]
llvm-14-tools/unstable 1:14.0.6-7 amd64 [pouvant être mis à jour depuis : 1:14.0.6-6]
llvm-14/unstable 1:14.0.6-7 amd64 [pouvant être mis à jour depuis : 1:14.0.6-6]
nautilus-data/testing,testing,testing,testing,unstable,unstable 43.0-1 all [pouvant être mis à jour depuis : 42.2-2]
nautilus/testing,testing,unstable 43.0-1 amd64 [pouvant être mis à jour depuis : 42.2-2]
onedrive/testing,testing,unstable 2.4.21-1+b1 amd64 [pouvant être mis à jour depuis : 2.4.18-0.1]
pipewire-media-session/testing,testing,unstable 0.4.1-4+b1 amd64 [pouvant être mis à jour depuis : 0.4.1-4]
 



upg


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  clang-14 clang-format-14 ghostscript gimp gnome gnome-control-center gnome-control-center-data gnome-core gnome-settings-daemon gnome-settings-daemon-common gnome-todo
  libclang-common-14-dev libclang-cpp14 libclang1-14 libgs9-common libllvm14 libspectre1 llvm-14 llvm-14-dev llvm-14-linker-tools llvm-14-runtime llvm-14-tools nautilus
  nautilus-data onedrive pipewire-media-session
0 mis à jour, 0 nouvellement installés, 0 à enlever et 26 non mis à jour.



alias


alias alu='apt list --upgradable'
alias fupg='sudo apt full-upgrade'
alias l='ls -CF'
alias la='ls -A'
alias ll='ls -l'
alias ls='ls --color=auto'
alias noyaux='sudo dpkg -l | grep -iE "linux-image-|linux-headers-"'
alias saa='sudo apt autoremove'
alias upd='sudo apt update'
alias upg='sudo apt upgrade'
alias yt='python3 /usr/local/bin/youtube-dl'
 

Hors ligne

#8 09-11-2022 21:57:25

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : upgrade paquets surprenant

salut Alain,
content que t'es découvert apt auto-remove ...   smile
Bon, vos querelles de mémères, tout le monde s'en fout ... big_smile
Mais, .... , c'est quoi ces commandes à la noix ?
Tu peux pas écrire upgrade (ou la commande dans son entier) au lieu d'upg ...
M'enfin ...


bash: upd : commande introuvable


bash: upg : commande introuvable



J'ai rien contre les alias, mais un alias c'est personnel, pas pour partager des infos à moins de les avoir déclaré avant ....
Déjà qu'il y a des gens qui postent des messages format sms-raccourci où il faut deviner toutes les voyelles qui n'y sont pas...
Si tout le monde s'y met pour les commandes, ça va être super ....
Bref, un effort stp... c'est pas dur de taper sur des touches...
é viv le faux rhum ....

Dernière modification par ubub (09-11-2022 22:03:40)

En ligne

Pied de page des forums