Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-02-2023 16:19:42

JeromeP
Membre
Lieu : Montpellier
Distrib. : Debian Facile
Noyau : Linux 6.0.0.0-0.deb11.6-amd64
(G)UI : XFCE
Inscription : 25-01-2023

[Résolu] Debian Facile ne se lance pas

Bonjour.
Je suis un widowsien intéressé maintenant par linux mais...
J'ai un pc dell acheté il y a quelques mois avec ubuntu installé.
J'ai choisi d'installer debian facile en parallèle mais au démarrage j'arrive bien au menu grub avec debian en premier puis ubuntu mais quand je choisi debian, je me retrouve avec un écran noir contenant deux lignes :

dell_smm_humon: unable to get SMM Dell signature
hdaudio hdaudioCOD2: unable to configure, disabling

Ces messages ne m'inquiètent pas plus que ça, par contre la fait que ça reste bloqué sur cet écran me dérange un peu plus

Quelqu'un peut il venir à mon secours

Dernière modification par JeromeP (10-02-2023 13:03:13)


Vieux windowsien (3.1) qui souhaite migrer sous linux
perso: asus (>10ans) i5 8G HDD 1To carte NVIDIA GEFORCE GTX950 2G avec Emmabuntus qui rame
pro: DELL Precision 3460 16G SSD256G i5 UBUNTU 20.04 OEM/Debian Facile (futur serveur test BDD) et portable de travail DELL Precision 7560 32G SSD 1To avec Windows 10Pro et plus tard rajout Linux indéterminé

Hors ligne

#2 07-02-2023 19:07:59

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [Résolu] Debian Facile ne se lance pas

Mhhm, je pense pas que ces erreurs soient fatales. Va falloir chercher un peu plus.
Si je devais parier je dirai que c'est un souci de driver graphique.
Ou que ta partition est pleine (mais ça paraît un peu tôt ; normalement tu l'aurai vu venir : aussi contre-intuitif que ça paraisse, une partition pleine empêche Xorg de se lancer :3).

J'essayerai de passer en TTY (ctrl+alt+F1-2-3-4-5-6-7-8...) de me connecter, et d'obtenir plus de messages d'erreurs, avec "dmesg" ou de comprendre pourquoi l'interface graphique se lance pas avec "systemctl status lightdm". Tu peux aussi voir avec "top" si y a pas un processus à fond, ou avec "df -h" pour la place restante sur tes partitions.


systemctl status lightdm
dmesg
top
df -h

Dernière modification par otyugh (07-02-2023 19:12:28)


virtue_signaling.png
Pas de repos pour les oppresseurs ! (/me inclus)

En ligne

#3 07-02-2023 19:32:48

JeromeP
Membre
Lieu : Montpellier
Distrib. : Debian Facile
Noyau : Linux 6.0.0.0-0.deb11.6-amd64
(G)UI : XFCE
Inscription : 25-01-2023

Re : [Résolu] Debian Facile ne se lance pas


active failed (Result: exit-code)
process ExecStart=/usr/sbin/lightdm (code=exited, status=1/FAILURE)
lightdm.service: Start request repeated too quickly.
lightdm.service: Failed with result 'exit-code'.

lightdm.service: Triggering OnFailure= dependencies.
 


top ne donne qu'une tâche active avec quasiment rien de cpu ou de mémoire

df -h donne 13% de /boot/efi utilisé et 0 à 9% pour les autres partitions

dmesg -H donne une erreur sec2: unhandled intr 00000010 en plus des deux erreurs précédentes


Vieux windowsien (3.1) qui souhaite migrer sous linux
perso: asus (>10ans) i5 8G HDD 1To carte NVIDIA GEFORCE GTX950 2G avec Emmabuntus qui rame
pro: DELL Precision 3460 16G SSD256G i5 UBUNTU 20.04 OEM/Debian Facile (futur serveur test BDD) et portable de travail DELL Precision 7560 32G SSD 1To avec Windows 10Pro et plus tard rajout Linux indéterminé

Hors ligne

#4 07-02-2023 20:17:44

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [Résolu] Debian Facile ne se lance pas

Mhm ma suspicion d'un problème de pilote graphique/kernel augmente.
C'est quoi comme CG ?

lspci -vmd ::0300



Le premier truc que j'essayerai c'est de lancer en éditant grub ; tu appuies sur "e" sur l'entrée ; retirer "quiet splash" et le remplacer par "nomodeset" ?

(j'admet que je suit aucun manuel pour te donner des conseils là, c'est mon expérience sur le tas qui parle, y a probablement une manière plus logique de procéder mais je ne peux dire que ce que je ferai ; faut juste garder en tête que c'est pas "la méthode" ~)

Dernière modification par otyugh (07-02-2023 20:22:11)


virtue_signaling.png
Pas de repos pour les oppresseurs ! (/me inclus)

En ligne

#5 07-02-2023 20:27:06

Tawal
Membre
Distrib. : Debian Stable à jour
Noyau : amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : [Résolu] Debian Facile ne se lance pas

Hello,

Sur un tty root, donne le retour de :

journalctl --no-pager -b -p err



Sinon, pour écarter un souci de pilote graphique, tu peux tenter de mettre nomodeset à la ligne de commande Grub.
Pour ce faire, sélectionne (sans lancer) l'entrée Debian Facile, appuie sur la touche e,
repère la ligne commençant par linux= (utilise les flèches du clavier pour naviguer dans le texte qui s'affiche) et ajoute nomodeset à la fin.
Enlève (si il y a) les mots quiet et splash (tu auras plus d'informations sur ton démarrage).
Attention le clavier est en QWERTY, donc pour m appuyer sur , ...
Une fois le mot nomodeset ajouté, appuie sur la touche F10 pour lancer le démarrage.
Cette modification du démarrage n'est valable que pour celui en cours.

Edit: Arff, grillé mrgreen.gif

Dernière modification par Tawal (07-02-2023 20:29:50)


Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

#6 07-02-2023 20:31:28

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [Résolu] Debian Facile ne se lance pas

Non, c'est mieux expliqué smile

Ça me fait penser à chaque fois que j'ai pas trouvé comment passer grub en azerty, c'est le genre de customisation que j'aurai bien aimé ajouter à DF, ça m'a frustré de pas y arriver roll

virtue_signaling.png
Pas de repos pour les oppresseurs ! (/me inclus)

En ligne

#7 07-02-2023 20:32:15

anonyme
Invité

Re : [Résolu] Debian Facile ne se lance pas

Bonsoir
tu a aussi
pour les erreurs


journalctl -b -r -p err
 


pour les erreurs de firmware


dmesg | grep -i firmware
 


pour les drm du gpu


dmesg | grep -i drm
 

#8 07-02-2023 20:48:52

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Debian Facile ne se lance pas

otyugh a écrit :

j'ai pas trouvé comment passer grub en azerty


Réponse courte : ça ne marche pas. J'ai essayé. Ce n'est pas fiable. La seule façon fiable, c'est d'avoir un BIOS/UEFI qui permet de définir la disposition du clavier (si si, ça existe, j'en ai vu un). Pour les cas compliqués, j'ai adopté la technique inverse : un clavier USB QWERTY.

Sur ce, j'arrête la digression hors-sujet et je vous laisse continuer à dépanner.

Dernière modification par raleur (07-02-2023 20:55:23)


Il vaut mieux montrer que raconter.

Hors ligne

#9 07-02-2023 21:06:11

Tawal
Membre
Distrib. : Debian Stable à jour
Noyau : amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : [Résolu] Debian Facile ne se lance pas

" je vous laisse continuer à dépanner."
Reviens donner un coup de main si on patauge tongue

Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

#10 07-02-2023 21:08:12

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [Résolu] Debian Facile ne se lance pas

Sur ce, j'arrête la digression hors-sujet et je vous laisse continuer à dépanner.


Ça me soulage beaucoup d'entendre ça; échouant seul j'ai tendance à attribuer ces échecs à <insérer un mot pour se déprécier>, merci du p'tit mot smile


virtue_signaling.png
Pas de repos pour les oppresseurs ! (/me inclus)

En ligne

#11 07-02-2023 21:20:12

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Debian Facile ne se lance pas

Vous vous en sortez bien avec la piste du pilote graphique à creuser. Attendons les informations.

Il vaut mieux montrer que raconter.

Hors ligne

#12 08-02-2023 09:20:29

anonyme
Invité

Re : [Résolu] Debian Facile ne se lance pas

Démarrer sous Ubuntu et lancer la commande du #4 de otyugh pour connaître le gpu
un lspci pour voir le matériel (de cette machine ).
pour debian le mode "rescue" avec la clé usb d'installation de debian . (monter la partition système , installer des paquets , visualiser des logs etc ..... ) et avec un clavier azerty

Dernière modification par anonyme (09-02-2023 11:34:21)

#13 09-02-2023 18:19:25

JeromeP
Membre
Lieu : Montpellier
Distrib. : Debian Facile
Noyau : Linux 6.0.0.0-0.deb11.6-amd64
(G)UI : XFCE
Inscription : 25-01-2023

Re : [Résolu] Debian Facile ne se lance pas

lspci -vmd ::0300



Device 00:02.0
Class: VGA compatible controller
Vendor: Intel Corporation
Device: Device 4690
SVendor: Dell
SDevice: Device 0ac7
Rev: 0c
Device: 01:00.0
Class: VGA compatible controller
Vendor: NVIDIA Corporation
Device: Device 1ff2
SVendor: Dell
SDevice: Device Device 1613
Rev: a1


Vieux windowsien (3.1) qui souhaite migrer sous linux
perso: asus (>10ans) i5 8G HDD 1To carte NVIDIA GEFORCE GTX950 2G avec Emmabuntus qui rame
pro: DELL Precision 3460 16G SSD256G i5 UBUNTU 20.04 OEM/Debian Facile (futur serveur test BDD) et portable de travail DELL Precision 7560 32G SSD 1To avec Windows 10Pro et plus tard rajout Linux indéterminé

Hors ligne

#14 09-02-2023 18:23:45

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [Résolu] Debian Facile ne se lance pas

Et ça démarre avec les modifs du grub qu'on t'a préconisé ?

J'aurai dû te dire de faire "lspci -vmkd ::0300" ça donne aussi le driver utilisé ^^'


Tu as un GPU interne et un externe, j'imagine qu'on regarde le second.

Class: VGA compatible controller
Vendor: NVIDIA Corporation
Device: Device 1ff2
SVendor: Dell
SDevice: Device Device 1613
Rev: a1



Heh. T'as tombé sur un modèle non référencé par lspci on dirait ? Va falloir scruter ta carte graphique manuellement tongue

Dernière modification par otyugh (09-02-2023 18:36:31)


virtue_signaling.png
Pas de repos pour les oppresseurs ! (/me inclus)

En ligne

#15 09-02-2023 18:57:02

JeromeP
Membre
Lieu : Montpellier
Distrib. : Debian Facile
Noyau : Linux 6.0.0.0-0.deb11.6-amd64
(G)UI : XFCE
Inscription : 25-01-2023

Re : [Résolu] Debian Facile ne se lance pas

journalctl --no-pager -b -p err



debian pipewire3478: Failed to receive portal pid: org.freedesktop.DBus.Error.NameHasNoOwner
GetManagedObjects() failed: org.freedesktop.DBus.Error.Noreply
 




dmesg | grep -i firmware


nouveau 0000:01:00.0: pmu: firmware unavailable


Les autres firmware sont NVidia et passent

dmesg | grep -i drm



DRM: BIT table 'A' not found
DRM: BIT table 'L' not found
[drm] Cannot find any crtc or sizes (3 fois)
systemd[1]Starting load Kernel
systemd[1]: modprobe@drm.services: Succeeded
systemd[1]: Finished Load Kernel Module drm
 


Vieux windowsien (3.1) qui souhaite migrer sous linux
perso: asus (>10ans) i5 8G HDD 1To carte NVIDIA GEFORCE GTX950 2G avec Emmabuntus qui rame
pro: DELL Precision 3460 16G SSD256G i5 UBUNTU 20.04 OEM/Debian Facile (futur serveur test BDD) et portable de travail DELL Precision 7560 32G SSD 1To avec Windows 10Pro et plus tard rajout Linux indéterminé

Hors ligne

#16 09-02-2023 18:59:42

JeromeP
Membre
Lieu : Montpellier
Distrib. : Debian Facile
Noyau : Linux 6.0.0.0-0.deb11.6-amd64
(G)UI : XFCE
Inscription : 25-01-2023

Re : [Résolu] Debian Facile ne se lance pas

ça démarre en nomodeset donc je dois modifier quel fichier pour que ça soit valable tout le temps ?

Dernière modification par JeromeP (09-02-2023 19:28:58)


Vieux windowsien (3.1) qui souhaite migrer sous linux
perso: asus (>10ans) i5 8G HDD 1To carte NVIDIA GEFORCE GTX950 2G avec Emmabuntus qui rame
pro: DELL Precision 3460 16G SSD256G i5 UBUNTU 20.04 OEM/Debian Facile (futur serveur test BDD) et portable de travail DELL Precision 7560 32G SSD 1To avec Windows 10Pro et plus tard rajout Linux indéterminé

Hors ligne

#17 09-02-2023 20:17:45

Tawal
Membre
Distrib. : Debian Stable à jour
Noyau : amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : [Résolu] Debian Facile ne se lance pas

Si ça démarre avec l'option kernel nomodeset alors c'est un problème de pilote de carte graphique.
Plutôt que de mettre ce mode en permanent, il serait judicieux de régler le problème de carte graphique.
Mais je ne suis pas expert en la matière, je laisse la main.

Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

#18 09-02-2023 20:19:06

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [Résolu] Debian Facile ne se lance pas

Avoir le modèle de la carte graphique serait un début.

virtue_signaling.png
Pas de repos pour les oppresseurs ! (/me inclus)

En ligne

#19 09-02-2023 21:24:34

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Debian Facile ne se lance pas

otyugh a écrit :

J'aurai dû te dire de faire "lspci -vmkd ::0300" ça donne aussi le driver utilisé


Oui, mais on peut récupérer des informations en comparant les identifiants avec les "alias" des modules.
Le GPU Intel devrait être géré par le module i915 mais il n'est pas dans les alias, probablement trop récent. Il faudrait essayer le noyau de bullseye-backports.
Le GPU Nvidia devrait être géré par le module nouveau mais l'alias couvre tous les GPU Nvidia donc ça ne donne pas d'information. D'après les logs du noyau, nouveau semble chercher un firmware, vérifier si le paquet firmware-misc-nonfree est installé.

otyugh a écrit :

T'as tombé sur un modèle non référencé par lspci on dirait ?


Où bien base de données d'identifiants PCI trop ancienne, à mettre à jour avec update-pciids. Avec une base récente :
8086:4690 = Intel Alder Lake-S GT1 [UHD Graphics 770]
10de:1ff2 = Nvidia TU117GL [T400 4GB]


Il vaut mieux montrer que raconter.

Hors ligne

#20 10-02-2023 00:12:11

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [Résolu] Debian Facile ne se lance pas

Où bien base de données d'identifiants PCI trop ancienne, à mettre à jour avec update-pciids


Wooh, astuce, je me note ça.

firmware-misc-nonfree


S'il a bien l'iso DF ça fait partie des paquets intégrés. https://debian-facile.org/git/ProjetsDF … ist.chroot

Dernière modification par otyugh (10-02-2023 00:13:26)


virtue_signaling.png
Pas de repos pour les oppresseurs ! (/me inclus)

En ligne

#21 10-02-2023 09:35:11

anonyme
Invité

Re : [Résolu] Debian Facile ne se lance pas

Bonjour

modifier le sources.list (avec les backports )


nano /etc/apt/sources.list
 



#debian11
deb http://deb.debian.org/debian/ bullseye main contrib non-free
deb http://security.debian.org/debian-security bullseye-security main contrib non-free
deb http://deb.debian.org/debian/ bullseye-updates main contrib non-free
deb http://deb.debian.org/debian/ bullseye-backports main contrib non-free
 


mettre a jour apt


apt update
 



installer le noyau et le firmware


apt install -t bullseye-backports linux-image-amd64 firmware-misc-nonfree
 



mettre a jour la BD du matériel


update-pciids
 



remarque: supprimer "nomodeset" dans grub

faire un reboot de la machine

ps: une autre solution est de migrer vers bookworm (actuellement debian testing (debian 12) ).

une autre remarque , tu a deux gpu (un portable peut être ) et tu précise pas ton bureau .
et si nouveau fonctionne mal , il y a un driver nonfree nvidia .
a voir aussi comment gérer ces deux gpu .

je n'ai pas vérifier la pertinence des deux paquets ci dessous (noyau et firmware) pour ce matériel
=> https://packages.debian.org/fr/bullseye … sc-nonfree
=> https://packages.debian.org/fr/bullseye … mage-amd64

Dernière modification par anonyme (10-02-2023 10:06:36)

#22 10-02-2023 12:16:57

JeromeP
Membre
Lieu : Montpellier
Distrib. : Debian Facile
Noyau : Linux 6.0.0.0-0.deb11.6-amd64
(G)UI : XFCE
Inscription : 25-01-2023

Re : [Résolu] Debian Facile ne se lance pas

La carte est une nvidia t400 mais debian ne la reconnait pas comme telle par les commandes


nvidia-detect
nvidia-driver


Les derniers drivers ont normalement été installés mais le problème reste le même


Vieux windowsien (3.1) qui souhaite migrer sous linux
perso: asus (>10ans) i5 8G HDD 1To carte NVIDIA GEFORCE GTX950 2G avec Emmabuntus qui rame
pro: DELL Precision 3460 16G SSD256G i5 UBUNTU 20.04 OEM/Debian Facile (futur serveur test BDD) et portable de travail DELL Precision 7560 32G SSD 1To avec Windows 10Pro et plus tard rajout Linux indéterminé

Hors ligne

#23 10-02-2023 12:30:19

JeromeP
Membre
Lieu : Montpellier
Distrib. : Debian Facile
Noyau : Linux 6.0.0.0-0.deb11.6-amd64
(G)UI : XFCE
Inscription : 25-01-2023

Re : [Résolu] Debian Facile ne se lance pas

Yessssssssssssss ça marche avec les manipulations indiquées par anonyme
Merci à toutes et tous pour votre aide.

Vieux windowsien (3.1) qui souhaite migrer sous linux
perso: asus (>10ans) i5 8G HDD 1To carte NVIDIA GEFORCE GTX950 2G avec Emmabuntus qui rame
pro: DELL Precision 3460 16G SSD256G i5 UBUNTU 20.04 OEM/Debian Facile (futur serveur test BDD) et portable de travail DELL Precision 7560 32G SSD 1To avec Windows 10Pro et plus tard rajout Linux indéterminé

Hors ligne

#24 10-02-2023 12:55:32

Tawal
Membre
Distrib. : Debian Stable à jour
Noyau : amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : [Résolu] Debian Facile ne se lance pas

C'est à dire ?

Utiliser les paquets du dépôt "backports" ?
Ou la migration ?

Tu peux mettre [Résolu] au titre de la discussion en éditant le 1er message wink

Edit:
L'utilisation de nomodeset était pour isoler le souci (ou l'écarter).
Mais n'était pas une solution wink

Dernière modification par Tawal (10-02-2023 12:56:41)


Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

#25 10-02-2023 13:02:15

JeromeP
Membre
Lieu : Montpellier
Distrib. : Debian Facile
Noyau : Linux 6.0.0.0-0.deb11.6-amd64
(G)UI : XFCE
Inscription : 25-01-2023

Re : [Résolu] Debian Facile ne se lance pas

Tawal a écrit :

C'est à dire ?

Utiliser les paquets du dépôt "backports" ?
Ou la migration ?

Tu peux mettre [Résolu] au titre de la discussion en éditant le 1er message wink

Edit:
L'utilisation de nomodeset était pour isoler le souci (ou l'écarter).
Mais n'était pas une solution wink



Le problème a été résolu en utilisant les paquets du dépôt "backports"


Vieux windowsien (3.1) qui souhaite migrer sous linux
perso: asus (>10ans) i5 8G HDD 1To carte NVIDIA GEFORCE GTX950 2G avec Emmabuntus qui rame
pro: DELL Precision 3460 16G SSD256G i5 UBUNTU 20.04 OEM/Debian Facile (futur serveur test BDD) et portable de travail DELL Precision 7560 32G SSD 1To avec Windows 10Pro et plus tard rajout Linux indéterminé

Hors ligne

Pied de page des forums