Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-03-2018 12:58:30

Tristan07
Adhérent(e)
Distrib. : Debian 9, Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : Gnome 3.22
Inscription : 21-05-2016
Site Web

Résolu -Mise à jour et dépendances logiciels, quelle attitude adopter?

Bonjour,

J'ai depuis quelques jours sur mon poste fixe des notifications de mise à jour. J'exécute celles-ci toujours avec un terminal. J'ai apparemment des dépendances de gir1.2-javascriptcoregtk-4.0 non satisfaites, il semble que la mise à niveau de ce dernier soit considéré comme "optionnelle"
voici l'historique des commandes :

apt update && apt dist-upgrade


bloc à supprimer si la commande n’affiche rien


4 packages can be upgraded. Run 'apt list --upgradable' to see them.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  gir1.2-javascriptcoregtk-4.0 libjavascriptcoregtk-4.0-18
0 mis à jour, 0 nouvellement installés, 0 à enlever et 2 non mis à jour.



apt list --upgradable



gir1.2-javascriptcoregtk-4.0/stable 2.18.6-1~deb9u1 amd64 [upgradable from: 2.16.6-0+deb9u1]
gir1.2-webkit2-4.0/stable 2.18.6-1~deb9u1 amd64 [upgradable from: 2.16.6-0+deb9u1]
libjavascriptcoregtk-4.0-18/stable 2.18.6-1~deb9u1 amd64 [upgradable from: 2.16.6-0+deb9u1]
libwebkit2gtk-4.0-37/stable 2.18.6-1~deb9u1 amd64 [upgradable from: 2.16.6-0+deb9u1



 aptitude why gir1.2-javascriptcoregtk-4.0


i   gufw               Dépend gir1.2-webkit2-4.0                              
i A gir1.2-webkit2-4.0 Dépend gir1.2-javascriptcoregtk-4.0 (= 2.16.6-0+deb9u1)



aptitude why-not gir1.2-javascriptcoregtk-4.0



Automatically installed, current version 2.16.6-0+deb9u1, priority optionnel
The candidate version 2.18.6-1~deb9u1 has priority optionnel
No dependencies require to remove gir1.2-javascriptcoregtk-4.0



apt install -f


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 4 non mis à jour.



 aptitude update && aptitude dist-upgrade


Atteint http://download.virtualbox.org/virtualbox/debian stretch InRelease
Atteint http://security.debian.org/debian-security stretch/updates InRelease                        
Atteint http://www.deb-multimedia.org stretch InRelease
Ignoré http://deb.debian.org/debian stretch InRelease                                  
Atteint http://deb.debian.org/debian stretch-updates InRelease                  
Atteint http://repository.spotify.com stable InRelease                                          
Atteint http://deb.debian.org/debian stretch Release                                                
Ignoré http://download.opensuse.org/repositories/home:/stevenpusser/Debian_9.0  InRelease
Atteint http://download.opensuse.org/repositories/home:/stevenpusser/Debian_9.0  Release
                                                       
Les paquets suivants seront mis à jour :                
  gir1.2-javascriptcoregtk-4.0 gir1.2-webkit2-4.0 libjavascriptcoregtk-4.0-18
  libwebkit2gtk-4.0-37{b}
4 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 11,6 Mo/15,9 Mo d'archives. Après dépaquetage, 2 196 ko seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
 libwebkit2gtk-4.0-37 : Dépend: libgstreamer-plugins-bad1.0-0 (< 1.10.5) but 1:1.10.4-dmo2 is installed
Les actions suivantes permettront de résoudre ces dépendances :

     Conserver les paquets suivants dans leur version actuelle :
1)     gir1.2-javascriptcoregtk-4.0 [2.16.6-0+deb9u1 (now)]    
2)     gir1.2-webkit2-4.0 [2.16.6-0+deb9u1 (now)]              
3)     libjavascriptcoregtk-4.0-18 [2.16.6-0+deb9u1 (now)]      
4)     libwebkit2gtk-4.0-37 [2.16.6-0+deb9u1 (now)]

Accepter cette solution ? [Y/n/q/?]
 



Je n'ai jamais été confronté à de tel choix sous Debian; du coup j'ai laissé en l'état pour le moment, aucun comportement "anormal" n'est à signaler et apt/aptitude fonctionnent normalement.

Mon source list :


deb http://deb.debian.org/debian/ stretch main contrib non-free
deb-src http://deb.debian.org/debian/ stretch main contrib non-free

deb http://security.debian.org/debian-security stretch/updates main contrib non-free
deb-src http://security.debian.org/debian-security stretch/updates main contrib non-free

# stretch-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
deb-src http://deb.debian.org/debian/ stretch-updates main contrib non-free

# stable deb-multimedia
deb http://www.deb-multimedia.org stretch main non-free

deb http://download.virtualbox.org/virtualbox/debian stretch contrib



Mon portable est équipé sensiblement de la même liste de logiciels, je n'ai pourtant pas cette indication de aptitude où tout est à jour également sans aucune MAJ signalée ...

Que choisir dans ce cas de figure, sachant que je fais le choix de Stretch pour avoir des machines de production stables?

merci
Bon dimanche

Dernière modification par Tristan07 (26-03-2018 23:12:15)


Debian Stable est ce qui rend la vie plus intéressante que l'informatique ( voir Robert Filliou pour l'origine de cette citation smile
Debian c'est pas difficile ! zen.gif
https://lescahiersdudebutant.fr/
Pour une aide efficace sur le forum : https://debian-facile.org/viewtopic.php?id=13352

Hors ligne

#2 25-03-2018 14:50:26

smolski
admin quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports (buster) 10
Noyau : 4.9.65-3+deb9u2 4.19.0-6-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : Résolu -Mise à jour et dépendances logiciels, quelle attitude adopter?

Et tu as fait un fichier de préférences ?
Voir le pinning :
https://debian-facile.org/doc:systeme:apt:pinning

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 25-03-2018 15:22:38

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : Résolu -Mise à jour et dépendances logiciels, quelle attitude adopter?

Bonjour,
C’est un paquet du dépôt multimédia qui semble bloqué la mise à jour

aptitude why libgstreamer-plugins-bad1.0-0


aptitude why-not libgstreamer-plugins-bad1.0-0


Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#4 25-03-2018 15:52:57

Tristan07
Adhérent(e)
Distrib. : Debian 9, Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : Gnome 3.22
Inscription : 21-05-2016
Site Web

Re : Résolu -Mise à jour et dépendances logiciels, quelle attitude adopter?

smolski a écrit :

Et tu as fait un fichier de préférences ?
Voir le pinning :
https://debian-facile.org/doc:systeme:apt:pinning



salut à vous :

j'ai fait un pinning :

Package: *
Pin: release o=Unofficial Multimedia Packages,a=stable
Pin-Priority: 100



https://debian-facile.org/doc:systeme:a … e-priorite

edit :

le portable est une installation fraîche, et lui n'a pas ce "problème"

Dernière modification par Tristan07 (25-03-2018 15:53:52)


Debian Stable est ce qui rend la vie plus intéressante que l'informatique ( voir Robert Filliou pour l'origine de cette citation smile
Debian c'est pas difficile ! zen.gif
https://lescahiersdudebutant.fr/
Pour une aide efficace sur le forum : https://debian-facile.org/viewtopic.php?id=13352

Hors ligne

#5 25-03-2018 16:02:45

Tristan07
Adhérent(e)
Distrib. : Debian 9, Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : Gnome 3.22
Inscription : 21-05-2016
Site Web

Re : Résolu -Mise à jour et dépendances logiciels, quelle attitude adopter?

J'ai retiré le fichier de préférences et effectivement du coup les MAJ passent. Forcément. roll
Je laisse ouvert car la question de base est surtout la bonne attitude dans ce cas précis ...
Ais-je jouer à la roulette russe en désactivant le fichier 50multimedia ?

quelle méthode pratiquez-vous ? / conseillez-vous ? outre le choix orthodoxe qui serait de ne pas utiliser le dépôt multimédia wink

Dernière modification par Tristan07 (25-03-2018 16:03:51)


Debian Stable est ce qui rend la vie plus intéressante que l'informatique ( voir Robert Filliou pour l'origine de cette citation smile
Debian c'est pas difficile ! zen.gif
https://lescahiersdudebutant.fr/
Pour une aide efficace sur le forum : https://debian-facile.org/viewtopic.php?id=13352

Hors ligne

#6 25-03-2018 17:10:00

smolski
admin quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports (buster) 10
Noyau : 4.9.65-3+deb9u2 4.19.0-6-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : Résolu -Mise à jour et dépendances logiciels, quelle attitude adopter?

En stable, il est conseillé de maintenir sa machine stable, donc le retour de tous les coups de revolvers dans l'dos venues des autres sources est à contrôler de très très près. Sinon :
Tu l'as voulu, Billy !
... ms2.gif PAN !

Dernière modification par smolski (25-03-2018 17:10:22)


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#7 25-03-2018 18:25:17

Tristan07
Adhérent(e)
Distrib. : Debian 9, Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : Gnome 3.22
Inscription : 21-05-2016
Site Web

Re : Résolu -Mise à jour et dépendances logiciels, quelle attitude adopter?

tu les trouves où tous toutes tes émoticônes animées ? big_smile

donc ... retour du pinning ou pas retour du pinning ?
toi du diras oui sans doute ? Et se passer du dépôt multimedia ?? (idéalement)

Debian Stable est ce qui rend la vie plus intéressante que l'informatique ( voir Robert Filliou pour l'origine de cette citation smile
Debian c'est pas difficile ! zen.gif
https://lescahiersdudebutant.fr/
Pour une aide efficace sur le forum : https://debian-facile.org/viewtopic.php?id=13352

Hors ligne

#8 25-03-2018 19:55:39

smolski
admin quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports (buster) 10
Noyau : 4.9.65-3+deb9u2 4.19.0-6-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : Résolu -Mise à jour et dépendances logiciels, quelle attitude adopter?

Le pinning sert à limiter les mises à jour, le mieux est de commenter les sources ostrogothes afin de ne plus avoir le suivi, sinon de notre propre volontée.

Les emoticones sont un cadeau d'arpi, là : https://arpinux.org/images/gifs/
Tu copies l'url de l'émoticone que tu colles ensuite sur le forum et puis tu la sélectionnes et tu l'encadres avec le bouton IMG. (gros le bouton...) ...  happy0005.gif

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#9 25-03-2018 20:05:44

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : Résolu -Mise à jour et dépendances logiciels, quelle attitude adopter?

Avais-tu fait le fichier de priorités dès le départ ou avais-tu un certain temps utilisé le dépôt multimédia sans ce fichier ?
Quel paquet as-tu installé depuis le dépôt deb-multimedia ?
Si on regarde les paquets qui bloquaient, on constate qu'il n'y a pas d'intérêt à utiliser ceux des dépôts la version semble identique scratchhead.gif

libwebkit2gtk-4.0-37:
  Installé : 2.18.6-1~deb9u1
  Candidat : 2.18.6-1~deb9u1
 Table de version :
     2.18.6-1~deb9u1.0 -1
         -1 http://www.deb-multimedia.org stable/main amd64 Packages
 *** 2.18.6-1~deb9u1 500
        500 http://deb.debian.org/debian stretch/main amd64 Packages
        100 /var/lib/dpkg/status
     2.18.6-1~bpo9+1 100
        100 http://deb.debian.org/debian stretch-backports/main amd64 Packages
 


libgstreamer-plugins-bad1.0-0:
  Installé : 1.10.4-1
  Candidat : 1.10.4-1
 Table de version :
     1:1.10.4-dmo2 -1
         -1 http://www.deb-multimedia.org stable/main amd64 Packages
 *** 1.10.4-1 500
        500 http://deb.debian.org/debian stretch/main amd64 Packages
        100 /var/lib/dpkg/status


Reste à savoir pourquoi tu avais la version du paquet libgstreamer-plugins-bad1.0-0 qui provient des dépôts deb-multimedia .
Bon maintenant que tu as fait la mise à jour en supprimant le fichier de priorités, tu risques d'avoir plus d'un paquet provenant de ce dépôt.
Edit : la commande suivante devrait te retourner ces paquet du dépôt (ils avec la chaîne de caractères dmo dans l'extension) :

dpkg-query -l | grep dmo


il peut y avoir des "faux positifs" : des paquets installés des dépôts officiels qui ont ces caractères dmo dans le nom mais ça permet toujours de faire le tri.

Dernière modification par chalu (25-03-2018 20:18:20)


Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#10 25-03-2018 21:38:00

jce76350
Membre
Lieu : Rouen
Distrib. : Debian9_Stretch 9.11
Noyau : 4.9.0-11-amd64
(G)UI : XFCE
Inscription : 24-08-2016
Site Web

Re : Résolu -Mise à jour et dépendances logiciels, quelle attitude adopter?

si ça vient de libgstreamer-plugins-bad1.0-0 qui bloque il y des posts sur
https://lists.debian.org/debian-user-fr … 00285.html

la solution est la
https://lists.debian.org/debian-user-fr … 00293.html

--
Jc E

Hors ligne

#11 26-03-2018 13:11:56

Tristan07
Adhérent(e)
Distrib. : Debian 9, Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : Gnome 3.22
Inscription : 21-05-2016
Site Web

Re : Résolu -Mise à jour et dépendances logiciels, quelle attitude adopter?

Merci à vous ...

alors voilà une belle connerie qui me permet d'en apprendre plus avec Debian !
J'ai vérifié avec ta commande chalu ainsi que via synaptic et beaucoup de logiciels proviennent du dépôt multimedia ! Normal, puisqu'à l'installation de Debian la première chose faite est d'adapter mon sources.list ! Et le dépôt multimedia est ainsi activé en amont des installations des logiciels utilisés ! kernal_panic.gif
Donc, je me retrouve avec vlc audacity et d'autres installés depuis ces dépôts puisque le fichier de préférences ne fut indiqué qu'en post installation ....

ii  audacity                                                    1:2.1.3-dmo1+deb9u1                         amd64        fast, cross-platform audio editor
ii  audacity-data                                               1:2.1.3-dmo1+deb9u1                         all          fast, cross-platform audio editor (data)
ii  avidemux                                                    1:2.6.20-dmo3                               amd64        Free video editor
ii  avidemux-common                                             1:2.6.20-dmo3                               all          Free video editor (Internationalization files)
ii  avidemux-plugins                                            1:2.6.20-dmo3                               amd64        Free video editor (plugins)
ii  avidemux-qt                                                 1:2.6.20-dmo3                               amd64        Free video editor (QT version)
ii  dvdrip                                                      1:0.98.11-dmo5                              amd64        perl front end for transcode and ffmpeg
ii  dvdrip-doc                                                  2:0.98.11-dmo1                              all          Documentation for dvd::rip
ii  dvdwizard                                                   0.7.1-dmo2                                  all          fully automated creation of a DVD-structure
ii  faac                                                        1:1.28-dmo5                                 amd64        AAC audio encoder.
ii  ffmpeg                                                      10:3.3.6-dmo1+deb9u1                        amd64        audio/video encoder, streaming server & audio/video file converter
ii  frei0r-plugins                                              1:1.5-dmo2                                  amd64        Minimalistic plugin API for video effects, plugins collection.
ii  gpac                                                        1:0.7.1-dmo1                                amd64        multimedia framework based on the MPEG-4 Systems standard
ii  gpac-modules-base:amd64                                     1:0.7.1-dmo1                                amd64        GPAC Project on Advanced Content - modules
ii  gstreamer1.0-libav:amd64                                    1:1.10.4-dmo1                               amd64        FFmpeg plugin for GStreamer
ii  gstreamer1.0-plugins-bad:amd64                              1:1.10.4-dmo2                               amd64        GStreamer plugins from the "bad" set
ii  gstreamer1.0-plugins-ugly:amd64                             1:1.10.4-dmo1                               amd64        GStreamer plugins from the "ugly" set
ii  gtk2-ex-formfactory-perl                                    0.67-dmo1                                   all          Makes building complex GUI's easy
ii  handbrake                                                   1:1.0.7-dmo3                                all          Versatile DVD ripper and video transcoder
ii  handbrake-cli                                               1:1.0.7-dmo3                                amd64        Versatile DVD ripper and video transcoder (command line)
ii  handbrake-gtk                                               1:1.0.7-dmo3                                amd64        Versatile DVD ripper and video transcoder (GTK GUI)
ii  imagination                                                 3.0-dmo3                                    amd64        DVD slide show maker
ii  imagination-common                                          3.0-dmo3                                    all          DVD slide show maker - common files
ii  kdenlive                                                    1:17.04.2-dmo1                              amd64        non-linear video editor
ii  kdenlive-data                                               1:17.04.2-dmo1                              all          non-linear video editor (data files)
ii  lame                                                        1:3.99.5-dmo6                               amd64        Open source MP3 encoder
ii  libaacs0:amd64                                              0.9.0-dmo1                                  amd64        free-and-libre implementation of AACS
ii  libaften0:amd64                                             0.0.8svn20100103-dmo2                       amd64        audio AC3 encoder - runtime files
ii  libasound2-plugins:amd64                                    1:1.1.4-dmo1                                amd64        ALSA library additional plugins
ii  libass9:amd64                                               2:0.13.7-dmo1                               amd64        library for SSA/ASS subtitles rendering
ii  libavcodec57:amd64                                          10:3.3.6-dmo1+deb9u1                        amd64        Library to encode decode multimedia streams - runtime files
ii  libavdevice57:amd64                                         10:3.3.6-dmo1+deb9u1                        amd64        FFmpeg library for handling input and output devices - runtime files
ii  libavfilter6:amd64                                          10:3.3.6-dmo1+deb9u1                        amd64        FFmpeg filter library
ii  libavformat57:amd64                                         10:3.3.6-dmo1+deb9u1                        amd64        FFmpeg file format library
ii  libavresample3:amd64                                        10:3.3.6-dmo1+deb9u1                        amd64        FFmpeg compatibility library for resampling - runtime files
ii  libavutil55:amd64                                           10:3.3.6-dmo1+deb9u1                        amd64        FFmpeg avutil library - runtime files
ii  libbabl-0.1-0:amd64                                         1:0.1.28-dmo1                               amd64        Dynamic, any to any, pixel format conversion library
ii  libbasicusageenvironment1                                   2:2017.04.26-dmo1                           amd64        multimedia RTSP streaming library (BasicUsageEnvironment class)
rc  libbdplus0                                                  0.1.2-dmo1+deb8u1                           amd64        BD+ library - shared library
ii  libbluray2:amd64                                            2:1.0.0-dmo1                                amd64        Blu-ray disc playback support library (shared library)
ii  libchromaprint1:amd64                                       1:1.4.2-dmo1                                amd64        Audio fingerprint library
ii  libdca0:amd64                                               0.0.5-dmo2+deb8u1                           amd64        decoding library for DTS Coherent Acoustics streams
ii  libdvbpsi10:amd64                                           1:1.3.1-dmo1                                amd64        library for MPEG TS and DVB PSI tables decoding and generating
ii  libdvdcss2:amd64                                            1.4.0-dmo1                                  amd64        Simple foundation for reading DVDs - runtime libraries
ii  libebml4v5:amd64                                            1:1.3.4-dmo1                                amd64        Access library for the EBML format (shared library)
ii  libevent-execflow-perl                                      0.64-dmo2                                   all          High level API for event-based execution flow control
ii  libfaac0:amd64                                              1:1.28-dmo5                                 amd64        AAC audio encoder - library files.
ii  libfdk-aac1:amd64                                           1:0.1.5-dmo2                                amd64        Fraunhofer FDK AAC codec library.
ii  libgegl-0.3-0:amd64                                         1:0.3.18-dmo1                               amd64        Generic Graphics Library.
ii  libgpac7:amd64                                              1:0.7.1-dmo1                                amd64        multimedia framework based on the MPEG-4 Systems standard
ii  libgroupsock8                                               2:2017.04.26-dmo1                           amd64        multimedia RTSP streaming library (network interfaces and sockets)
ii  libgstreamer-plugins-bad1.0-0:amd64                         1:1.10.4-dmo2                               amd64        GStreamer development files for libraries from the "bad" set
ii  libilbc2:amd64                                              2.0.2-dmo4                                  amd64        iLBC codec - shared library
ii  libkvazaar3:amd64                                           1:1.1.0-dmo1                                amd64        Open-source HEVC encoder - shared library
ii  liblavfile-2.1-0:amd64                                      2:2.1.0-dmo9                                amd64        MJPEG capture/editing/replay and MPEG encoding toolset (library)
ii  liblavjpeg-2.1-0:amd64                                      2:2.1.0-dmo9                                amd64        MJPEG capture/editing/replay and MPEG encoding toolset (library)
ii  liblavplay-2.1-0:amd64                                      2:2.1.0-dmo9                                amd64        MJPEG capture/editing/replay and MPEG encoding toolset (library)
ii  liblivemedia58                                              2:2017.04.26-dmo1                           amd64        multimedia RTSP streaming library
ii  libmatroska6v5:amd64                                        1:1.4.5-dmo1                                amd64        Extensible open standard audio/video container format (shared library)
ii  libmfx0:amd64                                               1.21-dmo1                                   amd64        Intel media sdk dispatcher - runtime files
ii  libmjpegutils-2.1-0:amd64                                   2:2.1.0-dmo9                                amd64        MJPEG capture/editing/replay and MPEG encoding toolset (library)
ii  libmlt++3:amd64                                             1:6.4.1-dmo3+deb9u1                         amd64        MLT multimedia framework C++ wrapper (runtime)
ii  libmlt-data                                                 1:6.4.1-dmo3+deb9u1                         all          multimedia framework (data)
ii  libmlt6:amd64                                               1:6.4.1-dmo3+deb9u1                         amd64        multimedia framework (runtime)
ii  libmovit6:amd64                                             1:1.5.1-dmo1                                amd64        OpenGL-based image processing on the GPU - devel files
ii  libmp3lame0:amd64                                           1:3.99.5-dmo6                               amd64        Shared libraries for MP3 encoding
ii  libmp4v2-2:amd64                                            2:2.0.0-dmo4                                amd64        MP4 container library - runtime files
ii  libmpeg2encpp-2.1-0:amd64                                   2:2.1.0-dmo9                                amd64        MJPEG capture/editing/replay and MPEG encoding toolset (library)
ii  libmplex2-2.1-0:amd64                                       2:2.1.0-dmo9                                amd64        MJPEG capture/editing/replay and MPEG encoding toolset (library)
ii  libnfs8:amd64                                               1.11.0-dmo1                                 amd64        NFS client library (shared library)
ii  libogmrip1:amd64                                            1.0.1-dmo9                                  amd64        Application for ripping and encoding DVD - libraries files
ii  libopenh264-2:amd64                                         1.6.0-dmo3                                  amd64        H.264 encoder/decoder from Cisco - shared library
ii  libpostproc54:amd64                                         10:3.3.6-dmo1+deb9u1                        amd64        postproc shared libraries
ii  libquicktime2:amd64                                         3:1.2.4-dmo19+deb9u1                        amd64        Library for reading and writing Quicktime files
ii  librtmp1:amd64                                              2:2.4~20160119.gitfa8646dae-dmo5            amd64        Toolkit for RTMP streams (shared library)
ii  libsuil-0-0:amd64                                           1:0.8.4-dmo1+deb9u1                         amd64        library for loading and wrapping LV2 plugin UIs (shared library)
ii  libswresample2:amd64                                        10:3.3.6-dmo1+deb9u1                        amd64        FFmpeg library for audio resampling, rematrixing etc. - runtime files
ii  libswscale4:amd64                                           10:3.3.6-dmo1+deb9u1                        amd64        FFmpeg library for image scaling and various conversions - runtime files
ii  libsynfig0v5                                                1:1.2.0-dmo1                                amd64        render library and plugins for synfig 2D animation
ii  libtwolame0:amd64                                           1:0.3.13-dmo3                               amd64        MPEG Audio Layer 2 encoding library
ii  libusageenvironment3                                        2:2017.04.26-dmo1                           amd64        multimedia RTSP streaming library (UsageEnvironment classes)
ii  libvamp-hostsdk3v5:amd64                                    1:2.7.1-dmo1                                amd64        helper library for Vamp hosts written in C++
ii  libvidstab1.0                                               2:0.98b-dmo1+deb8u1                         amd64        Video stabilization library.
ii  libvlc-bin:amd64                                            1:2.2.8-dmo1+deb9u1                         amd64        tools for VLC's base library
ii  libvlc5:amd64                                               1:2.2.8-dmo1+deb9u1                         amd64        multimedia player and streamer library
ii  libvlccore8:amd64                                           1:2.2.8-dmo1+deb9u1                         amd64        base library for VLC and its modules
ii  libx264-150:amd64                                           3:0.150.2833+gitdf79067-dmo1                amd64        x264 video coding library
ii  libx265-116:amd64                                           1:2.4-dmo1                                  amd64        x265 video coding library
ii  libxine2                                                    1:1.2.8-dmo5                                amd64        Xine media player library, meta-package (development branch)
ii  libxine2-bin:amd64                                          1:1.2.8-dmo5                                amd64        Xine video/media player library, binary files
ii  libxine2-doc                                                1:1.2.8-dmo5                                all          Xine video player library, documentation files
ii  libxine2-ffmpeg:amd64                                       1:1.2.8-dmo5                                amd64        MPEG-related plugins for libxine2
ii  libxine2-misc-plugins:amd64                                 1:1.2.8-dmo5                                amd64        Input, audio output and post plugins for libxine2
ii  libxine2-plugins                                            1:1.2.8-dmo5                                all          Xine video/media player library, meta package
ii  libxine2-x:amd64                                            1:1.2.8-dmo5                                amd64        X desktop video output plugins for libxine2
ii  libxvidcore4:amd64                                          3:1.3.4-dmo1                                amd64        High quality ISO MPEG4 codec library
ii  lxdvdrip                                                    1.77-dmo3                                   amd64        Command line tool to make a copy from a video DVD for private use.
ii  melt                                                        1:6.4.1-dmo3+deb9u1                         amd64        command line media player and video editor
ii  mencoder                                                    4:1.3.0~20170413.svn37931-dmo3+deb9u3       amd64        MPlayer's Movie Encoder
ii  mjpegtools                                                  2:2.1.0-dmo9                                amd64        MJPEG video capture/editting/playback MPEG encoding
ii  mjpegtools-gtk                                              2:2.1.0-dmo9                                amd64        MJPEG capture/editing/replay and MPEG encoding toolset (GTK+ frontend)
ii  mkvtoolnix                                                  9.8.0-dmo1                                  amd64        Set of command-line tools to work with Matroska files
ii  mplayer                                                     4:1.3.0~20170413.svn37931-dmo3+deb9u3       amd64        Ultimate Movie Player For Linux
ii  mpv                                                         1:0.27.2-dmo1+deb9u1                        amd64        Free and open-source general-purpose video player
ii  ogmrip                                                      1.0.1-dmo9                                  amd64        Application for ripping and encoding DVD
ii  ogmrip-doc                                                  1.0.1-dmo9                                  all          Application for ripping and encoding DVD - Documentation files
ii  openshot                                                    1.4.3-dmo4                                  all          Create and edit videos and movies.
ii  openshot-doc                                                1.4.3-dmo4                                  all          Help manual for OpenShot Video Editor
ii  phonon4qt5-backend-vlc:amd64                                1:0.9.1-dmo1                                amd64        Phonon4Qt5 VLC backend
ii  python-mlt                                                  1:6.4.1-dmo3+deb9u1                         amd64        multimedia framework (python bindings)
ii  rtmpdump                                                    2:2.4~20160119.gitfa8646dae-dmo5            amd64        Small dumper for media content streamed over the RTMP protocol
ii  subtitleripper                                              0.5.2-dmo3                                  amd64        DVD Subtitle Ripper for Linux
ii  synfig-examples                                             1:1.2.0-dmo1                                all          synfig animation examples
ii  synfigstudio                                                1:1.2.0-dmo1                                amd64        vector-based 2D animation package (graphical user interface)
ii  transcode                                                   4:1.1.7-dmo15                               amd64        Utility to encode raw video/audio streams
ii  transcode-doc                                               4:1.1.7-dmo15                               all          Documentation for transcode
ii  transcode-utils                                             4:1.1.7-dmo15                               amd64        Utility to encode raw video/audio streams
ii  twolame                                                     1:0.3.13-dmo3                               amd64        MPEG Audio Layer 2 encoder (command line frontend)
ii  vlc                                                         1:2.2.8-dmo1+deb9u1                         amd64        multimedia player and streamer
ii  vlc-bin                                                     1:2.2.8-dmo1+deb9u1                         amd64        binaries from VLC
ii  vlc-data                                                    1:2.2.8-dmo1+deb9u1                         all          Common data for VLC
ii  vlc-l10n                                                    1:2.2.8-dmo1+deb9u1                         all          Translations for VLC
ii  vlc-plugin-base:amd64                                       1:2.2.8-dmo1+deb9u1                         amd64        multimedia player and streamer (base plugins)
ii  vlc-plugin-notify:amd64                                     1:2.2.8-dmo1+deb9u1                         amd64        LibNotify plugin for VLC
ii  vlc-plugin-qt:amd64                                         1:2.2.8-dmo1+deb9u1                         amd64        multimedia player and streamer (Qt plugin)
ii  vlc-plugin-samba:amd64                                      1:2.2.8-dmo1+deb9u1                         amd64        Samba plugin for VLC
ii  vlc-plugin-skins2:amd64                                     1:2.2.8-dmo1+deb9u1                         amd64        multimedia player and streamer (Skins2 plugin)
ii  vlc-plugin-video-output:amd64                               1:2.2.8-dmo1+deb9u1                         amd64        multimedia player and streamer (video output plugins)
ii  vlc-plugin-video-splitter:amd64                             1:2.2.8-dmo1+deb9u1                         amd64        multimedia player and streamer (video splitter plugins)
ii  vlc-plugin-visualization:amd64                              1:2.2.8-dmo1+deb9u1                         amd64        multimedia player and streamer (visualization plugins)
ii  xine-ui  



Et vlan !devart-stupidme2.gif

Peut on faire "commuter" je crois que c'est le terme, les paquets du dépôt Multimedia vers Stable, enfin Stretch ?
Ou alors désinstaller à la main > désactiver Multimedia > réinstaller depuis les dépôts principaux de Stable ?

J'ai fait la MAJ depuis le dépôt Multimedia. Je ne note aucune difficulté ou dysfonctionnement pour le moment.

jce76350 a écrit :

si ça vient de libgstreamer-plugins-bad1.0-0 qui bloque il y des posts sur
https://lists.debian.org/debian-user-fr … 00285.html

la solution est la
https://lists.debian.org/debian-user-fr … 00293.html


merci. Mais du coup plus de problème en faisant la MAJ depuis le dépôt multimedia.
la solution semble est décrite en bas :

avec l'aide christian Marillat j'ai supprimé les paquet
en ligne de commande :

dpkg -P gstreamer1.0-gl libgstreamer-gl1.0-0 gstreamer1.0-plugins-bad

et puis j'ai fait un apt-get -f install et tout est rentré dans l'ordre

merci pour avoir éclairé ma lanterne



christian Marillat est le mainteneur (seul ??) du dépôt Multimedia.

merci

Dernière modification par Tristan07 (26-03-2018 13:12:33)


Debian Stable est ce qui rend la vie plus intéressante que l'informatique ( voir Robert Filliou pour l'origine de cette citation smile
Debian c'est pas difficile ! zen.gif
https://lescahiersdudebutant.fr/
Pour une aide efficace sur le forum : https://debian-facile.org/viewtopic.php?id=13352

Hors ligne

#12 26-03-2018 13:32:38

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.2.0-3 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : Résolu -Mise à jour et dépendances logiciels, quelle attitude adopter?

salut

tristan07 a écrit :

quelle méthode pratiquez-vous ? / conseillez-vous ? outre le choix orthodoxe qui serait de ne pas utiliser le dépôt multimédia wink



en effet , en cas  d'utilisation du dépôt multimédia , le fichier de pinning me semble nécessaire .

même vital .

il te bloquera toute installation depuis ce dépôt , sauf à moins de faire un

apt -s -t stable install xxxx


pour le  -t , je suis sûr , moins pour le "-t stable"  . -s : simulation

chez moi , avec le fichier préférences :

$ apt policy


Fichiers du paquet :
100 /var/lib/dpkg/status
     release a=now
100 http://www.deb-multimedia.org testing/non-free i386 Packages
     release v=0.0,o=Unofficial Multimedia Packages,a=testing,n=buster,l=Unofficial Multimedia Packages,c=non-free,b=i386
     origin www.deb-multimedia.org
100 http://www.deb-multimedia.org testing/non-free amd64 Packages
     release v=0.0,o=Unofficial Multimedia Packages,a=testing,n=buster,l=Unofficial Multimedia Packages,c=non-free,b=amd64
     origin www.deb-multimedia.org
100 http://www.deb-multimedia.org testing/main i386 Packages
     release v=0.0,o=Unofficial Multimedia Packages,a=testing,n=buster,l=Unofficial Multimedia Packages,c=main,b=i386
     origin www.deb-multimedia.org
100 http://www.deb-multimedia.org testing/main amd64 Packages
     release v=0.0,o=Unofficial Multimedia Packages,a=testing,n=buster,l=Unofficial Multimedia Packages,c=main,b=amd64
     origin www.deb-multimedia.org
  1 http://ftp.fr.debian.org/debian experimental/non-free i386 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=non-free,b=i386
     origin ftp.fr.debian.org
  1 http://ftp.fr.debian.org/debian experimental/non-free amd64 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=non-free,b=amd64
     origin ftp.fr.debian.org
  1 http://ftp.fr.debian.org/debian experimental/contrib i386 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=contrib,b=i386
     origin ftp.fr.debian.org
  1 http://ftp.fr.debian.org/debian experimental/contrib amd64 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=contrib,b=amd64
     origin ftp.fr.debian.org
  1 http://ftp.fr.debian.org/debian experimental/main i386 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=main,b=i386
     origin ftp.fr.debian.org
  1 http://ftp.fr.debian.org/debian experimental/main amd64 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=main,b=amd64
     origin ftp.fr.debian.org
100 http://ftp.fr.debian.org/debian unstable/non-free i386 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=non-free,b=i386
     origin ftp.fr.debian.org
100 http://ftp.fr.debian.org/debian unstable/non-free amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=non-free,b=amd64
     origin ftp.fr.debian.org
100 http://ftp.fr.debian.org/debian unstable/contrib i386 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=contrib,b=i386
     origin ftp.fr.debian.org
100 http://ftp.fr.debian.org/debian unstable/contrib amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=contrib,b=amd64
     origin ftp.fr.debian.org
100 http://ftp.fr.debian.org/debian unstable/main i386 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=main,b=i386
     origin ftp.fr.debian.org
100 http://ftp.fr.debian.org/debian unstable/main amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=main,b=amd64
     origin ftp.fr.debian.org
500 http://ftp.fr.debian.org/debian testing/non-free i386 Packages
     release o=Debian,a=testing,n=buster,l=Debian,c=non-free,b=i386
     origin ftp.fr.debian.org
500 http://ftp.fr.debian.org/debian testing/non-free amd64 Packages
     release o=Debian,a=testing,n=buster,l=Debian,c=non-free,b=amd64
     origin ftp.fr.debian.org
500 http://ftp.fr.debian.org/debian testing/contrib i386 Packages
     release o=Debian,a=testing,n=buster,l=Debian,c=contrib,b=i386
     origin ftp.fr.debian.org
500 http://ftp.fr.debian.org/debian testing/contrib amd64 Packages
     release o=Debian,a=testing,n=buster,l=Debian,c=contrib,b=amd64
     origin ftp.fr.debian.org
500 http://ftp.fr.debian.org/debian testing/main i386 Packages
     release o=Debian,a=testing,n=buster,l=Debian,c=main,b=i386
     origin ftp.fr.debian.org
500 http://ftp.fr.debian.org/debian testing/main amd64 Packages
     release o=Debian,a=testing,n=buster,l=Debian,c=main,b=amd64
     origin ftp.fr.debian.org
Paquets épinglés :
 



dans mon cas il faut taper

apt -s -t 0.0 install avidemux


ou

apt -s -t buster install avidemux


je rappelle : -s : simulation

pour nettoyer ta distrib des paquets dmo , voilà le lien :

attention , tu vas perdre flash et avidemux . pour ceux là , je sais que c'est le cas .

en gros , le lien retire les paquets "dmo" et installe les mêmes en paquets officiels :

remplacer les paquets dmo

Dernière modification par Debian Alain (26-03-2018 13:45:50)


1498812139.jpg Nightwish - Last Ride Of The Day (With Lyrics)
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

Hors ligne

#13 26-03-2018 13:43:07

Tristan07
Adhérent(e)
Distrib. : Debian 9, Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : Gnome 3.22
Inscription : 21-05-2016
Site Web

Re : Résolu -Mise à jour et dépendances logiciels, quelle attitude adopter?

en effet , en cas  d'utilisation du dépôt multimédia , le fichier de pinning me semble nécessaire .


Ce qui veut dire que quoi qu'il en soit on aura un message identique à ce post indiquant les MAJ posible via le dépôt Multimedia mais "contenues" par nos préférences ?

Je vais chercher un peu et attendre d'autres retours !
Merci Debian Alain !


Debian Stable est ce qui rend la vie plus intéressante que l'informatique ( voir Robert Filliou pour l'origine de cette citation smile
Debian c'est pas difficile ! zen.gif
https://lescahiersdudebutant.fr/
Pour une aide efficace sur le forum : https://debian-facile.org/viewtopic.php?id=13352

Hors ligne

#14 26-03-2018 13:56:07

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.2.0-3 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : Résolu -Mise à jour et dépendances logiciels, quelle attitude adopter?

comment dire ? ,

la commande que je t'ai postée (apt policy)

https://debian-facile.org/doc:systeme:apt:pinning

donne le détail des priorités affectées à chaque entrée du sources list.

après , selon mon exemple , tu as le choix .

soit :

apt install ...

qui installera les paquets  dont les liens sont supérieurs ou égaux à 500
savoir , dans mon cas , les paquets de buster .

ou

apt -t buster (ou 0.0) install ...

qui installera les paquets de "deb-multimedia"

par contre

apt -t experimental install ...

installera les paquets d'expérimental  .

et

apt -t unstable install

installera les paquets de sid

voilà mon fichier préférences :

$ cat /etc/apt/preferences.d/distribution.pref


Package: *
Pin: release a=unstable
Pin-Priority: 100

Package: *
Pin: release o=Unofficial Multimedia Packages,a=testing
Pin-Priority: 100
 



dans le cas présent , tu ne copies pas les lignes de "unstable"  et tu remplaces , dans ton fichier préférences a=testing par a=stable

si ça réponds plus à ta question :

$ sudo apt update



[sudo] Mot de passe de alain : 
Réception de:1 http://ftp.fr.debian.org/debian testing InRelease [142 kB]
Atteint:2 http://security.debian.org/debian-security testing/updates InRelease
Réception de:3 http://www.deb-multimedia.org testing InRelease [22,1 kB]      
Réception de:4 http://ftp.fr.debian.org/debian testing-updates InRelease [46,0 kB]
Réception de:5 http://ftp.fr.debian.org/debian unstable InRelease [241 kB]
Réception de:6 http://ftp.fr.debian.org/debian experimental InRelease [107 kB]
Réception de:7 http://www.deb-multimedia.org testing/main i386 Packages [153 kB]
Réception de:8 http://www.deb-multimedia.org testing/main amd64 Packages [154 kB]
Réception de:9 http://ftp.fr.debian.org/debian testing/main Sources.diff/Index [27,9 kB]
Réception de:10 http://ftp.fr.debian.org/debian testing/main Sources 2018-03-26-0819.44.pdiff [112 B]
Réception de:10 http://ftp.fr.debian.org/debian testing/main Sources 2018-03-26-0819.44.pdiff [112 B]
Réception de:11 http://ftp.fr.debian.org/debian unstable/main Sources.diff/Index [27,9 kB]
Réception de:12 http://ftp.fr.debian.org/debian unstable/main i386 Packages.diff/Index [27,9 kB]
Réception de:13 http://ftp.fr.debian.org/debian unstable/main amd64 Packages.diff/Index [27,9 kB]
Réception de:14 http://ftp.fr.debian.org/debian experimental/main Sources.diff/Index [27,8 kB]
Réception de:15 http://ftp.fr.debian.org/debian experimental/main amd64 Packages.diff/Index [27,8 kB]
Réception de:16 http://ftp.fr.debian.org/debian experimental/contrib amd64 Packages.diff/Index [27,8 kB]
Réception de:17 http://ftp.fr.debian.org/debian unstable/main Sources 2018-03-26-0819.44.pdiff [2965 B]
Réception de:17 http://ftp.fr.debian.org/debian unstable/main Sources 2018-03-26-0819.44.pdiff [2965 B]
Réception de:18 http://ftp.fr.debian.org/debian unstable/main i386 Packages 2018-03-26-0819.44.pdiff [2565 B]
Réception de:18 http://ftp.fr.debian.org/debian unstable/main i386 Packages 2018-03-26-0819.44.pdiff [2565 B]
Réception de:19 http://ftp.fr.debian.org/debian unstable/main amd64 Packages 2018-03-26-0819.44.pdiff [2114 B]
Réception de:19 http://ftp.fr.debian.org/debian unstable/main amd64 Packages 2018-03-26-0819.44.pdiff [2114 B]
Réception de:20 http://ftp.fr.debian.org/debian experimental/main Sources 2018-03-26-0819.44.pdiff [61 B]
Réception de:20 http://ftp.fr.debian.org/debian experimental/main Sources 2018-03-26-0819.44.pdiff [61 B]
Réception de:21 http://ftp.fr.debian.org/debian experimental/main amd64 Packages 2018-03-26-0819.44.pdiff [1281 B]
Réception de:21 http://ftp.fr.debian.org/debian experimental/main amd64 Packages 2018-03-26-0819.44.pdiff [1281 B]
Réception de:22 http://ftp.fr.debian.org/debian experimental/contrib amd64 Packages 2018-03-26-0819.44.pdiff [257 B]
Réception de:22 http://ftp.fr.debian.org/debian experimental/contrib amd64 Packages 2018-03-26-0819.44.pdiff [257 B]
1070 ko réceptionnés en 4s (282 ko/s)                                        
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
4 paquets peuvent être mis à jour. Exécutez « apt list --upgradable » pour les voir.
alain@Alain-PC-BUSTER:~$
 

Dernière modification par Debian Alain (26-03-2018 16:57:28)


1498812139.jpg Nightwish - Last Ride Of The Day (With Lyrics)
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

Hors ligne

#15 26-03-2018 14:32:24

Tristan07
Adhérent(e)
Distrib. : Debian 9, Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : Gnome 3.22
Inscription : 21-05-2016
Site Web

Re : Résolu -Mise à jour et dépendances logiciels, quelle attitude adopter?

Oui merci. J'avais placé un fichier de préférences comme indiqué dans le Wiki :

   

Package: *
    Pin: release o=Unofficial Multimedia Packages,a=stable
    Pin-Priority: 100



Pour le lien donné vers la résolution des DMO, j'avoue bloquer ici

rmfiles=$(dpkg -l | grep dmo | awk '{print $2}')

Check the contents of $rmfiles and make sure it is correct. (Use echo $rmfiles so check the contents.) Highly recommended: I also copied the list of packages to a text file so that I had a permanent record of what I was removing, in case I needed to reverse myself.

4. Remove the dmo packages. Since apt wants to remove a lot of packages which depend on the dmo packages , some of which will break Mint if removed, use dpkg to force the removal of only the dmo packages.

Code: Select all

sudo dpkg -P --force-depends $rmfiles


jet il s'agit de LMDE, bien que les dépôts soient similaires, je préfère éventuellement une Doc pour Debian ...
ici on parle de rétrograder vers Stable en "simplement" en accordant un fichier préférences APT
http://giantdorks.org/alain/switching-f … -versions/
mais encore une fois je préfère attendre un peu. J'imagine que cela peut aussi se faire à la main via synaptic ?

Quelqu'un utilise t-il ici le dépôt Multimedia activé sans pinning ? Depuis longtemps sous Debian ?
Est-ce si problématique ? (en dehors du discours orthodoxe ...)

Dernière modification par Tristan07 (26-03-2018 14:36:40)


Debian Stable est ce qui rend la vie plus intéressante que l'informatique ( voir Robert Filliou pour l'origine de cette citation smile
Debian c'est pas difficile ! zen.gif
https://lescahiersdudebutant.fr/
Pour une aide efficace sur le forum : https://debian-facile.org/viewtopic.php?id=13352

Hors ligne

#16 26-03-2018 14:41:49

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.2.0-3 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : Résolu -Mise à jour et dépendances logiciels, quelle attitude adopter?

ben vas y cherche , si tu trouves tu nous en parles .

je n'ai trouvé que celle là .

et pour l'avoir essayée , je peux te la garantir  100% efficace .

suis scrupuleusement les lignes de commande et les  conseils .

tu auras un souci au dernier point , le no 7.

comme c'est une commande pour mint , le résultat n'est pas très heureux sous debian.

mais si tu as bien tout suivi et tout compris , tu n'es pas obligé de l'executer .

n'oublie pas , comme demandé , de commenter ou décommenter  ta ligne de deb-multimédia dans ton sources.list .

avec # : commenté     : comme si on retirait la ligne du sources.list
sans # : décommenté : comme si on inscrivait la ligne dans le sources.list

si tu doutes  de toi , reviens ici , j'essaierai de te donner la marche à suivre étape par  étape .

en me basant sur ce post .

Dernière modification par Debian Alain (26-03-2018 14:47:06)


1498812139.jpg Nightwish - Last Ride Of The Day (With Lyrics)
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

Hors ligne

#17 26-03-2018 14:50:05

Tristan07
Adhérent(e)
Distrib. : Debian 9, Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : Gnome 3.22
Inscription : 21-05-2016
Site Web

Re : Résolu -Mise à jour et dépendances logiciels, quelle attitude adopter?

avec # : commenté     : comme si on retirait la ligne du sources.list
sans # : décommenté : comme si on inscrivait la ligne dans le sources.list



Oui, merci Debian Alain. Je ne suis pas aguerri comme tu l'es, mais quand même ... 
slinky__by_cookiemagik-d38uoah.gif

Je sauvegarde mes données avant d'essayer mais une question si tu permets :
il est indiqué :

Once you've reviewed the list and made sure it contains all dmo packages and only dmo packages, assign it to a bash variable to save a lot of typing later:


est-ce que c'est cette commande qui s'en charge seule de créer le "bash" ?

rmfiles=$(dpkg -l | grep dmo | awk '{print $2}')


Debian Stable est ce qui rend la vie plus intéressante que l'informatique ( voir Robert Filliou pour l'origine de cette citation smile
Debian c'est pas difficile ! zen.gif
https://lescahiersdudebutant.fr/
Pour une aide efficace sur le forum : https://debian-facile.org/viewtopic.php?id=13352

Hors ligne

#18 26-03-2018 14:55:00

Tristan07
Adhérent(e)
Distrib. : Debian 9, Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : Gnome 3.22
Inscription : 21-05-2016
Site Web

Re : Résolu -Mise à jour et dépendances logiciels, quelle attitude adopter?

tu auras un souci au dernier point , le no 7.

comme c'est une commande pour mint , le résultat n'est pas très heureux sous debian.


Il s'agit pour beaucoup des librairies permettant la lecture des formats non-free. Ce ne sont sans doute pas les mêmes ...


Debian Stable est ce qui rend la vie plus intéressante que l'informatique ( voir Robert Filliou pour l'origine de cette citation smile
Debian c'est pas difficile ! zen.gif
https://lescahiersdudebutant.fr/
Pour une aide efficace sur le forum : https://debian-facile.org/viewtopic.php?id=13352

Hors ligne

#19 26-03-2018 15:04:02

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.2.0-3 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : Résolu -Mise à jour et dépendances logiciels, quelle attitude adopter?

avec # : commenté     : comme si on retirait la ligne du sources.list
sans # : décommenté : comme si on inscrivait la ligne dans le sources.list




Oui, merci Debian Alain. Je ne suis pas aguerri comme tu l'es, mais quand même ...


oh non , dis pas ça ...

pardon tristan . excuse moi .
loin de moi l'idée de te prendre pour une buse ...

mais comme parfois on utilise des mots abscons ...


rmfiles=$(dpkg -l | grep dmo | awk '{print $2}')



si je me trompe pas , le but de la commande est de stocker dans une variable temporaire en mémoire le listing des paquets dmo .

normalement , c'est ce qu'elle fait .

mémoire qu'elle utilise peu après  pour réinstaller les même paquets mais .... en debian (mint dans l'exemple)

en ayant au préalable chargé dans l'utilisateur courant le contenu de la variable mémoire.

sudo dpkg -P --force-depends $rmfiles


charge en mémoire utilisateur le contenu de $rmfiles pour effacement



sudo apt-get update


met à jour le systeme préalablement configuré avec $rmfiles . donc aussi ,efface les paquets dmo

.

sudo apt-get install -f


installe les paquets listés dans $rmfiles

.

ne pas oublier de taper la ligne 7 et c'est fini , tout est ok

sudo apt-get install gstreamer1.0-libav libaacs0 libaudclient2 libchromaprint0 libdca0 libfaac0 libgegl-0.2-0 libhal1-flash libmjpegutils-2.1-0 libmp3lame0 libmpeg2encpp-2.1-0 libmplex2-2.1-0 librtmp1 libvamp-hostsdk3 libxvidcore4 libbasicusageenvironment0 libdvbpsi9 libavcodec56 libavfilter5 libavformat56 libavresample2 libavutil54 libbluray1 libebml4 libmatroska6 libswscale3


il y aura des erreurs mais c'est pas grave . n'en tiens pas compte .

Dernière modification par Debian Alain (01-04-2018 11:08:14)


1498812139.jpg Nightwish - Last Ride Of The Day (With Lyrics)
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

Hors ligne

#20 26-03-2018 15:23:45

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.2.0-3 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : Résolu -Mise à jour et dépendances logiciels, quelle attitude adopter?

tristan07 a écrit :


alain a écrit :

tu auras un souci au dernier point , le no 7.

comme c'est une commande pour mint , le résultat n'est pas très heureux sous debian.



Il s'agit pour beaucoup des librairies permettant la lecture des formats non-free. Ce ne sont sans doute pas les mêmes ...



en effet

tristan07 a écrit :

Quelqu'un utilise t-il ici le dépôt Multimedia activé sans pinning ? Depuis longtemps sous Debian ?
Est-ce si problématique ? (en dehors du discours orthodoxe ...)



https://linuxfr.org/news/attention-au-d … imedia-org

Dernière modification par Debian Alain (26-03-2018 17:04:52)


1498812139.jpg Nightwish - Last Ride Of The Day (With Lyrics)
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

Hors ligne

#21 26-03-2018 19:54:00

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : Résolu -Mise à jour et dépendances logiciels, quelle attitude adopter?

Tristan07 a écrit :

Ais-je jouer à la roulette russe en désactivant le fichier 50multimedia ?


Bon, c'est ton choix wink
Tu as la possibilité de garder en l'état en sachant que si un jour tu as un souci pour mettre à jour ou installer un paquet, il est probable qu'il soit lié au dépôt multimedia.
Ou bien tu remets le fichier de priorités puis tu désinstalles les paquets qui sont à la fois dans les dépôts officiels et dans le dépôt deb-multimedia  si la version des dépôts officiels te suffit (par exemple pour vlc...)
avidemux, tu ne le retrouveras pas dans les dépôts officiels tongue ce n'est pas comme pour linuxmint qui le propose peut-être.
Comme tu as carrément fait la mise à jour avec ce dépôt d'égale priorité aux dépôts officiels, ça fait plus de paquets que si tu avais regardé et désinstallé juste ce qui bloquait au début du fil.
à toi de voir wink

Edit : @debian-alain le lien https://linuxfr.org/news/attention-au-d … imedia-org n'a rien à voir avec l'adresse actuel du dépôt https://deb-multimedia.org/
ça dit juste aux anciens utilisateurs (avant whezzy je crois roll ) qu'il ne faut pas rester avec l'adresse debian-multimedia.org qui a été rachetée par quelqu'un qui n'a rien à voir avec Christian Marillat, ce dernier s'est occupé de ce dépôt et l'a transféré à l'adresse deb-multimedia.org wink
ce qui fait problème, ce n'est pas tant la sécurité du dépôt que le fait qu'aujourd'hui un certain nombre de paquets sont en doublon d'une version existante dans les dépôts officiels (cas de vlc par exemple ou audacity ...). Au départ il n'y avait pas ces doublons et donc pas de risque de schmilblick entre les dépôts big_smile


Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#22 26-03-2018 21:43:18

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.2.0-3 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : Résolu -Mise à jour et dépendances logiciels, quelle attitude adopter?

salut ,

je vais aller dans le sens de chalu .

mettre en place un fichier préférences  , ce n'est pas jouer à la roulette russe .
au contraire .
c'est ajouter une sécurité sur son systeme .

c'est , dans le cas présent , ne pas mettre de fichier préférences qui revient à jouer à la roulette russe .

maintenant , tu fais comme tu veux , c'est ton systeme .
tu peux très bien le garder fonctionnel longtemps comme le planter dans une semaine ou moins .

et réinstaller un systeme complet , c'est laborieux . ça prend du temps .

tu as tous les outils en mains , à toi de  choisir ....

chalu a écrit :

Edit : @debian-alain le lien https://linuxfr.org/news/attention-au-d … imedia-org n'a rien à voir avec l'adresse actuel du dépôt https://deb-multimedia.org/
ça dit juste aux anciens utilisateurs (avant whezzy je crois roll ) qu'il ne faut pas rester avec l'adresse debian-multimedia.org qui a été rachetée par quelqu'un qui n'a rien à voir avec Christian Marillat, ce dernier s'est occupé de ce dépôt et l'a transféré à l'adresse deb-multimedia.org wink
ce qui fait problème, ce n'est pas tant la sécurité du dépôt que le fait qu'aujourd'hui un certain nombre de paquets sont en doublon d'une version existante dans les dépôts officiels (cas de vlc par exemple ou audacity ...). Au départ il n'y avait pas ces doublons et donc pas de risque de schmilblick entre les dépôts big_smile


merci , savais pas .

on package duplication between Debian and debian-multimedia a écrit :


Cher Christian,
  comme vous le savez probablement, il y a des discussions récurrentes sur le site Web de la
duplication de paquets entre l'archive officielle de Debian et l'archive officielle de Debian.
debian-multimedia.org ("d-m.o" à partir de maintenant) que vous maintenez.

AFAIK, l'équipe Debian en charge de la maintenance des paquets multimédia.
(que je suis Cc:-ing) n'est pas heureux au sujet de la duplication et a approché
vous à ce sujet[1], en fournissant des preuves des difficultés qu'il a rencontrées dans le cadre d'un projet de loi sur l'accès à l'information et la protection de la vie privée.
des causes pour eux et pour les utilisateurs de Debian qui utilisent aussi d-m.o. OTOH.
Je suis sûr que vous maintenez d-m.o pour fournir un service utile à Debian.
lorsque certains des paquets que vous distribuez ne sont pas disponibles dans le format
Debian proprement dite.

[1] http://lists.alioth.debian.org/pipermai … 25498.html

Personnellement, je pense que ce principe est très bien, mais je m'inquiète au sujet du...
partie duplication. Non seulement en raison des problèmes qu'il pourrait causer à
mais aussi pour le gaspillage apparent des énergies de maintenance. Energies
qui pourrait être mieux utilisé si vous et l'équipe pkg-multimédia.
pourrait trouver un moyen de collaborer et de contribuer ainsi à la réalisation de l'objectif de la
empaquetage officiel* Debian du logiciel concerné.

Je n'ai pas d'opinion spécifique sur les revendications techniques que d-m.o. cause.
des problèmes avec les paquets Debian officiels. C'est peut-être vrai ou pas. Idem
pour vos allégations de conflit d'intérêts dans le maintien de l'intégrité de l'organisme.
ffmpeg ou libav dans Debian. Mais j'observe que *dans* Debian, nous avons
des mécanismes pour résoudre ce genre de problèmes, le cas échéant. Tant que
comme vous continuez à faire votre travail à l'extérieur de Debian au lieu d'élever le niveau de votre
dans Debian, nous devrons continuer à supposer que ce qui est le plus important dans Debian.
qui se fait dans Debian est très bien et a droit au statut officiel qui est le suivant
viennent avec le nom "Debian".

En y réfléchissant, je pense que nous devrions choisir l'une des deux voies possibles...
en avant :

1) Vous et l'équipe pkg-multimédia s'entendent sur les points suivants
   qui-packages-belong-welong-where. L'une des façons de régler ce problème serait que pour
   tous les paquets qui existent dans l'archive officielle de Debian, les mêmes que ceux qui se trouvent dans l'archive officielle de Debian.
   ne devrait pas exister dans d-m.o, à moins qu'il n'ait une version qui n'existe pas.
   ne pas interférer avec les paquets officiels dans Debian " standard ".
   installations. Une autre façon serait de renommer les paquets et les noms de fils.

   Je crois comprendre que de tels accords donneraient une sorte d'"avantage" aux pays membres de l'Union européenne.
   les gens de pkg-multimédia sur d-m.o, mais cela semble justifié.
   par le fait qu'ils s'occupent de l'emballage officiel, alors que vous êtes...
   pas.  Si, comme je l'espère, vous pouvez commencer à faire votre travail d'emballage.
   (dans la mesure du possible) au sein de Debian aussi, les choses seraient différentes.
   et nous pourrions envisager de résoudre des conflits techniques potentiels dans le cadre de l'initiative de la
   comme d'habitude dans Debian.

2) Vous cessez d'utiliser "debian" comme partie intégrante du nom de domaine de votre nom de domaine.
   ce qui est déroutant pour les utilisateurs (p. ex.[2,3]). Cela permettrait
   permettre à chaque partie de continuer à faire ce qu'ils veulent en termes de
   l'emballage, mais au moins éliminerait tous les doutes existants.
   sur le statut officiel de D.M.O.


   [2] http://bugs.debian.org/cgi-bin/bugrepor … =660924#20
   [3] http://bugs.debian.org/cgi-bin/bugrepor … =668308#47

  J'imagine que ce serait une étape douloureuse pour vous, compte tenu de la...
   nom de domaine bien établi. Mais il semble juste de vous demander de le faire.
   si nous n'arrivions pas à trouver un accord entre vous et l'Assemblée de l
   l'initiative officielle d'empaquetage Debian des logiciels que vous maintenez.
   dans un dépôt non officiel.

Nous pourrions également envisager diverses solutions intermédiaires, telles que l'ajout de
des avis de non-responsabilité bien en évidence sur votre site web expliquant que votre
n'est pas affiliée au projet Debian, afin qu'elle puisse
causent des incompatibilités techniques avec les paquets officiels, et que l'on ne peut pas les utiliser avec les paquets officiels, et que l'on ne peut pas les utiliser.
les dons que vous recueillez sont pour vous personnellement et non pas pour l'organisme de bienfaisance.
Projet Debian.

J'espère que nous parviendrons à un accord sur (quelques variantes du) point (1). Je suis
personnellement convaincu que d-m.o pourrait offrir un service très utile à Debian.
pour les paquets qui ne font pas partie de l'archive officielle. Mais d-m.o.d.
doit vraiment le faire d'une manière qui n'entrave pas le travail des officiels.
d'emballage, faute de quoi il restera une source pérenne d'émissions de
au détriment des deux parties.

Qu'en pensez-vous ?

Santé.

PS : nous voulons vraiment que cette discussion soit publique, alors s'il vous plaît, gardez l'icône
   pkg-multimedia-maintainers list Cc:-ed, comme demandé avec mon M-F-T-T M-F-T
   en-tête. Sinon, je prendrai la liberté de transmettre vos réponses à l'adresse suivante
   la liste moi-même.
--
Stefano Zacchiroli zack@{upsilon.cc,pps.jussieu.fr,debian.org}... o .
Maître de conférences ..................................................................................................................................................................................................... . o
Le chef du projet Debian ............ @zack sur identi.ca.......... o o o o o o o
"la première règle du club de tautologie est la première règle du club de tautologie ".
-------------------------- partie suivante -----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Une pièce jointe non textuelle a été frottée.....
Nom : signature.asc
Type : application/signaturepgp-signature
Taille : 828 octets
Desc : Signature numérique
URL : <http://lists.alioth.debian.org/pipermai … hment.pgp>>http://lists.alioth.debian.org/pipermail/pkg-multimedia-maintainers/attachments/20120505/1b2fda85/attachment.pgp

Dernière modification par Debian Alain (26-03-2018 22:28:30)


1498812139.jpg Nightwish - Last Ride Of The Day (With Lyrics)
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

Hors ligne

#23 26-03-2018 23:08:13

Tristan07
Adhérent(e)
Distrib. : Debian 9, Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : Gnome 3.22
Inscription : 21-05-2016
Site Web

Re : Résolu -Mise à jour et dépendances logiciels, quelle attitude adopter?

Salut et merci pour votre aide à tous.

Résumé de ce qui a été fait :

J'ai suivi aussi scrupuleusement que possible le tuto que Debian Alain donne au post #12. ça fonctionne plutôt pas mal. à condition d'être vigilent. Comme recommandé j'ai listé les DMO dans un fichier texte avant et après la procédure, seulement, je n'avais pas vu qu'une partie de Gnome fut désinstallée
> au reboot plus d'interface graphique. Pas grave, je réinstalle task-gnome-desktop et hop nous revoilà !
Mais comme j'aime bien les choses bien faite surtout quand je ne suis pas ultra calé pour prévenir d'éventuelles manques, j'ai réinstallé mon système.
Donc voici une Debian toute fraîche et clairement en stable sans le dépôt Multimedia installé. Le tout est de véritablement mesurer la nécessité de l'utiliser. Si pour la production des   cours notamment je me retrouve avec des lectures de formats impossible ou autre, alors on verra si j'active ou pas avec un fichier préférences.
Si tout est ok sans (ce que je souhaite), alors vade retro Multimedia !
Mon fichier sources.list est donc à présent des plus classique :

deb http://deb.debian.org/debian/ stretch main contrib non-free
deb-src http://deb.debian.org/debian/ stretch main contrib non-free

deb http://security.debian.org/debian-security stretch/updates main contrib non-free
deb-src http://security.debian.org/debian-security stretch/updates main contrib non-free

# stretch-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
deb-src http://deb.debian.org/debian/ stretch-updates main contrib non-free


cheerplz.gif

Avec les App Images, l'on peut très bien disposer de logiciels telles que Avidemux facilement et sans avoir à disposer d'un dépôt "chaud patate" !
Debian pour un système Stable longue durée sans me soucier trop de bidouiller ceci et cela, telle fut l'une de mes motivations essentielles... Les autres furent de m'approcher au plus près des valeurs véhiculées par le Logiciel Libre.
J'aviserai à la longue si mes besoins / nécessités changent d'ici là ...

Encore merci !

Dernière modification par Tristan07 (26-03-2018 23:43:46)


Debian Stable est ce qui rend la vie plus intéressante que l'informatique ( voir Robert Filliou pour l'origine de cette citation smile
Debian c'est pas difficile ! zen.gif
https://lescahiersdudebutant.fr/
Pour une aide efficace sur le forum : https://debian-facile.org/viewtopic.php?id=13352

Hors ligne

#24 27-03-2018 10:25:33

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.2.0-3 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : Résolu -Mise à jour et dépendances logiciels, quelle attitude adopter?

salut tristan ,

c'est surtout nous qui te remercions de faire confiance à debian et encore plus à l'équipe  D-F et aux contributeurs .

afin de  prévenir d'éventuelles installations futures du dépôt multimédia ,

je te conseille quand même d'installer un fichier préférences .

ça mange pas de pain et c'est une précaution pour pljus tard .

je suis quand même très peiné  que tu aies dû réinstaller ton systeme .

je ne me l'explique pas .

ou alors le dépôt deb-multimedia a vraiment corrompu ta machine.

quelle tristesse .

quoiqu'il en soit : je te souhaite quand même un bon séjour au pays du libre et a fortiori , ici .

nb: pour les appimages , je ne suis pas aussi sûr que toi .

toutes ne fonctionnent pas aussi bien que ça .

Dernière modification par Debian Alain (27-03-2018 10:34:54)


1498812139.jpg Nightwish - Last Ride Of The Day (With Lyrics)
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

Hors ligne

#25 27-03-2018 12:27:09

Tristan07
Adhérent(e)
Distrib. : Debian 9, Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : Gnome 3.22
Inscription : 21-05-2016
Site Web

Re : Résolu -Mise à jour et dépendances logiciels, quelle attitude adopter?

je te conseille quand même d'installer un fichier préférences .

ça mange pas de pain et c'est une précaution pour pljus tard .

je suis quand même très peiné  que tu aies dû réinstaller ton systeme .

je ne me l'explique pas .



salut Debian Alain !
Merci pour ta sollicitude, vraiment ...
Pour le fichier pref, même si c'est fait en 2 temps 3 mouvements, je ferai plus tard, là je peaufine mes installations car quitte à faire clean, autant le faire partout.
Concernant la réinstallation, franchement en faisant les bons back up c'est assez rapide sous Gnome. Et puis cela fonctionnait en fait, même très bien. C'est moi qui ai voulu repartir de zéro pour y voir plus clair...

nb: pour les appimages , je ne suis pas aussi sûr que toi .

toutes ne fonctionnent pas aussi bien que ça .
Let's see !! Je n'ai besoin éventuellement que d


je n'aibesoin que de Avidemux, ce sera l'occasion d'activer le fichier préférence ! big_smile
encore merci

quelle tristesse


Je n'ai pas eu à fuir la guerre en traversée la méditerranée toute de même wink

Dernière modification par Tristan07 (27-03-2018 13:04:46)


Debian Stable est ce qui rend la vie plus intéressante que l'informatique ( voir Robert Filliou pour l'origine de cette citation smile
Debian c'est pas difficile ! zen.gif
https://lescahiersdudebutant.fr/
Pour une aide efficace sur le forum : https://debian-facile.org/viewtopic.php?id=13352

Hors ligne

Pied de page des forums