Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 18-04-2018 20:23:00

unit
Membre
Lieu : Montreuil sur mer
Distrib. : Buster
Noyau : Linux 4.19.0-6 amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Souris razer deathader elite

Bonjour la compagnie, j'ai acheter la souris razer deathader elite suite au conseil du magazine "planète linux", j'ai donc télécharger le fichier pour la configurer : https://software.opensuse.org/download. … razer-meta mais il y a une erreur lors de l'installation :

dpkg -i openrazer-meta_2.3.0-1_all.deb



Sélection du paquet openrazer-meta précédemment désélectionné.
(Lecture de la base de données... 243731 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de openrazer-meta_2.3.0-1_all.deb ...
Dépaquetage de openrazer-meta (2.3.0-1) ...
dpkg: des problèmes de dépendances empêchent la configuration de openrazer-meta :
 openrazer-meta dépend de openrazer-kernel-modules-dkms ; cependant :
  Le paquet openrazer-kernel-modules-dkms n'est pas installé.
 openrazer-meta dépend de openrazer-daemon ; cependant :
  Le paquet openrazer-daemon n'est pas installé.
 openrazer-meta dépend de openrazer-doc ; cependant :
  Le paquet openrazer-doc n'est pas installé.

dpkg: erreur de traitement du paquet openrazer-meta (--install) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 openrazer-meta
 


Merci pour l'aide

Edit : ajout des balises codes. Voir le tuto : Le code, ça pique moins les yeux en couleur


Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

#2 18-04-2018 20:30:58

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-7-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Souris razer deathader elite

tu es allé là ?

https://software.opensuse.org/download. … razer-meta

peux tu nous donner aussi ton sources.list ?

cat /etc/apt/sources.list

Dernière modification par Debian Alain (18-04-2018 20:32:59)

Hors ligne

#3 18-04-2018 20:40:08

unit
Membre
Lieu : Montreuil sur mer
Distrib. : Buster
Noyau : Linux 4.19.0-6 amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Re : Souris razer deathader elite

Salut,

oui je suis aller sur ce site,

# deb cdrom:[Debian GNU/Linux 8.1.0 _Jessie_ - Official amd64 DVD Binary-1 20150606-14:19]/ jessie contrib main
# Debian Jessie, dépôt principal + paquets non libres
#deb cdrom:[Debian GNU/Linux 8.1.0 _Jessie_ - Official amd64 DVD Binary-1 20150606-14:19]/ jessie contrib main
deb http://httpredir.debian.org/debian/ jessie main contrib non-free
# Debian Jessie, mises-à-jour de sécurité + paquets non libres
deb http://security.debian.org/ jessie/updates main contrib non-free
# Debian Jessie, mises-à-jour "volatiles" + paquets non libres
deb http://httpredir.debian.org/debian/ jessie-updates main contrib non-free
# Debian Jessie, dépôt de rétroportages ("backports")
deb http://httpredir.debian.org/debian jessie-backports main contrib non-free



deb http://dl.bintray.com/dawidd6/neofetch jessie main
 


Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

#4 18-04-2018 20:52:42

èfpé
Membre
Inscription : 10-07-2016

Re : Souris razer deathader elite

Bonsoir,

@unit : comme son nom l'indique, le paquet openrazer-meta est un méta-paquet... d'où « quelques » dépendances :

apt install openrazer-meta

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
The following additional packages will be installed:
  libxdo3 openrazer-daemon openrazer-doc openrazer-kernel-modules-dkms python3-daemonize python3-evdev python3-notify2 python3-numpy
  python3-openrazer python3-pyudev python3-setproctitle xautomation xdotool
Paquets suggérés :
  python-daemonize-doc gfortran python-numpy-doc python3-dev python3-nose python3-numpy-dbg
Les NOUVEAUX paquets suivants seront installés :
  libxdo3 openrazer-daemon openrazer-doc openrazer-kernel-modules-dkms openrazer-meta python3-daemonize python3-evdev python3-notify2
  python3-numpy python3-openrazer python3-pyudev python3-setproctitle xautomation xdotool
0 mis à jour, 14 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 2 291 ko dans les archives.
Après cette opération, 12,6 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] n
Annulation.


La seule méthode un peu pragmatique, est d'ajouter le dépôt en question à tes sources de paquets (cf. explications).

edit: alors en fait, sous Debian 8 Jessie il y a un sérieux souci, en réalité, ce n'est pas du tout installable proprement,

echo deb http://download.opensuse.org/repositories/hardware:/razer/Debian_8.0/ / > /etc/apt/sources.list.d/hardware:razer.list


apt-key adv --keyserver keys.gnupg.net --recv-keys 062F9FD4D6D11CE4


apt-get update


apt-get install openrazer-meta

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 openrazer-meta : Dépend: openrazer-daemon mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».


apt-get install openrazer-daemon

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 openrazer-daemon : Dépend: dbus-user-session mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».


C'est ballot le paquet dbus-user-session n'est pas disponible dans le dépôt jessie, envisages-tu de passer à Stretch ?

Dernière modification par èfpé (19-04-2018 07:22:42)

Hors ligne

#5 18-04-2018 22:54:47

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-7-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Souris razer deathader elite

oui , j'ai oublié , bonsoir unit .   big_smile

regarde ici   :   https://debian-facile.org/doc:systeme:a … t:jessie?s  wink

remplace les "httpredir"  par "deb" dans ton sources.list   roll

l'idéal serai d'avoir le sources.list suivant :  smile


# Debian Jessie, dépôt principal + paquets non libres
deb http://deb.debian.org/debian/ jessie main contrib non-free
# Debian Jessie, mises à jour de sécurité + paquets non libres
deb http://security.debian.org/ jessie/updates main contrib non-free
# Debian Jessie, mises à jour "volatiles" + paquets non libres
deb http://deb.debian.org/debian/ jessie-updates main contrib non-free
# Debian Jessie, dépôt de rétroportages ("backports")
deb http://deb.debian.org/debian/ jessie-backports main contrib non-free

deb http://dl.bintray.com/dawidd6/neofetch jessie main
 


c'est quoi ce dernier dépôt ?
j'ai trouvé ceci  :  https://bintray.com/  ,  c'est quoi au juste ?  scratchhead.gif

aussi :
donne nous le retour de :

cat /etc/apt/sources.list.d/*



et , s'il n'y a rien , tapes ceci dans ton terminal :  peace_flag.gif
copier / coller , c'est plus simple , plus rapide et plus sûr .

$ echo 'deb http://download.opensuse.org/repositories/hardware:/razer/Debian_8.0/ /' > /etc/apt/sources.list.d/hardware:razer.list


puis  :

# apt-get update && apt-get install openrazer-meta

Dernière modification par Debian Alain (18-04-2018 23:05:02)

Hors ligne

#6 19-04-2018 20:21:55

unit
Membre
Lieu : Montreuil sur mer
Distrib. : Buster
Noyau : Linux 4.19.0-6 amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Re : Souris razer deathader elite

Salut,

c'est quoi ce dernier dépôt ?
j'ai trouvé ceci  :  https://bintray.com/  ,  c'est quoi au juste ?  scratchhead.gif


affiche les informations dans un terminal https://memo-linux.com/neofetch-affiche … -terminal/

cat /etc/apt/sources.list.d/*
deb http://download.opensuse.org/repositories/hardware:/razer/Debian_8.0/ /
deb http://download.opensuse.org/repositories/isv:/ownCloud:/community/Debian_7.0/ /
 

Dernière modification par unit (19-04-2018 20:27:29)


Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

Pied de page des forums