Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-12-2018 23:20:02

mecanotox
Membre
Distrib. : Ubuntu 16.04 LTS
Noyau : 4.15.0-15-generic
(G)UI : Unity 7
Inscription : 04-06-2008

Systemd et TMPFS

OS : Debian Stretch

Bonjour à toute la communauté,

Je tente de passer en TMPFS les dossiers /var/lib/snmp et /var/lib/strongswan en modifiant mon /etc/fstab

<code>
tmpfs /var/lib/snmp defaults 0 0
</code>

Après reboot, le système se remonte en mode RO et tant que je ne supprime pas la ligne ci-dessous l'OS ne redémarre pas correctement.

Est-ce que quelqu'un aurait une idée ?

Cordialement.

Hors ligne

#2 11-12-2018 23:28:03

melissa6969
Membre
Lieu : Dans ma tête blonde
Distrib. : SID && Stable
Noyau : Kernel Panic
(G)UI : Xfce && Cinnamon && Mate
Inscription : 30-11-2016
Site Web

Re : Systemd et TMPFS

à ta place je tenterais plutôt quelque chose comme ceci

tmpfs /var/lib/snmp tmpfs defaults,nosuid,nodev,noatime,mode=0755,size=15% 0 0


ET

tmpfs /var/lib/strongswan tmpfs defaults,nosuid,nodev,noatime,mode=0755,size=15% 0 0



Le size=15% tu l'ajuste à la valeur que tu souhaites.
là c'est 15% de pris sur ta ram.
donc si t'as 8 Go de ram au total, les 15% signifient que ces deux ""partitions volatiles"" utiliseront chacune 1.2 Go de ram.
mais comme c'est en tmpfs, forcément elles seront pas utilisées entièrement wink


Papy Toshiba de 6 ans
i7 3630qm - 8 Go de ram - SSD Crucial 256 Go - HDD Toshiba 750 Go - Nvidia GF108m

En ligne

#3 11-12-2018 23:44:10

mecanotox
Membre
Distrib. : Ubuntu 16.04 LTS
Noyau : 4.15.0-15-generic
(G)UI : Unity 7
Inscription : 04-06-2008

Re : Systemd et TMPFS

Je te remercie de ton retour.

Après test cela ne fonctionne pas.

Ci dessous le fichier /etc/fstab :

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system>             <mount point>       <type>  <options>                   <dump>  <pass>
# System
/dev/sda1                   /                   ext2    ro,errors=remount-ro                                    0       0
# System Optimization RO
# TMPFS
/dev/shm/tmp                /tmp                tmpfs   defaults,bind                                           0       0
/dev/shm/var/cache          /var/cache          tmpfs   defaults,bind                                           0       0
/dev/shm/var/log            /var/log            tmpfs   defaults,bind                                           0       0
/dev/shm/var/spool          /var/spool          tmpfs   defaults,bind                                           0       0
/dev/shm/var/spool/rsyslog  /var/spool/rsyslog  tmpfs   defaults,bind                                           0       0
/dev/shm/var/tmp            /var/tmp            tmpfs   defaults,bind                                           0       0
/dev/shm/var/lib/shorewall  /var/lib/shorewall  tmpfs   defaults,bind                                           0       0
/dev/shm/var/lib/dhcp       /var/lib/dhcp       tmpfs   defaults,bind                                           0       0
/dev/shm/var/lib/apt        /var/lib/apt        tmpfs   defaults,bind                                           0       0

Hors ligne

Pied de page des forums