Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 09-01-2019 22:48:49

laurent1
Membre
Distrib. : Debian 7.6
Noyau : Linux 3.2.0-0-686-pae
Inscription : 22-11-2014

Re : [Résolu] ipv6 et routage

Bonsoir,

Les captures d'écran ne montrent que le réglage pour désactiver l'IPv6, pas uniquement DHCPv6. On voit bien un onglet DHCPv6 dans la dernière, mais pas son contenu.



L'onglet dhcp6 ne contient qu'une case pour activer ou désactiver le serveur dhcpv6.

Bien sûr, en arrêtant le client DHCPv6 avec l'option pour lui faire libérer l'adresse. Ou avec ip route del, mais l'adresse risque de revenir si le client DHCPv6 est toujours actif.



J'ai desactiver le serveur dhcpv6 sur la box, puis je l'ai redemarrer mais cette adresse revient constamment au redemarrage du serveur

adr inet6: 3d6e:9c2b:6b9e:5d6a:a598:6ea1:7eb2:8a5d/64 Scope:Global



Je ne trouve aucune option pour lui faire liberer l'adresse dans les option de la box.scratchhead.gif

Cordialement.


Pc sous debian 7.6 => noyau Linux 3.2.0

Serveur debian 7.6 => Linux 3.2.0

Hors ligne

#27 10-01-2019 00:18:23

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] ipv6 et routage

Quel est le contenu du fichier interfaces maintenant ?

Hors ligne

#28 10-01-2019 13:42:30

LaFouine
Membre
Distrib. : Debian testing strech
Noyau : 4.9.0-2-amd64
(G)UI : Xfce
Inscription : 10-04-2017

Re : [Résolu] ipv6 et routage

Je m'interesse aux sujet, et j'y apporte une petite parenthese.

dans le fichier interface j'ai :


# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug enp1s0
iface enp1s0 inet dhcp
# This is an autoconfigured IPv6 interface
iface enp1s0 inet6 auto




donc en dhcp.

j'utilise les paquet suivant:


dpkg -l |grep dhcp


 


ii  isc-dhcp-client                4.4.1-2                     amd64        DHCP client for automatically obtaining an IP address
ii  isc-dhcp-common                4.4.1-2                     amd64        common manpages relevant to all of the isc-dhcp packages
ii  isc-dhcp-server                4.4.1-2                     amd64        ISC DHCP server for automatic IP address assignment



je ne peux actuellement pas utiliser l'ipv6  car ma config est en ipv4 pour le moment (le FAI notamment) hmm


Debian strech, 2 x nvidia 980 gtx sli, cm asurock 16 gb ram

Hors ligne

#29 10-01-2019 13:47:51

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] ipv6 et routage

LaFouine a écrit :

# This is an autoconfigured IPv6 interface
iface enp1s0 inet6 auto


donc en dhcp.


Pas pour IPv6. "auto" = configuration automatique sans état (SLAAC), qui utilise les annonces de routeur IPv6 (RA) et ne fait pas appel au protocole DHCPv6.

Dernière modification par raleur (10-01-2019 13:48:45)

Hors ligne

#30 10-01-2019 15:01:08

rodinux
CA Debian-Facile
Lieu : Ardèche
Distrib. : Debian Strecht 9 + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Gnome
Inscription : 29-05-2014
Site Web

Re : [Résolu] ipv6 et routage

Si jamais cela peut t'aider, il y a un tutto pour yunohost avec ipv6 et freebox

La vie, ce n'est pas d'attendre que l'orage passe, c'est de danser sous la pluie...

Hors ligne

#31 10-01-2019 17:29:31

LaFouine
Membre
Distrib. : Debian testing strech
Noyau : 4.9.0-2-amd64
(G)UI : Xfce
Inscription : 10-04-2017

Re : [Résolu] ipv6 et routage

Sympa le lien je garde tongue merci

Debian strech, 2 x nvidia 980 gtx sli, cm asurock 16 gb ram

Hors ligne

#32 10-01-2019 21:56:52

laurent1
Membre
Distrib. : Debian 7.6
Noyau : Linux 3.2.0-0-686-pae
Inscription : 22-11-2014

Re : [Résolu] ipv6 et routage

Bonsoir,

@ raleur : le contenu de interface est le suivant :

auto wlan0
iface wlan0 inet dhcp
  wpa-ap-scan 1
  wpa-scan-ssid 1
  wpa-ssid  xxx
iface wlan0 inet6 static
  address 3d6e:9c2b:6b9e:5d6a::2



@ LaFouine : si tu veux utiliser le dhcp6, il y a un onglet dans l'interface de la freebox. tu doit l'activer et modifié le fichier /etc/network/interface de la façon suivante :

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug enp1s0
iface enp1s0 inet dhcp
# This is an autoconfigured IPv6 interface
iface enp1s0 inet6 dhcp



Puis redemarrage freebox et serveur et ce sera OK yes.gif

@ rodinux : merci pour le tuto smile

Cordialement.

Dernière modification par laurent1 (10-01-2019 21:58:25)


Pc sous debian 7.6 => noyau Linux 3.2.0

Serveur debian 7.6 => Linux 3.2.0

Hors ligne

#33 11-01-2019 15:04:06

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] ipv6 et routage

L'adresse 3d6e:9c2b:6b9e:5d6a:a598:6ea1:7eb2:8a5d a la même partie hôte a598:6ea1:7eb2:8a5d que l'adresse link local fe80::a598:6ea1:7eb2:8a5d. Je soupçonne donc que c'est une adresse autoconfigurée par RA (la désactivation de DHCPv6 sur la box a dû activer SLAAC dans les RA). Dans ce cas il faut jouer sur les options accept_ra et/ou autoconf
dans la configuration de wlan0 dans /etc/network/interfaces.
Pourtant d'après la page de manuel d'interfaces, la méthode static devrait par défaut mettre autoconf=0 (désactiver l'autoconfiguration d'adresse à partir des RA).

Essaye avec autoconf=0 et accept_ra=1 (pour récupérer les préfixes et routes dans les RA). Si cela ne marche pas, essaie accept_ra=0, mais il faudra spécifier la longueur du préfixe (option netmask ou /64 à la suite de l'adresse) et l'adresse de routeur par défaut avec l'option gateway.

Note : Tu peux utiliser

ip -6 addr show dev wlan0


pour vérifier si c'est une adresse dynamique.

Hors ligne

#34 11-01-2019 20:26:29

laurent1
Membre
Distrib. : Debian 7.6
Noyau : Linux 3.2.0-0-686-pae
Inscription : 22-11-2014

Re : [Résolu] ipv6 et routage

Bonsoir,

En ajoutant les parametres suivant à /etc/network/interface :

autoconf 0
accept_ra 0



-> sa ne fonctionne pas

mais en ajoutant :

net.ipv6.conf.wlan0.autoconf = 0
net.ipv6.conf.wlan0.accept_ra = 0



ou bien

net.ipv6.conf.wlan0.autoconf = 0
net.ipv6.conf.wlan0.accept_ra = 1



Dans les 2 cas, l'adresse ipv6 ne s'affiche plus.

Merci raleur pour ton aide

Je met le poste en résolu smile

Cordialement.


Pc sous debian 7.6 => noyau Linux 3.2.0

Serveur debian 7.6 => Linux 3.2.0

Hors ligne

#35 11-01-2019 20:47:42

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] ipv6 et routage

laurent1 a écrit :

-> sa ne fonctionne pas


C'est-à-dire ? Aucun changement (adresse autoconfigurée toujours présente) ou bien plus de connectivité IPv6 ?

[Edit]
Par contre avec accept_ra=0 l'adresse n'est plus là mais la route du préfixe et la route par défaut non plus, non ?

PS: c'est un peu bizarre de configurer une interface en DHCP pour IPv4 et en statique pour IPv6.

Dernière modification par raleur (11-01-2019 20:50:37)

Hors ligne

#36 11-01-2019 21:46:37

laurent1
Membre
Distrib. : Debian 7.6
Noyau : Linux 3.2.0-0-686-pae
Inscription : 22-11-2014

Re : [Résolu] ipv6 et routage

C'est-à-dire ? Aucun changement (adresse autoconfigurée toujours présente) ou bien plus de connectivité IPv6 ?



-> Oui, l'addresse revient au reboot

S'agit-il des bon paramètre pour le fichier interface ? scratchhead.gif
En tout cas en passant par sysct.conf sa passe avec les option que j'ai précisé.

Par contre avec accept_ra=0 l'adresse n'est plus là mais la route du préfixe et la route par défaut non plus, non ?


La route par default passe par le routeur freeb*x parce que je l'ai definit en gateway dans le fichier interface.
j'ai essayer avec accept_ra=0 et sans accept_ra=1, dans les 2 cas ça marche
après dans les 2 cas, le gateway etait précisé dans interface.

PS: c'est un peu bizarre de configurer une interface en DHCP pour IPv4 et en statique pour IPv6.


Oui je pense aussi mais bon sa a l'air de marcher tongue

Cordialement.

Dernière modification par laurent1 (11-01-2019 21:49:51)


Pc sous debian 7.6 => noyau Linux 3.2.0

Serveur debian 7.6 => Linux 3.2.0

Hors ligne

#37 11-01-2019 23:07:03

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] ipv6 et routage

Dans le fichier interface il ne faut pas mettre de = mais je pense que tu l'avais vu.
J'ai testé sur Stretch, ces options se comportent comme attendu. Je me suis dit que ça venait peut-être de ta vieille version Wheezy, alors j'ai testé ainsi que sur Jessie, mais j'observe encore le comportement attendu. Dans tous les cas, sans ces options il n'y a pas d'adresse autoconfigurée, autoconf est mis à 0 par défaut.

laurent1 a écrit :

c'est un peu bizarre de configurer une interface en DHCP pour IPv4 et en statique pour IPv6.


Oui je pense aussi mais bon sa a l'air de marcher


Je ne dis pas le contraire, mais la raison de faire ainsi m'échappe.

Dernière modification par raleur (11-01-2019 23:09:45)

Hors ligne

#38 11-01-2019 23:47:49

laurent1
Membre
Distrib. : Debian 7.6
Noyau : Linux 3.2.0-0-686-pae
Inscription : 22-11-2014

Re : [Résolu] ipv6 et routage

Dans le fichier interface il ne faut pas mettre de = mais je pense que tu l'avais vu.



->  Oui, Il est rempli de cette façon

auto wlan0
iface wlan0 inet dhcp
iface wlan0 inet6 static
  adress ...
  gateway ...
  autoconf 0
  accept_ra 0
 



mais les parametres autoconf et accept_ra ne sont pas pris en compte, puisque la ligne revient au reboot (le "=" c'est pour sysctl.conf).

sur ce pc c'est un debian jessie qui tourne. Mais si tu me dit que par default l'autoconf est a 0, là comprend pas pourquoi la route revient.scratchhead.gif

Je ne dis pas le contraire, mais la raison de faire ainsi m'échappe.



Tu pense qu'il est plus judicieux de tout passer en static ou bien tout en dhcp ?

Cordialement

Edit à toto : Modif faite - pour une meilleure lisibilité par tous, utiliser Autre code pour transcrire le code et Citation pour le texte.

Dernière modification par laurent1 (11-01-2019 23:57:27)


Pc sous debian 7.6 => noyau Linux 3.2.0

Serveur debian 7.6 => Linux 3.2.0

Hors ligne

#39 12-01-2019 09:54:48

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] ipv6 et routage

laurent1 a écrit :

mais les parametres autoconf et accept_ra ne sont pas pris en compte, puisque la ligne revient au reboot (le "=" c'est pour sysctl.conf).


J'allais demander si tu l'avais mis dans sysctl.conf ou dans des options "up" du fichier interfaces, mais tu donnes la réponse de toi-même.
Tu pourrais exécuter ifup avec l'option -v pour afficher ses actions.

ifdown wlan0
ifup -v wlan0


Chez moi cela montre bien les commandes sysctl exécutées pour modifier accept_ra et autoconf.

laurent1 a écrit :

Tu pense qu'il est plus judicieux de tout passer en static ou bien tout en dhcp ?


Cela me paraît plus logique en tout cas. Mais il peut y avoir de bonnes raisons de faire autrement.

Hors ligne

#40 12-01-2019 11:15:18

laurent1
Membre
Distrib. : Debian 7.6
Noyau : Linux 3.2.0-0-686-pae
Inscription : 22-11-2014

Re : [Résolu] ipv6 et routage

ifdown wlan0
ifup -v wlan0



Le problème c'est que le seul accès que j'ai à la machine est par cette interface.
Y aureit-il un fichier log qui affiche tous cela ? scratchhead.gif


Cordialement.


Pc sous debian 7.6 => noyau Linux 3.2.0

Serveur debian 7.6 => Linux 3.2.0

Hors ligne

#41 12-01-2019 17:51:06

LaFouine
Membre
Distrib. : Debian testing strech
Noyau : 4.9.0-2-amd64
(G)UI : Xfce
Inscription : 10-04-2017

Re : [Résolu] ipv6 et routage

laurent1 a écrit :

ifdown wlan0
ifup -v wlan0



Le problème c'est que le seul accès que j'ai à la machine est par cette interface.
Y aurait-il un fichier log qui affiche tous cela ? https://debian-facile.org/img/smilies/x … chhead.gif


Cordialement.



tu peux loguer avec

screen -dmSL NomScreen commande (paramètre L je crois) l'avantage du screen c' est qu'il tourne en tache de fond quand tu va perdre ta connexion
pour revenir dans le screen : screen -x NomScreen
script ''fichier'' (je me souviens plus de la syntaxe exact ) (doit être exécuter dans le screen)

il y a peut être plus simple par contre ?


Debian strech, 2 x nvidia 980 gtx sli, cm asurock 16 gb ram

Hors ligne

#42 13-01-2019 10:53:12

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] ipv6 et routage

Attention à bien exécuter les deux commandes ifdown et ifup d'une traite, soit dans dans un script soit dans une même ligne, séparés par ";".
Sinon la connexion coupera avant de pouvoir taper ifup.

Autre possibilité : puisque c'est sous Jessie qui n'a pas de service networking natif pour systemd et l'activation de wlan0 est définie en auto et non allow-hotplug, l'interface est activée par le script de démarrage /etc.init.d/networking donc modifier ce script pour ajouter -v à la commande ifup et éventuellement une redirection de sa sortie dans un fichier log si journalctl ne contient pas la sortie d'ifup.

Dernière modification par raleur (13-01-2019 10:53:43)

Hors ligne

Pied de page des forums