Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-01-2019 22:52:53

MastX
Membre
Inscription : 10-01-2019

Installation de Pep/8 pour Assembleur [Résolu].

Bonjour a tous,
j'essaye d'installer le simulateur et assembleur Pep/8 dispo ici http://computersystemsbook.com/4th-edition/pep8/ pour mon debian buster x64
mais quand je lance l'installation il me dit

./Pep8: error while loading shared libraries: libQtWebKit.so.4: cannot open shared object file: No such file or directory
 


chose que je ne comprends pas car j'ai deja le package libqtcore4.
j'ai chercher ce fichier et je l'ai trouve mais './Pep8' ne le trouve pas
j'ai essaye les mise-a-jour la reinstallation de libqtcore4 et meme installer Qt creator mais rien.

SVP, aidez-moi car j'en ai besoin pour mon cours d'assembleur. Merci d'avance
je suis sous Plasma 5

PS: desole pour les fautes je suis sur un QWERTY

Dernière modification par MastX (11-01-2019 17:20:42)

Hors ligne

#2 11-01-2019 00:33:29

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 12-08-2015

Re : Installation de Pep/8 pour Assembleur [Résolu].

Si c'est le binaire que tu essayes de lancer :

file Pep8


Pep8: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux.so.2, for GNU/Linux 2.6.15, BuildID[sha1]=59393bb4f063551ac708a7690b8cb2fce1121ded, with debug_info, not stripped


Tu as une debian 32bits ?

Si ce n'est pas le cas, regarde ceci: https://wiki.debian.org/fr/Multiarch/HOWTO

Éventuellement, tu peux tenter de recompiler les sources si tu trouves la doc.

Dernière modification par Beta-Pictoris (11-01-2019 00:44:47)

Hors ligne

#3 11-01-2019 00:39:09

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 12-08-2015

Re : Installation de Pep/8 pour Assembleur [Résolu].

Tu peux t'inspirer du pkgbuild d'archlinux pour la compilation https://aur.archlinux.org/cgit/aur.git/ … p8-asm-git
Commandes qmake puis make.

Hors ligne

#4 11-01-2019 05:42:03

MastX
Membre
Inscription : 10-01-2019

Re : Installation de Pep/8 pour Assembleur [Résolu].

d'accord j'essaye tes solutions et je te reponds. merci beaucoup:):)

Hors ligne

#5 11-01-2019 05:48:29

tux12
Membre
Lieu : ./
Distrib. : stable
Noyau : celui de la stable
(G)UI : KDE
Inscription : 27-02-2008

Re : Installation de Pep/8 pour Assembleur [Résolu].

Bonjour,

Je n'ai pas regardé les détails mais il me paraît possible que ton programme ne trouve pas la librairie car il cherche dans un autre répertoire que celle ou elle se trouve. Il faudrait dans ce cas déterminer ou le programme cherche les libs et si on peut redéfinir simplement ce chemin (fichier ou option de config en ligne de commande). Sinon il reste à faire un lien symbolique vers la lib depuis le répertoire ou le programme s'attend à la trouver.

Si ça peut aider, smile

Dernière modification par tux12 (11-01-2019 05:50:15)

Hors ligne

#6 11-01-2019 06:39:45

MastX
Membre
Inscription : 10-01-2019

Re : Installation de Pep/8 pour Assembleur [Résolu].

j'ai egalement penser comme toi mais etant donne que Pep8 est un fichier ELF, je n'ai pas acces a son code source pour le modifier. j'ai essayer le multi-arch en vain. je viens de tester

qmake PKGBUILD


/home/mastx/PKGBUILD:20: Extra characters after test expression.
/home/mastx/PKGBUILD:25: Extra characters after test expression.
/home/mastx/PKGBUILD:31: Extra characters after test expression.
Error processing project file: PKGBUILD



il y'avait des erreurs similaires sur d'autres lignes et je les ai fixer sans comprendre en ajoutant juste le " \ " a la fin des lignes (merci a stackoverflow) par contre ces 3 lignes je n'y arrive pas.

Edit à toto : Supprimé le BBCode Code=bash à l'intérieur du BBCode Commande user.

Hors ligne

#7 11-01-2019 11:23:36

raleur
Membre
Inscription : 03-10-2014

Re : Installation de Pep/8 pour Assembleur [Résolu].

MastX a écrit :

./Pep8: error while loading shared libraries: libQtWebKit.so.4: cannot open shared object file: No such file or directory


chose que je ne comprends pas car j'ai deja le package libqtcore4.


Le fichier libQtWebKit.so.4 est contenu dans le paquet libqtwebkit4.
Le paquet libqtcore4 ne dépend pas de libqtwebkit4 (c'est l'inverse) donc ce dernier n'est pas forcément installé.
Comme déjà souligné, si l'exécutable Pep8 est pour l'architecture i386, il faut ajouter cette architecture avec le multi-arch et installer les bibliothèques pour i386.

Hors ligne

#8 11-01-2019 13:08:51

robert2a
Membre
Lieu : France
Distrib. : debian 10
Noyau : 4.19
(G)UI : Gnome
Inscription : 15-11-2014

Re : Installation de Pep/8 pour Assembleur [Résolu].

Bonjour
sur debian buster amd64 , il se trouve ici

/usr/lib/x86_64-linux-gnu/libQtWebKit.so.4



j'ai installé la version de debian (pep8 est un méta-paquet sur debian qui pointe sur "pycodestyle" )


Récupération des rapports de bogue… Fait
Analyse des informations Trouvé/Corrigé… Fait
Sélection du paquet python3-pycodestyle précédemment désélectionné.
(Lecture de la base de données... 240160 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../python3-pycodestyle_2.4.0-2_all.deb ...
Dépaquetage de python3-pycodestyle (2.4.0-2) ...
Sélection du paquet pycodestyle précédemment désélectionné.
Préparation du dépaquetage de .../pycodestyle_2.4.0-2_all.deb ...
Dépaquetage de pycodestyle (2.4.0-2) ...
Sélection du paquet pep8 précédemment désélectionné.
Préparation du dépaquetage de .../archives/pep8_1.7.1-3_all.deb ...
Dépaquetage de pep8 (1.7.1-3) ...
Paramétrage de python3-pycodestyle (2.4.0-2) ...
Traitement des actions différées (« triggers ») pour man-db (2.8.5-1) ...
Paramétrage de pycodestyle (2.4.0-2) ...
Paramétrage de pep8 (1.7.1-3) ...
 


l'installation du paquet "libqtwebkit4"


Récupération des rapports de bogue… Fait
Analyse des informations Trouvé/Corrigé… Fait
Sélection du paquet libaudio2:amd64 précédemment désélectionné.
(Lecture de la base de données... 240186 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../00-libaudio2_1.9.4-6_amd64.deb ...
Dépaquetage de libaudio2:amd64 (1.9.4-6) ...
Sélection du paquet qtcore4-l10n précédemment désélectionné.
Préparation du dépaquetage de .../01-qtcore4-l10n_4%3a4.8.7+dfsg-17_all.deb ...
Dépaquetage de qtcore4-l10n (4:4.8.7+dfsg-17) ...
Sélection du paquet libqtcore4:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../02-libqtcore4_4%3a4.8.7+dfsg-17_amd64.deb ...
Dépaquetage de libqtcore4:amd64 (4:4.8.7+dfsg-17) ...
Sélection du paquet libqt4-xml:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../03-libqt4-xml_4%3a4.8.7+dfsg-17_amd64.deb ...
Dépaquetage de libqt4-xml:amd64 (4:4.8.7+dfsg-17) ...
Sélection du paquet libqtdbus4:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../04-libqtdbus4_4%3a4.8.7+dfsg-17_amd64.deb ...
Dépaquetage de libqtdbus4:amd64 (4:4.8.7+dfsg-17) ...
Sélection du paquet qtchooser précédemment désélectionné.
Préparation du dépaquetage de .../05-qtchooser_66-1_amd64.deb ...
Dépaquetage de qtchooser (66-1) ...
Sélection du paquet qdbus précédemment désélectionné.
Préparation du dépaquetage de .../06-qdbus_4%3a4.8.7+dfsg-17_amd64.deb ...
Dépaquetage de qdbus (4:4.8.7+dfsg-17) ...
Sélection du paquet libqt4-dbus:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../07-libqt4-dbus_4%3a4.8.7+dfsg-17_amd64.deb ...
Dépaquetage de libqt4-dbus:amd64 (4:4.8.7+dfsg-17) ...
Sélection du paquet libqt4-network:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../08-libqt4-network_4%3a4.8.7+dfsg-17_amd64.deb ...
Dépaquetage de libqt4-network:amd64 (4:4.8.7+dfsg-17) ...
Sélection du paquet libqtgui4:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../09-libqtgui4_4%3a4.8.7+dfsg-17_amd64.deb ...
Dépaquetage de libqtgui4:amd64 (4:4.8.7+dfsg-17) ...
Sélection du paquet libqt4-opengl:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../10-libqt4-opengl_4%3a4.8.7+dfsg-17_amd64.deb ...
Dépaquetage de libqt4-opengl:amd64 (4:4.8.7+dfsg-17) ...
Sélection du paquet libqt4-xmlpatterns:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../11-libqt4-xmlpatterns_4%3a4.8.7+dfsg-17_amd64.deb ...
Dépaquetage de libqt4-xmlpatterns:amd64 (4:4.8.7+dfsg-17) ...
Sélection du paquet libqtwebkit4:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../12-libqtwebkit4_2.3.4.dfsg-10_amd64.deb ...
Dépaquetage de libqtwebkit4:amd64 (2.3.4.dfsg-10) ...
Sélection du paquet qt-at-spi:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../13-qt-at-spi_0.4.0-9_amd64.deb ...
Dépaquetage de qt-at-spi:amd64 (0.4.0-9) ...
Paramétrage de qtcore4-l10n (4:4.8.7+dfsg-17) ...
Paramétrage de qtchooser (66-1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.28-2) ...
Paramétrage de libqtcore4:amd64 (4:4.8.7+dfsg-17) ...
Traitement des actions différées (« triggers ») pour man-db (2.8.5-1) ...
Paramétrage de libqt4-xml:amd64 (4:4.8.7+dfsg-17) ...
Paramétrage de libaudio2:amd64 (1.9.4-6) ...
Paramétrage de libqtgui4:amd64 (4:4.8.7+dfsg-17) ...
Paramétrage de libqtdbus4:amd64 (4:4.8.7+dfsg-17) ...
Paramétrage de libqt4-opengl:amd64 (4:4.8.7+dfsg-17) ...
Paramétrage de qdbus (4:4.8.7+dfsg-17) ...
Paramétrage de libqt4-dbus:amd64 (4:4.8.7+dfsg-17) ...
Paramétrage de libqt4-network:amd64 (4:4.8.7+dfsg-17) ...
Paramétrage de qt-at-spi:amd64 (0.4.0-9) ...
Paramétrage de libqt4-xmlpatterns:amd64 (4:4.8.7+dfsg-17) ...
Paramétrage de libqtwebkit4:amd64 (2.3.4.dfsg-10) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.28-2) ...
 



dpkg --print-foreign-architectures
 


retour


i386
 



si je lance l'installation de la version que tu donne (que j'ai téléchargé)


./Pep8
./Pep8: error while loading shared libraries: libQtWebKit.so.4: cannot open shared object file: No such file or directory
 



par contre je sais pas si la version de debian10 fait ton affaire (a priori version 7)
mais bon la lib existe bien "libQtWebKit.so.4"  =>  "/usr/lib/x86_64-linux-gnu/libQtWebKit.so.4"

toutes les versions  =>  https://packages.debian.org/search?sear … ebkit.so.4
la i386 => /usr/lib/i386-linux-gnu/libQtWebKit.so.4

nota: je n'ai pas la version "i386" installé" sur ma machine

si je fait une simulation de l'installation en i386


apt-get -s install libqtwebkit4:i386
 


retour


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
  gstreamer1.0-plugins-base:i386 libaudio2:i386 libavahi-client3:i386 libavahi-common-data:i386 libavahi-common3:i386 libblkid1:i386
  libcairo2:i386 libcap2:i386 libcdparanoia0:i386 libcom-err2:i386 libcups2:i386 libdbus-1-3:i386 libfontconfig1:i386 libfreetype6:i386
  libgcrypt20:i386 libglib2.0-0:i386 libgmp10:i386 libgnutls30:i386 libgssapi-krb5-2:i386 libgstreamer-plugins-base1.0-0:i386
  libgstreamer1.0-0:i386 libhogweed4:i386 libice6:i386 libidn2-0:i386 libjbig0:i386 libjpeg62-turbo:i386 libk5crypto3:i386
  libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386 liblcms2-2:i386 liblz4-1:i386 liblzma5:i386 libmng1:i386 libmount1:i386
  libnettle6:i386 libogg0:i386 libopus0:i386 liborc-0.4-0:i386 libp11-kit0:i386 libpcre3:i386 libpixman-1-0:i386 libpng16-16:i386
  libqt4-dbus:i386 libqt4-network:i386 libqt4-opengl:i386 libqt4-xml:i386 libqt4-xmlpatterns:i386 libqtcore4:i386 libqtdbus4:i386
  libqtgui4:i386 libselinux1:i386 libsm6:i386 libsqlite3-0:i386 libsystemd0:i386 libtasn1-6:i386 libtheora0:i386 libtiff5:i386
  libunistring2:i386 libuuid1:i386 libvisual-0.4-0:i386 libvorbis0a:i386 libvorbisenc2:i386 libwebp6:i386 libxcb-render0:i386
  libxcb-shm0:i386 libxrender1:i386 libxt6:i386 libzstd1:i386 qt-at-spi:i386 uuid-runtime
Paquets suggérés :
  gvfs:i386 nas:i386 rng-tools:i386 gnutls-bin:i386 krb5-doc:i386 krb5-user:i386 libvisual-0.4-plugins:i386 gstreamer1.0-tools:i386
  liblcms2-utils:i386 opus-tools:i386 libicu57:i386 libthai0:i386 qt4-qtconfig:i386
Les NOUVEAUX paquets suivants seront installés :
  gstreamer1.0-plugins-base:i386 libaudio2:i386 libavahi-client3:i386 libavahi-common-data:i386 libavahi-common3:i386 libblkid1:i386
  libcairo2:i386 libcap2:i386 libcdparanoia0:i386 libcom-err2:i386 libcups2:i386 libdbus-1-3:i386 libfontconfig1:i386 libfreetype6:i386
  libgcrypt20:i386 libglib2.0-0:i386 libgmp10:i386 libgnutls30:i386 libgssapi-krb5-2:i386 libgstreamer-plugins-base1.0-0:i386
  libgstreamer1.0-0:i386 libhogweed4:i386 libice6:i386 libidn2-0:i386 libjbig0:i386 libjpeg62-turbo:i386 libk5crypto3:i386
  libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386 liblcms2-2:i386 liblz4-1:i386 liblzma5:i386 libmng1:i386 libmount1:i386
  libnettle6:i386 libogg0:i386 libopus0:i386 liborc-0.4-0:i386 libp11-kit0:i386 libpcre3:i386 libpixman-1-0:i386 libpng16-16:i386
  libqt4-dbus:i386 libqt4-network:i386 libqt4-opengl:i386 libqt4-xml:i386 libqt4-xmlpatterns:i386 libqtcore4:i386 libqtdbus4:i386
  libqtgui4:i386 libqtwebkit4:i386 libselinux1:i386 libsm6:i386 libsqlite3-0:i386 libsystemd0:i386 libtasn1-6:i386 libtheora0:i386
  libtiff5:i386 libunistring2:i386 libuuid1:i386 libvisual-0.4-0:i386 libvorbis0a:i386 libvorbisenc2:i386 libwebp6:i386
  libxcb-render0:i386 libxcb-shm0:i386 libxrender1:i386 libxt6:i386 libzstd1:i386 qt-at-spi:i386 uuid-runtime
 



je vais pas le faire , mais j'ai steam:i386 sur cette machine qui fonctionne.
il te manque peut être la version de ce paquet en i386 (la version de debian n'a installé aucun paquet i386 pour pep8)

Dernière modification par robert2a (11-01-2019 13:35:14)

Hors ligne

#9 11-01-2019 16:46:42

MastX
Membre
Inscription : 10-01-2019

Re : Installation de Pep/8 pour Assembleur [Résolu].

merci j'essaye ca big_smile:D

Hors ligne

#10 11-01-2019 17:07:43

MastX
Membre
Inscription : 10-01-2019

Re : Installation de Pep/8 pour Assembleur [Résolu].

merci beaucoup mon probleme est resolu.
je devais effectivement installe les librairies 32bits (je ne savais pas que chaque architecture avait ses propres librairies; je debute sur debian ops.gif
j'ai du installe libphonon4 et ses dependances.
tout va bien maintenant. Merci de votre aide

Hors ligne

#11 11-01-2019 17:12:16

smolski
admin quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports
Noyau : 4.9.65-3+deb9u2
(G)UI : gnome
Inscription : 21-10-2008

Re : Installation de Pep/8 pour Assembleur [Résolu].

MastX a écrit :

mon probleme est resolu.


Hop hop hop... :
\o/
Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre.


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#12 11-01-2019 21:31:08

raleur
Membre
Inscription : 03-10-2014

Re : Installation de Pep/8 pour Assembleur [Résolu].

robert2a a écrit :

pep8 est un méta-paquet sur debian qui pointe sur "pycodestyle"


Je n'ai pas l'impression que ce soit la même chose. Ce paquet ne ressemble pas à un assembleur/simulateur et n'a pas de dépendance avec Qt.

MastX a écrit :

(je ne savais pas que chaque architecture avait ses propres librairies; je debute sur debian


Ce n'est pas spécifique à Debian mais commun à toutes les distributions GNU/Linux et au delà, quasiment tous les autres systèmes d'exploitation comme Windows.
Les bibliothèques partagées sont des objets binaires compilés donc dépendants de l'architecture, comme les programmes binaires exécutables qui les utilisent.

Dernière modification par raleur (11-01-2019 21:32:45)

Hors ligne

#13 12-01-2019 04:36:45

robert2a
Membre
Lieu : France
Distrib. : debian 10
Noyau : 4.19
(G)UI : Gnome
Inscription : 15-11-2014

Re : Installation de Pep/8 pour Assembleur [Résolu].

raleur a écrit :

robert2a a écrit :

pep8 est un méta-paquet sur debian qui pointe sur "pycodestyle"


Je n'ai pas l'impression que ce soit la même chose. Ce paquet ne ressemble pas à un assembleur/simulateur et n'a pas de dépendance avec Qt.



Oui je pense aussi  wink

C'est plus pour la méthode a suivre qu' autre chose. (je comprend rien en assembleur/simulateur )  roll
je n'ai pas posté mais j'ai ouvert les paquets (.deb ou archive)  debian pep8 et du site "Pep/8"

@MastX

tu va pouvoir bosser ....  wink

le paquet existe sur debian (mot clé "pep" avec synaptic ) => pep8-simul
la description

The Pep/8 computer is a 16-bit complex instruction set
computer (CISC). It is designed to teach computer
architecture and assembly language programming principles.



il est en version 8.1.3+git20180702~ds1-3
il est plus propre d'utiliser la version de debian , plutôt qu'une autre , surtout que sur Buster (testing) les paquets sont assez récent

Force et courage comme dit le matou qui vient de gratter un point choco trop facilement tongue

Hors ligne

Pied de page des forums