Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 27-02-2019 13:19:26

vv222
Modérateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.2 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : npm refuse de s'installer

Debian Alain a écrit :

en tout cas je me pose des  questions sur la compatibilité de npm avec java 8 ????


Aucun souci à se faire de ce côté, ce sont deux applications complètement indépendantes qui ne devraient jamais avoir à communiquer entre elles wink


Jouer sous Debian ? Facile !

Hors ligne

#27 27-02-2019 14:11:02

saw
Membre
Distrib. : Debian GNU/Linux 9.5 (stretch)
Noyau : Linux 4.9.0-8-amd64
(G)UI : gnome
Inscription : 25-10-2018

Re : npm refuse de s'installer

sudo apt update


Atteint:1 https://packages.sury.org/php stretch InRelease
Atteint:2 https://deb.nodesource.com/node_10.x stretch InRelease
Atteint:3 https://dl.winehq.org/wine-builds/debian stretch InRelease
Ign:4 http://deb.debian.org/debian stretch InRelease                                  
Atteint:5 http://security.debian.org stretch/updates InRelease                        
Atteint:6 http://deb.debian.org/debian stretch-updates InRelease                      
Atteint:7 http://packages.microsoft.com/repos/vscode stable InRelease                
Atteint:8 http://deb.debian.org/debian stretch-backports InRelease                    
Atteint:9 http://deb.debian.org/debian stretch Release                                
Atteint:11 http://repo.steampowered.com/steam precise InRelease                      
Lecture des listes de paquets... Fait  
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
All packages are up to date.
 



Chez moi la commande "env" est fournie par /usr/bin/env, lui-même fourni par le paquet coreutils.



cd /usr/bin/env
 


bash: cd: /usr/bin/env: Aucun fichier ou dossier de ce type
 



command -v env
 

command -v env

vide



ls -l /usr/bin/env
 


lrwxrwxrwx 1 root staff 38 nov.  14 02:22 /usr/bin/env -> ../lib/node_modules/npm/bin/npm-cli.js
 



dpkg -l coreutils


Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom             Version      Architecture Description
+++-===============-============-============-====================================
ii  coreutils       8.26-3       amd64        GNU core utilities
 




voila en esperant que ca aide a localisé mon pb

Hors ligne

#28 27-02-2019 14:51:33

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.2.0-3 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : npm refuse de s'installer

pour commencer , il y a des choses qui me chiffonnent dans ton sources.list  :


tu peux pas  faire autrement ? :
Atteint:2 https://deb.nodesource.com/node_10.x stretch InRelease
Atteint:3 https://dl.winehq.org/wine-builds/debian stretch InRelease

dépôt en double , je le crains :
Ign:4 http://deb.debian.org/debian stretch InRelease

quoi ? un dépôt ubuntu ? (j'espère que je me trompe)
Atteint:11 http://repo.steampowered.com/steam precise InRelease
 



ensuite

command -v env



devrai te renvoyer ceci :
/usr/bin/env
 



et

ls -l /usr/bin/env


devrai te renvoyer ceci :
-rwxr-xr-x 1 root root 43680 août  29 22:20 /usr/bin/env
 


1498812139.jpg Nightwish - Last Ride Of The Day (With Lyrics)
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#29 27-02-2019 15:45:36

saw
Membre
Distrib. : Debian GNU/Linux 9.5 (stretch)
Noyau : Linux 4.9.0-8-amd64
(G)UI : gnome
Inscription : 25-10-2018

Re : npm refuse de s'installer

tu peux pas  faire autrement ? :
Atteint:2 https://deb.nodesource.com/node_10.x stretch InRelease
Atteint:3 https://dl.winehq.org/wine-builds/debian stretch InRelease



cette a dire ?

sudo apt update


Atteint:1 http://repo.steampowered.com/steam precise InRelease
Ign:2 http://deb.debian.org/debian stretch InRelease                                  
Atteint:3 http://security.debian.org stretch/updates InRelease                        
Atteint:4 http://packages.microsoft.com/repos/vscode stable InRelease                
Atteint:5 http://deb.debian.org/debian stretch-updates InRelease      
Atteint:6 http://deb.debian.org/debian stretch-backports InRelease
Atteint:7 http://deb.debian.org/debian stretch Release        
Atteint:8 https://packages.sury.org/php stretch InRelease      
Atteint:9 https://deb.nodesource.com/node_10.x stretch InRelease
Atteint:10 https://dl.winehq.org/wine-builds/debian stretch InRelease
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
All packages are up to date.
 



comment reparer mon dossier env ??

Hors ligne

#30 27-02-2019 15:54:52

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.2.0-3 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : npm refuse de s'installer

pour le dossier env , je sais pas ; pour ton sources.list , par contre , je peux t'aider

merci pour le sources.list

peux tu nous poster le rapport suivant :

cat /etc/apt/sources.list.d/*.list

S.T.P. ????

j'espère pouvoir voir d'éventuels doublons ....

Atteint:2 https://deb.nodesource.com/node_10.x stretch InRelease

c'est pour node.js je présume ?



tu es allé chercher ce lien ici :  -- le lien-- , je pense .

npm installe automatiquement node.js (en tout cas  sous testing) .

smolski est intéressant : smolski

installer npm depuis les backports me paraît une bonne idée .

pour wine , pas besoin de  dépôt spécial . la version des  backports est bonne aussi : https://wiki.debian.org/fr/Wine

pour steam , -- lien -- tu n'as pas besoin de dépots non plus .

Dernière modification par Debian Alain (27-02-2019 16:22:22)


1498812139.jpg Nightwish - Last Ride Of The Day (With Lyrics)
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#31 27-02-2019 16:01:41

saw
Membre
Distrib. : Debian GNU/Linux 9.5 (stretch)
Noyau : Linux 4.9.0-8-amd64
(G)UI : gnome
Inscription : 25-10-2018

Re : npm refuse de s'installer

cat /etc/apt/sources.list


# stable
deb http://deb.debian.org/debian/ stretch main contrib non-free
# stable updates
deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
# stable-backports
deb http://deb.debian.org/debian/ stretch-backports main contrib non-free
# stable security
deb http://security.debian.org/ stretch/updates main contrib non-free
 

Hors ligne

#32 27-02-2019 16:23:46

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.2.0-3 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : npm refuse de s'installer

voir mon post plus haut (#30)

si tout va bien , je règlerai ton eventuel problème de doublons .

pour node.js , winehq et steam , je pars du principe que tu sais ce que tu fais .

je ne marcherai donc pas sur tes plates bandes .

pour npm , je me rabats à l'avis de smolski : les backports devraient suffire .

pour node.js son installation se fait automatiquemennt avec npm .

pour env , je ne sais pas  comment t'aider . plus calé que moi pourra sûrement .

Dernière modification par Debian Alain (27-02-2019 16:42:26)


1498812139.jpg Nightwish - Last Ride Of The Day (With Lyrics)
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#33 27-02-2019 17:07:01

saw
Membre
Distrib. : Debian GNU/Linux 9.5 (stretch)
Noyau : Linux 4.9.0-8-amd64
(G)UI : gnome
Inscription : 25-10-2018

Re : npm refuse de s'installer

sudo apt-get install --reinstall coreutils



te permet de reinstaller /usr/bin/env

donc apache2 et code fonctionne a nouveau. je me penche tous de suite sur tes suggestion. :-)

Edit : je voudrais avoir la derniére version stable de node.js qui est 10.x or avec les backports je me retrouve avec



nodejs -v


v8.11.1



et npm je ne sais pas trop si c'est la derniére version stable :

npm -v


5.8.0





comment obtenir les dernière version stable ??

Dernière modification par saw (27-02-2019 18:33:06)

Hors ligne

#34 27-02-2019 19:30:14

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.2.0-3 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : npm refuse de s'installer

passer à buster / sid ???

tu auras les dernières M.A.J.

sinon , jouer avec les dépôts mais c'est risqué . et dangereux . c'est le meilleur moyen de tout casser .

1498812139.jpg Nightwish - Last Ride Of The Day (With Lyrics)
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#35 27-02-2019 19:32:38

smolski
admin quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports (buster) 10
Noyau : 4.9.65-3+deb9u2 4.19.0-6-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : npm refuse de s'installer

Voir le tuto des backports et son utilisation :
https://debian-facile.org/doc:apt:sourc … -backports cool

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#36 27-02-2019 19:32:51

saw
Membre
Distrib. : Debian GNU/Linux 9.5 (stretch)
Noyau : Linux 4.9.0-8-amd64
(G)UI : gnome
Inscription : 25-10-2018

Re : npm refuse de s'installer

buster sid ?? je ne sais pas ce que c'est

et oui mais chelou que l'on n'est pas accés au derniére verssion stable

Hors ligne

#37 27-02-2019 19:35:29

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.2.0-3 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : npm refuse de s'installer

comme l'a dit smolski :

Le dépôt backports propose des paquets plus récents ou absents du dépôt principal.

Ces paquets sont dérivés de la version de test et peuvent être installés sur une Debian stable.

Il servira à ceux qui ont absolument besoin d’une version plus récente d’un logiciel,

mais ne veulent pas compromettre la stabilité générale de leur système en migrant vers testing.



qu'est  ce que tu préfères ?

avoir une  version stable ... stable , c.a.d. fiable , qui ne pose pas de problème et dure dans le temps ...
ou
une version stable ... instable , qui plante au premier mot , à la première fonction , au premier fichier lancé ?

si tu préfères la version stable , il faut accepter la limitation des versions .

c'est un gage de sécurité : les versions ainsi livrées sont testées et retestées et garanties contre presque tous les problèmes .

sauf bien sur les problèmess d' I.C.C. ... (I.nterface C.haise C.lavier , I.C.C. ; toi , quoi ... ).

nb: buster , c'est la version de test de Debian et sid , c'est la version non - stable .

Dernière modification par Debian Alain (27-02-2019 19:47:43)


1498812139.jpg Nightwish - Last Ride Of The Day (With Lyrics)
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#38 27-02-2019 21:55:31

smolski
admin quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports (buster) 10
Noyau : 4.9.65-3+deb9u2 4.19.0-6-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : npm refuse de s'installer

Voir le tuto des branches debian pour le détail :
https://debian-facile.org/doc:systeme:a … hes-debian smile

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#39 28-02-2019 10:26:29

saw
Membre
Distrib. : Debian GNU/Linux 9.5 (stretch)
Noyau : Linux 4.9.0-8-amd64
(G)UI : gnome
Inscription : 25-10-2018

Re : npm refuse de s'installer

qu'est  ce que tu préfères ?

avoir une  version stable ... stable , c.a.d. fiable , qui ne pose pas de problème et dure dans le temps ...
ou
une version stable ... instable , qui plante au premier mot , à la première fonction , au premier fichier lancé ?



la version 10.x de de nodejs est une version LTS je ne te ferais pas l'affront de t'expliquer ce que ça veux dire. il est donc étonnant que les backports sensé avoir les versions les plus récentes S.T.A.B.L.E ne me propose pas la mise a jour. https://nodejs.org/en/

nb: buster , c'est la version de test de Debian et sid , c'est la version non - stable .



compris

Voir le tuto des branches debian pour le détail :



bah oui mais même sur les backports rétro je n'ai pas la stable 10.x alors je commence vraiment a désespérer

j'ai remarquer quelque chose :

sudo apt -t stretch-backports update


Atteint:1 http://security.debian.org stretch/updates InRelease
Ign:2 http://deb.debian.org/debian stretch InRelease                                                                      
Atteint:3 http://deb.debian.org/debian stretch-updates InRelease                                                                                      
Atteint:4 http://repo.steampowered.com/steam precise InRelease                                                                                        
Atteint:5 http://deb.debian.org/debian stretch-backports InRelease                                                                
Atteint:6 http://packages.microsoft.com/repos/vscode stable InRelease                            
Atteint:7 http://deb.debian.org/debian stretch Release                                          
Atteint:8 https://deb.nodesource.com/node_10.x stretch InRelease
Atteint:9 https://dl.winehq.org/wine-builds/debian stretch InRelease
Atteint:10 https://packages.sury.org/php stretch InRelease
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
[b]32 packages[/b] can be upgraded. Run 'apt list --upgradable' to see them.
 



apt list --upgradable


En train de lister... Fait



sudo apt -t stretch-backports upgrade


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  cmake cmake-data debhelper gir1.2-javascriptcoregtk-4.0 gir1.2-lokdocview-0.1 gir1.2-webkit2-4.0 libjavascriptcoregtk-4.0-18 liblibreofficekitgtk
  libreoffice-avmedia-backend-gstreamer libreoffice-base libreoffice-base-core libreoffice-base-drivers libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw
  libreoffice-evolution libreoffice-gnome libreoffice-gtk3 libreoffice-help-fr libreoffice-impress libreoffice-l10n-fr libreoffice-math libreoffice-report-builder-bin
  libreoffice-sdbc-postgresql libreoffice-style-tango libreoffice-writer libreofficekit-data libwebkit2gtk-4.0-37 python3-uno uno-libs3 ure
0 mis à jour, 0 nouvellement installés, 0 à enlever et 32 non mis à jour.
 



bizarre non ? je fais bien l'upgrade a l'instant mais les paquet ne se mettent pas a jours. une idée monsieur l'expert des backports ? ^^

EDIT:
un petit :

sudo apt -t stretch-backports full-upgrade
 


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libetonyek-0.1-1 libgltf-0.0-0v5 libmwaw-0.3-3 liborcus-0.11-0 libwps-0.4-4
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  libreoffice-style-galaxy
Les NOUVEAUX paquets suivants seront installés :
  dwz firebird3.0-server-core fonts-liberation2 libboost-chrono1.62.0 libboost-locale1.62.0 libgpgmepp6 libib-util libreoffice-help-common libreoffice-sdbc-firebird
  libreoffice-style-colibre libreoffice-style-elementary librhash0
Les paquets suivants seront mis à jour :
  cmake cmake-data debhelper gir1.2-javascriptcoregtk-4.0 gir1.2-lokdocview-0.1 gir1.2-webkit2-4.0 libjavascriptcoregtk-4.0-18 liblibreofficekitgtk
  libreoffice-avmedia-backend-gstreamer libreoffice-base libreoffice-base-core libreoffice-base-drivers libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw
  libreoffice-evolution libreoffice-gnome libreoffice-gtk3 libreoffice-help-fr libreoffice-impress libreoffice-l10n-fr libreoffice-math libreoffice-report-builder-bin
  libreoffice-sdbc-postgresql libreoffice-style-tango libreoffice-writer libreofficekit-data libwebkit2gtk-4.0-37 python3-uno uno-libs3 ure
32 mis à jour, 12 nouvellement installés, 1 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 135 Mo dans les archives.
Après cette opération, 63,3 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Réception de:1 http://deb.debian.org/debian stretch-backports/main amd64 libreoffice-l10n-fr all 1:6.1.5~rc1-2~bpo9+1 [596 kB]
Réception de:2 http://deb.debian.org/debian stretch-backports/main amd64 libreoffice-base-drivers amd64 1:6.1.5~rc1-2~bpo9+1 [496 kB]
Réception de:3 http://deb.debian.org/debian stretch-backports/main amd64 libreoffice-base amd64 1:6.1.5~rc1-2~bpo9+1 [1 744 kB]
Réception de:4 http://deb.debian.org/debian stretch-backports/main amd64 libreoffice-draw amd64 1:6.1.5~rc1-2~bpo9+1 [2 634 kB]
Réception de:5 http://deb.debian.org/debian stretch-backports/main amd64 libreoffice-evolution amd64 1:6.1.5~rc1-2~bpo9+1 [79,2 kB]                                            
Réception de:6 http://deb.debian.org/debian stretch-backports/main amd64 libreoffice-gnome amd64 1:6.1.5~rc1-2~bpo9+1 [50,1 kB]                                                
Réception de:7 http://deb.debian.org/debian stretch-backports/main amd64 libreoffice-gtk3 amd64 1:6.1.5~rc1-2~bpo9+1 [287 kB]                                                  
Réception de:8 http://deb.debian.org/debian stretch-backports/main amd64 libreoffice-impress amd64 1:6.1.5~rc1-2~bpo9+1 [964 kB]                                              
Réception de:9 http://deb.debian.org/debian stretch-backports/main amd64 libreoffice-writer amd64 1:6.1.5~rc1-2~bpo9+1 [8 547 kB]                                              
Réception de:10 http://deb.debian.org/debian stretch-backports/main amd64 libreoffice-core amd64 1:6.1.5~rc1-2~bpo9+1 [36,7 MB]                                                
Réception de:11 http://deb.debian.org/debian stretch-backports/main amd64 libreoffice-help-fr all 1:6.1.5~rc1-2~bpo9+1 [1 560 kB]                                              
Réception de:12 http://deb.debian.org/debian stretch-backports/main amd64 libreoffice-style-tango all 1:6.1.5~rc1-2~bpo9+1 [1 200 kB]                                          
Réception de:13 http://deb.debian.org/debian stretch-backports/main amd64 libreoffice-common all 1:6.1.5~rc1-2~bpo9+1 [36,9 MB]                                                
Réception de:14 http://deb.debian.org/debian stretch-backports/main amd64 libreoffice-calc amd64 1:6.1.5~rc1-2~bpo9+1 [7 172 kB]                                              
Réception de:15 http://deb.debian.org/debian stretch-backports/main amd64 gir1.2-lokdocview-0.1 amd64 1:6.1.5~rc1-2~bpo9+1 [4 554 B]                                          
Réception de:16 http://deb.debian.org/debian stretch-backports/main amd64 liblibreofficekitgtk amd64 1:6.1.5~rc1-2~bpo9+1 [63,6 kB]                                            
Réception de:17 http://deb.debian.org/debian stretch-backports/main amd64 uno-libs3 amd64 6.1.5~rc1-2~bpo9+1 [881 kB]                                                          
Réception de:18 http://deb.debian.org/debian stretch-backports/main amd64 libreoffice-sdbc-postgresql amd64 1:6.1.5~rc1-2~bpo9+1 [227 kB]                                      
Réception de:19 http://deb.debian.org/debian stretch-backports/main amd64 ure amd64 6.1.5~rc1-2~bpo9+1 [1 720 kB]                                                              
Réception de:20 http://deb.debian.org/debian stretch-backports/main amd64 python3-uno amd64 1:6.1.5~rc1-2~bpo9+1 [191 kB]                                                      
Réception de:21 http://deb.debian.org/debian stretch-backports/main amd64 libreoffice-report-builder-bin amd64 1:6.1.5~rc1-2~bpo9+1 [817 kB]                                  
Réception de:22 http://deb.debian.org/debian stretch-backports/main amd64 libreoffice-math amd64 1:6.1.5~rc1-2~bpo9+1 [380 kB]                                                
Réception de:23 http://deb.debian.org/debian stretch-backports/main amd64 libreoffice-base-core amd64 1:6.1.5~rc1-2~bpo9+1 [757 kB]                                            
Réception de:24 http://deb.debian.org/debian stretch-backports/main amd64 libreoffice-avmedia-backend-gstreamer amd64 1:6.1.5~rc1-2~bpo9+1 [23,6 kB]                          
Réception de:25 http://deb.debian.org/debian stretch-backports/main amd64 libreofficekit-data all 1:6.1.5~rc1-2~bpo9+1 [4 002 B]                                              
Réception de:26 http://deb.debian.org/debian stretch-backports/main amd64 libreoffice-help-common all 1:6.1.5~rc1-2~bpo9+1 [2 668 kB]                                          
Réception de:27 http://deb.debian.org/debian stretch-backports/main amd64 libreoffice-style-colibre all 1:6.1.5~rc1-2~bpo9+1 [966 kB]                                          
Réception de:28 http://deb.debian.org/debian stretch/main amd64 libboost-chrono1.62.0 amd64 1.62.0+dfsg-4 [36,0 kB]                                                            
Réception de:29 http://deb.debian.org/debian stretch/main amd64 libboost-locale1.62.0 amd64 1.62.0+dfsg-4 [262 kB]                                                            
Réception de:30 http://deb.debian.org/debian stretch-backports/main amd64 libgpgmepp6 amd64 1.12.0-6~bpo9+1 [234 kB]                                                          
Réception de:31 http://deb.debian.org/debian stretch-backports/main amd64 cmake amd64 3.13.2-1~bpo9+1 [3 423 kB]                                                              
Réception de:32 http://deb.debian.org/debian stretch-backports/main amd64 cmake-data all 3.13.2-1~bpo9+1 [1 486 kB]                                                            
Réception de:33 http://deb.debian.org/debian stretch/main amd64 librhash0 amd64 1.3.3-1+b2 [85,5 kB]                                                                          
Réception de:34 http://deb.debian.org/debian stretch/main amd64 dwz amd64 0.12-1+b1 [78,1 kB]                                                                                  
Réception de:35 http://deb.debian.org/debian stretch-backports/main amd64 debhelper all 12~bpo9+1 [997 kB]                                                                    
Réception de:36 http://deb.debian.org/debian stretch/main amd64 libib-util amd64 3.0.1.32609.ds4-14 [3 346 B]                                                                  
Réception de:37 http://deb.debian.org/debian stretch/main amd64 firebird3.0-server-core amd64 3.0.1.32609.ds4-14 [2 431 kB]                                                    
Réception de:38 http://deb.debian.org/debian stretch/main amd64 fonts-liberation2 all 2.00.1-3 [1 455 kB]                                                                      
Réception de:39 http://deb.debian.org/debian stretch-backports/main amd64 libwebkit2gtk-4.0-37 amd64 2.22.6-1~bpo9+1 [11,3 MB]                                                
Réception de:40 http://deb.debian.org/debian stretch-backports/main amd64 libjavascriptcoregtk-4.0-18 amd64 2.22.6-1~bpo9+1 [4 558 kB]                                        
Réception de:41 http://deb.debian.org/debian stretch-backports/main amd64 gir1.2-webkit2-4.0 amd64 2.22.6-1~bpo9+1 [126 kB]                                                    
Réception de:42 http://deb.debian.org/debian stretch-backports/main amd64 gir1.2-javascriptcoregtk-4.0 amd64 2.22.6-1~bpo9+1 [79,1 kB]                                        
Réception de:43 http://deb.debian.org/debian stretch-backports/main amd64 libreoffice-sdbc-firebird amd64 1:6.1.5~rc1-2~bpo9+1 [124 kB]                                        
Réception de:44 http://deb.debian.org/debian stretch-backports/main amd64 libreoffice-style-elementary all 1:6.1.5~rc1-2~bpo9+1 [942 kB]                                      
135 Mo réceptionnés en 1min 49s (1 234 ko/s)                                                                                                                                  
Lecture des fichiers de modifications (« changelog »)... Terminé
apt-listchanges : Envoi des modifications par courriel à root : apt-listchanges : nouveautés pour saw
Extraction des modèles depuis les paquets : 100%
(Lecture de la base de données... 209728 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../00-libreoffice-l10n-fr_1%3a6.1.5~rc1-2~bpo9+1_all.deb ...
Dépaquetage de libreoffice-l10n-fr (1:6.1.5~rc1-2~bpo9+1) sur (1:5.2.7-1+deb9u5) ...
Préparation du dépaquetage de .../01-libreoffice-base-drivers_1%3a6.1.5~rc1-2~bpo9+1_amd64.deb ...
Dépaquetage de libreoffice-base-drivers (1:6.1.5~rc1-2~bpo9+1) sur (1:5.2.7-1+deb9u5) ...
Préparation du dépaquetage de .../02-libreoffice-base_1%3a6.1.5~rc1-2~bpo9+1_amd64.deb ...
Dépaquetage de libreoffice-base (1:6.1.5~rc1-2~bpo9+1) sur (1:5.2.7-1+deb9u5) ...
Préparation du dépaquetage de .../03-libreoffice-help-fr_1%3a6.1.5~rc1-2~bpo9+1_all.deb ...
Dépaquetage de libreoffice-help-fr (1:6.1.5~rc1-2~bpo9+1) sur (1:5.2.7-1+deb9u5) ...
Préparation du dépaquetage de .../04-libreoffice-style-tango_1%3a6.1.5~rc1-2~bpo9+1_all.deb ...
Dépaquetage de libreoffice-style-tango (1:6.1.5~rc1-2~bpo9+1) sur (1:5.2.7-1+deb9u5) ...
dpkg: tentative de déconfiguration de libreoffice-common, qui serait cassé par l'installation de libreoffice-calc...
dpkg: oui, déconfiguration de libreoffice-common (cassé par libreoffice-calc).
Préparation du dépaquetage de .../05-libreoffice-calc_1%3a6.1.5~rc1-2~bpo9+1_amd64.deb ...
Déconfiguration de libreoffice-common (1:5.2.7-1+deb9u5) ...
Dépaquetage de libreoffice-calc (1:6.1.5~rc1-2~bpo9+1) sur (1:5.2.7-1+deb9u5) ...
Remplacement de fichiers dans l'ancien paquet libreoffice-common (1:5.2.7-1+deb9u5) ...
Préparation du dépaquetage de .../06-libreoffice-evolution_1%3a6.1.5~rc1-2~bpo9+1_amd64.deb ...
Dépaquetage de libreoffice-evolution (1:6.1.5~rc1-2~bpo9+1) sur (1:5.2.7-1+deb9u5) ...
Préparation du dépaquetage de .../07-libreoffice-gnome_1%3a6.1.5~rc1-2~bpo9+1_amd64.deb ...
Dépaquetage de libreoffice-gnome (1:6.1.5~rc1-2~bpo9+1) sur (1:5.2.7-1+deb9u5) ...
Préparation du dépaquetage de .../08-libreoffice-gtk3_1%3a6.1.5~rc1-2~bpo9+1_amd64.deb ...
Dépaquetage de libreoffice-gtk3 (1:6.1.5~rc1-2~bpo9+1) sur (1:5.2.7-1+deb9u5) ...
Préparation du dépaquetage de .../09-libreoffice-impress_1%3a6.1.5~rc1-2~bpo9+1_amd64.deb ...
Dépaquetage de libreoffice-impress (1:6.1.5~rc1-2~bpo9+1) sur (1:5.2.7-1+deb9u5) ...
Remplacement de fichiers dans l'ancien paquet libreoffice-common (1:5.2.7-1+deb9u5) ...
Préparation du dépaquetage de .../10-libreoffice-writer_1%3a6.1.5~rc1-2~bpo9+1_amd64.deb ...
Dépaquetage de libreoffice-writer (1:6.1.5~rc1-2~bpo9+1) sur (1:5.2.7-1+deb9u5) ...
Remplacement de fichiers dans l'ancien paquet libreoffice-common (1:5.2.7-1+deb9u5) ...
dpkg: tentative de déconfiguration de libreoffice-draw, qui serait cassé par l'installation de libreoffice-core...
dpkg: oui, déconfiguration de libreoffice-draw (cassé par libreoffice-core).
Préparation du dépaquetage de .../11-libreoffice-core_1%3a6.1.5~rc1-2~bpo9+1_amd64.deb ...
Déconfiguration de libreoffice-draw (1:5.2.7-1+deb9u5) ...
Dépaquetage de libreoffice-core (1:6.1.5~rc1-2~bpo9+1) sur (1:5.2.7-1+deb9u5) ...
Remplacement de fichiers dans l'ancien paquet libreoffice-common (1:5.2.7-1+deb9u5) ...
Sélection du paquet libreoffice-common précédemment désélectionné.
dpkg: tentative de déconfiguration de libreoffice-style-galaxy, qui serait cassé par l'installation de libreoffice-common...
dpkg: oui, déconfiguration de libreoffice-style-galaxy (cassé par libreoffice-common).
Préparation du dépaquetage de .../12-libreoffice-common_1%3a6.1.5~rc1-2~bpo9+1_all.deb ...
Déconfiguration de libreoffice-style-galaxy (1:5.2.7-1+deb9u5) ...
Dépaquetage de libreoffice-common (1:6.1.5~rc1-2~bpo9+1) sur (1:5.2.7-1+deb9u5) ...
Préparation du dépaquetage de .../13-libreoffice-draw_1%3a6.1.5~rc1-2~bpo9+1_amd64.deb ...
Dépaquetage de libreoffice-draw (1:6.1.5~rc1-2~bpo9+1) sur (1:5.2.7-1+deb9u5) ...
(Lecture de la base de données... 212681 fichiers et répertoires déjà installés.)
Suppression de libreoffice-style-galaxy (1:5.2.7-1+deb9u5) ...
(Lecture de la base de données... 212677 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../00-gir1.2-lokdocview-0.1_1%3a6.1.5~rc1-2~bpo9+1_amd64.deb ...
Dépaquetage de gir1.2-lokdocview-0.1 (1:6.1.5~rc1-2~bpo9+1) sur (1:5.2.7-1+deb9u5) ...
Préparation du dépaquetage de .../01-liblibreofficekitgtk_1%3a6.1.5~rc1-2~bpo9+1_amd64.deb ...
Dépaquetage de liblibreofficekitgtk (1:6.1.5~rc1-2~bpo9+1) sur (1:5.2.7-1+deb9u5) ...
Préparation du dépaquetage de .../02-uno-libs3_6.1.5~rc1-2~bpo9+1_amd64.deb ...
Dépaquetage de uno-libs3 (6.1.5~rc1-2~bpo9+1) sur (5.2.7-1+deb9u5) ...
Préparation du dépaquetage de .../03-libreoffice-sdbc-postgresql_1%3a6.1.5~rc1-2~bpo9+1_amd64.deb ...
Dépaquetage de libreoffice-sdbc-postgresql (1:6.1.5~rc1-2~bpo9+1) sur (1:5.2.7-1+deb9u5) ...
Préparation du dépaquetage de .../04-ure_6.1.5~rc1-2~bpo9+1_amd64.deb ...
Dépaquetage de ure (6.1.5~rc1-2~bpo9+1) sur (5.2.7-1+deb9u5) ...
Préparation du dépaquetage de .../05-python3-uno_1%3a6.1.5~rc1-2~bpo9+1_amd64.deb ...
Dépaquetage de python3-uno (1:6.1.5~rc1-2~bpo9+1) sur (1:5.2.7-1+deb9u5) ...
Préparation du dépaquetage de .../06-libreoffice-report-builder-bin_1%3a6.1.5~rc1-2~bpo9+1_amd64.deb ...
Dépaquetage de libreoffice-report-builder-bin (1:6.1.5~rc1-2~bpo9+1) sur (1:5.2.7-1+deb9u5) ...
Préparation du dépaquetage de .../07-libreoffice-math_1%3a6.1.5~rc1-2~bpo9+1_amd64.deb ...
Dépaquetage de libreoffice-math (1:6.1.5~rc1-2~bpo9+1) sur (1:5.2.7-1+deb9u5) ...
Préparation du dépaquetage de .../08-libreoffice-base-core_1%3a6.1.5~rc1-2~bpo9+1_amd64.deb ...
Dépaquetage de libreoffice-base-core (1:6.1.5~rc1-2~bpo9+1) sur (1:5.2.7-1+deb9u5) ...
Préparation du dépaquetage de .../09-libreoffice-avmedia-backend-gstreamer_1%3a6.1.5~rc1-2~bpo9+1_amd64.deb ...
Dépaquetage de libreoffice-avmedia-backend-gstreamer (1:6.1.5~rc1-2~bpo9+1) sur (1:5.2.7-1+deb9u5) ...
Préparation du dépaquetage de .../10-libreofficekit-data_1%3a6.1.5~rc1-2~bpo9+1_all.deb ...
Dépaquetage de libreofficekit-data (1:6.1.5~rc1-2~bpo9+1) sur (1:5.2.7-1+deb9u5) ...
Sélection du paquet libreoffice-help-common précédemment désélectionné.
Préparation du dépaquetage de .../11-libreoffice-help-common_1%3a6.1.5~rc1-2~bpo9+1_all.deb ...
Dépaquetage de libreoffice-help-common (1:6.1.5~rc1-2~bpo9+1) ...
Sélection du paquet libreoffice-style-colibre précédemment désélectionné.
Préparation du dépaquetage de .../12-libreoffice-style-colibre_1%3a6.1.5~rc1-2~bpo9+1_all.deb ...
Dépaquetage de libreoffice-style-colibre (1:6.1.5~rc1-2~bpo9+1) ...
Sélection du paquet libboost-chrono1.62.0:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../13-libboost-chrono1.62.0_1.62.0+dfsg-4_amd64.deb ...
Dépaquetage de libboost-chrono1.62.0:amd64 (1.62.0+dfsg-4) ...
Sélection du paquet libboost-locale1.62.0:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../14-libboost-locale1.62.0_1.62.0+dfsg-4_amd64.deb ...
Dépaquetage de libboost-locale1.62.0:amd64 (1.62.0+dfsg-4) ...
Sélection du paquet libgpgmepp6:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../15-libgpgmepp6_1.12.0-6~bpo9+1_amd64.deb ...
Dépaquetage de libgpgmepp6:amd64 (1.12.0-6~bpo9+1) ...
Préparation du dépaquetage de .../16-cmake_3.13.2-1~bpo9+1_amd64.deb ...
Dépaquetage de cmake (3.13.2-1~bpo9+1) sur (3.7.2-1) ...
Préparation du dépaquetage de .../17-cmake-data_3.13.2-1~bpo9+1_all.deb ...
Dépaquetage de cmake-data (3.13.2-1~bpo9+1) sur (3.7.2-1) ...
Sélection du paquet librhash0 précédemment désélectionné.
Préparation du dépaquetage de .../18-librhash0_1.3.3-1+b2_amd64.deb ...
Dépaquetage de librhash0 (1.3.3-1+b2) ...
Sélection du paquet dwz précédemment désélectionné.
Préparation du dépaquetage de .../19-dwz_0.12-1+b1_amd64.deb ...
Dépaquetage de dwz (0.12-1+b1) ...
Préparation du dépaquetage de .../20-debhelper_12~bpo9+1_all.deb ...
Dépaquetage de debhelper (12~bpo9+1) sur (10.2.5) ...
Sélection du paquet libib-util:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../21-libib-util_3.0.1.32609.ds4-14_amd64.deb ...
Dépaquetage de libib-util:amd64 (3.0.1.32609.ds4-14) ...
Sélection du paquet firebird3.0-server-core:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../22-firebird3.0-server-core_3.0.1.32609.ds4-14_amd64.deb ...
Dépaquetage de firebird3.0-server-core:amd64 (3.0.1.32609.ds4-14) ...
Sélection du paquet fonts-liberation2 précédemment désélectionné.
Préparation du dépaquetage de .../23-fonts-liberation2_2.00.1-3_all.deb ...
Dépaquetage de fonts-liberation2 (2.00.1-3) ...
Préparation du dépaquetage de .../24-libwebkit2gtk-4.0-37_2.22.6-1~bpo9+1_amd64.deb ...
Dépaquetage de libwebkit2gtk-4.0-37:amd64 (2.22.6-1~bpo9+1) sur (2.18.6-1~deb9u1) ...
Préparation du dépaquetage de .../25-libjavascriptcoregtk-4.0-18_2.22.6-1~bpo9+1_amd64.deb ...
Dépaquetage de libjavascriptcoregtk-4.0-18:amd64 (2.22.6-1~bpo9+1) sur (2.18.6-1~deb9u1) ...
Préparation du dépaquetage de .../26-gir1.2-webkit2-4.0_2.22.6-1~bpo9+1_amd64.deb ...
Dépaquetage de gir1.2-webkit2-4.0:amd64 (2.22.6-1~bpo9+1) sur (2.18.6-1~deb9u1) ...
Préparation du dépaquetage de .../27-gir1.2-javascriptcoregtk-4.0_2.22.6-1~bpo9+1_amd64.deb ...
Dépaquetage de gir1.2-javascriptcoregtk-4.0:amd64 (2.22.6-1~bpo9+1) sur (2.18.6-1~deb9u1) ...
Sélection du paquet libreoffice-sdbc-firebird précédemment désélectionné.
Préparation du dépaquetage de .../28-libreoffice-sdbc-firebird_1%3a6.1.5~rc1-2~bpo9+1_amd64.deb ...
Dépaquetage de libreoffice-sdbc-firebird (1:6.1.5~rc1-2~bpo9+1) ...
Sélection du paquet libreoffice-style-elementary précédemment désélectionné.
Préparation du dépaquetage de .../29-libreoffice-style-elementary_1%3a6.1.5~rc1-2~bpo9+1_all.deb ...
Dépaquetage de libreoffice-style-elementary (1:6.1.5~rc1-2~bpo9+1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.60) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-1) ...
Paramétrage de fonts-liberation2 (2.00.1-3) ...
Paramétrage de cmake-data (3.13.2-1~bpo9+1) ...
Traitement des actions différées (« triggers ») pour gnome-icon-theme (3.12.0-2) ...
Paramétrage de librhash0 (1.3.3-1+b2) ...
Traitement des actions différées (« triggers ») pour bamfdaemon (0.5.3-2) ...
Rebuilding /usr/share/applications/bamf-2.index...
Paramétrage de libib-util:amd64 (3.0.1.32609.ds4-14) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-11+deb9u4) ...
Paramétrage de dwz (0.12-1+b1) ...
Paramétrage de firebird3.0-server-core:amd64 (3.0.1.32609.ds4-14) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.6.1-2) ...
Traitement des actions différées (« triggers ») pour shared-mime-info (1.8-1+deb9u1) ...
Paramétrage de libjavascriptcoregtk-4.0-18:amd64 (2.22.6-1~bpo9+1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-9) ...
Paramétrage de cmake (3.13.2-1~bpo9+1) ...
Paramétrage de uno-libs3 (6.1.5~rc1-2~bpo9+1) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.15-1) ...
Paramétrage de ure (6.1.5~rc1-2~bpo9+1) ...
Paramétrage de libgpgmepp6:amd64 (1.12.0-6~bpo9+1) ...
Paramétrage de libboost-chrono1.62.0:amd64 (1.62.0+dfsg-4) ...
Traitement des actions différées (« triggers ») pour fontconfig (2.11.0-6.7+b1) ...
Paramétrage de debhelper (12~bpo9+1) ...
Paramétrage de libwebkit2gtk-4.0-37:amd64 (2.22.6-1~bpo9+1) ...
Paramétrage de gir1.2-javascriptcoregtk-4.0:amd64 (2.22.6-1~bpo9+1) ...
Paramétrage de libboost-locale1.62.0:amd64 (1.62.0+dfsg-4) ...
Paramétrage de gir1.2-webkit2-4.0:amd64 (2.22.6-1~bpo9+1) ...
Paramétrage de libreoffice-style-tango (1:6.1.5~rc1-2~bpo9+1) ...
Paramétrage de libreoffice-style-colibre (1:6.1.5~rc1-2~bpo9+1) ...
Paramétrage de libreoffice-common (1:6.1.5~rc1-2~bpo9+1) ...
Installation de la nouvelle version du fichier de configuration /etc/libreoffice/sofficerc ...
Paramétrage de libreoffice-core (1:6.1.5~rc1-2~bpo9+1) ...
Paramétrage de libreoffice-l10n-fr (1:6.1.5~rc1-2~bpo9+1) ...
Paramétrage de libreofficekit-data (1:6.1.5~rc1-2~bpo9+1) ...
Paramétrage de libreoffice-style-elementary (1:6.1.5~rc1-2~bpo9+1) ...
Paramétrage de python3-uno (1:6.1.5~rc1-2~bpo9+1) ...
Paramétrage de libreoffice-base-drivers (1:6.1.5~rc1-2~bpo9+1) ...
Paramétrage de libreoffice-gtk3 (1:6.1.5~rc1-2~bpo9+1) ...
Paramétrage de libreoffice-gnome (1:6.1.5~rc1-2~bpo9+1) ...
Paramétrage de libreoffice-draw (1:6.1.5~rc1-2~bpo9+1) ...
Paramétrage de libreoffice-avmedia-backend-gstreamer (1:6.1.5~rc1-2~bpo9+1) ...
Paramétrage de libreoffice-help-common (1:6.1.5~rc1-2~bpo9+1) ...
Paramétrage de libreoffice-impress (1:6.1.5~rc1-2~bpo9+1) ...
Paramétrage de libreoffice-sdbc-firebird (1:6.1.5~rc1-2~bpo9+1) ...
Paramétrage de liblibreofficekitgtk (1:6.1.5~rc1-2~bpo9+1) ...
Paramétrage de libreoffice-math (1:6.1.5~rc1-2~bpo9+1) ...
Paramétrage de libreoffice-sdbc-postgresql (1:6.1.5~rc1-2~bpo9+1) ...
Paramétrage de libreoffice-base-core (1:6.1.5~rc1-2~bpo9+1) ...
Paramétrage de libreoffice-calc (1:6.1.5~rc1-2~bpo9+1) ...
Paramétrage de libreoffice-help-fr (1:6.1.5~rc1-2~bpo9+1) ...
Paramétrage de gir1.2-lokdocview-0.1 (1:6.1.5~rc1-2~bpo9+1) ...
Paramétrage de libreoffice-writer (1:6.1.5~rc1-2~bpo9+1) ...
Paramétrage de libreoffice-base (1:6.1.5~rc1-2~bpo9+1) ...
Paramétrage de libreoffice-report-builder-bin (1:6.1.5~rc1-2~bpo9+1) ...
Paramétrage de libreoffice-evolution (1:6.1.5~rc1-2~bpo9+1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-11+deb9u4) ...
W: APT had planned for dpkg to do more than it reported back (220 vs 227).
   Affected packages: libreoffice-common:amd64
 



Edit: AAAAAAHHHHH ENFIN !!!

npm -v


6.4.1



AND

node -v


v10.15.1



magnifique :-D je conseille ce lien : https://blog.emmanuelgautier.fr/mettre- … s-via-npm/ que du bonheur simple et efficace.

Dernière modification par saw (28-02-2019 11:07:40)

Hors ligne

#40 28-02-2019 11:22:42

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.2.0-3 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : npm refuse de s'installer

1) je me répète , raleur et smolski me confirmeront sans doute ainsi que beaucoup des  anciens de ce  forum  :

si tu veux  à tout prix les dernières versions les plus récentes non homologuées par debian , il faut jouer  avec les dépôts .

c'est risqué , d'une part , parceque toutes  L.T.S. ou STABLES qu'elles soient , cela n'est pas garanti .

il n'est pas prouvé qu'elles soient adaptées a debian . L.T.S. ou STABLE , c'est purement commercial .

en plus il y a un autre souci : le problème de la version des paquets . il n'est pas rare qu'à vouloir à tout prix les derniers paquets ,

on casse sa machine . c'est un problème fréquent sur "deb-multimedia" par exemple . les versions des paquets n'étant plus compatibles

et demandant trop de changement .


2) je te l'ai déjà dit :

deb http://deb.debian.org/debian stretch


est en doublon sur ta machine . ce n'est pas  bon . il faut régler cette erreur .

3)

sudo apt -t stretch-backports update

sudo apt -t stretch-backports full-upgrade


sont des conneries monumentales , si tu veux à tout prix  les dernières versions , passe à testing / sid  .

ce que tu as  fait là , c'est l'un des meilleurs moyens de casser sa distribution .

mais tu ne le verra pas de suite .



https://wiki.debian.org/fr/DebianTesting

https://www.debian.org/releases/index.fr.html

https://www.debian.org/doc/manuals/debi … ng.fr.html

https://www.debian.org/CD/http-ftp/index.fr.html


1498812139.jpg Nightwish - Last Ride Of The Day (With Lyrics)
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#41 28-02-2019 11:36:21

saw
Membre
Distrib. : Debian GNU/Linux 9.5 (stretch)
Noyau : Linux 4.9.0-8-amd64
(G)UI : gnome
Inscription : 25-10-2018

Re : npm refuse de s'installer

L.T.S. ou STABLES qu'elles soient , cela n'est pas garanti
il n'est pas prouvé qu'elles soient adaptées a debian. L.T.S. ou STABLE , c'est purement commercial



bah c'est toujours mieux que la version testing dans tous les cas, si on ne peux plus se fier aux nom de version alors la ou va t'on.

les versions des paquets n'étant plus compatibles

et demandant trop de changement .



les version dans les backports sont dites sécurisé dans la doc de mémoire

pour résumer je me fie ++ a la documentation et au nom de version sans vouloir te vexer bien sur.

Hors ligne

#42 28-02-2019 11:42:57

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.2.0-3 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : npm refuse de s'installer

les versions des backports sont adaptées à stable .

si tu rajoute des dépôts hybrides ou externes à debian , il n'est pas du tout dit que ce soit le cas .

et la compatibilité n'est pas du tout garantie .

tu n'aimes pas testing : très bien .

mais sais tu que les backports sont issus , en droite ligne , de testing ?

Dernière modification par Debian Alain (28-02-2019 11:48:41)


1498812139.jpg Nightwish - Last Ride Of The Day (With Lyrics)
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#43 28-02-2019 12:55:56

smolski
admin quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports (buster) 10
Noyau : 4.9.65-3+deb9u2 4.19.0-6-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : npm refuse de s'installer

S'il est vrai que les backports viennent de testing, il reste que ce qu'ils proposent a une nette capacité à entrer dans stable, juste une question de temps passé après la mise en service de la nouvelle stable. smile

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#44 28-02-2019 13:18:21

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.2.0-3 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : npm refuse de s'installer

smolski a écrit :

S'il est vrai que les backports viennent de testing, il reste que ce qu'ils proposent a une nette capacité à entrer dans stable


tout à fait , d'ailleurs : https://wiki.debian.org/fr/Backports

t'inquiète pas trop , saw .

on est tous débutant quelquepart ; ou on l'a été .

tant que tu garde sang froid et esprit ouvert ...

force et courage ! ... comme dit souvent smolski

https://debian-facile.org/viewtopic.php … 22#p141722

Dernière modification par Debian Alain (28-02-2019 13:25:16)


1498812139.jpg Nightwish - Last Ride Of The Day (With Lyrics)
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#45 02-03-2019 15:07:49

saw
Membre
Distrib. : Debian GNU/Linux 9.5 (stretch)
Noyau : Linux 4.9.0-8-amd64
(G)UI : gnome
Inscription : 25-10-2018

Re : npm refuse de s'installer

je me pose une question avec mes sources.list dans le tuto c'est écrit :

ajouter ses sources la dans votre dépôt pour le non free:


    # Debian Stretch, dépôt principal + paquets non libres
    deb http://deb.debian.org/debian/ stretch main contrib non-free
    # Debian Stretch, mises à jour de sécurité + paquets non libres
    deb http://security.debian.org/ stretch/updates main contrib non-free
    # Debian Stretch, mises à jour "volatiles" + paquets non libres
    deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
    # Debian Stretch, dépôt de rétroportages ("backports")
    deb http://deb.debian.org/debian/ stretch-backports main contrib non-free



1- la source volatiles et sécurité se resemble beaucoup a tel point qu'on dirait des doublon je me trompe ? comment choisir si c'est le cas ?

2-est t'on obligé d'ajouter toute les sources ? sachant que je n'ai ajouter que la derniéres pour garder les mise a jour stable . est ce un probléme ?

Edit à toto : J'ai édité ton message pour le rendre plus lisible. Je te laisse cliquer sur le lien Modifier au bas à droite de ce post pour voir comment le bb-code est utilisé pour ça.
Voir le tuto : Le code, ça pique moins les yeux en couleur

Dernière modification par saw (02-03-2019 20:35:06)

Hors ligne

#46 02-03-2019 16:32:18

smolski
admin quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports (buster) 10
Noyau : 4.9.65-3+deb9u2 4.19.0-6-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : npm refuse de s'installer

deb http://security.debian.org/ stretch/updates
deb http://deb.debian.org/debian/ stretch-updates


Jeu des 7 erreurs, trouver la distinction entre les sources citées... cool

Le tutotte des depots : https://debian-facile.org/doc:systeme:a … ist#depots à lire...

toto modifie ton post et t'invite à regarder par Modifier (en bas à droite de ton post) pour voir comment on utilise le BBCode du forum pour écrire du code sur le forum afin que tout le monde puisse le lire commodément.
Là, il a utilisé le bouton Autre code pour mettre en valeur tes sources.

Regarde le lien qu'il te met aussi... wink

Force et courage

Dernière modification par smolski (02-03-2019 16:35:59)


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#47 02-03-2019 20:54:07

saw
Membre
Distrib. : Debian GNU/Linux 9.5 (stretch)
Noyau : Linux 4.9.0-8-amd64
(G)UI : gnome
Inscription : 25-10-2018

Re : npm refuse de s'installer

smolski a écrit :

deb http://security.debian.org/ stretch/updates
deb http://deb.debian.org/debian/ stretch-updates




Jeu des 7 erreurs, trouver la distinction entre les sources citées... cool



bon ça va hein j'ai lu vite fait + la fatigue ça arrive c'est pas cool de me le dire comme ça ..

smolki a écrit :

Le tutotte des depots : https://debian-facile.org/doc:systeme:a … ist#depots à lire...



bah écoute soit je suis bête soit je ne comprends pas tous. Dans ma question je demande si c'est possible de n’ajouter qu'une seule ligne. voir mon poste plus haut.

Hors ligne

#48 02-03-2019 22:26:00

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.2.0-3 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : npm refuse de s'installer

Là , je ne suis pas chez moi, 
donc je ne peux pas te répondre correctement.

Prends le temps de te renseigner sur le sources.list de stretch .

Sur le site de D-F par exemple.
Tu trouveras réponse  à tes questions  (beaucoup ).

1498812139.jpg Nightwish - Last Ride Of The Day (With Lyrics)
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#49 02-03-2019 22:39:28

smolski
admin quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports (buster) 10
Noyau : 4.9.65-3+deb9u2 4.19.0-6-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : npm refuse de s'installer

saw a écrit :

c'est pas cool de me le dire comme ça ..


Je m'excuse si je t'ai froissé.

Le tuto en lien explique ce que sont les sources que tu penses en double, je t'invite donc à le consulter puis, si tu ne comprends pas, de nous faire le retour de ce que tu ne comprends pas afin qu'on améliore ensemble et pour tous le libellé du tuto.

Donc, je préfère t'envoyer te renseigner directement afin que toi aussi tu participes à debian-facile et nous aide à maintenir le site. smile

Tu peux comprendre que ceux qui savent et entretiennent les tutos ne peuvent pas deviner comment sont reçues les explications par ceux qui ne savent pas encore, ton aide est donc précieuse, il ne s'agit pas d'un refus d'assistance de ma part mais bien d'une demande d'assistance de ta part au forum et au site.

cool


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

Pied de page des forums