Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-04-2019 16:41:56

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

gdebi et mise à jour de soft [résolu]

Bonjour,

Malheureusement mal habitué avec Ubuntu, j'ai toujours autant de mal à installer en ligne de commande...
En plus j'ai des softs d'impression qui ne sont pas dans les paquets "officiels" et qui sont obligatoirement en .deb...
Pour le surimi que je suis Gdbi est très bien mais je ne le maîtrise pas.

Pour les désinstallations sur les applis dédiées à çà, avec Ubuntu ou autres, il suffit de chercher dans la liste et de lancer la désinstallation.
Avec Gdebi (pas de liste) j'ai remarqué qu'en relancant le .deb de départ le choix de désinstallation était possible.
Je ne sais pas si c'est la bonne manière de procéder mais c'est moins risqué que de me faire mettre les mains dans les ligens de commandes wink

J'ai un soft qui me signale depuis plusieurs jours qu'une mise à jour est à faire.
Télécharger le .deb çà je sais faire wink
Par contre comme mon D9 tourne comme une horloge et que le soft aussi (celui qui m'a obligé à changer de carte vidéo), je suis frileux...
Je me demande donc si je dois d'abord désinstaller le .deb ancienne version via Gdebi ou lancer le nouveau .deb à l'arrache...

Donc j'ai besoin de conseils...
En considérant que pour les surimi comme moi il serait bien qu'il y ait une appli d'installation avec liste sur Debian...
J'ai d'ailleurs dédié mon Debian 100% à l'impression 3D car pour tout le reste je préfère ma distri Fedora qui est plus simple pour l'utilisateur de type Surimi...

Dernière modification par statis (23-04-2019 18:09:10)


J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#2 03-04-2019 16:52:39

phreg
Membre
Distrib. : MX Ubuntu LMDE Manjaro
Noyau : 4.9 à 4.20
(G)UI : Xfce Mate
Inscription : 02-04-2011

Re : gdebi et mise à jour de soft [résolu]

Bonjour,
si tu es frileux et que ce soft pas à jour fonctionne bien chez toi, il est urgent d'attendre.
Pendant ce temps, tu peux toujours chercher les améliorations apportées ou bugs corrigés.

Hors ligne

#3 03-04-2019 17:20:11

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : gdebi et mise à jour de soft [résolu]

Bonjour,
Les logiciels en .deb installés avec gdebi qui gère les dépendances et est très bien (pas la peine de culpabiliser wink )se trouvent ensuite listés dans Synaptic.
Tu lances Synaptic, tu le troves dans le menu Administration > Gestionnaire de paquets Synaptic
Tu saisis ton mot de passe pour administrer le système (celui de l'utilisateur qui a les droits sudo ou le mot de passe root suivant ce que tu as choisi à l'installation)
Ensuite la recherche du paquet avec le bouton rechercher devrait te donner une ligne correspondant à ton logiciel, un clic droit dessus  > selectionner pour suppression complète > appliquer et valider

Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#4 03-04-2019 17:32:27

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : gdebi et mise à jour de soft [résolu]

merci phreg,
Les softs d'impression 3D ne fonctionnent jamais bien, il est malheureusement nécessaire de les mettre à jour fréquemment...

merci chalu,
Je ne savais pas que l'on pouvait désinstaller un .deb mis en place par gdebi avec Synaptic (qui quand il va disparaître m'obligera à quitter définitivment Debian...).
Je vais regarder.

Cependant cela ne répond pas totalement à ma question.
Désinstallation complète puis réinstallation de la nouvelle version .deb ou installation par dessus ?

J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#5 04-04-2019 14:14:19

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : gdebi et mise à jour de soft [résolu]

Synaptic (comme apt en ligne de commande) gère les paquets .deb installés sur le système.
C'est quoi comme logiciel ?
Je n'ai jamais eu à utiliser ce type d'installation, moi je tenterais une installation par-dessus comme une mise à jour pour garder les préférences.
mais bon ça n'engage que moi smile

Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#6 04-04-2019 15:39:33

phreg
Membre
Distrib. : MX Ubuntu LMDE Manjaro
Noyau : 4.9 à 4.20
(G)UI : Xfce Mate
Inscription : 02-04-2011

Re : gdebi et mise à jour de soft [résolu]

Bonjour,
moi aussi, je préfère l'installation sans suppression préalable.
Mais comme c'est du soft assez particulier et spécialisé, je te conseille de chercher le descriptif des différences et de n'installer que si ça te semble utile dans ta config et pour ton utilisation.

Hors ligne

#7 04-04-2019 20:05:19

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : gdebi et mise à jour de soft [résolu]

Merci chalu et phreg smile

Le soft qui signale sa mise à jour est Flashprint.
C'est un des deux softs qui m'a fait bien galérer au niveau de la carte graphique https://debian-facile.org/viewtopic.php?id=23576

Il n'y a aucun descriptif pour ce soft, leur support dit qu'il ne peut tourner que sur ubuntu.
J'ai même eu une réponse de l'un des leurs disant que Flashprint ne pouvait tourner que sur Windows...
Flashprint marchait tellement bien sur Ubuntu que je n'avais pas accès au mode expert.
Avec D9, j'ai enfin pu utiliser ce mode wink

Je retiens que Synaptic peut installer du .deb, j'essaierais sur mon avant dernier disque que je n'ai pas encore écrasé/cloné (problème de cohabitation de clone dont il faut que je revienne sur le sujet).

J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#8 04-04-2019 20:09:19

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : gdebi et mise à jour de soft [résolu]

statis a écrit :

Je retiens que Synaptic peut installer du .deb, j


non il ne peut pas installer un paquet .deb téléchargé. Tu installes ce paquet avec gdebi et ensuite synaptic te permettra de le supprimer si tu le souhaites.


Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#9 04-04-2019 23:43:38

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : gdebi et mise à jour de soft [résolu]

Merci chalu,
Super, pas besoin que je me souvienne quel .deb j'avais utilisé pour le désinstaller avec Gdebi, c'est plus simple avec Synaptic wink

J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#10 09-04-2019 15:32:58

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : gdebi et mise à jour de soft [résolu]

Comme je n'utilise mon D9 que pour l'impression 3D, je n'avais pas essayé la mise à jour depuis.

Tentative d'écraser l'ancienne version de Flashprint avec Gdebi, message d'erreur

Erreur !
La dépendance
ne peut
être
satisfaite :
libusb-0.1



Désinstallation de l'ancienne version et pareil même erreur...
Entre temps je vois qu'il y a une nouvelle version de Flashprint...
Et pareil même erreur...

En regardant sur Synaptic (qui heureusement existe encore) je vois que j'ai libusb-0.1-4

Tentative de passer en console

sudo dpkg -i flashprint_3.26.1_amd64.deb



(Lecture de la base de données... 199067 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de flashprint_3.26.1_amd64.deb ...
Dépaquetage de flashprint (3.26.1) sur (3.25.1) ...
dpkg: des problèmes de dépendances empêchent la configuration de flashprint :
 flashprint dépend de libftdi-dev ; cependant :
  Le paquet libftdi-dev n'est pas installé.
 flashprint dépend de libftdi1-dev ; cependant :
  Le paquet libftdi1-dev n'est pas installé.
 flashprint dépend de libhidapi-dev ; cependant :
  Le paquet libhidapi-dev n'est pas installé.
 flashprint dépend de libusb-0.1 ; cependant :
  Le paquet libusb-0.1 n'est pas installé.

dpkg: erreur de traitement du paquet flashprint (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.15-1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.60) ...
Des erreurs ont été rencontrées pendant l'exécution :
 flashprint
 



libftdi-dev n'est pas vu installé sur Synnaptic
libftdi1-dev n'est pas vu isntallé sur Synaptic
libhidapi-dev n'est pas vu isntallé sur Synaptic
libusb-0.1 comme dit plus haut est vu installé mais en ibusb-0.1-4

Donc je constate que Gdebi ne peut remplacer les lignes de commandes.
Et qu'en ligne de commandes je ne suis pas mieux loti...

Synaptic m'a signalé que j'avais un paquet cassé (après le dpkg), c'est corrigé mais je n'ai pas eu d'alerte en console...

Pourquoi c'est si compliqué pour des pauvres personnes qui ont un QI de surimi comme moi ;'(


J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#11 09-04-2019 16:06:18

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : gdebi et mise à jour de soft [résolu]

suite...
N'ayant pas fermé synaptic pendant la rédaction du post, je viens de m'apercevoir que la "réparation du paquet cassé" impliquait la suppression de "Flashprint" et l'installation des libmachin's.
Après redémarrage, tentative d'installer de nouveau Flashprint (et non Flashforge comme dit avant, la vieille version a été virée aussi).
Et de nouveau des erreurs :

sudo dpkg -i flashprint_3.26.1_amd64.deb


Sélection du paquet flashprint précédemment désélectionné.
(Lecture de la base de données... 199460 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de flashprint_3.26.1_amd64.deb ...
Dépaquetage de flashprint (3.26.1) ...
dpkg: des problèmes de dépendances empêchent la configuration de flashprint :
 flashprint dépend de libusb-0.1 ; cependant :
  Le paquet libusb-0.1 n'est pas installé.

dpkg: erreur de traitement du paquet flashprint (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.15-1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.60) ...
Des erreurs ont été rencontrées pendant l'exécution :
 flashprint
 



Le paquet libusb-0.1 n'est pas installé

...
C'est libusb-0.1-4 qui l'est...

Et de nouveau paquet cassé mais cette fois-ci l'implication ne concerne que la supression de Flashprint...
Heureusement l'ancienne version s'installe sans rien casser...


J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#12 09-04-2019 22:29:01

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : gdebi et mise à jour de soft [résolu]

Tu devrais signaler l’erreur au concepteur du logiciel.
Il n’y a pas de paquet nommé libusb-0.1 tout court dans les dépôts

Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#13 09-04-2019 23:52:15

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : gdebi et mise à jour de soft [résolu]

merci chalu.

Flashforge va encore me dire qu'il n'y aurait aucun problème avec Ubuntu...

J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#14 11-04-2019 15:50:30

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : gdebi et mise à jour de soft [résolu]

je confirme, le support Flashforge me dit qu'il n'y a aucun problème sur ubuntu 16.04 i386.
En noyeau 4.4.0-145 sur l'ubuntu 16.04 x86_64 que j'ai sous la main je rencontre le même problème avec libusb-0.1 et sur lequel synpatic est en erreur en essai d'installation pour voir les paquets cassés...
Comme le support Flashforge ne sert à rien je vais rester sur ma vieille version...

En conclusion Gdebi tout comme l'utilitaire Ubuntu d'installation de logiciels, ne sont pas adaptés à tous les softs.
Le dpkg peut générer des erreurs (paquet cassé) qu'un novice comme moi ne saura pas gérer surtout pour la partie installation des "trucs sous-paquets" manquants.
Et synaptic peut ne plus être utilisable sur certaines distribution Debian (Ubuntu c'est pas autre chose...).

J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#15 11-04-2019 20:24:42

èfpé
Membre
Inscription : 10-07-2016

Re : gdebi et mise à jour de soft [résolu]

Bonsoir,

statis a écrit :

Le support FlashForge me dit qu'il n'y a aucun problème sur Ubuntu 16.04 i386.


Ce n'est peut-être pas du pipeau, l'erreur (fichier control) peut ne concerner que la version amd64 :

dpkg-deb --field flashprint_3.26.0_amd64.deb

Package: flashprint
Version: 3.26.0
Architecture: amd64
Maintainer: Zheng Gang <zg@sz3dp.com>
Installed-Size: 98431
Depends: libudev-dev, libqt5gui5, libqt5core5a, libqt5opengl5, libqt5network5, libqt5xml5,
 libelf-dev, libftdi-dev, libftdi1-dev, libhidapi-dev, libusb-0.1
Section: utils
Priority: extra
Homepage: http://www.sz3dp.com/
Description: FlashForge 3D printer controler


dpkg-deb --field flashprint_3.26.0_i386.deb

Package: flashprint
Version: 3.26.0
Architecture: i386
Maintainer: Zheng Gang <zg@sz3dp.com>
Installed-Size: 98929
Depends: libudev-dev, libqt5gui5, libqt5core5a, libqt5opengl5, libqt5network5, libqt5xml5,
 libelf-dev, libftdi-dev, libftdi1-dev, libhidapi-dev, libusb-0.1
Section: utils
Priority: extra
Homepage: http://www.sz3dp.com/
Description: FlashForge 3D printer controler


Comme cela a déjà (?) été dit, le paquet libusb-0.1 n'existe pas plus sous Ubuntu que sous Debian.

head -n 14 /usr/share/FlashPrint/doc/FlashPrint-ChangeLogs-en_US.txt

Change Logs

The upgrades in FlashPrint-3.26.0
1. Optimize the slicing funciton of Creator 3.
2. Add PA,PC,PETG,PVA to Creator 3.
3. Support to show some Slice Parameters when preview.
4. Creator Pro supports to Reset Motherboard Completely.
5. Fixed Overhang Threshold setting bug of Auto Supports.
6. Add to support Portuguese.
7. Additional optimization and bug fixing.

The upgrades in FlashPrint-3.25.1
1. Extruder temperature upper limit of Guider II and Guider II S is changed to 300.
2. Compatible with some special edition of Finder.


Si cet extrait du ChangeLogs provoque chez toi une grande excitation, le problème sera vite résolu :

dpkg-deb --raw-extract flashprint_3.26.0_amd64.deb flashprint

sed -i s,libusb-0.1,libusb-0.1-4, flashprint/DEBIAN/control

dpkg-deb --build flashprint flashprint_3.26.0~fixed_amd64.deb


Et tu installes ce paquet proprement, c'est-à-dire, soit avec la commande apt, soit avec ton GDebi.

Note : la version 3.26.1 (ajoute le support du coréen) ne semble pas disponible au téléchargement !

Dernière modification par èfpé (11-04-2019 21:04:42)

Hors ligne

#16 11-04-2019 22:13:24

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : gdebi et mise à jour de soft [résolu]

Merci èfpé,

Par curiosité tes opérations "cassent" le .deb et le reconstruisent pour qu'il utilise la bonne version de libusb ?

Je ne peux pas lancer le nouveau .deb avec

dpkg -i flashprint_3.26.0~fixed_amd64.deb


?

Rajout
J'étais trop impatient donc j'ai allumé mon Debian pour faire les opérations wink
Et me voilà avec la version 3.26.1 en place

Le forum Debian Facile est vraiment au top niveau.
èfpé que je remercie a fait plus fort que l'équipe Flashforge wink
Je dirais demain si la réponse que j’attends d'eux (pas le même fuseau horaire du tout, ils sont en Chine) contenait une solution mais j'en doute.
Je mettrais en résolu demain.

Dernière modification par statis (11-04-2019 22:58:15)


J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#17 11-04-2019 22:54:42

èfpé
Membre
Inscription : 10-07-2016

Re : gdebi et mise à jour de soft [résolu]

Re-,

statis a écrit :

Tes opérations [extraient] le .deb et le reconstruisent pour qu'il utilise [le bon nom de paquet] ?


Oui c'est exactement le but de cette opération micro-chirurgicale... J'ai testé, et le machin s'exécute.

statis a écrit :

Je ne peux pas [installer] le nouveau .deb avec "dpkg -i flashprint_3.26.0~fixed_amd64.deb" ?


Tu peux, mais cela relève du sado-masochisme, contrairement à dpkg, apt installe les dépendances.

Dernière modification par èfpé (13-04-2019 17:04:42)

Hors ligne

#18 11-04-2019 23:01:27

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : gdebi et mise à jour de soft [résolu]

merci èfpé pour ta dernière réponse qui est venue en même temps que mon rajout.

En fait j'ai utilisé dpkg car les dépendances étaient déjà installées via Synaptic quand j'ai cherché le truc libusb hier et qu'il y avait signalement de paquet cassé.

J'ai cherché comment installer un .deb avec apt mais pas trouvé...

Flashforge devrait collaborer avec toi et te faire cadeau d'une imprimante wink

Dernière modification par statis (11-04-2019 23:05:15)


J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#19 11-04-2019 23:10:42

èfpé
Membre
Inscription : 10-07-2016

Re : gdebi et mise à jour de soft [résolu]

Re-,

statis a écrit :

J'ai cherché comment installer un .deb avec apt mais pas trouvé...


Tu n'as pas dû beaucoup chercher. Installer un nouveau paquet > Paquet téléchargé depuis un site !

Hors ligne

#20 11-04-2019 23:20:36

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : gdebi et mise à jour de soft [résolu]

Merci et super èfpé wink

J'ai cherché via google "installer un .deb avec apt" et me suis tapé plusieurs liens qui en fait donnaient du dpkg...
Sur le forum je ne trouve jamais rien avec l'option "recherche", je pense que c'est pour du langage humain et comme je parle le surimi wink

Très bonne fin de soirée à toi smile

J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#21 12-04-2019 08:43:29

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : gdebi et mise à jour de soft [résolu]

Ils testent sur un système ayant des paquets obsolètes s’ils n’ont pas d’erreur alors.

Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#22 12-04-2019 12:14:42

èfpé
Membre
Inscription : 10-07-2016

Re : gdebi et mise à jour de soft [résolu]

Bon appétit,

chalu a écrit :

Ils testent sur un système ayant des paquets obsolètes s’ils n’ont pas d’erreur alors.


Non. Selon archive.debian.org, le paquet s'appelait déjà libusb-0.1-4 en 2002 (Debian 3.0 Woody).

Hors ligne

#23 12-04-2019 12:16:39

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : gdebi et mise à jour de soft [résolu]

voilà leur dernière réponse

After run “sudo dpkg -i flashprint-xxxx.deb”, please run “sudo apt-get -f install” to resolve the dependency.


Cela n'aurait pas résolu le problème de libusb-0.1 non trouvable puisqu'en libusb-0.1-4 et pourtant je leur ai bien communiqué toutes les infos comme ici.
èfpé à trouvé la solution eux non wink
je reviendrais sur le post +tard.


J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#24 12-04-2019 14:07:49

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : gdebi et mise à jour de soft [résolu]

On se demande comment ils réussissent à passer à côté de l’erreur roll

Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#25 23-04-2019 18:08:48

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : gdebi et mise à jour de soft [résolu]

Je n'avais pas mis le sujet en résolu car je voulais voir si Flashorint ne poserait pas de problèmes.
Mis à part du bug graphique déjà présent sur les versions précédentes j'ai pu l'utiliser à plusieurs reprises merci à tou(te)s.
Et surtout, félicitations à èfpé qui est plus fort qu'un support professionnel d'imprimantes 3D prétendues haut de gamme...

J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

Pied de page des forums